Разработка и согласование учебных планов

Дополнительные главы документации по учебному процессу (31.03.2018)
Раздел целиком Одним файлом
Разработка и согласование учебных планов

Подсистема разработки и согласования учебных планов автоматизирует процессы подготовки проектов учебных планов факультетов и отделений на основе действующих образовательных стандартов, контроля соответствия проектов планов утвержденным требованиям и нормативами, процедуры согласования планов должностными лицами ВУЗа, контроля степени готовности планов очередного учебного года.

Доступ к функционалу подсистемы осуществляется посредством форм работы с данными Образовательные стандарты, Базовые и рабочие учебные планы, Ход согласования учебных планов. Данные формы доступны на Консоли управления системы в визуальной группе Разработка учебных планов.

Доступ пользователя к функционалу подсистемы зависит о его включения в одну из ролей:

  • Разработчик учебных планов
  • Специалист Методического управления
  • Проректор, согласующий учебные планы
  • Первый проректор, утверждающий рабочие учебные планы, согласующий базовые учебные планы
  • Ректор, утверждающий базовые учебные планы
  • Администратор подсистемы разработки учебных планов

Работа по подготовке, согласованию и утверждению учебных планов состоит из следующих этапов:

  1. Формирование справочника типов образовательных стандартов.
  2. Ввод образовательных стандартов.
  3. Формирование базовых учебных планов на основе образовательных стандартов.
  4. Формирование рабочих учебных планов на основе базовых учебных планов.

Описанный порядок работы касается как учебных планов основных образовательных программ подготовки бакалавров, специалистов и магистров, так и учебных планов аспирантуры.

Помимо учебных планов образовательных программ в системе также предусмотрена работа со следующими особыми видами учебных планов:

Рабочие учебные планы общевузовских дисциплин - это наборы дисциплин, которые предлагаются для выбора всем студентам вуза независимо от того, по какой образовательной программе они обучаются.

Майноры учебных планов - это наборы дисциплин, предлагаемых отдельными образовательными программами для изучения студентами других образовательных программ. Дисциплины майнора являются связанными друг с другом и планируются для изучения в течение нескольких лет (курсов). Студенты выбирают для изучения тот или иной майнор, после чего дисциплины, входящие в состав майнора, становятся обязательными для студента. Майноры могут принадлежать к одному из двух типов:

  • Обычный майнор - это набор дисциплин, изучение которых запланировано в определенной последовательности. При выборе студентом такого майнора на начальном курсе, дисциплины майнора становятся обязательным для него как на этом, так и на последующих курсах.
  • Свободный майнор - это такой майнор, выбрав который, студент сохраняет свободу в выборе дисциплин из любых майноров в течение всех лет обучения. В системе такой майнор создается, но не наполняется дисциплинами (т.е. остается пустым).

Мйноры, по аналогии с учебными планами, могут быть "базовыми" и "рабочими". Базовые майноры позволяют планировать перечень дисциплин и последовательность их изучения на все годы реализации майнора. Рабочие майноры более подробно отражают изучение дисциплин майноров в одном учебном году (для одного курса студентов). Каждый Рабочий майнор должен разрабатываться на основе утвержденного Базового майнора, должен содержать те же группы дисциплин и дисциплины, соответствующие дисциплинам Базового майнора, реализуемым в одном учебном году.

  • Настройки для работы с учебными планами
  • Справочник "Типы образовательных стандартов"
  • Образовательные стандарты
  • Объединенные учебные планы
  • Базовые учебные планы (БУПы)
  • Объединенные планы факультетских дисциплин
  • Объединенные майноры
  • Базовые майноры
  • Рабочие майноры
  • Объединенные учебные планы аспирантуры
  • Базовые учебные планы аспирантуры (БУПы аспирантуры)
  • Рабочие учебные планы (РУПы)
  • Рабочие учебные планы аспирантуры (РУПы аспирантуры)
  • Рабочие учебные планы общевузовских дисциплин
  • Объединенные планы общевузовских дисциплин
  • Учебные планы лицея
  • Особенности наполнения отдельных разделов БУП и РУП
  • Расчетные показатели учебных планов
  • Ход согласования учебных планов
  • Оценка затратности реализации учебных планов
  • Каталог дисциплин
  • График учебного процесса
  • Переводы для учебных планов
  • Аналитические отчеты по РУП


Настройки для работы с учебными планами

Одним файлом
Настройки для работы с учебными планами

Прежде чем начать пользоваться функционалом участка Разработка учебных планов необходимо задать настройки Филиал и Факультет. Для определения данных настроек нужно воспользоваться разделом Настройки для работы с учебными планами на участке Разработка учебных планов.
Настройки для работы с учебными планами

После нажатия кнопки ОК все настройки будут заданы.


Справочник "Типы образовательных стандартов"

Справочник "Типы образовательных стандартов"

Работа со справочником ведется в форме Образовательные стандарты на вкладке Типы образовательных стандартов.

Типы образовательных стандартов

Для добавления нового вида стандарта нужно вызвать в таблице данных действие Добавить тип стандарта и заполнить поля Краткое наименование и Полное наименование.

Добавление типа стандарта

После добавления типа стандарта его краткое и полное наименование можно скорректировать непосредственно в таблице данных, введя новое значение с клавиатуры и нажав клавишу Enter.

Если тип стандарта создан ошибочно, его можно удалить, вызвав действие Удалить. Удаление возможно только в том случае, если в системе не существует стандартов данного вида.


Образовательные стандарты

Раздел целиком Одним файлом
Образовательные стандарты

Образовательный стандарт в системе представляет собой иерархическую структуру учебных циклов и включенных в них учебных дисциплин, снабженных информацией о трудоемкости их усвоения, выраженной в зачетных единицах (кредитах) или в учебных часах. Каждый образовательный стандарт соответствует одной степени / квалификации по одному из направлений / специальностей подготовки. К каждому образовательному стандарту относится перечень компетенций, развиваемых в ходе обучения студента по соответствующей образовательной программе. Развитие компетенций в каждом из учебных циклов отражается за счет связи цикла с набором компетенций стандарта.

Создание нового образовательного стандарта включает следующие этапы работы:

  1. Создание записи о стандарте.
  2. Наполнение стандарта записями о циклах дисциплин, учебных дисциплинах и других видах учебной нагрузки.
  3. Создание перечня компетенций, входящих в состав стандарта.
  4. Связывание записей стандарта с компетенциями.
Работа с компетенциями (пункты 3 и 4) ведется только при работе с образовательными стандартами III поколения (ФГОС, Оригинальные образовательные стандарты).

  • Создание нового образовательного стандарта
  • Наполнение образовательного стандарта
  • Работа с компетенциями ФГОС
  • Работа с компетенциями оригинальных стандартов


Создание нового образовательного стандарта

Создание нового образовательного стандарта

Для создания нового образовательного стандарта необходимо открыть форму Образовательные стандарты. Форма доступна на Консоли управления или на Панели инструментов системы.

В основной таблице данных Образовательные стандарты необходимо вызвать действие Добавить образовательный стандарт. При вызове действия будет отображена форма параметров нового стандарта:

Добавление образовательного стандарта

Поля формы добавления нужно заполнить следующим образом:

  • В поле Тип образовательного стандарта нужно выбрать один из типов, занесенных в Справочник "Типы образовательных стандартов".
  • В поле Уровень образования из выпадающего списка необходимо выбрать один из вариантов Бакалавриат, Специалитет, Магистратура или Аспирантура в зависимости от того, для какого уровня образования предназначен стандарт.
  • В поле Направление / специальность нужно выбрать соответствующую запись из общевузовского справочника . При выборе направления или специальности обращайте внимание не только на ее наименование, но и на код. Если в предыдущем поле выбрано значение "Бакалавриат" или "Магистратура", то для выбора будут предложены записи справочника, являющиеся направлениями, если же выбрано значение "Специалитет", то будут предложены записи, являющиеся специальностями (установлен флаг Является специальностью). В случае если Вы не находите нужного направления или специальности в этом справочнике, необходимо обратиться к бизнес-администратору системы с просьбой добавить его в справочник.
  • В поле Степень (квалификация) нужно выбрать степень или квалификацию, соответствующую уровню образования. В случае, если в предыдущем поле выбрано направление подготовки, то для выбора будут доступны степени бакалавр или магистр. Если же выбрана специальность, то для выбора будет доступна соответствующая квалификация. При создании образовательного стандарта для аспирантуры нужно выбрать степень кандидат наук.

Поле заполнения полей формы добавления надо нажать кнопку ОК, в результате чего в таблице появится запись о новом стандарте. При создании стандарта ему автоматически присваивается наименование, состоящее из типа стандарта, кода и наименования направления (специальности) и степени (квалификации). Создание двух и более стандартов одного типа по одной и той же степени (квалификации) одного и того же направления (специальности) недопустимо. При попытке создать второй аналогичный стандарт пользователь увидит сообщение об ошибке дублирования объектов.

Все созданные в системе образовательные стандарты отображаются в одной таблице данных, сгруппированной по уровням образования.


Наполнение образовательного стандарта

Раздел целиком Одним файлом
Наполнение образовательного стандарта

После создания записи о стандарте можно формировать структуру компонентов и дисциплин, составляющих стандарт. Записи стандарта имеют иерархическую структуру, отражающую включенность одних компонентов в состав других и вхождение дисциплин и других видов учебной нагрузки в группы и компоненты. Каждая запись наряду с атрибутами "наименование", "число часов", "число кредитов" и проч. имеет атрибут Входит в раздел, содержащий ссылку на раздел (или группу), в состав которого входит данная запись.

Стандарт состоит из записей нескольких видов:

  • раздел (цикл, компонент)
  • группа дисциплин
  • дисциплина
  • научно-исследовательский семинар
  • курсовая работа
  • практика
  • итоговый госэкзамен
  • выпускная квалификационная работа
  • зачетно-экзаменационные недели

Добавление записей стандарта производится путем вызова соответствующего действия их группы действий Добавить ....

Вид записи группа дисциплин должен использоваться во всех случаях, когда добавляемая запись строго не соответствует одной конкретной дисциплине, которая будет преподаваться на факультете определенной кафедрой по определенной программе или одной конкретной практике, курсовой работе и т.п. Например, запись "Иностранный язык" должна создаваться как группа дисциплин, в которую впоследствии будут включаться дисциплины "Английский язык", "Немецкий язык", "Французский язык" и т.д. Если набор иностранных языков, которые могут (должны) преподаваться по стандарту, известен, то их можно включить в группу иностранных языков как дисциплины. Если же набор иностранных языков не зафиксирован в стандарте, их можно будет задать позже при работе с базовым или рабочим учебным планом.

Если в стандарте задается объем нагрузки для курсовых работ в целом, а не для каждой работы, то такая запись также должна быть создана как раздел или группа дисциплин.

Если в стандарте задаются конкретные виды практик (учебная практика, преддипломная практика и т.д.), то такие записи могут быть созданы как практики. Если же в стандарте задается практика в целом, то такую запись нужно создать как раздел или как группу дисциплин.

В раздел итоговой государственной аттестации можно включить записи вида "итоговый госэкзамен" и "выпускная квалификационная работа", под которыми имеются в виду конкретные виды итоговых испытаний.

В дальнейшем при работе над базовыми и рабочими учебными планами, формируемыми на базе стандарта, в разделы и группы дисциплин можно будет включить записи о конкретных учебных дисциплинах и других видах учебной нагрузки. Также группы дисциплин используются в БУП и РУП для выделения групп дисциплин по выбору и задания их характеристик (число дисциплин или число кредитов, которое должно быть выбрано студентом по группе дисциплин).

Добавление записей стандарта должно начинаться с добавления корневого раздела (компонента). Для корневого раздела, как правило, задается наименование Вся образовательная программа. Для корневого компонента значение атрибута Входит в раздел должно быть пустым. Остальные записи должны включаться в состав этого корневого компонента или в состав других компонентов. Включение записей в состав дисциплин недопустимо. Иерархическая структура позволяет формировать стандарты любой структуры. Следующие ниже примеры будут иллюстрировать создание стандартов II и III поколения. Если ВУЗ имеет право вести обучение по собственным (оригинальным) стандартам, то они должны быть сформированы по аналогичным принципам.

Разделы и дисциплины стандарта могут иметь коды (ГСЭ.0, ЕН.Ф.03, Б1, Б5). В связи с тем, что в стандартах разных типов принято использование различных систем кодирования, включающих различные символы, а также в связи с тем, что не все записи стандарта имеют коды, для корректного задания порядка следования записей в стандарте используется дополнительное числовое поле Порядковый номер. Сортировка записей стандарта будет производиться в порядке возрастания значения порядкового номера в рамках каждого уровня иерархии (т.е. в рамках каждого раздела).

Пример структуры стандарта II поколения:

Структура стандарта II поколения

Пример структуры стандарта III поколения:

  • Добавление разделов (циклов, компанентов) стандарта
  • Добавление групп дисциплин
  • Добавление дисциплин
  • Добавление научно-исследовательских семинаров
  • Добавление курсовых работ
  • Добавление практик
  • Добавление итоговых госэкзаменов
  • Добавление выпускных квалификационных работ
  • Добавление зачетно-экзаменационных недель
  • Внесение изменений в созданный стандарт


Добавление разделов (циклов, компанентов) стандарта

Добавление разделов (циклов, компанентов) стандарта

Для добавления компонента стандарта нужно выбрать запись о стандарте в основной таблице данных Образовательные стандарты, после чего в подчиненной таблице Состав стандарта вызвать действие Добавить ... / раздел. При добавлении первой записи нужно выполнить щелчок правой кнопкой мыши в пустом поле таблицы. При добавлении записи более низкого уровня сначала нужно выбрать запись компонента, в который планируется включить новый компонент, и только после этого вызвать действие добавления. Ссылка на запись компонента, выбранного в момент вызова действия добавления отобразится в поле Входит в раздел формы параметров. Если по ошибке вместо компонента выбрана дисциплина, то в поле Входит в раздел будет подставлена ссылка на раздел (компонент), в который включена данная дисциплина.

Добавление компонента стандарта II поколения:

Добавление раздела стандарта II поколения

Добавление компонента стандарта III поколения:

Добавление раздела стандарта III поколения

Поля формы добавления нужно заполнить следующим образом:

  • В поле Входит в раздел значение подставляется автоматически. Новая запись будет включена именно в данный раздел. При добавлении первой записи данное поле нужно оставить пустым. Если в поле подставилось значение, а Вы хотите добавить запись на первый уровень, то значение в поле нужно очистить, выделив весь текст и нажав клавишу Del.
  • Поле Компонент плана предназначено для работы со стандартами II поколения. В этом случае нужно выбрать необходимый компонент из справочника компонентов стандартов II поколения. После выбора значения в этом поле автоматически заполнятся и станут недоступными для изменения значения в полях Код записи и Наименование. При работе со стандартами III поколения это поле нужно оставить пустым.
  • В поле Наименование нужно ввести наименование раздела в случае, если не выбрано значение в предыдущем поле.
  • В поле Код записи нужно ввести код раздела в случае, если он задан в стандарте. Для стандартов II поколения это поле будет заполнено автоматически после выбора компонента плана в поле Компонент плана.
  • В поле Порядковый номер нужно ввести целое число, которое будет определять позицию записи в ряду всех записей, входящих в один раздел. Это значение предлагается автоматически как максимально существующий в данном разделе порядковый номер + 1. Если Вы хотите вставить запись не в конец, а в середину то это значение можно скорректировать. В этом случае после добавления записи нужно будет проверить и при необходимости изменить порядковые номера других записей. Сортировка записей стандарта будет производиться по значениям порядковых номеров в пределах каждого раздела. Допустим (но не рекомендуется) повтор значений порядковых номеров. В этом случае записи будут отсортированы в случайном порядке. Допустим пропуск значений позиций (например, 5, 10, 15, ...).
  • В поле Общее число часов нужно ввести значение общего числа часов по всем записям плана, входящим в раздел, в случае если это значение задано в стандарте.
  • В поле Число недель нужно ввести число недель, выделяемое на раздел, если это значение задано в стандарте.
  • Поля Минимальное число кредитов и Максимальное число кредитов предназначены для задания диапазона допустимых сумм кредитов для стандартов III поколения. В случае если задано одно значение числа кредитов, его нужно повторить в обоих полях.


Добавление групп дисциплин

Добавление групп дисциплин

В случае, если в стандарте указаны не конкретные дисциплины, а их обобщенные наименования (например, "Иностранный язык", "Древние языки", "Инженерно-технологические дисциплины, отражающие специфику отраслей сферы материального производства" и т.п.), то такие записи должны добавляться как группы дисциплин. При разработке базового учебного плана эти группы должны быть уточнены путем включения в них тех дисциплин, которые будут читаться студентам факультета (например, в группу "Иностранный язык" в базовом плане будут включены дисциплины "Английский язык", "Немецкий язык", в группу "Древние языки" будут включены дисциплины "Древнегреческий язык", "Латинский язык").

Для того, чтобы добавить в стандарт группу дисциплин нужно на вкладке Состав стандарта выбрать раздел, в который должна быть включена новая группа дисциплин и вызвать действие Добавить ... / группу дисциплин.

Добавление группы дисциплин в стандарт
  • В поле Входит в раздел должна отображаться ссылка на раздел, в который будет включена новая группа дисциплин. Если отображается неверный раздел, то нужно закрыть форму добавления, выбрать в списке записей стандарта нужный раздел и повторить вызов действия добавления.
  • В поле Наименование нужно ввести наименование группы дисциплин.
  • В поле Порядковый номер будет предложен очередной порядковый номер записи в выбранном разделе. При необходимости его можно изменить.
  • В поле Количество выбираемых дисциплин нужно занести числовое значение числа дисциплин данной группы, которое обязательно к изучению студентами.
  • В поле Общее число часов нужно занести число часов, выделяемых на изучение дисциплин группы.
  • В поле Число недель будет предложено значение, равное заданному числу часов, разделенному на 54. При необходимости это значение можно изменить.
  • В поле Число кредитовбудет предложено значение, равное заданному числу часов, разделенному на 36. При необходимости это значение можно изменить.

После нажатия кнопки ОК запись о новой группе дисциплин появится в таблице данных. После добавления группы дисциплин в нее можно включать отдельные дисциплины (если набор дисциплин задается в стандарте).


Добавление дисциплин

Добавление дисциплин

Дисциплины могут добавляться в любой из компонентов стандарта или в группу дисциплин. Для добавления дисциплины нужно выбрать в таблице данных компонент или группу, в которую должна быть включена дисциплина, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / дисциплину. При помощи этого действия должны добавляться только конкретные учебные дисциплины, которые будут читаться на факультете (отделении) определенной кафедрой по определенной программе. Если же в стандарте дисциплины заданы укрупненно, то нужно пользоваться действием добавления группы дисциплин (Добавление групп дисциплин).

Добавление дисциплины стандарта

Поля формы добавления дисциплины нужно заполнить следующим образом:

  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного компонента и снова вызвать действие добавления дисциплины.
  • В поле Дисциплина нужно выбрать дисциплину из общевузовского справочника дисциплин. Выбор можно осуществлять путем ввода начала наименования дисциплины с клавиатуры. При вводе будут предлагаться существующие в справочнике дисциплины. Процедура поиска дисциплины чувствительная к регистру символов. Наименования всех дисциплин справочника, как правило, начинаются с заглавной буквы. Если нужной дисциплины нет в справочнике, ее можно добавить, открыв справочник и вызвав действие Добавить дисциплину ВУЗа. Для добавления новой дисциплины достаточно ввести ее полное наименование. Наименование должно вводиться без сокращений. В дальнейшем оно будет использоваться во всех отчетных документах, а также в дипломе студента. Если при попытке добавления новой дисциплины произошла ошибка дублирования объектов, это означает, что дисциплина с таким наименованием уже существует.
  • В поле Код записи нужно ввести значение кода дисциплины в стандарте, если оно задано.
  • В поле Порядковый номер значение предлагается автоматически как следующая за максимально существующей в рамках раздела. При необходимости это значение можно изменить. Если необходимо добавить дисциплину не в конец, а в середину существующего списка, необходимо проверить и уточнить позиции всех следующих за ней дисциплин.
  • В поле Вид дисциплины нужно выбрать один из видов из выпадающего списка. Выбранный вид дисциплины в дальнейшем будет использоваться при контроле полноты и корректности формирования БУПов и РУПов, который может предполагать различные контрольные нормативы для обязательных дисциплин, факультативов, адаптационных дисциплин. Также от выбранного вида дисциплины зависит ее обязательность для изучения всеми студентами.
  • В поле По выбору студентов значение подставляется автоматически в зависимости от значения, выбранного в поле Вид дисциплины. Для видов Обязательная дисциплина и Обязательный факультатив подставляется значение Да, в остальных случаях - значение Нет. При необходимости установленное автоматически значение можно изменить.
  • В поле Общее число часов нужно ввести значение числа часов, выделяемых на изучение дисциплины, если оно задано в стандарте. При изменении значения в этом поле будут автоматически пересчитываться значения в полях Число недель и Число кредитов.
  • В поле Число недель значение будет заполнено автоматически путем деления значения из поля Общее число часов на 54. При необходимости это значение можно скорректировать.
  • В поле Число кредитов значение будет заполнено автоматически путем деления значения из поля Общее число часов на 36. При необходимости это значение можно скорректировать.


Добавление научно-исследовательских семинаров

Добавление научно-исследовательских семинаров

Для добавления научно-исследовательского семинара предназначено действие Добавить / научно-исследовательский семинар. Форма добавление семинара и принципы ее заполнения аналогичны форме добавления дисциплины. Сам семинар выбирается из справочника всех дисциплин вуза. Если нужно семинара нет в справочнике, его можно добавить.


Добавление курсовых работ

Добавление курсовых работ

Добавлять в образовательный стандарт курсовые работы надо только в том случае, если в нем зафиксированы конкретные работы, которые должны быть выполнены студентами. Если же курсовые работы заданы в стандарте укрупненно, то нужно пользоваться действиями, описанными в разделах Добавление разделов (циклов, компонентов) стандарта и Добавление групп дисциплин.

Для добавления курсовой работы нужно выбрать в таблице данных компонент или группу, в которую должна быть включена курсовая работа, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / курсовую работу. Курсовые работы могут быть как по одной конкретной учебной дисциплине, так и междисциплинарные. На приведенных ниже рисунках представлены примеры заполнения формы параметров в этих двух случаях. Если курсовая работа выполняется по конкретной дисциплине, но дисциплина может выбираться студентом, то курсовая работа добавляется по аналогии с междисциплинарной (дисциплина не указывается).

Добавление курсовой работы по дисциплине в стандарт

Добавление междисциплинарной курсовой в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел (группу дисциплин), который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления курсовой работы.
  • Поле По дисциплине нужно заполнять только в том случае, если курсовая работа должна выполняться по одной конкретной учебной дисциплине всеми студентами. Если дисциплина может выбираться студентами, или если курсовая работа является междисциплинарной, то данное поле нужно оставить пустым.
  • Поле Наименование доступно для заполнения только в том случае, если не выбрана дисциплина. По умолчанию предлагается наименование "Курсовая работа", но его можно изменить (например, "Междисциплинарная курсовая работа"). Если же дисциплина выбрана, то наименование курсовой работы будет сформировано автоматически.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для курсовых работ.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на данную курсовую работу.

После нажатия кнопки ОК на форме параметров запись о курсовой работе появится в таблице данных в соответствующей позиции.


Добавление практик

Добавление практик

Добавлять в образовательный стандарт практики надо только в том случае, если в нем зафиксированы конкретные виды практик, которые должны быть пройдены студентами. Если же практики заданы в стандарте укрупненно, то нужно пользоваться действиями, описанными в разделах Добавление разделов (циклов, компонентов) стандарта и Добавление групп дисциплин.

Для добавления практики нужно выбрать в таблице данных компонент или группу, в которую должна быть включена практика, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить... / практику. Как правило, в образовательных стандартах выделяются специальные разделы практик.

Добавление практики в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел (группу дисциплин), который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления практики.
  • В поле Вид практики нужно выбрать практику из общевузовского справочника .
  • В поле Способ проведения практики нужно выбрать один из способов проведения практики.
  • После выбора вида практики в поле Наименование будет автоматически сформировано значение, соответствующее выбранному виду практики. Изменять его независимо от вида практики недопустимо.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • В поле Общее число часов значение можно оставить пустым, если оно не зафиксировано в стандарте.
  • В поле Число недель нужно задать число недель, выделяемых на практику.
  • В поле Число кредитов нужно установить число кредитов, выделяемых на практику, соблюдая требуемое соотношение между числом недель и числом кредитов.

После нажатия кнопки ОК на форме параметров запись о практике появится в таблице данных в соответствующей позиции.


Добавление итоговых госэкзаменов

Добавление итоговых госэкзаменов

итоговые государственные экзамены должны добавляться в раздел итоговой аттестации. Итоговые госэкзамены могут быть по одной конкретной дисциплине, или междисциплинарными.

Для добавления итогового экзамена нужно выбрать в таблице данных раздел итоговой аттестации, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / итоговый госэкзамен. На приведенных ниже рисунках представлены примеры заполнения формы параметров для случая добавления экзамена по дисциплине и междисциплинарного экзамена.

Добавление итогового экзамена по дисциплине в стандарт

Добавление междисциплинарного итогового экзамена в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления итогового госэкзамена.
  • Поле Дисциплина нужно заполнять только в случае экзамена по дисциплине. При выборе дисциплины автоматически формируется наименование записи об итоговом экзамене. Если экзамен является междисциплинарным, то поле Дисциплина нужно оставить пустым.
  • Поле Наименование доступно для заполнения только в случае, если поле Дисциплина пустое. В этом случае наименование итогового экзамена нужно ввести вручную с клавиатуры.
    Наименование, заданное для итогового экзамена, будет в дальнейшем использовано при формировании дипломов студентов.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для итогового экзамена.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на итоговый экзамен в соответствии с действующими нормативами.

После нажатия кнопки ОК на форме параметров запись об итоговом госэкзамене появится в таблице данных в соответствующей позиции.


Добавление выпускных квалификационных работ

Добавление выпускных квалификационных работ

Выпускные квалификационные работы (ВКР) должны добавляться в раздел итоговой аттестации.

Для добавления ВКР нужно выбрать в таблице данных раздел итоговой аттестации, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / выпускную работу.

Добавление ВКР в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления ВКР.
  • В поле Наименование нужно ввести наименование ВКР с клавиатуры (Например, "Подготовка и защита выпускной работы бакалавра" или "Подготовка и защита магистерской диссертации").
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для ВКР.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на ВКР в соответствии с действующими нормативами.

После нажатия кнопки ОК на форме параметров запись о выпускной работе появится в таблице данных в соответствующей позиции.


Добавление зачетно-экзаменационных недель

Добавление зачетно-экзаменационных недель

Зачетно-экзаменационные недели должны добавляться в корневой раздел стандарта (раздел "Вся образовательная программа").

Для добавления записи о зачетно-экзаменационных неделях нужно выбрать в таблице данных корневой раздел, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / зачетно-экзаменационные недели.

Добавление зачетно-экзаменационных недель в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления ВКР.
  • В поле Наименование автоматически формируется строка "Зачетно-экзаменационные недели". При необходимости это значение можно изменить.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • В поля Общее число часов и Число недель нужно занести значения, предусмотренные стандартом.

После нажатия кнопки ОК на форме параметров запись о зачетно-экзаменационных неделях появится в таблице данных в соответствующей позиции.


Внесение изменений в созданный стандарт

Внесение изменений в созданный стандарт

После того, как созданы записи стандарта, можно изменять как отдельные свойства записей, так и структуру стандарта. Доступны изменения следующих видов:

  1. Добавление новых записей.
    Для дополнения стандарта новыми записями необходимо вызвать одно из действий добавления, описанных в предыдущих разделах.
  2. Уточнение значений свойств записей стандарта.
    Значения различных свойств записей изменяются разными способами:
    • Наименование можно изменять путем ввода нового значения с клавиатуры с последующим нажатием клавиши Enter для всех записей, кроме тех, которые соответствуют дисциплинам (заполнено значение в колонке Дисциплина) или компонентам стандарта II поколения (заполнено значение в колонке Компонент плана). Для изменения наименования записи, соответствующей дисциплине, нужно в колонке Дисциплина выбрать другую дисциплину из справочника дисциплин. Если нужно дисциплины в справочнике нет, ее можно добавить в справочник. Для изменения наименования записи, соответствующей компоненту стандарта II поколения (ГОС) нужно выбрать другой компонент в колонке Компонент плана. Если нужного компонента в справочнике нет, необходимо обратиться к бизнес-администратору системы с просьбой уточнить данные справочника. При изменении наименования практики нужно проследить за тем, чтобы наименование соответствовало значению, установленному в колонке Вид практики.
    • Порядковый номер можно изменять путем ввода нового числового значения с клавиатуры с последующим нажатием клавиши Enter. При изменении порядкового номера одной из записей необходимо просмотреть значения порядковых номеров всех следующих за ней записей раздела и при необходимости скорректировать и их.
    • Код записи, Общее число часов, Число недель, Минимальное число кредитов, Максимальное число кредитов можно изменять путем ввода нового значения с клавиатуры с последующим нажатием клавиши Enter.
    • При изменении значений, выбранных в колонках Дисциплина и Компонент плана автоматически изменится значение в колонке Наименование.
    • Если Вы изменяете значение, выбранное в колонке Вид практики, необходимо вручную уточнить значение в колонке Наименование.
  3. Изменение структуры стандарта.
    Под изменением структуры понимается перенос записей из одного раздела в другой. Для этого нужно выбрать запись, которую Вы хотите перенести и вызвать для нее действие Перенести в другой раздел. Для выполнения действия нужно указать раздел, которому будет непосредственно подчинена запись.

    Перенос записи в другой раздел

    Для выбора будут доступны только записи вида Раздел плана (компоненты и группы дисциплин). Если Вы выполняете перенос раздела или группы, то необходимо следить за тем, чтобы не включить раздел сам в себя. При подобной попытке будет отображено сообщение об ошибке с текстом "Недопустимо включать раздел сам в себя".
  4. Удаление записей.
    Удаление записей производится при помощи действия Удалить, доступного в контекстном меню. Удалить можно только ту запись, в которую не включено ни одной другой записи. Это означает, что для того, чтобы удалить запись о разделе, нужно сначала удалить или перенести в другие разделы все входящие в него записи. Также удаление будет невозможным в случае, если на основе записи уже созданы записи базового или рабочего учебного плана.


Работа с компетенциями ФГОС

Раздел целиком Одним файлом
Работа с компетенциями ФГОС
  • Создание перечня компетенций стандарта
  • Связь компетенций с записями стандарта


Создание перечня компетенций стандарта

Создание перечня компетенций стандарта

В стандартах III поколения (Федеральных государственных образовательных стандартах, или ФГОС) присутствует перечень компетенций, развиваемых у студента в ходе обучения по соответствующим учебным программам. Перечень всех компетенций, перечисленных в стандарте, должен быть введен в систему. Сделать это можно, выбрав в таблице данных Образовательные стандарты нужный стандарт, и открыв подчиненную таблицу данных Компетенции в стандарте.

Добавление новой компетенции производиться при помощи действия Добавить компетенцию.

  • В поле Код компетенции нужно занести код, используемый для обозначения компетенции в стандарте.
  • В поле Тип компетенции нужно выбрать одно из предлагаемых значений из справочника типов компетенций.
  • В поле Описание компетенции нужно занести текст, разъясняющий содержание компетенции. Можно использовать стандартные действия копирования и вставки значений из других документов.

Перечень компетенций отображается сгруппированным по типам компетенций. После того, как компетенции будут связаны с определенными записями стандарта в подчиненной таблице Развитие в компонентах стандарта для каждой компетенции можно будет увидеть перечень записей стандарта, в которых она присутствует.

Перечень компетенций стандарта

В случае если в разных стандартах присутствуют схожие перечни компетенций, можно воспользоваться действиями Копировать и Вставить, вызываемыми из контекстного меню в таблице данных. Для этого нужно в главной таблице данных выбрать стандарт, для которого уже создан перечень компетеницй, в подчиненной таблице данных выбрать одну или несколько компетенций, выполнить действие Копировать. После этого выбрать другой стандарт в главной таблице, и в подчиненной таблице выполнить действие Вставить. После вставки значения кодов и описаний компетенций можно будет скорректировать.


Связь компетенций с записями стандарта

Связь компетенций с записями стандарта

После того как сформированы записи стандарта (см. Наполнение стандарта компонентами и дисциплинами) и сформирован перечень компетенций стандарта (см. Создание перечня компетенций стандарта) можно устанавливать связи между записями стандарта и компетенциями. Для этого предназначена таблица данных, Развиваемые компетенции, расположенная на третьем уровне формы под таблицей Состав стандарта.

Компетенции могут связываться с любыми записями стандарта, как с компонентами, так и с дисциплинами. Для того, чтобы задать эту связь, нужно выбрать одну из записей стандарта, после чего в подчинненой таблице данных Развиваемые компетенции вызвать действие Добавить компетенцию.

Добавление компетенции к записи стандарта

В единственном поле формы параметров добавления компетенции нужно выбрать компетенцию из списка всех компетенций стандарта, или ввести код компетенции с клавиатуры. Для корректного поиска компетенции в перечне компетенций стандарта необходимо соблюдать регистр символов.

Полный перечень компетенций, связанных с записью стандарта, формируется многократным выполнением процедуры добавления компетенции. В случае, если нужной компетенции не найдено в перечне, предлагаемом для выбора, необходимо вернуться к этапу Создание перечня компетенций стандарта.


Работа с компетенциями оригинальных стандартов

Раздел целиком Одним файлом
Работа с компетенциями оригинальных стандартов

В данном разделе описана реализованная в системе функциональность работы с системой компетенций. Ссистема компетенций может включать компетенции следующих видов:

  • Универсальные (системные) компетенции являются общими для всех направлений подготовки.
  • Профессиональные (инструментальные, социально-личностные) компетенции связаны с видами профессиональной деятельности.

Система компетенций состоит из общевузовских классификаторов компетенций трех основных видов: системных, социально-личностных и инструментальных, а также из перечня компетенций, формируемого для каждого из оригинальных образовательных стандартов на базе общевузовских справочников. Система компетенций включает в себя кодификацию, позволяющую отражать типологию компетенций, порядок их следования и взаимную связь друг с другом.

Работа с компетенциями оригинальных стандартов ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты.

Работа по формированию компетенций для каждого из образовательных стандартов должна включать следующие этапы:

  1. Формирование общевузовских справочников компетенций всех трех видов.
  2. Формирование перечня компетенций для образовательного стандарта, заключающееся в первичном наполнении перечня компетенциями из общевузовского справочника с дальнейшим уточнением их состава и содержания. Работа по уточнению перечня компетенций для стандарта ведется по-разному в зависимости от вида компетенции. Особенности работы с компетенциями разных видов описаны в следующих ниже разделах.

  • Общевузовские справочники компетенций
  • Формирование и уточнение перечня компетенций для оригинального образовательного стандарта


Общевузовские справочники компетенций

Раздел целиком Одним файлом
Общевузовские справочники компетенций

Работа по формированию системы компетенций оригинальных образовательных стандартов должна быть начата с формирования общевузовских классификаторов компетенций каждого из трех видов системных, социально-личностных и инструментальных.

Порядок работы с данными справочниками не существенен, однако до начала формирования перечней компетенций для конкретных образовательных стандартов общевузовские справочники компетенций должны быть сформированы полностью.

  • Системные (универсальные) компетенции
  • Социально-личностные компетенции
  • Инструментальные компетенции


Системные (универсальные) компетенции

Системные (универсальные) компетенции

Работа с общевузовским справочником системных (универсальных) компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Системные компетенции.

Системные компетенции. Общевузовский справочник

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая системная компетенция имеет код и порядковый номер. Коды системных компетенций формируются автоматически из префикса СК-, символа уровня образования (Б или М) и порядкового номера (например, "СК-Б01", "СК-Б03", "СК-М08", "СК-М15"). Смысловое содержание компетенции представлено в поле Формулировка компетентностных образовательных результатов.

Для наполнения или уточнения общевузовского справочника системных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить системную компетенцию
  • Изменить порядковый номер
  • Удалить компетенцию
Уточнять текстовую формулировку компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter.

Добавление компетенции

Для того, чтобы добавить в справочник новую системную компетенцию, нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить системную компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление системной компетенции в общевузовский справочник

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Код компетенции значение будет составлено автоматически из префикса "СК-" (системная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура) и порядкового номера компетенции. Для порядковых номеров меньших 10 в первой позиции будет дописан 0. Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Формулировка компетентностных образовательных результатов значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой системной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера (кода) компетенции

Для изменения порядка следования компетенций предусмотрено действие контекстного меню Изменить порядковый номер. При изменении порядкового номера соответствующим образом изменится и код компетенции.

Изменение порядкового номера системной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции. При его изменении будет изменяться и код компетенции. Повтор порядковых номер компетенций недопустим. При попытке изменить порядковый номер компетенции на существующий произойдет ошибка дублирования объектов.


Социально-личностные компетенции

Социально-личностные компетенции

Работа с общевузовским справочником социально-личностных компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Социально-личностные компетенции.

Социально-личностные компетенции. Общевузовский справочник

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая социально-личностная компетенция имеет код и порядковый номер. Коды социально-личностных компетенций формируются автоматически из префикса СЛК-, символа уровня образования (Б или М) и порядкового номера (например, "СЛК-Б05", "СЛК-Б12", "СЛК-М02", "СЛК-М11"). Смысловое содержание компетенции представлено в поле Формулировка компетентностных образовательных результатов.

Для наполнения или уточнения общевузовского справочника социально-личностных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить социально-личностную компетенцию
  • Изменить порядковый номер
  • Удалить компетенцию
Уточнять текстовую формулировку компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter.

Добавление компетенции

Для того, чтобы добавить в справочник новую социально-личностную компетенцию, нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить социально-личностную компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление социально-личностной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Код компетенции значение будет составлено автоматически из префикса "СЛК-" (социально-личностная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура) и порядкового номера компетенции. Для порядковых номеров меньших 10 в первой позиции будет дописан 0. Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Формулировка компетентностных образовательных результатов значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера (кода) компетенции

Для изменения порядка следования компетенций предусмотрено действие контекстного меню Изменить порядковый номер. При изменении порядкового номера соответствующим образом изменится и код компетенции.

Изменение порядкового номера социально-личностной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции. При его изменении будет изменяться и код компетенции. Повтор порядковых номер компетенций недопустим. При попытке изменить порядковый номер компетенции на существующий произойдет ошибка дублирования объектов.


Инструментальные компетенции

Инструментальные компетенции

Работа с общевузовским справочником инструментальных компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Инструментальные компетенции.

Инструментальные компетенции. Общевузовский справочник

Справочник имеет иерархическую структуру, которая отражает конкретизацию компетенций. Компетенции первого уровня являются наиболее общими и обозначают укрупненные виды деятельности (проектная деятельность, общение и коммуникация и проч.). Компетенция, которую конкретизирует данная компетенция, далее будет называться "родительской", а те компетенции, которые, в свою очередь, конкретизируют данную, будут называться "дочерними". Например, на представленном выше рисунке по отношению к компетенции "ИК-Б1.1 участвовать" родительской является компетенция "ИК-Б1 Проектная и иная деятельность", а дочерними являются компетенции "ИК-Б1.1н в научной деятельности" и "ИК-Б1.1и в исследовательской деятельности".

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая инструментальная компетенция имеет код и порядковый номер, а также может иметь символьное обозначение. Коды социально-личностных компетенций формируются автоматически из префикса ИК-, символа уровня образования (Б или М), собственного порядкового номера и порядковых номеров родительских компетенций, разделенных точкой, и символьного обозначения (при его наличии). Например, коды инструментальных компетенций могут иметь следующий вид: "ИК-Б1", "ИК-Б2.3", "ИК-М3.1и", "ИК-М2.2э". Для инструментальных компетенций в справочник заносится только наименование. Формулировки компетентностных образовательных результатов для компетенций данного вида будут задаваться отдельно для каждого из образовательных стандартов. Также в справочнике отображается формируемое автоматически полное наименование компетенции, составленное из наименования самой компетенции и всех ее родительских компетенций, разделенных символами "/".

Для наполнения или уточнения общевузовского справочника инструментальных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить компетенцию на первый уровень
  • Добавить дочернюю компетенцию
  • Изменить порядковый номер или символьное обозначение
  • Изменить родительскую компетенцию
  • Удалить компетенцию
Уточнять наименование компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter. Полное наименование компетенции при этом изменится автоматически.

Добавление компетенции

Для добавления инструментальных компетенций предусмотрено два действия: Добавить компетенцию на первый уровень и Добавить дочернюю компетенцию. Выбор действия зависит от того, нужно ли добавить самостоятельную компетенцию первого уровня, соответствующую укрупненному виду деятельности, которая не будет иметь родительской компетенции, или нужно добавить компетенцию, уточняющую одну из существующих (дочернюю по отношению к существующей).

Для добавления самостоятельной компетенции первого уровня нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить компетенцию на первый уровень. Отобразиться форма параметров процедуры добавления:

Добавление инструментальной компетенции на первый уровень

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего на первом уровне для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Символьное обозначение можно ввести символ, дополняющий код компетенции, если это необходимо. Если символьное обозначение для данной компетенции не используется, поле нужно оставить пустым.
  • В поле Код компетенции значение будет составлено автоматически из префикса "ИК-" (инструментальная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура), порядкового номера компетенции, символьного обозначения (если оно использовано). Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Наименование компетенции значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Для добавления компетенции, конкретизирующей одну из существующих, нужно сначала выбрать существующую (родительскую) компетенцию, которая должна быть конкретизирована, после чего вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить дочернюю компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление дочерней инструментальной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Родительская компетенция будет отображен код родительской компетенции, которая была выбрана в таблице данных перед вызовом действия добавления. Если новая компетенция должна быть подчинена другой родительской компетенции, то нужно закрыть данную форму при помощи кнопки Отмена, выбрать в таблице данных нужную родительскую компетенцию и снова вызвать действие добавления дочерней компетенции.
  • В поле Уровень образования значение будет подставлено автоматически на основе выбранной родительской компетенции. Изменять это значение при добавлении недопустимо. Если нужно добавить компетенцию для другого уровня образования, то нужно закрыть данную форму, выбрать в таблице данных родительскую компетенцию, принадлежащую к другому уровню образования и повторить добавление.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего на данном уровне иерархии для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Символьное обозначение можно ввести символ, дополняющий код компетенции, если это необходимо. Если символьное обозначение для данной компетенции не используется, поле нужно оставить пустым.
  • В поле Код компетенции значение будет составлено автоматически из префикса "ИК-" (инструментальная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура), порядкового номера компетенции и ее родительских компетенций, символьного обозначения (если оно использовано). Управлять значением данного поля можно изменяя порядковый номер, символьное значение или выбрав другую родительскую компетенцию перед добавлением.
  • В поле Наименование компетенции значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Удаление компетенции, имеющей дочерние компетенции, недопустимо. Если такую компетенцию все же надо удалить, то сначала нужно удалить все ее дочерние компетенции.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера и символьного обозначения компетенции

Для изменения порядка следования компетенций и их символьных обозначений предусмотрено действие контекстного меню Изменить порядковый номер или символьное обозначение. При изменении порядкового номера или символьного обозначения соответствующим образом изменится и код компетенции.

Изменение порядкового номера или символьного обозначения инструментальной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции и символьное обозначение. При изменении этих значений будет изменяться и код компетенции. Повтор полученных кодов компетенций недопустим. При попытке изменить порядковый номер или символьное обозначение таким образом, что полученный код компетенции будет повторять один из существующих, произойдет ошибка дублирования объектов.

Перенос компетенций по иерархической структуре

Для того, чтобы перенести существующую компетенцию по структуре (т.е. изменить для нее родительскую компетенцию), можно воспользоваться действием Изменить родительскую компетенцию.

Изменение родительской компетенции для инструментальной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Родительская компетенция нужно выбрать другую компетенцию из предложенного перечня, которая должна стать родительской по отношению к данной.
  • Значение полей Уровень образования и Наименование компетенции при использовании данной процедуры изменять нельзя.
  • В полях Порядковый номер и Символьное обозначение можно изменять значения описанным выше образом. Также при этом будет изменяться значение в поле Код компетенции.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о компетенции изменит свое положение в иерархической структуре. Также ей будут присвоены новые значения порядкового номера, сиваольного обозначения и кода.


Формирование и уточнение перечня компетенций для оригинального образовательного стандарта

Раздел целиком Одним файлом
Формирование и уточнение перечня компетенций для оригинального образовательного стандарта

При формировании на основе общевузовских справочников перечней компетенций для каждого из образовательных стандартов действуют следующие принципы:

  1. Системные (универсальные) компетенции переносятся в каждый из образовательных стандартов в полном соответствии с общевузовским справочником. Изменение перечня системных компетенций, их формулировок или кодов в конкретном стандарте недопустимо.
  2. Формулировки социально-личностных компетенций в каждом из образовательном стандарте могут уточнятся. При этом код компетенции автоматически получит постфикс, соответствующий аббревиатуре направления подготовки.
  3. Общевузовский справочник инструментальных компетенций имеет иерархическую структуру. Для инструментальных компетенций в общевузовском справочнике задаются только их наименования. Формулировка компетентностных образовательных результатов для инструментальных компетенций заносится только при добавлении компетенции в стандарт.
  4. В образовательный стандарт могут добавляться дополнительные социально-личностные компетенции, не связанные с компетенциями из общевузовского справочника. Добавление в стандарты системных и инструментальных компетенций, не связанных с общевузовскими справочниками, недопустимо.

Работа по формированию и уточнению перечня компетенций для каждого из образовательных стандартов ведется в форме Образовательные стандарты. Для того, чтобы просмотреть, сформировать или отредактировать перечень компетенций для стандарта, нужно выбрать этот стандарт на вкладке Образовательные стандарты и открыть подчиненную таблицу Компетенции в оригинальном стандарте.

До начала работы по формированию перечня компетенций для образовательных стандартов должны быть полностью сформированы Общевузовские справочники компетенций.

Для формирования и уточнения перечня компетенций в таблице данных Компетенции в оригинальном стандарте доступны действия, позволяющие:

  • переносить в образовательный стандарт полный набор компетенций определенного вида, занесенных в общевузовский справочник
  • добавлять к образовательному стандарту компетенции по одной
  • уточнять формулировку и код компетенции (доступно для социально-личностных и инструментальных компетенций)
  • удалять ошибочно добавленные компетенции

Коды компетенций, добавляемых в стандарт, могут отличаться от кодов, заданных в общевузовском справочнике. Отличие, как правило, заключается в дописывании к коду компетенции из общевузовского справочника аббревиатуры направления подготовки.

Аббревиатуры направлений подготовки задаются в общевузовском справочнике пользователями, наделенными правами на работу с данным справочником. Каждый образовательный стандарт относится к определенному направлению подготовки. Если аббревиатура направления не отображается в таблице "Образовательные стандарты" или отображается неверно, нужно обратиться к пользователю, ответственному за работу со справочником направлений и специальностей с просьбой уточнить аббревиатуру нужного направления.
  • Формирование перечня системных компетенций
  • Формирование перечня социально-личностных компетенций
  • Формирование перечня инструментальных компетенций


Формирование перечня системных компетенций

Формирование перечня системных компетенций

Системные (универсальные) компетенции переносятся в каждый из образовательных стандартов в полном соответствии с общевузовским справочником. Изменение перечня системных компетенций, их формулировок или кодов в конкретном стандарте недопустимо.

Для переноса полного перечня системных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все системные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень системных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. Изменять формулировки или коды системных компетенций по сравнению с общевузовским справочником недопустимо.

Системные компетенции в образовательном стандарте

Если после последнего формирования перечня системных компетенций для стандарта произошло добавление системных компетенций в общевузовский справочник, действие Добавить все системные компетенции можно вызвать повторно. Его выполнение приведет к добавлению недостающих системных компетенций, коды и формулировки существующих компетенций будут приведены в соответствие со значениями из общевузовского справочника.

Если возникла необходимость удалить одну из системных компетенций, добавленных к стандарту, из общевузовского справочника, потребуется предварительно удалить ее из стандарта. Для этого необходимо выбрать удаляемую компетенцию в списке и выполнить действие Удалить компетенцию.

Если компетенция была удалена из стандарта ошибочно, или если перечень системных компетенций в общевузовском справочнике был расширен, отдельную системную компетенцию можно добавить в стандарт при помощи действия Добавить компетенцию... / системную компетенцию.

Добавление системной компетенции

Для добавления нужно в поле Компетенция из общевузовского справочника выбрать добавляемую компетенцию из общевузовского справочника системных компетенций. Формулировка выбранной компетенции отобразится в поле Формулировка компетентностных образовательных результатов автоматически. Изменение кода или формулировки системной компетенции недопустимо. После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте.

Повторное добавление компетенции в стандарт недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.


Формирование перечня социально-личностных компетенций

Формирование перечня социально-личностных компетенций

Социально-личностные компетенции переносятся в каждый из образовательных стандартов в соответствии с общевузовским справочником. При этом в конкретном образовательном стандарте формулировка социально-личностной компетенции может быть изменена. При изменении формулировки изменяется и код социально-личностной компетенции - к нему дописывается аббревиатура направления подготовки.

В отличие от других видов компетенций в образовательный стандарт могут добавляться социально-личностные компетенции, не связанные с соответствующими компетенциями общевузовского справочника. Далее такие компетенции называются дополнительные социально-личностные компетенции.

Перенос социально-личностных компетенций из общевузовского справочника в образовательный стандарт можно выполнять одним из двух способов:

  • Добавить все социально-личностные компетенции из общевузовского справочника, после чего уточнить формулировки и коды тех компетенций, для которых это необходимо (рекомендуется в случае, если не планируется существенных изменений по сравнению с общевузовским справочником)
  • Добавлять социально-личностные компетенции по одной с одновременным уточнением их формулировок и кодов (рекомендуется в случае, если состав и содержание социально-личностных компетенций в стандарте должно существенно отличаться от общевузовского справочника)

Формирование перечня социально-личностных компетенций

Для переноса полного перечня социально-личностных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все социально-личностные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень социально-личностных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. После добавления коды и формулировки компетенций можно будет уточнить.

Социально-личностные компетенции в образовательном стандарте

Если после последнего формирования перечня социально-личностных компетенций для стандарта произошло добавление компетенций данного вида в общевузовский справочник, действие Добавить все социально-личностные компетенции можно вызвать повторно. Его выполнение приведет к добавлению недостающих системных компетенций, коды и формулировки существующих компетенций будут приведены в соответствие со значениями из общевузовского справочника.

Отдельную социально-личностную компетенцию, имеющую соответствие в общевузовском справочнике, можно добавить в стандарт при помощи действия Добавить компетенцию... / социально-личностную компетенцию. Одновременно с добавлением компетенции можно выполнить и ее уточнение.

Добавление социально-личностной компетенции

Для добавления нужно в поле Компетенция из общевузовского справочника выбрать добавляемую компетенцию из общевузовского справочника социально-личностных компетенций. Формулировка выбранной компетенции отобразится в поле Формулировка компетентностных образовательных результатов (значение из общевузовского справочника, недоступно для изменения). Та же формулировка отобразится в поле Формулировка компетентностных образовательных результатов (в стандарте). Если формулировку компетенции в стандарте нужно изменить, это можно сделать в поле, доступном для редактирования. Если изменение формулировки произведено, код компетенции будет дополнен аббревиатурой направления.

После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте. В таблице будут отображены как значения кода и формулировки, уточненные для стандарта, так и значения из общевузовского справочника.

Повторное добавление в стандарт компетенции, ссылающейся на ту же запись общевузовского справочника, недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

Для добавления дополнительной социально-личностной компетенции, не связанной с общевузовским справочником, предназначено действие Добавить компетенцию... / дополнительную социально-личностную компетенцию.

Добавление дополнительной социально-личностной компетенции

Для добавления нужно занести формулировку компетенции и ее порядковый номер. Для дополнительных компетенций необходимо использовать порядковые номер от 101 до 200. Код компетенции будет сформирован автоматически из префикса"СЛК-", порядкового номера и аббревиатуры направления подготовки.

После нажатия кнопки ОК дополнительная компетенция будет добавлена в стандарт. В таблице всех компетенций стандарта для дополнительных социально-личностных компетенций в колонках Код общевузовской компетенции и Формулировка компетентностных образовательных результатов (общевуз.) будут отображены пустые значения.

Уточнение социально-личностных компетенций

Социально-личностные компетенции, ранее добавленные в стандарт, могут уточняться по сравнению с компетенциями общевузовского справочника. Для того, чтобы уточнить компетенцию, нужно выбрать ее в таблице данных, после чего вызвать действие Уточнить компетенцию... / социально-личностную компетенцию

Уточнение социально-личностных компетенций

Уточнение компетенции заключается к корректировке ее формулировки по сравнению с формулировкой, заданной в общевузовском справочнике. Если формулировка изменена, в код компетенции будет автоматически дописана аббревиатура направления подготовки.

Удаление социально-личностной компетенции

Если возникла необходимость удалить одну из социально-личностных компетенций, добавленных к стандарту, нужно выбрать ее в таблице данных и воспользоваться действием Удалить компетенцию.


Формирование перечня инструментальных компетенций

Формирование перечня инструментальных компетенций

Формирование перечня инструментальных компетенций для образовательного стандарта заключается в выборе соответствующих инструментальных компетенций из общевузовского справочника и занесения их формулировок. Так как в общевузовском справочнике инструментальных компетенций формулировки компетенций не заносятся, при добавлении инструментальных компетенций в стандарт формулировки должны быть заданы для каждой компетенции. Коды инструментальных компетенций в стандарте будут сформированы автоматически на основе кода компетенции в общевузовском справочнике и аббревиатуры направления подготовки.

Добавление в стандарт инструментальных компетенций, не связанных ни с одной записью общевузовского справочника, недопустимо.

Формирование перечня инструментальных компетенций для стандарта на основе общевузовского справочника можно выполнять одним из двух способов:

  • Добавить все инструментальные компетенции из общевузовского справочника, после чего уточнить все их формулировки и коды
  • Добавлять инструментальные компетенции по одной с одновременным уточнением их формулировок и кодов

Формирование перечня инструментальных компетенций

Для переноса полного перечня инструментальных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все инструментальные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень социально-личностных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. В качестве формулировки компетенции будет подставлено ее наименование их общевузовского справочника. После добавления инструментальных компетенций коды и формулировки всех компетенций необходимо будет уточнить.

Инструментальные компетенции в стандарте

По одной инструментальные компетенции можно добавлять при помощи действия Добавить компетенцию... / инструментальную компетенцию. Одновременно с добавлением компетенции можно выполнить и ее уточнение.

Добавление инструментальной компетенции в стандарт

Для добавления инструментальной компетенции нужно занести ее формулировку в поле Формулировка компетентностных образовательных результатов, после чего в поле Компетенция из общевузовского справочника выбрать наиболее подходящую общевузовскую компетенцию. Для удобства выбора общевузовский справочник инструментальных компетенций отображается в виде иерархической структуры. При этом для добавления в стандарт необходимо выбирать компетенции, не имеющие дочерних компетенций.

После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте. В таблице будут отображены как значения кода и формулировки, уточненные для стандарта, так и значения кода и наименования из общевузовского справочника.

Повторное добавление в стандарт компетенции, ссылающейся на ту же запись общевузовского справочника, недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

Уточнение инструментальных компетенций

Инструментальные компетенции, ранее добавленные в стандарт, могут уточняться по сравнению с компетенциями общевузовского справочника. Для того, чтобы уточнить компетенцию, нужно выбрать ее в таблице данных, после чего вызвать действие Уточнить компетенцию... / инструментальную компетенцию.

Уточнение инструментальных компетенций

Уточнение компетенции заключается к корректировке ее формулировки. Также при уточнении формулировки в код компетенции будет автоматически дописана аббревиатура направления подготовки.

Удаление инструментальной компетенции

Если возникла необходимость удалить одну из инструментальных компетенций, добавленных к стандарту, нужно выбрать ее в таблице данных и воспользоваться действием Удалить компетенцию.


Объединенные учебные планы

Раздел целиком Одним файлом
Объединенные учебные планы

"Объединенные учебные планы" - это такой вид учебных планов, который объединяет в себе "базовый учебный план" и "рабочий учебный план". Объединенный учебный план разрабатывается сразу на все годы реализации образовательной программы, содержит полный набор разделов, дисциплин и других видов записей планов на весь период обучения, и в то же время отражает планирование нагрузки как по дисциплине в целом, так и по видам работ (лекции, семинары, практически и т.п.), по учебным годам (курсам студентов), по периодам каждого года (модулям и семестрам), а также отражает планирование испытаний текущего и рубежного контроля. Дополнительной возможностью Объединенных учебных планов (по сравнению с РУП) является возможность распределения кредитов, аудиторных часов и общих часов по "частям дисциплины", ограниченным рубежными испытаниями (зачетами и экзаменами).

  • Создание нового объединенного учебного плана
  • Редактирование объединенного учебного плана
  • Передача плана на факультет
  • Вывод планов на печать
  • Оценка плановой затратности плана
  • Оценка фактической затратности ОП


Создание нового объединенного учебного плана

Создание нового объединенного учебного плана

Работа с Объединенными учебными планами ведется на участке "Разработка учебных планов" в форме "Объединенные учебные планы". Для создания нового объединенного учебного плана необходимо чтобы предварительно был сформирован соответствующий образовательный стандарт. Работа с образовательными стандартами описана в разделе Образовательные стандарты.

Для добавления объединенного учебного плана необходимо в верхней таблице данных Объединенные учебные планы с помощью контекстного меню вызвать действие Добавить объединенный план.

Добавление объединенного учебного плана

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров добавления объединенного учебного плана

  • В поле Уровень образования - указать уровень образования, для которого создается план.
  • В полях Образовательный стандарт и Образовательную программа - выбрать образовательный стандарт и программу, для которой создается план.
  • Поля Факультет, Филиал, Форма обучения, Магистерская программа, Число лет обучения будут заполнены автоматически данными, заданными для образовательного стандарта и выбранной образовательной программы.
  • При необходимости в полях Специализация и Магистерская специализация можно указать специализацию или магистерскую специализацию, если они не заданы для Образовательной программы.
  • В полях Год начала обучения, Год окончания обучения указать года начала и окончания обучения, периоды, по которым будет планироваться нагрузка (по модулям или по семестрам).
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов в году указать количество периодов в учебном году.

После того, как для всех полей формы добавления Объединенных учебных планов будут заданы допустимые значения, кнопка ОК на форме добавления станет доступной. После ее нажатия запись о новом объединенном учебном плане появится в таблице данных. При попытке добавления второго объединенного учебного плана на основе той же образовательной программы, образовательного стандарта для того же факультета, года начала обучения, специализации, магистерской программы, магистерской специализации произойдет ошибка дублирования объектов.


Редактирование объединенного учебного плана

Раздел целиком Одним файлом
Редактирование объединенного учебного плана

Сформировать структуру и состав нового объединенного учебного плана можно на основе образовательного стандарта. Для этого нужно выбрать объединенный учебный план в таблице данных и в контекстном меню выбрать действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Подтверждение формирования БУП

Если Вы уверены, что хотите сформировать учебный план на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Все записи плана.

После того, как объединенный учебный план сформирован на основе стандарта, его можно редактировать. Для редактирования предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования ОУП

Редактирование объединенного учебного плана должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), распределять нагрузку по видам работы (лекции, семинары, практические и т.д.), по годам обучения (курсам студентов) и по периодам обучения в каждом году (модулям, семестрам), а также планировать рубежные испытания, распределять кредиты и объем нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: дисциплину, научно-исследовательский семинар, курсовую работу, практику, проект студентов, дисциплину других планов, итоговый экзамен, выпускную квалификационную работу, зачетно-экзаменационные недели.

Добавление записи в ОУП

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

Редактирование записей объединенного плана

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение ряда свойств разделов и дисциплин БУП.

По окончании работы с объединенным учебным планом его можно вывести на печать. Для этого можно воспользоваться одним из действий Выгрузить для печати, Выгрузить для печати как Базовый, Выгрузить для печати как рабочий, расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

  • Добавление дисциплин и НИС
  • Добавление курсовой работы
  • Добавление практики
  • Добавление итогового экзамена
  • Добавление выпускной работы
  • Добавление зачетно-экзаменационной недели
  • Добавление проекта студентов
  • Добавление дисциплины других планов
  • Формирование информации о численности контингента


Добавление дисциплин и НИС

Раздел целиком Одним файлом
Добавление дисциплин и НИС

При добавлении дисциплины или НИС в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие дисциплину или научно-исследовательский семинар, после чего заполнить следующую форму параметров:

Добавление дисциплины в ОУП
Пользователям разработчикам учебных планов предоставлена возможность связывания дисциплин и НИС учебного плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
      Для выбора из плана-предложения кафедры будут доступны только те дисциплины, которые совпадают по периоду реализации с периодом, заданным с помощью полей Год начала реализации и Год окончания реализации.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных специализаций, необходимо выбрать специализации, для которых добавляется дисциплина. Для выбора специализаций необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей специализаций, после чего нужно нажать кнопку ОК.
      Для каждой специализации в ОУП будет создана отдельная запись по дисциплине.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных специализаций, необходимо выбрать специализации, для которых добавляется дисциплина. Для выбора специализаций необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей специализаций, после чего нужно нажать кнопку ОК.
      Для каждой специализации в ОУП будет создана отдельная запись по дисциплине.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать и изменять специализацию для дисциплин и НИС (см. Установить или снять специализацию).
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.
  • Установить или снять специализацию
  • Изменение периода реализации
  • Связать с предложением кафедры


Установить или снять специализацию

Установить или снять специализацию

Для установки, снятия и изменения специализации, установленной для дисциплины или НИС, необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Все записи плана выбрать дисциплину или НИС, для которой необходимо установить, снять или изменить специализацию.
    При добавлении дисциплины или НИС можно установить сразу несколько специализаций, для каждой из них будет создана отдельная запись о дисциплине или НИС (см. Добавление дисциплин и НИС). В связи с этим необходимо удостовериться, что выбранная дисциплина или НИС соответствуют той записи, которую необходимо изменить. Установленные специализации можно проверить в поле Для специализации.
  3. Из контекстного меню вызвать действие Установить\изменить специализацию.
  4. В форме параметров указать Специализацию факультета (для ОУП бакалавриата и специалитета) или Магистерская специализация (для ОУП магистратуры).
  5. Нажать кнопку ОК.


Изменение периода реализации

Изменение периода реализации

Для изменения периода реализации дисциплины или НИС, необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Все записи плана выбрать дисциплину или НИС, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.


Связать с предложением кафедры

Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.


Добавление курсовой работы

Добавление курсовой работы

При добавлении курсовой работы в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие курсовую работы, после чего заполнить следующую форму параметров:

Добавление курсовой работы в ОУП

В первую очередь необходимо указать Наименование для курсовой работы, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК курсовая работа будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по курсовой работе.


Добавление практики

Добавление практики

При добавлении практики в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие практику, после чего заполнить следующую форму параметров:

Добавление практики в ОУП

В первую очередь необходимо указать Вид практики (справочник ) и Способ проведения практики, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК практика будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по практике.


Добавление итогового экзамена

Добавление итогового экзамена

При добавлении итогового экзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие итоговый экзамен, после чего заполнить следующую форму параметров:

Добавление итогового экзамена в ОУП

В первую очередь необходимо указать Наименование для итогового экзамена, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК итоговый экзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по итоговому экзамену.


Добавление выпускной работы

Добавление выпускной работы

При добавлении выпускной работы в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие выпускную работу, после чего заполнить следующую форму параметров:

Добавление ВКРБ в ОУП

В первую очередь необходимо указать Наименование и Форму итогового контроля для выпускной работы, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК выпускная работа будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по выпускной работе.


Добавление зачетно-экзаменационной недели

Добавление зачетно-экзаменационной недели

При добавлении зачетно-экзаменационной недели в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие зачетно-экзаменационную неделю, после чего заполнить следующую форму параметров:

Добавление зачетно-экзаменационных недель в ОУП

В первую очередь необходимо указать Наименование зачетно-экзаменационной недели, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК зачетно-экзаменационная неделя будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки для зачетно-экзаменационной недели.


Добавление проекта студентов

Раздел целиком Одним файлом
Добавление проекта студентов

При добавлении проекта студентов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие проект студентов..., после чего заполнить следующую форму параметров:
Добавление проекта в ОУП

  • В поле Проект для студентов необходимо выбрать проект из справочника Проекты для студентов, если проект отсутствует, то его можно добавить (см. Проекты для студентов). Данное поле можно оставить пустым и не устанавливать ссылку на проект из справочника, а только указать Наименование проекта, Вид дисциплины в плане и Число кредитов.
    Записи о проектах в объединенных учебных планах, не связанные с записью справочника проектов, в учебный план факультета передаваться не будут.
  • В поле Вид дисциплины в плане выбрать вид дисциплины.
  • В поле Число кредитов указать соответствующее данному проекту число кредитов.
  • При необходимости установить признак Только в кумулятивный рейтинг.

После нажатия кнопки ОК проект будет добавлена в объединенный учебный план.

  • Проекты для студентов
  • Типы проектов для студентов


Проекты для студентов

Раздел целиком Одним файлом
Проекты для студентов

Справочник "Проекты для студентов" позволяет работать с информацией о проектах, в которые могут включаться студенты в своей внеадиторной деятельности. Справочник распологается в разделе Объединенные учебные планы на соотвествующей вкладке Проекты для студентов.
Справочник проекты для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить проект.
    Вызов действия Добавить проект
  2. Заполнить форму параметров следующим образом:
    Форма параметров Добавить проект
    • Заполнить поля Идентификатор во внешней системе, Полное наименование, Полное наименование на английском языке, Тип проекта (выбирается из справочника Типы проектов для студентов), Вид проектной деятельности (выбирается из списка).
    • В одной из групп полей Руководитель из вуза или Внешний руководитель указать подразделение/организацию руководителя (выбирается из справочников или Места прохождения практики) и выбрать самого руководителя проекта (выбирается из справочника или Работники организации).
      Руководителем проекта может быть только либо представитель вуза, либо внешний руководитель. При этом если начать заполнять одну из групп полей (Руководитель из вуза или Внешний руководитель) другая перестанет быть доступной для заполнения.
    • Заполнить поля Учебный год, Дата начала реализации, Дата окончания реализации, Дата окончания записи на проект, Количество модулей, Период итогового контроля, Вид итогового контроля и Плановое количество кредитов.
  3. Нажать кнопку ОК.
  • Выгрузить проекты студентов
  • Загрузка данных о проектах с портала
  • Загрузка данных о назначении проектов студентам


Выгрузить проекты студентов

Выгрузить проекты студентов

В справочнике Проекты для студентов предоставлена возможность сформировать отчет с информацией о проектах и студентах, которым назначены данные проекты.

Для формирования отчета необходимо:

  1. В справочнике Проекты для студентов из контекстного меню системы вызвать действие Выгрузить проекты студентов.
    Вызов действия Выгрузить проекты
  2. В форме пераметров с помощью выбора значений для параметров Филиал, Факультет, Образовательная программа, Курс, Группа, Проект можно ограничить выборку проектов, для которых будет формироваться отчет. Если все поля формы параметров оставить пустыми, то отчет сформируется для всех проектов ВУЗа, присутствующих в справочнике Проекты для студентов.
  3. Нажать кнопку ОК.

В результате сформируется отчет в формате MS Excel, содержащий информацию об образовательной программе, ФИО, курсе и группах студентов, участвующих в проектах, наименовании проекта, плановом и фактическом количестве кредитов, руководителях проектов, результатах участия в проекте студентов.


Загрузка данных о проектах с портала

Загрузка данных о проектах с портала


Загрузка данных о назначении проектов студентам

Загрузка данных о назначении проектов студентам


Типы проектов для студентов

Типы проектов для студентов

Справочник "Типы проектов для студентов" содержит в себе перечень типов проектов для внеаудиторной деятельности студентов и распологается в разделе Объединенные учебные планы на соотвествующей вкладке Типы проектов для студентов.
Справочник Типы проектов для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить тип проекта.
    Вызов действия Добавить тип проекта
  2. В форме параметров указать Краткое наименование и Полное наименование типа проекта для студентов.
    Форма параметров Добавить тип проекта
  3. Нажать кнопку ОК.


Добавление дисциплины других планов

Добавление дисциплины других планов

Для добавления дисциплин, которые участвуют в расчетах затратности, но при этом не передаются в реализацию на факультеты и которые не участвуют в планировании нагрузки, необходимо:

  1. В форме редактирования объединенного учебного плана или в представлении Все записи плана из контекстного меню, в группе процедур Добавить, вызвать действие дисциплинудругих планов.
  2. Заполнить следующую форму параметров:
    Добавление дисциплины других учебных планов в ОУП
    • В полях Наименование и Наименование на английском языке указать наименование на русском и английском языке (при необходимости) соответственно.
    • При необходимости в поле Кафедра можно указать подразделение ВУЗа, которое реализует данную дисциплину. Для этого необходимо нажать кнопку Справочник, из справочника , с помощью чек-бокса Чек-бокс, выбрать подразделение и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, Общее число часов, Аудиторных часов и Только в кумулятивный рейтинг.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
  3. Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

Отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля) можно непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице, предназначено действие Дополнительные свойства.


Формирование информации о численности контингента

Формирование информации о численности контингента

Для добавления информации о численности контингента необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать план, для записей которого будет уточняться информация о численности контингента.
  2. В представлении Все записи по годам обучения для записей учебного плана в соответствующих полях указать Количество потоков, Количество групп, Количество подгрупп и Количество студентов (после изменения значения каждого из параметров нужно нажимать клавишу Enter).


Передача плана на факультет

Передача плана на факультет

Для того, чтобы дисциплины объединенного учебного плана могли быть назначены студентам, необходимо для плана выполнить действие Передать на факультет. Для каждого отдельного года реализации плана можно также вызывать действие Передать в план факультета в подчиненной таблице Реализация плана по годам.

Передача ОУП на факультет

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.
Записи о проектах студентов в объединенных учебных планах, не связанные с записью справочника проектов, в учебный план факультета передаваться не будут.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Учебные планы факультета. Эта таблица доступна в разделе Студент, в форме Справочники факультета на вкладке Учебные планы факультета.

Назначение дисциплин студентам на участке Студент выполняется именно из таблицы данных Учебные планы факультета. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного учебного плана необходимо выполнять действие по передаче плана на факультет.


Вывод планов на печать

Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как Рабочий, Выгрузить для печати как Базовый, Выгрузить для печати как Рабочий с нагрузкой преподавателей, Выгрузить для печати на английском, Выгрузить для печати как Базовый на английском или Выгрузить для печати как Рабочий на английском.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.


Оценка плановой затратности плана

Оценка плановой затратности плана

Для оценки плановой затратности плана необходимо:

С помощью формирования отчета "Оценка плановой затратности плана"

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
    Группа действий Дополнительные действия
  2. Выбрать действие Оценка плановой затратности (отчет).
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате сформируется отчет с оценкой затратности реализации объединенного учебного плана.

С помощью действия Рассчитать плановую затратность

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
  2. Выбрать действие Рассчитать плановую затратность.
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате будет выведено сообщение с указание плановой затратности плана.


Оценка фактической затратности ОП

Оценка фактической затратности ОП

Для оценки фактической затратности образовательной программы необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать запись объединенного учебного плана.
  2. Из контекстного меню системы вызвать действие Оценка фактической затратности ОП.
  3. В форме параметров указать Учебный год, если нужна конкретизация по преподавателям, то для признака С конкретизацией по преподавателям нужно установить значение "Да".
  4. Нажать кнопку ОК.

В результате сформируется отчет с оценкой фактической затратности реализации образовательной программы.


Базовые учебные планы (БУПы)

Раздел целиком Одним файлом
Базовые учебные планы (БУПы)

Базовый учебный план (БУП) представляет собой иерархическую структуру учебных циклов и включенных в них дисциплин, формируемую на основе соответствующего образовательного стандарта. Базовый учебный план уточняет образовательный стандарт в части набора и трудоемкости дисциплин и других видов подготовки, а также отражает распределение учебной нагрузки по годам обучения студентов. Параметры базового учебного плана могут отличаться от образовательного стандарта. Допустимость или недопустимость таких различий регулируется при помощи контрольных соотношений, формируемых для БУПов.

Каждый базовый учебный план создается но основе одного из образовательных стандартов, задающего уровень образования, направление (специальность) и степень (квалификацию), для выбранного факультета (отделения) и года набора студентов. По одному образовательному стандарту для одного факультета и года набора может быть создано несколько БУПов, отличающихся специализацией (для бакалавриата и магистратуры) или магистерской программой и магистерской специализацией (для магистратуры).

Создание нового базового учебного плана включает следующие этапы работы:

  1. Создание записи о БУПе и его наполнение на основе образовательного стандарта.
  2. Редактирование сформированного БУПа.
  3. Связывание записей БУПа с компетенциями.

  • Создание нового базового учебного плана
  • Создание базового учебного плана как копии существующего
  • Редактирование базового учебного плана
  • Связывание записей базового плана с развиваемыми компетенциями


Создание нового базового учебного плана

Создание нового базового учебного плана

Работа с базовыми учебными планами ведется в форме Базовые и рабочие учебные планы на вкладке Базовые учебные планы. Для создания нового БУПа необходимо чтобы предварительно был сформирован соответствующий образовательный стандарт. Работа с образовательными стандартами описана в разделе Образовательные стандарты. Для добавления нового БУП необходимо выполнить действие Добавить базовый учебный план, после чего заполнить форму параметров добавления следующим образом:

Форма добавления БУП (бакалавриат)

Форма добавления БУП (магистратура)
  • Поле Факультет будет заполнено автоматически, если Вы являетесь пользователем одного из факультетов и для Вас задана настройка "Факультет". В этом случае поле будет недоступно для изменения. Если же для Вас не установлена настройка факультета, то в данном поле Вы должны выбрать один из факультетов из общевузовского справочника Если Вам не удается выбрать нужный факультет, обратитесь к бизнес-администратору системы с просьбой уточнить установленные для Вас настройки.
  • Поле Ведущий факультет необходимо будет заполнить только в том случае, если БУП согласовывается с другим факультетом, для этого необходимо выбрать один из факультетов из общевузовского справочника
  • В поле Образовательная программа необходимо указать образовательную программу из соотвествующего справочника. В зависимости от выбранной образовательной программы изменяется доступность для заполнения полей Специализация, Магистерская программа, Магистерская специализация.
  • Поле Уровень образования будет заполнено автоматически.
  • В поле Образовательный стандарт необходимо выбрать один из существующих в системе образовательных стандартов. Для выбора предлагаются только стандарты для уровня образования, указанного в поле Уровень образования. Если необходимого образовательного стандарта нет в предлагаемом для выбора перечне, необходимо перейти в форму Образовательные стандарты и создать новый стандарт, после чего повторить добавление БУПа.
  • Поле Продолжительность программы ДПО является обязательным для заполнения только для программ подготовки специалистов, реализуемые в сокращенные или ускоренные сроки, для этого необходимо будет выбрать значение продолжительности программы только для ускоренных и сокращенных программы из соотвествующего справочника.
  • В поле Всего кредитов по плану будет автоматически предложено значение, соответствующее уровню образования (Бакалавриат - 240 кредитов, Специалитет - 300 кредитов, Магистратура - 120 кредитов). Однако, если для образовательной программы задано общее число кредитов, отличающее от значение, предлагаемых системой, эти значения можно исправить.
  • Поле Специализация доступно только в случае, если в поле Уровень образования указано значение Бакалавриат или Специалитет. Для выбора предлагаются специализации, существующие в справочнике . Если нужной специализации в этом перечне нет, то ее нужно добавить в справочник специализаций факультета. Если БУП не предполагает специализации, но это поле нужно оставить пустым. В дальнейшем на базе одного БУПа могут быть созданы различные рабочие учебные планы (РУПы) для различных специализаций.
  • Поле Магистерская программа доступно только в том случае, если в поле Уровень образования указано значение Магистратура. Для выбора доступны магистерские программы, существующие в справочнике . Если нужной программы в этом справочнике нет, ее нужно добавить, перейдя в справочник, после чего вернуться к созданию БУПа.
  • Поле Магистерская специализация доступно только в том случае, если в поле Уровень образования указано значение Магистратура. Для выбора доступны только магистерские специализации, существующие в справочнике и принадлежащие к выбранной магистерской программе. Если выбранная магистерская программе не предусматривает магистерских специализаций, или если БУП относится к программе в целом, то данное поле нужно оставить пустым. В дальнейшем на основе БУП для магистерской программы можно будет создавать различные рабочие учебные планы (РУПы) для разных магистерских специализаций.
  • В поле Форма обучения нужно выбрать форму обучения, по которой будет реализовываться образовательная программа, из общевузовского справочника .
  • В поле Программа двойных дипломов нужно установить флажок (значение Да) в случае, если БУП разрабатывается для программы двойных дипломов, реализуемой совместно с другими вузами (в т.ч. зарубежными). В противном случае флажок должен быть снят (значение Нет).
  • В поле Число лет обучения автоматически подставляется значение в зависимости от выбранной образовательной программы и уровня образования (Бакалавриат - 4 года, Специалитет - 5 лет, Магистратура - 2 года). Если БУП реализуется в течение другого числа лет, то это значение можно изменить.
  • В поле Реализуется по периодам нужно выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов в году необходимо указать количество преиодов в учебном году.
  • В поле Год начала обучения нужно выбрать год набора студентов, которые будут обучаться по данному БУП. Выбор производится из справочника среди учебных годов. Если нужного учебного года в справочнике нет, необходимо обратиться к бизнес-администратору системы с просьбой добавить его в справочник.
  • В поле Год окончания обучения нужно выбрать учебный год, в котором студенты, обучающиеся по данному БУП завершат обучение. Выбор производится аналогично выбору в поле Год начала обучения.
  • Поле Вариант позволяет создать несколько вариантов БУП одного и того же БУП с тем, чтобы в дальнейшем выбрать наиболее удачный вариант. Для этого в данном поле нужно указать метку варианта (например, "в-2"). Желательно использовать минимальное число символов. Если Вы не планируете работать с несколькими вариантами одного и того же БУП, это поле нужно оставить пустым.

После того, как для всех полей формы добавления БУП заданы допустимые значения, кнопка ОК на форме добавления станет доступной. После ее нажатия запись о новом БУП появится в таблице данных. При попытке добавления второго БУП на основе той же образовательной программы, образовательного стандарта для того же факультета, года начала обучения, специализации, магистерской программы, магистерской специализации БУП произойдет ошибка дублирования объектов.


Создание базового учебного плана как копии существующего

Создание базового учебного плана как копии существующего

Если необходимо создать базовый учебный план, существенно схожий с уже существующим, можно воспользоваться возможностью копирования плана. Новый план, создаваемый методом копирования, должен отличаться от исходного не менее чем одним из следующих параметров:

  • специализацией;
  • магистерской специализацией;
  • годами обучения студентов;
  • при необходимости продолжительность программы ДПО.
Для того чтобы создать новый план на основе существующего, нужно выбрать исходный план в таблице данных и вызвать действие Скопировать как новый план.

Форма копирования нового БУП на базе старого

При открытии формы копирования плана все поля заполняются значениями, установленными для исходного плана. Для создания нового плана нужно изменить те значения, которые будут отличаться для нового плана и нажать кнопку ОК.

Результатом работы процедуры копирования будет запись о новом базовом учебном плане в таблице данных Базовые учебные планы. В подчиненной таблице Записи базового плана будет создан набор записей, полностью аналогичный составу исходного плана. Также для нового плана будет перенесена информация о распределении учебной нагрузки по годам обучения. Если с записями исходного плана были связаны компетенции, то они также будут скопированы в новый план и связаны с соответствующими записями.

После выполнения процедуры копирования можно продолжить редактирование нового плана. Редактирование может заключаться в добавлении новых записей, удалении созданных при копировании, уточнении форм итогового контроля по дисциплинам, значений объема учебной нагрузки в часах, неделях, кредитах.

Выполнять копирование плана лучше после того, как работа над составом и структурой исходного плана завершена (или близка к завершению). Автоматически актуализировать структуру и состав копии плана после изменения исходного плана будет невозможно. Однако возможно выполнить для нового плана действие Очистить, удалить план и снова сформировать его как копию существующего. Переформировывать таким образом план можно только пока он находится в статусе проект.


Редактирование базового учебного плана

Редактирование базового учебного плана

Если БУП создавался методом копирования, то его состав уже сформирован и можно переходить к его редактированию. Если же создан пустой БУП, то его структуру и состав можно сформировать на основе образовательного стандарта. Для этого нужно выбрать БУП в таблице данных и выполнить действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Подтверждение формирования БУП

Если Вы уверены, что хотите сформировать БУП на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Записи базового плана. В таблице данных Развитие компетенций, подчиненной по отношению к записям плана, будут сформированы записи о компетенциях повторяющие записи, созданные в стандарте.

После того, как БУП сформирован на основе стандарта или скопирован, его можно редактировать. Для редактирования предназначена специализированная форма работы с БУП, которая открывается при вызове действия Открыть.

Редактирование БУП должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), установки видов итоговых испытаний, распределении нагрузки в часах и кредитах по года обучения (курсам). Для выполнения этих действий предназначены соответствующие действия контекстного меню. Для добавлении записи в определенный раздел нужно сначала выбрать заголовок этого раздела или одну из входящих в него записей.

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение ряда свойств разделов и дисциплин БУП.

График учебного процесса, являющийся частью БУП, необходимо разработать отдельно в виде файла формата MS Excel или MS Word. Полученный файл нужно загрузить как значение в колонке График учебного процесса. Для этого нужно непосредственно в колонке воспользоваться кнопкой открытия файла и выбрать файл при помощи стандартного диалога MS Windows. Для сохранения в базе данных системы загруженного файла необходимо нажать клавишу Enter. Если график нужно будет изменить, то его можно выгрузить и сохранить на диске при помощи кнопки сохранения файла, скорректировать файл и загрузить обратно (после повторной загрузки также необходимо нажимать Enter).

По окончании работы с БУП его можно вывести на печать. Для этого можно воспользоваться действием Напечатать план, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия БУП будет выгружен для печати в MS Excel.


Связывание записей базового плана с развиваемыми компетенциями

Связывание записей базового плана с развиваемыми компетенциями

Записи базового учебного плана различных видов (разделы, дисциплины, группы дисциплин, курсовые работы, практики и т.д.) могут связываться с компетенциями, заданными для образовательного стандарта, на основе которого сформирован базовый план. До начала работы с распределением компетенций по записям базового плана, необходимо убедиться в том, что для стандарта корректно сформирован перечень компетенций (раздел Создание перечня компетенций стандарта).

Если базовый учебный план формировался с использованием действия Сформировать на основе стандарта, то перечень компетенций, связанных с записями стандарта (см. раздел Связь компетенций с записями стандарта), будет сформирован и для записей базового учебного плана. Дальнейшая работа должна заключаться в дополнительном связывании компетенций с записями базового плана с целью уточнения из развития за счет отдельных дисциплин.

Для того, чтобы связать компетенцию с записью БУП, нужно открыть форму Базовые и рабочие учебные планы, в ней открыть первую вкладку Базовые учебные планы. Среди всех доступных БУП нужно выбрать план, с которым предстоит работать. На вкладке второго уровня Записи базового плана нужно выбрать запись (дисциплину, группу дисциплин, курсовую работу и т.п.), с которой нужно связать компетенции. После этого на третьем уровне в таблице данных Развиваемые компетенции нужно вызвать действие Добавить компетенцию.

Для выбора в поле Компетенция стандарта доступны все компетенции, сформированные для стандарта в таблице данных Компетенции в стандарте. Если с одной записью БУП нужно связать несколько компетенций, то добавление компетенции нужно повторить.

Если компетенция связана с записью БУП ошибочно, ее можно удалить из списка при помощи действия Удалить.


Объединенные планы факультетских дисциплин

Раздел целиком Одним файлом
Объединенные планы факультетских дисциплин

Объединенный план факультеских дисциплин представляет собой иерархическую структуру групп дисциплин (раделов) и включенных в них дисциплин.

Создание нового объединенного плана факултетских дисциплин включает следующие этапы работы:

  • Создание нового объединенного плана факультетских дисциплин
  • Редактирование объединенного плана факультетских дисциплин
  • Передача объединенного плана факультетских дисциплин в реализацию
  • Вывод планов на печать


Создание нового объединенного плана факультетских дисциплин

Создание нового объединенного плана факультетских дисциплин

Работа с Объединенными учебными планами ведется на участке "Разработка учебных планов" в форме "Объединенные планы факультетских дисциплин".

Для добавления плана необходимо в верхней таблице данных Объединенные планы факультетских дисциплин с помощью контекстного меню вызвать действие Добавить объединенный план факультетских дисциплин.

Процедура добавления объединеннго плана факультетских дисциплин

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров добавления объединенного плана факультетских дисциплин

  • В поле Год начала обучения указать год начала обучения по данному плану.
  • В поле Филиал указать филиал, в котором находится факультет.
  • В поле Факультет выбрать один из факультетов из общевузовского справочника
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов указать количество периодов в учебном году.
  • В поле Число лет указать количество лет, в течение которых реализуется объединенный план факультетских дисциплин.

После того, как для все поля формы будут заполнены, кнопка ОК на форме добавления станет доступной. После ее нажатия, запись о новом объединенном плане факультетских дисциплин появится в таблице данных. При попытке добавления второго плана идентичного уже созданному произойдет ошибка дублирования объектов.


Редактирование объединенного плана факультетских дисциплин

Раздел целиком Одним файлом
Редактирование объединенного плана факультетских дисциплин

Редактирование объединенного плана факультетских дисциплин заключается в создании Групп дисциплин (разделов), добавлении дисциплин в разделы, распределении нагрузки по видам работы (лекции, семинары, практические и т.д.), по годам обучения и по периодам обучения в каждом году (модулям, семестрам), а также планировании рубежных испытаний, распределении кредитов и объемов нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Добавление Группы дисциплин (раздела)

Для редактирования объединенного плана факультетских дисциплин необходимо в таблице данных Объединенные планы факультетских дисциплин выбрать план и с помощью контекстного меню вызвать действие Открыть.

Открытие формы редактирования объединенного плана факультета

В итоге откроется форма редактирования с пустым планом, в которой для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Процедура добавления раздела в объединенный план факультета

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования объединенного плана.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования объединенного плана факультетских дисциплин.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

Добавление Дисциплины или НИС

Для добавления Дисциплины необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие Дисциплину или НИС,

Процедура добавления дисциплины в объединенный план факультета

после чего заполнить следующую форму параметров:

Форма параметров добавления дисциплины в объединеннй план факультетских дисциплин

Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.

    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

Перемещение Группы дисциплин (раздела) или дисциплины

В случае если при добавлении Группы дисциплин или Дисциплины был неверно указан раздел, куда они должны быть включены, то в отношении такой Группы дисциплин или Дисциплины необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить Группу дисциплин или Дисциплину, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина будут перемещены в корень объединенного плана факультетских дисциплин.

Также можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

Печать объединенных планов факультетских дисциплин

По окончании работы с объединенным учебным планом его можно вывести на печать. Для этого можно воспользоваться одним из действий Выгрузить для печати, Выгрузить для печати как Базовый, Выгрузить для печати как Рабочий расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

  • Изменение периода реализации дисциплин
  • Связать с предложением кафедры
  • Формирование информации о численности контингента


Изменение периода реализации дисциплин

Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные планы факультетских дисциплин (форма Объединенные планы факультетских дисциплин) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи плана выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.


Связать с предложением кафедры

Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.


Формирование информации о численности контингента

Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных планов факультетских дисциплин выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.


Передача объединенного плана факультетских дисциплин в реализацию

Передача объединенного плана факультетских дисциплин в реализацию

Для того, чтобы дисциплины объединенного плана факультетских дисциплин могли быть назначены студентам, необходимо для плана выполнить действие Передать на факультет. Для каждого отдельного года реализации плана можно также вызывать действие Передать в план факультета в подчиненной таблице Реализация учебного плана по годам.

Передача плана факультетских дисциплин в реализацию

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Планы факультетских дисциплин. Эта таблица доступна в разделе Студент, в форме Справочники факультета на вкладке Планы факультетских дисциплин.

Назначение дисциплин студентам на участке Студент выполняется именно из таблицы данных Планы факультетских дисциплин. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного плана факультетских дисциплин необходимо выполнять действие по передаче плана на факультет.


Вывод планов на печать

Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные планы факультетских дисциплин (форма Объединенные планы факультетских дисциплин) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как РУП, Выгрузить для печати как БУП.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.


Объединенные майноры

Раздел целиком Одним файлом
Объединенные майноры

Объединенный майнор - это такой вид планов, который объединяет в себе "базовый майнор" и "рабочий майнор". Объединенный майнор разрабатывается на несколько лет обучения, содержит полный набор разделов, дисциплин и других видов записей планов на весь период обучения, и в то же время отражает планирование нагрузки как по дисциплине в целом, так и по видам работ (лекции, семинары, практически и т.п.), по учебным годам (курсам студентов), по периодам каждого года (модулям и семестрам), а также отражает планирование испытаний текущего и рубежного контроля. Дополнительной возможностью Объединенных майноров является возможность распределения кредитов, аудиторных часов и общих часов по "частям дисциплины", ограниченным рубежными испытаниями (зачетами и экзаменами).

  • Создание нового объединенного майнора
  • Редактирование объединенного майнора
  • Передача объединенного майнора в реализацию
  • Изменение периода реализации дисциплин
  • Связать с предложением кафедры
  • Вывод планов на печать
  • Оценка плановой затратности плана
  • Формирование информации о численности контингента


Создание нового объединенного майнора

Создание нового объединенного майнора

Создание объединенного майнора и работа с ним осуществляется в форме Майноры учебных планов, доступной на консоли управления в разделе Разработка учебных планов.

Меню разработка РУП

Представление для работы с базовыми майнорами расположено на первой вкладке данной формы.

Представление объединенные майноры

Для добавления нового объединенного майнора в таблице данных нужно вызвать действие Добавить объединенный майнор. При вызове действия будет отображена форма параметров, которую нужно заполнить следующим образом:

Форма параметров для добавления объединенного майнора
  • Уровень образования - в этом поле из выпадающего списка необходимо выбрать тот уровень образования, для студентов которого будет предназначен майор.
  • Наименование майнора - каждому майнору нужно присвоить наименование. Наименованием может быть любое строковое значение длиной не более 128 символов.
  • Начинается с курса - необходимо указать курс, начиная с которого будет реализовываться майнор.
  • Число лет реализации - в этом поле нужно установить целочисленное значение числа лет реализации майнора.
  • Учебный год начала реализации - в этом поле нужно выбрать учебный год, начиная с которого будет реализовываться данный майнор.
  • Год окончания реализации - в этом поле нужно выбрать учебный год, в котором студенты завершат обучение по данному майнору.
  • Филиал, Факультет - для выбора Образовательной программы, реализующей майнор, в этих полях нужно указать Филиал и Факультет, на которых реализуется данная программа.
  • Образовательная программа, реализующая майнор - в этом поле необходимо выбрать образовательную программу, которая предлагает и будет реализовывать данный майнор.
  • Минимальное количество студентов - в этом поле нужно задать целое число, соответствующее минимальному количеству студентов, для которых будет реализовываться майнор; если минимальное количество студентов не ограничивается, это значение нужно оставить пустым.
  • Максимальное количество студентов - в этом поле нужно задать целое число, соответствующее максимальному количеству студентов, для которых будет реализовываться майнор; если максимальное количество студентов не ограничивается, это значение нужно оставить пустым.
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов в году указать количество периодов в учебном году.

После нажатия кнопки ОК запись о новом майноре будет добавлена в основную таблицу данных.


Редактирование объединенного майнора

Редактирование объединенного майнора

Редактирование майнора состоит в наполнении его дисциплинами, которые могут быть объединены в группы, уточнении объема нагрузки по дисциплинам, установке форм итогового контроля по дисциплинам.

Майнор может состоять из записей двух видов: разделы (группы дисциплин) и дисциплины. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в майнор записей других типов (НИСы, курсовые, практики и проч.) недопустимо.

Редактирование объединенного майнора выполняется при помощи специализированной формы редактирования, которая открывается при вызове для майнора действия Открыть или при двойном щелчке мышью по записи о майноре.

Редактирование объединенногоо плана

Добавление и удаление записей майнора, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню.

Добавление Группы дисциплин (раздела)

Для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Добавление группы дисциплин в объединенный майнор

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

Добавление Дисциплины

Для добавления Дисциплины необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие Дисциплину,

Процедура добавление дисциплины в объединенный майнор

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный майнор

Пользователям разработчикам объединенных майноров предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

    • После того как запись о дисциплинебудет добавлена в майнор, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик объединенного майнора больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

Перемещение Группы дисциплин (раздела) или дисциплины

В случае если при добавлении Группы дисциплин или Дисциплины был неверно указан раздел, куда они должны быть включены, то в отношении такой Группы дисциплин или Дисциплины необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить Группу дисциплин или Дисциплину, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина будет перемещена в корень объединенного майнора.

Также можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

Печать объединенных планов факультетских дисциплин

По окончании работы с объединенным майнором его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати, Выгрузить для печати как Базовый майнор, Выгрузить для печати как Рабочий майнор расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.


Передача объединенного майнора в реализацию

Передача объединенного майнора в реализацию

Для того, чтобы дисциплины объединенного майнора могли быть назначены студентам, необходимо для плана выполнить действие Передать на факультет.

Передача объединенного майнора в реализацию

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Майноры учебных планов. Эта таблица доступна в разделе Общевузовские ресурсы, в форме Учебные планы, формы и программы обучения на вкладке Майноры учебных планов.

Назначение дисциплин майноров студентам на участке Студент выполняется именно из таблицы данных Майноры учебных планов. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного майнора необходимо выполнять действие по передаче майнора на факультет.


Изменение периода реализации дисциплин

Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные майноры (форма Майноры учебных планов) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи майнора выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.


Связать с предложением кафедры

Связать с предложением кафедры

Для того чтобы связать запись объединенного майнора с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись майнора.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.


Вывод планов на печать

Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные майноры (форма Майноры учебных планов) выбрать майнор, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как РУП, Выгрузить для печати как БУП.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести майнор на печать.


Оценка плановой затратности плана

Оценка плановой затратности плана

Для оценки плановой затратности майнора необходимо:

  1. В форме редактирования объединенного майнора открыть группу действий Дополнительные действия (правый верхний угол).
    Форма редактирования ОМ Дополнительные действия
  2. Выбрать действие Оценка плановой затратности (отчет).
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате сформируется отчет с оценкой затратности реализации объединенного майнора.


Формирование информации о численности контингента

Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных майноров выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.


Базовые майноры

Раздел целиком Одним файлом
Базовые майноры

Базовый майнор - это план изучения определенного набора дисциплин в течение нескольких лет обучения. Каждый базовый майнор разрабатывается для определенного уровня образования. Базовый майнор реализуется одной из образовательных программ вуза в течение определенного периода (нескольних ученых годов). Для базового майнора может задаваться минимальное и максимальное число студентов, необходимое для реализации майнора.

  • Создание нового базового майнора
  • Редактирование базового майнора


Создание нового базового майнора

Создание нового базового майнора

Создание базового майнора и работа с ним осуществляется в форме Майноры учебных планов, доступной на консоли управления в разделе Разработка учебных планов.

Майноры на консоли управления

Представление для работы с базовыми майнорами расположено на второй вкладке данной формы.

Таблица данных Базовые майноры

Для добавления нового базового майнора в таблице данных нужно вызвать действие Добавить базовый майнор. При вызове действия будет отображена форма параметров, которую нужно заполнить следующим образом:

Добавление Базового майнора
  • Уровень образования - в этом поле из выпадающего списка необходимо выбрать тот уровень образования, для студентов которого будет предназначен майор.
  • Наименование майнора - каждому майнору нужно присвоить наименование. Наименованием может быть любое строковое значение длиной не более 128 символов.
  • Год начала реализации - в этом поле нужно выбрать учебный год, в котором студенты, для которых предназначается майнор, учились (будут учиться) на первом курсе.
  • Год окончания реализации - в этом поле нужно выбрать учебный год, в котором студенты, для которых предназначается майнор, завершат обучение.
  • Число курсов - в этом поле нужно установить целочисленное значение числа курсов (лет обучения), соответствующее уровню образования
  • Образовательная программа, реализующая майнор - в этом поле необходимо выбрать образовательную программу, которая предлагает и будет реализовывать данный майнор.
  • Минимальное количество студентов - в этом поле нужно задать целое число, соответствующее минимальному количеству студентов, для которых будет реализовываться майнор; если минимальное количество студентов не ограничивается, это значение нужно оставить пустым.
  • Максимальное количество студентов - в этом поле нужно задать целое число, соответствующее максимальному количеству студентов, для которых будет реализовываться майнор; если максимальное количество студентов не ограничивается, это значение нужно оставить пустым.

После нажатия кнопки ОК запись о новом майноре будет добавлена в основную таблицу данных. При этом в подчиненной таблице данных Записи базового майнора будет создана одна запись вида "Раздел плана" с наименованием "Весь майнор", которая будет служить "коревой" записью для будущего майнора.

Выбирая значения полей Год начала реализации, Год окончания реализации, Число курсов нужно исходить из того, что майнор разрабатывается для всех курсов обучения студентов, для которых предназначен майнор. Даже в случае, если известно, например, что майнор будет использоваться для студентов 2 - 3 курсов бакалавриата, для майнора должно быть задано Число лет обучения = 4, и выбраны годы обучения с 1-го по 4-ый курс.


Редактирование базового майнора

Редактирование базового майнора

Редактирование майнора состоит в наполнении его дисциплинами, которые могут быть объединены в группы, уточнении объема нагрузки по дисциплинам, установке форм итогового контроля по дисциплинам. Формируя майнор, нужно исходить из следующих требования к его структуре:

Требования к структуре майнора:

  • Майнор обязательно должен иметь одну и только одну корневую запись типа "Раздел плана". При создании майнора такая запись создается автоматически и получает наименование " Весь майнор ". Это наименование допустимо изменить.
  • Майнор может состоять из записей двух видов: разделы (группы дисциплин) и дисциплины. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в майнор записей других типов (НИСы, курсовые, практики и проч.) недопустимо.

Редактирование базового майнора выполняется при помощи специализированной формы редактирования, которая открывается при вызове для майнора действия Открыть или при двойном щелчке мышью по записи о майноре.

Форма редактирования Базового майнора

Добавление и удаление записей майнора, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню. Основные характеристики записей майнора (число часов, кредитов, формы итогового контроля) редактируются непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей майнора, не видимых в таблице, предназначено действие Дополнительные свойства.

Удалить запись базового майнора можно только при выполнении следюущих условий:

  • не существует записей рабочих майноров, связанных с данной записью базового майнора
  • раздел (группу дисциплин) можно удалить только в случае, если в него не влкючена ни одна дисциплина и ни один другой раздел; если раздел необходимо удалить, сначала из него неоходимо удалить все дисциплины и другие разделы;

В основном процесс редактирования базового майнора аналогичен процессу редактирования Базового учебного плана (см. раздел Редактирование базового учебного плана) с учетом особенностей работы с записями разных типов, описанных в разделе Особенности наполнения отдельных разделов БУП и РУП. Для базового майнора предусмотрена работа только с разделами (группами дисциплин) и с дисциплинами.


Рабочие майноры

Раздел целиком Одним файлом
Рабочие майноры

Рабочий майнор - это план изучения определенного набора дисциплин, входящих в состав одно из Базовых майноров в течение одного учебного года (одного курса студентов). Рабочие майноры разрабатываются на основе разработанных и утвержденных Базовых майноров.

Рабочие майноры для "свободных майноров" не создаются.

  • Создание нового рабочего майнора
  • Редактирование рабочего майнора


Создание нового рабочего майнора

Создание нового рабочего майнора

Создание рабочего майнора и работа с ним осуществляется в форме Майноры учебных планов, доступной на консоли управления в разделе Разработка учебных планов.

Майноры на консоли управления

Представление для работы с рабочими майнорами расположено на третьей вкладке данной формы.

Таблица данных Рабочие майноры

Создать новый рабочий майнор можно только на основе ранее созданного базового майнора вида "Обычный майнор". Рабочие майноры для "свободных" майноров не создаются. Для добавления нового рабочего майнора в таблице данных нужно вызвать действие Добавить рабочий майнор. При вызове действия будет отображена форма параметров, которую нужно заполнить следующим образом:

Добавление Рабочего майнора
  • Базовый майнор - в этом поле нужно выбрать один из базовых майноров, на основе которого будет разрабатываться новый рабочий майнор.
  • Учебный год - в этом поле нужно выбрать учебный код, для которого будет разрабатываться новый рабочий майнор, из справочника .
  • Курс - в этом поле нужно выбрать курс студентов, для которого будет разрабатываться новый рабочий майнор.
  • Реализуется по периодам - в этом поле нужно выбрать один из вариантов реализации майнора - по модулям или по семестрам.
  • Количество периодов - в этом поле нужно задать целочисленного значение числа периодов (модулей или семестров), для которых будет распределяться нагрузка по дисциплинам майнора.

После нажатия кнопки ОК запись о новом майноре будет добавлена в основную таблицу данных.


Редактирование рабочего майнора

Редактирование рабочего майнора

Редактирование рабочего майнора состоит в задании кафедр, которые будут реализовывать дисциплины, уточнении параметров нагрузки по дисциплине (часов, кредитов), распределении нагрузки по видам работы (лекции, семинары, самостоятельная работа и проч.), и по периодам обучения (модулям или семестрам), установке числа форм текущего контроля (контрольных работ, домашних задний и проч.). Структура рабочего майнора должна повторять структуру базового майнора и соответствовать требованиям, предъявляемым к структуре базового майнора, которые описаны в разделе Редактирование базового майнора. Отличие структуры рабочего майнора от структуры базового майнора может состоять только в отсутствии в рабочем майноре групп дисциплин, которые не реализуются на соответствующем курсе.

Редактирование рабочего майнора выполняется при помощи специализированной формы редактирования, которая открывается при вызове для майнора действия Открыть или при двойном щелчке мышью по записи о майноре.

Форма редактирования Рабочего майнора

Установка кафедры, реализующей дисциплину майнора, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню. Основные характеристики записей майнора (число часов, кредитов), их распределение по видам работы и периодам обучения выполняется непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей майнора, не видимых в таблице, предназначено действие Дополнительные свойства. Для уточнения нагрузки и видов испытаний по периодам обучения предназначено действие Дополнительные свойства в периоде. Перед вызовом этого действия нужно выбрать одну из ячеек в колонке, соответствующей периоду, в правой части формы.

В основном процесс редактирования рабочего майнора аналогичен процессу редактирования Рабочего учебного плана (см. раздел Редактирование рабочего учебного плана) с учетом особенностей работы с записями разных типов, описанных в разделе Особенности наполнения отдельных разделов БУП и РУП. Для рабочего майнора предусмотрена работа только с разделами (группами дисциплин) и с дисциплинами.


Объединенные учебные планы аспирантуры

Раздел целиком Одним файлом
Объединенные учебные планы аспирантуры

"Объединенные учебные планы аспирантуры" - это такой вид учебных планов, который объединяет в себе "базовый учебный план аспирантуры" и "рабочий учебный план аспирантуры". Объединенный учебный план разрабатывается сразу на все годы реализации образовательной программы, содержит полный набор разделов, дисциплин и других видов записей планов на весь период обучения, и в то же время отражает планирование нагрузки как по дисциплине в целом, так и по видам работ (лекции, семинары, практически и т.п.), по учебным годам, по периодам каждого года, а также отражает планирование испытаний текущего и рубежного контроля.

  • Создание нового объединенного учебного плана аспирантуры
  • Редактирование объединенного учебного плана аспирантуры
  • Передача плана на факультет
  • Вывод планов на печать
  • Оценка плановой затратности плана


Создание нового объединенного учебного плана аспирантуры

Создание нового объединенного учебного плана аспирантуры

Работа с Объединенными учебными планами аспирантуры ведется на участке "Разработка учебных планов" в форме "Объединенные учебные планы аспирантуры". Для создания нового объединенного учебного плана аспирантуры необходимо чтобы предварительно был сформирован соответствующий образовательный стандарт. Работа с образовательными стандартами описана в разделе Образовательные стандарты.

Для добавления объединенного учебного плана, необходимо в представлении Объединенные учебные планы аспирантуры с помощью контекстного меню вызвать действие Добавить объединенный план аспирантуры.

Вызвать действие Добавить ОУП аспирантов

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров Добавить ОУП аспирантуры

  • В полях Образовательный стандарт и Образовательную программа - выбрать образовательный стандарт и программу, для которой создается план.
  • Поля Аспирантская школа, Филиал, Форма обучения и Число лет обучения будут заполнены автоматически данными, заданными для образовательного стандарта и выбранной образовательной программы.
  • В полях Год начала обучения, Год окончания обучения указать года начала и окончания обучения, периоды, по которым будет планироваться нагрузка.
  • При наличии соответствующей информации можно указать Число кредитов по плану в целом.
  • В поле Реализуется по периодам выбрать один из предлагаемых вариантов реализации: по модулям, по семестрам или по периодам в аспирантуре.
  • В поле Количество периодов в году указать количество периодов в учебном году.

После того, как будет заполнена форма параметров, нужно нажать кнопку ОК. В результате запись о новом объединенном учебном плане аспирантов появится в представлении. При попытке добавления второго объединенного учебного плана аспирантуры на основе той же образовательной программы, образовательного стандарта для той же аспирантской школы, года начала обучения, произойдет ошибка дублирования объектов.


Редактирование объединенного учебного плана аспирантуры

Раздел целиком Одним файлом
Редактирование объединенного учебного плана аспирантуры

Сформировать структуру и состав нового объединенного учебного плана аспирантуры можно на основе образовательного стандарта. Для этого нужно выбрать объединенный учебный план аспирантуры в представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) и в контекстном меню выбрать действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Сообщение о формировании ОУП аспирантов на основании стандарта

Если Вы уверены, что хотите сформировать учебный план на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненном представлении Все записи плана.

После того, как объединенный учебный план сформирован на основе стандарта, его можно редактировать. Для редактирования предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования ОУп аспирантов

Редактирование объединенного учебного плана аспирантов должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (практик аспирантов, кандидатских экзаменов, и т.п.), распределять нагрузку по видам работы (лекции, семинары, практические и т.д.), по годам обучения и по периодам обучения в каждом году, а также планировать рубежные испытания, распределять кредиты и объем нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: дисциплину, научно-исследовательский семинар, научные исследования аспирантов, практику аспирантов, кандидатский экзамен, итоговый госэкзамен, защиту научного доклада.

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, дисциплина по выбору или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

Форма редактирования ОУП аспирантов распределение нагрузки по годам

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение свойств разделов и дисциплин ОУП.

По окончании работы с объединенным учебным планом аспирантов его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении действия учебный план будет выгружен для печати в MS Excel.

  • Добавление дисциплин и НИС
  • Добавление практики аспирантов
  • Добавление научного исследования аспирантов
  • Добавление кандидатских экзаменов
  • Добавление итогового госэкзамена
  • Добавление защиты научного доклада
  • Формирование информации о численности контингента
  • Изменение периода реализации
  • Уточнение свойств разделов и дисциплин ОУП
  • Связать с предложением кафедры
  • Установить/ изменить профиль


Добавление дисциплин и НИС

Добавление дисциплин и НИС

При добавлении дисциплины или НИС в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие дисциплину или научно-исследовательский семинар, после чего заполнить следующую форму параметров:

Форма параметров Добавить дисциплину в ОУП аспирантуры
Пользователям разработчикам учебных планов предоставлена возможность связывания дисциплин и НИС учебного плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
      Для выбора из плана-предложения кафедры будут доступны только те дисциплины, которые совпадают по периоду реализации с периодом, заданным с помощью полей Год начала реализации и Год окончания реализации.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • Установить значение для признака Входит в расчет недельной нагрузки.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных профилей аспирантуры, необходимо выбрать профили, для которых добавляется дисциплина. Для выбора профилей необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей профилей, после чего нужно нажать кнопку ОК.
      Для каждого профиля в ОУП будет создана отдельная запись по дисциплине.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Вид дисциплины в плане, По выбору студентов, Формат изучения,На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных профилей подготовки аспирантуре, необходимо выбрать профили, для которых добавляется дисциплина. Для выбора профилей необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей профилей, после чего нужно нажать кнопку ОК.
      Для каждого профиля в ОУП будет создана отдельная запись по дисциплине.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план аспирантуры.
    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (более подробно см. Редактирование объединенного учебного плана аспирантуры). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признак Входит в расчет недельной нагрузки.
  • Профили для дисциплин и НИС (см. Установить/ изменить профиль).
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.


Добавление практики аспирантов

Добавление практики аспирантов

При добавлении практики аспирантов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие практику аспирантов, после чего заполнить следующую форму параметров:

Форма параметров Добавить практику в ОУП аспирантуры

В первую очередь необходимо ввести Наименование практики и Общее число часов, указать Вид практики (справочник ) и Способ проведения практики, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК практика будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по практике (см. Редактирование объединенного учебного плана аспирантуры).


Добавление научного исследования аспирантов

Добавление научного исследования аспирантов

При добавлении научного исследования аспирантов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие научные исследования аспирантов, после чего заполнить следующую форму параметров:

Форма параметров Добавить научные исследования в ОУП аспирантуры

В первую очередь необходимо указать Наименование и Общее число часов для научных исследований аспирантов, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК запись о научных исследованиях аспирантов будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по научным исследованиям (см. Редактирование объединенного учебного плана аспирантуры).


Добавление кандидатских экзаменов

Добавление кандидатских экзаменов

При добавлении кандидатского экзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие кандидатский экзамен, после чего заполнить следующую форму параметров:

Форма параметров Добавить кандидатский экзамен в ОУП аспирантуры

В первую очередь необходимо ввести Наименование для экзамена и Общее число часов, выбрать Дисциплину ВУЗа, по которой будет проходить кандидатский экзамен, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК кандидатский экзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по кандидатскому экзамену (см. Редактирование объединенного учебного плана аспирантуры).


Добавление итогового госэкзамена

Добавление итогового госэкзамена

При добавлении госэкзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие итоговый госэкзамен, после чего заполнить следующую форму параметров:

Форма параметров Добавить госэкзамен в ОУП аспирантуры

В первую очередь необходимо ввести Наименование для экзамена и Общее число часов, при необходимости можно выбрать Дисциплину, по программе которой будет проходить экзамен, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК госэкзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по госэкзамену (см. Редактирование объединенного учебного плана аспирантуры).


Добавление защиты научного доклада

Добавление защиты научного доклада

При добавлении защиты научного доклада в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие защита научного доклада, после чего заполнить следующую форму параметров:

Форма параметров Добавить защиту докладов в ОУП аспирантуры

В первую очередь необходимо ввести Наименование, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК госэкзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по защите научного доклада (см. Редактирование объединенного учебного плана аспирантуры).


Формирование информации о численности контингента

Формирование информации о численности контингента

Для добавления информации о численности контингента необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать план, для записей которого будет уточняться информация о численности контингента.
  2. В представлении Все записи по годам обучения для записей учебного плана в соответствующих полях указать Количество потоков, Количество групп, Количество подгрупп и Количество студентов (аспирантов) (после изменения значения каждого из параметров нужно нажимать клавишу Enter).


Изменение периода реализации

Изменение периода реализации

Для изменения периода реализации записи объединенного учебного плана аспирантов, необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать учебный план.
  2. В представлении Все записи плана выбрать запись учебного плана, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.


Уточнение свойств разделов и дисциплин ОУП

Уточнение свойств разделов и дисциплин ОУП

В формах редактирования объединенных учебных планов аспирантуры работают проверки контрольных соотношений, при помощи которых контролируется корректность и целостность плана, соответствие характеристик записей плана требованиям образовательного стандарта, выполнение Методических указаний по разработке объединенных учебных планов аспирантуры. Также при помощи функционала формы редактирования можно выполнять автоматизированные пересчеты показателей плана, в частности, суммирование значений числа часов, недель, кредитов по разделам и группам дисциплин.

В образовательном стандарте не содержится достаточно информации для того, чтобы реализовать корректную работу некоторых автоматизированных проверок и пересчетов. По этой причине после формирования учебного плана на основе стандарта, необходимо выполнить уточнение следующих значений для некоторых разделов и дисциплин учебного плана:

  1. Признак Рассчитывается как сумма элементов для групп дисциплин и разделов.

    Все разделы и группы дисциплин можно разделить на два вида:

    • Разделы или группы, показатели которых должны определяться путем суммирования показателей входящих в них записей.
    • Разделы или группы, показатели которых могут устанавливаться независимо.

    К первой группе относятся разделы и группы, все дисциплины которых обязательны для изучения всеми аспирантами. Ко второй группе относятся разделы и группы дисциплин по выбору. Для того, чтобы отличить один вид разделов от другого используется признак Рассчитывается как сумма элементов. При формировании учебного плана на основе стандарта для всех разделов и групп дисциплин этот признак получает значение Да. Если для признака установить значение Нет, то проверка соответствия суммы показателей для всех записей раздела со значением, установленным для раздела в целом, проводиться не будет, и сообщения об ошибках не будут формироваться. Для группы дисциплин (раздела) по выбору значения числа часов, недель, кредитов, числа экзаменов и зачетов нужно установить вручную таким образом, чтобы раздел, в свою очередь, внес необходимый вклад в план в целом. Например, если в раздел включено три дисциплины по выбору, трудоемкостью 108 часов каждая, а аспиранты должны выбрать только одну из них, для раздела вручную должно быть установлено число часов, равное 108.

    Для того чтобы в дальнейшем на основании разработанных объединенных учебных планов можно было сформировать учебный план аспиранта и проверить его полноту и корректность, необходимо задать для каждой группы или раздела дисциплин по выбору минимальное и максимальное количество дисциплин, которые должны быть обязательно выбраны аспирантом, также необходимо задать минимально и максимальное число кредитов, которое необходимо набрать при выборе дисциплин аспирантом. Если при наполнении образовательного стандарта эти значения не заданы, то их необходимо задать в форме редактирования объединенного учебного плана при помощи действия Дополнительные свойства.

  2. Признак Входит в расчет недельной нагрузки. Данный признак используется для того, чтобы исключить некоторые дисциплины учебного плана из расчета недельной аудиторной нагрузки аспирантов. Изменить значение данного признака можно в форме редактирования учебного плана при помощи действия Дополнительные свойства. При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются двумя звездочками (**) в колонке "Наименование дисциплины". По этой причине вносить знаки * в наименование дисциплины не нужно. В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.


Связать с предложением кафедры

Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связать с предложением кафедры в ОУП аспирантуры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.


Установить/ изменить профиль

Установить/ изменить профиль

Для установки, снятия и изменения профиля, установленного для записи учебного плана, необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать учебный план, в который входит запись.
  2. В представлении Все записи плана выбрать запись, для которой необходимо установить, снять или изменить профиль.
    При добавлении дисциплины или НИС можно установить сразу несколько специализаций, для каждой из них будет создана отдельная запись о дисциплине или НИС (см. Добавление дисциплин и НИС). В связи с этим необходимо удостовериться, что выбранная дисциплина или НИС соответствуют той записи, которую необходимо изменить. Установленные специализации можно проверить в поле Специализация.
  3. Из контекстного меню вызвать действие Установить\изменить профиль.
  4. В форме параметров указать Специализацию (профиль аспирантуры).
  5. Нажать кнопку ОК.


Передача плана на факультет

Передача плана на факультет

Для того чтобы дисциплины объединенного учебного плана аспирантуры могли быть назначены аспирантам, необходимо для плана выполнить действие Передать план в реализацию.

Вызов действия Передать план в реализацию для ОУП аспирантов

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

Результатом выполнения процедуры будет создание или уточнение свойств записей в представлении Учебные планы аспирантуры. Данное представление доступно на участке Аспирант, в форме Учебные планы аспирантуры.


Вывод планов на печать

Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать действие Выгрузить для печати.
  3. В форме параметров указать Профиль, для которого нужно вывести на печать, или оставить пустое значение, если нужно вывести на печать учебный план для всех профилей.
  4. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.


Оценка плановой затратности плана

Оценка плановой затратности плана

Выполнить оценку плановой затратности плана можно:

С помощью формирования отчета "Оценка плановой затратности плана"

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
    Вызов действия отчет оценка затратности ОУп аспирантов
  2. Выбрать действие Оценка плановой затратности (отчет).
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате сформируется отчет с оценкой затратности реализации объединенного учебного плана аспирантов.

С помощью действия Рассчитать плановую затратность

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
  2. Выбрать действие Рассчитать плановую затратность.
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате будет выведено сообщение с указанием плановой затратности плана.


Базовые учебные планы аспирантуры (БУПы аспирантуры)

Раздел целиком Одним файлом
Базовые учебные планы аспирантуры (БУПы аспирантуры)

Базовые учебные планы аспирантуры разрабатываются на основе Образовательных стандартов аспирантуры отдельно для каждой и для каждого набора аспирантов. Базовый учебный план аспирантуры отражает полный цикл дисциплин и других видов нагрузки, которые должны быть прослушаны и сданы аспирантами в течение всего срока обучения в аспирантуре с разбиением нагрузки по годам обучения.

Каждый базовый учебный план аспирантуры может расширять и уточнять содержание соответствующего образовательного стандарта. Работа с БУПом аспирантуры состоит из этапов:

  • Создание БУП аспирантуры на основе образовательного стандарта
  • Редактирование БУП аспирантуры
  • Согласование и утверждение БУП аспирантуры
  • Создание нового базового учебного плана аспирантуры
  • Редактирование базового учебного плана аспирантуры


Создание нового базового учебного плана аспирантуры

Создание нового базового учебного плана аспирантуры

Для создания БУП аспирантуры необходимо, чтобы предварительно были сформированы следующие данные:

  • Создан и полностью сформирован Образовательный стандарт аспирантуры по соответствующему направлению подготовки.
  • В справочнике создана соответствующая аспирантская школа.
  • В справочнике созданы учебные года, соответствующие всем годам, в течение которых будет реализовываться новый БУП (от года начала обучения до года окончания обучения).
  • В справочнике созданы записи о форме и годах обучения, для которых будет разрабатываться БУП.

Создание и дальнейшая работа с БУП аспирантуры ведется в разделе Разработка учебных планов в форме Базовые и рабочие учебные планы аспирантуры на первой вкладке Базовые учебные планы аспирантуры. Для создания нового БУП аспирантуры на этой вкладке необходимо вызвать действие Добавить базовый учебный план.

Добавление БУП аспирантуры

Для добавления нужно в поле Аспирантская школа выбрать соответствующую школу из справочника , выбрать Образовательный стандарт из справочника Образовательные стандарты, выбрать Форму обучения и задать соответствующее этой форме Число лет обучения. Также необходимо выбрать Год начала обучения и Год окончания обучения из справочника .

После корректного заполнения всех полей формы добавления кнопка ОК станет активной. После ее нажатия новый базовый учебные план аспирантуры будет добавлен в таблицу данных.


Редактирование базового учебного плана аспирантуры

Редактирование базового учебного плана аспирантуры

После создания БУП аспирантуры его необходимо заполнить и отредактировать путем выполнения следующих двух этапов:

  1. Сформировать на основе стандарта
  2. Отредактировать, указав распределение нагрузки, заданной стандартом по годам обучения, при необходимости уточнив и дополнив содержание стандарта.

Формирование БУП аспирантуры на основе стандарта

После создания БУП аспирантуры необходимо выбрать его в таблице данных и вызвать действие Сформировать на основе стандарта. Результатом выполнения этого действие будет копирование в БУП всего содержания стандарта с сохранением структуры разделов и величин нагрузки, заданных в стандарте.

Редактирование БУП аспирантуры

Для редактирования БУП аспирантуры предназначена специализированная форма, которая доступна посредством вызова действия Открыть по выбранному БУП. При помощи формы редактирования можно выполнять следующие операции:

  • Корректировать (в случае необходимости) или дополнять значения нагрузки, полученные из стандарта
  • Распределять нагрузку, предусмотренную по дисциплине в целом по годам обучения.
  • Дополнять содержание стандарта дополнительными дисциплинами и другими видами работы.
  • Уточнять структуру плана за счет добавления новых разделов или групп дисциплин и переноса дисциплин между разделами.

В целом принцип редактирования БУП аспирантуры аналогичен принципу редактирования БУП студентов, описанному в разделе Редактирование базового учебного плана. Работа с Графиками учебного процесса для БУП аспирантуры не предусмотрена.

Принципы работы с отдельными видами записей БУП аспирантуры аналогичны принципам, заложенным для БУП студентов и описаны в разделе Особенности наполнения отдельных разделов БУП и РУП.

В форме редактирования БУП аспирантуры реализованы проверки и автоматически расчеты, аналогичные реализованным для БУП факультетов. Принцип действия этих расчетов описан в разделе Расчетные показатели учебных планов.

Готовый БУП аспирантуры можно выгрузить в утвержденной форме в MS Excel при помощи действия Выгрузить для печати.


Рабочие учебные планы (РУПы)

Раздел целиком Одним файлом
Рабочие учебные планы (РУПы)

Рабочие учебные планы представляют собой иерархическую структуру компонентов (разделов, циклов), групп дисциплин, дисциплин и записей других видов (курсовых работ, практик, итоговых госэкзаменов, выпускных квалификационных работ). Рабочий учебный план разрабатывается на один учебный год для одного курса студентов факультета (отделения), обучающихся по одному направлению (специальности), по одной специализации, магистерской программе и магистерской специализации. Рабочие учебные планы содержат информацию о видах и количестве испытаний текущего, промежуточного и итогового контроля по дисциплинам, о распределении учебной нагрузки по видам (лекции, семинары, самостоятельная работа и т.п.), а также о реализации дисциплин различными кафедрами ВУЗа.

Каждый рабочий учебный план формируется на основе базового учебного плана, благодаря чему получает атрибуты Тип образовательного стандарта, Образовательный стандартНаправление (специальность), Степень (квалификация), Факультет. Если для базового учебного плана были заданы Специализация, Магистерская программа, Магистерская специализация, то они также будут использованы для РУП. Если эти атрибуты не были заданы для БУП, их можно уточнить при создании РУП.

Создание нового рабочего учебного плана включает следующие этапы работы:

  1. Создание записи о РУПе и его наполнение на основе базового учебного плана.
  2. Редактирование сформированного РУПа.
  3. Связывание записей РУПа с компетенциями.

  • Создание нового рабочего учебного плана
  • Создание рабочего учебного плана как копии существующего
  • Редактирование рабочего учебного плана
  • Связывание записей рабочего плана с развиваемыми компетенциями


Создание нового рабочего учебного плана

Создание нового рабочего учебного плана

Работа с РУПами ведется в форме Базовые и рабочие учебные планы в таблице данных Рабочие учебные планы. Для создания нового РУП нужно в этой таблице данных вызвать действие Добавить рабочий учебный план.

Добавление РУП бакалавриата

Форма добавления РУП (бакалавриат)

Добавление РУП магистратуры

Форма добавления РУП (магистратура)
  • В поле Факультет значение подставится автоматически, если Вы являетесь пользователем одного из факультетов. Если Вы имеете права на работу со всеми факультетами, то в этом поле нужно выбрать факультет, для которого создается РУП.
  • В поле Уровень обучения нужно выбрать один из предлагаемых вариантов (Бакалавриат, Специалитет, Магистратура)
  • В поле Базовый учебный план для выбора будут предложены все ранее созданные БУПы выбранного факультета и уровня обучения. После выбора БУП автоматически заполнятся поля Направление / специальность (обязательно присутствует в БУП), а также Специализация, Магистерская программа, Магистерская специализация (если они заданы в БУП).
  • Поле Направление / специальность заполняется автоматически при выборе БУП и недоступно для самостоятельного изменения.
  • Поле Специализация доступно для изменения только в случае, если в поле Уровень образования выбраны значения Бакалавриат или Специалитет, а также если специализация не задана в БУП. В этом случае специализацию можно выбрать из перечня специализаций, существующих в справочнике . Если РУП не требует задания специализации, то это поле нужно оставить пустым.
  • Поле Магистерская программа заполняется автоматически на основании выбранного БУП. Это поле недоступно для отдельного изменения.
  • Поле Магистерская специализация доступно для заполнения только в случае, если в поле Уровень образования выбрано значение Магистратура а также если магистерская специализация не задана в БУП. В этом случае ее можно выбрать из перечня, существующего в справочнике для выбранной магистерской программы.
  • В поле Форма обучения нужно выбрать ту форму обучения, по которой будет реализовываться РУП. Выбор производится из общевузовского справочника .
  • В поле Курс нужно выбрать курс факультета, для которого формируется РУП.
  • В поле Учебный год нужно выбрать учебный год, в котором будет реализовываться формируемый РУП.
  • Поле Вариант позволяет создать несколько вариантов РУП одного и того же РУП с тем, чтобы в дальнейшем выбрать наиболее удачный вариант. Для этого в данном поле нужно указать метку варианта (например, "в-2"). Желательно использовать минимального число символов. Если Вы не планируете работать с несколькими вариантами одного и того же РУП, это поле нужно оставить пустым.
  • В поле Реализуется по периодам нужно выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество учебных периодов нужно задать число модулей или семестров, по которым будет реализовываться план.
  • В поле Количество потоков нужно задать плановое число потоков по данному РУП.
  • В поле Количество студентов нужно задать плановое число студентов, которые будут обучаться по данному РУП.
  • В поле Количество групп нужно задать число групп студентов, которые будут обучаться по РУП.

После заполнения всех необходимых полей, нужно нажать кнопку ОК, и запись о новом РУП появится в таблице данных. Не допускается создание двух РУП с одинаковым сочетанием атрибутов

  • Факультет
  • Учебный год
  • Направление/специальность
  • Специализация
  • Магистерская программа
  • Магистерская специализация
  • Метка варианта плана
При попытке создания второго РУП с тем же сочетанием атрибутов произойдет ошибка дублирования объектов.


Создание рабочего учебного плана как копии существующего

Создание рабочего учебного плана как копии существующего

Если необходимо создать рабочий учебный план, существенно схожий с уже существующим, можно воспользоваться возможностью копирования плана. При помощи копирования можно создать РУП другой специализации, другой магистерской специализации. Также допустимо копировать РУП с одного учебного года на другой. Для этого необходимо сменить БУП, на основе которого разрабатывается РУП на БУП другого года набора. Также при помощи копирования можно создать другую версию того же плана.
Несмотря на то, что при копировании РУП разрешена смена БУП, являющегося основой РУП, не рекомендуется копировать РУП со сменой направления (специальности) подготовки. Копировать РУП с одного учебного года на другой стоит только в том случае, если структура плана (разделы плана и порядок их включения друг в друга) сохраняется. Если же структура плана должна быть другой, то лучше создать новый план, после чего воспользоваться действием Сформировать не основе базового плана.
Для того чтобы создать новый план на основе существующего, нужно выбрать исходный план в таблице данных и вызвать действие Скопировать как новый план.

Форма копирования нового РУП на базе старого

Набор полей формы копирования аналогичен набору полей формы добавления рабочего плана. Принципы работы со всеми полями описаны в разделе Создание нового рабочего учебного плана. При открытии формы копирования плана все поля заполняются значениями, установленными для исходного плана. Для создания нового плана нужно изменить те значения, которые будут отличаться для нового плана и нажать кнопку ОК.

Результатом работы процедуры копирования будет запись о новом рабочем учебном плане в таблице данных Рабочие учебные планы. В подчиненной таблице Записи рабочего плана будет создан набор записей, полностью аналогичный составу исходного плана. Также для нового плана будет перенесена информация о распределении учебной нагрузки по периодам обучения и формы текущего контроля. Если с записями исходного плана были связаны компетенции, то они также будут скопированы в новый план и связаны с соответствующими записями.

После выполнения процедуры копирования можно продолжить редактирование нового плана. Редактирование может заключаться в добавлении новых записей, удалении созданных при копировании, уточнении форм итогового и текущего контроля по дисциплинам, значений объема учебной нагрузки в часах, неделях, кредитах.

Выполнять копирование плана лучше после того, как работа над составом и структурой исходного плана завершена (или близка к завершению). Автоматически актуализировать структуру и состав копии плана после изменения исходного плана будет невозможно. Однако возможно выполнить для нового плана действие Очистить, удалить план и снова сформировать его как копию существующего. Переформировывать таким образом план можно только пока он находится в статусе проект.


Редактирование рабочего учебного плана

Редактирование рабочего учебного плана

Если рабочий учебный план не создавался методом копирования, то после создания его содержимое можно сформировать на основе выбранного при создании базового учебного плана. Для этого нужно выбрать РУП в таблице данных и выполнить действие Сформировать на основе базового плана. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Записи рабочего учебного плана. В таблице данных Развиваемые компетенции, подчиненной по отношению к записям плана, будут сформированы записи о компетенциях повторяющие записи, созданные в БУП.

После того, как РУП сформирован на основании БУП или скопирован, его можно редактировать. Для редактирования предназначена специализированная форма работы с РУП, которая открывается при вызове действия Открыть.

Редактирование РУП должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), выборе кафедр, которые будут преподавать дисциплины на факультете, распределении учебной нагрузки по видам (лекции, семинары, самостоятельная работа) и по учебным периодам. Для добавления записей в РУП предназначены соответствующие действия контекстного меню. Для добавлении записи в определенный раздел нужно сначала выбрать заголовок этого раздела или одну из входящих в него записей.

При добавлении дисциплины в РУП потребуется найти нужную дисциплину в общевузовском справочнике всех дисциплин. Данный справочник, как правило, содержит очень много записей, многие из которых имеют похожие наименования. Для поиска нужной дисциплины можно использовать следующие приемы:
  1. Начать ввод с клавиатуры названия дисциплины в поле Дисциплина формы добавления. По ходу вводу символов будут автоматически предлагаться дисциплины, наименование которых начинается с введенных символов (при вводе необходимо соблюдать регистр!).
  2. Открыть справочник дисциплин, воспользоваться фильтром по наименованию или по части наименования. В строке фильтра допустимо использование символов "*" (любое число любых символов) и "?" (один любой символ). Например, введя в строку фильтра значение *экономическ* и нажав Enter можно отобрать для показа только те дисциплины, которые имеют в своем наименовании буквосочетание "экономическ" ("История экономических учений", "Введение в экономическую географию", "Политико-экономический анализ" и т.п.). При этом дисциплина с наименованием "Экономическая теория" отобрана не будет, т.к. символ "Э" введен в ней в верхнем регистре.

    Установка фильтра 1
  3. Открыть справочник дисциплин, выбрать в нем любую запись, в записи выбрать колонку "Полное наименование". Прижав клавишу Alt, начать вводить наименование дисциплины. Регистр символов при этом не играет роли.

    Установка фильтра 2

    После того, как клавиша Alt будет отпущена, в таблице данных будет найдена и выделена первая дисциплина, наименование которой начинается с символов "дискр" в любом регистре, например, "Дискретная математика".

По окончании работы с РУП его можно вывести на печать. Для этого можно воспользоваться действием Напечатать план, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия РУП будет выгружен для печати в MS Excel.


Связывание записей рабочего плана с развиваемыми компетенциями

Связывание записей рабочего плана с развиваемыми компетенциями

При формировании рабочего учебного плана не основе базового, компетенции, связанные с записями базового плана будут связаны с соответствующими записями рабочего плана. Для дополнения и уточнения развития компетенций в РУП можно удалить или добавить компетенции к записям РУП, что делается аналогично связыванию компетенций с записями БУП (см. раздел Связывание записей базового плана с развиваемыми компетенциями ).


Рабочие учебные планы аспирантуры (РУПы аспирантуры)

Раздел целиком Одним файлом
Рабочие учебные планы аспирантуры (РУПы аспирантуры)

Рабочие учебные планы аспирантуры разрабатываются на основе Базовых учебных планов аспирантуры отдельно для каждой и для каждого учебного года. Рабочий учебный план аспирантуры отражает цикл дисциплин и других видов нагрузки, которые должны быть прослушаны и сданы аспирантами в течение одного года обучения с разбиением нагрузки по периодам обучения (полугодиям) т указанием форм промежуточного и итогового контроля по периодам обучения.

Каждый рабочий учебный план аспирантуры может расширять и уточнять содержание соответствующего базового учебного плана. Работа с РУПом аспирантуры состоит из этапов:

  • Создание РУП аспирантуры на основе БУП
  • Редактирование РУП аспирантуры
  • Согласование и утверждение РУП аспирантуры
  • Создание нового рабочего учебного плана аспирантуры
  • Редактирование рабочего учебного плана аспирантуры


Создание нового рабочего учебного плана аспирантуры

Создание нового рабочего учебного плана аспирантуры

Для создания БУП аспирантуры необходимо, чтобы предварительно были сформированы следующие данные:

  • Создан и полностью сформирован Базовый учебный план аспирантуры, на основе которого должен быть разработан новый РУП.
  • В справочнике создан учебный год, на который будет разрабатываться новый РУП, и в составе этого учебного года должны быть созданы периоды обучения, по которым предстоит распределять нагрузку и планировать испытания (зачеты и экзамены).
  • В справочнике создана запись о форме и годе обучения, для которых будет разрабатываться РУП.

Создание и дальнейшая работа с РУП аспирантуры ведется в разделе Разработка учебных планов в форме Базовые и рабочие учебные планы аспирантуры на второй вкладке Рабочие учебные планы аспирантуры. Для создания нового РУП аспирантуры на этой вкладке необходимо вызвать действие Добавить рабочий учебный план.

Добавление РУП аспирантуры

Для добавления нужно в поле Аспирантская школа выбрать соответствующую школу из справочника , выбрать Базовый учебный план. После выбора базового учебного плана поля Направление / специальность и Форма обучения будут заполнены данными, соответствующими БУП. Изменять из независимо от БУП невозможно. Также необходимо выбрать Год обучения аспирантов из справочника и Учебный год из справочника . Значение в поле Количество учебных периодов позволит выполнять планировать нагрузку и проведение испытаний по соответствующему числу сессий. Значения Количество потоков, Количество групп, Количество аспирантов позволят рассчитывать нагрузку кафедр и преподавателей по реализации данного РУП.

После корректного заполнения всех полей формы добавления кнопка ОК станет активной. После ее нажатия новый рабочий учебные план аспирантуры будет добавлен в таблицу данных.


Редактирование рабочего учебного плана аспирантуры

Редактирование рабочего учебного плана аспирантуры

После создания РУП аспирантуры его необходимо заполнить и отредактировать путем выполнения следующих двух этапов:

  1. Сформировать на основе БУП
  2. Отредактировать, указав распределение нагрузки, заданной БУП, по периодам учебного года, запланировать рубежные испытания (экзамены и зачеты) и текущий контроль (домашние задания, рефераты, контрольные работы). При необходимости можно уточнить и дополнить содержание БУП.

Формирование РУП аспирантуры на основе БУП

После создания РУП аспирантуры необходимо выбрать его в таблице данных и вызвать действие Сформировать на основе базового. Результатом выполнения этого действие будет копирование в РУП всего содержания РУП на один из годов обучения с сохранением структуры разделов и величин нагрузки, заданных в БУП.

Редактирование РУП аспирантуры

Для редактирования РУП аспирантуры предназначена специализированная форма, которая доступна посредством вызова действия Открыть по выбранному РУП. При помощи формы редактирования можно выполнять следующие операции:

  • Корректировать (в случае необходимости) или дополнять значения нагрузки, полученные из БУП
  • Распределять нагрузку, предусмотренную по дисциплине в учебном году по периодам учебного года.
  • Планировать текущий контроль (домашние задания, рефераты, контрольные работы и проч.).
  • Дополнять содержание БУП дополнительными дисциплинами и другими видами работы.
  • Уточнять структуру плана за счет добавления новых разделов или групп дисциплин и переноса дисциплин между разделами.

В целом принцип редактирования РУП аспирантуры аналогичен принципу редактирования РУП студентов, описанному в разделе Редактирование рабочего учебного плана.

Принципы работы с отдельными видами записей РУП аспирантуры аналогичны принципам, заложенным для РУП студентов и описаны в разделе Особенности наполнения отдельных разделов БУП и РУП.

В форме редактирования РУП аспирантуры реализованы проверки и автоматически расчеты, аналогичные реализованным для РУП факультетов. Принцип действия этих расчетов описан в разделе Расчетные показатели учебных планов.

Готовый РУП аспирантуры можно выгрузить в утвержденной форме в MS Excel при помощи действия Выгрузить для печати.


Рабочие учебные планы общевузовских дисциплин

Раздел целиком Одним файлом
Рабочие учебные планы общевузовских дисциплин

В системе поддерживается возможность разработки рабочих учебных планов (РУПов), в которые будут включены дисциплины, преподаваемые не для студентов определенных образовательных программ, а предлагаемые для выбора всем студентам вуза. В отличие от обычных РУПов РУПы общевузовских дисциплин разрабатываются независимо от Базовых учебных планов (БУП) и Образовательных стандартов.

Структура и атрибутивный состав записей РУПов общевузовских дисциплин аналогичны обычным РУПам. При этом для РУПов общевузовских дисциплин не предусмотрен расчет итоговых показателей плана (сумма часов и кредитов, средняя аудиторная нагрузка и проч.). Также для РУПов общевузовских дисциплин не предусмотрены процедуры согласования и утверждения.

Данные о дисциплинах, входящих в общевузовские РУПы, используются при составлении планов нагрузки преподавателей. Нагрузка по дисциплинам общевузовских РУП рассчитывается аналогично нагрузке по дисциплинам обычных РУП.

Создание и редактирование РУПов общевузовских дисциплин выполняется в разделе Разработка учебных планов в форме Учебные планы общевузовских дисциплин на вкладке Рабочие планы общевузовских дисциплин.

  • Создание РУПа общевузовских дисциплин
  • Редактирование РУПа общевузовских дисцплин
  • Передача РУПа общевузовских дисциплин на реализацию


Создание РУПа общевузовских дисциплин

Создание РУПа общевузовских дисциплин

Создание РУПов общевузовских дисциплин выполняется в разделе Разработка учебных планов в форме Учебные планы общевузовских дисциплин на вкладке Рабочие планы общевузовских дисциплин. Для создания нового плана нужно вызвать действие Добавить учебный план общевузовских дисциплин.

Добавление РУП общевузовских дисциплин

Для создания нового РУП необходимо выбрать Учебный год, занести Наименование плана, выбрать Уровень образования (параметр необязательный), выбрать тип периодов реализации в поле Реализуется по периодам и задать Количество учебных периодов.

От выбора Уровня образования будет зависеть то, по каким нормативам будет считаться нагрузка кафедр и преподавателей по дисциплинам этого плана. От выбора Периодов реализации и их количества будет зависеть то, по каким периодам будут планироваться испытания (экзамены и зачеты) по этим дисциплинам.


Редактирование РУПа общевузовских дисцплин

Редактирование РУПа общевузовских дисцплин

После создания РУПа общевузовских дисциплин его можно редактировать при помощи формы редактирования. Форма редактирования открывается при помощи действия Открыть.

Добавление разделов, групп дисциплин и дисциплин, уточнение их характеристик, распределения аудиторных часов по модулям выполняется аналогично этим же возможностям в обычных РУП. Подробнее - Редактирование рабочего учебного плана. Итоговые значения для плана в целом и средние значения недельной аудиторной нагрзки по плану в целом не подсчитываются.


Передача РУПа общевузовских дисциплин на реализацию

Передача РУПа общевузовских дисциплин на реализацию

Для того, чтобы дисциплины общевузовского РУП могли быть назначены студентам, необходимо выполнить для плана действие Передать план на факультет. Для каждой отдельной дисциплины можно также вызывать действие Передать в план факультета в подчиненной таблице Записи рабочего учебного плана.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Дисциплины вне учебных планов. Эта таблица доступна в разделе Общевузовские ресурсы, в форме Учебные планы, программы и формы обучения на вкладке Дисциплины вне учебных планов.

Назначение дисциплин студентам на участке Студент выполняется именно из таблицы данных Дисциплины вне учебных планов. Поэтому при завершении создания дисциплины или при внесении изменений в данные общевузовского РУП необходимо выполнять действие по передаче плана или дисциплин на факультет.


Объединенные планы общевузовских дисциплин

Раздел целиком Одним файлом
Объединенные планы общевузовских дисциплин

Объединенный план общевузовских дисциплин дисциплин представляет собой иерархическую структуру групп дисциплин (раделов) и включенных в них дисциплин (НИС и дисциплин для иностранных студентов).

Создание и редактирование нового объединенного плана общевузовских дисциплин включает следующие этапы работы:

  • Создание нового объединенного плана общевузовских дисциплин
  • Редактирование объединенного плана общевузовских дисциплин
  • Передача планов в реализацию
  • Вывод планов на печать


Создание нового объединенного плана общевузовских дисциплин

Создание нового объединенного плана общевузовских дисциплин

Работа с Объединенными учебными планами общевузовских дисциплин ведется на участке "Разработка учебных планов" в форме "Учебные планы общевузовских дисциплин".

Расположение формы Учебные планы общевузовских дисциплин

Для добавления плана необходимо в верхней таблице данных Объединенные планы общевузовских дисциплин с помощью контекстного меню вызвать действие Добавить объединенный план общеуниверситетских дисциплин.

Процедура добавления объединеннго плана общевузовских дисциплин

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров добавления объединенного плана общевузовских дисциплин
  • В поле Тип общевузовского плана выбрать из списка (кнопка Список) соотвествующий тип плана.
  • В поле Уровень образования из выпадающего списка необходимо выбрать тот уровень образования, для студентов которого предназначен создаваемый учебный план.
  • В поле Наименование плана учебному плану нужно присвоить наименование. Наименованием может быть любое строковое значение длиной не более 128 символов.
  • В поле Число лет реализации указать количество лет, в течение которых реализуется объединенный план общевузовских дисциплин.
  • В поле Учебный год начала реализации указать год начала обучения по данному плану.
  • В поле Год окончания реализации нужно выбрать учебный год, в котором студенты завершат обучение по данному плану.
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов указать количество периодов в учебном году.

После того, как все поля формы будут заполнены, кнопка ОК на форме добавления станет доступной. После ее нажатия, запись о новом объединенном плане общевузовских дисциплин появится в таблице данных. При попытке добавления второго плана идентичного уже созданному произойдет ошибка дублирования объектов.


Редактирование объединенного плана общевузовских дисциплин

Раздел целиком Одним файлом
Редактирование объединенного плана общевузовских дисциплин

Редактирование объединенного плана общевузовских дисциплин состоит в наполнении его дисциплинами, НИС, или дисциплинами иностранных студентов, которые могут быть объединены в группы, уточнении объема нагрузки, установке форм итогового контроля.

Объединенный план может состоять из следующих видов записей: разделы (группы дисциплин), дисциплины, НИС и Дисциплины иностранных студентов. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в план записей других типов (курсовые, практики и проч.) недопустимо.

Редактирование объединенного плана выполняется при помощи специализированной формы редактирования, которая открывается при вызове для выбранного учебного плана действия Открыть или при двойном щелчке мышью по записи об учебном плане.

Редактирование объединенного плана общевузовских дисциплин

Добавление и удаление записей учебного плана, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню.

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

Редактирование записей объединенного плана

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

По окончании работы с объединенным планом его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати или Выгрузить для печати как РУП расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия учебный план будет выгружен для печати в MS Excel.

  • Добавление раздела (группы дисциплин)
  • Добавление дисциплины
  • Добавление НИС
  • Добавление дисциплины иностранных студентов
  • Перемещение записей
  • Изменение периода реализации дисциплин
  • Связать с предложением кафедры
  • Формирование информации о численности контингента


Добавление раздела (группы дисциплин)

Добавление раздела (группы дисциплин)

Для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Добавление группы дисциплин в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.


Добавление дисциплины

Добавление дисциплины

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать действие дисциплину,

Процедура добавление дисциплины в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный план общевузовских дисциплин
Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

    • После того как запись о дисциплине будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с записью дисциплины, предлагаемой кафедрой, разработчик объедиеннного учебного плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.


Добавление НИС

Добавление НИС

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать действие научно-исследовательский семинар,

Процедура добавление НИС в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный план общевузовских дисциплин
Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Семинар, предлагаемый кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего будет добавлен в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Семинар, предлагаемый кафедрой оставить пустым.
    • в поле Семинар (дисциплина ВУЗа) указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.

    • После того как запись о НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания семинара с дисциплиной-предложением кафедры разработчик объединенного учебного плана больше не сможет изменять параметры нагрузки по семинару, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.


Добавление дисциплины иностранных студентов

Добавление дисциплины иностранных студентов

Добавлять Дисциплины для иностранных студентов можно только в объединенные планы общевузовских дисциплин, у которых при создании Тип общевузовского плана был установлен как "Дисциплины для иностранных студентов". (см. Создание нового объединенного плана общевузовских дисциплин).

Для добавления Дисциплины иностранных студентов необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие дисциплину иностранных студентов,

Процедура добавление дисциплины иностранных студентов в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины иностранных студентов в объединенный план общевузовских дисциплин
  1. В поле Кафедра задать кафедру, которая будет вести дисциплину.
  2. в поле Дисциплина для иностранных студентов указать требуемую дисциплину, для этого необходимо открыть справочник Все дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Все дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
  3. Заполнить поля: Имеет пререквизиты, Код записи, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  4. Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соотвествующую область науки из выпадающего списка Список или с помощью справочника Справочник.
  5. Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

Отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля) можно непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице, предназначено действие Дополнительные свойства.

Редактирование записей объединенного плана

При необходимости вновь созданную дисципину для иностранных студентов можно связать с записью дисциплины, предлагаемой к реализации кафедрами, для этого:

  1. Из контекстного меню нужно вызвать действие Связать с предложением кафедры. При помощи параметров этой процедуры можно попытаться поискать подходящую дисциплину. Можно выполнить поиск не точно такой же, а "похожей" дисциплины. Для этого нужно очистить значение в поле Дисциплина для выбора и снова поискать дисциплину в поле Предложение кафедры. Можно также очистить поле Кафедра и поискать дисциплину на всех кафедрах. Если походящая дисциплина найдена, ее нужно выбрать и нажать кнопку ОК.
  2. Если же подходящей дисциплины так и не найдено, нужно заполнить кафедру в поле Кафедра и установить флажок Создать заявку на дисциплину (флажок доступен при условии, что кафедра задана, а поле "Предложение кафедры" пустое), после чего нажать кнопку ОК. В результате будет выполнен поиск плана-предложения кафедры с атрибутами Год начала реализации, Уровень образования, Реализуется по периодам, соответствующими атрибутам учебного плана; если такого плана-предложения найдено не будет, он будет создан для указанной кафедры. В найденный или созданный план-предложение будет добавлена дисциплина со всей информацией о нагрузке, раннее занесенной для нее в учебном плане; дисциплина в плане-предложении кафедры получит статус "заявка на дисциплину".

После связывания дисциплины плана с дисциплиной, предлагаемой кафедрой, разработчик объединенного учебного плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.


Перемещение записей

Перемещение записей

В случае если при добавлении Группы дисциплин или Дисциплины (НИС, Дисциплины иностранных студентов) был неверно указан раздел, куда они должны быть включены, то в отношении такой записи необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить запись, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина (НИС, Дисциплины иностранных студентов) будет перемещена в корень объединенного плана общевузовских дисциплин.

Также для изменения порядка следования записей можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.


Изменение периода реализации дисциплин

Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные планы общевузовских дисциплин (форма Учебные планы общевузовских дисциплин) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи плана выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.


Формирование информации о численности контингента

Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных планов общевузовских дисциплин выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.


Передача планов в реализацию

Передача планов в реализацию

Для того, чтобы дисциплины объединенного плана общевузовских дисциплин могли быть назначены студентам, необходимо для плана выполнить действие Передать в реализацию.

Процедура передачи плана на факультет

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Дисциплины вне учебных планов. Эта таблица доступна в разделе Общевузовские ресурсы, в форме Учебные планы, формы и программы обучения на вкладке Дисциплины вне учебных планов.

Назначение общевузовских дисциплин студентам на участке Студент выполняется именно из таблицы данных Дисциплины вне учебных планов. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного плана общевузовских дисциплин необходимо выполнять действие по передаче плана в реализацию.


Вывод планов на печать

Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные планы общевузовских дисциплин (форма Учебные планы общевузовских дисциплин) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как РУП, Выгрузить для печати на английском языке, Выгрузить для печати как рабочий на английском языке.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.


Учебные планы лицея

Раздел целиком Одним файлом
Учебные планы лицея

Учебные планы представляют собой иерархическую структуру компонентов (разделов), школьных предметов и проектов школьников. Учебный план лицея разрабатывается сразу на все годы реализации образовательной программы, и содержит информацию о видах и количестве испытаний по школьным предметам, о распределении учебной нагрузки по периодам и т.д.

Создание нового учебного плана лицея включает следующие этапы работы:

  1. Создание записи об учебном плане лицея.
  2. Наполнение и редактирование учебного плана.
  3. Передача плана в реализацию.

  • Создание нового учебного плана лицея
  • Редактирование учебного плана лицея
  • Передача плана в реализацию


Создание нового учебного плана лицея

Создание нового учебного плана лицея

Работа с учебными планами лицея ведется на участке "Разработка учебных планов" в форме "Учебные планы лицея".

Для добавления нового учебного плана лицея необходимо в представлении Учебные планы лицея с помощью контекстного меню вызвать действие Добавить план лицея.

Процедура Добавить план лицея

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров Добавить план лицея

  • В поле Направление в лицее - указать направление обучения школьников.
  • В полях Образовательный программа - выбрать образовательную программу, для которой создается план.
  • В поле Класс начала обучения - указать класс, начиная с которого будет реализовываться план.
  • В поле Число лет обучения - указать количество лет реализации плана.
  • В полях Год начала обучения, Год окончания обучения указать года начала и окончания обучения, периоды, по которым будет планироваться нагрузка.
  • В поле Реализуется по периодам выбрать один из предлагаемых вариантов реализации.
  • В поле Количество периодов в году указать количество периодов в учебном году.
  • При необходимости можно указать Количество учащихся и Количество классов.

После того, как для всех полей формы добавления учебного плана лицея будут заданы допустимые значения, кнопка ОК на форме добавления станет доступной. После ее нажатия запись о новом учебном плане появится в представлении Учебные планы лицея. При попытке добавления второго учебного плана такого же направления, образовательной программы и года начала обучения произойдет ошибка дублирования объектов.


Редактирование учебного плана лицея

Раздел целиком Одним файлом
Редактирование учебного плана лицея

Для редактирования учебного плана лицея предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования учебного плана лицея

Редактирование учебного плана должно заключаться в добавлении разделов, школьных предметов и проектов школьников, распределении нагрузки по видам работы (лекции, семинары, практические и т.д.), по годам обучения (классам) и по периодам обучения в каждом году (модулям, семестрам), а также планировании рубежных контролей.

Для добавления раздела необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие раздел плана.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: школьный предмет, проект школьников.

Форма редактирования группа процедур Добавить

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, формы контролей), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается школьниками или нет и т.д.), предназначено действие Дополнительные свойства.

Редактирование записей учебного плана лицея

  • Добавление раздела
  • Добавление школьного предмета
  • Добавление проекта школьников


Добавление раздела

Добавление раздела

Для создания раздела необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие раздел плана,

Форма редактирования Добавить раздел в учебный план лицея

после чего заполнить следующую форму параметров:

Форма параметров добавить раздел учебный план лицея

  • В поле Раздел из справочника выбрать раздел для добавления.
  • В поле Наименование необходимо ввести название раздела.
  • В поле Код записи при необходимости можно указать код записи для добавляемого раздела.
  • В полях Общее число часов и Число недель можно указать общее количество часов и число недель по плану для данного раздела. При необходимости данные поля можно оставить пустыми и указать данные параметры непосредственно в форме редактирования.
  • В поле Рассчитывается как сумма элементов необходимо установить значение "Да", если показатели раздела определяться путем суммирования показателей входящих в них записей. Если показатели раздела плана должны устанавливаться независимо, то необходимо установить значение "Нет".
  • Для разделов показатели, которых устанавливаются независимо, при необходимости можно указать Минимальное и Максимальное число дисциплин для выбора, и Минимальное и Максимальное число кредитов для выбирамых дисциплин.

После нажатия кнопки ОК, раздел будет добавлен.


Добавление школьного предмета

Добавление школьного предмета

При добавлении школьного предмета в форме редактирования учебного плана лицея необходимо из контекстного меню в группе процедур Добавить вызвать действие школьный предмет, после чего заполнить следующую форму параметров:

Форма параметров Добавить школьный предмет в учебный план лицея
  • В поле Школьный предмет с помощью списка Список или справочника Справочник нужно выбрать школьный предмет для добавления.
  • В поле Кафедра при необходимости можно указать кафедру, которая будет реализовать школьный предмет.
  • В поле Вид дисциплины необходимо выбрать вид добавляемой дисциплины.
  • В поле По выбору студентов нужно установить значение "Да" для школьных предметов, назначаемых школьникам в обязательном порядке, и значение "Нет" для школьных предметов, которые назначаются при выборе школьником.
  • В полях Аудиторных часов и Число недель необходимо указать соответствующие числовые характеристики добавляемого школьного предмета.

После заполнения формы параметров необходимо нажать кнопку ОК, после чего школьный предмет будет добавлен в учебный план.

После того как запись о школьном предмете будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, недель, формы контролей), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается школьниками или нет и т.д.), предназначено действие Дополнительные свойства.


Добавление проекта школьников

Добавление проекта школьников

При добавлении проекта школьников в форме редактирования учебного плана лицея необходимо из контекстного меню в группе процедур Добавить вызвать действие проект школьников, после чего заполнить следующую форму параметров:

Форма параметров Добавить проект школьников в учебный план лицея
  • В поле Наименование необходимо ввести наименование проекта школьников.
  • В поле Кафедра при необходимости можно указать кафедру, которая будет реализовать проект школьников.
  • В полях Число недель, Аудиторных часов нужно указать соответствующие числовые характеристики добавляемого школьного проекта.
  • Значение для Аудиторных часов в неделю определяется автоматически.
  • Если нагрузка по проекту должна учитываться при расчете недельной нагрузки, то в поле Входит в расчет недельной нагрузки должно быть установлено значение "Да".
  • В поле По выбору студентов должно быть установлено значение "Да" для проектов школьников, назначаемых школьникам в обязательном порядке, и значение "Нет" для проектов школьников, которые назначаются при выборе школьником.

После заполнения формы параметров необходимо нажать кнопку ОК, после чего школьный предмет будет добавлен в учебный план.


Передача плана в реализацию

Передача плана в реализацию

Для того чтобы записи учебного плана могли быть назначены школьникам, необходимо для плана выполнить действие Передать план в реализацию.

Вызов действия передать план в реализацию

После чего в форме параметров нужно указать учебный год (поле На учебный год), за который будет передаваться план в реализацию, указать Номер класса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в представлении Учебные планы лицея. Данное представление доступно на участке Лицей университета, в форме Учебные планы лицея.


Особенности наполнения отдельных разделов БУП и РУП

Раздел целиком Одним файлом
Особенности наполнения отдельных разделов БУП и РУП

Разделы БУП и РУП, наполненные дисциплинами, обязательными для изучения всеми студентами, не представляют большой сложности при заполнении. В них могут добавляться дисциплины, не присутствующие в стандарте или в БУП, при этом суммарные значения числа часов, числа недель, числа кредитов могут быть пересчитаны автоматически. Разделы, в состав которых входят дисциплины, необязательные для изучения всеми студентами, а также разделы, содержащие прочие виды нагрузки (курсовые работы, практики, итоговые экзамены, выпускные работы) требуют отдельного внимания.

Для того, чтобы отразить особенности различных разделов, дисциплин и других видов нагрузки, входящих в БУП или РУП, после автоматизированного формирования структуры плана для его записей необходимо уточнить ряд дополнительных свойств, таких как

  • Вид дисциплины, обязательность для изучения студентами
  • Учет в текущем, или только в кумулятивном рейтинге
  • Вхождение в расчет недельной аудиторной нагрузки студентов
  • Преподавание дисциплины на иностранном языке
  • Допустимость нескольких испытаний в одном периоде

Работа записями плана, не являющимися дисциплинами (курсовыми работами, практиками, итоговыми государственными экзаменами, выпускными квалификационными работами связана с рядом особенностей, которые изложены в следюущих ниже разделах.

  • Уточнение ряда свойств разделов и дисциплин БУП и РУП
  • Организация разделов и групп дисциплин по выбору
  • Работа с факультативами
  • Работа с адаптационными дисциплинами
  • Курсовые работы
  • Работа с практиками
  • Работа с разделом итоговой государственной аттестации


Уточнение ряда свойств разделов и дисциплин БУП и РУП

Уточнение ряда свойств разделов и дисциплин БУП и РУП

В формах редактирования БУП и РУП работают проверки контрольных соотношений, при помощи которых контролируется корректность и целостность плана, соответствие характеристик записей плана требованиям образовательного стандарта, выполнение Методических указаний по разработке БУП и РУП. Также при помощи функционала формы редактирования можно выполнять автоматизированные пересчеты показателей плана, в частности, суммирование значений числа часов, недель, кредитов по разделам и группам дисциплин.

В образовательном стандарте не содержится достаточно информации для того, чтобы реализовать корректную работу некоторых автоматизированных проверок и пересчетов. По этой причине после формирования БУП на основе стандарта или РУП на основе БУП, необходимо выполнить уточнение следующих значений для некоторых разделов и дисциплин БУП или РУП:

  1. Признак Рассчитывается как сумма элементов для групп дисциплин и разделов.
  2. Свойство Количество выбираемых дисциплин для разделов и групп дисциплин по выбору.
  3. Признак Только в кумулятивный рейтинг для дисциплин, число кредитов по которым не должно участвовать в подсчете суммы по разделу и по плану в целом.
  4. Свойство Вид дисциплины и признак Выбирается студентами.
  5. Признак Входит в расчет недельной нагрузки.
  6. Свойство На иностранном языке.
  7. Свойство Допустимо несколько испытаний в периоде.
Уточнение данных свойств производится в форме редактирования БУП или РУП при помощи действия Дополнительные свойства.

Дополнительные свойства раздела плана:

Дополнительные свойства для раздела

Дополнительные свойства дисциплины плана:

Дополнительные свойства для дисциплины

1. Уточнение признака Рассчитывается как сумма элементов для групп дисциплин и разделов.

Все разделы и группы дисциплин можно разделить на два вида:

  • Разделы или группы, показатели которых должны определяться путем суммирования показателей входящих в них записей.
  • Разделы или группы, показатели которых могут устанавливаться независимо.
К первой группе относятся разделы и группы, все дисциплины которых обязательны для изучения всеми студентами. Ко второй группе относятся разделы и группы дисциплин по выбору, факультативов адаптационных дисциплин. Для того, чтобы отличить один вид разделов от другого используется признак Рассчитывается как сумма элементов. При формировании БУП на основе стандарта для всех разделов и групп дисциплин этот признак получает значение Да. При формировании РУП на основе БУП для разделов РУП устанавливается то же значение признака, которое было задано для данного раздела в БУП.

Если для признака установить значение Нет, то проверка соответствия суммы показателей для всех записей раздела со значением, установленным для раздела в целом, проводиться не будет и сообщения об ошибках не будут формироваться. В этом случая значения числа часов, недель, кредитов, числа экзаменов и зачетов (в РУП) для раздела нужно установить вручную таким образом, чтобы раздел, в свою очередь, внес необходимый вклад в план в целом. Например, если в раздел включено три дисциплины по выбору, трудоемкостью 108 часов каждая, а студенты должны выбрать только одну из них, для раздела вручную должно быть установлено число часов, равное 108.

Наименования разделов, для которых не используется контроль равенства суммы показателей раздела и суммы показателей входящих в него записей выделяется курсивным шрифтом. При проверке плана на такие разделы нужно обращать отдельное внимание.

Разделы, рассчитываемые и не рассчитываемые как сумма

2. Уточнение значения Количество выбираемых дисциплин

Для того, чтобы в дальнейшем на основании разработанных БУП и РУП можно было сформировать учебный план студента и проверить его полноту и корректность, необходимо задать для каждой группы или раздела дисциплин по выбору количество дисциплин, которые должны быть обязательно выбраны студентом.

Если при наполнении образовательного стандарта эти значения не заданы, то их необходимо задать в форме редактирования БУП или РУП при помощи действия Дополнительные свойства.

3. Уточнение признака Только в кумулятивный рейтинг

Ряд дисциплин, принадлежащих к разделу факультативов или к группам адаптационных дисциплин, могут не участвовать в подсчете суммы кредитов по группе, по разделу и по плану в целом. Кредиты по таким дисциплинам начисляются студентам только при расчете кумулятивного рейтинга, но не начисляются при расчете текущего рейтинга. Для того, чтобы было возможным рассчитать кумулятивный рейтинг студентов по таким дисциплинам, значения числа кредитов должны быть заданы, однако для того, чтобы корректно провести проверку суммарного числа кредитов БУП и РУП такие дисциплины необходимо выделить из перечня обычных дисциплин.

Уточнение данного признака производится в форме редактирования БУП и РУП при помощи действия Дополнительные свойства.

При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются одной звездочкой (*) в колонке "Зачетные единицы". В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.

4. Уточнение признаков Вид дисциплины и Выбирается студентами

Если при формировании стандарта или БУП для дисциплины были неверно заданы значения свойств Вид дисциплины и Выбирается студентами, то эти значения можно уточнить в формах редактирования БУП и РУП при помощи действия Дополнительные свойства. Эти свойства являются зависимыми, т.е. если для свойства Вид дисциплины установить значение Обязательная дисциплина или Обязательный факультатив, то для признака Выбирается студентами будет автоматически подставлено значение Нет. Если же для вида дисциплины выбрать значение Дисциплина по выбору или Факультатив, то признак автоматически получит значение Да. При исключении из этого правила, значение признака Выбирается студентами можно изменить вручную.

Корректная установка этих свойств важна для дальнейшего назначения учебных планов студентам и контроля полноты сформированных учебных планов студентов.

5. Уточнение признака Входит в расчет недельной нагрузки.

Данный признак используется для того, чтобы исключить некоторые дисциплины РУП из расчета недельной аудиторной нагрузки студентов. При формировании РУП на основе БУП для данного признака устанавливается значение Да. При редактировании РУП для факультативов, а также других дисциплин, аудиторная нагрузка по которым не должна входить в расчет недельной аудиторной нагрузки студентов, необходимо изменить значение этого признака на Нет.

Изменить значение данного признака можно в форме редактирования РУП при помощи действия Дополнительные свойства.

При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются двумя звездочками (**) в колонке "Наименование дисциплины". По этой причине вносить знаки * в наименование дисциплины не нужно. В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.

6. Выделение предметов, преподаваемых на иностранном языке.

Для того чтобы выделить дисциплины плана, преподаваемые на иностранном языке, при помощи действия Дополнительные свойства для них можно установить свойство На иностранном языке. При формировании БУП и РУП данное для данного свойства устанавливается пустое значение, что означает, что дисциплина преподается на русском языке. Для дисциплин, преподаваемых на иностранных языках, можно выбрать один из иностранных языков, преподаваемых в ВУЗе. Если в выпадающем списке нет нужного языка, необходимо обратиться к администратору системы с просьбой добавить язык в доступный перечень.

7. Наличие нескольких испытаний в одном периоде для дисциплины плана.

Как правило по всем дисциплинам плана в каждом из учебных периодов (модуле, семестре), предусматривается одно (или ни одного) испытание рубежного контроля. Если возникает исключительная ситуация, при которой необходимо запланировать более одного испытания в одном учебном периоде (например, экзамен и итоговый полевой сбор по военной подготовке), это можно сделать следующим образом:

  1. Выбрать дисциплину, вызвать действие Дополнительные свойства.
  2. Установить флажок к поле Допустимо несколько испытаний в периоде. В правой части строки в колонках, предназначенных для указания видов испытаний ("Экзамен", "Зачет") будут отображены два уровня по аналогии с записями разделов.
    Несколько испытаний в одном периоде
  3. Установить количество (в штуках) экзаменов и / или зачетов в строке дисциплины на соответствующем уровне (рядом со словом "Экз." или "Зач.").
  4. Проконтролировать правильность вычисления количества экзаменов и зачетов для раздела плана, в который входит данная дисциплина.

Если необходимость наличия нескольких испытаний в периоде отпала, или была установлена ошибочно, от нее можно отказаться, вызвав для дисциплины действие Дополнительные свойства и сняв флажок Допустимо несколько испытаний в периоде. Строка дисциплины снова будет отображаться обычным образом. В столбцах, отвечающих за виды испытаний по периодам, нужно выбрать значения "Экзамен" или "Зачет".


Организация разделов и групп дисциплин по выбору

Организация разделов и групп дисциплин по выбору

Присутствующие в БУП или РУП дисциплины по выбору могут либо представлять собой единую группу, входящую в раздел "Дисциплины по выбору" одного из компонентов, либо формироваться в несколько групп, из каждой из которых студентами должно быть выбрано определенное количество дисциплин.

Если группы дисциплин были заданы в стандарте, то они будут созданы в БУП при его формировании по стандарту. При формировании РУП на основе БУП созданные в БУП группы будут перенесены в РУП. Группы дисциплин можно создавать и при редактировании БУП или РУП. После создания групп в них можно добавлять отдельные дисциплины. Также можно переносить существующие дисциплины в группы при помощи действия Перенести в другой раздел.

В отличие от обычных разделов и групп, для которых значения числа часов, недель и кредитов вычисляется как сумма значений, заданных для входящих в них дисциплин, для разделов и групп дисциплин по выбору эти значения должны задаваться самостоятельно. Для того, чтобы проверки и автоматические расчеты, работающие в формах редактирования БУП и РУП, работали корректно, а также с целью последующего контроля формирования индивидуальных учебных планов студентов, для разделов и групп дисциплин по выбору должны быть дополнительно уточнены значения ряда свойств. Уточнение выполняется при помощи действия Дополнительные свойства.

Дополнительные свойства для дисциплин по выбору
  • Для признака Рассчитывается как сумма элементов должно быть установлено значение Нет.
  • Если для раздела или группы определяется количество дисциплин, которые должны быть выбраны студентом, то это значение нужно занести в колонку Количество выбираемых дисциплин. Если количество дисциплин не задается, а накладывается ограничение только на число кредитов, то это значение нужно оставить пустым. Вы этом случае контролироваться будет не количество выбранных студентом дисциплин, а значение суммы кредитов по всем выбранным им дисциплинам.
  • Должны быть уточнены значения Трудоемкость в часах, Недели и Трудоемкость в зачетных единицах, объем аудиторной нагрузки по периодам, число форм текущего контроля (РУП). После того как для признака Рассчитывается как сумма элементов установлено значение Нет, значения числа часов, недель и кредитов, заданные для группы, не будут сравниваться с суммой значений для входящих в группу дисциплин и не будут автоматически пересчитываться.
Раздел дисциплин по выбору

Если все дисциплины раздела распределены по группам, для каждой из которых задано определенное значение числа часов, недель и кредитов, которые должны быть набраны студентом, то для раздела в целом значение признака Рассчитывается как сумма элементов должно быть установлено в Да, так как, действительно, для раздела должны быть просуммированы значения, заданные для каждой из групп.

Раздел дисциплин по выбору с группами

В данном примере для групп ДПВ1 (1 из 2) и ДПВ2 (1 из 6) значение признака Рассчитывается как сумма элементов установлено как Нет, а для записи раздела ОПД.В.00 Дисциплины по выбору установлено значение Да.


Работа с факультативами

Работа с факультативами

Факультативы, также как и дисциплины по выбору должны быть выделены в БУП и в РУП в отдельный раздел или группу дисциплин. Для разделов или групп факультативов при помощи действия Дополнительные свойства признак Рассчитывается как сумма элементов должен быть установлен как Нет.

Дополнительные свойства для раздела факультативов

Для всех дисциплин, являющихся факультативами дополнительные свойства должны быть установлены следующим образом:

Дополнительные свойства для дисциплин факультативов

После того, как для факультативов установлен признак Только в кумулятивный рейтинг, число кредитов будет помечено знаком *. После установки значения Нет для признака Входит в расчет недельной нагрузки число аудиторных часов по факультативу в учебном периоде (модуле, семестре) не будет участвовать в расчете аудиторной нагрузки в периоде по разделу.

Если число часов, недель, кредитов, выделяемых на факультативы, не должно учитываться при расчете суммовых показателей плана, то для них в строке раздела или группы Факультативы можно задать нулевые или пустые значения.


Работа с адаптационными дисциплинами

Работа с адаптационными дисциплинами

Если в БУП или РУП включаются адаптационные дисциплины (т.е. дисциплины, изучаемые студентами, не имеющими на момент поступления достаточной подготовки по тем или иным предметам), то при работе с ними необходимо учитывать их особенности.

Адаптационной дисциплиной может быть как дополнительная дисциплина, не изучаемая основной массой студентов, так и дополнительная нагрузка по одной из существующих в БУП или РУП дисциплин (например, дополнительные часы по иностранному языку, экономической теории или математике). В любом случае адаптационная дисциплина должна добавляться в БУП и РУП как отдельная запись. При добавлении такой дисциплины в поле Вид дисциплины должно быть выбрано значение Адаптационный курс, в поле По выбору студентов должно быть установлено значение Да. Скорректировать значения данных свойств для адаптационных дисциплин можно в формах редактирования РУП и БУП при помощи действия Дополнительные свойства.

Дополнительные свойства для адаптационных дисциплин

Так как адаптационные дисциплины не являются обязательными для всех студентов, на них либо не выделяются кредиты, либо эти кредиты не участвуют в расчете текущего рейтинга. Поэтому для адаптационных дисциплин необходимо либо установить число кредитов, равное нулю, либо установить значение Да в колонке Только в кумулятивный рейтинг.

Нагрузка по адаптационным дисциплинам не должна учитываться при подсчете суммы часов, недель и кредитов и других показателей по разделу, в который они входят. Для того, чтобы расчет сумм по разделу был произведен корректно, рекомендуется выделить адаптационные дисциплины в отдельную группу дисциплин. Для этой группы для признака Рассчитывается как сумма элементов должно быть установлено значение Нет, а для свойств Трудоемкость в часах, Недели и Трудоемкость в зачетных единицах и других должны быть установлены пустые или нулевые значения. Такая установка свойств позволит корректно рассчитать суммы по разделу, в который входит группа адаптационных дисциплин.

Раздел адаптационных дисциплин


Курсовые работы

Курсовые работы

Курсовые работы могут присутствовать в различных разделах БУП и РУП. Если курсовые работы были занесены в стандарт, то они будут созданы и в БУП после его формирования на основе стандарта. При формировании РУП на основе БУП в нем будут созданы курсовые работы в случае если в БУП по курсовой работе были заданы часы или кредиты на данном курсе. Также курсовые работы можно создавать и непосредственно в БУП и РУП, используя действие Добавить ... / курсовую работу.

Если курсовая работа выполняется по одной дисциплине всеми студентами, то эту дисциплину необходимо выбрать в поле Дисциплина при добавлении курсовой работы. Если же курсовая работа является междисциплинарной, или если студенты могут выбирать дисциплину, по которой они будут выполнять работу, то поле Дисциплина надо оставить пустым. Заполнение поля Кафедра в РУП для курсовой работы необязательно. Оно должно заполняться только в том случае, если известно, что все студенты должны выполнить данную курсовую работу на данной кафедре.

Если создается курсовая работа по дисциплине, то ее Наименование будет сформировано автоматически. Если дисциплина не используется, то наименование курсовой работе может быть присвоено произвольно.

Значение числа кредитов для курсовых работ устанавливается независимо от значений числа часов и числа недель.

Раздел с курсовой работой

Если в БУП или РУП присутствует курсовая работа, то о ней должна быть обязательно создана запись типа Курсовая работа, даже если в плане существует одноименный раздел. Уточнить свойства записи о курсовой работе можно при помощи действия Дополнительные свойства

Дополнительные свойства для курсовой работы

Изменять тип записи при помощи этого действия нельзя. Если Вы ошиблись с типом записи, то нужно удалить существующую запись о курсовой работе и создать новую при помощи действия Добавить ... / курсовую работу.

В РУП для курсовой работы, так же как и для любой другой записи плана должно быть указано испытание рубежного контроля. Для того, чтобы в дипломе студентов по курсовой работе отображались оценки "отлично", "хорошо" и проч. видом рубежного контроля для курсовой работы должен быть "Экзамен". В противном случае в дипломе студента будут отображены результаты "зачтено" или "незачтено". Испытание должно быть запланировано в том модуле (семестре), в котором студенты должны сдать и защитить курсовую работу.

При расчете числа зачетов и экзаменов по модулям, отображаемого в печатной форме РУП, испытания по курсовым работам не учитываются.


Работа с практиками

Работа с практиками

Как в образовательном стандарте, так и в БУП и в РУП практики должны быть выделены в отдельный раздел (разделы). Если в стандарте значения трудоемкости задавались для раздела практик в целом, то в БУП и РУП обязательно нужно добавить записи о конкретных практиках того или иного вида. Добавление практики в БУП или РУП производится при помощи действия Добавить ... / практику.

При добавлении практики нужно обязательно задать Вид практики путем выбора из выпадающего списка. При выборе вида практики для нее будет автоматически предложено Наименование. Если в план необходимо добавить несколько практик одного вида, то наименование надо скорректировать таким образом, чтобы эти практики можно было отличить, например, "производственная практика 2 курс", "производственная практика 3 курс".

При помощи действия Дополнительные свойства можно уточнить параметры созданной записи о практике

Дополнительные свойства практик

При помощи данной формы можно уточнить вид практики. Тип записи обязательно должен быть установлен как Практика. Если тип записи установлен неверно, его нельзя изменить при помощи этой формы. В этом случае нужно удалить запись ошибочного типа и добавить новую при помощи действия Добавить ... / практику.

В БУП и РУП магистратуры наименования разделов могут включать в себя (и даже полностью повторять) наименование видов практики, например, "НИР.М.02 Научно-педагогическая практика" или "НИР.М.03 Научно-исследовательская практика". Несмотря на это, в такие разделы необходимо добавить записи о практиках соответствующего вида.

Значения числа недель и числа кредитов для практик устанавливаются независимо от числа часов.


Работа с разделом итоговой государственной аттестации

Работа с разделом итоговой государственной аттестации

Итоговая государственная аттестация в образовательных стандартах выделяется в отдельный раздел. В состав итоговой аттестации могут входить итоговые экзамены и выпускная квалификационная работа (ВКР). Если записи о конкретных итоговых экзаменах и ВКР были созданы в стандарте, то они будут созданы и в БУП при его формировании по стандарту. Также записи об отдельных видах итоговой аттестации, созданные в БУП будут перенесены в РУП при его формировании на основе БУП. Если же в стандарте или БУП записи о конкретных испытаниях итоговой аттестации созданы не были, то их необходимо добавить в раздел итоговой аттестации при помощи действий Добавить ... / итоговый гоэкзамен и Добавить ... / выпускную работу.

Итоговый госэкзамен может быть как по одной конкретной дисциплине, так и междисциплинарным. Если итоговый госэкзамен проводится по дисциплине, то эту дисциплину необходимо выбрать в поле Дисциплина. При этом в поле Наименование автоматически сформируется значение, повторяющее наименование дисциплины. Если же экзамен является междисциплинарным, то поле Дисциплина нужно оставить пустым, в наименование ввести с клавиатуры (например, "Междисциплинарный экзамен по направлению подготовки").

Для свойства Форма итогового контроля должно быть установлено значение Экзамен.

Значение числа кредитов для итогового госэкзамена устанавливаются независимо от значений числа часов и числа недель.

При добавлении выпускной квалификационной работы (ВКР) ее наименование можно задать произвольно (например, "Подготовка и защита выпускной квалификационной работы"). Для свойства Форма итогового контроля должно быть установлено значение Экзамен.

Значение числа недель и числа кредитов для ВКР устанавливаются независимо от значений числа часов и числа недель.

Раздел итоговой аттестации


Расчетные показатели учебных планов

Раздел целиком Одним файлом
Расчетные показатели учебных планов

В ходе работы над базовыми и рабочими учебными планами необходимо помнить о том, что в итоговом варианте документа должны быть соблюдены требования к ряду расчетных показателей, характеризующих план в целом. Ниже описаны принципы расчета применяемых показателей и пути достижения необходимых значений.

  • Суммы показателей по разделам и по плану в целом
  • Аудиторная нагрузка по периодам (РУП)
  • Число экзаменов и зачетов по периодам (РУП)
  • Недельная аудиторная нагрузка, число аудиторных часов в день (РУП)


Суммы показателей по разделам и по плану в целом

Суммы показателей по разделам и по плану в целом

Образовательный стандарт представляет собой иерархическую структуру разделов (компонентов, циклов) и входящих в них дисциплин. Стандарт должен быть сформирован таким образом, чтобы на первом уровне иерархии была единственная запись. Как правило, эта запись имеет наименование Вся образовательная программа. Аналогичную структуру имеют БУПы и РУПы, сформированные на основе стандартов.

Формы редактирования БУП и РУП содержат проверки, контролирующие равенство сумм показателей (числа часов, недель, кредитов и проч.) записей, входящих в раздел, и значений тех же показателей, заданных для раздела. В суммировании участвуют только записи, непосредственно подчиненные данному разделу. Это означает, что если в раздел входит несколько других разделов, в состав которых, в свою очередь, входят дисциплины и записи других видов, то в суммировании будут участвовать только значения заданные для разделов в целом, а значения записей более низких уровней анализироваться не будут.

Для некоторых разделов (разделов дисциплин по выбору, факультативов, а иногда и других) итоговые значения не должны рассчитываться как сумма входящих в раздел дисциплин, т.к. не все указанные дисциплины должны в обязательном порядке изучаться студентами. Для того, чтобы отличить один вид разделов от другого, предназначено свойство раздела Рассчитывается как сумма элементов. Для просмотра и изменения значения этого свойства предназначено действие Дополнительные свойства, которым можно воспользоваться в формах редактирования БУП и РУП, предварительно выбрав строку нужного раздела.

Если для раздела установлено значение признака таким образом, что показатели входящих в него записей не суммируются, то проверок соответствия сумм проводиться не будет. При этом важно задать для раздела в целом такие значения, которые дадут необходимую сумму для вышестоящих разделов и для плана в целом. Например, для разделов или групп дисциплин по выбору надо задать такие значения нагрузки, которые обязательно должны быть выполнены студентами. Для разделов факультативов и адаптационных дисциплин допустимо устанавливать итоговые значения по разделу нулевыми или пустыми.

Суммирование показателей по разделам

В данном примере для раздела Дисциплины по выбору признак Рассчитывается как сумма элементов установлен как Нет (наименование раздела отображается курсивным шрифтом). Для всех остальных разделов установлено значение Да. При этом для раздела дисциплин по выбору установлены самостоятельные значения числа часов, недель и кредитов. Для раздела Общие гуманитарные и социально-экономические дисциплины значения рассчитываются как сумма по трем разделам, непосредственно входящим в него: 2160 = 1836 + 108 + 216.

Такой принцип суммирования и контроля значений для разделов действует как для базовых, так и для рабочих учебных планов.


Аудиторная нагрузка по периодам (РУП)

Аудиторная нагрузка по периодам (РУП)

В рабочих учебных планах рассчитываются показатели аудиторной нагрузки по периодам. При этом в разделе возможно наличие дисциплин, аудиторная нагрузка по которым не входит в расчет недельной аудиторной нагрузки. Такими дисциплинами могут быть факультативы, физическая культура и некоторые другие дисциплины. Для таких дисциплин при помощи действия Дополнительные свойства необходимо установить признак Входит в расчет недельной нагрузки, равным Нет.

При суммировании значений аудиторной нагрузки в периоде по разделу в суммировании участвуют только те записи, нагрузка по которым входит в расчет недельной нагрузки. При этом допустимой считается ситуация, когда в строке раздела сумма аудиторных часов по всем периодам не будет равна значению, установленному в колонке "Аудиторные занятия".

Аудиторная нагрузка по периодам

В данном примере аудиторная нагрузка по дисциплине Физическая культура не входит в расчет недельной аудиторной нагрузки.


Число экзаменов и зачетов по периодам (РУП)

Число экзаменов и зачетов по периодам (РУП)

В рабочих учебных планах для записей разделов определяется число экзаменов и зачетов в каждом периоде обучения. Если показатели раздела рассчитываются как сумма по входящим в раздел элементам, то число экзаменов и зачетов по разделу будет контролироваться проверками системы. Если же показатели раздела не подлежат суммированию, то количество экзаменов и зачетов по разделу нужно установить вручную.

Испытания по курсовым работам не учитываются при подсчете числа зачетов и экзаменов в периоде.

Проверить и при необходимости изменить признак Рассчитывается как сумма элементов для раздела можно при помощи действия Дополнительные свойства.

Количество экзаменов и зачетов, получившееся в корневой строке "Вся образовательная программа будет считаться показателем плана в целом.

Аудиторная нагрузка по периодам

В данном примере видно, что в разделе "Другие виды подготовки" первом и третьем модулях нет ни экзаменов, ни зачетов, во втором модуле - 2 зачета, в четвертом модуле 1 экзамен и 2 зачета.


Недельная аудиторная нагрузка, число аудиторных часов в день (РУП)

Недельная аудиторная нагрузка, число аудиторных часов в день (РУП)

Недельная аудиторная нагрузка в каждом учебном периоде (модуле, семестре) в рабочем учебном плане определяется как число аудиторных часов в периоде, рассчитанное для корневой записи плана, деленное на число недель в периоде.

Количество недель в периоде отображается в отдельной строке внизу плана после перечня всех его записей. При формировании РУП число недель в каждом периоде устанавливается равным значению, заданному для периода в общевузовском справочнике . Однако в каждом РУП при необходимости это значение можно изменить.

Ниже строки с количеством недель в периоде следует строка Недельная аудиторная нагрузка. Значение в этой строке является расчетным и не подлежит редактированию. Оно рассчитывается как число аудиторных часов в периоде, стоящее в корневой строке плана ("Вся образовательная программа"), деленное на число недель, стоящее в предыдущей строке.

Если полученное значение недельной аудиторной нагрузки не отвечает установленным требованиям, то его можно скорректировать изменив число аудиторных часов по отдельным дисциплинам плана или изменив его распределение по периодам обучения. Эти изменения приведут в свою очередь к изменениям значений для разделов плана и для корневого раздела "Вся образовательная программа".

Недельная аудиторная нагрузка

Показатель Число аудиторных часов в день определяется как рассчитанное значение недельной аудиторной нагрузки, деленное на 6 дней. Левее колонок, показывающих средние значения показателей по периодам расположена колонка, отображающая средние значения, рассчитанные для всех периодов.


Ход согласования учебных планов

Раздел целиком Одним файлом
Ход согласования учебных планов

Базовые, рабочие и объединенные учебные планы могут участвовать в процедурах согласования и утверждения. Переход плана с одного этапа согласования на другой заключается в смене статуса плана, а также в изменении режима доступа пользователей к данным плана.

Процессы согласования объединенных и базовых (рабочих) учебных планов отличаются, графически их можно представить следующим образом:

  1. Процесс согласования базовых и рабочих учебных планов:

    Ход согласования учебных планов

  2. Процесс согласования объединенных учебных планов:

    Согласование объединенного учебного плана

  3. Процесс согласования объединенных учебных планов аспирантуры:

    Схема согласования ОУП аспирантуры

  • Мониторинг готовности учебных планов факультетов и отделений
  • Работа Ректора
  • Работа пользователя-разработчика плана
  • Работа разработчика ОУП аспирантуры
  • Работа разработчика учебного плана лицея
  • Работа декана факультета
  • Работа декана "ведущего" факультета
  • Работа директора аспирантской школы
  • Работа управления аспирантуры и докторантуры
  • Работа Заместителя директора филиала
  • Работа пользователей методического управления
  • Работа Директора по ДПО
  • Работа проректора, согласующего планы
  • Работа проректора, утверждающего ОУП аспирантуры
  • Работа первого проректора согласующего / утверждающего планы


Мониторинг готовности учебных планов факультетов и отделений

Мониторинг готовности учебных планов факультетов и отделений

В форме Ход согласования учебных планов в таблицах данных Базовые учебные планы и Рабочие учебные планы представлены планы, доступные для просмотра пользователю. Пользователи-разработчики планов от отдельного факультета или отделения могут просматривать только планы своего факультета (отделения). Пользователи, принадлежащие к ролям методического управления, проректора и первого проректора могут просматривать планы всех факультетов и отделений.

За счет возможностей таблиц данных можно просматривать статусы планов по факультетам и отделениям, направлениям и специальностям, магистерским программам, учебным годам, курсам и т.д.

Мониторинг состояния БУП


Работа Ректора

Работа Ректора

Работа ректора, утверждающего учебные планы, состоит в следующем:

Согласование планов
Для согласования доступны планы, переведенные первым проректором в статус на утверждении ректором. С планами, находящимися в этом статусе, первый проректор может выполнять следующие действия:

  • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
  • Если по итогам работы с планом ректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в МУ.
  • Если у ректора нет критических замечаний к плану, он должен выполнить действие Утвердить.
  • Отслеживание статусов планов
    Первому проректору доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.


Работа пользователя-разработчика плана

Работа пользователя-разработчика плана

Работа пользователя, разрабатывающего учебный план, состоит из следующих этапов:

  1. Создание проекта плана
    При создании базового, рабочего учебного плана или объединенного учебного плана, план получает статус проект. В процессе создания базового учебного плана для факультетов филиалов, требуется указать "ведущий" факультет ВУЗа, с которым необходимо согласовать план, что описано в разделе Создание нового базового учебного плана. После создания, план наполняется на основании источника (стандарта или базового плана) и дополняется всей необходимой информацией, что описано в разделах Редактирование базового учебного плана, Редактирование рабочего учебного плана, Редактирование объединенного учебного плана. После того, как разработчик завершил первичное формирование плана, он должен выполнить действие Направить на согласование с деканом факультета.
  2. Согласование с деканом факультета
    На данном этапе разработчик плана не может корректировать план, но может просматривать замечания, сформулированные деканом факультета. Если декан факультета примет решение о возврате плана на доработку, то план перейдет в статус корректировка разработчиком и разработчик снова сможет корректировать план. Если же декан факультета примет решение о согласовании плана и направлении его на дальнейшее согласование, то от разработчика дальнейших действий не потребуется, они сможет только следить за дальнейшим изменением статусов плана.
  3. Корректировка разработчиком
    На этом этапе разработчик может вносить в план любые изменения на основе замечаний, полученных от декана факултета. По завершении работы разработчик снова должен выполнить действие Направить на согласование с деканом факультета.
  4. Отслеживание статуса плана
    После того, как план согласован с деканом факультета, активная работа разработчика заканчивается. План будет переводиться из одного статуса в другой другими пользователями. Разработчик сможет получать сообщения об изменении статуса планов, а также просматривать состояние статусов всех планов в таблице данных Базовые учебные планы или Рабочие учебные планы.


Работа разработчика ОУП аспирантуры

Работа разработчика ОУП аспирантуры

Работа пользователя, разрабатывающего ОУП аспирантуры, состоит из следующих этапов:

  1. Создание проекта плана
    При создании объединенного учебного плана, план получает статус проект. После создания, план наполняется на основании источника (стандарта) и дополняется всей необходимой информацией, что описано в разделе Редактирование объединенного учебного плана аспирантуры. После того, как разработчик завершил первичное формирование плана, он должен выполнить действие Направить на согласование с Директором аспирантской школы.
  2. Согласование с Директором аспирантской школы
    На данном этапе разработчик плана не может корректировать план, но может просматривать замечания, сформулированные директором аспирантской школы. Если директор аспирантской школы примет решение о возврате плана на доработку, то план перейдет в статус корректировка разработчиком и разработчик снова сможет корректировать план. Если же директор аспирантской школы примет решение о согласовании плана и направлении его на дальнейшее согласование, то от разработчика дальнейших действий не потребуется, они сможет только следить за дальнейшим изменением статусов плана.
  3. Корректировка разработчиком
    На этом этапе разработчик может вносить в план любые изменения на основе замечаний, полученных от директора аспирантской школы. По завершении работы разработчик снова должен выполнить действие Направить на согласованиес Директором аспирантской школы.
  4. Отслеживание статуса плана
    После того, как план согласован с директором аспирантской школы, план будет переводиться из одного статуса в другой другими пользователями, при этом на любом из этапов план может быть передан разработчику на корректировку. Разработчик сможет получать сообщения об изменении статуса планов, а также просматривать состояние статусов всех планов в представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры).


Работа разработчика учебного плана лицея

Работа разработчика учебного плана лицея

Работа пользователя, разрабатывающего учебные планы лицея, состоит из следующих этапов:

  1. Создание проекта плана
    При создании плана, план получает статус проект. После того, как разработчик завершил первичное формирование плана, он должен выполнить действие Направить на согласование с УРОП.
  2. Согласование с пользователями методического управления
    На данном этапе разработчик плана не может корректировать план, но может просматривать замечания, сформулированные пользователями методического управления. Если методическое управление примет решение о возврате плана на доработку, то план перейдет в статус корректировка разработчиком и разработчик снова сможет корректировать план. Если же методическое управление примет решение о согласовании плана и направлении его на дальнейшее согласование, то от разработчика дальнейших действий не потребуется, он сможет только следить за дальнейшим изменением статусов плана.
  3. Корректировка разработчиком
    На этом этапе разработчик может вносить в план любые изменения на основе замечаний, полученных от пользователей, согласующих план. По завершении работы разработчик снова должен выполнить действие Направить на согласованиес УРОП.
  4. Отслеживание статуса плана
    После того, как план согласован с УРОП, план будет переводиться из одного статуса в другой другими пользователями. Разработчик сможет получать сообщения об изменении статуса планов, а также просматривать состояние статусов всех планов в представлении Учебные планы лицея (форма Учебные планы лицея).


Работа декана факультета

Работа декана факультета

Работа декана факультета, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные разработчиками в статус согласование с деканом факультета. С планами, находящимися в этом статусе декан факультета может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом деканом факультета принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени декана факультета. При этом, при появлении необходимости редактирования плана после этого, декан факультета может воспользоваться действием Отозвать согласование деканом факультета, после чего он сможет осуществлять редактирование плана.
    • После того, как декан факультета согласовал план, он должен выполнить действие Направить на утверждение. При этом, если декан факультета является деканом факультета филиала и требуется согласование с "ведущим" факульетом, он пользуется действием Направить на согласование с ведущим факультетом . Если же, он является деканом "ведущего" факультета ВУЗа, то он должен воспользоваться действием Направить на согласование с МУ (Методическим управлением). В отношении учебных планов, для которых установлен признак Является программой ДПО, необходимо воспользоваться действием Направить на согласование с МУ.
      Следует учитывать, что параметру Является программой ДПО будет присвоено значение Да только для БУП, разработанных пользователями-разработчиками подразделений ДПО. Для всех остальных подразделений будет установлено значение Нет.
  2. Отслеживание статусов планов
    Декану факультета доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.


Работа декана "ведущего" факультета

Работа декана "ведущего" факультета

Работа декана ведущего факультета, согласующего учебные планы, состоит в следующем:

Согласование планов
Для согласования доступны планы, переведенные деканами факультетов филиалов в статус согласование с ведущим факультетом. Также доступны планы собственного факультета, переведенными разработчиками в статус согласование с деканом факультета. С планами, находящимися в этих статусах декан ведущего факультета может выполнять следующие действия:

  • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
  • Если по итогам работы с планом деканом ведущего факультета принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику или вернуть на доработку (деканам факультетов филиала).
  • Если у декана ведущего факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от ведущего факультета. При этом, при появлении необходимости редактирования плана после этого, декан факультета может воспользоваться действием Отозвать согласование ведущим факультетом, после чего он сможет осуществлять редактирование плана.
  • После того, как декан ведущего факультета согласовал план факультета филиала, он должен выполнить действие Направить на согласование с зам. директора филиала. После согласования плана собственного факультета, он направляется на согласование с МУ. При этом, декан факультета пользуется действием Направить на согласование с МУ (Методическим Управлением).
  • Отслеживание статусов планов
    Декану ведущего факультета доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.


Работа директора аспирантской школы

Работа директора аспирантской школы

Работа директора аспирантской школы, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные разработчиками в статус на согласовании с Директором аспирантской школы. С планами, находящимися в этом статусе директор аспирантской школы может выполнять следующие действия (все действия с учебными планами выполняются в форме На согласовании с Директором аспирантской школы):
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом директором аспирантской школы принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у директора аспирантской школы нет критических замечаний к плану, он должен выполнить действие Согласовать план. При этом, при появлении необходимости редактирования плана, директор аспирантской школы может воспользоваться действием Отозвать согласование, после чего он сможет осуществлять редактирование плана.
    • После того, как директор аспирантской школы согласовал план, он должен выполнить действие Направить на согласование УАД.


Работа управления аспирантуры и докторантуры

Работа управления аспирантуры и докторантуры

Работа пользователей, состоит из следующих этапов:

  1. Отслеживание статусов планов
    Пользователям Управления аспирантуры и докторантуры доступны для просмотра объединенные учебные планы аспирантуры всех аспирантских школ, находящиеся во всех статусах. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) пользователи УАД могут видеть картину готовности планов по аспирантским школам, учебным годам и проч.
  2. Согласование планов
    С планами, находящимся в статусе Направить на согласование с УАД пользователи УАД могут выполнять следующие операции:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом пользователем УАД принято решение вернуть план разработчику, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у пользователя УАД нет критических замечаний к плану, он должен выполнить действие Согласовать план.
    • После того, как пользователь УАД согласовал план, он должен выполнить действие Направить на согласование с зам. директора филиала для планов аспирантов филиала, и Направить на утверждение проректором для всех остальных планов аспирантуры.


Работа Заместителя директора филиала

Раздел целиком Одним файлом
Работа Заместителя директора филиала

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.
  • Согласование БУП и РУП
  • Согласование ОУП аспирантуры
  • Согласование ОУП


Согласование БУП и РУП

Согласование БУП и РУП

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.


Согласование ОУП аспирантуры

Согласование ОУП аспирантуры

Работа заместителя директора филиала, согласующего объединенные учебные планы аспирантуры, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы в представлении Объединенные учебные планы аспирантуры, в данном представлении отображаются планы, переведенные директорами аспирантских школ в статус на согласовании с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у зам.директора филиала нет критических замечаний к плану, он должен выполнить действие Согласовать план. При этом, при появлении необходимости редактирования плана, заместитель директора филиала может воспользоваться действием Отозвать согласование, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на утверждение проректором.


Согласование ОУП

Согласование ОУП

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у зам.директора филиала нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Объединенные учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.


Работа пользователей методического управления

Работа пользователей методического управления

Работа пользователей Методического управления, состоит из следующих этапов:

  1. Отслеживание статусов планов
    Пользователям Методического управления доступны для просмотра объединенные, базовые и рабочие учебные планы и майноры, объединенные планы факультетских дисциплин, базовые и рабочие планы аспирантуры, учебные планы лицея, находящиеся во всех статусах. В соответствующих представлениях формы На согласовании с УРОП пользователи УРОП могут видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.
  2. Согласование планов от имени УРОП
    С планами, находящимися в статусе на согласовании с УРОП пользователи Методического управления могут выполнять следующие операции:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания, как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом пользователем МУ принято решение вернуть план разработчику, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у пользователя МУ нет критических замечаний к плану, он должен выполнить действие Согласовать от имени УРОП.
    • После того, как пользователь УРОП согласовал план, он должен выполнить действие Направить на согласование с Директором по ДПО для планов ДПО, и Направить на согласование с проректором для всех остальных планов.
  3. Согласование с проректором и Директором по ДПО
    На данном этапе пользователь УРОП не может вносить замечания в план. Он может только просматривать замечания и комментарии, сделанные проректором и директором по ДПО. Если проректором будет принято решение вернуть план на доработку в УРОП, то план перейдет в статус на согласовании с УРОП, и пользователи УРОП снова смогут работать с планом.
  4. Утверждение плана
    На данном этапе пользователь УРОП не может вносить замечания в план. Он может только просматривать замечания и комментарии, сделанные проректором или Директором по ДПО. Если проректором или Директором по ДПО будет принято решение вернуть план на доработку в УРОП, то план перейдет в статус на согласовании с УРОП, и пользователи УРОП снова смогут работать с планом. Если план будет утвержден, то для всех пользователей он будет доступен только для просмотра.


Работа Директора по ДПО

Работа Директора по ДПО

Работа Директора по ДПО, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные пользователями МУ в статус согласование с Директором по ДПО. С планами, находящимися в этом статусе Директор по ДПО может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом Директором по ДПО принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в МУ.
    • Если у Директора по ДПО нет критических замечаний к плану, он должен выполнить действие Согласовать от имени Директора по ДПО. При этом, при появлении необходимости редактирования плана после этого, Директор по ДПО филиала может воспользоваться действием Отозвать согласование Директора по ДПО, после чего он сможет осуществлять редактирование плана.
    • После того, как Директор по ДПО согласовал план, он должен выполнить действие Направить на согласование с проректором.
  2. Отслеживание статусов планов
    Директору по ДПО доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.


Работа проректора, согласующего планы

Работа проректора, согласующего планы

Работа проректора, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные пользователями УРОП, а также директором по ДПО в статус согласование с проректором. С планами, находящимися в этом статусе проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания, как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в УРОП.
    • Если у проректора нет критических замечаний к плану, он должен выполнить действие Согласовать от имени проректора. При появлении необходимости редактирования плана после этого, проректор может воспользоваться действием Отозвать согласование проектором, после чего он сможет осуществлять редактирование плана.
    • После того, как проректор согласовал план, он должен выполнить действие Направить на согласование с первым проректором для базовых учебных планов студентов и аспирантов и Направить на утверждение для остальных планов.
  2. Отслеживание статусов планов
    Проректору доступны для просмотра объединенные, базовые, рабочие учебные планы и майноры студентов, объединенные планы факультетских дисциплин, базовые и учебные планы аспирантуры, учебные планы лицея, находящиеся во всех статусах. В соответствующих представлениях формы На согласовании / утверждении проректором можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.


Работа проректора, утверждающего ОУП аспирантуры

Работа проректора, утверждающего ОУП аспирантуры

Работа проректора, утверждающего объединенные учебные планы аспирантуры, состоит в следующем:

  1. Утверждение планов
    Для утверждения доступны планы, переведенные пользователями УАД или заместителем директора филиала в статус на утверждении с проректором. С планами, находящимися в этом статусе проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у проректора нет критических замечаний к плану, он должен выполнить действие Утвердить план. При этом, при появлении необходимости редактирования плана, проректор может воспользоваться действием Отозвать утверждение, после чего он сможет осуществлять редактирование плана.
  2. Отслеживание статусов планов
    Проректору доступны для просмотра ОУП аспирантуры всех аспирантских школ, находящиеся во всех статусах. В представлении Объединенные учебные планы аспирантуры можно видеть картину готовности планов по аспирантским школам, учебным годам и проч.


Работа первого проректора согласующего / утверждающего планы

Работа первого проректора согласующего / утверждающего планы

Работа первого проректора, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные проректором в статус на согласовании с первым проректором. С планами, находящимися в этом статусе, первый проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания, как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом первым проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в УРОП.
    • Если у первого проректора нет критических замечаний к плану, он должен выполнить действие Согласовать. При появлении необходимости редактирования плана после этого, первый проректор может воспользоваться действием Отозвать согласование первым проректором, после чего он сможет осуществлять редактирование плана.
    • После того, как первый проректор согласовал план, он должен выполнить действие Направить на утверждение ректором.
    • В отношении Объединенных учебных планов, Объединенных планов факультетских дисциплин и Объединенных майноров, при отсутствии критических замечаний, первый проректор должен выполнить действие Утвердить план.
  2. Утверждение планов
    Для утверждения доступны планы, переведенные проректором в статус на утверждении первым проректором. С планами, находящимися в этом статусе, первый проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом первым проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в УРОП.
    • Если у первого проректора нет критических замечаний к плану, он должен выполнить действие Утвердить план.


Оценка затратности реализации учебных планов

Раздел целиком Одним файлом
Оценка затратности реализации учебных планов

Оценкa зaтрaтности рeaлизaции учeбных плaнов зaключaeтся в оцeнке отношения количества студентов, которые будут обучаться по данному учебному плану к объeму нaгрузки прeподaвaтeлeй, трeбуeмому для рeaлизaции этого учeбного плана, выраженному в числе условных ставок преподавателей. Данное отношение называется Коэффициентом затратности плана. Чем коэффициент затратности выше, тем ниже затратность плана, и чем коэффиент ниже, тем выше затратность.

Оцeнкa зaтрaтности рeaлизaции плaнов рeaлиовaнa в систeмe в двух вaриaнтaх: для Paбочих учeбных плaнов и для Объeдинeнных учeбных плaнов. Для Объeдинeнных учeбных плaнов оцeнкa зaтрaтности производится отдльно для кaждого учeбного годa рeaлизaции. Принцип оцeнки зaтрaтности одинaков для рaзных видов плaнов и зaключaeтся в слeдующeм:

  1. Для кaждой дисциплины и НИС выполняeтся оцeнкa количeствa чaсов нaгрузки для рeaлизaции отдeльных видов нaгрузки (лeкций, сeминaров, прaктичeских, провeдeния экзaмeнов и зaчeтов, провeрки испытaний тeкущeго контроля)
  2. Для прочих видов зaписeй плaнa (курсовых рaбот, прaкик, итоговых госэкзaмeнов, ВКP) выполняeтся оцeнкa нaгрузки для типовых случaeв (курсовыe и ВКP нe нa инострaнном языкe, групповой вид прaктики, итоговыe экзaмeны в устной формe и т.п.)
  3. Количeтво чaсов нaгрузки по всeм зaписям плaнa суммируeтся и дeлится нa знaчeниe нaстройки "Нормaтив нaгрузки условного прeподaвaтeля" (нaпримeр, 700 чaсов). Тaким обрaзом вычисляeтся число условных стaвок прeподaвaтeлeй, трeбуeмых для рeaлизaции плaнa.
  4. Опрeдeляeтся отношeниe числa студeнтов, укaзaнного для плaнa в цeлом (в случae PУП) или для одного годa рeaлизaции Объeдинeнного плaнa, к числу условных стaвок прeподaвaтeлeй. Тaким обрaзом получaeтс знaчeниe Коэффициeнтa зaтрaтности плaнa.
  5. Получeнноe знaчeниe Коэффициeнтa зaтрaтности срaвнивaeтся с нормaтивными знaчeниями, хрaнящмися в спрaвочникe "Нормaтивныe коэффициeнты зaтрaтности плaнa", дeлaeтся вывод о повышeнной зaтрaтности плaнa или о зaтрaтности в рaмкaх стaндaртной.

Оценка затратности реализована в системе в виде интерактивного Excel-отчета, показывающего составляющие, на основе которых была произведена оценка и позволяющего сохранять полученное значение коэффициента затратности в базе данных.

  • Формирование справочников и установка настроек, необходимых для расчета
  • Оценка затратности Рабочего учебного плана
  • Оценка затратности Объедиенного плана
  • Формирование Перечня учебных планов с коэффициентами затратности
  • Отчеты о фактической затратности


Формирование справочников и установка настроек, необходимых для расчета

Формирование справочников и установка настроек, необходимых для расчета

До того, как появится возможность оценить затратность отдельных учебных планов, следующие данных должны быть заполнены централизовано пользователем, имеющим права на работу со справочниками по планированию нагрузки преподавателей.

  1. Должно быть установлено значение настройки "Норматив нагрузки условного преподавателя". Значение выражено в числе часов нагрузки, составляющем одну условную ставку преподавателя (например, 700).
  2. Должны быть сформированы три записи справочника "Нормативные коэффициенты затратности плана" для уровней образования "Бакалавриат","Специалитет" и "Магистратура". Для каждого уровня должно быть занесено стандартное (минимально допустимое нормой) значение коэффициента затратности. Данный справочник расположен в разделе "Справочники на планированию нагрузки" на одноименной вкладке верхнего уровня.
  3. Справочник "Виды учебной работы преподавателей" должен быть полностью сформирован на тот учебный год, планы которого планируется оценивать. Среди видов работ, связанных с курсовыми работами, практиками, итоговыми госэкзаменами, ВКР при помощи простановки признака "Используется для оценки плана" должны быть выделены те виды работ, которые являются типовыми (не зависят от выбора студентами) и которые должны использоваться для оценки затратности плана. Простановка этого признака для дисциплин и НИС не требуется.


Оценка затратности Рабочего учебного плана

Оценка затратности Рабочего учебного плана

Оценка затратности РУП может выполняться тогда, когда план уже практически полностью сформирован (создан перечень дисциплин, распределена нагрузка по видам работы, занесено число испытаний текущего контроля, созданы зачеты и экзамены). Для получения оценки затратности РУП нужно проделать следующее:

  1. Уточнить (или задать) число студентов, установленное для плана в целом в таблице "Рабочие учебные планы" в колонке "Количество студентов".
  2. В подчиненной таблице "Записи рабочего учебного плана" необходимо проставить значения в колонках "Количество студентов", "Количество подгрупп", "Количество групп", "Количество потоков" для всех записей плана кроме разделов и зачетно-экзаменационных недель. Достаточно задать только те значения, от которых зависит расчет нагрузки для данной записи плана. Например, если по дисциплине или НИС нет лекций, значение "Количество потоков" можно не задавать. Заносимые значения должны учитывать в себе понижающие коэффициенты для случаев, когда известно, что студенты, обучающиеся по данному плану, будут изучать дисциплину в одном потоке с другими студентами. Например, если одну из дисциплин по выбору студенты будут изучать совместно со студентами, обучающимися по другим планам, то Количество потоков нужно сократить до доли, которую займут студенты данного плана (например, 0,33). Также можно уменьшать, в том числе до дробных значений, количество групп и подгрупп. Количество студентов должно быть задано таким, как оно оценивается для данной конкретной дисциплины.
  3. При помощи действия контекстного меню Оценка затратности плана выгрузить Excel-отчет, показывающий оценку величины нагрузки по каждой записи плана, по плану в целом, число условных ставок преподавателей, требуемых для реализации плана, а также полученную величину Коэффициента затратности плана и ее оценку ("план избыточно затратен" или "затратность плана в пределах стандарта").
  4. В случае получения нулевых или некорректных значений объема нагрузки нужно уточнить значение числа студентов, групп, подгрупп, потоков по плану в целом или для отдельных дисциплин. Если наблюдается некорректность расчета, нужно обратиться к пользователям, ответственным за работу со справочниками по планированию нагрузки. Если план избыточно затратен, для снижения затратности можно уменьшить число форм текущего контроля, экзаменов, использовать больше дисциплин, читаемых совместно со студентами других учебных планов или больше "внешних" дисциплин (например, MOOC’s). После внесения изменений в показатели плана отчет нужно выгрузить заново.
  5. Если полученное значение коэффициента затратности является корректным, нужно нажать на кнопку "Сохранить значение коэффициента", расположенную в "шапке" плана. Полученное значение коэффициента будет сохранено в таблице данных "Рабочие учебные планы" в одноименной колонке.


Оценка затратности Объедиенного плана

Оценка затратности Объедиенного плана

Оценка затратности Объединенного плана выполняется применительно к одному учебному году и может выполняться тогда, когда план уже практически полностью сформирован на данный учебный год (создан перечень дисциплин, распределена нагрузка по видам работы, занесено число испытаний текущего контроля, созданы зачеты и экзамены). Для получения оценки затратности Объединенного плана нужно проделать следующее:

  1. Задать число студентов для плана в целом применительно к учебному году, для которого выполняется оценка затратности, в подчиненной таблице "Реализация плана по годам".
  2. "Количество студентов", "Количество подгрупп", "Количество групп", "Количество потоков" для каждой из записей плана также оценивается применительно каждому учебному году. Установить эти значения нужно в подчиненной таблице "Все записи плана по годам" для нужного учебного года в одноименных колонках таблицы. Значения должны быть установлены для всех записей плана кроме разделов и зачетно-экзаменационных недель. Достаточно задать только те значения, от которых зависит расчет нагрузки для данной записи плана. Например, если по дисциплине или НИС нет лекций, значение "Количество потоков" можно не задавать. Заносимые значения должны учитывать в себе понижающие коэффициенты для случаев, когда известно, что студенты, обучающиеся по данному плану, будут изучать дисциплину в одном потоке с другими студентами. Например, если одну из дисциплин по выбору студенты будут изучать совместно со студентами, обучающимися по другим планам, то Количество потоков нужно сократить до доли, которую займут студенты данного плана (например, 0,33). Также можно уменьшать, в том числе до дробных значений, количество групп и подгрупп. Количество студентов должно быть задано таким, как оно оценивается для данной конкретной дисциплины.
  3. Выгрузить Excel-отчет при помощи действия контекстного меню Оценка затратности плана. Отчет требует указать учебный год, для которого он формируется. Отчет показывает оценку величины нагрузки по каждой записи плана, по плану в целом, число условных ставок преподавателей, требуемых для реализации плана, а также полученную величину Коэффициента затратности плана и ее оценку ("план избыточно затратен" или "затратность плана в пределах стандарта").
  4. В случае получения нулевых или некорректных значений объема нагрузки нужно уточнить значение числа студентов, групп, подгрупп, потоков по плану в целом или для отдельных дисциплин. Если наблюдается некорректность расчета, нужно обратиться к пользователям, ответственным за работу со справочниками по планированию нагрузки. Если план избыточно затратен, для снижения затратности можно уменьшить число форм текущего контроля, экзаменов, использовать больше дисциплин, читаемых совместно со студентами других учебных планов или больше "внешних" дисциплин (например, MOOC’s). После внесения изменений в показатели плана отчет нужно выгрузить заново.
  5. Если полученное значение коэффициента затратности является корректным, нужно нажать на кнопку "Сохранить значение коэффициента", расположенную в "шапке" плана. Полученное значение коэффициента будет сохранено в таблице данных "Реализация плана по годам" в одноименной колонке применительно к указанному при формировании отчета учебному году.


Формирование Перечня учебных планов с коэффициентами затратности

Формирование Перечня учебных планов с коэффициентами затратности

Отчет, выгружающий в MS Excel перечень всех Рабочих учебных планов одного учебного года (включая РУП, полученные по данным Объединенных планов) можно сформировать при помощи действия "Перечень утвержденных РУП", доступного с консоли управления в разделе Разработка учебных планов / Аналитические отчеты по РУП.

Перечень утвержденных РУП

При формировании отчета необходимо задать значение "Да" для параметра Выгружать коэффициенты затратности. В этом случае таблица сформируется со столбцом, содержащим коэффициенты затратности планов. В итоговых строках будут отражены средние значения коэффициента затратности по филиалу, факультету, уровню образования.


Отчеты о фактической затратности

Раздел целиком Одним файлом
Отчеты о фактической затратности

Для оценки фактической затратности реализации образовательных программ представлены следующие отчеты:

  • Оценка фактической затратности ОП
  • Сводный отчет по затратности ОП в учебном году
  • Сводный отчет по затратности ОП по годам
  • Оценка фактической затратности ОП
  • Сводный отчет по затратности ОП в учебном году
  • Сводный отчет по затратности ОП по годам


Оценка фактической затратности ОП

Оценка фактической затратности ОП

Для формирования отчета Оценка фактической затратности ОП необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) выбрать учебный план.
  2. Из контекстного меню вызвать действие Оценка фактической затратности ОП.
    Вызов действия Оценка фактической затратности ОП
  3. В форме параметров необходимо указать Учебный год реализации образовательной программы, при этом Курс будет установлен автоматически. Для того чтобы отчет формировался подробно по каждому преподавателю, необходимо установить признак С конкретизацией по преподавателям.
    Форма параметров Оценка фактической затратности ОП

В результате сформируется отчет в виде Excel файла с оценкой фактической затратности реализации для одной выбранной образовательной программы, одного учебного года и одного курса.

Фактические значения рассчитываться следующим образом:

- Для дисциплины, НИС количество студентов данной ОП, которым назначена дисциплина или НИС для изучения на данном курсе.

- Для курсовой работы количество испытаний студентов данной ОП на данном курсе по курсовой работе с установленным признаком "В диплом" и непустым полем "Руководитель".

- Для практики количество испытаний студентов данной ОП на данном курсе по практике с установленным признаком "В диплом" и непустым полем "Руководитель практики".

- Для итогового экзамена количество студентов данной ОП, которым назначен итоговый экзамен для изучения на данном курсе.

- Для ВКР количество испытаний студентов данной ОП на данном курсе по ВКР с установленным признаком "В диплом" и непустым полем "Руководитель".

- Для проекта студентов количество испытаний студентов данной ОП на данном курсе по проекту с установленным признаком "В диплом" и непустым полем "Руководитель проекта - сотрудник вуза".

Доля студентов данной программы на данном курсе в предметной единице определяется как отношение количества студентов данной программы на данном курсе к общему количеству студентов в предметной единице. Количеством предметных единиц для строки отчета должна быть сумма долей по всем предметным единицам, подчиненным записи плана.

Количество студентов для расчета нагрузки за прием экзамена или зачета по дисциплинам, НИС и практикам определяется по ведомостям.

Количество потоков (при приеме письменных экзаменов) для дисциплин, НИС и практик рассчитывается как сумма долей студентов ОП определенного курса для каждого связанного приметного потока.

Количество групп (для консультаций при семестровой организации) для дисциплин НИС и практик рассчитывается как сумма долей студентов ОП для каждой связанной приметной группы.

Количество экзаменов для ВКР и итоговых экзаменов определяется как количество испытаний студентов данной ОП данного курса с признаком "в диплом", с непустым значением Руководитель работы (для ВКР), включенных в Локальные ГЭК.

Если при формировании отчета был установлен признак "С конкретизацией по преподавателям", то в отчет выгрузятся только те преподаватели, которым в плане нагрузки была назначена какая-либо нагрузка по записи учебного плана. При этом для видов работ, для которых невозможно определить однозначную связь преподаватель-студент, рассчитывается доля вклада преподавателя в выполнение нагрузки как отношение объема нагрузки определенного вида по записи плана, запланированной для данного преподавателя к объему нагрузки этого же вида, запланированной для всех преподавателей. Для отдельных видов работ фактическая нагрузка преподавателей считается по фактическому количеству связанных с ним студентов.


Сводный отчет по затратности ОП в учебном году

Сводный отчет по затратности ОП в учебном году

Для формирования отчета Сводный отчет по затратности ОП в учебном году необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) из контекстного меню вызвать действие Сводный отчет по затратности ОП в учебном году.
    Вызов действия Сводный отчет по затратности ОП в учебном году
  2. В форме параметров необходимо указать Учебный год, за который будет формироваться отчет. При необходимости можно конкретизировать перечень образовательных программ и курсов с помощью параметров Филиал, Факультет, Уровень образования, Форма обучения, Образовательная программа и Курс факультета.
    Если в форме параметров указан только параметр Учебный год, то отчет будет формироваться по всем образовательным программам и курсам ВУЗа, реализуемым в данном учебном году.
    Для выбора Образовательных программ и Курсов факультета, необходимо щелкнуть левой клавишей мыши на кнопку открытия справочника Справочник, в открывшихся справочниках или с помощью чек-бокса Чек-бокс выбрать одну или несколько записей и нажать кнопку ОК.

    Форма параметров Сводный отчет по затратности ОП в учебном году

В результате сформируется отчет в виде Excel файла со сводным отчетом по затратности в указанном учебном году для выбранных образовательных программ и курсов.


Сводный отчет по затратности ОП по годам

Сводный отчет по затратности ОП по годам

Для формирования отчета Сводный отчет по затратности ОП по годам необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) из контекстного меню вызвать действие Сводный отчет по затратности ОП по годам.
    Вызов действия Сводный отчет по затратности ОП по годам
  2. В форме параметров необходимо указать Учебный год начала обучения. При необходимости можно конкретизировать перечень образовательных программ и курсов с помощью параметров Филиал, Факультет, Уровень образования, Форма обучения, Образовательная программа и Курс факультета.
    Если в форме параметров указан только параметр Учебный год, то отчет будет формироваться по всем образовательным программам и курсам ВУЗа, реализуемым в данном учебном году.
    Для выбора Образовательных программ и Курсов факультета, необходимо щелкнуть левой клавишей мыши на кнопку открытия справочника Справочник, в открывшихся справочниках или с помощью чек-бокса Чек-бокс выбрать одну или несколько записей и нажать кнопку ОК.

    Форма параметров Сводный отчет по затратности ОП по годам

В результате сформируется отчет в виде Excel файла со сводным отчетом по затратности выбранных образовательных программ и курсов в учебных годах, начиная с указанного Учебного года начала обучения и до крайнего учебного года реализации образовательных программ.


Каталог дисциплин

Каталог дисциплин

Справочник "Каталог дисциплин"

Справочник содержит записи о дисциплинах, каждая из которых характеризуется определенным содержанием и объемом, который в свою очередь задается числом кредитов.

Поля:

  • Статус дисциплины - признак утверждения дисциплины Методическим управлением. Возможные варианты для статуса: проект и утверждено. При этом только утвержденные дисциплины могут быть доступны разработчикам учебных планов. Изменение статуса дисциплины доступно только пользователям Методического управления.
  • Код дисциплины - автоматически вычисляемое поле на основании данных подчиненной таблицы.
  • Дисциплина ВУЗа - наименование дисциплины ВУЗа из справочника Все дисциплины ВУЗа.
  • Число кредитов - числовое значение, весовая характеристика объема дисциплины.
  • Наименование на английском языке - наименование дисциплины на английском языке.
  • Порядковый номер - числовое значение. Позволяет располагать дисциплины в заданном пользователем порядке.

Для добавления новой дисциплины в католог необходимо воспользоваться соответствующим пунктом контекстного меню.

Откроется окно создания новой дисциплины:

Добавить дисциплину в каталог

- Дисциплина ВУЗа - наименование дисциплины ВУЗа из справочника Все дисциплины ВУЗа.

- Полное наименование дисциплины - заполняется автоматически из справочника Все дисциплины ВУЗа.

- Наименование на английском языке - наименование дисциплины на английском языке.

- Число кредитов - задается числовое значение кредитов для данной дисциплины.

Далее в правой части формы осуществляется выбор направлений (специальностей), для которых преподается данная дисциплина в соответствующих группах полей (по уровням образования).

Выбор осуществляется из справочников Направления и специальности (для уровней Бакалавриат, Специалитет и Магистратура), Отрасли науки и научные специальности (для аспирантуры) и Направления ДПО (для дополнительного профессионального образования).

Для каждого из уровней образования можно выбрать до трех специальностей (направлений).

После нажатия кнопки "Ок", запись о новой дисциплине появится в главной таблице. В поле "Статус дисциплины" будет установлено значение "проект".

Также в подчиненной таблице Направления/Специальности будет содержать перечень уровней и направлений (специальностей) подготовки, для которых преподается, созданная дисциплина.

Поля таблицы Направления/Специальности :

  • Уровень образования - показывается уровень образования для данного направления/специальности.
  • Аббревиатура направления/специальности - аббревиатура, соответствующая направлению/специальности из справочника Направления и специальности.
  • Направление/специальность ВПО - наименование направления/специальности, для которого преподается данная дисциплина. Выбор из справочника Направления и специальности. Для уровней образования Аспирантура и ДПО поле недоступно для редактирования и должно быть пустым.
  • Код научной специальности - код из справочника Отрасли науки и научные специальности
  • Научная специальность - наименование научной специальности аспирантуры, для которой преподается данная дисциплина. Выбор из справочника Отрасли науки и научные специальности
  • Аббревиатура направления ДПО - аббревиатура из справочника Направления ДПО
  • Направление ДПО - наименование направления ДПО, для которого преподается данная дисциплина. Выбор из справочника Направления ДПО.

По данным таблицы Направления ДПО система автоматически генерирует код дисциплины, который заносится в соответствующее поле главной таблицы.

Код дисциплины автоматически переформировывается при добавлении/удалении записей таблицы Направления/Специальности, а также при изменении числа кредитов в таблице Каталог дисциплин.

Алгоритм формирования кода дисциплины:

Код состоит из трех частей, разделенных знаком "/".

1-я часть: Аббревиатура всех уровней образования, для которых преподается данная дисциплина.

  • Б - бакалавриат
  • С - специалитет
  • М - магистратура
  • А - аспирантура
  • Д - ДПО

2-я часть: Аббревиатура (или коды) направлений, специальностей, научных специальностей, направлений ДПО, для которых преподается дисциплина. Для того, чтобы можно было различить направления (специальности) высшего образрования, научные специальности и направления ДПО, перед соответствующим кодом (аббревиатурой) проставляется индекс:

  • н - научная специальность
  • д - направление ДПО

Аббревиатуры (коды) направлений разделяются знаком "-".

Пример сформированных кодов дисциплин:

Пример 1:

Пример формирования кода дисциплины

Пример 2:


График учебного процесса

График учебного процесса

График учебного процесса является составной частью базового учебного плана. График учебного процесса в ВУЗе в базовом учебном плане составляется на весь период обучения по данному направлению (специальности) с учетом разбиения времени по модулям. На графике указываются продолжительность теоретического обучения, время, отводимое на все виды практики, подготовку выпускной квалификационной работы (ВКР), государственную итоговую аттестацию, каникулы, отпуск после окончания вуза.

Работы по формированию графика учебного процесса производятся на участке РАЗРАБОТКА УЧЕБНЫХ ПЛАНОВ в разделе Базовые и рабочие учебные планы в таблице Базовые учебные планы. Для отображения записей графика учебной работы предназначена подчиненная таблица График учебного процесса.

Перед началом работ по формированию графика учебного процесса необходимо убедиться, что для соответствующего БУП корректно заполнены поля "Реализуется по периодам" и "Число периодов в году" таблицы Базовые учебные планы

Таблица График учебного процесса

Для формирования графика учебного процесса необходимо в таблице Базовые учебные планы выбрать запись БУП, для которой планируется формировать график учебного процесса, вызвать контекстное меню (правая кнопка мыши) и воспользоваться действием "Сформировать график учебного процесса".

Откроется окно задания количества недель в году:

Сформировать график по умолчанию

По умолчанию количество недель проставляется равным "52". Это значение можно изменить.

После нажатия на кнопку "Ок" в таблице График учебного процесса будут созданы записи общим количеством равным заданному количеству недель в году умноженному на количество курсов, по данному учебному плану.

Также в подчиненной таблице Вид недельной нагрузки для каждой из записей таблицы График учебного процесса будут установлены значения "Теоретическое обучение".

Процесс формирования графика учебного процесса заключается в распределении по модулям, неделям и курсам видов учебной и внеучебной деятельности, таких как теоретическое обучение, практика, подготовка выпускной квалификационной работы (ВКР), государственная итоговая аттестация, каникулы, отпуск после окончания вуза.

Для этого необходимо в таблице Базовые учебные планы выбрать БУП, по которому создается график, вызвать контекстное меню (правая кнопка мыши) и воспользоваться пунктом "Открыть график учебного процесса".

Откроется форма редактирования соответствующего графика учебного плана.

Редактирование графика учебного процесса

Форма для редактирования графика учебного процесса содержит временную шкалу учебного года (начиная с сентября), которая рабита по месяцам и неделям. Также таблица разбита по курсам для выбранной степени образования. В правой части таблицы расчитывается количество недель, выделенное на нагрузку каждого вида для каждого курса и их сумма, а также показаны зачетные единицы из соответствующего БУП.

Для нового, только что созданного, графика учебного процесса во всех ячейках временной шкалы проставлены значения "Т" (теоретической обучение).

В первую очередь необходимо задать временные периоды модулей. Вертикальные границы серых областей, которыми обозначены модули, являются перемещаемыми по горизонтали. Для того, чтобы переместить одну из границ области необходимо подвести курсор мыши к перетаскиваемой границе, чтобы он принял вид Курсор. После этого нужно зажать левую кнопку мыши и перетащить границу на нужную неделю. Области модулей пересекаться не могут.

После того, как модули расположены на временной шкале, можно приступить к заполнению ячеек таблицы признаками вида учебной нагрузки. В результате должны быть заполнены ВСЕ ячейки временной шкалы.

Для того, чтобы установить вид недельной нагрузки в соответствующую ячейку необходимо выделить ячейку нажатием левой кнопки мыши (ячейка быдет выделена синим цветом), нажать правую кнопку мыши и из появившегося списка выбрать нужный вид недельной нагрузки. В одной ячейке может быть выбрано несколько видов недельной нагрузки. Для выбора каждого из них, необходимо каждый раз снова вызвать список выбора правой кнопкой мыши.

Выбор вида недельной нагрузки

В форме редактирования предусмотрена возможность назначения вида недельной нагрузки одновременно для нескольких соседних ячеек. Для множественного выбора необходимо, зажав левую кнопку мыши, провести ею над всеми ячейками, которые должны быть изменены. Все выбранные ячейки будут выделены синим цветом. Затем можно вызвать список видов недельной нагрузки нажатием правой кнопки мыши. Во всех выделенных ячейках проставится соответствующий вид нагрузки.

Кроме реквизитов БУП указанных в шапке формы, в верхнем правом углу расположены информационные элементы:

  • Статус плана - показывается статус согласования БУП
  • Программа двойных дипломов - признак программы двойных дипломов
  • Ход согласования - при нажатии на ссылку откроется таблица, содержащая сведения о ходе согласования БУП.
  • Дополнительные действия - открывется список дополнительных действий:
    • Сформировать протокол проверки - будет сформирован протоколол в проверки БУП в формате Excel, в котором будут отображены сообщения Системы о результатах проверки.
    • Напечатать график - будет создан и показан на экране файл Excel, содержащий печатную форму графика учебного процесса для проверки и распечатки. Пример Графика учебного процесса
    • Напечатать план - будет создан и показан на экране файл Excel, содержащий печатную форму БУП.

После того как работа с формой редактирования графика учебного процесса закончена, форму можно закрыть.

Просмотреть и распечатать график учебного процесса можно из таблицы Базовые учебные планы, воспользовавшись пунктом контекстного меню "График учебного процесса".


Переводы для учебных планов

Переводы для учебных планов

Данная форма содержит в себе таблицы данных с перечнем всех терминов и элементов перечислений, используемых на веб-страницах для публикации Базовых и Рабочих учебных планов на английском языке.
Форма переводы для учебных планов

Для корректировки перевода необходимо:

  1. Для термина, перевод которого необходимо изменить, в поле Перевод щелкнуть левой клавишей мыши.
  2. С помощью кнопки Справочник открыть окно редактирования и ввести тест с новым переводом.
  3. Закрыть окно редактирования и подтвердить сохранение изменений.


Аналитические отчеты по РУП

Раздел целиком Одним файлом
Аналитические отчеты по РУП
  • Перечень утвержденных РУП (Форма 1)
  • Регламентирующие показатели РУП (Форма 3)
  • Виды дисциплин в БУП и РУП (Форма 7)
  • Формы контроля в РУП (Форма 10)
  • Дисциплины РУП по циклам ГОС (Форма 11)
  • Дисциплины, не назначенные ни одному студенту
  • Дисциплины по числу вхождений в РУП
  • Выгрузка записей РУП для анализа


Перечень утвержденных РУП (Форма 1)

Перечень утвержденных РУП (Форма 1)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Перечень утвержденных РУП (форма 1).
    Перечень утвержденных РУП

  2. В открывшейся форме параметров:
    Форма параметров Перечень утвержденных РУП

    • В поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • В поле Учебный год указать учебный год, для которого формируется отчет.
    • Для параметров Только по утвержденным РУП и Выводить оценку затратности с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения


Регламентирующие показатели РУП (Форма 3)

Регламентирующие показатели РУП (Форма 3)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Регламентирующие показатели РУП (форма 3).
    Регламентирующие показатели РУП

  2. В открывшейся форме параметров:
    Форма параметров Регламентирующие показатели РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • В поле Учебный год указать учебный год, для которого формируется отчет.
    • Для параметров Показывать соотношение в % и Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения


Виды дисциплин в БУП и РУП (Форма 7)

Виды дисциплин в БУП и РУП (Форма 7)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Виды дисциплин в БУП и РУП (форма 7).
    Виды дисциплин в БУП и РУП

  2. В открывшейся форме параметров:
    Форма параметров Виды дисциплин в БУП и РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • В поле Учебный год указать учебный год, для которого формируется отчет.
    • В поле Вид учебных планов выбрать требуемый вид учебных планов.
    • Для параметра Только по утвержденным планам с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения


Формы контроля в РУП (Форма 10)

Формы контроля в РУП (Форма 10)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Формы контроля в РУП (форма 10).
    Формы контроля в РУП

  2. В открывшейся форме параметров:
    Форма параметров Формы контроля в РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметра Учебный год.
    • При необходимости можно установить ограничение для отчета и указать параметр Только уровень образования.
    • Для параметра Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения


Дисциплины РУП по циклам ГОС (Форма 11)

Дисциплины РУП по циклам ГОС (Форма 11)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Дисциплины РУП по циклам ГОС (форма 11).
    Дисциплины РУП по циклам ГОС

  2. В открывшейся форме параметров:
    Форма параметров Дисциплины РУП по циклам ГОС

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметра Учебный год.
    • Для параметра Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения


Дисциплины, не назначенные ни одному студенту

Дисциплины, не назначенные ни одному студенту

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Дисциплины, не назначенные ни одному студенту.
    Дисциплины, не назначенные ни одному студенту

  2. В открывшейся форме параметров:
    Форма параметров Дисциплины, не назначенные ни одному студенту

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметров Учебный год и Факультет.
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения


Дисциплины по числу вхождений в РУП

Дисциплины по числу вхождений в РУП

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Дисциплины по числу вхождений в РУП.
    Дисциплины по числу вхождений в РУП

  2. В открывшейся форме параметров:
    Форма параметров Дисциплины по числу вхождений в РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметра Учебный год.
    • При необходимости можно установить параметр Минимальное число вхождений.
    • Для параметра Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения


Выгрузка записей РУП для анализа

Выгрузка записей РУП для анализа

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Выгрузка записей РУП для анализа.
    Выгрузка записей РУП для анализа

  2. В открывшейся форме параметров:
    Форма параметров Выгрузка записей РУП для анализа

    • Устновить значения параметров Учебный год, Уровень образования, Филиал, Факультет и Образовательная программа.
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения


Рабочее место кафедры

Раздел целиком Одним файлом
Рабочее место кафедры
  • Настройка участка "Рабочее место кафедры"
  • Работа с ведомостями
  • Предложения кафедры в учебные планы
  • Планирование реализации дисциплин


Настройка участка "Рабочее место кафедры"

Настройка участка "Рабочее место кафедры"

Для установки настроек Кафедра пользователям участка Рабочее место кафедры необходимо выполнить следующие действия:

  1. На участке Кафедра открыть один из разделов:
    • Настройка пользователя кафедры ;
    • Справочники кафедры ;
    • Предложения кафедры в учебном году ;
    • Дисциплины учебных планов и успеваемость ;
    • Дисциплины кафедры в РУП.
  2. В основной таблице данных вызвать контекстное меню (щелчок правой клавишей мыши) и выбрать процедуру Настройка пользователя кафедры. Установка настроек 'кафедра' на участке "Рабочее место кафедры"
  3. Заполнить форму настроек и нажать кнопку ОК, после чего пользователю будут доступны только данные определенной кафедры.
    Форма настроеек пользователя кафедры
В разделе Справочники кафедры прежде чем вызывать контекстное меню, следует выбрать закладку Преподаватели кафедры из основной таблицы данных.


Работа с ведомостями

Работа с ведомостями

Для просмотра ведомостей кафедры, необходимо в форме Дисциплины учебных планов и успеваемость открыть таблицу Все ведомости кафедры. В данной таблице отображаются ведомости только по дисциплинам, реализуемым кафедрой, с которой работает текущий пользователь.

Пользователю доступны следующие действия по работе с ведомостями:

  1. Выгрузка на печать ведомости, сформированной пользователем факультета. Для этого необходимо в таблице Все ведомости кафедры выбрать запись с требуемой ведомостью и через контекстное меню вызвать действие "Ведомость для печати" или "Ведомость для печати (двуязычная)".

    Вывод ведомости на печать

    Откроется форма параметров, в которой при необходимости можно указать Фамилию ИО преподавателя, которая будет выводиться в ведомость. При нажатии кнопки "ОК" будет сформирована ведомость.

  2. Вывод на печать «Объединенной ведомости». Для этого необходимо в таблице Все ведомости кафедры выбрать записи ведомостей, которые должны попасть в «Объединенную ведомость» и через контекстное меню вызвать действие "Объединенная ведомость". При нажатии кнопки "ОК" будет сформирована «Объединенная ведомость», в которой заголовок ведомости сформируется по данным первой из ведомостей, включенных в список, а также в заголовке сформируется список ФИО всех преподавателей, присоединенных ко всем ведомостям списка. Основную часть ведомости будет составлять таблица со списком студентов, включенных во все ведомости из переданного списка.

Для того, чтобы преподаватели могли скачивать и распечатывать свои ведомости используя веб-браузер, предоставлена возможность работы с специализированным веб-сервисом печати ведомостей. Для доступа к веб-сервису на главной веб-странице системы расположена ссылка «Я – преподватель», ведущая на страницу работы с ведомостями.


Предложения кафедры в учебные планы

Раздел целиком Одним файлом
Предложения кафедры в учебные планы

Функционал раздела "Предложения кафедры в учебные планы" позволяет пользователям кафедры создавать и редактировать группы дисциплин ("планы-предложения"), которые кафедра готова реализовывать для различных образовательных программ университета.

Объединение в "группы" ("планы-предложения") может использоваться для разделения дисциплин, предлагаемых для разных уровней образования, реализуемых в разные периоды, и планируемых по разным видам периодов - по модулям или по семестрам.
  • Создание плана-предложения кафедры
  • Формирование плана-предложения кафедры
  • Добавление нагрузки для дисциплин и НИС
  • Установка ограничений на использование дисциплины
  • Статусы дисциплин плана-предложения
  • Печать плана-предложения кафедры
  • Изменение периода реализации дисциплины или НИС


Создание плана-предложения кафедры

Создание плана-предложения кафедры

Для добавления нового "плана-предложения" необходимо:

  1. На участке Рабочее место кафедры выбрать раздел "Предложения кафедры в учебные планы".
  2. В основной таблице данных Планы-предложения кафедры с помощью контекстного меню вызвать действие Добавить план-предложение кафедры.
    Добавление плана предложения
  3. В форме добавления необходимо:
    Форма добавления плана предложения
    • В полях Филиал, Факультет, Кафедра - указать соответствующие значения, если до этого были установлены соответствующие настройки пользователя (Настройка участка "Рабочее место кафедры"), то эти параметры будут заполнены автоматически.
    • С помощью полей Год начала реализации, Уровень образования и Число лет можно создавать планы предложения кафедры, как на все годы, так и группировать дисциплины в разные планы по годам или по уровням образования.
    • В поле Реализуется по периодам - выбрать вид периодов реализации плана (по модулям или по семестрам).
    • В поле Количество периодов - ввести количество периодов в учебном году (число модулей или число семестров).
  4. Нажать кнопку ОК, после чего план-предложение кафедры будет добавлен.


Формирование плана-предложения кафедры

Формирование плана-предложения кафедры

Наполнение и редактирование плана-предложения кафедры выполняется с помощью специальной Формы редактирования, для открытия которой необходимо в разделе "Предложения кафедры в учебные планы" выбрать требуемое план-предложение и через контекстное меню вызвать действие Открыть и указать параметры для открытия формы редактирования.
Форма параметров для открытия формы редактирования ПП

  • Если в форму редактирования нужно вклучить дисциплины других планов предложений кафедры, то в поле Включить дисциплины других планов необходимо установить значение "Да".
  • С помощью полей С учебного года и По учебный год установить период для открытия формы редактирования.

    При открытии в форме редактирования будут только дисциплины, которые реализуются хотя бы в одном из учебных годов между указанными в полях С учебного года и По учебный год.

    В форме редактирования для изменения периода нужно воспользоваться действием Параметры редактирования (правый верхний угол формы редактирования).

Редактирование плана-предложения заключается в добавлении в существующие разделы дисциплин или семинаров, распределении учебной нагрузки по видам (лекции, семинары, самостоятельная работа) и по учебным периодам. Для добавления записей в план предложение предназначены соответствующие действия контекстного меню. Для добавлении записи в определенный раздел нужно сначала выбрать заголовок этого раздела или одну из входящих в него записей.

Добавлять в план-предложение кафедры можно "дисциплины" и "научно-исследовательские семинары", для этого необходимо в уже открытой Форме редактирования в контекстном меню найти группу действий Добавить и выбрать одно из действий дисциплину... или научно-исследовательский семинар... Добавление дисциплины в план-предложение кафедры

В результате откроется окно параметров, в котором необходимо: Форма параметров добавление дисциплины в план-предложение кафедры

  • В поле Источник финансирования из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
  • Установить Год начала реализации и Год окончания реализации.
  • В поле Дисциплина вуза или Семинар (дисциплина вуза) - с помощью списка Список или справочника Справочник выбрать дисциплину или семинар для добавления.
  • При необходимости установить значения параметров в полях Имеет пререквизиты, На иностранном языке, Читается носителем языка.
  • В поле Формат изучения установить формат изучения дисциплины.
  • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
  • В полях Общее число часов, Аудиторных часов - указать соответствующие числовые характеристики добавляемой дисциплины или семинара.

После нажатия кнопки ОК, дисциплина (семинар) будет добавлена и ей будет присвоен свободный порядковый номер.

Для изменения периода реализации дисциплины или НИС необходимо использовать процедуру Изменить период реализации.

Дисциплины (семинары), входящие в план-предложение кафедры имеют свойство Статус. Сразу после создания дисциплины пользователем кафедры дисциплина получает статус "проект". Пока дисциплина находится в этом статусе, разработчики планов образовательных программ не видят эту дисциплину и не могут использовать ее в своих планах. Этот статус необходим для того, чтобы пользователь кафедры закончил работу со всеми необходимыми характеристиками дисциплины, а также задал ограничения на использование дисциплины в учебных планах.


Добавление нагрузки для дисциплин и НИС

Добавление нагрузки для дисциплин и НИС

В планах предложениях для каждой дисциплины нужно сформировать нагрузку, как по годам, так и периодам каждого года.

Для добавления нагрузки необходимо:

  1. В представлении Планы-предложения кафедры (форма Предложения кафедры в учебные планы) выбрать план предложение, для которого будет формироваться нагрузка.
  2. Вызвать из контекстного меню действие Открыть.
  3. В форме редактирования выбрать дисциплину или НИС, для которой добавляются данные о нагрузке.
  4. Для каждой дисциплины (НИС) в форме редактирования представлен набор параметров (каждому параметру соответствует своя колонка), с помощью которых можно задать нагрузку:
    Форма редактирования фформирование нагрузки в плане предложении
    • В полях Всего часов по дисциплине и Всего аудиторных часов по дисциплине можно отредактировать соответствующее количество часов за весь период реализации дисциплины.
    • Для каждого учебного года, в рамках которых реализуется дисциплина, необходимо указать значения полей Всего часов в году и Аудиторных часов в году, а также распределить часы по видам работ в группах полей Ауд. часы по видам работы, Самостоятельная работа.
      Если для какого-либо учебного года были внесены данные о нагрузке (указаны Всего часов в году, Аудиторных часов в году и т.д.), то в представлении Нагрузка по годам появится соответствующая запись о нагрузке в учебном году, для которого добавлена информация о нагрузке.
    • Для каждого отдельного периода (модуля/семестра) необходимо указать значения следующих полей: Аудиторных часов в периоде, Форма контроля (указывается если в данном периоде предусмотрен рубежный контроль), Аудиторных часов за часть дисциплины и Общих часов за часть дисциплины (если в данном периоде предусмотрен рубежный, то нужно указать количество аудиторных и общих часов, которое будет зачтено при прохождении рубежного контроля в данном периоде (модуле/семестре)).
      Если для какого-либо периода в учебном году были внесены данные о нагрузке, то в представлении Нагрузка по периодам года (представление подчиненно представлению Предлагаемые дисциплины и НИС по годам) появится соответствующая запись о нагрузке в периоде, для которого добавлена информация о нагрузке.

Допустим в форме редактирования плана-предложения требуется ввести данные для дисциплины "Иностранный язык", которая характеризуется следующим набором данных:

  • Продолжительность: с 1 по 4 модуль первого года обучения.
  • Рубежный контроль: во 2 модуле зачет; в 4 модуле экзамен.
  • Всего часов: 108 (из них всего аудиторных 68).
  • Распределение часов по видам работ: 68 часов практических занятий и 40 часов самостоятельной работы.
  • Распределение часов по периодам: в 1, 2 и 3 модуле по 16 ауд.часов и 10 часов самостоятельной работы; в 4 модуле 20 ауд. часов и 10 часов самостоятельной работы.

Для этого необходимо найти нужный план-предложение и открыть форму редактирования (действие Открыть из контекстного меню). В форме редактирования найти дисциплину "Иностранный язык" и в следующих полях указать соответствующие данные:

  1. В полях Всего часов по дисциплине и Всего аудиторных часов по дисциплине указать значения 108 и 68 часов соответственно.
  2. Для 1 года обучения указать:
    • в полях Всего часов в году и Аудиторных часов в году указать 108 и 68 часов соответственно;
    • в поле практические занятия 68 часов;
    • в поле самостоятельная работа 40 часов;
  3. Для 1 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • поля Форма контроля, Аудиторных часов за часть дисциплины и Общих часов за часть дисциплины необходимо оставить пустыми, так как рубежный контроль в данном периоде не предусмотрен и часы за данный период будут суммироваться в периоде, в котором встречается следующий рубежный контроль (во 2 модуле).
  4. Для 2 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • в поле Форма контроля установить форму контроля "Зачет";
    • в поле Аудиторных часов за часть дисциплины 32 часа (так как в 1 модуле рубежного контроля не было, то аудиторные часы за часть дисциплины в 1 модуле суммируются к часам 2 модуля).
    • в поле Общих часов за часть дисциплины 52 часа (так так как в 1 модуле рубежного контроля не было, то общие часы за часть дисциплины в 1 модуле суммируются к часам 2 модуля).
  5. Для 3 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • поля Форма контроля, Аудиторных часов за часть дисциплины и Общих часов за часть дисциплины необходимо оставить пустыми, так как рубежный контроль в данном периоде не предусмотрен и часы за данный период будут суммироваться в периоде, в котором встречается следующий рубежный контроль (в 4 модуле).
  6. Для 4 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • в поле Форма контроля установить форму контроля "Экзамен";
    • в поле Аудиторных часов за часть дисциплины 36 часа (так как в 3 модуле рубежного контроля не было, то аудиторные часы за часть дисциплины в 3 модуле суммируются к часам 4 модуля).
    • в поле Общих часов за часть дисциплины 56 часа (так так как в 3 модуле рубежного контроля не было, то общие часы за часть дисциплины в 3 модуле суммируются к часам 4 модуля).


Установка ограничений на использование дисциплины

Установка ограничений на использование дисциплины

Пользователям кафедры предоставлена возможность устанавливать ограничения на использование дисциплины в тех или иных учебных планах, часть ограничений следуют из характеристик плана-предложения кафедры, в который включена дисциплина: Год начала реализации, Уровень образования, Реализуется по периодам.

При необходимости для каждой отдельной дисциплины (семинара) можно дополнительно ограничить возможность выбора дисциплины:

  • по направлению (специальности) образовательной программы;
  • по филиалу образовательной программы;
  • по факультету образовательной программы;
  • по конкретной образовательной программе (или конкретному набору программ).

Для добавления ограничения необходимо:

  1. Открыть раздел "Предложения кафедры в учебные планы".
  2. В подчиненной таблице данных Предлагаемые дисциплины и НИС выбрать дисциплину (семинар), на которую необходимо установить ограничения.
  3. В подчиненной вкладке Ограничения на выбор дисциплины с помощью контекстного меню вызвать действие Добавить ограничение.
    Установка ограничения на выбор дисциплины
  4. В форме параметров:
    Форма добавления ограничений
    • Если существует потребность одновременно с добавлением новых ограничений удалить старые, то необходимо для признака Удалять существующие ограничения установить значение "Да".
    • Можно установить ограничения по виду плана, для этого необходимо в поле Вид учебного плана установить вид плана, которому должна быть доступна данная дисциплина. Для объединенного плана общевузовских дисциплин дополнительно можно указать ограничение по типу общевузовского плана (поле Тип общевузовского плана), а для объединенного майнора по виду майнора (поле Вид майнора).
    • Можно установить ограничения по уровню образованич, для этого необходимо установить значение "Да" для тех уровней образования, которым должна быть доступна дисциплина.
    • В поле Направления / специальности можно выбрать направления / специальности для установки ограничений, для этого нужно нажать кнопку Справочник и с помощью чек-бокса Чек-бокс выбрать одно и более записей, после чего нажать кнопку ОК. Все выбранные записи отобразятся в поле Направления / специальности.
      Поле Направления / специальности будет доступно для установки ограничений, только если в поле Вид учебного плана установлено пустое значение или "Объединенный учебный план".
    • Аналогично направлениям / специальностям можно установить одно и более ограничений по Филиалу, Факультету, Образовательной программе и Курсу студентов.

      Для вида учебного плана "Объединенный план общевузовских дисциплин" поля для установки ограничений Филиал, Факультет, Образовательная программа и Курс студентов будут недоступны.

      Для вида учебного плана "Объединенный майнор" поля для установки ограничений Факультет, Образовательная программа и Курс студентов будут недоступны.

      Для вида учебного плана "Объединенный план факультетских дисциплин" поля для установки ограничений Образовательная программа и Курс студентов будут недоступны.

  5. После нажатия кнопки ОК будут созданы все возможные варианты ограничений с учетом установленных значений в форме параметров.
Если нужно задать ограничение таким образом, чтобы оно действовало не по одному, а по нескольким (но не всем) значениям, нужно добавить несколько подобных ограничений (например, добавить несколько ограничений, указав отдельные образовательные программы; в этом случае дисциплину можно будет использовать только в учебных планах этих конкретных образовательных программ).


Статусы дисциплин плана-предложения

Статусы дисциплин плана-предложения

Каждая дисциплина (НИС) в плане-предложении может находиться в одном из статусов:

  • проект;
  • заявка на дисциплину;
  • принята кафедрой;
  • отклонена;
  • утверждена.

Для изменения статуса пользователю кафедры необходимо открыть раздел Предложения кафедры в учебные планы и в таблице данных Предлагаемые дисциплины и НИС выбрать дисциплину, в контекстном меню системы найти группу действий Изменить статус и вызвать одно из действий: Принять к реализации, Вернуть в статус "проект", Утвердить реализацию, Отклонить реализацию.

При добавлении в план-предложение дисциплина получает статус "проект". После добавления пользователь кафедры должен максимально полно занести данные о нагрузке по дисциплине, ее распределении по видам работ и по периодам обучения, задать формы текущего и рубежного контроля. Эта информация будет необходима пользователям-разработчикам учебных планов для принятия решения о включении или невключении дисциплины в свои планы. Также, пока дисциплина находится в статусе "проект", пользователь кафедры должен занести ограничения на использование дисциплины. Из статуса "проект" пользователь кафедры может перевести дисциплину в статус "принята кафедрой" при помощи действия Принять к реализации. Дисциплины в статусе "принята кафедрой" становятся доступными для выбора пользователями - разработчиками учебных планов.

Для дисциплины в статусе "принята кафедрой" возможно выполнение действия Вернуть в статус "проект", однако выполнить это действие будет возможно только в случае, если дисциплина еще не включена ни в один из учебных планов.

Дисциплина может оказаться включенной в план-предложение кафедры разработчиком одного из учебных планов. В этом случае дисциплина появится в плане-предложении кафедры без непосредственного участия пользователя кафедры. Такие дисциплины будут появляться в статусе "заявка на дисциплину". Над дисциплиной в статусе "заявка на дисциплину" пользователь кафедры может выполнять следующие операции:

  • вносить изменения в данные о нагрузке по дисциплине;
  • выполнить для этой дисциплины действие Принять к реализации, в этом случае дисциплина перейдет в статус "принята кафедрой" ;
  • выполнить для этой дисциплины действие Отклонить реализацию ;
  • "объединить" дисциплину с какой-то другой из дисциплин своей кафедры; эта операция предусмотрена для случаев, когда пользователь кафедры считает, что разработчик учебного плана излишне создал дисциплину, и в учебном плане можно использовать другую схожую дисциплину со схожими параметрами нагрузки.

Пользователь кафедры может вносить изменения в данные о дисциплинах своей кафедры на разных этапах работы с учебными планам. Все изменения, сделанные пользователем кафедры, будут сразу же применяться ко всем учебным планам образовательных программ, в которых они задействованы. Однако перед "утверждением" учебных планов внесение изменений в данные о дисциплинах должно быть прекращено. Для фиксации такого состояния предназначен статус дисциплины "утверждена". Этот статус означает, что изменения в данные о дисциплине больше не вносятся. Перевести дисциплину в статус "утверждена" можно при помощи действия Утвердить реализацию.


Печать плана-предложения кафедры

Печать плана-предложения кафедры

Для выгрузки плана-предложения кафедры для печати необходимо в форме Предложения кафедры в учебные планы (таблица данных Планы-предложения кафедры) из контекстного меню вызвать действие Выгрузить для печати.
Вызов процедуры Выгрузить для печати план-предложение кафедры

В результате сформируется и откроется Excel-файл, содержащий всю информацию о плане-предложении.


Изменение периода реализации дисциплины или НИС

Изменение периода реализации дисциплины или НИС

Для изменения периода реализации дисциплины или НИС, необходимо:

  1. В представлении Планы-предложения кафедры (форма Предложения кафедры в учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Предлагаемые дисциплины и НИС выбрать дисциплину или НИС, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.


Планирование реализации дисциплин

Раздел целиком Одним файлом
Планирование реализации дисциплин

Для планирования реализации дисциплин и НИС, преподаваемых кафедрой, необходимо выполнить формирование предметных единиц (предметных потоков, предметных групп, предметных подгрупп) для всех дисциплин и НИС, которые будут преподаваться кафедрой в очередном учебном году. Данные предметные единицы будут использованы при планировании нагрузки, для составления расписания занятий, для оценки фактически выполненной кафедрой учебной нагрузки.

В форме Планирование реализации дисциплин на вкладке Студенты, изучающие дисциплину, можно увидеть список студентов, которым дисциплина уже назначена. На основе этой информации можно оценить необходимое количество предметных потоков, групп, подгрупп. По мере включения академических групп в предметные единицы и распределения студентов по предметным единицам эта информация будет отображаться на подчиненных вкладках Связанные академические группы и на вкладке Студенты, изучающие дисциплину в колонках Предметный поток, Предметная группа, Предметная подгруппа, отдельно по каждому студенту.

Пользователи кафедр формируют предметные единицы, устанавливают максимальное количество студентов, которое может быть в них включено, и накладывают ограничения на использование предметных единиц. Включение студентов в предметные единицы будут выполнять Менеджеры образовательных программ, ответственные за организацию обучения студентов. Менеджерам образовательных программ будут доступны предметные единицы с учетом наложенных ограничений и они не смогут включить в предметную единицу больше студентов, чем установлено пользователем кафедры. Для случаев, когда кафедра не считает нужным ограничивать количество студентов, которые могут быть включены в предметную единицу, атрибут Максимальное количество студентов можно оставить пустым.

Формирование предметных единиц обязательное действие в следующих случаях:

  1. Создание предметных потоков для дисциплин обязательно, если есть лекции, проведение экзаменов в письменной форме.
  2. Создание предметных потоков для НИС обязательно во всех случаях.
  3. Создание предметных групп для дисциплин обязательно, если есть семинары, тренинги; при обучении по семестрам (для учета консультаций перед экзаменом).
  4. Создание предметных групп для НИС обязательно во всех случаях
  5. Создание предметных подгрупп для дисциплин обязательно, если есть практические, лабораторные работы, мастер-классы.
  6. Создание предметных подгрупп для НИС необязательно.

Для формирования предметных единиц необходимо выполнить ряд действий:

  • Формирование предметных потоков
  • Формирование предметных групп
  • Формирование предметных подгрупп
  • Установка ограничений на использование предметных единиц


Формирование предметных потоков

Формирование предметных потоков

Представление (таблица данных) Предметные потоки содержит перечень предметных потоков для каждой дисциплины кафедры. Для добавления предметных потоков необходимо:

Создание предметных потоков обязательно:
  1. Для всех НИС.
  2. Для дисциплин, если есть лекции, проведение экзаменов в письменной форме.
  1. Открыть раздел Планирование реализации дисциплин и выбрать дисциплину или НИС, для которой будут формироваться предметные единицы.
  2. В подчиненном представлении (таблице данных) Предметные потоки из контекстного меню вызвать действие Добавить предметный поток.
    Вызвов действия добавить предметный поток
  3. В форме параметров ввести Краткое наименование, при необходимости можно ограничить число студентов в потоке, указав Максимальное количество студентов на потоке.
  4. Нажать кнопку ОК.

Для редактирования существующих записей предметных единиц, необходимо дважды щелкнуть левой клавишей мыши по ячейке с параметром, который нужно изменить, ввести новое значение и нажать кнопку Enter.

После того как предметная единица была создана необходимо установить ограничения на ее использование см. Установка ограничений на использование предметных единиц.


Формирование предметных групп

Формирование предметных групп

Представление (таблица данных) Предметные группы содержит перечень предметных групп для каждой дисциплины кафедры. Предметные группы можно связывать с предметными потоками (в случаях, когда предметный поток формируется из определенных предметных групп), а можно создавать без связи с предметными потоками. Для добавления предметных групп необходимо:

Создание предметных групп обязательно:
  1. Для всех НИС.
  2. Для дисциплин, если есть семинары, тренинги; при обучении по семестрам (для учета консультаций перед экзаменом).
  1. Открыть раздел Планирование реализации дисциплин и выбрать дисциплину или НИС, для которой будут формироваться предметные единицы.
  2. В подчиненном представлении (таблице данных) Предметные группы из контекстного меню вызвать действие Добавить предметную группу.
    Вызов действия добавить предметную группу
  3. В форме параметров ввести Краткое наименование, при необходимости можно ограничить число студентов в группе, указав Максимальное количество студентов в группе. Также можно установить связь группы с потоком, выбрав в поле Входит в предметный поток соответствующий поток из справочника Предметные потоки (кнопка Справочник).
  4. Нажать кнопку ОК.

Для редактирования существующих записей предметных единиц, необходимо дважды щелкнуть левой клавишей мыши по ячейке с параметром, который нужно изменить, ввести новое значение и нажать кнопку Enter.

После того как предметная единица была создана необходимо установить ограничения на ее использование см.Установка ограничений на использование предметных единиц.


Формирование предметных подгрупп

Формирование предметных подгрупп

Представление (таблица данных) Предметные подгруппы содержит перечень предметных подгрупп для каждой дисциплины кафедры. Предметные подгруппы можно связывать с предметными группами, а можно создавать независимо от предметных групп. Для добавления предметных подгрупп необходимо:

  1. Открыть раздел Планирование реализации дисциплин и выбрать дисциплину или НИС, для которой будут формироваться предметные единицы.
  2. В подчиненном представлении (таблице данных) Предметные подгруппы из контекстного меню вызвать действие Добавить предметную подгруппу.
    Вызов действия добавить предметную подгруппу
  3. В форме параметров ввести Краткое наименование, при необходимости можно ограничить число студентов в подгруппе, указав Максимальное количество студентов в подгруппе. Также можно установить связь подгруппы с группой, выбрав в поле Входит в предметную группу соответствующую группу из справочника Предметные группы (кнопка Справочник).
  4. Нажать кнопку ОК.

Для редактирования существующих записей предметных единиц, необходимо дважды щелкнуть левой клавишей мыши по ячейке со значением атрибута, который нужно изменить, ввести новое значение и нажать кнопку Enter.

Создание предметных подгрупп обязательно только для дисциплин, если есть практические, лабораторные работы, мастер-классы. Формирование предметных подгрупп для НИС необязательно.

После того как предметная единица была создана необходимо установить ограничения на ее использование см.Установка ограничений на использование предметных единиц


Установка ограничений на использование предметных единиц

Установка ограничений на использование предметных единиц

После того как предметные единицы были созданы (см. Формирование предметных потоков, Формирование предметных групп и Формирование предметных подгрупп) необходимо установить ограничения на их использование, для этого необходимо:
Если предметная единица должна быть доступна Менеджерам образовательных программ всех Филиалов, Факультетов и Образовательных программ, то устанавливать ограничения нет необходимости.

  1. Открыть представление (таблицу данных) Предметные потоки, Предметные группы или Предметные подгруппы и выбрать предметную единицу.
  2. В подчиненном представлении (таблице данных) Ограничения использования потока, Ограничения использования группы или Ограничения использования подгруппы из контекстного меню вызвать действие Добавить ограничение.
    Вызов действия Добавить ограничение
  3. В форме установить Филиал, Факультет (при необходимости) и Образовательную программу (при необходимости).
  4. Нажать кнопку ОК. После чего предметная единица будет доступна только Менеджерам образовательных программ добавленного в ограничения Филиала, Факультета и Образовательной программы.


Проверки и расчеты (руководство администратора)

Раздел целиком Одним файлом
Проверки и расчеты (руководство администратора)
Проверки и расчеты учебных планов хранятся в базе данных в виде объектов классов "Контрольное соотношение учебного плана" и "Действие соотношения учебного плана". На каждое контрольное соотношение может быть создано любое количество действий. Проверки и расчеты
  • Проверки
  • Объекты, доступные в теле скриптов проверок и расчетов


Проверки

Проверки
При создании проверки необходимо указать
  • Имя и наименование проверки. Имя проверки должно быть уникальным. Наименование проверки будет по умолчанию показано пользователю при невыполнении условий проверки.
  • Очередность применения проверки. Проверки применяются в порядке, определяемом этим свойством. В случае наличия проверок с одинаковой очередностью, порядок их применения может быть любым, и вам не следует делать предположений об этом порядке.
  • Область применимости проверки. Проверки могут применяться к базовым учебным планам, к рабочим учебным планам или к обоим типам. Проверки могут применяться либо к показателям, распределяемым по периодам обучения, либо нет. Также можно указать конкретный показатель плана, к которому будет применяться проверка.


Объекты, доступные в теле скриптов проверок и расчетов

Объекты, доступные в теле скриптов проверок и расчетов
  • ContextObject: IContext Контекстный объект, реализующий .
  • Period: Integer Для проверок, работающих по учебным периодам - номер проверяемого периода. Нумерация периодов начинается с нуля.
  • CurrentYear: Integer Для проверок, работающих по учебным периодам - номер проверяемого периода. Для учебных планов лицея, объединенных учебных планов и планов предложения кафедры - номер проверямого года для проверок, работающих по учебным годам. Нумерация периодов начинается с нуля.
  • CurrentControlType: WideString Для проверок, работающих по формам текущего контроля - идентификатор формы текущего контроля.
  • MasterPlan: WideString Идентификатор учебного плана.
  • ItemCount[SubjectClass: WideString]: Integer Количество записей плана с типом SubjectClass.
  • Course: WideString Идентификатор курса.
  • CourseNumber: Integer Номер курса.
  • RootItem: PlanItem Объект, обеспечивающий доступ к сумме корневых строк плана. Объект реализует описанный ниже интерфейс IPlanItem.
  • WeekCount[Period: Integer]: Integer Количество недель в соответствующем периоде.
  • WeeksByYearByPeriod[Year: Integer; Period: Integer]: Integer Количество недель в соответствующем периоде года (для объединенного рабочего плана).
  • AudHoursInWeekCountByYearByPeriod[Year: Integer; Period: Integer]: Double Количество аудиторных часов всех дисиплин, входящих в недельную нагрузку в соответствующем периоде года (для объединенного рабочего плана).
  • Result: OleVariant Через эту переменную передается результат расчета расчетного показателя.
  • ControlTypeCount[const ControlType: WideString; Period: Integer]: Integer Количество (по плану в целом) видов рубежного испытания ControlType за период Period
  • Message(Optional MessageText: WideString, Optional Color: WideString) Процедура генерирует сообщение проверки для пользователя. Текст сообщения и "цвет" по умолчанию берутся из свойств самой проверки.
  • Item: IPlanItem Объект, обеспечивающий доступ к свойствам проверяемой строки плана. Объект реализует описанный ниже интерфейс IPlanItem :
      IPlanItem = interface
    property ID: WideString readonly;

    property Parent: IPlanItem readonly;
    property ChildCount: Integer readonly;
    property Child[Index: Integer]: IPlanItem readonly;

    property PeriodCount: Integer readonly;

    property SubjectClass: WideString readonly;
    property IsCalculated: WordBool readonly;
    property CumulOnly: WordBool readonly;
    property SubjectType: WideString readonly;
    property PracticeType: WideString readonly;

    property BlockCode: WideString readonly;
    property Description: WideString readonly;
    property UnivSubject: WideString;
    property FacDepartment: WideString;

    property StandHours: Double readonly;
    property EntireHours: Double;
    property WeekCount: Double;
    property Credits: Double;
    property AudHours: Double;
    property LectionHours: Double;
    property SeminarHours: Double;
    property PracticeHours: Double;
    property SelfHours: Double;
    property FinalControl: WideString;
    property HoursByPeriod[Period: Integer]: Double;
    property CreditsByPeriod[Period: Integer]: Double;
    property AudHoursByPeriod[Period: Integer]: Double;
    property ControlsByPeriod[Period: Integer]: WideString;
    property CurrentControls[const CurrentControlType: WideString]: Integer;
    property ExamCountByPeriod[Period: Integer]: Integer;
    property TestCountByPeriod[Period: Integer]: Integer;

    function ChildrenAudHours: Double;
    function ChildrenLectionHours: Double;
    function ChildrenSeminarHours: Double;
    function ChildrenPracticeHours: Double;
    function ChildrenSelfHours: Double;
    function ChildrenStandHours: Double;
    function ChildrenEntireHours: Double;
    function ChildrenWeekCount: Double;
    function ChildrenCredits: Double;
    function ChildrenHoursByPeriod(Period: Integer): Double;
    function ChildrenCreditsByPeriod(Period: Integer): Double;
    function ChildrenCurrentControls(const CurrentControlType: WideString): Integer;
    function ChildrenAudHoursByPeriod(Period: Integer): Double;
    function ChildrenExamCountByPeriod(Period: Integer): Integer;
    function ChildrenTestCountByPeriod(Period: Integer): Integer;

    property YearsCount: Integer readonly;
    property AudHoursByYear[Year: Integer]: Double;
    property WeeksByYear[Year: Integer]: Double;
    property AudHoursByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property WeeksByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property ControlTypeByYearByPeriod[Year: Integer; Period: Integer]: WideString;

    function ChildrenAudHourByYear(Year: Integer): Double;
    function ChildrenWeeksByYear(Year: Integer): Double;
    function ChildrenAudHoursByYearByPeriod(Year: Integer; Period: Integer): Double;
    function ChildrenWeeksByYearByPeriod(Year: Integer; Period: Integer): Double;

    property StandCredits: Double readonly;
    property StandMinCredits: Double readonly;
    property StandMaxCredits: Double readonly;

    property CreditsByYear[Year: Integer]: Double;
    property EntireHoursByYear[Year: Integer]: Double;
    property LectionHoursByYear[Year: Integer]: Double;
    property SeminarHoursByYear[Year: Integer]: Double;
    property PracticeHoursByYear[Year: Integer]: Double;
    property SelfHoursByYear[Year: Integer]: Double;
    property CreditsByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property ExamAudHoursByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property ExamEntireHoursByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property CurrentControlsByYear[Year: Integer; const CurrentControlType: WideString]: Integer;

    property ItemStatus: WideString readonly;
    property ProposalStatus: WideString readonly;

    function ChildrenStandCredits: Double;
    function ChildrenCreditsByYear(Year: Integer): Double;
    function ChildrenEntireHoursByYear(Year: Integer): Double;
    function ChildrenLectionHoursByYear(Year: Integer): Double;
    function ChildrenSeminarHoursByYear(Year: Integer): Double;
    function ChildrenPracticeHoursByYear(Year: Integer): Double;
    function ChildrenSelfHoursByYear(Year: Integer): Double;
    function ChildrenCreditsByYearByPeriod(Year: Integer; Period: Integer): Double;
    function ChildrenExamAudHoursByYearByPeriod(Year: Integer; Period: Integer): Double;
    function ChildrenExamEntireHoursByYearByPeriod(Year: Integer; Period: Integer): Double;
    function ChildrenCurrentControlsByYear(Year: Integer; const CurrentControlType: WideString): Integer;

    property ExamCountByYearByPeriod[Year: Integer; Period: Integer]: Integer;
    property TestCountByYearByPeriod[Year: Integer; Period: Integer]: Integer;

    function ChildrenExamCountByYearByPeriod(Year: Integer; Period: Integer): Integer;
    function ChildrenTestCountByYearByPeriod(Year: Integer; Period: Integer): Integer;

    property MinCurrentCoefByYear(Year: Integer): Double readonly;
    property MinCurrentHoursByYear(Year: Integer): Double readonly;
    property PlanCurrentCoefByYear(Year: Integer): Double;
    property PlanCurrentHoursByYear(Year: Integer): Double;

    function ChildrenMinCurrentHoursByYear(Year: Integer): Double; safecall;
    function ChildrenPlanCurrentHoursByYear(Year: Integer): Double; safecall;

    property StudyFormat: WideString; safecall;
  end;
    • Свойство ID содержит идентифкатор строки учебного плана.
    • Свойство Parent содержит ссылку на объект, описыващий родительскую запись плана (если она есть). Объект реализует тот же интерфейс IPlanItem
    • Свойства ChildCount и Child возвращают, соответственно, количество дочерних записей плана и ссылки на объекты, описывающие дочерние записи (реализуют тот же интерфейс IPlanItem).
    • Свойство PeriodCount определяет количество учебных периодов, содержащихся в учебном плане. Для плана лицея - количество учебных периодов в году.
    • Свойство SubjectClass возвращает идентификатор класса строки учебного плана.
    • Свойство IsCalculated равно True, если строка является суммой своих дочерних строк.
    • Свойство CumulOnly равно True, если строка включается только в кумулятивный рейтинг.
    • Свойство SubjectType возвращает идентификатор вида дисциплины строки учебного плана.
    • Свойство PracticeType возвращает идентификатор вида практики строки учебного плана.
    • Свойство BlockCode возвращает код раздела учебного плана.
    • Свойство Description возвращает наименование строки учебного плана.
    • Свойство UnivSubject возвращает и устанавливает идентификатор дисциплины, которая описывается строкой учебного плана.
    • Свойство FacDepartment возвращает и устанавливает идентификатор кафедры строки учебного плана.
    • Свойство StandHours возвращает количество часов по стандарту.
    • Свойство EntireHours возвращает и устанавливает общее количество часов.
    • Свойство WeekCount возвращает и устанавливает общее количество недель.
    • Свойство Credits возвращает и устанавливает общее количество зачетных единиц.
    • Свойство AudHours возвращает и устанавливает количество аудиторных часов.
    • Свойство LectionHours возвращает и устанавливает количество часов лекций.
    • Свойство SeminarHours возвращает и устанавливает количество часов семинаров.
    • Свойство PracticeHours возвращает и устанавливает количество часов практических занятий.
    • Свойство SelfHours возвращает и устанавливает количество часов самостоятельной работы.
    • Свойство FinalControl возвращает и устанавливает идентификатор типа итогового контроля.
    • Свойство HoursByPeriod[Period] возвращает и устанавливает общее количество часов в учебном периоде с номером Period.
    • Свойство CreditsByPeriod[Period] возвращает и устанавливает количество зачетных единиц в учебном периоде с номером Period.
    • Свойство AudHoursByPeriod[Period] возвращает и устанавливает количество аудиторных часов в учебном периоде с номером Period.
    • Свойство ControlsByPeriod[Period] возвращает и устанавливает количество зачетных единиц в учебном периоде с номером Period.
    • Свойство ExamCountByPeriod[Period] возвращает и устанавливает количество экзаменов в учебном периоде с номером Period.
    • Свойство TestCountByPeriod[Period] возвращает и устанавливает количество зачетов в учебном периоде с номером Period.
    • Свойство CurrentControls[CurrentControlType] возвращает и устанавливает количество формы текущего контроля с идентификатором CurrentControlType.
    • Функции ChildrenAudHours, ChildrenLectionHours, ChildrenSeminarHours, ChildrenPracticeHours, ChildrenSelfHours, ChildrenStandHours, ChildrenEntireHours, ChildrenWeekCount, ChildrenCredits, ChildrenHoursByPeriod, ChildrenCreditsByPeriod, ChildrenCurrentControls, ChildrenAudHoursByPeriod, ChildrenAudHoursByPeriod, ChildrenAudHoursByPeriod, ChildrenExamCountByPeriod, ChildrenTestCountByPeriod, ChildrenAudHourByYear (только для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры), ChildrenWeeksByYear (только для учебного плана лицея), ChildrenAudHoursByYearByPeriod (только для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры), ChildrenWeeksByYearByPeriod (только для учебного плана лицея), ChildrenStandCredits (только для объединенного учебного плана и плана-предложения кафедры), ChildrenCreditsByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenEntireHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenLectionHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenSeminarHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenPracticeHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenSelfHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenCreditsByYearByPeriod (только для объединенного учебного плана и плана-предложения кафедры), ChildrenExamAudHoursByYearByPeriod (только для объединенного учебного плана и плана-предложения кафедры), ChildrenExamEntireHoursByYearByPeriod (только для объединенного учебного плана и плана-предложения кафедры), ChildrenCurrentControlsByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenExamCountByYearByPeriod (только для объединенного учебного плана), ChildrenTestCountByYearByPeriod (только для объединенного учебного плана) агрегируют соответствующие показатели по дочерним записям учебного плана. Важно, что строки, которые включается только в кумулятивный рейтинг, не агрегируются функциями ChildrenCredits и ChildrenCreditsByPeriod.
    • Свойство YearsCount определяет количество лет обучения (для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры)
    • Свойство AudHoursByYear[Year: Integer] возвращает и устанавливает количество аудиторных часов в учебном году с номером Year (нумеруются с нуля) (для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры).
    • Свойство WeeksByYear[Year: Integer] возвращает и устанавливает количество недель в учебном году с номером Year (нумеруются с нуля) (только для учебного плана лицея).
    • Свойство AudHoursByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает количество аудиторных часов в учебном периоде с номером Period (нумеруются с нуля) учебного года номером Year (нумеруются с нуля) (для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры).
    • Свойство WeeksByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает количество недель в учебном периоде с номером Period (нумеруются с нуля) учебного года номером Year (нумеруются с нуля) (только для учебного плана лицея).
    • Свойство ControlTypeByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает тип контоля в учебном периоде с номером Period (нумеруются с нуля) учебного года номером Year (нумеруются с нуля) (для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры).
    • Свойство StandCredits возвращает количество зачетных единиц по стандарту
    • Свойство StandMinCredits возвращает минимальное количество зачетных единиц по стандарту
    • Свойство StandMaxCredits возвращает максимальное количество зачетных единиц по стандарту
    • Свойство CreditsByYear[Year: Integer] возвращает и устанавливает количество зачетных единиц в учебном году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство EntireHoursByYear[Year: Integer] возвращает и устанавливает общее количество учебных часов в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство LectionHoursByYear[Year: Integer] возвращает и устанавливает количество учебных часов лекций в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство SeminarHoursByYear[Year: Integer] возвращает и устанавливает количество учебных часов семинаров в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство PracticeHoursByYear[Year: Integer] возвращает и устанавливает количество учебных часов практических занятий в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство SelfHoursByYear[Year: Integer] возвращает и устанавливает количество учебных часов самостоятельной работы в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство CreditsByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает количество зачетных единиц за период в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство ExamAudHoursByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает количество аудиторных часов на испытание за период в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство ExamEntireHoursByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает общее количество часов на испытание за период в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство CurrentControlsByYear[Year: Integer; const CurrentControlType: WideString] возвращает и устанавливает количество формы текущего контроля с идентификатором CurrentControlType за период в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство ItemStatus возвращает статус записи плана (для плана-предложения кафедры)
    • Свойство ProposalStatus возвращает статус предложения записи (для объединенного учебного плана)
    • Свойство ExamCountByYearByPeriod возвращает и устанавливает количество экзаменов в году с номером Year в учебном периоде с номером Period (для объединенного учебного плана).
    • Свойство TestCountByYearByPeriod возвращает и устанавливает количество зачетов в году с номером Year в учебном периоде с номером Period (для объединенного учебного плана).
    Соответствие между показателями учебного плана и элементами интерфейса IPlanItem представлено на рисунке:
    Показатели плана как члены интерфейса IPlanItem
    Показатели объединенного учебного плана
    Показатели плана-предложения кафедры


Расширение возможностей документирования пользовательских инструкций

Раздел целиком Одним файлом
Расширение возможностей документирования пользовательских инструкций

Помимо встроенных возможностей документирования, в Системе предусмотрена возможность интегрирования внешних систем создания файлов документации.

Возможности подобного интегрирования будут рассмотрены далее на примере программного обеспечения HELP&MANUAL версии 5.6.0 (страница для скачивания здесь ). HELP&MANUAL является инструментом для создания документации, а также системой управления контентом. Данный продукт является коммерческим.

  • Установка ПО
  • Создание проекта документации
  • Интеграция программы документирования с учетной системой


Установка ПО

Установка ПО

- Скачать дистрибутив программы с сайта разработчика ( http://www.helpandmanual.com/downloads.html )

- Запустить исполняемый файл установщика hmsetup.exe. Начнется процесс установки.

Первый экран установки программы - приветствие: Установка HM 1

Нажать "Next".

Экран лицензионного соглашения:

Установка HM 2

Выбрать пункт "I accept the agreement", нажать "Next".

Экран выбора директории установки:

Установка HM 3

Здесь необходимо выбрать папку на жестком диске компьютера для установки Help&Manual, нажать "Next".

Экран выбора компонентов программы для установки:

Установка HM 4

Можно оставить без изменений, нажать "Next".

Экран выбора наименования группы программ в меню "Start" ("Пуск"):

Установка HM 5

Нажать "Next".

Экран дополнительных установок:

Установка HM 6

Здесь можно указать, должен ли установщик разместить значок Help&Manual для запуска программы на рабочем столе компьютера. Сделать выбор, нажать "Next".

Сводный экран установки программы:

Установка HM 7

Здесь указаны все параметры установки программы, выбранные на предыдущих шагах. Если необходимо внести изменения в параметры, можно воспользоваться кнопкой "Back". Если все параметры верны, нажать кнопку "Install".

Начнется процесс установки программного обеспечения:

Установка HM 8

После установки будет выведен полседний экран:

Установка HM Finish

Чекбокс "Launch Help&Manual" позволяет запустить программное обеспечение сразу после нажатия на кнопку "Finish".

При первом запуске программы будет выведен запрос на ввод код активации полного функционала программы:

Здесь необходимо указать серийный номер (Serial Number) и код активации (Activation Code). Данная информация доступна после приобретения программы. После ввода нажать кнопку "ОК". Программа готова для работы.


Создание проекта документации

Создание проекта документации

После запуска программы будет выведено окно приветствия:

HM окно приветствия

Для создания нового проекта документации необходимо воспользоваться кнопкой или комбинацией клавиш "Alt+1".

HM new project

Откроется окно выбора параметров нового проекта:

HM параметры нового проекта 1

Оставляем параметры без изменений и нажимаем кнопку "Next".

Следующее окно параметров:

HM Окно выбора параметров нового проекта 2

В поле "Output File" необходимо указать название и место расположения на жестком диске файла проекта. Расширение файла оставляем без изменения. В поле "Project Title" можно ввести наименование проекта документации. В поле "Project Language" указывается язык проекта.

В поле "Character Set" должно быть установлено значение "RUSSIAN_CHARSET".

Нажать кнопку "Next".

Окно создания структуры проекта документации:

HM создание структуры документа

В этом окне можно задать предварительную структуру будущего документа. Пункты оглавления можно создавать, удалять, перемещать по списку. Структуру проекта можно будет изменять в дальнейшем в процессе работы. После нажатия кнопки "ОК" структура документа, описанная здесь, будет создана автоматически.

Главное окно программы:

HM главное окно

В левой части расположено навигационное дерево статей проекта документации, в правой отображается содержимое статей.

После того, как статьи созданы, необходимо добавить ключевые слова и фразы, для этого необходимо перейти на вкладку "Topic Options":

HM Topic Options Tab

Откроется окно установки свойств статьи:

HM Topic Options

Здесь в поле "Keywords" необходимо указать ключевые слова и фразы, по которым будет осуществляться переход из системы в соответствующую статью.

После того как все необходимые статьи созданы, ключевые фразы добавлены, файл документации нужно сохранить в формате chm. Для этого используется кнопка "Publish".

После ее нажатия будет выведено окно выбора формата конечного файла:

HM Выбор формата файла

Здесь выбирается вкладка "HTML Help (.chm)", указывается путь на жестком диске для сохранения.

После нажатия кнопки "ОК" файл будет сохранен в нужном формате.


Интеграция программы документирования с учетной системой

Интеграция программы документирования с учетной системой

Связь Системы и программы создания документации осуществляется при помощи ключевых слов и фраз. После того как статья документации получила ключевые слова или фразы, необходимо указать их в Системе.

Для примера разберем связывание соответствующей статьи файла документации и формы Зарегистрировать, вызываемой с помощью пункта контекстного меню "Зарегистрировать" из таблицы Абитуриенты бакалавриата раздела Абитуриенты бакалавриата текущего набора участка Абитуриент.

Форма Зарегистрировать абитуриента бакалавриата

Нам необходимо добиться, чтобы при нажатии на выделенную красным кнопку на этой форме был вызван документ chm, содержащий инструкции для пользователей. При этом должна открыться статья, содержащая сведения именно о процессе заполнения формы Зарегистрировать.

Созданный в программе Help&Manual файл документации, должен находится в одной папке с запускаемым файлом DataBrowser.exe обозревателя DataMill.

Подпрограмма "Зарегистрировать" ("Register") является дочерней по отношению к классу "Абитуриент бакалавриата" ("TBachAbiturSt").

В Системе нужно открыть раздел Системная форма участка Администратору. На вкладке Классы при помощи фильтра по имени или наименованию найти класс "Абитуриент бакалавриата" ("TBachAbiturSt"). В подчиненном представлении перейти на вкладку Подпрограммы и найти подпрограмму "Зарегистрировать" ("Register"). В подчиненном представлении перейти на вкладку Ключи контекстной помощи, вызвать контекстное меню и воспользоваться пунктом "Создать".

Откроется окно ввода параметров:

Создание ключа контекстной помощи

В поле "Ключевое словосочетание" указывается ключевое слово или фраза, в том виде как они прописаны в программе Help&Manual в свойствах соответствующей статьи.

В поле "Хранилище" указывается имя chm-файла документации без расширения, который содержит в себе данную статью.

После нажатия кнопки "Ок" ключ будет добавлен в таблицу.

Создание ключей контекстного поиска

Таким образом, после вызова справки из формы "Зарегистрировать" пользователь увидит соответствующую статью:

HM Вывод статьи

Если ключей несколько и они ссылаются на разные статьи или документы, то при нажатии в форме "Зарегистрировать" на кнопку вызова помощи, пользователю будет предложено на выбор несколько вариантов ссылок.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Рабочее место кафедры (раздел целиком) (31.03.2018) Одним файлом
Рабочее место кафедры

1. Настройка участка "Рабочее место кафедры"

Для установки настроек Кафедра пользователям участка Рабочее место кафедры необходимо выполнить следующие действия:

  1. На участке Кафедра открыть один из разделов:
    • Настройка пользователя кафедры ;
    • Справочники кафедры ;
    • Предложения кафедры в учебном году ;
    • Дисциплины учебных планов и успеваемость ;
    • Дисциплины кафедры в РУП.
  2. В основной таблице данных вызвать контекстное меню (щелчок правой клавишей мыши) и выбрать процедуру Настройка пользователя кафедры. Установка настроек 'кафедра' на участке "Рабочее место кафедры"
  3. Заполнить форму настроек и нажать кнопку ОК, после чего пользователю будут доступны только данные определенной кафедры.
    Форма настроеек пользователя кафедры
В разделе Справочники кафедры прежде чем вызывать контекстное меню, следует выбрать закладку Преподаватели кафедры из основной таблицы данных.

2. Работа с ведомостями

Для просмотра ведомостей кафедры, необходимо в форме Дисциплины учебных планов и успеваемость открыть таблицу Все ведомости кафедры. В данной таблице отображаются ведомости только по дисциплинам, реализуемым кафедрой, с которой работает текущий пользователь.

Пользователю доступны следующие действия по работе с ведомостями:

  1. Выгрузка на печать ведомости, сформированной пользователем факультета. Для этого необходимо в таблице Все ведомости кафедры выбрать запись с требуемой ведомостью и через контекстное меню вызвать действие "Ведомость для печати" или "Ведомость для печати (двуязычная)".

    Вывод ведомости на печать

    Откроется форма параметров, в которой при необходимости можно указать Фамилию ИО преподавателя, которая будет выводиться в ведомость. При нажатии кнопки "ОК" будет сформирована ведомость.

  2. Вывод на печать «Объединенной ведомости». Для этого необходимо в таблице Все ведомости кафедры выбрать записи ведомостей, которые должны попасть в «Объединенную ведомость» и через контекстное меню вызвать действие "Объединенная ведомость". При нажатии кнопки "ОК" будет сформирована «Объединенная ведомость», в которой заголовок ведомости сформируется по данным первой из ведомостей, включенных в список, а также в заголовке сформируется список ФИО всех преподавателей, присоединенных ко всем ведомостям списка. Основную часть ведомости будет составлять таблица со списком студентов, включенных во все ведомости из переданного списка.

Для того, чтобы преподаватели могли скачивать и распечатывать свои ведомости используя веб-браузер, предоставлена возможность работы с специализированным веб-сервисом печати ведомостей. Для доступа к веб-сервису на главной веб-странице системы расположена ссылка «Я – преподватель», ведущая на страницу работы с ведомостями.

3. Предложения кафедры в учебные планы

Функционал раздела "Предложения кафедры в учебные планы" позволяет пользователям кафедры создавать и редактировать группы дисциплин ("планы-предложения"), которые кафедра готова реализовывать для различных образовательных программ университета.

Объединение в "группы" ("планы-предложения") может использоваться для разделения дисциплин, предлагаемых для разных уровней образования, реализуемых в разные периоды, и планируемых по разным видам периодов - по модулям или по семестрам.

3.1. Создание плана-предложения кафедры

Для добавления нового "плана-предложения" необходимо:

  1. На участке Рабочее место кафедры выбрать раздел "Предложения кафедры в учебные планы".
  2. В основной таблице данных Планы-предложения кафедры с помощью контекстного меню вызвать действие Добавить план-предложение кафедры.
    Добавление плана предложения
  3. В форме добавления необходимо:
    Форма добавления плана предложения
    • В полях Филиал, Факультет, Кафедра - указать соответствующие значения, если до этого были установлены соответствующие настройки пользователя (Настройка участка "Рабочее место кафедры"), то эти параметры будут заполнены автоматически.
    • С помощью полей Год начала реализации, Уровень образования и Число лет можно создавать планы предложения кафедры, как на все годы, так и группировать дисциплины в разные планы по годам или по уровням образования.
    • В поле Реализуется по периодам - выбрать вид периодов реализации плана (по модулям или по семестрам).
    • В поле Количество периодов - ввести количество периодов в учебном году (число модулей или число семестров).
  4. Нажать кнопку ОК, после чего план-предложение кафедры будет добавлен.

3.2. Формирование плана-предложения кафедры

Наполнение и редактирование плана-предложения кафедры выполняется с помощью специальной Формы редактирования, для открытия которой необходимо в разделе "Предложения кафедры в учебные планы" выбрать требуемое план-предложение и через контекстное меню вызвать действие Открыть и указать параметры для открытия формы редактирования.
Форма параметров для открытия формы редактирования ПП

  • Если в форму редактирования нужно вклучить дисциплины других планов предложений кафедры, то в поле Включить дисциплины других планов необходимо установить значение "Да".
  • С помощью полей С учебного года и По учебный год установить период для открытия формы редактирования.

    При открытии в форме редактирования будут только дисциплины, которые реализуются хотя бы в одном из учебных годов между указанными в полях С учебного года и По учебный год.

    В форме редактирования для изменения периода нужно воспользоваться действием Параметры редактирования (правый верхний угол формы редактирования).

Редактирование плана-предложения заключается в добавлении в существующие разделы дисциплин или семинаров, распределении учебной нагрузки по видам (лекции, семинары, самостоятельная работа) и по учебным периодам. Для добавления записей в план предложение предназначены соответствующие действия контекстного меню. Для добавлении записи в определенный раздел нужно сначала выбрать заголовок этого раздела или одну из входящих в него записей.

Добавлять в план-предложение кафедры можно "дисциплины" и "научно-исследовательские семинары", для этого необходимо в уже открытой Форме редактирования в контекстном меню найти группу действий Добавить и выбрать одно из действий дисциплину... или научно-исследовательский семинар... Добавление дисциплины в план-предложение кафедры

В результате откроется окно параметров, в котором необходимо: Форма параметров добавление дисциплины в план-предложение кафедры

  • В поле Источник финансирования из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
  • Установить Год начала реализации и Год окончания реализации.
  • В поле Дисциплина вуза или Семинар (дисциплина вуза) - с помощью списка Список или справочника Справочник выбрать дисциплину или семинар для добавления.
  • При необходимости установить значения параметров в полях Имеет пререквизиты, На иностранном языке, Читается носителем языка.
  • В поле Формат изучения установить формат изучения дисциплины.
  • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
  • В полях Общее число часов, Аудиторных часов - указать соответствующие числовые характеристики добавляемой дисциплины или семинара.

После нажатия кнопки ОК, дисциплина (семинар) будет добавлена и ей будет присвоен свободный порядковый номер.

Для изменения периода реализации дисциплины или НИС необходимо использовать процедуру Изменить период реализации.

Дисциплины (семинары), входящие в план-предложение кафедры имеют свойство Статус. Сразу после создания дисциплины пользователем кафедры дисциплина получает статус "проект". Пока дисциплина находится в этом статусе, разработчики планов образовательных программ не видят эту дисциплину и не могут использовать ее в своих планах. Этот статус необходим для того, чтобы пользователь кафедры закончил работу со всеми необходимыми характеристиками дисциплины, а также задал ограничения на использование дисциплины в учебных планах.

3.3. Добавление нагрузки для дисциплин и НИС

В планах предложениях для каждой дисциплины нужно сформировать нагрузку, как по годам, так и периодам каждого года.

Для добавления нагрузки необходимо:

  1. В представлении Планы-предложения кафедры (форма Предложения кафедры в учебные планы) выбрать план предложение, для которого будет формироваться нагрузка.
  2. Вызвать из контекстного меню действие Открыть.
  3. В форме редактирования выбрать дисциплину или НИС, для которой добавляются данные о нагрузке.
  4. Для каждой дисциплины (НИС) в форме редактирования представлен набор параметров (каждому параметру соответствует своя колонка), с помощью которых можно задать нагрузку:
    Форма редактирования фформирование нагрузки в плане предложении
    • В полях Всего часов по дисциплине и Всего аудиторных часов по дисциплине можно отредактировать соответствующее количество часов за весь период реализации дисциплины.
    • Для каждого учебного года, в рамках которых реализуется дисциплина, необходимо указать значения полей Всего часов в году и Аудиторных часов в году, а также распределить часы по видам работ в группах полей Ауд. часы по видам работы, Самостоятельная работа.
      Если для какого-либо учебного года были внесены данные о нагрузке (указаны Всего часов в году, Аудиторных часов в году и т.д.), то в представлении Нагрузка по годам появится соответствующая запись о нагрузке в учебном году, для которого добавлена информация о нагрузке.
    • Для каждого отдельного периода (модуля/семестра) необходимо указать значения следующих полей: Аудиторных часов в периоде, Форма контроля (указывается если в данном периоде предусмотрен рубежный контроль), Аудиторных часов за часть дисциплины и Общих часов за часть дисциплины (если в данном периоде предусмотрен рубежный, то нужно указать количество аудиторных и общих часов, которое будет зачтено при прохождении рубежного контроля в данном периоде (модуле/семестре)).
      Если для какого-либо периода в учебном году были внесены данные о нагрузке, то в представлении Нагрузка по периодам года (представление подчиненно представлению Предлагаемые дисциплины и НИС по годам) появится соответствующая запись о нагрузке в периоде, для которого добавлена информация о нагрузке.

Допустим в форме редактирования плана-предложения требуется ввести данные для дисциплины "Иностранный язык", которая характеризуется следующим набором данных:

  • Продолжительность: с 1 по 4 модуль первого года обучения.
  • Рубежный контроль: во 2 модуле зачет; в 4 модуле экзамен.
  • Всего часов: 108 (из них всего аудиторных 68).
  • Распределение часов по видам работ: 68 часов практических занятий и 40 часов самостоятельной работы.
  • Распределение часов по периодам: в 1, 2 и 3 модуле по 16 ауд.часов и 10 часов самостоятельной работы; в 4 модуле 20 ауд. часов и 10 часов самостоятельной работы.

Для этого необходимо найти нужный план-предложение и открыть форму редактирования (действие Открыть из контекстного меню). В форме редактирования найти дисциплину "Иностранный язык" и в следующих полях указать соответствующие данные:

  1. В полях Всего часов по дисциплине и Всего аудиторных часов по дисциплине указать значения 108 и 68 часов соответственно.
  2. Для 1 года обучения указать:
    • в полях Всего часов в году и Аудиторных часов в году указать 108 и 68 часов соответственно;
    • в поле практические занятия 68 часов;
    • в поле самостоятельная работа 40 часов;
  3. Для 1 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • поля Форма контроля, Аудиторных часов за часть дисциплины и Общих часов за часть дисциплины необходимо оставить пустыми, так как рубежный контроль в данном периоде не предусмотрен и часы за данный период будут суммироваться в периоде, в котором встречается следующий рубежный контроль (во 2 модуле).
  4. Для 2 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • в поле Форма контроля установить форму контроля "Зачет";
    • в поле Аудиторных часов за часть дисциплины 32 часа (так как в 1 модуле рубежного контроля не было, то аудиторные часы за часть дисциплины в 1 модуле суммируются к часам 2 модуля).
    • в поле Общих часов за часть дисциплины 52 часа (так так как в 1 модуле рубежного контроля не было, то общие часы за часть дисциплины в 1 модуле суммируются к часам 2 модуля).
  5. Для 3 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • поля Форма контроля, Аудиторных часов за часть дисциплины и Общих часов за часть дисциплины необходимо оставить пустыми, так как рубежный контроль в данном периоде не предусмотрен и часы за данный период будут суммироваться в периоде, в котором встречается следующий рубежный контроль (в 4 модуле).
  6. Для 4 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • в поле Форма контроля установить форму контроля "Экзамен";
    • в поле Аудиторных часов за часть дисциплины 36 часа (так как в 3 модуле рубежного контроля не было, то аудиторные часы за часть дисциплины в 3 модуле суммируются к часам 4 модуля).
    • в поле Общих часов за часть дисциплины 56 часа (так так как в 3 модуле рубежного контроля не было, то общие часы за часть дисциплины в 3 модуле суммируются к часам 4 модуля).

3.4. Установка ограничений на использование дисциплины

Пользователям кафедры предоставлена возможность устанавливать ограничения на использование дисциплины в тех или иных учебных планах, часть ограничений следуют из характеристик плана-предложения кафедры, в который включена дисциплина: Год начала реализации, Уровень образования, Реализуется по периодам.

При необходимости для каждой отдельной дисциплины (семинара) можно дополнительно ограничить возможность выбора дисциплины:

  • по направлению (специальности) образовательной программы;
  • по филиалу образовательной программы;
  • по факультету образовательной программы;
  • по конкретной образовательной программе (или конкретному набору программ).

Для добавления ограничения необходимо:

  1. Открыть раздел "Предложения кафедры в учебные планы".
  2. В подчиненной таблице данных Предлагаемые дисциплины и НИС выбрать дисциплину (семинар), на которую необходимо установить ограничения.
  3. В подчиненной вкладке Ограничения на выбор дисциплины с помощью контекстного меню вызвать действие Добавить ограничение.
    Установка ограничения на выбор дисциплины
  4. В форме параметров:
    Форма добавления ограничений
    • Если существует потребность одновременно с добавлением новых ограничений удалить старые, то необходимо для признака Удалять существующие ограничения установить значение "Да".
    • Можно установить ограничения по виду плана, для этого необходимо в поле Вид учебного плана установить вид плана, которому должна быть доступна данная дисциплина. Для объединенного плана общевузовских дисциплин дополнительно можно указать ограничение по типу общевузовского плана (поле Тип общевузовского плана), а для объединенного майнора по виду майнора (поле Вид майнора).
    • Можно установить ограничения по уровню образованич, для этого необходимо установить значение "Да" для тех уровней образования, которым должна быть доступна дисциплина.
    • В поле Направления / специальности можно выбрать направления / специальности для установки ограничений, для этого нужно нажать кнопку Справочник и с помощью чек-бокса Чек-бокс выбрать одно и более записей, после чего нажать кнопку ОК. Все выбранные записи отобразятся в поле Направления / специальности.
      Поле Направления / специальности будет доступно для установки ограничений, только если в поле Вид учебного плана установлено пустое значение или "Объединенный учебный план".
    • Аналогично направлениям / специальностям можно установить одно и более ограничений по Филиалу, Факультету, Образовательной программе и Курсу студентов.

      Для вида учебного плана "Объединенный план общевузовских дисциплин" поля для установки ограничений Филиал, Факультет, Образовательная программа и Курс студентов будут недоступны.

      Для вида учебного плана "Объединенный майнор" поля для установки ограничений Факультет, Образовательная программа и Курс студентов будут недоступны.

      Для вида учебного плана "Объединенный план факультетских дисциплин" поля для установки ограничений Образовательная программа и Курс студентов будут недоступны.

  5. После нажатия кнопки ОК будут созданы все возможные варианты ограничений с учетом установленных значений в форме параметров.
Если нужно задать ограничение таким образом, чтобы оно действовало не по одному, а по нескольким (но не всем) значениям, нужно добавить несколько подобных ограничений (например, добавить несколько ограничений, указав отдельные образовательные программы; в этом случае дисциплину можно будет использовать только в учебных планах этих конкретных образовательных программ).

3.5. Статусы дисциплин плана-предложения

Каждая дисциплина (НИС) в плане-предложении может находиться в одном из статусов:

  • проект;
  • заявка на дисциплину;
  • принята кафедрой;
  • отклонена;
  • утверждена.

Для изменения статуса пользователю кафедры необходимо открыть раздел Предложения кафедры в учебные планы и в таблице данных Предлагаемые дисциплины и НИС выбрать дисциплину, в контекстном меню системы найти группу действий Изменить статус и вызвать одно из действий: Принять к реализации, Вернуть в статус "проект", Утвердить реализацию, Отклонить реализацию.

При добавлении в план-предложение дисциплина получает статус "проект". После добавления пользователь кафедры должен максимально полно занести данные о нагрузке по дисциплине, ее распределении по видам работ и по периодам обучения, задать формы текущего и рубежного контроля. Эта информация будет необходима пользователям-разработчикам учебных планов для принятия решения о включении или невключении дисциплины в свои планы. Также, пока дисциплина находится в статусе "проект", пользователь кафедры должен занести ограничения на использование дисциплины. Из статуса "проект" пользователь кафедры может перевести дисциплину в статус "принята кафедрой" при помощи действия Принять к реализации. Дисциплины в статусе "принята кафедрой" становятся доступными для выбора пользователями - разработчиками учебных планов.

Для дисциплины в статусе "принята кафедрой" возможно выполнение действия Вернуть в статус "проект", однако выполнить это действие будет возможно только в случае, если дисциплина еще не включена ни в один из учебных планов.

Дисциплина может оказаться включенной в план-предложение кафедры разработчиком одного из учебных планов. В этом случае дисциплина появится в плане-предложении кафедры без непосредственного участия пользователя кафедры. Такие дисциплины будут появляться в статусе "заявка на дисциплину". Над дисциплиной в статусе "заявка на дисциплину" пользователь кафедры может выполнять следующие операции:

  • вносить изменения в данные о нагрузке по дисциплине;
  • выполнить для этой дисциплины действие Принять к реализации, в этом случае дисциплина перейдет в статус "принята кафедрой" ;
  • выполнить для этой дисциплины действие Отклонить реализацию ;
  • "объединить" дисциплину с какой-то другой из дисциплин своей кафедры; эта операция предусмотрена для случаев, когда пользователь кафедры считает, что разработчик учебного плана излишне создал дисциплину, и в учебном плане можно использовать другую схожую дисциплину со схожими параметрами нагрузки.

Пользователь кафедры может вносить изменения в данные о дисциплинах своей кафедры на разных этапах работы с учебными планам. Все изменения, сделанные пользователем кафедры, будут сразу же применяться ко всем учебным планам образовательных программ, в которых они задействованы. Однако перед "утверждением" учебных планов внесение изменений в данные о дисциплинах должно быть прекращено. Для фиксации такого состояния предназначен статус дисциплины "утверждена". Этот статус означает, что изменения в данные о дисциплине больше не вносятся. Перевести дисциплину в статус "утверждена" можно при помощи действия Утвердить реализацию.

3.6. Печать плана-предложения кафедры

Для выгрузки плана-предложения кафедры для печати необходимо в форме Предложения кафедры в учебные планы (таблица данных Планы-предложения кафедры) из контекстного меню вызвать действие Выгрузить для печати.
Вызов процедуры Выгрузить для печати план-предложение кафедры

В результате сформируется и откроется Excel-файл, содержащий всю информацию о плане-предложении.

3.7. Изменение периода реализации дисциплины или НИС

Для изменения периода реализации дисциплины или НИС, необходимо:

  1. В представлении Планы-предложения кафедры (форма Предложения кафедры в учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Предлагаемые дисциплины и НИС выбрать дисциплину или НИС, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

4. Планирование реализации дисциплин

Для планирования реализации дисциплин и НИС, преподаваемых кафедрой, необходимо выполнить формирование предметных единиц (предметных потоков, предметных групп, предметных подгрупп) для всех дисциплин и НИС, которые будут преподаваться кафедрой в очередном учебном году. Данные предметные единицы будут использованы при планировании нагрузки, для составления расписания занятий, для оценки фактически выполненной кафедрой учебной нагрузки.

В форме Планирование реализации дисциплин на вкладке Студенты, изучающие дисциплину, можно увидеть список студентов, которым дисциплина уже назначена. На основе этой информации можно оценить необходимое количество предметных потоков, групп, подгрупп. По мере включения академических групп в предметные единицы и распределения студентов по предметным единицам эта информация будет отображаться на подчиненных вкладках Связанные академические группы и на вкладке Студенты, изучающие дисциплину в колонках Предметный поток, Предметная группа, Предметная подгруппа, отдельно по каждому студенту.

Пользователи кафедр формируют предметные единицы, устанавливают максимальное количество студентов, которое может быть в них включено, и накладывают ограничения на использование предметных единиц. Включение студентов в предметные единицы будут выполнять Менеджеры образовательных программ, ответственные за организацию обучения студентов. Менеджерам образовательных программ будут доступны предметные единицы с учетом наложенных ограничений и они не смогут включить в предметную единицу больше студентов, чем установлено пользователем кафедры. Для случаев, когда кафедра не считает нужным ограничивать количество студентов, которые могут быть включены в предметную единицу, атрибут Максимальное количество студентов можно оставить пустым.

Формирование предметных единиц обязательное действие в следующих случаях:

  1. Создание предметных потоков для дисциплин обязательно, если есть лекции, проведение экзаменов в письменной форме.
  2. Создание предметных потоков для НИС обязательно во всех случаях.
  3. Создание предметных групп для дисциплин обязательно, если есть семинары, тренинги; при обучении по семестрам (для учета консультаций перед экзаменом).
  4. Создание предметных групп для НИС обязательно во всех случаях
  5. Создание предметных подгрупп для дисциплин обязательно, если есть практические, лабораторные работы, мастер-классы.
  6. Создание предметных подгрупп для НИС необязательно.

Для формирования предметных единиц необходимо выполнить ряд действий:

4.1. Формирование предметных потоков

Представление (таблица данных) Предметные потоки содержит перечень предметных потоков для каждой дисциплины кафедры. Для добавления предметных потоков необходимо:

Создание предметных потоков обязательно:
  1. Для всех НИС.
  2. Для дисциплин, если есть лекции, проведение экзаменов в письменной форме.
  1. Открыть раздел Планирование реализации дисциплин и выбрать дисциплину или НИС, для которой будут формироваться предметные единицы.
  2. В подчиненном представлении (таблице данных) Предметные потоки из контекстного меню вызвать действие Добавить предметный поток.
    Вызвов действия добавить предметный поток
  3. В форме параметров ввести Краткое наименование, при необходимости можно ограничить число студентов в потоке, указав Максимальное количество студентов на потоке.
  4. Нажать кнопку ОК.

Для редактирования существующих записей предметных единиц, необходимо дважды щелкнуть левой клавишей мыши по ячейке с параметром, который нужно изменить, ввести новое значение и нажать кнопку Enter.

После того как предметная единица была создана необходимо установить ограничения на ее использование см. Установка ограничений на использование предметных единиц.

4.2. Формирование предметных групп

Представление (таблица данных) Предметные группы содержит перечень предметных групп для каждой дисциплины кафедры. Предметные группы можно связывать с предметными потоками (в случаях, когда предметный поток формируется из определенных предметных групп), а можно создавать без связи с предметными потоками. Для добавления предметных групп необходимо:

Создание предметных групп обязательно:
  1. Для всех НИС.
  2. Для дисциплин, если есть семинары, тренинги; при обучении по семестрам (для учета консультаций перед экзаменом).
  1. Открыть раздел Планирование реализации дисциплин и выбрать дисциплину или НИС, для которой будут формироваться предметные единицы.
  2. В подчиненном представлении (таблице данных) Предметные группы из контекстного меню вызвать действие Добавить предметную группу.
    Вызов действия добавить предметную группу
  3. В форме параметров ввести Краткое наименование, при необходимости можно ограничить число студентов в группе, указав Максимальное количество студентов в группе. Также можно установить связь группы с потоком, выбрав в поле Входит в предметный поток соответствующий поток из справочника Предметные потоки (кнопка Справочник).
  4. Нажать кнопку ОК.

Для редактирования существующих записей предметных единиц, необходимо дважды щелкнуть левой клавишей мыши по ячейке с параметром, который нужно изменить, ввести новое значение и нажать кнопку Enter.

После того как предметная единица была создана необходимо установить ограничения на ее использование см.Установка ограничений на использование предметных единиц.

4.3. Формирование предметных подгрупп

Представление (таблица данных) Предметные подгруппы содержит перечень предметных подгрупп для каждой дисциплины кафедры. Предметные подгруппы можно связывать с предметными группами, а можно создавать независимо от предметных групп. Для добавления предметных подгрупп необходимо:

  1. Открыть раздел Планирование реализации дисциплин и выбрать дисциплину или НИС, для которой будут формироваться предметные единицы.
  2. В подчиненном представлении (таблице данных) Предметные подгруппы из контекстного меню вызвать действие Добавить предметную подгруппу.
    Вызов действия добавить предметную подгруппу
  3. В форме параметров ввести Краткое наименование, при необходимости можно ограничить число студентов в подгруппе, указав Максимальное количество студентов в подгруппе. Также можно установить связь подгруппы с группой, выбрав в поле Входит в предметную группу соответствующую группу из справочника Предметные группы (кнопка Справочник).
  4. Нажать кнопку ОК.

Для редактирования существующих записей предметных единиц, необходимо дважды щелкнуть левой клавишей мыши по ячейке со значением атрибута, который нужно изменить, ввести новое значение и нажать кнопку Enter.

Создание предметных подгрупп обязательно только для дисциплин, если есть практические, лабораторные работы, мастер-классы. Формирование предметных подгрупп для НИС необязательно.

После того как предметная единица была создана необходимо установить ограничения на ее использование см.Установка ограничений на использование предметных единиц

4.4. Установка ограничений на использование предметных единиц

После того как предметные единицы были созданы (см. Формирование предметных потоков, Формирование предметных групп и Формирование предметных подгрупп) необходимо установить ограничения на их использование, для этого необходимо:
Если предметная единица должна быть доступна Менеджерам образовательных программ всех Филиалов, Факультетов и Образовательных программ, то устанавливать ограничения нет необходимости.

  1. Открыть представление (таблицу данных) Предметные потоки, Предметные группы или Предметные подгруппы и выбрать предметную единицу.
  2. В подчиненном представлении (таблице данных) Ограничения использования потока, Ограничения использования группы или Ограничения использования подгруппы из контекстного меню вызвать действие Добавить ограничение.
    Вызов действия Добавить ограничение
  3. В форме установить Филиал, Факультет (при необходимости) и Образовательную программу (при необходимости).
  4. Нажать кнопку ОК. После чего предметная единица будет доступна только Менеджерам образовательных программ добавленного в ограничения Филиала, Факультета и Образовательной программы.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Редактирование объединенного плана общевузовских дисциплин (раздел целиком) (31.03.2018) Одним файлом
Редактирование объединенного плана общевузовских дисциплин

Редактирование объединенного плана общевузовских дисциплин состоит в наполнении его дисциплинами, НИС, или дисциплинами иностранных студентов, которые могут быть объединены в группы, уточнении объема нагрузки, установке форм итогового контроля.

Объединенный план может состоять из следующих видов записей: разделы (группы дисциплин), дисциплины, НИС и Дисциплины иностранных студентов. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в план записей других типов (курсовые, практики и проч.) недопустимо.

Редактирование объединенного плана выполняется при помощи специализированной формы редактирования, которая открывается при вызове для выбранного учебного плана действия Открыть или при двойном щелчке мышью по записи об учебном плане.

Редактирование объединенного плана общевузовских дисциплин

Добавление и удаление записей учебного плана, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню.

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

Редактирование записей объединенного плана

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

По окончании работы с объединенным планом его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати или Выгрузить для печати как РУП расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия учебный план будет выгружен для печати в MS Excel.

1. Добавление раздела (группы дисциплин)

Для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Добавление группы дисциплин в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

2. Добавление дисциплины

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать действие дисциплину,

Процедура добавление дисциплины в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный план общевузовских дисциплин
Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

    • После того как запись о дисциплине будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с записью дисциплины, предлагаемой кафедрой, разработчик объедиеннного учебного плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

3. Добавление НИС

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать действие научно-исследовательский семинар,

Процедура добавление НИС в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный план общевузовских дисциплин
Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Семинар, предлагаемый кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего будет добавлен в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Семинар, предлагаемый кафедрой оставить пустым.
    • в поле Семинар (дисциплина ВУЗа) указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.

    • После того как запись о НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания семинара с дисциплиной-предложением кафедры разработчик объединенного учебного плана больше не сможет изменять параметры нагрузки по семинару, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

4. Добавление дисциплины иностранных студентов

Добавлять Дисциплины для иностранных студентов можно только в объединенные планы общевузовских дисциплин, у которых при создании Тип общевузовского плана был установлен как "Дисциплины для иностранных студентов". (см. Создание нового объединенного плана общевузовских дисциплин).

Для добавления Дисциплины иностранных студентов необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие дисциплину иностранных студентов,

Процедура добавление дисциплины иностранных студентов в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины иностранных студентов в объединенный план общевузовских дисциплин
  1. В поле Кафедра задать кафедру, которая будет вести дисциплину.
  2. в поле Дисциплина для иностранных студентов указать требуемую дисциплину, для этого необходимо открыть справочник Все дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Все дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
  3. Заполнить поля: Имеет пререквизиты, Код записи, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  4. Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соотвествующую область науки из выпадающего списка Список или с помощью справочника Справочник.
  5. Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

Отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля) можно непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице, предназначено действие Дополнительные свойства.

Редактирование записей объединенного плана

При необходимости вновь созданную дисципину для иностранных студентов можно связать с записью дисциплины, предлагаемой к реализации кафедрами, для этого:

  1. Из контекстного меню нужно вызвать действие Связать с предложением кафедры. При помощи параметров этой процедуры можно попытаться поискать подходящую дисциплину. Можно выполнить поиск не точно такой же, а "похожей" дисциплины. Для этого нужно очистить значение в поле Дисциплина для выбора и снова поискать дисциплину в поле Предложение кафедры. Можно также очистить поле Кафедра и поискать дисциплину на всех кафедрах. Если походящая дисциплина найдена, ее нужно выбрать и нажать кнопку ОК.
  2. Если же подходящей дисциплины так и не найдено, нужно заполнить кафедру в поле Кафедра и установить флажок Создать заявку на дисциплину (флажок доступен при условии, что кафедра задана, а поле "Предложение кафедры" пустое), после чего нажать кнопку ОК. В результате будет выполнен поиск плана-предложения кафедры с атрибутами Год начала реализации, Уровень образования, Реализуется по периодам, соответствующими атрибутам учебного плана; если такого плана-предложения найдено не будет, он будет создан для указанной кафедры. В найденный или созданный план-предложение будет добавлена дисциплина со всей информацией о нагрузке, раннее занесенной для нее в учебном плане; дисциплина в плане-предложении кафедры получит статус "заявка на дисциплину".

После связывания дисциплины плана с дисциплиной, предлагаемой кафедрой, разработчик объединенного учебного плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

5. Перемещение записей

В случае если при добавлении Группы дисциплин или Дисциплины (НИС, Дисциплины иностранных студентов) был неверно указан раздел, куда они должны быть включены, то в отношении такой записи необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить запись, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина (НИС, Дисциплины иностранных студентов) будет перемещена в корень объединенного плана общевузовских дисциплин.

Также для изменения порядка следования записей можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

6. Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные планы общевузовских дисциплин (форма Учебные планы общевузовских дисциплин) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи плана выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

7. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

8. Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных планов общевузовских дисциплин выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Расширение возможностей документирования пользовательских инструкций (раздел целиком) (31.03.2018) Одним файлом
Расширение возможностей документирования пользовательских инструкций

Помимо встроенных возможностей документирования, в Системе предусмотрена возможность интегрирования внешних систем создания файлов документации.

Возможности подобного интегрирования будут рассмотрены далее на примере программного обеспечения HELP&MANUAL версии 5.6.0 (страница для скачивания здесь ). HELP&MANUAL является инструментом для создания документации, а также системой управления контентом. Данный продукт является коммерческим.

1. Установка ПО

- Скачать дистрибутив программы с сайта разработчика ( http://www.helpandmanual.com/downloads.html )

- Запустить исполняемый файл установщика hmsetup.exe. Начнется процесс установки.

Первый экран установки программы - приветствие: Установка HM 1

Нажать "Next".

Экран лицензионного соглашения:

Установка HM 2

Выбрать пункт "I accept the agreement", нажать "Next".

Экран выбора директории установки:

Установка HM 3

Здесь необходимо выбрать папку на жестком диске компьютера для установки Help&Manual, нажать "Next".

Экран выбора компонентов программы для установки:

Установка HM 4

Можно оставить без изменений, нажать "Next".

Экран выбора наименования группы программ в меню "Start" ("Пуск"):

Установка HM 5

Нажать "Next".

Экран дополнительных установок:

Установка HM 6

Здесь можно указать, должен ли установщик разместить значок Help&Manual для запуска программы на рабочем столе компьютера. Сделать выбор, нажать "Next".

Сводный экран установки программы:

Установка HM 7

Здесь указаны все параметры установки программы, выбранные на предыдущих шагах. Если необходимо внести изменения в параметры, можно воспользоваться кнопкой "Back". Если все параметры верны, нажать кнопку "Install".

Начнется процесс установки программного обеспечения:

Установка HM 8

После установки будет выведен полседний экран:

Установка HM Finish

Чекбокс "Launch Help&Manual" позволяет запустить программное обеспечение сразу после нажатия на кнопку "Finish".

При первом запуске программы будет выведен запрос на ввод код активации полного функционала программы:

Здесь необходимо указать серийный номер (Serial Number) и код активации (Activation Code). Данная информация доступна после приобретения программы. После ввода нажать кнопку "ОК". Программа готова для работы.

2. Создание проекта документации

После запуска программы будет выведено окно приветствия:

HM окно приветствия

Для создания нового проекта документации необходимо воспользоваться кнопкой или комбинацией клавиш "Alt+1".

HM new project

Откроется окно выбора параметров нового проекта:

HM параметры нового проекта 1

Оставляем параметры без изменений и нажимаем кнопку "Next".

Следующее окно параметров:

HM Окно выбора параметров нового проекта 2

В поле "Output File" необходимо указать название и место расположения на жестком диске файла проекта. Расширение файла оставляем без изменения. В поле "Project Title" можно ввести наименование проекта документации. В поле "Project Language" указывается язык проекта.

В поле "Character Set" должно быть установлено значение "RUSSIAN_CHARSET".

Нажать кнопку "Next".

Окно создания структуры проекта документации:

HM создание структуры документа

В этом окне можно задать предварительную структуру будущего документа. Пункты оглавления можно создавать, удалять, перемещать по списку. Структуру проекта можно будет изменять в дальнейшем в процессе работы. После нажатия кнопки "ОК" структура документа, описанная здесь, будет создана автоматически.

Главное окно программы:

HM главное окно

В левой части расположено навигационное дерево статей проекта документации, в правой отображается содержимое статей.

После того, как статьи созданы, необходимо добавить ключевые слова и фразы, для этого необходимо перейти на вкладку "Topic Options":

HM Topic Options Tab

Откроется окно установки свойств статьи:

HM Topic Options

Здесь в поле "Keywords" необходимо указать ключевые слова и фразы, по которым будет осуществляться переход из системы в соответствующую статью.

После того как все необходимые статьи созданы, ключевые фразы добавлены, файл документации нужно сохранить в формате chm. Для этого используется кнопка "Publish".

После ее нажатия будет выведено окно выбора формата конечного файла:

HM Выбор формата файла

Здесь выбирается вкладка "HTML Help (.chm)", указывается путь на жестком диске для сохранения.

После нажатия кнопки "ОК" файл будет сохранен в нужном формате.

3. Интеграция программы документирования с учетной системой

Связь Системы и программы создания документации осуществляется при помощи ключевых слов и фраз. После того как статья документации получила ключевые слова или фразы, необходимо указать их в Системе.

Для примера разберем связывание соответствующей статьи файла документации и формы Зарегистрировать, вызываемой с помощью пункта контекстного меню "Зарегистрировать" из таблицы Абитуриенты бакалавриата раздела Абитуриенты бакалавриата текущего набора участка Абитуриент.

Форма Зарегистрировать абитуриента бакалавриата

Нам необходимо добиться, чтобы при нажатии на выделенную красным кнопку на этой форме был вызван документ chm, содержащий инструкции для пользователей. При этом должна открыться статья, содержащая сведения именно о процессе заполнения формы Зарегистрировать.

Созданный в программе Help&Manual файл документации, должен находится в одной папке с запускаемым файлом DataBrowser.exe обозревателя DataMill.

Подпрограмма "Зарегистрировать" ("Register") является дочерней по отношению к классу "Абитуриент бакалавриата" ("TBachAbiturSt").

В Системе нужно открыть раздел Системная форма участка Администратору. На вкладке Классы при помощи фильтра по имени или наименованию найти класс "Абитуриент бакалавриата" ("TBachAbiturSt"). В подчиненном представлении перейти на вкладку Подпрограммы и найти подпрограмму "Зарегистрировать" ("Register"). В подчиненном представлении перейти на вкладку Ключи контекстной помощи, вызвать контекстное меню и воспользоваться пунктом "Создать".

Откроется окно ввода параметров:

Создание ключа контекстной помощи

В поле "Ключевое словосочетание" указывается ключевое слово или фраза, в том виде как они прописаны в программе Help&Manual в свойствах соответствующей статьи.

В поле "Хранилище" указывается имя chm-файла документации без расширения, который содержит в себе данную статью.

После нажатия кнопки "Ок" ключ будет добавлен в таблицу.

Создание ключей контекстного поиска

Таким образом, после вызова справки из формы "Зарегистрировать" пользователь увидит соответствующую статью:

HM Вывод статьи

Если ключей несколько и они ссылаются на разные статьи или документы, то при нажатии в форме "Зарегистрировать" на кнопку вызова помощи, пользователю будет предложено на выбор несколько вариантов ссылок.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Работа с компетенциями оригинальных стандартов (раздел целиком) (31.03.2018) Одним файлом
Работа с компетенциями оригинальных стандартов

В данном разделе описана реализованная в системе функциональность работы с системой компетенций. Ссистема компетенций может включать компетенции следующих видов:

  • Универсальные (системные) компетенции являются общими для всех направлений подготовки.
  • Профессиональные (инструментальные, социально-личностные) компетенции связаны с видами профессиональной деятельности.

Система компетенций состоит из общевузовских классификаторов компетенций трех основных видов: системных, социально-личностных и инструментальных, а также из перечня компетенций, формируемого для каждого из оригинальных образовательных стандартов на базе общевузовских справочников. Система компетенций включает в себя кодификацию, позволяющую отражать типологию компетенций, порядок их следования и взаимную связь друг с другом.

Работа с компетенциями оригинальных стандартов ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты.

Работа по формированию компетенций для каждого из образовательных стандартов должна включать следующие этапы:

  1. Формирование общевузовских справочников компетенций всех трех видов.
  2. Формирование перечня компетенций для образовательного стандарта, заключающееся в первичном наполнении перечня компетенциями из общевузовского справочника с дальнейшим уточнением их состава и содержания. Работа по уточнению перечня компетенций для стандарта ведется по-разному в зависимости от вида компетенции. Особенности работы с компетенциями разных видов описаны в следующих ниже разделах.

1. Общевузовские справочники компетенций

Работа по формированию системы компетенций оригинальных образовательных стандартов должна быть начата с формирования общевузовских классификаторов компетенций каждого из трех видов системных, социально-личностных и инструментальных.

Порядок работы с данными справочниками не существенен, однако до начала формирования перечней компетенций для конкретных образовательных стандартов общевузовские справочники компетенций должны быть сформированы полностью.

1.1. Системные (универсальные) компетенции

Работа с общевузовским справочником системных (универсальных) компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Системные компетенции.

Системные компетенции. Общевузовский справочник

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая системная компетенция имеет код и порядковый номер. Коды системных компетенций формируются автоматически из префикса СК-, символа уровня образования (Б или М) и порядкового номера (например, "СК-Б01", "СК-Б03", "СК-М08", "СК-М15"). Смысловое содержание компетенции представлено в поле Формулировка компетентностных образовательных результатов.

Для наполнения или уточнения общевузовского справочника системных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить системную компетенцию
  • Изменить порядковый номер
  • Удалить компетенцию
Уточнять текстовую формулировку компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter.

Добавление компетенции

Для того, чтобы добавить в справочник новую системную компетенцию, нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить системную компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление системной компетенции в общевузовский справочник

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Код компетенции значение будет составлено автоматически из префикса "СК-" (системная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура) и порядкового номера компетенции. Для порядковых номеров меньших 10 в первой позиции будет дописан 0. Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Формулировка компетентностных образовательных результатов значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой системной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера (кода) компетенции

Для изменения порядка следования компетенций предусмотрено действие контекстного меню Изменить порядковый номер. При изменении порядкового номера соответствующим образом изменится и код компетенции.

Изменение порядкового номера системной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции. При его изменении будет изменяться и код компетенции. Повтор порядковых номер компетенций недопустим. При попытке изменить порядковый номер компетенции на существующий произойдет ошибка дублирования объектов.

1.2. Социально-личностные компетенции

Работа с общевузовским справочником социально-личностных компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Социально-личностные компетенции.

Социально-личностные компетенции. Общевузовский справочник

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая социально-личностная компетенция имеет код и порядковый номер. Коды социально-личностных компетенций формируются автоматически из префикса СЛК-, символа уровня образования (Б или М) и порядкового номера (например, "СЛК-Б05", "СЛК-Б12", "СЛК-М02", "СЛК-М11"). Смысловое содержание компетенции представлено в поле Формулировка компетентностных образовательных результатов.

Для наполнения или уточнения общевузовского справочника социально-личностных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить социально-личностную компетенцию
  • Изменить порядковый номер
  • Удалить компетенцию
Уточнять текстовую формулировку компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter.

Добавление компетенции

Для того, чтобы добавить в справочник новую социально-личностную компетенцию, нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить социально-личностную компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление социально-личностной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Код компетенции значение будет составлено автоматически из префикса "СЛК-" (социально-личностная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура) и порядкового номера компетенции. Для порядковых номеров меньших 10 в первой позиции будет дописан 0. Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Формулировка компетентностных образовательных результатов значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера (кода) компетенции

Для изменения порядка следования компетенций предусмотрено действие контекстного меню Изменить порядковый номер. При изменении порядкового номера соответствующим образом изменится и код компетенции.

Изменение порядкового номера социально-личностной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции. При его изменении будет изменяться и код компетенции. Повтор порядковых номер компетенций недопустим. При попытке изменить порядковый номер компетенции на существующий произойдет ошибка дублирования объектов.

1.3. Инструментальные компетенции

Работа с общевузовским справочником инструментальных компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Инструментальные компетенции.

Инструментальные компетенции. Общевузовский справочник

Справочник имеет иерархическую структуру, которая отражает конкретизацию компетенций. Компетенции первого уровня являются наиболее общими и обозначают укрупненные виды деятельности (проектная деятельность, общение и коммуникация и проч.). Компетенция, которую конкретизирует данная компетенция, далее будет называться "родительской", а те компетенции, которые, в свою очередь, конкретизируют данную, будут называться "дочерними". Например, на представленном выше рисунке по отношению к компетенции "ИК-Б1.1 участвовать" родительской является компетенция "ИК-Б1 Проектная и иная деятельность", а дочерними являются компетенции "ИК-Б1.1н в научной деятельности" и "ИК-Б1.1и в исследовательской деятельности".

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая инструментальная компетенция имеет код и порядковый номер, а также может иметь символьное обозначение. Коды социально-личностных компетенций формируются автоматически из префикса ИК-, символа уровня образования (Б или М), собственного порядкового номера и порядковых номеров родительских компетенций, разделенных точкой, и символьного обозначения (при его наличии). Например, коды инструментальных компетенций могут иметь следующий вид: "ИК-Б1", "ИК-Б2.3", "ИК-М3.1и", "ИК-М2.2э". Для инструментальных компетенций в справочник заносится только наименование. Формулировки компетентностных образовательных результатов для компетенций данного вида будут задаваться отдельно для каждого из образовательных стандартов. Также в справочнике отображается формируемое автоматически полное наименование компетенции, составленное из наименования самой компетенции и всех ее родительских компетенций, разделенных символами "/".

Для наполнения или уточнения общевузовского справочника инструментальных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить компетенцию на первый уровень
  • Добавить дочернюю компетенцию
  • Изменить порядковый номер или символьное обозначение
  • Изменить родительскую компетенцию
  • Удалить компетенцию
Уточнять наименование компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter. Полное наименование компетенции при этом изменится автоматически.

Добавление компетенции

Для добавления инструментальных компетенций предусмотрено два действия: Добавить компетенцию на первый уровень и Добавить дочернюю компетенцию. Выбор действия зависит от того, нужно ли добавить самостоятельную компетенцию первого уровня, соответствующую укрупненному виду деятельности, которая не будет иметь родительской компетенции, или нужно добавить компетенцию, уточняющую одну из существующих (дочернюю по отношению к существующей).

Для добавления самостоятельной компетенции первого уровня нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить компетенцию на первый уровень. Отобразиться форма параметров процедуры добавления:

Добавление инструментальной компетенции на первый уровень

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего на первом уровне для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Символьное обозначение можно ввести символ, дополняющий код компетенции, если это необходимо. Если символьное обозначение для данной компетенции не используется, поле нужно оставить пустым.
  • В поле Код компетенции значение будет составлено автоматически из префикса "ИК-" (инструментальная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура), порядкового номера компетенции, символьного обозначения (если оно использовано). Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Наименование компетенции значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Для добавления компетенции, конкретизирующей одну из существующих, нужно сначала выбрать существующую (родительскую) компетенцию, которая должна быть конкретизирована, после чего вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить дочернюю компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление дочерней инструментальной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Родительская компетенция будет отображен код родительской компетенции, которая была выбрана в таблице данных перед вызовом действия добавления. Если новая компетенция должна быть подчинена другой родительской компетенции, то нужно закрыть данную форму при помощи кнопки Отмена, выбрать в таблице данных нужную родительскую компетенцию и снова вызвать действие добавления дочерней компетенции.
  • В поле Уровень образования значение будет подставлено автоматически на основе выбранной родительской компетенции. Изменять это значение при добавлении недопустимо. Если нужно добавить компетенцию для другого уровня образования, то нужно закрыть данную форму, выбрать в таблице данных родительскую компетенцию, принадлежащую к другому уровню образования и повторить добавление.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего на данном уровне иерархии для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Символьное обозначение можно ввести символ, дополняющий код компетенции, если это необходимо. Если символьное обозначение для данной компетенции не используется, поле нужно оставить пустым.
  • В поле Код компетенции значение будет составлено автоматически из префикса "ИК-" (инструментальная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура), порядкового номера компетенции и ее родительских компетенций, символьного обозначения (если оно использовано). Управлять значением данного поля можно изменяя порядковый номер, символьное значение или выбрав другую родительскую компетенцию перед добавлением.
  • В поле Наименование компетенции значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Удаление компетенции, имеющей дочерние компетенции, недопустимо. Если такую компетенцию все же надо удалить, то сначала нужно удалить все ее дочерние компетенции.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера и символьного обозначения компетенции

Для изменения порядка следования компетенций и их символьных обозначений предусмотрено действие контекстного меню Изменить порядковый номер или символьное обозначение. При изменении порядкового номера или символьного обозначения соответствующим образом изменится и код компетенции.

Изменение порядкового номера или символьного обозначения инструментальной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции и символьное обозначение. При изменении этих значений будет изменяться и код компетенции. Повтор полученных кодов компетенций недопустим. При попытке изменить порядковый номер или символьное обозначение таким образом, что полученный код компетенции будет повторять один из существующих, произойдет ошибка дублирования объектов.

Перенос компетенций по иерархической структуре

Для того, чтобы перенести существующую компетенцию по структуре (т.е. изменить для нее родительскую компетенцию), можно воспользоваться действием Изменить родительскую компетенцию.

Изменение родительской компетенции для инструментальной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Родительская компетенция нужно выбрать другую компетенцию из предложенного перечня, которая должна стать родительской по отношению к данной.
  • Значение полей Уровень образования и Наименование компетенции при использовании данной процедуры изменять нельзя.
  • В полях Порядковый номер и Символьное обозначение можно изменять значения описанным выше образом. Также при этом будет изменяться значение в поле Код компетенции.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о компетенции изменит свое положение в иерархической структуре. Также ей будут присвоены новые значения порядкового номера, сиваольного обозначения и кода.

2. Формирование и уточнение перечня компетенций для оригинального образовательного стандарта

При формировании на основе общевузовских справочников перечней компетенций для каждого из образовательных стандартов действуют следующие принципы:

  1. Системные (универсальные) компетенции переносятся в каждый из образовательных стандартов в полном соответствии с общевузовским справочником. Изменение перечня системных компетенций, их формулировок или кодов в конкретном стандарте недопустимо.
  2. Формулировки социально-личностных компетенций в каждом из образовательном стандарте могут уточнятся. При этом код компетенции автоматически получит постфикс, соответствующий аббревиатуре направления подготовки.
  3. Общевузовский справочник инструментальных компетенций имеет иерархическую структуру. Для инструментальных компетенций в общевузовском справочнике задаются только их наименования. Формулировка компетентностных образовательных результатов для инструментальных компетенций заносится только при добавлении компетенции в стандарт.
  4. В образовательный стандарт могут добавляться дополнительные социально-личностные компетенции, не связанные с компетенциями из общевузовского справочника. Добавление в стандарты системных и инструментальных компетенций, не связанных с общевузовскими справочниками, недопустимо.

Работа по формированию и уточнению перечня компетенций для каждого из образовательных стандартов ведется в форме Образовательные стандарты. Для того, чтобы просмотреть, сформировать или отредактировать перечень компетенций для стандарта, нужно выбрать этот стандарт на вкладке Образовательные стандарты и открыть подчиненную таблицу Компетенции в оригинальном стандарте.

До начала работы по формированию перечня компетенций для образовательных стандартов должны быть полностью сформированы Общевузовские справочники компетенций.

Для формирования и уточнения перечня компетенций в таблице данных Компетенции в оригинальном стандарте доступны действия, позволяющие:

  • переносить в образовательный стандарт полный набор компетенций определенного вида, занесенных в общевузовский справочник
  • добавлять к образовательному стандарту компетенции по одной
  • уточнять формулировку и код компетенции (доступно для социально-личностных и инструментальных компетенций)
  • удалять ошибочно добавленные компетенции

Коды компетенций, добавляемых в стандарт, могут отличаться от кодов, заданных в общевузовском справочнике. Отличие, как правило, заключается в дописывании к коду компетенции из общевузовского справочника аббревиатуры направления подготовки.

Аббревиатуры направлений подготовки задаются в общевузовском справочнике пользователями, наделенными правами на работу с данным справочником. Каждый образовательный стандарт относится к определенному направлению подготовки. Если аббревиатура направления не отображается в таблице "Образовательные стандарты" или отображается неверно, нужно обратиться к пользователю, ответственному за работу со справочником направлений и специальностей с просьбой уточнить аббревиатуру нужного направления.

2.1. Формирование перечня системных компетенций

Системные (универсальные) компетенции переносятся в каждый из образовательных стандартов в полном соответствии с общевузовским справочником. Изменение перечня системных компетенций, их формулировок или кодов в конкретном стандарте недопустимо.

Для переноса полного перечня системных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все системные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень системных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. Изменять формулировки или коды системных компетенций по сравнению с общевузовским справочником недопустимо.

Системные компетенции в образовательном стандарте

Если после последнего формирования перечня системных компетенций для стандарта произошло добавление системных компетенций в общевузовский справочник, действие Добавить все системные компетенции можно вызвать повторно. Его выполнение приведет к добавлению недостающих системных компетенций, коды и формулировки существующих компетенций будут приведены в соответствие со значениями из общевузовского справочника.

Если возникла необходимость удалить одну из системных компетенций, добавленных к стандарту, из общевузовского справочника, потребуется предварительно удалить ее из стандарта. Для этого необходимо выбрать удаляемую компетенцию в списке и выполнить действие Удалить компетенцию.

Если компетенция была удалена из стандарта ошибочно, или если перечень системных компетенций в общевузовском справочнике был расширен, отдельную системную компетенцию можно добавить в стандарт при помощи действия Добавить компетенцию... / системную компетенцию.

Добавление системной компетенции

Для добавления нужно в поле Компетенция из общевузовского справочника выбрать добавляемую компетенцию из общевузовского справочника системных компетенций. Формулировка выбранной компетенции отобразится в поле Формулировка компетентностных образовательных результатов автоматически. Изменение кода или формулировки системной компетенции недопустимо. После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте.

Повторное добавление компетенции в стандарт недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

2.2. Формирование перечня социально-личностных компетенций

Социально-личностные компетенции переносятся в каждый из образовательных стандартов в соответствии с общевузовским справочником. При этом в конкретном образовательном стандарте формулировка социально-личностной компетенции может быть изменена. При изменении формулировки изменяется и код социально-личностной компетенции - к нему дописывается аббревиатура направления подготовки.

В отличие от других видов компетенций в образовательный стандарт могут добавляться социально-личностные компетенции, не связанные с соответствующими компетенциями общевузовского справочника. Далее такие компетенции называются дополнительные социально-личностные компетенции.

Перенос социально-личностных компетенций из общевузовского справочника в образовательный стандарт можно выполнять одним из двух способов:

  • Добавить все социально-личностные компетенции из общевузовского справочника, после чего уточнить формулировки и коды тех компетенций, для которых это необходимо (рекомендуется в случае, если не планируется существенных изменений по сравнению с общевузовским справочником)
  • Добавлять социально-личностные компетенции по одной с одновременным уточнением их формулировок и кодов (рекомендуется в случае, если состав и содержание социально-личностных компетенций в стандарте должно существенно отличаться от общевузовского справочника)

Формирование перечня социально-личностных компетенций

Для переноса полного перечня социально-личностных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все социально-личностные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень социально-личностных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. После добавления коды и формулировки компетенций можно будет уточнить.

Социально-личностные компетенции в образовательном стандарте

Если после последнего формирования перечня социально-личностных компетенций для стандарта произошло добавление компетенций данного вида в общевузовский справочник, действие Добавить все социально-личностные компетенции можно вызвать повторно. Его выполнение приведет к добавлению недостающих системных компетенций, коды и формулировки существующих компетенций будут приведены в соответствие со значениями из общевузовского справочника.

Отдельную социально-личностную компетенцию, имеющую соответствие в общевузовском справочнике, можно добавить в стандарт при помощи действия Добавить компетенцию... / социально-личностную компетенцию. Одновременно с добавлением компетенции можно выполнить и ее уточнение.

Добавление социально-личностной компетенции

Для добавления нужно в поле Компетенция из общевузовского справочника выбрать добавляемую компетенцию из общевузовского справочника социально-личностных компетенций. Формулировка выбранной компетенции отобразится в поле Формулировка компетентностных образовательных результатов (значение из общевузовского справочника, недоступно для изменения). Та же формулировка отобразится в поле Формулировка компетентностных образовательных результатов (в стандарте). Если формулировку компетенции в стандарте нужно изменить, это можно сделать в поле, доступном для редактирования. Если изменение формулировки произведено, код компетенции будет дополнен аббревиатурой направления.

После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте. В таблице будут отображены как значения кода и формулировки, уточненные для стандарта, так и значения из общевузовского справочника.

Повторное добавление в стандарт компетенции, ссылающейся на ту же запись общевузовского справочника, недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

Для добавления дополнительной социально-личностной компетенции, не связанной с общевузовским справочником, предназначено действие Добавить компетенцию... / дополнительную социально-личностную компетенцию.

Добавление дополнительной социально-личностной компетенции

Для добавления нужно занести формулировку компетенции и ее порядковый номер. Для дополнительных компетенций необходимо использовать порядковые номер от 101 до 200. Код компетенции будет сформирован автоматически из префикса"СЛК-", порядкового номера и аббревиатуры направления подготовки.

После нажатия кнопки ОК дополнительная компетенция будет добавлена в стандарт. В таблице всех компетенций стандарта для дополнительных социально-личностных компетенций в колонках Код общевузовской компетенции и Формулировка компетентностных образовательных результатов (общевуз.) будут отображены пустые значения.

Уточнение социально-личностных компетенций

Социально-личностные компетенции, ранее добавленные в стандарт, могут уточняться по сравнению с компетенциями общевузовского справочника. Для того, чтобы уточнить компетенцию, нужно выбрать ее в таблице данных, после чего вызвать действие Уточнить компетенцию... / социально-личностную компетенцию

Уточнение социально-личностных компетенций

Уточнение компетенции заключается к корректировке ее формулировки по сравнению с формулировкой, заданной в общевузовском справочнике. Если формулировка изменена, в код компетенции будет автоматически дописана аббревиатура направления подготовки.

Удаление социально-личностной компетенции

Если возникла необходимость удалить одну из социально-личностных компетенций, добавленных к стандарту, нужно выбрать ее в таблице данных и воспользоваться действием Удалить компетенцию.

2.3. Формирование перечня инструментальных компетенций

Формирование перечня инструментальных компетенций для образовательного стандарта заключается в выборе соответствующих инструментальных компетенций из общевузовского справочника и занесения их формулировок. Так как в общевузовском справочнике инструментальных компетенций формулировки компетенций не заносятся, при добавлении инструментальных компетенций в стандарт формулировки должны быть заданы для каждой компетенции. Коды инструментальных компетенций в стандарте будут сформированы автоматически на основе кода компетенции в общевузовском справочнике и аббревиатуры направления подготовки.

Добавление в стандарт инструментальных компетенций, не связанных ни с одной записью общевузовского справочника, недопустимо.

Формирование перечня инструментальных компетенций для стандарта на основе общевузовского справочника можно выполнять одним из двух способов:

  • Добавить все инструментальные компетенции из общевузовского справочника, после чего уточнить все их формулировки и коды
  • Добавлять инструментальные компетенции по одной с одновременным уточнением их формулировок и кодов

Формирование перечня инструментальных компетенций

Для переноса полного перечня инструментальных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все инструментальные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень социально-личностных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. В качестве формулировки компетенции будет подставлено ее наименование их общевузовского справочника. После добавления инструментальных компетенций коды и формулировки всех компетенций необходимо будет уточнить.

Инструментальные компетенции в стандарте

По одной инструментальные компетенции можно добавлять при помощи действия Добавить компетенцию... / инструментальную компетенцию. Одновременно с добавлением компетенции можно выполнить и ее уточнение.

Добавление инструментальной компетенции в стандарт

Для добавления инструментальной компетенции нужно занести ее формулировку в поле Формулировка компетентностных образовательных результатов, после чего в поле Компетенция из общевузовского справочника выбрать наиболее подходящую общевузовскую компетенцию. Для удобства выбора общевузовский справочник инструментальных компетенций отображается в виде иерархической структуры. При этом для добавления в стандарт необходимо выбирать компетенции, не имеющие дочерних компетенций.

После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте. В таблице будут отображены как значения кода и формулировки, уточненные для стандарта, так и значения кода и наименования из общевузовского справочника.

Повторное добавление в стандарт компетенции, ссылающейся на ту же запись общевузовского справочника, недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

Уточнение инструментальных компетенций

Инструментальные компетенции, ранее добавленные в стандарт, могут уточняться по сравнению с компетенциями общевузовского справочника. Для того, чтобы уточнить компетенцию, нужно выбрать ее в таблице данных, после чего вызвать действие Уточнить компетенцию... / инструментальную компетенцию.

Уточнение инструментальных компетенций

Уточнение компетенции заключается к корректировке ее формулировки. Также при уточнении формулировки в код компетенции будет автоматически дописана аббревиатура направления подготовки.

Удаление инструментальной компетенции

Если возникла необходимость удалить одну из инструментальных компетенций, добавленных к стандарту, нужно выбрать ее в таблице данных и воспользоваться действием Удалить компетенцию.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Рабочие учебные планы (РУПы) (раздел целиком) (31.03.2018) Одним файлом
Рабочие учебные планы (РУПы)

Рабочие учебные планы представляют собой иерархическую структуру компонентов (разделов, циклов), групп дисциплин, дисциплин и записей других видов (курсовых работ, практик, итоговых госэкзаменов, выпускных квалификационных работ). Рабочий учебный план разрабатывается на один учебный год для одного курса студентов факультета (отделения), обучающихся по одному направлению (специальности), по одной специализации, магистерской программе и магистерской специализации. Рабочие учебные планы содержат информацию о видах и количестве испытаний текущего, промежуточного и итогового контроля по дисциплинам, о распределении учебной нагрузки по видам (лекции, семинары, самостоятельная работа и т.п.), а также о реализации дисциплин различными кафедрами ВУЗа.

Каждый рабочий учебный план формируется на основе базового учебного плана, благодаря чему получает атрибуты Тип образовательного стандарта, Образовательный стандартНаправление (специальность), Степень (квалификация), Факультет. Если для базового учебного плана были заданы Специализация, Магистерская программа, Магистерская специализация, то они также будут использованы для РУП. Если эти атрибуты не были заданы для БУП, их можно уточнить при создании РУП.

Создание нового рабочего учебного плана включает следующие этапы работы:

  1. Создание записи о РУПе и его наполнение на основе базового учебного плана.
  2. Редактирование сформированного РУПа.
  3. Связывание записей РУПа с компетенциями.

1. Создание нового рабочего учебного плана

Работа с РУПами ведется в форме Базовые и рабочие учебные планы в таблице данных Рабочие учебные планы. Для создания нового РУП нужно в этой таблице данных вызвать действие Добавить рабочий учебный план.

Добавление РУП бакалавриата

Форма добавления РУП (бакалавриат)

Добавление РУП магистратуры

Форма добавления РУП (магистратура)
  • В поле Факультет значение подставится автоматически, если Вы являетесь пользователем одного из факультетов. Если Вы имеете права на работу со всеми факультетами, то в этом поле нужно выбрать факультет, для которого создается РУП.
  • В поле Уровень обучения нужно выбрать один из предлагаемых вариантов (Бакалавриат, Специалитет, Магистратура)
  • В поле Базовый учебный план для выбора будут предложены все ранее созданные БУПы выбранного факультета и уровня обучения. После выбора БУП автоматически заполнятся поля Направление / специальность (обязательно присутствует в БУП), а также Специализация, Магистерская программа, Магистерская специализация (если они заданы в БУП).
  • Поле Направление / специальность заполняется автоматически при выборе БУП и недоступно для самостоятельного изменения.
  • Поле Специализация доступно для изменения только в случае, если в поле Уровень образования выбраны значения Бакалавриат или Специалитет, а также если специализация не задана в БУП. В этом случае специализацию можно выбрать из перечня специализаций, существующих в справочнике . Если РУП не требует задания специализации, то это поле нужно оставить пустым.
  • Поле Магистерская программа заполняется автоматически на основании выбранного БУП. Это поле недоступно для отдельного изменения.
  • Поле Магистерская специализация доступно для заполнения только в случае, если в поле Уровень образования выбрано значение Магистратура а также если магистерская специализация не задана в БУП. В этом случае ее можно выбрать из перечня, существующего в справочнике для выбранной магистерской программы.
  • В поле Форма обучения нужно выбрать ту форму обучения, по которой будет реализовываться РУП. Выбор производится из общевузовского справочника .
  • В поле Курс нужно выбрать курс факультета, для которого формируется РУП.
  • В поле Учебный год нужно выбрать учебный год, в котором будет реализовываться формируемый РУП.
  • Поле Вариант позволяет создать несколько вариантов РУП одного и того же РУП с тем, чтобы в дальнейшем выбрать наиболее удачный вариант. Для этого в данном поле нужно указать метку варианта (например, "в-2"). Желательно использовать минимального число символов. Если Вы не планируете работать с несколькими вариантами одного и того же РУП, это поле нужно оставить пустым.
  • В поле Реализуется по периодам нужно выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество учебных периодов нужно задать число модулей или семестров, по которым будет реализовываться план.
  • В поле Количество потоков нужно задать плановое число потоков по данному РУП.
  • В поле Количество студентов нужно задать плановое число студентов, которые будут обучаться по данному РУП.
  • В поле Количество групп нужно задать число групп студентов, которые будут обучаться по РУП.

После заполнения всех необходимых полей, нужно нажать кнопку ОК, и запись о новом РУП появится в таблице данных. Не допускается создание двух РУП с одинаковым сочетанием атрибутов

  • Факультет
  • Учебный год
  • Направление/специальность
  • Специализация
  • Магистерская программа
  • Магистерская специализация
  • Метка варианта плана
При попытке создания второго РУП с тем же сочетанием атрибутов произойдет ошибка дублирования объектов.

2. Создание рабочего учебного плана как копии существующего

Если необходимо создать рабочий учебный план, существенно схожий с уже существующим, можно воспользоваться возможностью копирования плана. При помощи копирования можно создать РУП другой специализации, другой магистерской специализации. Также допустимо копировать РУП с одного учебного года на другой. Для этого необходимо сменить БУП, на основе которого разрабатывается РУП на БУП другого года набора. Также при помощи копирования можно создать другую версию того же плана.
Несмотря на то, что при копировании РУП разрешена смена БУП, являющегося основой РУП, не рекомендуется копировать РУП со сменой направления (специальности) подготовки. Копировать РУП с одного учебного года на другой стоит только в том случае, если структура плана (разделы плана и порядок их включения друг в друга) сохраняется. Если же структура плана должна быть другой, то лучше создать новый план, после чего воспользоваться действием Сформировать не основе базового плана.
Для того чтобы создать новый план на основе существующего, нужно выбрать исходный план в таблице данных и вызвать действие Скопировать как новый план.

Форма копирования нового РУП на базе старого

Набор полей формы копирования аналогичен набору полей формы добавления рабочего плана. Принципы работы со всеми полями описаны в разделе Создание нового рабочего учебного плана. При открытии формы копирования плана все поля заполняются значениями, установленными для исходного плана. Для создания нового плана нужно изменить те значения, которые будут отличаться для нового плана и нажать кнопку ОК.

Результатом работы процедуры копирования будет запись о новом рабочем учебном плане в таблице данных Рабочие учебные планы. В подчиненной таблице Записи рабочего плана будет создан набор записей, полностью аналогичный составу исходного плана. Также для нового плана будет перенесена информация о распределении учебной нагрузки по периодам обучения и формы текущего контроля. Если с записями исходного плана были связаны компетенции, то они также будут скопированы в новый план и связаны с соответствующими записями.

После выполнения процедуры копирования можно продолжить редактирование нового плана. Редактирование может заключаться в добавлении новых записей, удалении созданных при копировании, уточнении форм итогового и текущего контроля по дисциплинам, значений объема учебной нагрузки в часах, неделях, кредитах.

Выполнять копирование плана лучше после того, как работа над составом и структурой исходного плана завершена (или близка к завершению). Автоматически актуализировать структуру и состав копии плана после изменения исходного плана будет невозможно. Однако возможно выполнить для нового плана действие Очистить, удалить план и снова сформировать его как копию существующего. Переформировывать таким образом план можно только пока он находится в статусе проект.

3. Редактирование рабочего учебного плана

Если рабочий учебный план не создавался методом копирования, то после создания его содержимое можно сформировать на основе выбранного при создании базового учебного плана. Для этого нужно выбрать РУП в таблице данных и выполнить действие Сформировать на основе базового плана. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Записи рабочего учебного плана. В таблице данных Развиваемые компетенции, подчиненной по отношению к записям плана, будут сформированы записи о компетенциях повторяющие записи, созданные в БУП.

После того, как РУП сформирован на основании БУП или скопирован, его можно редактировать. Для редактирования предназначена специализированная форма работы с РУП, которая открывается при вызове действия Открыть.

Редактирование РУП должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), выборе кафедр, которые будут преподавать дисциплины на факультете, распределении учебной нагрузки по видам (лекции, семинары, самостоятельная работа) и по учебным периодам. Для добавления записей в РУП предназначены соответствующие действия контекстного меню. Для добавлении записи в определенный раздел нужно сначала выбрать заголовок этого раздела или одну из входящих в него записей.

При добавлении дисциплины в РУП потребуется найти нужную дисциплину в общевузовском справочнике всех дисциплин. Данный справочник, как правило, содержит очень много записей, многие из которых имеют похожие наименования. Для поиска нужной дисциплины можно использовать следующие приемы:
  1. Начать ввод с клавиатуры названия дисциплины в поле Дисциплина формы добавления. По ходу вводу символов будут автоматически предлагаться дисциплины, наименование которых начинается с введенных символов (при вводе необходимо соблюдать регистр!).
  2. Открыть справочник дисциплин, воспользоваться фильтром по наименованию или по части наименования. В строке фильтра допустимо использование символов "*" (любое число любых символов) и "?" (один любой символ). Например, введя в строку фильтра значение *экономическ* и нажав Enter можно отобрать для показа только те дисциплины, которые имеют в своем наименовании буквосочетание "экономическ" ("История экономических учений", "Введение в экономическую географию", "Политико-экономический анализ" и т.п.). При этом дисциплина с наименованием "Экономическая теория" отобрана не будет, т.к. символ "Э" введен в ней в верхнем регистре.

    Установка фильтра 1
  3. Открыть справочник дисциплин, выбрать в нем любую запись, в записи выбрать колонку "Полное наименование". Прижав клавишу Alt, начать вводить наименование дисциплины. Регистр символов при этом не играет роли.

    Установка фильтра 2

    После того, как клавиша Alt будет отпущена, в таблице данных будет найдена и выделена первая дисциплина, наименование которой начинается с символов "дискр" в любом регистре, например, "Дискретная математика".

По окончании работы с РУП его можно вывести на печать. Для этого можно воспользоваться действием Напечатать план, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия РУП будет выгружен для печати в MS Excel.

4. Связывание записей рабочего плана с развиваемыми компетенциями

При формировании рабочего учебного плана не основе базового, компетенции, связанные с записями базового плана будут связаны с соответствующими записями рабочего плана. Для дополнения и уточнения развития компетенций в РУП можно удалить или добавить компетенции к записям РУП, что делается аналогично связыванию компетенций с записями БУП (см. раздел Связывание записей базового плана с развиваемыми компетенциями ).


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Наполнение образовательного стандарта (раздел целиком) (31.03.2018) Одним файлом
Наполнение образовательного стандарта

После создания записи о стандарте можно формировать структуру компонентов и дисциплин, составляющих стандарт. Записи стандарта имеют иерархическую структуру, отражающую включенность одних компонентов в состав других и вхождение дисциплин и других видов учебной нагрузки в группы и компоненты. Каждая запись наряду с атрибутами "наименование", "число часов", "число кредитов" и проч. имеет атрибут Входит в раздел, содержащий ссылку на раздел (или группу), в состав которого входит данная запись.

Стандарт состоит из записей нескольких видов:

  • раздел (цикл, компонент)
  • группа дисциплин
  • дисциплина
  • научно-исследовательский семинар
  • курсовая работа
  • практика
  • итоговый госэкзамен
  • выпускная квалификационная работа
  • зачетно-экзаменационные недели

Добавление записей стандарта производится путем вызова соответствующего действия их группы действий Добавить ....

Вид записи группа дисциплин должен использоваться во всех случаях, когда добавляемая запись строго не соответствует одной конкретной дисциплине, которая будет преподаваться на факультете определенной кафедрой по определенной программе или одной конкретной практике, курсовой работе и т.п. Например, запись "Иностранный язык" должна создаваться как группа дисциплин, в которую впоследствии будут включаться дисциплины "Английский язык", "Немецкий язык", "Французский язык" и т.д. Если набор иностранных языков, которые могут (должны) преподаваться по стандарту, известен, то их можно включить в группу иностранных языков как дисциплины. Если же набор иностранных языков не зафиксирован в стандарте, их можно будет задать позже при работе с базовым или рабочим учебным планом.

Если в стандарте задается объем нагрузки для курсовых работ в целом, а не для каждой работы, то такая запись также должна быть создана как раздел или группа дисциплин.

Если в стандарте задаются конкретные виды практик (учебная практика, преддипломная практика и т.д.), то такие записи могут быть созданы как практики. Если же в стандарте задается практика в целом, то такую запись нужно создать как раздел или как группу дисциплин.

В раздел итоговой государственной аттестации можно включить записи вида "итоговый госэкзамен" и "выпускная квалификационная работа", под которыми имеются в виду конкретные виды итоговых испытаний.

В дальнейшем при работе над базовыми и рабочими учебными планами, формируемыми на базе стандарта, в разделы и группы дисциплин можно будет включить записи о конкретных учебных дисциплинах и других видах учебной нагрузки. Также группы дисциплин используются в БУП и РУП для выделения групп дисциплин по выбору и задания их характеристик (число дисциплин или число кредитов, которое должно быть выбрано студентом по группе дисциплин).

Добавление записей стандарта должно начинаться с добавления корневого раздела (компонента). Для корневого раздела, как правило, задается наименование Вся образовательная программа. Для корневого компонента значение атрибута Входит в раздел должно быть пустым. Остальные записи должны включаться в состав этого корневого компонента или в состав других компонентов. Включение записей в состав дисциплин недопустимо. Иерархическая структура позволяет формировать стандарты любой структуры. Следующие ниже примеры будут иллюстрировать создание стандартов II и III поколения. Если ВУЗ имеет право вести обучение по собственным (оригинальным) стандартам, то они должны быть сформированы по аналогичным принципам.

Разделы и дисциплины стандарта могут иметь коды (ГСЭ.0, ЕН.Ф.03, Б1, Б5). В связи с тем, что в стандартах разных типов принято использование различных систем кодирования, включающих различные символы, а также в связи с тем, что не все записи стандарта имеют коды, для корректного задания порядка следования записей в стандарте используется дополнительное числовое поле Порядковый номер. Сортировка записей стандарта будет производиться в порядке возрастания значения порядкового номера в рамках каждого уровня иерархии (т.е. в рамках каждого раздела).

Пример структуры стандарта II поколения:

Структура стандарта II поколения

Пример структуры стандарта III поколения:

1. Добавление разделов (циклов, компанентов) стандарта

Для добавления компонента стандарта нужно выбрать запись о стандарте в основной таблице данных Образовательные стандарты, после чего в подчиненной таблице Состав стандарта вызвать действие Добавить ... / раздел. При добавлении первой записи нужно выполнить щелчок правой кнопкой мыши в пустом поле таблицы. При добавлении записи более низкого уровня сначала нужно выбрать запись компонента, в который планируется включить новый компонент, и только после этого вызвать действие добавления. Ссылка на запись компонента, выбранного в момент вызова действия добавления отобразится в поле Входит в раздел формы параметров. Если по ошибке вместо компонента выбрана дисциплина, то в поле Входит в раздел будет подставлена ссылка на раздел (компонент), в который включена данная дисциплина.

Добавление компонента стандарта II поколения:

Добавление раздела стандарта II поколения

Добавление компонента стандарта III поколения:

Добавление раздела стандарта III поколения

Поля формы добавления нужно заполнить следующим образом:

  • В поле Входит в раздел значение подставляется автоматически. Новая запись будет включена именно в данный раздел. При добавлении первой записи данное поле нужно оставить пустым. Если в поле подставилось значение, а Вы хотите добавить запись на первый уровень, то значение в поле нужно очистить, выделив весь текст и нажав клавишу Del.
  • Поле Компонент плана предназначено для работы со стандартами II поколения. В этом случае нужно выбрать необходимый компонент из справочника компонентов стандартов II поколения. После выбора значения в этом поле автоматически заполнятся и станут недоступными для изменения значения в полях Код записи и Наименование. При работе со стандартами III поколения это поле нужно оставить пустым.
  • В поле Наименование нужно ввести наименование раздела в случае, если не выбрано значение в предыдущем поле.
  • В поле Код записи нужно ввести код раздела в случае, если он задан в стандарте. Для стандартов II поколения это поле будет заполнено автоматически после выбора компонента плана в поле Компонент плана.
  • В поле Порядковый номер нужно ввести целое число, которое будет определять позицию записи в ряду всех записей, входящих в один раздел. Это значение предлагается автоматически как максимально существующий в данном разделе порядковый номер + 1. Если Вы хотите вставить запись не в конец, а в середину то это значение можно скорректировать. В этом случае после добавления записи нужно будет проверить и при необходимости изменить порядковые номера других записей. Сортировка записей стандарта будет производиться по значениям порядковых номеров в пределах каждого раздела. Допустим (но не рекомендуется) повтор значений порядковых номеров. В этом случае записи будут отсортированы в случайном порядке. Допустим пропуск значений позиций (например, 5, 10, 15, ...).
  • В поле Общее число часов нужно ввести значение общего числа часов по всем записям плана, входящим в раздел, в случае если это значение задано в стандарте.
  • В поле Число недель нужно ввести число недель, выделяемое на раздел, если это значение задано в стандарте.
  • Поля Минимальное число кредитов и Максимальное число кредитов предназначены для задания диапазона допустимых сумм кредитов для стандартов III поколения. В случае если задано одно значение числа кредитов, его нужно повторить в обоих полях.

2. Добавление групп дисциплин

В случае, если в стандарте указаны не конкретные дисциплины, а их обобщенные наименования (например, "Иностранный язык", "Древние языки", "Инженерно-технологические дисциплины, отражающие специфику отраслей сферы материального производства" и т.п.), то такие записи должны добавляться как группы дисциплин. При разработке базового учебного плана эти группы должны быть уточнены путем включения в них тех дисциплин, которые будут читаться студентам факультета (например, в группу "Иностранный язык" в базовом плане будут включены дисциплины "Английский язык", "Немецкий язык", в группу "Древние языки" будут включены дисциплины "Древнегреческий язык", "Латинский язык").

Для того, чтобы добавить в стандарт группу дисциплин нужно на вкладке Состав стандарта выбрать раздел, в который должна быть включена новая группа дисциплин и вызвать действие Добавить ... / группу дисциплин.

Добавление группы дисциплин в стандарт
  • В поле Входит в раздел должна отображаться ссылка на раздел, в который будет включена новая группа дисциплин. Если отображается неверный раздел, то нужно закрыть форму добавления, выбрать в списке записей стандарта нужный раздел и повторить вызов действия добавления.
  • В поле Наименование нужно ввести наименование группы дисциплин.
  • В поле Порядковый номер будет предложен очередной порядковый номер записи в выбранном разделе. При необходимости его можно изменить.
  • В поле Количество выбираемых дисциплин нужно занести числовое значение числа дисциплин данной группы, которое обязательно к изучению студентами.
  • В поле Общее число часов нужно занести число часов, выделяемых на изучение дисциплин группы.
  • В поле Число недель будет предложено значение, равное заданному числу часов, разделенному на 54. При необходимости это значение можно изменить.
  • В поле Число кредитовбудет предложено значение, равное заданному числу часов, разделенному на 36. При необходимости это значение можно изменить.

После нажатия кнопки ОК запись о новой группе дисциплин появится в таблице данных. После добавления группы дисциплин в нее можно включать отдельные дисциплины (если набор дисциплин задается в стандарте).

3. Добавление дисциплин

Дисциплины могут добавляться в любой из компонентов стандарта или в группу дисциплин. Для добавления дисциплины нужно выбрать в таблице данных компонент или группу, в которую должна быть включена дисциплина, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / дисциплину. При помощи этого действия должны добавляться только конкретные учебные дисциплины, которые будут читаться на факультете (отделении) определенной кафедрой по определенной программе. Если же в стандарте дисциплины заданы укрупненно, то нужно пользоваться действием добавления группы дисциплин (Добавление групп дисциплин).

Добавление дисциплины стандарта

Поля формы добавления дисциплины нужно заполнить следующим образом:

  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного компонента и снова вызвать действие добавления дисциплины.
  • В поле Дисциплина нужно выбрать дисциплину из общевузовского справочника дисциплин. Выбор можно осуществлять путем ввода начала наименования дисциплины с клавиатуры. При вводе будут предлагаться существующие в справочнике дисциплины. Процедура поиска дисциплины чувствительная к регистру символов. Наименования всех дисциплин справочника, как правило, начинаются с заглавной буквы. Если нужной дисциплины нет в справочнике, ее можно добавить, открыв справочник и вызвав действие Добавить дисциплину ВУЗа. Для добавления новой дисциплины достаточно ввести ее полное наименование. Наименование должно вводиться без сокращений. В дальнейшем оно будет использоваться во всех отчетных документах, а также в дипломе студента. Если при попытке добавления новой дисциплины произошла ошибка дублирования объектов, это означает, что дисциплина с таким наименованием уже существует.
  • В поле Код записи нужно ввести значение кода дисциплины в стандарте, если оно задано.
  • В поле Порядковый номер значение предлагается автоматически как следующая за максимально существующей в рамках раздела. При необходимости это значение можно изменить. Если необходимо добавить дисциплину не в конец, а в середину существующего списка, необходимо проверить и уточнить позиции всех следующих за ней дисциплин.
  • В поле Вид дисциплины нужно выбрать один из видов из выпадающего списка. Выбранный вид дисциплины в дальнейшем будет использоваться при контроле полноты и корректности формирования БУПов и РУПов, который может предполагать различные контрольные нормативы для обязательных дисциплин, факультативов, адаптационных дисциплин. Также от выбранного вида дисциплины зависит ее обязательность для изучения всеми студентами.
  • В поле По выбору студентов значение подставляется автоматически в зависимости от значения, выбранного в поле Вид дисциплины. Для видов Обязательная дисциплина и Обязательный факультатив подставляется значение Да, в остальных случаях - значение Нет. При необходимости установленное автоматически значение можно изменить.
  • В поле Общее число часов нужно ввести значение числа часов, выделяемых на изучение дисциплины, если оно задано в стандарте. При изменении значения в этом поле будут автоматически пересчитываться значения в полях Число недель и Число кредитов.
  • В поле Число недель значение будет заполнено автоматически путем деления значения из поля Общее число часов на 54. При необходимости это значение можно скорректировать.
  • В поле Число кредитов значение будет заполнено автоматически путем деления значения из поля Общее число часов на 36. При необходимости это значение можно скорректировать.

4. Добавление научно-исследовательских семинаров

Для добавления научно-исследовательского семинара предназначено действие Добавить / научно-исследовательский семинар. Форма добавление семинара и принципы ее заполнения аналогичны форме добавления дисциплины. Сам семинар выбирается из справочника всех дисциплин вуза. Если нужно семинара нет в справочнике, его можно добавить.

5. Добавление курсовых работ

Добавлять в образовательный стандарт курсовые работы надо только в том случае, если в нем зафиксированы конкретные работы, которые должны быть выполнены студентами. Если же курсовые работы заданы в стандарте укрупненно, то нужно пользоваться действиями, описанными в разделах Добавление разделов (циклов, компонентов) стандарта и Добавление групп дисциплин.

Для добавления курсовой работы нужно выбрать в таблице данных компонент или группу, в которую должна быть включена курсовая работа, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / курсовую работу. Курсовые работы могут быть как по одной конкретной учебной дисциплине, так и междисциплинарные. На приведенных ниже рисунках представлены примеры заполнения формы параметров в этих двух случаях. Если курсовая работа выполняется по конкретной дисциплине, но дисциплина может выбираться студентом, то курсовая работа добавляется по аналогии с междисциплинарной (дисциплина не указывается).

Добавление курсовой работы по дисциплине в стандарт

Добавление междисциплинарной курсовой в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел (группу дисциплин), который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления курсовой работы.
  • Поле По дисциплине нужно заполнять только в том случае, если курсовая работа должна выполняться по одной конкретной учебной дисциплине всеми студентами. Если дисциплина может выбираться студентами, или если курсовая работа является междисциплинарной, то данное поле нужно оставить пустым.
  • Поле Наименование доступно для заполнения только в том случае, если не выбрана дисциплина. По умолчанию предлагается наименование "Курсовая работа", но его можно изменить (например, "Междисциплинарная курсовая работа"). Если же дисциплина выбрана, то наименование курсовой работы будет сформировано автоматически.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для курсовых работ.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на данную курсовую работу.

После нажатия кнопки ОК на форме параметров запись о курсовой работе появится в таблице данных в соответствующей позиции.

6. Добавление практик

Добавлять в образовательный стандарт практики надо только в том случае, если в нем зафиксированы конкретные виды практик, которые должны быть пройдены студентами. Если же практики заданы в стандарте укрупненно, то нужно пользоваться действиями, описанными в разделах Добавление разделов (циклов, компонентов) стандарта и Добавление групп дисциплин.

Для добавления практики нужно выбрать в таблице данных компонент или группу, в которую должна быть включена практика, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить... / практику. Как правило, в образовательных стандартах выделяются специальные разделы практик.

Добавление практики в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел (группу дисциплин), который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления практики.
  • В поле Вид практики нужно выбрать практику из общевузовского справочника .
  • В поле Способ проведения практики нужно выбрать один из способов проведения практики.
  • После выбора вида практики в поле Наименование будет автоматически сформировано значение, соответствующее выбранному виду практики. Изменять его независимо от вида практики недопустимо.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • В поле Общее число часов значение можно оставить пустым, если оно не зафиксировано в стандарте.
  • В поле Число недель нужно задать число недель, выделяемых на практику.
  • В поле Число кредитов нужно установить число кредитов, выделяемых на практику, соблюдая требуемое соотношение между числом недель и числом кредитов.

После нажатия кнопки ОК на форме параметров запись о практике появится в таблице данных в соответствующей позиции.

7. Добавление итоговых госэкзаменов

итоговые государственные экзамены должны добавляться в раздел итоговой аттестации. Итоговые госэкзамены могут быть по одной конкретной дисциплине, или междисциплинарными.

Для добавления итогового экзамена нужно выбрать в таблице данных раздел итоговой аттестации, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / итоговый госэкзамен. На приведенных ниже рисунках представлены примеры заполнения формы параметров для случая добавления экзамена по дисциплине и междисциплинарного экзамена.

Добавление итогового экзамена по дисциплине в стандарт

Добавление междисциплинарного итогового экзамена в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления итогового госэкзамена.
  • Поле Дисциплина нужно заполнять только в случае экзамена по дисциплине. При выборе дисциплины автоматически формируется наименование записи об итоговом экзамене. Если экзамен является междисциплинарным, то поле Дисциплина нужно оставить пустым.
  • Поле Наименование доступно для заполнения только в случае, если поле Дисциплина пустое. В этом случае наименование итогового экзамена нужно ввести вручную с клавиатуры.
    Наименование, заданное для итогового экзамена, будет в дальнейшем использовано при формировании дипломов студентов.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для итогового экзамена.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на итоговый экзамен в соответствии с действующими нормативами.

После нажатия кнопки ОК на форме параметров запись об итоговом госэкзамене появится в таблице данных в соответствующей позиции.

8. Добавление выпускных квалификационных работ

Выпускные квалификационные работы (ВКР) должны добавляться в раздел итоговой аттестации.

Для добавления ВКР нужно выбрать в таблице данных раздел итоговой аттестации, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / выпускную работу.

Добавление ВКР в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления ВКР.
  • В поле Наименование нужно ввести наименование ВКР с клавиатуры (Например, "Подготовка и защита выпускной работы бакалавра" или "Подготовка и защита магистерской диссертации").
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для ВКР.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на ВКР в соответствии с действующими нормативами.

После нажатия кнопки ОК на форме параметров запись о выпускной работе появится в таблице данных в соответствующей позиции.

9. Добавление зачетно-экзаменационных недель

Зачетно-экзаменационные недели должны добавляться в корневой раздел стандарта (раздел "Вся образовательная программа").

Для добавления записи о зачетно-экзаменационных неделях нужно выбрать в таблице данных корневой раздел, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / зачетно-экзаменационные недели.

Добавление зачетно-экзаменационных недель в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления ВКР.
  • В поле Наименование автоматически формируется строка "Зачетно-экзаменационные недели". При необходимости это значение можно изменить.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • В поля Общее число часов и Число недель нужно занести значения, предусмотренные стандартом.

После нажатия кнопки ОК на форме параметров запись о зачетно-экзаменационных неделях появится в таблице данных в соответствующей позиции.

10. Внесение изменений в созданный стандарт

После того, как созданы записи стандарта, можно изменять как отдельные свойства записей, так и структуру стандарта. Доступны изменения следующих видов:

  1. Добавление новых записей.
    Для дополнения стандарта новыми записями необходимо вызвать одно из действий добавления, описанных в предыдущих разделах.
  2. Уточнение значений свойств записей стандарта.
    Значения различных свойств записей изменяются разными способами:
    • Наименование можно изменять путем ввода нового значения с клавиатуры с последующим нажатием клавиши Enter для всех записей, кроме тех, которые соответствуют дисциплинам (заполнено значение в колонке Дисциплина) или компонентам стандарта II поколения (заполнено значение в колонке Компонент плана). Для изменения наименования записи, соответствующей дисциплине, нужно в колонке Дисциплина выбрать другую дисциплину из справочника дисциплин. Если нужно дисциплины в справочнике нет, ее можно добавить в справочник. Для изменения наименования записи, соответствующей компоненту стандарта II поколения (ГОС) нужно выбрать другой компонент в колонке Компонент плана. Если нужного компонента в справочнике нет, необходимо обратиться к бизнес-администратору системы с просьбой уточнить данные справочника. При изменении наименования практики нужно проследить за тем, чтобы наименование соответствовало значению, установленному в колонке Вид практики.
    • Порядковый номер можно изменять путем ввода нового числового значения с клавиатуры с последующим нажатием клавиши Enter. При изменении порядкового номера одной из записей необходимо просмотреть значения порядковых номеров всех следующих за ней записей раздела и при необходимости скорректировать и их.
    • Код записи, Общее число часов, Число недель, Минимальное число кредитов, Максимальное число кредитов можно изменять путем ввода нового значения с клавиатуры с последующим нажатием клавиши Enter.
    • При изменении значений, выбранных в колонках Дисциплина и Компонент плана автоматически изменится значение в колонке Наименование.
    • Если Вы изменяете значение, выбранное в колонке Вид практики, необходимо вручную уточнить значение в колонке Наименование.
  3. Изменение структуры стандарта.
    Под изменением структуры понимается перенос записей из одного раздела в другой. Для этого нужно выбрать запись, которую Вы хотите перенести и вызвать для нее действие Перенести в другой раздел. Для выполнения действия нужно указать раздел, которому будет непосредственно подчинена запись.

    Перенос записи в другой раздел

    Для выбора будут доступны только записи вида Раздел плана (компоненты и группы дисциплин). Если Вы выполняете перенос раздела или группы, то необходимо следить за тем, чтобы не включить раздел сам в себя. При подобной попытке будет отображено сообщение об ошибке с текстом "Недопустимо включать раздел сам в себя".
  4. Удаление записей.
    Удаление записей производится при помощи действия Удалить, доступного в контекстном меню. Удалить можно только ту запись, в которую не включено ни одной другой записи. Это означает, что для того, чтобы удалить запись о разделе, нужно сначала удалить или перенести в другие разделы все входящие в него записи. Также удаление будет невозможным в случае, если на основе записи уже созданы записи базового или рабочего учебного плана.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Работа с компетенциями ФГОС (раздел целиком) (31.03.2018) Одним файлом
Работа с компетенциями ФГОС

1. Создание перечня компетенций стандарта

В стандартах III поколения (Федеральных государственных образовательных стандартах, или ФГОС) присутствует перечень компетенций, развиваемых у студента в ходе обучения по соответствующим учебным программам. Перечень всех компетенций, перечисленных в стандарте, должен быть введен в систему. Сделать это можно, выбрав в таблице данных Образовательные стандарты нужный стандарт, и открыв подчиненную таблицу данных Компетенции в стандарте.

Добавление новой компетенции производиться при помощи действия Добавить компетенцию.

  • В поле Код компетенции нужно занести код, используемый для обозначения компетенции в стандарте.
  • В поле Тип компетенции нужно выбрать одно из предлагаемых значений из справочника типов компетенций.
  • В поле Описание компетенции нужно занести текст, разъясняющий содержание компетенции. Можно использовать стандартные действия копирования и вставки значений из других документов.

Перечень компетенций отображается сгруппированным по типам компетенций. После того, как компетенции будут связаны с определенными записями стандарта в подчиненной таблице Развитие в компонентах стандарта для каждой компетенции можно будет увидеть перечень записей стандарта, в которых она присутствует.

Перечень компетенций стандарта

В случае если в разных стандартах присутствуют схожие перечни компетенций, можно воспользоваться действиями Копировать и Вставить, вызываемыми из контекстного меню в таблице данных. Для этого нужно в главной таблице данных выбрать стандарт, для которого уже создан перечень компетеницй, в подчиненной таблице данных выбрать одну или несколько компетенций, выполнить действие Копировать. После этого выбрать другой стандарт в главной таблице, и в подчиненной таблице выполнить действие Вставить. После вставки значения кодов и описаний компетенций можно будет скорректировать.

2. Связь компетенций с записями стандарта

После того как сформированы записи стандарта (см. Наполнение стандарта компонентами и дисциплинами) и сформирован перечень компетенций стандарта (см. Создание перечня компетенций стандарта) можно устанавливать связи между записями стандарта и компетенциями. Для этого предназначена таблица данных, Развиваемые компетенции, расположенная на третьем уровне формы под таблицей Состав стандарта.

Компетенции могут связываться с любыми записями стандарта, как с компонентами, так и с дисциплинами. Для того, чтобы задать эту связь, нужно выбрать одну из записей стандарта, после чего в подчинненой таблице данных Развиваемые компетенции вызвать действие Добавить компетенцию.

Добавление компетенции к записи стандарта

В единственном поле формы параметров добавления компетенции нужно выбрать компетенцию из списка всех компетенций стандарта, или ввести код компетенции с клавиатуры. Для корректного поиска компетенции в перечне компетенций стандарта необходимо соблюдать регистр символов.

Полный перечень компетенций, связанных с записью стандарта, формируется многократным выполнением процедуры добавления компетенции. В случае, если нужной компетенции не найдено в перечне, предлагаемом для выбора, необходимо вернуться к этапу Создание перечня компетенций стандарта.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Особенности наполнения отдельных разделов БУП и РУП (раздел целиком) (31.03.2018) Одним файлом
Особенности наполнения отдельных разделов БУП и РУП

Разделы БУП и РУП, наполненные дисциплинами, обязательными для изучения всеми студентами, не представляют большой сложности при заполнении. В них могут добавляться дисциплины, не присутствующие в стандарте или в БУП, при этом суммарные значения числа часов, числа недель, числа кредитов могут быть пересчитаны автоматически. Разделы, в состав которых входят дисциплины, необязательные для изучения всеми студентами, а также разделы, содержащие прочие виды нагрузки (курсовые работы, практики, итоговые экзамены, выпускные работы) требуют отдельного внимания.

Для того, чтобы отразить особенности различных разделов, дисциплин и других видов нагрузки, входящих в БУП или РУП, после автоматизированного формирования структуры плана для его записей необходимо уточнить ряд дополнительных свойств, таких как

  • Вид дисциплины, обязательность для изучения студентами
  • Учет в текущем, или только в кумулятивном рейтинге
  • Вхождение в расчет недельной аудиторной нагрузки студентов
  • Преподавание дисциплины на иностранном языке
  • Допустимость нескольких испытаний в одном периоде

Работа записями плана, не являющимися дисциплинами (курсовыми работами, практиками, итоговыми государственными экзаменами, выпускными квалификационными работами связана с рядом особенностей, которые изложены в следюущих ниже разделах.

1. Уточнение ряда свойств разделов и дисциплин БУП и РУП

В формах редактирования БУП и РУП работают проверки контрольных соотношений, при помощи которых контролируется корректность и целостность плана, соответствие характеристик записей плана требованиям образовательного стандарта, выполнение Методических указаний по разработке БУП и РУП. Также при помощи функционала формы редактирования можно выполнять автоматизированные пересчеты показателей плана, в частности, суммирование значений числа часов, недель, кредитов по разделам и группам дисциплин.

В образовательном стандарте не содержится достаточно информации для того, чтобы реализовать корректную работу некоторых автоматизированных проверок и пересчетов. По этой причине после формирования БУП на основе стандарта или РУП на основе БУП, необходимо выполнить уточнение следующих значений для некоторых разделов и дисциплин БУП или РУП:

  1. Признак Рассчитывается как сумма элементов для групп дисциплин и разделов.
  2. Свойство Количество выбираемых дисциплин для разделов и групп дисциплин по выбору.
  3. Признак Только в кумулятивный рейтинг для дисциплин, число кредитов по которым не должно участвовать в подсчете суммы по разделу и по плану в целом.
  4. Свойство Вид дисциплины и признак Выбирается студентами.
  5. Признак Входит в расчет недельной нагрузки.
  6. Свойство На иностранном языке.
  7. Свойство Допустимо несколько испытаний в периоде.
Уточнение данных свойств производится в форме редактирования БУП или РУП при помощи действия Дополнительные свойства.

Дополнительные свойства раздела плана:

Дополнительные свойства для раздела

Дополнительные свойства дисциплины плана:

Дополнительные свойства для дисциплины

1. Уточнение признака Рассчитывается как сумма элементов для групп дисциплин и разделов.

Все разделы и группы дисциплин можно разделить на два вида:

  • Разделы или группы, показатели которых должны определяться путем суммирования показателей входящих в них записей.
  • Разделы или группы, показатели которых могут устанавливаться независимо.
К первой группе относятся разделы и группы, все дисциплины которых обязательны для изучения всеми студентами. Ко второй группе относятся разделы и группы дисциплин по выбору, факультативов адаптационных дисциплин. Для того, чтобы отличить один вид разделов от другого используется признак Рассчитывается как сумма элементов. При формировании БУП на основе стандарта для всех разделов и групп дисциплин этот признак получает значение Да. При формировании РУП на основе БУП для разделов РУП устанавливается то же значение признака, которое было задано для данного раздела в БУП.

Если для признака установить значение Нет, то проверка соответствия суммы показателей для всех записей раздела со значением, установленным для раздела в целом, проводиться не будет и сообщения об ошибках не будут формироваться. В этом случая значения числа часов, недель, кредитов, числа экзаменов и зачетов (в РУП) для раздела нужно установить вручную таким образом, чтобы раздел, в свою очередь, внес необходимый вклад в план в целом. Например, если в раздел включено три дисциплины по выбору, трудоемкостью 108 часов каждая, а студенты должны выбрать только одну из них, для раздела вручную должно быть установлено число часов, равное 108.

Наименования разделов, для которых не используется контроль равенства суммы показателей раздела и суммы показателей входящих в него записей выделяется курсивным шрифтом. При проверке плана на такие разделы нужно обращать отдельное внимание.

Разделы, рассчитываемые и не рассчитываемые как сумма

2. Уточнение значения Количество выбираемых дисциплин

Для того, чтобы в дальнейшем на основании разработанных БУП и РУП можно было сформировать учебный план студента и проверить его полноту и корректность, необходимо задать для каждой группы или раздела дисциплин по выбору количество дисциплин, которые должны быть обязательно выбраны студентом.

Если при наполнении образовательного стандарта эти значения не заданы, то их необходимо задать в форме редактирования БУП или РУП при помощи действия Дополнительные свойства.

3. Уточнение признака Только в кумулятивный рейтинг

Ряд дисциплин, принадлежащих к разделу факультативов или к группам адаптационных дисциплин, могут не участвовать в подсчете суммы кредитов по группе, по разделу и по плану в целом. Кредиты по таким дисциплинам начисляются студентам только при расчете кумулятивного рейтинга, но не начисляются при расчете текущего рейтинга. Для того, чтобы было возможным рассчитать кумулятивный рейтинг студентов по таким дисциплинам, значения числа кредитов должны быть заданы, однако для того, чтобы корректно провести проверку суммарного числа кредитов БУП и РУП такие дисциплины необходимо выделить из перечня обычных дисциплин.

Уточнение данного признака производится в форме редактирования БУП и РУП при помощи действия Дополнительные свойства.

При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются одной звездочкой (*) в колонке "Зачетные единицы". В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.

4. Уточнение признаков Вид дисциплины и Выбирается студентами

Если при формировании стандарта или БУП для дисциплины были неверно заданы значения свойств Вид дисциплины и Выбирается студентами, то эти значения можно уточнить в формах редактирования БУП и РУП при помощи действия Дополнительные свойства. Эти свойства являются зависимыми, т.е. если для свойства Вид дисциплины установить значение Обязательная дисциплина или Обязательный факультатив, то для признака Выбирается студентами будет автоматически подставлено значение Нет. Если же для вида дисциплины выбрать значение Дисциплина по выбору или Факультатив, то признак автоматически получит значение Да. При исключении из этого правила, значение признака Выбирается студентами можно изменить вручную.

Корректная установка этих свойств важна для дальнейшего назначения учебных планов студентам и контроля полноты сформированных учебных планов студентов.

5. Уточнение признака Входит в расчет недельной нагрузки.

Данный признак используется для того, чтобы исключить некоторые дисциплины РУП из расчета недельной аудиторной нагрузки студентов. При формировании РУП на основе БУП для данного признака устанавливается значение Да. При редактировании РУП для факультативов, а также других дисциплин, аудиторная нагрузка по которым не должна входить в расчет недельной аудиторной нагрузки студентов, необходимо изменить значение этого признака на Нет.

Изменить значение данного признака можно в форме редактирования РУП при помощи действия Дополнительные свойства.

При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются двумя звездочками (**) в колонке "Наименование дисциплины". По этой причине вносить знаки * в наименование дисциплины не нужно. В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.

6. Выделение предметов, преподаваемых на иностранном языке.

Для того чтобы выделить дисциплины плана, преподаваемые на иностранном языке, при помощи действия Дополнительные свойства для них можно установить свойство На иностранном языке. При формировании БУП и РУП данное для данного свойства устанавливается пустое значение, что означает, что дисциплина преподается на русском языке. Для дисциплин, преподаваемых на иностранных языках, можно выбрать один из иностранных языков, преподаваемых в ВУЗе. Если в выпадающем списке нет нужного языка, необходимо обратиться к администратору системы с просьбой добавить язык в доступный перечень.

7. Наличие нескольких испытаний в одном периоде для дисциплины плана.

Как правило по всем дисциплинам плана в каждом из учебных периодов (модуле, семестре), предусматривается одно (или ни одного) испытание рубежного контроля. Если возникает исключительная ситуация, при которой необходимо запланировать более одного испытания в одном учебном периоде (например, экзамен и итоговый полевой сбор по военной подготовке), это можно сделать следующим образом:

  1. Выбрать дисциплину, вызвать действие Дополнительные свойства.
  2. Установить флажок к поле Допустимо несколько испытаний в периоде. В правой части строки в колонках, предназначенных для указания видов испытаний ("Экзамен", "Зачет") будут отображены два уровня по аналогии с записями разделов.
    Несколько испытаний в одном периоде
  3. Установить количество (в штуках) экзаменов и / или зачетов в строке дисциплины на соответствующем уровне (рядом со словом "Экз." или "Зач.").
  4. Проконтролировать правильность вычисления количества экзаменов и зачетов для раздела плана, в который входит данная дисциплина.

Если необходимость наличия нескольких испытаний в периоде отпала, или была установлена ошибочно, от нее можно отказаться, вызвав для дисциплины действие Дополнительные свойства и сняв флажок Допустимо несколько испытаний в периоде. Строка дисциплины снова будет отображаться обычным образом. В столбцах, отвечающих за виды испытаний по периодам, нужно выбрать значения "Экзамен" или "Зачет".

2. Организация разделов и групп дисциплин по выбору

Присутствующие в БУП или РУП дисциплины по выбору могут либо представлять собой единую группу, входящую в раздел "Дисциплины по выбору" одного из компонентов, либо формироваться в несколько групп, из каждой из которых студентами должно быть выбрано определенное количество дисциплин.

Если группы дисциплин были заданы в стандарте, то они будут созданы в БУП при его формировании по стандарту. При формировании РУП на основе БУП созданные в БУП группы будут перенесены в РУП. Группы дисциплин можно создавать и при редактировании БУП или РУП. После создания групп в них можно добавлять отдельные дисциплины. Также можно переносить существующие дисциплины в группы при помощи действия Перенести в другой раздел.

В отличие от обычных разделов и групп, для которых значения числа часов, недель и кредитов вычисляется как сумма значений, заданных для входящих в них дисциплин, для разделов и групп дисциплин по выбору эти значения должны задаваться самостоятельно. Для того, чтобы проверки и автоматические расчеты, работающие в формах редактирования БУП и РУП, работали корректно, а также с целью последующего контроля формирования индивидуальных учебных планов студентов, для разделов и групп дисциплин по выбору должны быть дополнительно уточнены значения ряда свойств. Уточнение выполняется при помощи действия Дополнительные свойства.

Дополнительные свойства для дисциплин по выбору
  • Для признака Рассчитывается как сумма элементов должно быть установлено значение Нет.
  • Если для раздела или группы определяется количество дисциплин, которые должны быть выбраны студентом, то это значение нужно занести в колонку Количество выбираемых дисциплин. Если количество дисциплин не задается, а накладывается ограничение только на число кредитов, то это значение нужно оставить пустым. Вы этом случае контролироваться будет не количество выбранных студентом дисциплин, а значение суммы кредитов по всем выбранным им дисциплинам.
  • Должны быть уточнены значения Трудоемкость в часах, Недели и Трудоемкость в зачетных единицах, объем аудиторной нагрузки по периодам, число форм текущего контроля (РУП). После того как для признака Рассчитывается как сумма элементов установлено значение Нет, значения числа часов, недель и кредитов, заданные для группы, не будут сравниваться с суммой значений для входящих в группу дисциплин и не будут автоматически пересчитываться.
Раздел дисциплин по выбору

Если все дисциплины раздела распределены по группам, для каждой из которых задано определенное значение числа часов, недель и кредитов, которые должны быть набраны студентом, то для раздела в целом значение признака Рассчитывается как сумма элементов должно быть установлено в Да, так как, действительно, для раздела должны быть просуммированы значения, заданные для каждой из групп.

Раздел дисциплин по выбору с группами

В данном примере для групп ДПВ1 (1 из 2) и ДПВ2 (1 из 6) значение признака Рассчитывается как сумма элементов установлено как Нет, а для записи раздела ОПД.В.00 Дисциплины по выбору установлено значение Да.

3. Работа с факультативами

Факультативы, также как и дисциплины по выбору должны быть выделены в БУП и в РУП в отдельный раздел или группу дисциплин. Для разделов или групп факультативов при помощи действия Дополнительные свойства признак Рассчитывается как сумма элементов должен быть установлен как Нет.

Дополнительные свойства для раздела факультативов

Для всех дисциплин, являющихся факультативами дополнительные свойства должны быть установлены следующим образом:

Дополнительные свойства для дисциплин факультативов

После того, как для факультативов установлен признак Только в кумулятивный рейтинг, число кредитов будет помечено знаком *. После установки значения Нет для признака Входит в расчет недельной нагрузки число аудиторных часов по факультативу в учебном периоде (модуле, семестре) не будет участвовать в расчете аудиторной нагрузки в периоде по разделу.

Если число часов, недель, кредитов, выделяемых на факультативы, не должно учитываться при расчете суммовых показателей плана, то для них в строке раздела или группы Факультативы можно задать нулевые или пустые значения.

4. Работа с адаптационными дисциплинами

Если в БУП или РУП включаются адаптационные дисциплины (т.е. дисциплины, изучаемые студентами, не имеющими на момент поступления достаточной подготовки по тем или иным предметам), то при работе с ними необходимо учитывать их особенности.

Адаптационной дисциплиной может быть как дополнительная дисциплина, не изучаемая основной массой студентов, так и дополнительная нагрузка по одной из существующих в БУП или РУП дисциплин (например, дополнительные часы по иностранному языку, экономической теории или математике). В любом случае адаптационная дисциплина должна добавляться в БУП и РУП как отдельная запись. При добавлении такой дисциплины в поле Вид дисциплины должно быть выбрано значение Адаптационный курс, в поле По выбору студентов должно быть установлено значение Да. Скорректировать значения данных свойств для адаптационных дисциплин можно в формах редактирования РУП и БУП при помощи действия Дополнительные свойства.

Дополнительные свойства для адаптационных дисциплин

Так как адаптационные дисциплины не являются обязательными для всех студентов, на них либо не выделяются кредиты, либо эти кредиты не участвуют в расчете текущего рейтинга. Поэтому для адаптационных дисциплин необходимо либо установить число кредитов, равное нулю, либо установить значение Да в колонке Только в кумулятивный рейтинг.

Нагрузка по адаптационным дисциплинам не должна учитываться при подсчете суммы часов, недель и кредитов и других показателей по разделу, в который они входят. Для того, чтобы расчет сумм по разделу был произведен корректно, рекомендуется выделить адаптационные дисциплины в отдельную группу дисциплин. Для этой группы для признака Рассчитывается как сумма элементов должно быть установлено значение Нет, а для свойств Трудоемкость в часах, Недели и Трудоемкость в зачетных единицах и других должны быть установлены пустые или нулевые значения. Такая установка свойств позволит корректно рассчитать суммы по разделу, в который входит группа адаптационных дисциплин.

Раздел адаптационных дисциплин

5. Курсовые работы

Курсовые работы могут присутствовать в различных разделах БУП и РУП. Если курсовые работы были занесены в стандарт, то они будут созданы и в БУП после его формирования на основе стандарта. При формировании РУП на основе БУП в нем будут созданы курсовые работы в случае если в БУП по курсовой работе были заданы часы или кредиты на данном курсе. Также курсовые работы можно создавать и непосредственно в БУП и РУП, используя действие Добавить ... / курсовую работу.

Если курсовая работа выполняется по одной дисциплине всеми студентами, то эту дисциплину необходимо выбрать в поле Дисциплина при добавлении курсовой работы. Если же курсовая работа является междисциплинарной, или если студенты могут выбирать дисциплину, по которой они будут выполнять работу, то поле Дисциплина надо оставить пустым. Заполнение поля Кафедра в РУП для курсовой работы необязательно. Оно должно заполняться только в том случае, если известно, что все студенты должны выполнить данную курсовую работу на данной кафедре.

Если создается курсовая работа по дисциплине, то ее Наименование будет сформировано автоматически. Если дисциплина не используется, то наименование курсовой работе может быть присвоено произвольно.

Значение числа кредитов для курсовых работ устанавливается независимо от значений числа часов и числа недель.

Раздел с курсовой работой

Если в БУП или РУП присутствует курсовая работа, то о ней должна быть обязательно создана запись типа Курсовая работа, даже если в плане существует одноименный раздел. Уточнить свойства записи о курсовой работе можно при помощи действия Дополнительные свойства

Дополнительные свойства для курсовой работы

Изменять тип записи при помощи этого действия нельзя. Если Вы ошиблись с типом записи, то нужно удалить существующую запись о курсовой работе и создать новую при помощи действия Добавить ... / курсовую работу.

В РУП для курсовой работы, так же как и для любой другой записи плана должно быть указано испытание рубежного контроля. Для того, чтобы в дипломе студентов по курсовой работе отображались оценки "отлично", "хорошо" и проч. видом рубежного контроля для курсовой работы должен быть "Экзамен". В противном случае в дипломе студента будут отображены результаты "зачтено" или "незачтено". Испытание должно быть запланировано в том модуле (семестре), в котором студенты должны сдать и защитить курсовую работу.

При расчете числа зачетов и экзаменов по модулям, отображаемого в печатной форме РУП, испытания по курсовым работам не учитываются.

6. Работа с практиками

Как в образовательном стандарте, так и в БУП и в РУП практики должны быть выделены в отдельный раздел (разделы). Если в стандарте значения трудоемкости задавались для раздела практик в целом, то в БУП и РУП обязательно нужно добавить записи о конкретных практиках того или иного вида. Добавление практики в БУП или РУП производится при помощи действия Добавить ... / практику.

При добавлении практики нужно обязательно задать Вид практики путем выбора из выпадающего списка. При выборе вида практики для нее будет автоматически предложено Наименование. Если в план необходимо добавить несколько практик одного вида, то наименование надо скорректировать таким образом, чтобы эти практики можно было отличить, например, "производственная практика 2 курс", "производственная практика 3 курс".

При помощи действия Дополнительные свойства можно уточнить параметры созданной записи о практике

Дополнительные свойства практик

При помощи данной формы можно уточнить вид практики. Тип записи обязательно должен быть установлен как Практика. Если тип записи установлен неверно, его нельзя изменить при помощи этой формы. В этом случае нужно удалить запись ошибочного типа и добавить новую при помощи действия Добавить ... / практику.

В БУП и РУП магистратуры наименования разделов могут включать в себя (и даже полностью повторять) наименование видов практики, например, "НИР.М.02 Научно-педагогическая практика" или "НИР.М.03 Научно-исследовательская практика". Несмотря на это, в такие разделы необходимо добавить записи о практиках соответствующего вида.

Значения числа недель и числа кредитов для практик устанавливаются независимо от числа часов.

7. Работа с разделом итоговой государственной аттестации

Итоговая государственная аттестация в образовательных стандартах выделяется в отдельный раздел. В состав итоговой аттестации могут входить итоговые экзамены и выпускная квалификационная работа (ВКР). Если записи о конкретных итоговых экзаменах и ВКР были созданы в стандарте, то они будут созданы и в БУП при его формировании по стандарту. Также записи об отдельных видах итоговой аттестации, созданные в БУП будут перенесены в РУП при его формировании на основе БУП. Если же в стандарте или БУП записи о конкретных испытаниях итоговой аттестации созданы не были, то их необходимо добавить в раздел итоговой аттестации при помощи действий Добавить ... / итоговый гоэкзамен и Добавить ... / выпускную работу.

Итоговый госэкзамен может быть как по одной конкретной дисциплине, так и междисциплинарным. Если итоговый госэкзамен проводится по дисциплине, то эту дисциплину необходимо выбрать в поле Дисциплина. При этом в поле Наименование автоматически сформируется значение, повторяющее наименование дисциплины. Если же экзамен является междисциплинарным, то поле Дисциплина нужно оставить пустым, в наименование ввести с клавиатуры (например, "Междисциплинарный экзамен по направлению подготовки").

Для свойства Форма итогового контроля должно быть установлено значение Экзамен.

Значение числа кредитов для итогового госэкзамена устанавливаются независимо от значений числа часов и числа недель.

При добавлении выпускной квалификационной работы (ВКР) ее наименование можно задать произвольно (например, "Подготовка и защита выпускной квалификационной работы"). Для свойства Форма итогового контроля должно быть установлено значение Экзамен.

Значение числа недель и числа кредитов для ВКР устанавливаются независимо от значений числа часов и числа недель.

Раздел итоговой аттестации


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Объединенные планы общевузовских дисциплин (раздел целиком) (31.03.2018) Одним файлом
Объединенные планы общевузовских дисциплин

Объединенный план общевузовских дисциплин дисциплин представляет собой иерархическую структуру групп дисциплин (раделов) и включенных в них дисциплин (НИС и дисциплин для иностранных студентов).

Создание и редактирование нового объединенного плана общевузовских дисциплин включает следующие этапы работы:

1. Создание нового объединенного плана общевузовских дисциплин

Работа с Объединенными учебными планами общевузовских дисциплин ведется на участке "Разработка учебных планов" в форме "Учебные планы общевузовских дисциплин".

Расположение формы Учебные планы общевузовских дисциплин

Для добавления плана необходимо в верхней таблице данных Объединенные планы общевузовских дисциплин с помощью контекстного меню вызвать действие Добавить объединенный план общеуниверситетских дисциплин.

Процедура добавления объединеннго плана общевузовских дисциплин

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров добавления объединенного плана общевузовских дисциплин
  • В поле Тип общевузовского плана выбрать из списка (кнопка Список) соотвествующий тип плана.
  • В поле Уровень образования из выпадающего списка необходимо выбрать тот уровень образования, для студентов которого предназначен создаваемый учебный план.
  • В поле Наименование плана учебному плану нужно присвоить наименование. Наименованием может быть любое строковое значение длиной не более 128 символов.
  • В поле Число лет реализации указать количество лет, в течение которых реализуется объединенный план общевузовских дисциплин.
  • В поле Учебный год начала реализации указать год начала обучения по данному плану.
  • В поле Год окончания реализации нужно выбрать учебный год, в котором студенты завершат обучение по данному плану.
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов указать количество периодов в учебном году.

После того, как все поля формы будут заполнены, кнопка ОК на форме добавления станет доступной. После ее нажатия, запись о новом объединенном плане общевузовских дисциплин появится в таблице данных. При попытке добавления второго плана идентичного уже созданному произойдет ошибка дублирования объектов.

2. Редактирование объединенного плана общевузовских дисциплин

Редактирование объединенного плана общевузовских дисциплин состоит в наполнении его дисциплинами, НИС, или дисциплинами иностранных студентов, которые могут быть объединены в группы, уточнении объема нагрузки, установке форм итогового контроля.

Объединенный план может состоять из следующих видов записей: разделы (группы дисциплин), дисциплины, НИС и Дисциплины иностранных студентов. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в план записей других типов (курсовые, практики и проч.) недопустимо.

Редактирование объединенного плана выполняется при помощи специализированной формы редактирования, которая открывается при вызове для выбранного учебного плана действия Открыть или при двойном щелчке мышью по записи об учебном плане.

Редактирование объединенного плана общевузовских дисциплин

Добавление и удаление записей учебного плана, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню.

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

Редактирование записей объединенного плана

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

По окончании работы с объединенным планом его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати или Выгрузить для печати как РУП расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия учебный план будет выгружен для печати в MS Excel.

2.1. Добавление раздела (группы дисциплин)

Для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Добавление группы дисциплин в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

2.2. Добавление дисциплины

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать действие дисциплину,

Процедура добавление дисциплины в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный план общевузовских дисциплин
Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

    • После того как запись о дисциплине будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с записью дисциплины, предлагаемой кафедрой, разработчик объедиеннного учебного плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

2.3. Добавление НИС

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать действие научно-исследовательский семинар,

Процедура добавление НИС в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный план общевузовских дисциплин
Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Семинар, предлагаемый кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего будет добавлен в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Семинар, предлагаемый кафедрой оставить пустым.
    • в поле Семинар (дисциплина ВУЗа) указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.

    • После того как запись о НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания семинара с дисциплиной-предложением кафедры разработчик объединенного учебного плана больше не сможет изменять параметры нагрузки по семинару, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

2.4. Добавление дисциплины иностранных студентов

Добавлять Дисциплины для иностранных студентов можно только в объединенные планы общевузовских дисциплин, у которых при создании Тип общевузовского плана был установлен как "Дисциплины для иностранных студентов". (см. Создание нового объединенного плана общевузовских дисциплин).

Для добавления Дисциплины иностранных студентов необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие дисциплину иностранных студентов,

Процедура добавление дисциплины иностранных студентов в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины иностранных студентов в объединенный план общевузовских дисциплин
  1. В поле Кафедра задать кафедру, которая будет вести дисциплину.
  2. в поле Дисциплина для иностранных студентов указать требуемую дисциплину, для этого необходимо открыть справочник Все дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Все дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
  3. Заполнить поля: Имеет пререквизиты, Код записи, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  4. Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соотвествующую область науки из выпадающего списка Список или с помощью справочника Справочник.
  5. Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

Отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля) можно непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице, предназначено действие Дополнительные свойства.

Редактирование записей объединенного плана

При необходимости вновь созданную дисципину для иностранных студентов можно связать с записью дисциплины, предлагаемой к реализации кафедрами, для этого:

  1. Из контекстного меню нужно вызвать действие Связать с предложением кафедры. При помощи параметров этой процедуры можно попытаться поискать подходящую дисциплину. Можно выполнить поиск не точно такой же, а "похожей" дисциплины. Для этого нужно очистить значение в поле Дисциплина для выбора и снова поискать дисциплину в поле Предложение кафедры. Можно также очистить поле Кафедра и поискать дисциплину на всех кафедрах. Если походящая дисциплина найдена, ее нужно выбрать и нажать кнопку ОК.
  2. Если же подходящей дисциплины так и не найдено, нужно заполнить кафедру в поле Кафедра и установить флажок Создать заявку на дисциплину (флажок доступен при условии, что кафедра задана, а поле "Предложение кафедры" пустое), после чего нажать кнопку ОК. В результате будет выполнен поиск плана-предложения кафедры с атрибутами Год начала реализации, Уровень образования, Реализуется по периодам, соответствующими атрибутам учебного плана; если такого плана-предложения найдено не будет, он будет создан для указанной кафедры. В найденный или созданный план-предложение будет добавлена дисциплина со всей информацией о нагрузке, раннее занесенной для нее в учебном плане; дисциплина в плане-предложении кафедры получит статус "заявка на дисциплину".

После связывания дисциплины плана с дисциплиной, предлагаемой кафедрой, разработчик объединенного учебного плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

2.5. Перемещение записей

В случае если при добавлении Группы дисциплин или Дисциплины (НИС, Дисциплины иностранных студентов) был неверно указан раздел, куда они должны быть включены, то в отношении такой записи необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить запись, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина (НИС, Дисциплины иностранных студентов) будет перемещена в корень объединенного плана общевузовских дисциплин.

Также для изменения порядка следования записей можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

2.6. Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные планы общевузовских дисциплин (форма Учебные планы общевузовских дисциплин) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи плана выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

2.7. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

2.8. Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных планов общевузовских дисциплин выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.

3. Передача планов в реализацию

Для того, чтобы дисциплины объединенного плана общевузовских дисциплин могли быть назначены студентам, необходимо для плана выполнить действие Передать в реализацию.

Процедура передачи плана на факультет

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Дисциплины вне учебных планов. Эта таблица доступна в разделе Общевузовские ресурсы, в форме Учебные планы, формы и программы обучения на вкладке Дисциплины вне учебных планов.

Назначение общевузовских дисциплин студентам на участке Студент выполняется именно из таблицы данных Дисциплины вне учебных планов. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного плана общевузовских дисциплин необходимо выполнять действие по передаче плана в реализацию.

4. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные планы общевузовских дисциплин (форма Учебные планы общевузовских дисциплин) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как РУП, Выгрузить для печати на английском языке, Выгрузить для печати как рабочий на английском языке.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Рабочие учебные планы аспирантуры (РУПы аспирантуры) (раздел целиком) (31.03.2018) Одним файлом
Рабочие учебные планы аспирантуры (РУПы аспирантуры)

Рабочие учебные планы аспирантуры разрабатываются на основе Базовых учебных планов аспирантуры отдельно для каждой и для каждого учебного года. Рабочий учебный план аспирантуры отражает цикл дисциплин и других видов нагрузки, которые должны быть прослушаны и сданы аспирантами в течение одного года обучения с разбиением нагрузки по периодам обучения (полугодиям) т указанием форм промежуточного и итогового контроля по периодам обучения.

Каждый рабочий учебный план аспирантуры может расширять и уточнять содержание соответствующего базового учебного плана. Работа с РУПом аспирантуры состоит из этапов:

  • Создание РУП аспирантуры на основе БУП
  • Редактирование РУП аспирантуры
  • Согласование и утверждение РУП аспирантуры

1. Создание нового рабочего учебного плана аспирантуры

Для создания БУП аспирантуры необходимо, чтобы предварительно были сформированы следующие данные:

  • Создан и полностью сформирован Базовый учебный план аспирантуры, на основе которого должен быть разработан новый РУП.
  • В справочнике создан учебный год, на который будет разрабатываться новый РУП, и в составе этого учебного года должны быть созданы периоды обучения, по которым предстоит распределять нагрузку и планировать испытания (зачеты и экзамены).
  • В справочнике создана запись о форме и годе обучения, для которых будет разрабатываться РУП.

Создание и дальнейшая работа с РУП аспирантуры ведется в разделе Разработка учебных планов в форме Базовые и рабочие учебные планы аспирантуры на второй вкладке Рабочие учебные планы аспирантуры. Для создания нового РУП аспирантуры на этой вкладке необходимо вызвать действие Добавить рабочий учебный план.

Добавление РУП аспирантуры

Для добавления нужно в поле Аспирантская школа выбрать соответствующую школу из справочника , выбрать Базовый учебный план. После выбора базового учебного плана поля Направление / специальность и Форма обучения будут заполнены данными, соответствующими БУП. Изменять из независимо от БУП невозможно. Также необходимо выбрать Год обучения аспирантов из справочника и Учебный год из справочника . Значение в поле Количество учебных периодов позволит выполнять планировать нагрузку и проведение испытаний по соответствующему числу сессий. Значения Количество потоков, Количество групп, Количество аспирантов позволят рассчитывать нагрузку кафедр и преподавателей по реализации данного РУП.

После корректного заполнения всех полей формы добавления кнопка ОК станет активной. После ее нажатия новый рабочий учебные план аспирантуры будет добавлен в таблицу данных.

2. Редактирование рабочего учебного плана аспирантуры

После создания РУП аспирантуры его необходимо заполнить и отредактировать путем выполнения следующих двух этапов:

  1. Сформировать на основе БУП
  2. Отредактировать, указав распределение нагрузки, заданной БУП, по периодам учебного года, запланировать рубежные испытания (экзамены и зачеты) и текущий контроль (домашние задания, рефераты, контрольные работы). При необходимости можно уточнить и дополнить содержание БУП.

Формирование РУП аспирантуры на основе БУП

После создания РУП аспирантуры необходимо выбрать его в таблице данных и вызвать действие Сформировать на основе базового. Результатом выполнения этого действие будет копирование в РУП всего содержания РУП на один из годов обучения с сохранением структуры разделов и величин нагрузки, заданных в БУП.

Редактирование РУП аспирантуры

Для редактирования РУП аспирантуры предназначена специализированная форма, которая доступна посредством вызова действия Открыть по выбранному РУП. При помощи формы редактирования можно выполнять следующие операции:

  • Корректировать (в случае необходимости) или дополнять значения нагрузки, полученные из БУП
  • Распределять нагрузку, предусмотренную по дисциплине в учебном году по периодам учебного года.
  • Планировать текущий контроль (домашние задания, рефераты, контрольные работы и проч.).
  • Дополнять содержание БУП дополнительными дисциплинами и другими видами работы.
  • Уточнять структуру плана за счет добавления новых разделов или групп дисциплин и переноса дисциплин между разделами.

В целом принцип редактирования РУП аспирантуры аналогичен принципу редактирования РУП студентов, описанному в разделе Редактирование рабочего учебного плана.

Принципы работы с отдельными видами записей РУП аспирантуры аналогичны принципам, заложенным для РУП студентов и описаны в разделе Особенности наполнения отдельных разделов БУП и РУП.

В форме редактирования РУП аспирантуры реализованы проверки и автоматически расчеты, аналогичные реализованным для РУП факультетов. Принцип действия этих расчетов описан в разделе Расчетные показатели учебных планов.

Готовый РУП аспирантуры можно выгрузить в утвержденной форме в MS Excel при помощи действия Выгрузить для печати.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Редактирование объединенного учебного плана аспирантуры (раздел целиком) (31.03.2018) Одним файлом
Редактирование объединенного учебного плана аспирантуры

Сформировать структуру и состав нового объединенного учебного плана аспирантуры можно на основе образовательного стандарта. Для этого нужно выбрать объединенный учебный план аспирантуры в представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) и в контекстном меню выбрать действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Сообщение о формировании ОУП аспирантов на основании стандарта

Если Вы уверены, что хотите сформировать учебный план на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненном представлении Все записи плана.

После того, как объединенный учебный план сформирован на основе стандарта, его можно редактировать. Для редактирования предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования ОУп аспирантов

Редактирование объединенного учебного плана аспирантов должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (практик аспирантов, кандидатских экзаменов, и т.п.), распределять нагрузку по видам работы (лекции, семинары, практические и т.д.), по годам обучения и по периодам обучения в каждом году, а также планировать рубежные испытания, распределять кредиты и объем нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: дисциплину, научно-исследовательский семинар, научные исследования аспирантов, практику аспирантов, кандидатский экзамен, итоговый госэкзамен, защиту научного доклада.

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, дисциплина по выбору или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

Форма редактирования ОУП аспирантов распределение нагрузки по годам

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение свойств разделов и дисциплин ОУП.

По окончании работы с объединенным учебным планом аспирантов его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении действия учебный план будет выгружен для печати в MS Excel.

1. Добавление дисциплин и НИС

При добавлении дисциплины или НИС в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие дисциплину или научно-исследовательский семинар, после чего заполнить следующую форму параметров:

Форма параметров Добавить дисциплину в ОУП аспирантуры
Пользователям разработчикам учебных планов предоставлена возможность связывания дисциплин и НИС учебного плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
      Для выбора из плана-предложения кафедры будут доступны только те дисциплины, которые совпадают по периоду реализации с периодом, заданным с помощью полей Год начала реализации и Год окончания реализации.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • Установить значение для признака Входит в расчет недельной нагрузки.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных профилей аспирантуры, необходимо выбрать профили, для которых добавляется дисциплина. Для выбора профилей необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей профилей, после чего нужно нажать кнопку ОК.
      Для каждого профиля в ОУП будет создана отдельная запись по дисциплине.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Вид дисциплины в плане, По выбору студентов, Формат изучения,На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных профилей подготовки аспирантуре, необходимо выбрать профили, для которых добавляется дисциплина. Для выбора профилей необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей профилей, после чего нужно нажать кнопку ОК.
      Для каждого профиля в ОУП будет создана отдельная запись по дисциплине.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план аспирантуры.
    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (более подробно см. Редактирование объединенного учебного плана аспирантуры). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признак Входит в расчет недельной нагрузки.
  • Профили для дисциплин и НИС (см. Установить/ изменить профиль).
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

2. Добавление практики аспирантов

При добавлении практики аспирантов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие практику аспирантов, после чего заполнить следующую форму параметров:

Форма параметров Добавить практику в ОУП аспирантуры

В первую очередь необходимо ввести Наименование практики и Общее число часов, указать Вид практики (справочник ) и Способ проведения практики, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК практика будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по практике (см. Редактирование объединенного учебного плана аспирантуры).

3. Добавление научного исследования аспирантов

При добавлении научного исследования аспирантов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие научные исследования аспирантов, после чего заполнить следующую форму параметров:

Форма параметров Добавить научные исследования в ОУП аспирантуры

В первую очередь необходимо указать Наименование и Общее число часов для научных исследований аспирантов, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК запись о научных исследованиях аспирантов будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по научным исследованиям (см. Редактирование объединенного учебного плана аспирантуры).

4. Добавление кандидатских экзаменов

При добавлении кандидатского экзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие кандидатский экзамен, после чего заполнить следующую форму параметров:

Форма параметров Добавить кандидатский экзамен в ОУП аспирантуры

В первую очередь необходимо ввести Наименование для экзамена и Общее число часов, выбрать Дисциплину ВУЗа, по которой будет проходить кандидатский экзамен, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК кандидатский экзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по кандидатскому экзамену (см. Редактирование объединенного учебного плана аспирантуры).

5. Добавление итогового госэкзамена

При добавлении госэкзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие итоговый госэкзамен, после чего заполнить следующую форму параметров:

Форма параметров Добавить госэкзамен в ОУП аспирантуры

В первую очередь необходимо ввести Наименование для экзамена и Общее число часов, при необходимости можно выбрать Дисциплину, по программе которой будет проходить экзамен, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК госэкзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по госэкзамену (см. Редактирование объединенного учебного плана аспирантуры).

6. Добавление защиты научного доклада

При добавлении защиты научного доклада в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие защита научного доклада, после чего заполнить следующую форму параметров:

Форма параметров Добавить защиту докладов в ОУП аспирантуры

В первую очередь необходимо ввести Наименование, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК госэкзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по защите научного доклада (см. Редактирование объединенного учебного плана аспирантуры).

7. Формирование информации о численности контингента

Для добавления информации о численности контингента необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать план, для записей которого будет уточняться информация о численности контингента.
  2. В представлении Все записи по годам обучения для записей учебного плана в соответствующих полях указать Количество потоков, Количество групп, Количество подгрупп и Количество студентов (аспирантов) (после изменения значения каждого из параметров нужно нажимать клавишу Enter).

8. Изменение периода реализации

Для изменения периода реализации записи объединенного учебного плана аспирантов, необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать учебный план.
  2. В представлении Все записи плана выбрать запись учебного плана, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

9. Уточнение свойств разделов и дисциплин ОУП

В формах редактирования объединенных учебных планов аспирантуры работают проверки контрольных соотношений, при помощи которых контролируется корректность и целостность плана, соответствие характеристик записей плана требованиям образовательного стандарта, выполнение Методических указаний по разработке объединенных учебных планов аспирантуры. Также при помощи функционала формы редактирования можно выполнять автоматизированные пересчеты показателей плана, в частности, суммирование значений числа часов, недель, кредитов по разделам и группам дисциплин.

В образовательном стандарте не содержится достаточно информации для того, чтобы реализовать корректную работу некоторых автоматизированных проверок и пересчетов. По этой причине после формирования учебного плана на основе стандарта, необходимо выполнить уточнение следующих значений для некоторых разделов и дисциплин учебного плана:

  1. Признак Рассчитывается как сумма элементов для групп дисциплин и разделов.

    Все разделы и группы дисциплин можно разделить на два вида:

    • Разделы или группы, показатели которых должны определяться путем суммирования показателей входящих в них записей.
    • Разделы или группы, показатели которых могут устанавливаться независимо.

    К первой группе относятся разделы и группы, все дисциплины которых обязательны для изучения всеми аспирантами. Ко второй группе относятся разделы и группы дисциплин по выбору. Для того, чтобы отличить один вид разделов от другого используется признак Рассчитывается как сумма элементов. При формировании учебного плана на основе стандарта для всех разделов и групп дисциплин этот признак получает значение Да. Если для признака установить значение Нет, то проверка соответствия суммы показателей для всех записей раздела со значением, установленным для раздела в целом, проводиться не будет, и сообщения об ошибках не будут формироваться. Для группы дисциплин (раздела) по выбору значения числа часов, недель, кредитов, числа экзаменов и зачетов нужно установить вручную таким образом, чтобы раздел, в свою очередь, внес необходимый вклад в план в целом. Например, если в раздел включено три дисциплины по выбору, трудоемкостью 108 часов каждая, а аспиранты должны выбрать только одну из них, для раздела вручную должно быть установлено число часов, равное 108.

    Для того чтобы в дальнейшем на основании разработанных объединенных учебных планов можно было сформировать учебный план аспиранта и проверить его полноту и корректность, необходимо задать для каждой группы или раздела дисциплин по выбору минимальное и максимальное количество дисциплин, которые должны быть обязательно выбраны аспирантом, также необходимо задать минимально и максимальное число кредитов, которое необходимо набрать при выборе дисциплин аспирантом. Если при наполнении образовательного стандарта эти значения не заданы, то их необходимо задать в форме редактирования объединенного учебного плана при помощи действия Дополнительные свойства.

  2. Признак Входит в расчет недельной нагрузки. Данный признак используется для того, чтобы исключить некоторые дисциплины учебного плана из расчета недельной аудиторной нагрузки аспирантов. Изменить значение данного признака можно в форме редактирования учебного плана при помощи действия Дополнительные свойства. При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются двумя звездочками (**) в колонке "Наименование дисциплины". По этой причине вносить знаки * в наименование дисциплины не нужно. В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.

10. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связать с предложением кафедры в ОУП аспирантуры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

11. Установить/ изменить профиль

Для установки, снятия и изменения профиля, установленного для записи учебного плана, необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать учебный план, в который входит запись.
  2. В представлении Все записи плана выбрать запись, для которой необходимо установить, снять или изменить профиль.
    При добавлении дисциплины или НИС можно установить сразу несколько специализаций, для каждой из них будет создана отдельная запись о дисциплине или НИС (см. Добавление дисциплин и НИС). В связи с этим необходимо удостовериться, что выбранная дисциплина или НИС соответствуют той записи, которую необходимо изменить. Установленные специализации можно проверить в поле Специализация.
  3. Из контекстного меню вызвать действие Установить\изменить профиль.
  4. В форме параметров указать Специализацию (профиль аспирантуры).
  5. Нажать кнопку ОК.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Объединенные учебные планы (раздел целиком) (31.03.2018) Одним файлом
Объединенные учебные планы

"Объединенные учебные планы" - это такой вид учебных планов, который объединяет в себе "базовый учебный план" и "рабочий учебный план". Объединенный учебный план разрабатывается сразу на все годы реализации образовательной программы, содержит полный набор разделов, дисциплин и других видов записей планов на весь период обучения, и в то же время отражает планирование нагрузки как по дисциплине в целом, так и по видам работ (лекции, семинары, практически и т.п.), по учебным годам (курсам студентов), по периодам каждого года (модулям и семестрам), а также отражает планирование испытаний текущего и рубежного контроля. Дополнительной возможностью Объединенных учебных планов (по сравнению с РУП) является возможность распределения кредитов, аудиторных часов и общих часов по "частям дисциплины", ограниченным рубежными испытаниями (зачетами и экзаменами).

1. Создание нового объединенного учебного плана

Работа с Объединенными учебными планами ведется на участке "Разработка учебных планов" в форме "Объединенные учебные планы". Для создания нового объединенного учебного плана необходимо чтобы предварительно был сформирован соответствующий образовательный стандарт. Работа с образовательными стандартами описана в разделе Образовательные стандарты.

Для добавления объединенного учебного плана необходимо в верхней таблице данных Объединенные учебные планы с помощью контекстного меню вызвать действие Добавить объединенный план.

Добавление объединенного учебного плана

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров добавления объединенного учебного плана

  • В поле Уровень образования - указать уровень образования, для которого создается план.
  • В полях Образовательный стандарт и Образовательную программа - выбрать образовательный стандарт и программу, для которой создается план.
  • Поля Факультет, Филиал, Форма обучения, Магистерская программа, Число лет обучения будут заполнены автоматически данными, заданными для образовательного стандарта и выбранной образовательной программы.
  • При необходимости в полях Специализация и Магистерская специализация можно указать специализацию или магистерскую специализацию, если они не заданы для Образовательной программы.
  • В полях Год начала обучения, Год окончания обучения указать года начала и окончания обучения, периоды, по которым будет планироваться нагрузка (по модулям или по семестрам).
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов в году указать количество периодов в учебном году.

После того, как для всех полей формы добавления Объединенных учебных планов будут заданы допустимые значения, кнопка ОК на форме добавления станет доступной. После ее нажатия запись о новом объединенном учебном плане появится в таблице данных. При попытке добавления второго объединенного учебного плана на основе той же образовательной программы, образовательного стандарта для того же факультета, года начала обучения, специализации, магистерской программы, магистерской специализации произойдет ошибка дублирования объектов.

2. Редактирование объединенного учебного плана

Сформировать структуру и состав нового объединенного учебного плана можно на основе образовательного стандарта. Для этого нужно выбрать объединенный учебный план в таблице данных и в контекстном меню выбрать действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Подтверждение формирования БУП

Если Вы уверены, что хотите сформировать учебный план на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Все записи плана.

После того, как объединенный учебный план сформирован на основе стандарта, его можно редактировать. Для редактирования предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования ОУП

Редактирование объединенного учебного плана должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), распределять нагрузку по видам работы (лекции, семинары, практические и т.д.), по годам обучения (курсам студентов) и по периодам обучения в каждом году (модулям, семестрам), а также планировать рубежные испытания, распределять кредиты и объем нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: дисциплину, научно-исследовательский семинар, курсовую работу, практику, проект студентов, дисциплину других планов, итоговый экзамен, выпускную квалификационную работу, зачетно-экзаменационные недели.

Добавление записи в ОУП

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

Редактирование записей объединенного плана

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение ряда свойств разделов и дисциплин БУП.

По окончании работы с объединенным учебным планом его можно вывести на печать. Для этого можно воспользоваться одним из действий Выгрузить для печати, Выгрузить для печати как Базовый, Выгрузить для печати как рабочий, расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

2.1. Добавление дисциплин и НИС

При добавлении дисциплины или НИС в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие дисциплину или научно-исследовательский семинар, после чего заполнить следующую форму параметров:

Добавление дисциплины в ОУП
Пользователям разработчикам учебных планов предоставлена возможность связывания дисциплин и НИС учебного плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
      Для выбора из плана-предложения кафедры будут доступны только те дисциплины, которые совпадают по периоду реализации с периодом, заданным с помощью полей Год начала реализации и Год окончания реализации.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных специализаций, необходимо выбрать специализации, для которых добавляется дисциплина. Для выбора специализаций необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей специализаций, после чего нужно нажать кнопку ОК.
      Для каждой специализации в ОУП будет создана отдельная запись по дисциплине.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных специализаций, необходимо выбрать специализации, для которых добавляется дисциплина. Для выбора специализаций необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей специализаций, после чего нужно нажать кнопку ОК.
      Для каждой специализации в ОУП будет создана отдельная запись по дисциплине.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать и изменять специализацию для дисциплин и НИС (см. Установить или снять специализацию).
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

2.1.1. Установить или снять специализацию

Для установки, снятия и изменения специализации, установленной для дисциплины или НИС, необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Все записи плана выбрать дисциплину или НИС, для которой необходимо установить, снять или изменить специализацию.
    При добавлении дисциплины или НИС можно установить сразу несколько специализаций, для каждой из них будет создана отдельная запись о дисциплине или НИС (см. Добавление дисциплин и НИС). В связи с этим необходимо удостовериться, что выбранная дисциплина или НИС соответствуют той записи, которую необходимо изменить. Установленные специализации можно проверить в поле Для специализации.
  3. Из контекстного меню вызвать действие Установить\изменить специализацию.
  4. В форме параметров указать Специализацию факультета (для ОУП бакалавриата и специалитета) или Магистерская специализация (для ОУП магистратуры).
  5. Нажать кнопку ОК.

2.1.2. Изменение периода реализации

Для изменения периода реализации дисциплины или НИС, необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Все записи плана выбрать дисциплину или НИС, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

2.1.3. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

2.2. Добавление курсовой работы

При добавлении курсовой работы в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие курсовую работы, после чего заполнить следующую форму параметров:

Добавление курсовой работы в ОУП

В первую очередь необходимо указать Наименование для курсовой работы, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК курсовая работа будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по курсовой работе.

2.3. Добавление практики

При добавлении практики в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие практику, после чего заполнить следующую форму параметров:

Добавление практики в ОУП

В первую очередь необходимо указать Вид практики (справочник ) и Способ проведения практики, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК практика будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по практике.

2.4. Добавление итогового экзамена

При добавлении итогового экзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие итоговый экзамен, после чего заполнить следующую форму параметров:

Добавление итогового экзамена в ОУП

В первую очередь необходимо указать Наименование для итогового экзамена, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК итоговый экзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по итоговому экзамену.

2.5. Добавление выпускной работы

При добавлении выпускной работы в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие выпускную работу, после чего заполнить следующую форму параметров:

Добавление ВКРБ в ОУП

В первую очередь необходимо указать Наименование и Форму итогового контроля для выпускной работы, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК выпускная работа будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по выпускной работе.

2.6. Добавление зачетно-экзаменационной недели

При добавлении зачетно-экзаменационной недели в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие зачетно-экзаменационную неделю, после чего заполнить следующую форму параметров:

Добавление зачетно-экзаменационных недель в ОУП

В первую очередь необходимо указать Наименование зачетно-экзаменационной недели, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК зачетно-экзаменационная неделя будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки для зачетно-экзаменационной недели.

2.7. Добавление проекта студентов

При добавлении проекта студентов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие проект студентов..., после чего заполнить следующую форму параметров:
Добавление проекта в ОУП

  • В поле Проект для студентов необходимо выбрать проект из справочника Проекты для студентов, если проект отсутствует, то его можно добавить (см. Проекты для студентов). Данное поле можно оставить пустым и не устанавливать ссылку на проект из справочника, а только указать Наименование проекта, Вид дисциплины в плане и Число кредитов.
    Записи о проектах в объединенных учебных планах, не связанные с записью справочника проектов, в учебный план факультета передаваться не будут.
  • В поле Вид дисциплины в плане выбрать вид дисциплины.
  • В поле Число кредитов указать соответствующее данному проекту число кредитов.
  • При необходимости установить признак Только в кумулятивный рейтинг.

После нажатия кнопки ОК проект будет добавлена в объединенный учебный план.

2.7.1. Проекты для студентов

Справочник "Проекты для студентов" позволяет работать с информацией о проектах, в которые могут включаться студенты в своей внеадиторной деятельности. Справочник распологается в разделе Объединенные учебные планы на соотвествующей вкладке Проекты для студентов.
Справочник проекты для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить проект.
    Вызов действия Добавить проект
  2. Заполнить форму параметров следующим образом:
    Форма параметров Добавить проект
    • Заполнить поля Идентификатор во внешней системе, Полное наименование, Полное наименование на английском языке, Тип проекта (выбирается из справочника Типы проектов для студентов), Вид проектной деятельности (выбирается из списка).
    • В одной из групп полей Руководитель из вуза или Внешний руководитель указать подразделение/организацию руководителя (выбирается из справочников или Места прохождения практики) и выбрать самого руководителя проекта (выбирается из справочника или Работники организации).
      Руководителем проекта может быть только либо представитель вуза, либо внешний руководитель. При этом если начать заполнять одну из групп полей (Руководитель из вуза или Внешний руководитель) другая перестанет быть доступной для заполнения.
    • Заполнить поля Учебный год, Дата начала реализации, Дата окончания реализации, Дата окончания записи на проект, Количество модулей, Период итогового контроля, Вид итогового контроля и Плановое количество кредитов.
  3. Нажать кнопку ОК.

2.7.1.1. Выгрузить проекты студентов

В справочнике Проекты для студентов предоставлена возможность сформировать отчет с информацией о проектах и студентах, которым назначены данные проекты.

Для формирования отчета необходимо:

  1. В справочнике Проекты для студентов из контекстного меню системы вызвать действие Выгрузить проекты студентов.
    Вызов действия Выгрузить проекты
  2. В форме пераметров с помощью выбора значений для параметров Филиал, Факультет, Образовательная программа, Курс, Группа, Проект можно ограничить выборку проектов, для которых будет формироваться отчет. Если все поля формы параметров оставить пустыми, то отчет сформируется для всех проектов ВУЗа, присутствующих в справочнике Проекты для студентов.
  3. Нажать кнопку ОК.

В результате сформируется отчет в формате MS Excel, содержащий информацию об образовательной программе, ФИО, курсе и группах студентов, участвующих в проектах, наименовании проекта, плановом и фактическом количестве кредитов, руководителях проектов, результатах участия в проекте студентов.

2.7.1.2. Загрузка данных о проектах с портала

2.7.1.3. Загрузка данных о назначении проектов студентам

2.7.2. Типы проектов для студентов

Справочник "Типы проектов для студентов" содержит в себе перечень типов проектов для внеаудиторной деятельности студентов и распологается в разделе Объединенные учебные планы на соотвествующей вкладке Типы проектов для студентов.
Справочник Типы проектов для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить тип проекта.
    Вызов действия Добавить тип проекта
  2. В форме параметров указать Краткое наименование и Полное наименование типа проекта для студентов.
    Форма параметров Добавить тип проекта
  3. Нажать кнопку ОК.

2.8. Добавление дисциплины других планов

Для добавления дисциплин, которые участвуют в расчетах затратности, но при этом не передаются в реализацию на факультеты и которые не участвуют в планировании нагрузки, необходимо:

  1. В форме редактирования объединенного учебного плана или в представлении Все записи плана из контекстного меню, в группе процедур Добавить, вызвать действие дисциплинудругих планов.
  2. Заполнить следующую форму параметров:
    Добавление дисциплины других учебных планов в ОУП
    • В полях Наименование и Наименование на английском языке указать наименование на русском и английском языке (при необходимости) соответственно.
    • При необходимости в поле Кафедра можно указать подразделение ВУЗа, которое реализует данную дисциплину. Для этого необходимо нажать кнопку Справочник, из справочника , с помощью чек-бокса Чек-бокс, выбрать подразделение и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, Общее число часов, Аудиторных часов и Только в кумулятивный рейтинг.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
  3. Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

Отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля) можно непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице, предназначено действие Дополнительные свойства.

2.9. Формирование информации о численности контингента

Для добавления информации о численности контингента необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать план, для записей которого будет уточняться информация о численности контингента.
  2. В представлении Все записи по годам обучения для записей учебного плана в соответствующих полях указать Количество потоков, Количество групп, Количество подгрупп и Количество студентов (после изменения значения каждого из параметров нужно нажимать клавишу Enter).

3. Передача плана на факультет

Для того, чтобы дисциплины объединенного учебного плана могли быть назначены студентам, необходимо для плана выполнить действие Передать на факультет. Для каждого отдельного года реализации плана можно также вызывать действие Передать в план факультета в подчиненной таблице Реализация плана по годам.

Передача ОУП на факультет

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.
Записи о проектах студентов в объединенных учебных планах, не связанные с записью справочника проектов, в учебный план факультета передаваться не будут.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Учебные планы факультета. Эта таблица доступна в разделе Студент, в форме Справочники факультета на вкладке Учебные планы факультета.

Назначение дисциплин студентам на участке Студент выполняется именно из таблицы данных Учебные планы факультета. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного учебного плана необходимо выполнять действие по передаче плана на факультет.

4. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как Рабочий, Выгрузить для печати как Базовый, Выгрузить для печати как Рабочий с нагрузкой преподавателей, Выгрузить для печати на английском, Выгрузить для печати как Базовый на английском или Выгрузить для печати как Рабочий на английском.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.

5. Оценка плановой затратности плана

Для оценки плановой затратности плана необходимо:

С помощью формирования отчета "Оценка плановой затратности плана"

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
    Группа действий Дополнительные действия
  2. Выбрать действие Оценка плановой затратности (отчет).
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате сформируется отчет с оценкой затратности реализации объединенного учебного плана.

С помощью действия Рассчитать плановую затратность

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
  2. Выбрать действие Рассчитать плановую затратность.
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате будет выведено сообщение с указание плановой затратности плана.

6. Оценка фактической затратности ОП

Для оценки фактической затратности образовательной программы необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать запись объединенного учебного плана.
  2. Из контекстного меню системы вызвать действие Оценка фактической затратности ОП.
  3. В форме параметров указать Учебный год, если нужна конкретизация по преподавателям, то для признака С конкретизацией по преподавателям нужно установить значение "Да".
  4. Нажать кнопку ОК.

В результате сформируется отчет с оценкой фактической затратности реализации образовательной программы.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Объединенные планы факультетских дисциплин (раздел целиком) (31.03.2018) Одним файлом
Объединенные планы факультетских дисциплин

Объединенный план факультеских дисциплин представляет собой иерархическую структуру групп дисциплин (раделов) и включенных в них дисциплин.

Создание нового объединенного плана факултетских дисциплин включает следующие этапы работы:

1. Создание нового объединенного плана факультетских дисциплин

Работа с Объединенными учебными планами ведется на участке "Разработка учебных планов" в форме "Объединенные планы факультетских дисциплин".

Для добавления плана необходимо в верхней таблице данных Объединенные планы факультетских дисциплин с помощью контекстного меню вызвать действие Добавить объединенный план факультетских дисциплин.

Процедура добавления объединеннго плана факультетских дисциплин

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров добавления объединенного плана факультетских дисциплин

  • В поле Год начала обучения указать год начала обучения по данному плану.
  • В поле Филиал указать филиал, в котором находится факультет.
  • В поле Факультет выбрать один из факультетов из общевузовского справочника
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов указать количество периодов в учебном году.
  • В поле Число лет указать количество лет, в течение которых реализуется объединенный план факультетских дисциплин.

После того, как для все поля формы будут заполнены, кнопка ОК на форме добавления станет доступной. После ее нажатия, запись о новом объединенном плане факультетских дисциплин появится в таблице данных. При попытке добавления второго плана идентичного уже созданному произойдет ошибка дублирования объектов.

2. Редактирование объединенного плана факультетских дисциплин

Редактирование объединенного плана факультетских дисциплин заключается в создании Групп дисциплин (разделов), добавлении дисциплин в разделы, распределении нагрузки по видам работы (лекции, семинары, практические и т.д.), по годам обучения и по периодам обучения в каждом году (модулям, семестрам), а также планировании рубежных испытаний, распределении кредитов и объемов нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Добавление Группы дисциплин (раздела)

Для редактирования объединенного плана факультетских дисциплин необходимо в таблице данных Объединенные планы факультетских дисциплин выбрать план и с помощью контекстного меню вызвать действие Открыть.

Открытие формы редактирования объединенного плана факультета

В итоге откроется форма редактирования с пустым планом, в которой для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Процедура добавления раздела в объединенный план факультета

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования объединенного плана.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования объединенного плана факультетских дисциплин.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

Добавление Дисциплины или НИС

Для добавления Дисциплины необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие Дисциплину или НИС,

Процедура добавления дисциплины в объединенный план факультета

после чего заполнить следующую форму параметров:

Форма параметров добавления дисциплины в объединеннй план факультетских дисциплин

Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.

    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

Перемещение Группы дисциплин (раздела) или дисциплины

В случае если при добавлении Группы дисциплин или Дисциплины был неверно указан раздел, куда они должны быть включены, то в отношении такой Группы дисциплин или Дисциплины необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить Группу дисциплин или Дисциплину, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина будут перемещены в корень объединенного плана факультетских дисциплин.

Также можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

Печать объединенных планов факультетских дисциплин

По окончании работы с объединенным учебным планом его можно вывести на печать. Для этого можно воспользоваться одним из действий Выгрузить для печати, Выгрузить для печати как Базовый, Выгрузить для печати как Рабочий расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

2.1. Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные планы факультетских дисциплин (форма Объединенные планы факультетских дисциплин) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи плана выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

2.2. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

2.3. Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных планов факультетских дисциплин выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.

3. Передача объединенного плана факультетских дисциплин в реализацию

Для того, чтобы дисциплины объединенного плана факультетских дисциплин могли быть назначены студентам, необходимо для плана выполнить действие Передать на факультет. Для каждого отдельного года реализации плана можно также вызывать действие Передать в план факультета в подчиненной таблице Реализация учебного плана по годам.

Передача плана факультетских дисциплин в реализацию

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Планы факультетских дисциплин. Эта таблица доступна в разделе Студент, в форме Справочники факультета на вкладке Планы факультетских дисциплин.

Назначение дисциплин студентам на участке Студент выполняется именно из таблицы данных Планы факультетских дисциплин. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного плана факультетских дисциплин необходимо выполнять действие по передаче плана на факультет.

4. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные планы факультетских дисциплин (форма Объединенные планы факультетских дисциплин) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как РУП, Выгрузить для печати как БУП.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Рабочие майноры (раздел целиком) (31.03.2018) Одним файлом
Рабочие майноры

Рабочий майнор - это план изучения определенного набора дисциплин, входящих в состав одно из Базовых майноров в течение одного учебного года (одного курса студентов). Рабочие майноры разрабатываются на основе разработанных и утвержденных Базовых майноров.

Рабочие майноры для "свободных майноров" не создаются.

1. Создание нового рабочего майнора

Создание рабочего майнора и работа с ним осуществляется в форме Майноры учебных планов, доступной на консоли управления в разделе Разработка учебных планов.

Майноры на консоли управления

Представление для работы с рабочими майнорами расположено на третьей вкладке данной формы.

Таблица данных Рабочие майноры

Создать новый рабочий майнор можно только на основе ранее созданного базового майнора вида "Обычный майнор". Рабочие майноры для "свободных" майноров не создаются. Для добавления нового рабочего майнора в таблице данных нужно вызвать действие Добавить рабочий майнор. При вызове действия будет отображена форма параметров, которую нужно заполнить следующим образом:

Добавление Рабочего майнора
  • Базовый майнор - в этом поле нужно выбрать один из базовых майноров, на основе которого будет разрабатываться новый рабочий майнор.
  • Учебный год - в этом поле нужно выбрать учебный код, для которого будет разрабатываться новый рабочий майнор, из справочника .
  • Курс - в этом поле нужно выбрать курс студентов, для которого будет разрабатываться новый рабочий майнор.
  • Реализуется по периодам - в этом поле нужно выбрать один из вариантов реализации майнора - по модулям или по семестрам.
  • Количество периодов - в этом поле нужно задать целочисленного значение числа периодов (модулей или семестров), для которых будет распределяться нагрузка по дисциплинам майнора.

После нажатия кнопки ОК запись о новом майноре будет добавлена в основную таблицу данных.

2. Редактирование рабочего майнора

Редактирование рабочего майнора состоит в задании кафедр, которые будут реализовывать дисциплины, уточнении параметров нагрузки по дисциплине (часов, кредитов), распределении нагрузки по видам работы (лекции, семинары, самостоятельная работа и проч.), и по периодам обучения (модулям или семестрам), установке числа форм текущего контроля (контрольных работ, домашних задний и проч.). Структура рабочего майнора должна повторять структуру базового майнора и соответствовать требованиям, предъявляемым к структуре базового майнора, которые описаны в разделе Редактирование базового майнора. Отличие структуры рабочего майнора от структуры базового майнора может состоять только в отсутствии в рабочем майноре групп дисциплин, которые не реализуются на соответствующем курсе.

Редактирование рабочего майнора выполняется при помощи специализированной формы редактирования, которая открывается при вызове для майнора действия Открыть или при двойном щелчке мышью по записи о майноре.

Форма редактирования Рабочего майнора

Установка кафедры, реализующей дисциплину майнора, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню. Основные характеристики записей майнора (число часов, кредитов), их распределение по видам работы и периодам обучения выполняется непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей майнора, не видимых в таблице, предназначено действие Дополнительные свойства. Для уточнения нагрузки и видов испытаний по периодам обучения предназначено действие Дополнительные свойства в периоде. Перед вызовом этого действия нужно выбрать одну из ячеек в колонке, соответствующей периоду, в правой части формы.

В основном процесс редактирования рабочего майнора аналогичен процессу редактирования Рабочего учебного плана (см. раздел Редактирование рабочего учебного плана) с учетом особенностей работы с записями разных типов, описанных в разделе Особенности наполнения отдельных разделов БУП и РУП. Для рабочего майнора предусмотрена работа только с разделами (группами дисциплин) и с дисциплинами.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Аналитические отчеты по РУП (раздел целиком) (31.03.2018) Одним файлом
Аналитические отчеты по РУП

1. Перечень утвержденных РУП (Форма 1)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Перечень утвержденных РУП (форма 1).
    Перечень утвержденных РУП

  2. В открывшейся форме параметров:
    Форма параметров Перечень утвержденных РУП

    • В поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • В поле Учебный год указать учебный год, для которого формируется отчет.
    • Для параметров Только по утвержденным РУП и Выводить оценку затратности с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

2. Регламентирующие показатели РУП (Форма 3)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Регламентирующие показатели РУП (форма 3).
    Регламентирующие показатели РУП

  2. В открывшейся форме параметров:
    Форма параметров Регламентирующие показатели РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • В поле Учебный год указать учебный год, для которого формируется отчет.
    • Для параметров Показывать соотношение в % и Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

3. Виды дисциплин в БУП и РУП (Форма 7)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Виды дисциплин в БУП и РУП (форма 7).
    Виды дисциплин в БУП и РУП

  2. В открывшейся форме параметров:
    Форма параметров Виды дисциплин в БУП и РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • В поле Учебный год указать учебный год, для которого формируется отчет.
    • В поле Вид учебных планов выбрать требуемый вид учебных планов.
    • Для параметра Только по утвержденным планам с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

4. Формы контроля в РУП (Форма 10)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Формы контроля в РУП (форма 10).
    Формы контроля в РУП

  2. В открывшейся форме параметров:
    Форма параметров Формы контроля в РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметра Учебный год.
    • При необходимости можно установить ограничение для отчета и указать параметр Только уровень образования.
    • Для параметра Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

5. Дисциплины РУП по циклам ГОС (Форма 11)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Дисциплины РУП по циклам ГОС (форма 11).
    Дисциплины РУП по циклам ГОС

  2. В открывшейся форме параметров:
    Форма параметров Дисциплины РУП по циклам ГОС

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметра Учебный год.
    • Для параметра Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

6. Дисциплины, не назначенные ни одному студенту

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Дисциплины, не назначенные ни одному студенту.
    Дисциплины, не назначенные ни одному студенту

  2. В открывшейся форме параметров:
    Форма параметров Дисциплины, не назначенные ни одному студенту

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметров Учебный год и Факультет.
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

7. Дисциплины по числу вхождений в РУП

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Дисциплины по числу вхождений в РУП.
    Дисциплины по числу вхождений в РУП

  2. В открывшейся форме параметров:
    Форма параметров Дисциплины по числу вхождений в РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметра Учебный год.
    • При необходимости можно установить параметр Минимальное число вхождений.
    • Для параметра Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

8. Выгрузка записей РУП для анализа

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Выгрузка записей РУП для анализа.
    Выгрузка записей РУП для анализа

  2. В открывшейся форме параметров:
    Форма параметров Выгрузка записей РУП для анализа

    • Устновить значения параметров Учебный год, Уровень образования, Филиал, Факультет и Образовательная программа.
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Разработка и согласование учебных планов (раздел целиком) (31.03.2018) Одним файлом
Разработка и согласование учебных планов

Подсистема разработки и согласования учебных планов автоматизирует процессы подготовки проектов учебных планов факультетов и отделений на основе действующих образовательных стандартов, контроля соответствия проектов планов утвержденным требованиям и нормативами, процедуры согласования планов должностными лицами ВУЗа, контроля степени готовности планов очередного учебного года.

Доступ к функционалу подсистемы осуществляется посредством форм работы с данными Образовательные стандарты, Базовые и рабочие учебные планы, Ход согласования учебных планов. Данные формы доступны на Консоли управления системы в визуальной группе Разработка учебных планов.

Доступ пользователя к функционалу подсистемы зависит о его включения в одну из ролей:

  • Разработчик учебных планов
  • Специалист Методического управления
  • Проректор, согласующий учебные планы
  • Первый проректор, утверждающий рабочие учебные планы, согласующий базовые учебные планы
  • Ректор, утверждающий базовые учебные планы
  • Администратор подсистемы разработки учебных планов

Работа по подготовке, согласованию и утверждению учебных планов состоит из следующих этапов:

  1. Формирование справочника типов образовательных стандартов.
  2. Ввод образовательных стандартов.
  3. Формирование базовых учебных планов на основе образовательных стандартов.
  4. Формирование рабочих учебных планов на основе базовых учебных планов.

Описанный порядок работы касается как учебных планов основных образовательных программ подготовки бакалавров, специалистов и магистров, так и учебных планов аспирантуры.

Помимо учебных планов образовательных программ в системе также предусмотрена работа со следующими особыми видами учебных планов:

Рабочие учебные планы общевузовских дисциплин - это наборы дисциплин, которые предлагаются для выбора всем студентам вуза независимо от того, по какой образовательной программе они обучаются.

Майноры учебных планов - это наборы дисциплин, предлагаемых отдельными образовательными программами для изучения студентами других образовательных программ. Дисциплины майнора являются связанными друг с другом и планируются для изучения в течение нескольких лет (курсов). Студенты выбирают для изучения тот или иной майнор, после чего дисциплины, входящие в состав майнора, становятся обязательными для студента. Майноры могут принадлежать к одному из двух типов:

  • Обычный майнор - это набор дисциплин, изучение которых запланировано в определенной последовательности. При выборе студентом такого майнора на начальном курсе, дисциплины майнора становятся обязательным для него как на этом, так и на последующих курсах.
  • Свободный майнор - это такой майнор, выбрав который, студент сохраняет свободу в выборе дисциплин из любых майноров в течение всех лет обучения. В системе такой майнор создается, но не наполняется дисциплинами (т.е. остается пустым).

Мйноры, по аналогии с учебными планами, могут быть "базовыми" и "рабочими". Базовые майноры позволяют планировать перечень дисциплин и последовательность их изучения на все годы реализации майнора. Рабочие майноры более подробно отражают изучение дисциплин майноров в одном учебном году (для одного курса студентов). Каждый Рабочий майнор должен разрабатываться на основе утвержденного Базового майнора, должен содержать те же группы дисциплин и дисциплины, соответствующие дисциплинам Базового майнора, реализуемым в одном учебном году.

1. Настройки для работы с учебными планами

Прежде чем начать пользоваться функционалом участка Разработка учебных планов необходимо задать настройки Филиал и Факультет. Для определения данных настроек нужно воспользоваться разделом Настройки для работы с учебными планами на участке Разработка учебных планов.
Настройки для работы с учебными планами

После нажатия кнопки ОК все настройки будут заданы.

2. Справочник "Типы образовательных стандартов"

Работа со справочником ведется в форме Образовательные стандарты на вкладке Типы образовательных стандартов.

Типы образовательных стандартов

Для добавления нового вида стандарта нужно вызвать в таблице данных действие Добавить тип стандарта и заполнить поля Краткое наименование и Полное наименование.

Добавление типа стандарта

После добавления типа стандарта его краткое и полное наименование можно скорректировать непосредственно в таблице данных, введя новое значение с клавиатуры и нажав клавишу Enter.

Если тип стандарта создан ошибочно, его можно удалить, вызвав действие Удалить. Удаление возможно только в том случае, если в системе не существует стандартов данного вида.

3. Образовательные стандарты

Образовательный стандарт в системе представляет собой иерархическую структуру учебных циклов и включенных в них учебных дисциплин, снабженных информацией о трудоемкости их усвоения, выраженной в зачетных единицах (кредитах) или в учебных часах. Каждый образовательный стандарт соответствует одной степени / квалификации по одному из направлений / специальностей подготовки. К каждому образовательному стандарту относится перечень компетенций, развиваемых в ходе обучения студента по соответствующей образовательной программе. Развитие компетенций в каждом из учебных циклов отражается за счет связи цикла с набором компетенций стандарта.

Создание нового образовательного стандарта включает следующие этапы работы:

  1. Создание записи о стандарте.
  2. Наполнение стандарта записями о циклах дисциплин, учебных дисциплинах и других видах учебной нагрузки.
  3. Создание перечня компетенций, входящих в состав стандарта.
  4. Связывание записей стандарта с компетенциями.
Работа с компетенциями (пункты 3 и 4) ведется только при работе с образовательными стандартами III поколения (ФГОС, Оригинальные образовательные стандарты).

3.1. Создание нового образовательного стандарта

Для создания нового образовательного стандарта необходимо открыть форму Образовательные стандарты. Форма доступна на Консоли управления или на Панели инструментов системы.

В основной таблице данных Образовательные стандарты необходимо вызвать действие Добавить образовательный стандарт. При вызове действия будет отображена форма параметров нового стандарта:

Добавление образовательного стандарта

Поля формы добавления нужно заполнить следующим образом:

  • В поле Тип образовательного стандарта нужно выбрать один из типов, занесенных в Справочник "Типы образовательных стандартов".
  • В поле Уровень образования из выпадающего списка необходимо выбрать один из вариантов Бакалавриат, Специалитет, Магистратура или Аспирантура в зависимости от того, для какого уровня образования предназначен стандарт.
  • В поле Направление / специальность нужно выбрать соответствующую запись из общевузовского справочника . При выборе направления или специальности обращайте внимание не только на ее наименование, но и на код. Если в предыдущем поле выбрано значение "Бакалавриат" или "Магистратура", то для выбора будут предложены записи справочника, являющиеся направлениями, если же выбрано значение "Специалитет", то будут предложены записи, являющиеся специальностями (установлен флаг Является специальностью). В случае если Вы не находите нужного направления или специальности в этом справочнике, необходимо обратиться к бизнес-администратору системы с просьбой добавить его в справочник.
  • В поле Степень (квалификация) нужно выбрать степень или квалификацию, соответствующую уровню образования. В случае, если в предыдущем поле выбрано направление подготовки, то для выбора будут доступны степени бакалавр или магистр. Если же выбрана специальность, то для выбора будет доступна соответствующая квалификация. При создании образовательного стандарта для аспирантуры нужно выбрать степень кандидат наук.

Поле заполнения полей формы добавления надо нажать кнопку ОК, в результате чего в таблице появится запись о новом стандарте. При создании стандарта ему автоматически присваивается наименование, состоящее из типа стандарта, кода и наименования направления (специальности) и степени (квалификации). Создание двух и более стандартов одного типа по одной и той же степени (квалификации) одного и того же направления (специальности) недопустимо. При попытке создать второй аналогичный стандарт пользователь увидит сообщение об ошибке дублирования объектов.

Все созданные в системе образовательные стандарты отображаются в одной таблице данных, сгруппированной по уровням образования.

3.2. Наполнение образовательного стандарта

После создания записи о стандарте можно формировать структуру компонентов и дисциплин, составляющих стандарт. Записи стандарта имеют иерархическую структуру, отражающую включенность одних компонентов в состав других и вхождение дисциплин и других видов учебной нагрузки в группы и компоненты. Каждая запись наряду с атрибутами "наименование", "число часов", "число кредитов" и проч. имеет атрибут Входит в раздел, содержащий ссылку на раздел (или группу), в состав которого входит данная запись.

Стандарт состоит из записей нескольких видов:

  • раздел (цикл, компонент)
  • группа дисциплин
  • дисциплина
  • научно-исследовательский семинар
  • курсовая работа
  • практика
  • итоговый госэкзамен
  • выпускная квалификационная работа
  • зачетно-экзаменационные недели

Добавление записей стандарта производится путем вызова соответствующего действия их группы действий Добавить ....

Вид записи группа дисциплин должен использоваться во всех случаях, когда добавляемая запись строго не соответствует одной конкретной дисциплине, которая будет преподаваться на факультете определенной кафедрой по определенной программе или одной конкретной практике, курсовой работе и т.п. Например, запись "Иностранный язык" должна создаваться как группа дисциплин, в которую впоследствии будут включаться дисциплины "Английский язык", "Немецкий язык", "Французский язык" и т.д. Если набор иностранных языков, которые могут (должны) преподаваться по стандарту, известен, то их можно включить в группу иностранных языков как дисциплины. Если же набор иностранных языков не зафиксирован в стандарте, их можно будет задать позже при работе с базовым или рабочим учебным планом.

Если в стандарте задается объем нагрузки для курсовых работ в целом, а не для каждой работы, то такая запись также должна быть создана как раздел или группа дисциплин.

Если в стандарте задаются конкретные виды практик (учебная практика, преддипломная практика и т.д.), то такие записи могут быть созданы как практики. Если же в стандарте задается практика в целом, то такую запись нужно создать как раздел или как группу дисциплин.

В раздел итоговой государственной аттестации можно включить записи вида "итоговый госэкзамен" и "выпускная квалификационная работа", под которыми имеются в виду конкретные виды итоговых испытаний.

В дальнейшем при работе над базовыми и рабочими учебными планами, формируемыми на базе стандарта, в разделы и группы дисциплин можно будет включить записи о конкретных учебных дисциплинах и других видах учебной нагрузки. Также группы дисциплин используются в БУП и РУП для выделения групп дисциплин по выбору и задания их характеристик (число дисциплин или число кредитов, которое должно быть выбрано студентом по группе дисциплин).

Добавление записей стандарта должно начинаться с добавления корневого раздела (компонента). Для корневого раздела, как правило, задается наименование Вся образовательная программа. Для корневого компонента значение атрибута Входит в раздел должно быть пустым. Остальные записи должны включаться в состав этого корневого компонента или в состав других компонентов. Включение записей в состав дисциплин недопустимо. Иерархическая структура позволяет формировать стандарты любой структуры. Следующие ниже примеры будут иллюстрировать создание стандартов II и III поколения. Если ВУЗ имеет право вести обучение по собственным (оригинальным) стандартам, то они должны быть сформированы по аналогичным принципам.

Разделы и дисциплины стандарта могут иметь коды (ГСЭ.0, ЕН.Ф.03, Б1, Б5). В связи с тем, что в стандартах разных типов принято использование различных систем кодирования, включающих различные символы, а также в связи с тем, что не все записи стандарта имеют коды, для корректного задания порядка следования записей в стандарте используется дополнительное числовое поле Порядковый номер. Сортировка записей стандарта будет производиться в порядке возрастания значения порядкового номера в рамках каждого уровня иерархии (т.е. в рамках каждого раздела).

Пример структуры стандарта II поколения:

Структура стандарта II поколения

Пример структуры стандарта III поколения:

3.2.1. Добавление разделов (циклов, компанентов) стандарта

Для добавления компонента стандарта нужно выбрать запись о стандарте в основной таблице данных Образовательные стандарты, после чего в подчиненной таблице Состав стандарта вызвать действие Добавить ... / раздел. При добавлении первой записи нужно выполнить щелчок правой кнопкой мыши в пустом поле таблицы. При добавлении записи более низкого уровня сначала нужно выбрать запись компонента, в который планируется включить новый компонент, и только после этого вызвать действие добавления. Ссылка на запись компонента, выбранного в момент вызова действия добавления отобразится в поле Входит в раздел формы параметров. Если по ошибке вместо компонента выбрана дисциплина, то в поле Входит в раздел будет подставлена ссылка на раздел (компонент), в который включена данная дисциплина.

Добавление компонента стандарта II поколения:

Добавление раздела стандарта II поколения

Добавление компонента стандарта III поколения:

Добавление раздела стандарта III поколения

Поля формы добавления нужно заполнить следующим образом:

  • В поле Входит в раздел значение подставляется автоматически. Новая запись будет включена именно в данный раздел. При добавлении первой записи данное поле нужно оставить пустым. Если в поле подставилось значение, а Вы хотите добавить запись на первый уровень, то значение в поле нужно очистить, выделив весь текст и нажав клавишу Del.
  • Поле Компонент плана предназначено для работы со стандартами II поколения. В этом случае нужно выбрать необходимый компонент из справочника компонентов стандартов II поколения. После выбора значения в этом поле автоматически заполнятся и станут недоступными для изменения значения в полях Код записи и Наименование. При работе со стандартами III поколения это поле нужно оставить пустым.
  • В поле Наименование нужно ввести наименование раздела в случае, если не выбрано значение в предыдущем поле.
  • В поле Код записи нужно ввести код раздела в случае, если он задан в стандарте. Для стандартов II поколения это поле будет заполнено автоматически после выбора компонента плана в поле Компонент плана.
  • В поле Порядковый номер нужно ввести целое число, которое будет определять позицию записи в ряду всех записей, входящих в один раздел. Это значение предлагается автоматически как максимально существующий в данном разделе порядковый номер + 1. Если Вы хотите вставить запись не в конец, а в середину то это значение можно скорректировать. В этом случае после добавления записи нужно будет проверить и при необходимости изменить порядковые номера других записей. Сортировка записей стандарта будет производиться по значениям порядковых номеров в пределах каждого раздела. Допустим (но не рекомендуется) повтор значений порядковых номеров. В этом случае записи будут отсортированы в случайном порядке. Допустим пропуск значений позиций (например, 5, 10, 15, ...).
  • В поле Общее число часов нужно ввести значение общего числа часов по всем записям плана, входящим в раздел, в случае если это значение задано в стандарте.
  • В поле Число недель нужно ввести число недель, выделяемое на раздел, если это значение задано в стандарте.
  • Поля Минимальное число кредитов и Максимальное число кредитов предназначены для задания диапазона допустимых сумм кредитов для стандартов III поколения. В случае если задано одно значение числа кредитов, его нужно повторить в обоих полях.

3.2.2. Добавление групп дисциплин

В случае, если в стандарте указаны не конкретные дисциплины, а их обобщенные наименования (например, "Иностранный язык", "Древние языки", "Инженерно-технологические дисциплины, отражающие специфику отраслей сферы материального производства" и т.п.), то такие записи должны добавляться как группы дисциплин. При разработке базового учебного плана эти группы должны быть уточнены путем включения в них тех дисциплин, которые будут читаться студентам факультета (например, в группу "Иностранный язык" в базовом плане будут включены дисциплины "Английский язык", "Немецкий язык", в группу "Древние языки" будут включены дисциплины "Древнегреческий язык", "Латинский язык").

Для того, чтобы добавить в стандарт группу дисциплин нужно на вкладке Состав стандарта выбрать раздел, в который должна быть включена новая группа дисциплин и вызвать действие Добавить ... / группу дисциплин.

Добавление группы дисциплин в стандарт
  • В поле Входит в раздел должна отображаться ссылка на раздел, в который будет включена новая группа дисциплин. Если отображается неверный раздел, то нужно закрыть форму добавления, выбрать в списке записей стандарта нужный раздел и повторить вызов действия добавления.
  • В поле Наименование нужно ввести наименование группы дисциплин.
  • В поле Порядковый номер будет предложен очередной порядковый номер записи в выбранном разделе. При необходимости его можно изменить.
  • В поле Количество выбираемых дисциплин нужно занести числовое значение числа дисциплин данной группы, которое обязательно к изучению студентами.
  • В поле Общее число часов нужно занести число часов, выделяемых на изучение дисциплин группы.
  • В поле Число недель будет предложено значение, равное заданному числу часов, разделенному на 54. При необходимости это значение можно изменить.
  • В поле Число кредитовбудет предложено значение, равное заданному числу часов, разделенному на 36. При необходимости это значение можно изменить.

После нажатия кнопки ОК запись о новой группе дисциплин появится в таблице данных. После добавления группы дисциплин в нее можно включать отдельные дисциплины (если набор дисциплин задается в стандарте).

3.2.3. Добавление дисциплин

Дисциплины могут добавляться в любой из компонентов стандарта или в группу дисциплин. Для добавления дисциплины нужно выбрать в таблице данных компонент или группу, в которую должна быть включена дисциплина, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / дисциплину. При помощи этого действия должны добавляться только конкретные учебные дисциплины, которые будут читаться на факультете (отделении) определенной кафедрой по определенной программе. Если же в стандарте дисциплины заданы укрупненно, то нужно пользоваться действием добавления группы дисциплин (Добавление групп дисциплин).

Добавление дисциплины стандарта

Поля формы добавления дисциплины нужно заполнить следующим образом:

  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного компонента и снова вызвать действие добавления дисциплины.
  • В поле Дисциплина нужно выбрать дисциплину из общевузовского справочника дисциплин. Выбор можно осуществлять путем ввода начала наименования дисциплины с клавиатуры. При вводе будут предлагаться существующие в справочнике дисциплины. Процедура поиска дисциплины чувствительная к регистру символов. Наименования всех дисциплин справочника, как правило, начинаются с заглавной буквы. Если нужной дисциплины нет в справочнике, ее можно добавить, открыв справочник и вызвав действие Добавить дисциплину ВУЗа. Для добавления новой дисциплины достаточно ввести ее полное наименование. Наименование должно вводиться без сокращений. В дальнейшем оно будет использоваться во всех отчетных документах, а также в дипломе студента. Если при попытке добавления новой дисциплины произошла ошибка дублирования объектов, это означает, что дисциплина с таким наименованием уже существует.
  • В поле Код записи нужно ввести значение кода дисциплины в стандарте, если оно задано.
  • В поле Порядковый номер значение предлагается автоматически как следующая за максимально существующей в рамках раздела. При необходимости это значение можно изменить. Если необходимо добавить дисциплину не в конец, а в середину существующего списка, необходимо проверить и уточнить позиции всех следующих за ней дисциплин.
  • В поле Вид дисциплины нужно выбрать один из видов из выпадающего списка. Выбранный вид дисциплины в дальнейшем будет использоваться при контроле полноты и корректности формирования БУПов и РУПов, который может предполагать различные контрольные нормативы для обязательных дисциплин, факультативов, адаптационных дисциплин. Также от выбранного вида дисциплины зависит ее обязательность для изучения всеми студентами.
  • В поле По выбору студентов значение подставляется автоматически в зависимости от значения, выбранного в поле Вид дисциплины. Для видов Обязательная дисциплина и Обязательный факультатив подставляется значение Да, в остальных случаях - значение Нет. При необходимости установленное автоматически значение можно изменить.
  • В поле Общее число часов нужно ввести значение числа часов, выделяемых на изучение дисциплины, если оно задано в стандарте. При изменении значения в этом поле будут автоматически пересчитываться значения в полях Число недель и Число кредитов.
  • В поле Число недель значение будет заполнено автоматически путем деления значения из поля Общее число часов на 54. При необходимости это значение можно скорректировать.
  • В поле Число кредитов значение будет заполнено автоматически путем деления значения из поля Общее число часов на 36. При необходимости это значение можно скорректировать.

3.2.4. Добавление научно-исследовательских семинаров

Для добавления научно-исследовательского семинара предназначено действие Добавить / научно-исследовательский семинар. Форма добавление семинара и принципы ее заполнения аналогичны форме добавления дисциплины. Сам семинар выбирается из справочника всех дисциплин вуза. Если нужно семинара нет в справочнике, его можно добавить.

3.2.5. Добавление курсовых работ

Добавлять в образовательный стандарт курсовые работы надо только в том случае, если в нем зафиксированы конкретные работы, которые должны быть выполнены студентами. Если же курсовые работы заданы в стандарте укрупненно, то нужно пользоваться действиями, описанными в разделах Добавление разделов (циклов, компонентов) стандарта и Добавление групп дисциплин.

Для добавления курсовой работы нужно выбрать в таблице данных компонент или группу, в которую должна быть включена курсовая работа, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / курсовую работу. Курсовые работы могут быть как по одной конкретной учебной дисциплине, так и междисциплинарные. На приведенных ниже рисунках представлены примеры заполнения формы параметров в этих двух случаях. Если курсовая работа выполняется по конкретной дисциплине, но дисциплина может выбираться студентом, то курсовая работа добавляется по аналогии с междисциплинарной (дисциплина не указывается).

Добавление курсовой работы по дисциплине в стандарт

Добавление междисциплинарной курсовой в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел (группу дисциплин), который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления курсовой работы.
  • Поле По дисциплине нужно заполнять только в том случае, если курсовая работа должна выполняться по одной конкретной учебной дисциплине всеми студентами. Если дисциплина может выбираться студентами, или если курсовая работа является междисциплинарной, то данное поле нужно оставить пустым.
  • Поле Наименование доступно для заполнения только в том случае, если не выбрана дисциплина. По умолчанию предлагается наименование "Курсовая работа", но его можно изменить (например, "Междисциплинарная курсовая работа"). Если же дисциплина выбрана, то наименование курсовой работы будет сформировано автоматически.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для курсовых работ.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на данную курсовую работу.

После нажатия кнопки ОК на форме параметров запись о курсовой работе появится в таблице данных в соответствующей позиции.

3.2.6. Добавление практик

Добавлять в образовательный стандарт практики надо только в том случае, если в нем зафиксированы конкретные виды практик, которые должны быть пройдены студентами. Если же практики заданы в стандарте укрупненно, то нужно пользоваться действиями, описанными в разделах Добавление разделов (циклов, компонентов) стандарта и Добавление групп дисциплин.

Для добавления практики нужно выбрать в таблице данных компонент или группу, в которую должна быть включена практика, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить... / практику. Как правило, в образовательных стандартах выделяются специальные разделы практик.

Добавление практики в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел (группу дисциплин), который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления практики.
  • В поле Вид практики нужно выбрать практику из общевузовского справочника .
  • В поле Способ проведения практики нужно выбрать один из способов проведения практики.
  • После выбора вида практики в поле Наименование будет автоматически сформировано значение, соответствующее выбранному виду практики. Изменять его независимо от вида практики недопустимо.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • В поле Общее число часов значение можно оставить пустым, если оно не зафиксировано в стандарте.
  • В поле Число недель нужно задать число недель, выделяемых на практику.
  • В поле Число кредитов нужно установить число кредитов, выделяемых на практику, соблюдая требуемое соотношение между числом недель и числом кредитов.

После нажатия кнопки ОК на форме параметров запись о практике появится в таблице данных в соответствующей позиции.

3.2.7. Добавление итоговых госэкзаменов

итоговые государственные экзамены должны добавляться в раздел итоговой аттестации. Итоговые госэкзамены могут быть по одной конкретной дисциплине, или междисциплинарными.

Для добавления итогового экзамена нужно выбрать в таблице данных раздел итоговой аттестации, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / итоговый госэкзамен. На приведенных ниже рисунках представлены примеры заполнения формы параметров для случая добавления экзамена по дисциплине и междисциплинарного экзамена.

Добавление итогового экзамена по дисциплине в стандарт

Добавление междисциплинарного итогового экзамена в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления итогового госэкзамена.
  • Поле Дисциплина нужно заполнять только в случае экзамена по дисциплине. При выборе дисциплины автоматически формируется наименование записи об итоговом экзамене. Если экзамен является междисциплинарным, то поле Дисциплина нужно оставить пустым.
  • Поле Наименование доступно для заполнения только в случае, если поле Дисциплина пустое. В этом случае наименование итогового экзамена нужно ввести вручную с клавиатуры.
    Наименование, заданное для итогового экзамена, будет в дальнейшем использовано при формировании дипломов студентов.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для итогового экзамена.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на итоговый экзамен в соответствии с действующими нормативами.

После нажатия кнопки ОК на форме параметров запись об итоговом госэкзамене появится в таблице данных в соответствующей позиции.

3.2.8. Добавление выпускных квалификационных работ

Выпускные квалификационные работы (ВКР) должны добавляться в раздел итоговой аттестации.

Для добавления ВКР нужно выбрать в таблице данных раздел итоговой аттестации, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / выпускную работу.

Добавление ВКР в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления ВКР.
  • В поле Наименование нужно ввести наименование ВКР с клавиатуры (Например, "Подготовка и защита выпускной работы бакалавра" или "Подготовка и защита магистерской диссертации").
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для ВКР.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на ВКР в соответствии с действующими нормативами.

После нажатия кнопки ОК на форме параметров запись о выпускной работе появится в таблице данных в соответствующей позиции.

3.2.9. Добавление зачетно-экзаменационных недель

Зачетно-экзаменационные недели должны добавляться в корневой раздел стандарта (раздел "Вся образовательная программа").

Для добавления записи о зачетно-экзаменационных неделях нужно выбрать в таблице данных корневой раздел, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / зачетно-экзаменационные недели.

Добавление зачетно-экзаменационных недель в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления ВКР.
  • В поле Наименование автоматически формируется строка "Зачетно-экзаменационные недели". При необходимости это значение можно изменить.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • В поля Общее число часов и Число недель нужно занести значения, предусмотренные стандартом.

После нажатия кнопки ОК на форме параметров запись о зачетно-экзаменационных неделях появится в таблице данных в соответствующей позиции.

3.2.10. Внесение изменений в созданный стандарт

После того, как созданы записи стандарта, можно изменять как отдельные свойства записей, так и структуру стандарта. Доступны изменения следующих видов:

  1. Добавление новых записей.
    Для дополнения стандарта новыми записями необходимо вызвать одно из действий добавления, описанных в предыдущих разделах.
  2. Уточнение значений свойств записей стандарта.
    Значения различных свойств записей изменяются разными способами:
    • Наименование можно изменять путем ввода нового значения с клавиатуры с последующим нажатием клавиши Enter для всех записей, кроме тех, которые соответствуют дисциплинам (заполнено значение в колонке Дисциплина) или компонентам стандарта II поколения (заполнено значение в колонке Компонент плана). Для изменения наименования записи, соответствующей дисциплине, нужно в колонке Дисциплина выбрать другую дисциплину из справочника дисциплин. Если нужно дисциплины в справочнике нет, ее можно добавить в справочник. Для изменения наименования записи, соответствующей компоненту стандарта II поколения (ГОС) нужно выбрать другой компонент в колонке Компонент плана. Если нужного компонента в справочнике нет, необходимо обратиться к бизнес-администратору системы с просьбой уточнить данные справочника. При изменении наименования практики нужно проследить за тем, чтобы наименование соответствовало значению, установленному в колонке Вид практики.
    • Порядковый номер можно изменять путем ввода нового числового значения с клавиатуры с последующим нажатием клавиши Enter. При изменении порядкового номера одной из записей необходимо просмотреть значения порядковых номеров всех следующих за ней записей раздела и при необходимости скорректировать и их.
    • Код записи, Общее число часов, Число недель, Минимальное число кредитов, Максимальное число кредитов можно изменять путем ввода нового значения с клавиатуры с последующим нажатием клавиши Enter.
    • При изменении значений, выбранных в колонках Дисциплина и Компонент плана автоматически изменится значение в колонке Наименование.
    • Если Вы изменяете значение, выбранное в колонке Вид практики, необходимо вручную уточнить значение в колонке Наименование.
  3. Изменение структуры стандарта.
    Под изменением структуры понимается перенос записей из одного раздела в другой. Для этого нужно выбрать запись, которую Вы хотите перенести и вызвать для нее действие Перенести в другой раздел. Для выполнения действия нужно указать раздел, которому будет непосредственно подчинена запись.

    Перенос записи в другой раздел

    Для выбора будут доступны только записи вида Раздел плана (компоненты и группы дисциплин). Если Вы выполняете перенос раздела или группы, то необходимо следить за тем, чтобы не включить раздел сам в себя. При подобной попытке будет отображено сообщение об ошибке с текстом "Недопустимо включать раздел сам в себя".
  4. Удаление записей.
    Удаление записей производится при помощи действия Удалить, доступного в контекстном меню. Удалить можно только ту запись, в которую не включено ни одной другой записи. Это означает, что для того, чтобы удалить запись о разделе, нужно сначала удалить или перенести в другие разделы все входящие в него записи. Также удаление будет невозможным в случае, если на основе записи уже созданы записи базового или рабочего учебного плана.

3.3. Работа с компетенциями ФГОС

3.3.1. Создание перечня компетенций стандарта

В стандартах III поколения (Федеральных государственных образовательных стандартах, или ФГОС) присутствует перечень компетенций, развиваемых у студента в ходе обучения по соответствующим учебным программам. Перечень всех компетенций, перечисленных в стандарте, должен быть введен в систему. Сделать это можно, выбрав в таблице данных Образовательные стандарты нужный стандарт, и открыв подчиненную таблицу данных Компетенции в стандарте.

Добавление новой компетенции производиться при помощи действия Добавить компетенцию.

  • В поле Код компетенции нужно занести код, используемый для обозначения компетенции в стандарте.
  • В поле Тип компетенции нужно выбрать одно из предлагаемых значений из справочника типов компетенций.
  • В поле Описание компетенции нужно занести текст, разъясняющий содержание компетенции. Можно использовать стандартные действия копирования и вставки значений из других документов.

Перечень компетенций отображается сгруппированным по типам компетенций. После того, как компетенции будут связаны с определенными записями стандарта в подчиненной таблице Развитие в компонентах стандарта для каждой компетенции можно будет увидеть перечень записей стандарта, в которых она присутствует.

Перечень компетенций стандарта

В случае если в разных стандартах присутствуют схожие перечни компетенций, можно воспользоваться действиями Копировать и Вставить, вызываемыми из контекстного меню в таблице данных. Для этого нужно в главной таблице данных выбрать стандарт, для которого уже создан перечень компетеницй, в подчиненной таблице данных выбрать одну или несколько компетенций, выполнить действие Копировать. После этого выбрать другой стандарт в главной таблице, и в подчиненной таблице выполнить действие Вставить. После вставки значения кодов и описаний компетенций можно будет скорректировать.

3.3.2. Связь компетенций с записями стандарта

После того как сформированы записи стандарта (см. Наполнение стандарта компонентами и дисциплинами) и сформирован перечень компетенций стандарта (см. Создание перечня компетенций стандарта) можно устанавливать связи между записями стандарта и компетенциями. Для этого предназначена таблица данных, Развиваемые компетенции, расположенная на третьем уровне формы под таблицей Состав стандарта.

Компетенции могут связываться с любыми записями стандарта, как с компонентами, так и с дисциплинами. Для того, чтобы задать эту связь, нужно выбрать одну из записей стандарта, после чего в подчинненой таблице данных Развиваемые компетенции вызвать действие Добавить компетенцию.

Добавление компетенции к записи стандарта

В единственном поле формы параметров добавления компетенции нужно выбрать компетенцию из списка всех компетенций стандарта, или ввести код компетенции с клавиатуры. Для корректного поиска компетенции в перечне компетенций стандарта необходимо соблюдать регистр символов.

Полный перечень компетенций, связанных с записью стандарта, формируется многократным выполнением процедуры добавления компетенции. В случае, если нужной компетенции не найдено в перечне, предлагаемом для выбора, необходимо вернуться к этапу Создание перечня компетенций стандарта.

3.4. Работа с компетенциями оригинальных стандартов

В данном разделе описана реализованная в системе функциональность работы с системой компетенций. Ссистема компетенций может включать компетенции следующих видов:

  • Универсальные (системные) компетенции являются общими для всех направлений подготовки.
  • Профессиональные (инструментальные, социально-личностные) компетенции связаны с видами профессиональной деятельности.

Система компетенций состоит из общевузовских классификаторов компетенций трех основных видов: системных, социально-личностных и инструментальных, а также из перечня компетенций, формируемого для каждого из оригинальных образовательных стандартов на базе общевузовских справочников. Система компетенций включает в себя кодификацию, позволяющую отражать типологию компетенций, порядок их следования и взаимную связь друг с другом.

Работа с компетенциями оригинальных стандартов ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты.

Работа по формированию компетенций для каждого из образовательных стандартов должна включать следующие этапы:

  1. Формирование общевузовских справочников компетенций всех трех видов.
  2. Формирование перечня компетенций для образовательного стандарта, заключающееся в первичном наполнении перечня компетенциями из общевузовского справочника с дальнейшим уточнением их состава и содержания. Работа по уточнению перечня компетенций для стандарта ведется по-разному в зависимости от вида компетенции. Особенности работы с компетенциями разных видов описаны в следующих ниже разделах.

3.4.1. Общевузовские справочники компетенций

Работа по формированию системы компетенций оригинальных образовательных стандартов должна быть начата с формирования общевузовских классификаторов компетенций каждого из трех видов системных, социально-личностных и инструментальных.

Порядок работы с данными справочниками не существенен, однако до начала формирования перечней компетенций для конкретных образовательных стандартов общевузовские справочники компетенций должны быть сформированы полностью.

3.4.1.1. Системные (универсальные) компетенции

Работа с общевузовским справочником системных (универсальных) компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Системные компетенции.

Системные компетенции. Общевузовский справочник

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая системная компетенция имеет код и порядковый номер. Коды системных компетенций формируются автоматически из префикса СК-, символа уровня образования (Б или М) и порядкового номера (например, "СК-Б01", "СК-Б03", "СК-М08", "СК-М15"). Смысловое содержание компетенции представлено в поле Формулировка компетентностных образовательных результатов.

Для наполнения или уточнения общевузовского справочника системных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить системную компетенцию
  • Изменить порядковый номер
  • Удалить компетенцию
Уточнять текстовую формулировку компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter.

Добавление компетенции

Для того, чтобы добавить в справочник новую системную компетенцию, нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить системную компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление системной компетенции в общевузовский справочник

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Код компетенции значение будет составлено автоматически из префикса "СК-" (системная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура) и порядкового номера компетенции. Для порядковых номеров меньших 10 в первой позиции будет дописан 0. Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Формулировка компетентностных образовательных результатов значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой системной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера (кода) компетенции

Для изменения порядка следования компетенций предусмотрено действие контекстного меню Изменить порядковый номер. При изменении порядкового номера соответствующим образом изменится и код компетенции.

Изменение порядкового номера системной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции. При его изменении будет изменяться и код компетенции. Повтор порядковых номер компетенций недопустим. При попытке изменить порядковый номер компетенции на существующий произойдет ошибка дублирования объектов.

3.4.1.2. Социально-личностные компетенции

Работа с общевузовским справочником социально-личностных компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Социально-личностные компетенции.

Социально-личностные компетенции. Общевузовский справочник

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая социально-личностная компетенция имеет код и порядковый номер. Коды социально-личностных компетенций формируются автоматически из префикса СЛК-, символа уровня образования (Б или М) и порядкового номера (например, "СЛК-Б05", "СЛК-Б12", "СЛК-М02", "СЛК-М11"). Смысловое содержание компетенции представлено в поле Формулировка компетентностных образовательных результатов.

Для наполнения или уточнения общевузовского справочника социально-личностных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить социально-личностную компетенцию
  • Изменить порядковый номер
  • Удалить компетенцию
Уточнять текстовую формулировку компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter.

Добавление компетенции

Для того, чтобы добавить в справочник новую социально-личностную компетенцию, нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить социально-личностную компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление социально-личностной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Код компетенции значение будет составлено автоматически из префикса "СЛК-" (социально-личностная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура) и порядкового номера компетенции. Для порядковых номеров меньших 10 в первой позиции будет дописан 0. Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Формулировка компетентностных образовательных результатов значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера (кода) компетенции

Для изменения порядка следования компетенций предусмотрено действие контекстного меню Изменить порядковый номер. При изменении порядкового номера соответствующим образом изменится и код компетенции.

Изменение порядкового номера социально-личностной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции. При его изменении будет изменяться и код компетенции. Повтор порядковых номер компетенций недопустим. При попытке изменить порядковый номер компетенции на существующий произойдет ошибка дублирования объектов.

3.4.1.3. Инструментальные компетенции

Работа с общевузовским справочником инструментальных компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Инструментальные компетенции.

Инструментальные компетенции. Общевузовский справочник

Справочник имеет иерархическую структуру, которая отражает конкретизацию компетенций. Компетенции первого уровня являются наиболее общими и обозначают укрупненные виды деятельности (проектная деятельность, общение и коммуникация и проч.). Компетенция, которую конкретизирует данная компетенция, далее будет называться "родительской", а те компетенции, которые, в свою очередь, конкретизируют данную, будут называться "дочерними". Например, на представленном выше рисунке по отношению к компетенции "ИК-Б1.1 участвовать" родительской является компетенция "ИК-Б1 Проектная и иная деятельность", а дочерними являются компетенции "ИК-Б1.1н в научной деятельности" и "ИК-Б1.1и в исследовательской деятельности".

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая инструментальная компетенция имеет код и порядковый номер, а также может иметь символьное обозначение. Коды социально-личностных компетенций формируются автоматически из префикса ИК-, символа уровня образования (Б или М), собственного порядкового номера и порядковых номеров родительских компетенций, разделенных точкой, и символьного обозначения (при его наличии). Например, коды инструментальных компетенций могут иметь следующий вид: "ИК-Б1", "ИК-Б2.3", "ИК-М3.1и", "ИК-М2.2э". Для инструментальных компетенций в справочник заносится только наименование. Формулировки компетентностных образовательных результатов для компетенций данного вида будут задаваться отдельно для каждого из образовательных стандартов. Также в справочнике отображается формируемое автоматически полное наименование компетенции, составленное из наименования самой компетенции и всех ее родительских компетенций, разделенных символами "/".

Для наполнения или уточнения общевузовского справочника инструментальных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить компетенцию на первый уровень
  • Добавить дочернюю компетенцию
  • Изменить порядковый номер или символьное обозначение
  • Изменить родительскую компетенцию
  • Удалить компетенцию
Уточнять наименование компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter. Полное наименование компетенции при этом изменится автоматически.

Добавление компетенции

Для добавления инструментальных компетенций предусмотрено два действия: Добавить компетенцию на первый уровень и Добавить дочернюю компетенцию. Выбор действия зависит от того, нужно ли добавить самостоятельную компетенцию первого уровня, соответствующую укрупненному виду деятельности, которая не будет иметь родительской компетенции, или нужно добавить компетенцию, уточняющую одну из существующих (дочернюю по отношению к существующей).

Для добавления самостоятельной компетенции первого уровня нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить компетенцию на первый уровень. Отобразиться форма параметров процедуры добавления:

Добавление инструментальной компетенции на первый уровень

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего на первом уровне для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Символьное обозначение можно ввести символ, дополняющий код компетенции, если это необходимо. Если символьное обозначение для данной компетенции не используется, поле нужно оставить пустым.
  • В поле Код компетенции значение будет составлено автоматически из префикса "ИК-" (инструментальная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура), порядкового номера компетенции, символьного обозначения (если оно использовано). Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Наименование компетенции значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Для добавления компетенции, конкретизирующей одну из существующих, нужно сначала выбрать существующую (родительскую) компетенцию, которая должна быть конкретизирована, после чего вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить дочернюю компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление дочерней инструментальной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Родительская компетенция будет отображен код родительской компетенции, которая была выбрана в таблице данных перед вызовом действия добавления. Если новая компетенция должна быть подчинена другой родительской компетенции, то нужно закрыть данную форму при помощи кнопки Отмена, выбрать в таблице данных нужную родительскую компетенцию и снова вызвать действие добавления дочерней компетенции.
  • В поле Уровень образования значение будет подставлено автоматически на основе выбранной родительской компетенции. Изменять это значение при добавлении недопустимо. Если нужно добавить компетенцию для другого уровня образования, то нужно закрыть данную форму, выбрать в таблице данных родительскую компетенцию, принадлежащую к другому уровню образования и повторить добавление.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего на данном уровне иерархии для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Символьное обозначение можно ввести символ, дополняющий код компетенции, если это необходимо. Если символьное обозначение для данной компетенции не используется, поле нужно оставить пустым.
  • В поле Код компетенции значение будет составлено автоматически из префикса "ИК-" (инструментальная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура), порядкового номера компетенции и ее родительских компетенций, символьного обозначения (если оно использовано). Управлять значением данного поля можно изменяя порядковый номер, символьное значение или выбрав другую родительскую компетенцию перед добавлением.
  • В поле Наименование компетенции значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Удаление компетенции, имеющей дочерние компетенции, недопустимо. Если такую компетенцию все же надо удалить, то сначала нужно удалить все ее дочерние компетенции.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера и символьного обозначения компетенции

Для изменения порядка следования компетенций и их символьных обозначений предусмотрено действие контекстного меню Изменить порядковый номер или символьное обозначение. При изменении порядкового номера или символьного обозначения соответствующим образом изменится и код компетенции.

Изменение порядкового номера или символьного обозначения инструментальной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции и символьное обозначение. При изменении этих значений будет изменяться и код компетенции. Повтор полученных кодов компетенций недопустим. При попытке изменить порядковый номер или символьное обозначение таким образом, что полученный код компетенции будет повторять один из существующих, произойдет ошибка дублирования объектов.

Перенос компетенций по иерархической структуре

Для того, чтобы перенести существующую компетенцию по структуре (т.е. изменить для нее родительскую компетенцию), можно воспользоваться действием Изменить родительскую компетенцию.

Изменение родительской компетенции для инструментальной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Родительская компетенция нужно выбрать другую компетенцию из предложенного перечня, которая должна стать родительской по отношению к данной.
  • Значение полей Уровень образования и Наименование компетенции при использовании данной процедуры изменять нельзя.
  • В полях Порядковый номер и Символьное обозначение можно изменять значения описанным выше образом. Также при этом будет изменяться значение в поле Код компетенции.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о компетенции изменит свое положение в иерархической структуре. Также ей будут присвоены новые значения порядкового номера, сиваольного обозначения и кода.

3.4.2. Формирование и уточнение перечня компетенций для оригинального образовательного стандарта

При формировании на основе общевузовских справочников перечней компетенций для каждого из образовательных стандартов действуют следующие принципы:

  1. Системные (универсальные) компетенции переносятся в каждый из образовательных стандартов в полном соответствии с общевузовским справочником. Изменение перечня системных компетенций, их формулировок или кодов в конкретном стандарте недопустимо.
  2. Формулировки социально-личностных компетенций в каждом из образовательном стандарте могут уточнятся. При этом код компетенции автоматически получит постфикс, соответствующий аббревиатуре направления подготовки.
  3. Общевузовский справочник инструментальных компетенций имеет иерархическую структуру. Для инструментальных компетенций в общевузовском справочнике задаются только их наименования. Формулировка компетентностных образовательных результатов для инструментальных компетенций заносится только при добавлении компетенции в стандарт.
  4. В образовательный стандарт могут добавляться дополнительные социально-личностные компетенции, не связанные с компетенциями из общевузовского справочника. Добавление в стандарты системных и инструментальных компетенций, не связанных с общевузовскими справочниками, недопустимо.

Работа по формированию и уточнению перечня компетенций для каждого из образовательных стандартов ведется в форме Образовательные стандарты. Для того, чтобы просмотреть, сформировать или отредактировать перечень компетенций для стандарта, нужно выбрать этот стандарт на вкладке Образовательные стандарты и открыть подчиненную таблицу Компетенции в оригинальном стандарте.

До начала работы по формированию перечня компетенций для образовательных стандартов должны быть полностью сформированы Общевузовские справочники компетенций.

Для формирования и уточнения перечня компетенций в таблице данных Компетенции в оригинальном стандарте доступны действия, позволяющие:

  • переносить в образовательный стандарт полный набор компетенций определенного вида, занесенных в общевузовский справочник
  • добавлять к образовательному стандарту компетенции по одной
  • уточнять формулировку и код компетенции (доступно для социально-личностных и инструментальных компетенций)
  • удалять ошибочно добавленные компетенции

Коды компетенций, добавляемых в стандарт, могут отличаться от кодов, заданных в общевузовском справочнике. Отличие, как правило, заключается в дописывании к коду компетенции из общевузовского справочника аббревиатуры направления подготовки.

Аббревиатуры направлений подготовки задаются в общевузовском справочнике пользователями, наделенными правами на работу с данным справочником. Каждый образовательный стандарт относится к определенному направлению подготовки. Если аббревиатура направления не отображается в таблице "Образовательные стандарты" или отображается неверно, нужно обратиться к пользователю, ответственному за работу со справочником направлений и специальностей с просьбой уточнить аббревиатуру нужного направления.

3.4.2.1. Формирование перечня системных компетенций

Системные (универсальные) компетенции переносятся в каждый из образовательных стандартов в полном соответствии с общевузовским справочником. Изменение перечня системных компетенций, их формулировок или кодов в конкретном стандарте недопустимо.

Для переноса полного перечня системных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все системные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень системных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. Изменять формулировки или коды системных компетенций по сравнению с общевузовским справочником недопустимо.

Системные компетенции в образовательном стандарте

Если после последнего формирования перечня системных компетенций для стандарта произошло добавление системных компетенций в общевузовский справочник, действие Добавить все системные компетенции можно вызвать повторно. Его выполнение приведет к добавлению недостающих системных компетенций, коды и формулировки существующих компетенций будут приведены в соответствие со значениями из общевузовского справочника.

Если возникла необходимость удалить одну из системных компетенций, добавленных к стандарту, из общевузовского справочника, потребуется предварительно удалить ее из стандарта. Для этого необходимо выбрать удаляемую компетенцию в списке и выполнить действие Удалить компетенцию.

Если компетенция была удалена из стандарта ошибочно, или если перечень системных компетенций в общевузовском справочнике был расширен, отдельную системную компетенцию можно добавить в стандарт при помощи действия Добавить компетенцию... / системную компетенцию.

Добавление системной компетенции

Для добавления нужно в поле Компетенция из общевузовского справочника выбрать добавляемую компетенцию из общевузовского справочника системных компетенций. Формулировка выбранной компетенции отобразится в поле Формулировка компетентностных образовательных результатов автоматически. Изменение кода или формулировки системной компетенции недопустимо. После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте.

Повторное добавление компетенции в стандарт недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

3.4.2.2. Формирование перечня социально-личностных компетенций

Социально-личностные компетенции переносятся в каждый из образовательных стандартов в соответствии с общевузовским справочником. При этом в конкретном образовательном стандарте формулировка социально-личностной компетенции может быть изменена. При изменении формулировки изменяется и код социально-личностной компетенции - к нему дописывается аббревиатура направления подготовки.

В отличие от других видов компетенций в образовательный стандарт могут добавляться социально-личностные компетенции, не связанные с соответствующими компетенциями общевузовского справочника. Далее такие компетенции называются дополнительные социально-личностные компетенции.

Перенос социально-личностных компетенций из общевузовского справочника в образовательный стандарт можно выполнять одним из двух способов:

  • Добавить все социально-личностные компетенции из общевузовского справочника, после чего уточнить формулировки и коды тех компетенций, для которых это необходимо (рекомендуется в случае, если не планируется существенных изменений по сравнению с общевузовским справочником)
  • Добавлять социально-личностные компетенции по одной с одновременным уточнением их формулировок и кодов (рекомендуется в случае, если состав и содержание социально-личностных компетенций в стандарте должно существенно отличаться от общевузовского справочника)

Формирование перечня социально-личностных компетенций

Для переноса полного перечня социально-личностных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все социально-личностные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень социально-личностных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. После добавления коды и формулировки компетенций можно будет уточнить.

Социально-личностные компетенции в образовательном стандарте

Если после последнего формирования перечня социально-личностных компетенций для стандарта произошло добавление компетенций данного вида в общевузовский справочник, действие Добавить все социально-личностные компетенции можно вызвать повторно. Его выполнение приведет к добавлению недостающих системных компетенций, коды и формулировки существующих компетенций будут приведены в соответствие со значениями из общевузовского справочника.

Отдельную социально-личностную компетенцию, имеющую соответствие в общевузовском справочнике, можно добавить в стандарт при помощи действия Добавить компетенцию... / социально-личностную компетенцию. Одновременно с добавлением компетенции можно выполнить и ее уточнение.

Добавление социально-личностной компетенции

Для добавления нужно в поле Компетенция из общевузовского справочника выбрать добавляемую компетенцию из общевузовского справочника социально-личностных компетенций. Формулировка выбранной компетенции отобразится в поле Формулировка компетентностных образовательных результатов (значение из общевузовского справочника, недоступно для изменения). Та же формулировка отобразится в поле Формулировка компетентностных образовательных результатов (в стандарте). Если формулировку компетенции в стандарте нужно изменить, это можно сделать в поле, доступном для редактирования. Если изменение формулировки произведено, код компетенции будет дополнен аббревиатурой направления.

После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте. В таблице будут отображены как значения кода и формулировки, уточненные для стандарта, так и значения из общевузовского справочника.

Повторное добавление в стандарт компетенции, ссылающейся на ту же запись общевузовского справочника, недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

Для добавления дополнительной социально-личностной компетенции, не связанной с общевузовским справочником, предназначено действие Добавить компетенцию... / дополнительную социально-личностную компетенцию.

Добавление дополнительной социально-личностной компетенции

Для добавления нужно занести формулировку компетенции и ее порядковый номер. Для дополнительных компетенций необходимо использовать порядковые номер от 101 до 200. Код компетенции будет сформирован автоматически из префикса"СЛК-", порядкового номера и аббревиатуры направления подготовки.

После нажатия кнопки ОК дополнительная компетенция будет добавлена в стандарт. В таблице всех компетенций стандарта для дополнительных социально-личностных компетенций в колонках Код общевузовской компетенции и Формулировка компетентностных образовательных результатов (общевуз.) будут отображены пустые значения.

Уточнение социально-личностных компетенций

Социально-личностные компетенции, ранее добавленные в стандарт, могут уточняться по сравнению с компетенциями общевузовского справочника. Для того, чтобы уточнить компетенцию, нужно выбрать ее в таблице данных, после чего вызвать действие Уточнить компетенцию... / социально-личностную компетенцию

Уточнение социально-личностных компетенций

Уточнение компетенции заключается к корректировке ее формулировки по сравнению с формулировкой, заданной в общевузовском справочнике. Если формулировка изменена, в код компетенции будет автоматически дописана аббревиатура направления подготовки.

Удаление социально-личностной компетенции

Если возникла необходимость удалить одну из социально-личностных компетенций, добавленных к стандарту, нужно выбрать ее в таблице данных и воспользоваться действием Удалить компетенцию.

3.4.2.3. Формирование перечня инструментальных компетенций

Формирование перечня инструментальных компетенций для образовательного стандарта заключается в выборе соответствующих инструментальных компетенций из общевузовского справочника и занесения их формулировок. Так как в общевузовском справочнике инструментальных компетенций формулировки компетенций не заносятся, при добавлении инструментальных компетенций в стандарт формулировки должны быть заданы для каждой компетенции. Коды инструментальных компетенций в стандарте будут сформированы автоматически на основе кода компетенции в общевузовском справочнике и аббревиатуры направления подготовки.

Добавление в стандарт инструментальных компетенций, не связанных ни с одной записью общевузовского справочника, недопустимо.

Формирование перечня инструментальных компетенций для стандарта на основе общевузовского справочника можно выполнять одним из двух способов:

  • Добавить все инструментальные компетенции из общевузовского справочника, после чего уточнить все их формулировки и коды
  • Добавлять инструментальные компетенции по одной с одновременным уточнением их формулировок и кодов

Формирование перечня инструментальных компетенций

Для переноса полного перечня инструментальных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все инструментальные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень социально-личностных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. В качестве формулировки компетенции будет подставлено ее наименование их общевузовского справочника. После добавления инструментальных компетенций коды и формулировки всех компетенций необходимо будет уточнить.

Инструментальные компетенции в стандарте

По одной инструментальные компетенции можно добавлять при помощи действия Добавить компетенцию... / инструментальную компетенцию. Одновременно с добавлением компетенции можно выполнить и ее уточнение.

Добавление инструментальной компетенции в стандарт

Для добавления инструментальной компетенции нужно занести ее формулировку в поле Формулировка компетентностных образовательных результатов, после чего в поле Компетенция из общевузовского справочника выбрать наиболее подходящую общевузовскую компетенцию. Для удобства выбора общевузовский справочник инструментальных компетенций отображается в виде иерархической структуры. При этом для добавления в стандарт необходимо выбирать компетенции, не имеющие дочерних компетенций.

После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте. В таблице будут отображены как значения кода и формулировки, уточненные для стандарта, так и значения кода и наименования из общевузовского справочника.

Повторное добавление в стандарт компетенции, ссылающейся на ту же запись общевузовского справочника, недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

Уточнение инструментальных компетенций

Инструментальные компетенции, ранее добавленные в стандарт, могут уточняться по сравнению с компетенциями общевузовского справочника. Для того, чтобы уточнить компетенцию, нужно выбрать ее в таблице данных, после чего вызвать действие Уточнить компетенцию... / инструментальную компетенцию.

Уточнение инструментальных компетенций

Уточнение компетенции заключается к корректировке ее формулировки. Также при уточнении формулировки в код компетенции будет автоматически дописана аббревиатура направления подготовки.

Удаление инструментальной компетенции

Если возникла необходимость удалить одну из инструментальных компетенций, добавленных к стандарту, нужно выбрать ее в таблице данных и воспользоваться действием Удалить компетенцию.

4. Объединенные учебные планы

"Объединенные учебные планы" - это такой вид учебных планов, который объединяет в себе "базовый учебный план" и "рабочий учебный план". Объединенный учебный план разрабатывается сразу на все годы реализации образовательной программы, содержит полный набор разделов, дисциплин и других видов записей планов на весь период обучения, и в то же время отражает планирование нагрузки как по дисциплине в целом, так и по видам работ (лекции, семинары, практически и т.п.), по учебным годам (курсам студентов), по периодам каждого года (модулям и семестрам), а также отражает планирование испытаний текущего и рубежного контроля. Дополнительной возможностью Объединенных учебных планов (по сравнению с РУП) является возможность распределения кредитов, аудиторных часов и общих часов по "частям дисциплины", ограниченным рубежными испытаниями (зачетами и экзаменами).

4.1. Создание нового объединенного учебного плана

Работа с Объединенными учебными планами ведется на участке "Разработка учебных планов" в форме "Объединенные учебные планы". Для создания нового объединенного учебного плана необходимо чтобы предварительно был сформирован соответствующий образовательный стандарт. Работа с образовательными стандартами описана в разделе Образовательные стандарты.

Для добавления объединенного учебного плана необходимо в верхней таблице данных Объединенные учебные планы с помощью контекстного меню вызвать действие Добавить объединенный план.

Добавление объединенного учебного плана

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров добавления объединенного учебного плана

  • В поле Уровень образования - указать уровень образования, для которого создается план.
  • В полях Образовательный стандарт и Образовательную программа - выбрать образовательный стандарт и программу, для которой создается план.
  • Поля Факультет, Филиал, Форма обучения, Магистерская программа, Число лет обучения будут заполнены автоматически данными, заданными для образовательного стандарта и выбранной образовательной программы.
  • При необходимости в полях Специализация и Магистерская специализация можно указать специализацию или магистерскую специализацию, если они не заданы для Образовательной программы.
  • В полях Год начала обучения, Год окончания обучения указать года начала и окончания обучения, периоды, по которым будет планироваться нагрузка (по модулям или по семестрам).
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов в году указать количество периодов в учебном году.

После того, как для всех полей формы добавления Объединенных учебных планов будут заданы допустимые значения, кнопка ОК на форме добавления станет доступной. После ее нажатия запись о новом объединенном учебном плане появится в таблице данных. При попытке добавления второго объединенного учебного плана на основе той же образовательной программы, образовательного стандарта для того же факультета, года начала обучения, специализации, магистерской программы, магистерской специализации произойдет ошибка дублирования объектов.

4.2. Редактирование объединенного учебного плана

Сформировать структуру и состав нового объединенного учебного плана можно на основе образовательного стандарта. Для этого нужно выбрать объединенный учебный план в таблице данных и в контекстном меню выбрать действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Подтверждение формирования БУП

Если Вы уверены, что хотите сформировать учебный план на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Все записи плана.

После того, как объединенный учебный план сформирован на основе стандарта, его можно редактировать. Для редактирования предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования ОУП

Редактирование объединенного учебного плана должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), распределять нагрузку по видам работы (лекции, семинары, практические и т.д.), по годам обучения (курсам студентов) и по периодам обучения в каждом году (модулям, семестрам), а также планировать рубежные испытания, распределять кредиты и объем нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: дисциплину, научно-исследовательский семинар, курсовую работу, практику, проект студентов, дисциплину других планов, итоговый экзамен, выпускную квалификационную работу, зачетно-экзаменационные недели.

Добавление записи в ОУП

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

Редактирование записей объединенного плана

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение ряда свойств разделов и дисциплин БУП.

По окончании работы с объединенным учебным планом его можно вывести на печать. Для этого можно воспользоваться одним из действий Выгрузить для печати, Выгрузить для печати как Базовый, Выгрузить для печати как рабочий, расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

4.2.1. Добавление дисциплин и НИС

При добавлении дисциплины или НИС в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие дисциплину или научно-исследовательский семинар, после чего заполнить следующую форму параметров:

Добавление дисциплины в ОУП
Пользователям разработчикам учебных планов предоставлена возможность связывания дисциплин и НИС учебного плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
      Для выбора из плана-предложения кафедры будут доступны только те дисциплины, которые совпадают по периоду реализации с периодом, заданным с помощью полей Год начала реализации и Год окончания реализации.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных специализаций, необходимо выбрать специализации, для которых добавляется дисциплина. Для выбора специализаций необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей специализаций, после чего нужно нажать кнопку ОК.
      Для каждой специализации в ОУП будет создана отдельная запись по дисциплине.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных специализаций, необходимо выбрать специализации, для которых добавляется дисциплина. Для выбора специализаций необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей специализаций, после чего нужно нажать кнопку ОК.
      Для каждой специализации в ОУП будет создана отдельная запись по дисциплине.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать и изменять специализацию для дисциплин и НИС (см. Установить или снять специализацию).
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

4.2.1.1. Установить или снять специализацию

Для установки, снятия и изменения специализации, установленной для дисциплины или НИС, необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Все записи плана выбрать дисциплину или НИС, для которой необходимо установить, снять или изменить специализацию.
    При добавлении дисциплины или НИС можно установить сразу несколько специализаций, для каждой из них будет создана отдельная запись о дисциплине или НИС (см. Добавление дисциплин и НИС). В связи с этим необходимо удостовериться, что выбранная дисциплина или НИС соответствуют той записи, которую необходимо изменить. Установленные специализации можно проверить в поле Для специализации.
  3. Из контекстного меню вызвать действие Установить\изменить специализацию.
  4. В форме параметров указать Специализацию факультета (для ОУП бакалавриата и специалитета) или Магистерская специализация (для ОУП магистратуры).
  5. Нажать кнопку ОК.

4.2.1.2. Изменение периода реализации

Для изменения периода реализации дисциплины или НИС, необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Все записи плана выбрать дисциплину или НИС, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

4.2.1.3. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

4.2.2. Добавление курсовой работы

При добавлении курсовой работы в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие курсовую работы, после чего заполнить следующую форму параметров:

Добавление курсовой работы в ОУП

В первую очередь необходимо указать Наименование для курсовой работы, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК курсовая работа будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по курсовой работе.

4.2.3. Добавление практики

При добавлении практики в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие практику, после чего заполнить следующую форму параметров:

Добавление практики в ОУП

В первую очередь необходимо указать Вид практики (справочник ) и Способ проведения практики, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК практика будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по практике.

4.2.4. Добавление итогового экзамена

При добавлении итогового экзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие итоговый экзамен, после чего заполнить следующую форму параметров:

Добавление итогового экзамена в ОУП

В первую очередь необходимо указать Наименование для итогового экзамена, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК итоговый экзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по итоговому экзамену.

4.2.5. Добавление выпускной работы

При добавлении выпускной работы в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие выпускную работу, после чего заполнить следующую форму параметров:

Добавление ВКРБ в ОУП

В первую очередь необходимо указать Наименование и Форму итогового контроля для выпускной работы, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК выпускная работа будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по выпускной работе.

4.2.6. Добавление зачетно-экзаменационной недели

При добавлении зачетно-экзаменационной недели в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие зачетно-экзаменационную неделю, после чего заполнить следующую форму параметров:

Добавление зачетно-экзаменационных недель в ОУП

В первую очередь необходимо указать Наименование зачетно-экзаменационной недели, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК зачетно-экзаменационная неделя будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки для зачетно-экзаменационной недели.

4.2.7. Добавление проекта студентов

При добавлении проекта студентов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие проект студентов..., после чего заполнить следующую форму параметров:
Добавление проекта в ОУП

  • В поле Проект для студентов необходимо выбрать проект из справочника Проекты для студентов, если проект отсутствует, то его можно добавить (см. Проекты для студентов). Данное поле можно оставить пустым и не устанавливать ссылку на проект из справочника, а только указать Наименование проекта, Вид дисциплины в плане и Число кредитов.
    Записи о проектах в объединенных учебных планах, не связанные с записью справочника проектов, в учебный план факультета передаваться не будут.
  • В поле Вид дисциплины в плане выбрать вид дисциплины.
  • В поле Число кредитов указать соответствующее данному проекту число кредитов.
  • При необходимости установить признак Только в кумулятивный рейтинг.

После нажатия кнопки ОК проект будет добавлена в объединенный учебный план.

4.2.7.1. Проекты для студентов

Справочник "Проекты для студентов" позволяет работать с информацией о проектах, в которые могут включаться студенты в своей внеадиторной деятельности. Справочник распологается в разделе Объединенные учебные планы на соотвествующей вкладке Проекты для студентов.
Справочник проекты для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить проект.
    Вызов действия Добавить проект
  2. Заполнить форму параметров следующим образом:
    Форма параметров Добавить проект
    • Заполнить поля Идентификатор во внешней системе, Полное наименование, Полное наименование на английском языке, Тип проекта (выбирается из справочника Типы проектов для студентов), Вид проектной деятельности (выбирается из списка).
    • В одной из групп полей Руководитель из вуза или Внешний руководитель указать подразделение/организацию руководителя (выбирается из справочников или Места прохождения практики) и выбрать самого руководителя проекта (выбирается из справочника или Работники организации).
      Руководителем проекта может быть только либо представитель вуза, либо внешний руководитель. При этом если начать заполнять одну из групп полей (Руководитель из вуза или Внешний руководитель) другая перестанет быть доступной для заполнения.
    • Заполнить поля Учебный год, Дата начала реализации, Дата окончания реализации, Дата окончания записи на проект, Количество модулей, Период итогового контроля, Вид итогового контроля и Плановое количество кредитов.
  3. Нажать кнопку ОК.

4.2.7.1.1. Выгрузить проекты студентов

В справочнике Проекты для студентов предоставлена возможность сформировать отчет с информацией о проектах и студентах, которым назначены данные проекты.

Для формирования отчета необходимо:

  1. В справочнике Проекты для студентов из контекстного меню системы вызвать действие Выгрузить проекты студентов.
    Вызов действия Выгрузить проекты
  2. В форме пераметров с помощью выбора значений для параметров Филиал, Факультет, Образовательная программа, Курс, Группа, Проект можно ограничить выборку проектов, для которых будет формироваться отчет. Если все поля формы параметров оставить пустыми, то отчет сформируется для всех проектов ВУЗа, присутствующих в справочнике Проекты для студентов.
  3. Нажать кнопку ОК.

В результате сформируется отчет в формате MS Excel, содержащий информацию об образовательной программе, ФИО, курсе и группах студентов, участвующих в проектах, наименовании проекта, плановом и фактическом количестве кредитов, руководителях проектов, результатах участия в проекте студентов.

4.2.7.1.2. Загрузка данных о проектах с портала

4.2.7.1.3. Загрузка данных о назначении проектов студентам

4.2.7.2. Типы проектов для студентов

Справочник "Типы проектов для студентов" содержит в себе перечень типов проектов для внеаудиторной деятельности студентов и распологается в разделе Объединенные учебные планы на соотвествующей вкладке Типы проектов для студентов.
Справочник Типы проектов для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить тип проекта.
    Вызов действия Добавить тип проекта
  2. В форме параметров указать Краткое наименование и Полное наименование типа проекта для студентов.
    Форма параметров Добавить тип проекта
  3. Нажать кнопку ОК.

4.2.8. Добавление дисциплины других планов

Для добавления дисциплин, которые участвуют в расчетах затратности, но при этом не передаются в реализацию на факультеты и которые не участвуют в планировании нагрузки, необходимо:

  1. В форме редактирования объединенного учебного плана или в представлении Все записи плана из контекстного меню, в группе процедур Добавить, вызвать действие дисциплинудругих планов.
  2. Заполнить следующую форму параметров:
    Добавление дисциплины других учебных планов в ОУП
    • В полях Наименование и Наименование на английском языке указать наименование на русском и английском языке (при необходимости) соответственно.
    • При необходимости в поле Кафедра можно указать подразделение ВУЗа, которое реализует данную дисциплину. Для этого необходимо нажать кнопку Справочник, из справочника , с помощью чек-бокса Чек-бокс, выбрать подразделение и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, Общее число часов, Аудиторных часов и Только в кумулятивный рейтинг.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
  3. Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

Отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля) можно непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице, предназначено действие Дополнительные свойства.

4.2.9. Формирование информации о численности контингента

Для добавления информации о численности контингента необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать план, для записей которого будет уточняться информация о численности контингента.
  2. В представлении Все записи по годам обучения для записей учебного плана в соответствующих полях указать Количество потоков, Количество групп, Количество подгрупп и Количество студентов (после изменения значения каждого из параметров нужно нажимать клавишу Enter).

4.3. Передача плана на факультет

Для того, чтобы дисциплины объединенного учебного плана могли быть назначены студентам, необходимо для плана выполнить действие Передать на факультет. Для каждого отдельного года реализации плана можно также вызывать действие Передать в план факультета в подчиненной таблице Реализация плана по годам.

Передача ОУП на факультет

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.
Записи о проектах студентов в объединенных учебных планах, не связанные с записью справочника проектов, в учебный план факультета передаваться не будут.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Учебные планы факультета. Эта таблица доступна в разделе Студент, в форме Справочники факультета на вкладке Учебные планы факультета.

Назначение дисциплин студентам на участке Студент выполняется именно из таблицы данных Учебные планы факультета. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного учебного плана необходимо выполнять действие по передаче плана на факультет.

4.4. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как Рабочий, Выгрузить для печати как Базовый, Выгрузить для печати как Рабочий с нагрузкой преподавателей, Выгрузить для печати на английском, Выгрузить для печати как Базовый на английском или Выгрузить для печати как Рабочий на английском.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.

4.5. Оценка плановой затратности плана

Для оценки плановой затратности плана необходимо:

С помощью формирования отчета "Оценка плановой затратности плана"

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
    Группа действий Дополнительные действия
  2. Выбрать действие Оценка плановой затратности (отчет).
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате сформируется отчет с оценкой затратности реализации объединенного учебного плана.

С помощью действия Рассчитать плановую затратность

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
  2. Выбрать действие Рассчитать плановую затратность.
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате будет выведено сообщение с указание плановой затратности плана.

4.6. Оценка фактической затратности ОП

Для оценки фактической затратности образовательной программы необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать запись объединенного учебного плана.
  2. Из контекстного меню системы вызвать действие Оценка фактической затратности ОП.
  3. В форме параметров указать Учебный год, если нужна конкретизация по преподавателям, то для признака С конкретизацией по преподавателям нужно установить значение "Да".
  4. Нажать кнопку ОК.

В результате сформируется отчет с оценкой фактической затратности реализации образовательной программы.

5. Базовые учебные планы (БУПы)

Базовый учебный план (БУП) представляет собой иерархическую структуру учебных циклов и включенных в них дисциплин, формируемую на основе соответствующего образовательного стандарта. Базовый учебный план уточняет образовательный стандарт в части набора и трудоемкости дисциплин и других видов подготовки, а также отражает распределение учебной нагрузки по годам обучения студентов. Параметры базового учебного плана могут отличаться от образовательного стандарта. Допустимость или недопустимость таких различий регулируется при помощи контрольных соотношений, формируемых для БУПов.

Каждый базовый учебный план создается но основе одного из образовательных стандартов, задающего уровень образования, направление (специальность) и степень (квалификацию), для выбранного факультета (отделения) и года набора студентов. По одному образовательному стандарту для одного факультета и года набора может быть создано несколько БУПов, отличающихся специализацией (для бакалавриата и магистратуры) или магистерской программой и магистерской специализацией (для магистратуры).

Создание нового базового учебного плана включает следующие этапы работы:

  1. Создание записи о БУПе и его наполнение на основе образовательного стандарта.
  2. Редактирование сформированного БУПа.
  3. Связывание записей БУПа с компетенциями.

5.1. Создание нового базового учебного плана

Работа с базовыми учебными планами ведется в форме Базовые и рабочие учебные планы на вкладке Базовые учебные планы. Для создания нового БУПа необходимо чтобы предварительно был сформирован соответствующий образовательный стандарт. Работа с образовательными стандартами описана в разделе Образовательные стандарты. Для добавления нового БУП необходимо выполнить действие Добавить базовый учебный план, после чего заполнить форму параметров добавления следующим образом:

Форма добавления БУП (бакалавриат)

Форма добавления БУП (магистратура)
  • Поле Факультет будет заполнено автоматически, если Вы являетесь пользователем одного из факультетов и для Вас задана настройка "Факультет". В этом случае поле будет недоступно для изменения. Если же для Вас не установлена настройка факультета, то в данном поле Вы должны выбрать один из факультетов из общевузовского справочника Если Вам не удается выбрать нужный факультет, обратитесь к бизнес-администратору системы с просьбой уточнить установленные для Вас настройки.
  • Поле Ведущий факультет необходимо будет заполнить только в том случае, если БУП согласовывается с другим факультетом, для этого необходимо выбрать один из факультетов из общевузовского справочника
  • В поле Образовательная программа необходимо указать образовательную программу из соотвествующего справочника. В зависимости от выбранной образовательной программы изменяется доступность для заполнения полей Специализация, Магистерская программа, Магистерская специализация.
  • Поле Уровень образования будет заполнено автоматически.
  • В поле Образовательный стандарт необходимо выбрать один из существующих в системе образовательных стандартов. Для выбора предлагаются только стандарты для уровня образования, указанного в поле Уровень образования. Если необходимого образовательного стандарта нет в предлагаемом для выбора перечне, необходимо перейти в форму Образовательные стандарты и создать новый стандарт, после чего повторить добавление БУПа.
  • Поле Продолжительность программы ДПО является обязательным для заполнения только для программ подготовки специалистов, реализуемые в сокращенные или ускоренные сроки, для этого необходимо будет выбрать значение продолжительности программы только для ускоренных и сокращенных программы из соотвествующего справочника.
  • В поле Всего кредитов по плану будет автоматически предложено значение, соответствующее уровню образования (Бакалавриат - 240 кредитов, Специалитет - 300 кредитов, Магистратура - 120 кредитов). Однако, если для образовательной программы задано общее число кредитов, отличающее от значение, предлагаемых системой, эти значения можно исправить.
  • Поле Специализация доступно только в случае, если в поле Уровень образования указано значение Бакалавриат или Специалитет. Для выбора предлагаются специализации, существующие в справочнике . Если нужной специализации в этом перечне нет, то ее нужно добавить в справочник специализаций факультета. Если БУП не предполагает специализации, но это поле нужно оставить пустым. В дальнейшем на базе одного БУПа могут быть созданы различные рабочие учебные планы (РУПы) для различных специализаций.
  • Поле Магистерская программа доступно только в том случае, если в поле Уровень образования указано значение Магистратура. Для выбора доступны магистерские программы, существующие в справочнике . Если нужной программы в этом справочнике нет, ее нужно добавить, перейдя в справочник, после чего вернуться к созданию БУПа.
  • Поле Магистерская специализация доступно только в том случае, если в поле Уровень образования указано значение Магистратура. Для выбора доступны только магистерские специализации, существующие в справочнике и принадлежащие к выбранной магистерской программе. Если выбранная магистерская программе не предусматривает магистерских специализаций, или если БУП относится к программе в целом, то данное поле нужно оставить пустым. В дальнейшем на основе БУП для магистерской программы можно будет создавать различные рабочие учебные планы (РУПы) для разных магистерских специализаций.
  • В поле Форма обучения нужно выбрать форму обучения, по которой будет реализовываться образовательная программа, из общевузовского справочника .
  • В поле Программа двойных дипломов нужно установить флажок (значение Да) в случае, если БУП разрабатывается для программы двойных дипломов, реализуемой совместно с другими вузами (в т.ч. зарубежными). В противном случае флажок должен быть снят (значение Нет).
  • В поле Число лет обучения автоматически подставляется значение в зависимости от выбранной образовательной программы и уровня образования (Бакалавриат - 4 года, Специалитет - 5 лет, Магистратура - 2 года). Если БУП реализуется в течение другого числа лет, то это значение можно изменить.
  • В поле Реализуется по периодам нужно выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов в году необходимо указать количество преиодов в учебном году.
  • В поле Год начала обучения нужно выбрать год набора студентов, которые будут обучаться по данному БУП. Выбор производится из справочника среди учебных годов. Если нужного учебного года в справочнике нет, необходимо обратиться к бизнес-администратору системы с просьбой добавить его в справочник.
  • В поле Год окончания обучения нужно выбрать учебный год, в котором студенты, обучающиеся по данному БУП завершат обучение. Выбор производится аналогично выбору в поле Год начала обучения.
  • Поле Вариант позволяет создать несколько вариантов БУП одного и того же БУП с тем, чтобы в дальнейшем выбрать наиболее удачный вариант. Для этого в данном поле нужно указать метку варианта (например, "в-2"). Желательно использовать минимальное число символов. Если Вы не планируете работать с несколькими вариантами одного и того же БУП, это поле нужно оставить пустым.

После того, как для всех полей формы добавления БУП заданы допустимые значения, кнопка ОК на форме добавления станет доступной. После ее нажатия запись о новом БУП появится в таблице данных. При попытке добавления второго БУП на основе той же образовательной программы, образовательного стандарта для того же факультета, года начала обучения, специализации, магистерской программы, магистерской специализации БУП произойдет ошибка дублирования объектов.

5.2. Создание базового учебного плана как копии существующего

Если необходимо создать базовый учебный план, существенно схожий с уже существующим, можно воспользоваться возможностью копирования плана. Новый план, создаваемый методом копирования, должен отличаться от исходного не менее чем одним из следующих параметров:

  • специализацией;
  • магистерской специализацией;
  • годами обучения студентов;
  • при необходимости продолжительность программы ДПО.
Для того чтобы создать новый план на основе существующего, нужно выбрать исходный план в таблице данных и вызвать действие Скопировать как новый план.

Форма копирования нового БУП на базе старого

При открытии формы копирования плана все поля заполняются значениями, установленными для исходного плана. Для создания нового плана нужно изменить те значения, которые будут отличаться для нового плана и нажать кнопку ОК.

Результатом работы процедуры копирования будет запись о новом базовом учебном плане в таблице данных Базовые учебные планы. В подчиненной таблице Записи базового плана будет создан набор записей, полностью аналогичный составу исходного плана. Также для нового плана будет перенесена информация о распределении учебной нагрузки по годам обучения. Если с записями исходного плана были связаны компетенции, то они также будут скопированы в новый план и связаны с соответствующими записями.

После выполнения процедуры копирования можно продолжить редактирование нового плана. Редактирование может заключаться в добавлении новых записей, удалении созданных при копировании, уточнении форм итогового контроля по дисциплинам, значений объема учебной нагрузки в часах, неделях, кредитах.

Выполнять копирование плана лучше после того, как работа над составом и структурой исходного плана завершена (или близка к завершению). Автоматически актуализировать структуру и состав копии плана после изменения исходного плана будет невозможно. Однако возможно выполнить для нового плана действие Очистить, удалить план и снова сформировать его как копию существующего. Переформировывать таким образом план можно только пока он находится в статусе проект.

5.3. Редактирование базового учебного плана

Если БУП создавался методом копирования, то его состав уже сформирован и можно переходить к его редактированию. Если же создан пустой БУП, то его структуру и состав можно сформировать на основе образовательного стандарта. Для этого нужно выбрать БУП в таблице данных и выполнить действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Подтверждение формирования БУП

Если Вы уверены, что хотите сформировать БУП на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Записи базового плана. В таблице данных Развитие компетенций, подчиненной по отношению к записям плана, будут сформированы записи о компетенциях повторяющие записи, созданные в стандарте.

После того, как БУП сформирован на основе стандарта или скопирован, его можно редактировать. Для редактирования предназначена специализированная форма работы с БУП, которая открывается при вызове действия Открыть.

Редактирование БУП должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), установки видов итоговых испытаний, распределении нагрузки в часах и кредитах по года обучения (курсам). Для выполнения этих действий предназначены соответствующие действия контекстного меню. Для добавлении записи в определенный раздел нужно сначала выбрать заголовок этого раздела или одну из входящих в него записей.

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение ряда свойств разделов и дисциплин БУП.

График учебного процесса, являющийся частью БУП, необходимо разработать отдельно в виде файла формата MS Excel или MS Word. Полученный файл нужно загрузить как значение в колонке График учебного процесса. Для этого нужно непосредственно в колонке воспользоваться кнопкой открытия файла и выбрать файл при помощи стандартного диалога MS Windows. Для сохранения в базе данных системы загруженного файла необходимо нажать клавишу Enter. Если график нужно будет изменить, то его можно выгрузить и сохранить на диске при помощи кнопки сохранения файла, скорректировать файл и загрузить обратно (после повторной загрузки также необходимо нажимать Enter).

По окончании работы с БУП его можно вывести на печать. Для этого можно воспользоваться действием Напечатать план, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия БУП будет выгружен для печати в MS Excel.

5.4. Связывание записей базового плана с развиваемыми компетенциями

Записи базового учебного плана различных видов (разделы, дисциплины, группы дисциплин, курсовые работы, практики и т.д.) могут связываться с компетенциями, заданными для образовательного стандарта, на основе которого сформирован базовый план. До начала работы с распределением компетенций по записям базового плана, необходимо убедиться в том, что для стандарта корректно сформирован перечень компетенций (раздел Создание перечня компетенций стандарта).

Если базовый учебный план формировался с использованием действия Сформировать на основе стандарта, то перечень компетенций, связанных с записями стандарта (см. раздел Связь компетенций с записями стандарта), будет сформирован и для записей базового учебного плана. Дальнейшая работа должна заключаться в дополнительном связывании компетенций с записями базового плана с целью уточнения из развития за счет отдельных дисциплин.

Для того, чтобы связать компетенцию с записью БУП, нужно открыть форму Базовые и рабочие учебные планы, в ней открыть первую вкладку Базовые учебные планы. Среди всех доступных БУП нужно выбрать план, с которым предстоит работать. На вкладке второго уровня Записи базового плана нужно выбрать запись (дисциплину, группу дисциплин, курсовую работу и т.п.), с которой нужно связать компетенции. После этого на третьем уровне в таблице данных Развиваемые компетенции нужно вызвать действие Добавить компетенцию.

Для выбора в поле Компетенция стандарта доступны все компетенции, сформированные для стандарта в таблице данных Компетенции в стандарте. Если с одной записью БУП нужно связать несколько компетенций, то добавление компетенции нужно повторить.

Если компетенция связана с записью БУП ошибочно, ее можно удалить из списка при помощи действия Удалить.

6. Объединенные планы факультетских дисциплин

Объединенный план факультеских дисциплин представляет собой иерархическую структуру групп дисциплин (раделов) и включенных в них дисциплин.

Создание нового объединенного плана факултетских дисциплин включает следующие этапы работы:

6.1. Создание нового объединенного плана факультетских дисциплин

Работа с Объединенными учебными планами ведется на участке "Разработка учебных планов" в форме "Объединенные планы факультетских дисциплин".

Для добавления плана необходимо в верхней таблице данных Объединенные планы факультетских дисциплин с помощью контекстного меню вызвать действие Добавить объединенный план факультетских дисциплин.

Процедура добавления объединеннго плана факультетских дисциплин

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров добавления объединенного плана факультетских дисциплин

  • В поле Год начала обучения указать год начала обучения по данному плану.
  • В поле Филиал указать филиал, в котором находится факультет.
  • В поле Факультет выбрать один из факультетов из общевузовского справочника
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов указать количество периодов в учебном году.
  • В поле Число лет указать количество лет, в течение которых реализуется объединенный план факультетских дисциплин.

После того, как для все поля формы будут заполнены, кнопка ОК на форме добавления станет доступной. После ее нажатия, запись о новом объединенном плане факультетских дисциплин появится в таблице данных. При попытке добавления второго плана идентичного уже созданному произойдет ошибка дублирования объектов.

6.2. Редактирование объединенного плана факультетских дисциплин

Редактирование объединенного плана факультетских дисциплин заключается в создании Групп дисциплин (разделов), добавлении дисциплин в разделы, распределении нагрузки по видам работы (лекции, семинары, практические и т.д.), по годам обучения и по периодам обучения в каждом году (модулям, семестрам), а также планировании рубежных испытаний, распределении кредитов и объемов нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Добавление Группы дисциплин (раздела)

Для редактирования объединенного плана факультетских дисциплин необходимо в таблице данных Объединенные планы факультетских дисциплин выбрать план и с помощью контекстного меню вызвать действие Открыть.

Открытие формы редактирования объединенного плана факультета

В итоге откроется форма редактирования с пустым планом, в которой для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Процедура добавления раздела в объединенный план факультета

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования объединенного плана.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования объединенного плана факультетских дисциплин.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

Добавление Дисциплины или НИС

Для добавления Дисциплины необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие Дисциплину или НИС,

Процедура добавления дисциплины в объединенный план факультета

после чего заполнить следующую форму параметров:

Форма параметров добавления дисциплины в объединеннй план факультетских дисциплин

Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.

    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

Перемещение Группы дисциплин (раздела) или дисциплины

В случае если при добавлении Группы дисциплин или Дисциплины был неверно указан раздел, куда они должны быть включены, то в отношении такой Группы дисциплин или Дисциплины необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить Группу дисциплин или Дисциплину, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина будут перемещены в корень объединенного плана факультетских дисциплин.

Также можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

Печать объединенных планов факультетских дисциплин

По окончании работы с объединенным учебным планом его можно вывести на печать. Для этого можно воспользоваться одним из действий Выгрузить для печати, Выгрузить для печати как Базовый, Выгрузить для печати как Рабочий расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

6.2.1. Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные планы факультетских дисциплин (форма Объединенные планы факультетских дисциплин) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи плана выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

6.2.2. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

6.2.3. Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных планов факультетских дисциплин выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.

6.3. Передача объединенного плана факультетских дисциплин в реализацию

Для того, чтобы дисциплины объединенного плана факультетских дисциплин могли быть назначены студентам, необходимо для плана выполнить действие Передать на факультет. Для каждого отдельного года реализации плана можно также вызывать действие Передать в план факультета в подчиненной таблице Реализация учебного плана по годам.

Передача плана факультетских дисциплин в реализацию

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Планы факультетских дисциплин. Эта таблица доступна в разделе Студент, в форме Справочники факультета на вкладке Планы факультетских дисциплин.

Назначение дисциплин студентам на участке Студент выполняется именно из таблицы данных Планы факультетских дисциплин. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного плана факультетских дисциплин необходимо выполнять действие по передаче плана на факультет.

6.4. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные планы факультетских дисциплин (форма Объединенные планы факультетских дисциплин) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как РУП, Выгрузить для печати как БУП.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.

7. Объединенные майноры

Объединенный майнор - это такой вид планов, который объединяет в себе "базовый майнор" и "рабочий майнор". Объединенный майнор разрабатывается на несколько лет обучения, содержит полный набор разделов, дисциплин и других видов записей планов на весь период обучения, и в то же время отражает планирование нагрузки как по дисциплине в целом, так и по видам работ (лекции, семинары, практически и т.п.), по учебным годам (курсам студентов), по периодам каждого года (модулям и семестрам), а также отражает планирование испытаний текущего и рубежного контроля. Дополнительной возможностью Объединенных майноров является возможность распределения кредитов, аудиторных часов и общих часов по "частям дисциплины", ограниченным рубежными испытаниями (зачетами и экзаменами).

7.1. Создание нового объединенного майнора

Создание объединенного майнора и работа с ним осуществляется в форме Майноры учебных планов, доступной на консоли управления в разделе Разработка учебных планов.

Меню разработка РУП

Представление для работы с базовыми майнорами расположено на первой вкладке данной формы.

Представление объединенные майноры

Для добавления нового объединенного майнора в таблице данных нужно вызвать действие Добавить объединенный майнор. При вызове действия будет отображена форма параметров, которую нужно заполнить следующим образом:

Форма параметров для добавления объединенного майнора
  • Уровень образования - в этом поле из выпадающего списка необходимо выбрать тот уровень образования, для студентов которого будет предназначен майор.
  • Наименование майнора - каждому майнору нужно присвоить наименование. Наименованием может быть любое строковое значение длиной не более 128 символов.
  • Начинается с курса - необходимо указать курс, начиная с которого будет реализовываться майнор.
  • Число лет реализации - в этом поле нужно установить целочисленное значение числа лет реализации майнора.
  • Учебный год начала реализации - в этом поле нужно выбрать учебный год, начиная с которого будет реализовываться данный майнор.
  • Год окончания реализации - в этом поле нужно выбрать учебный год, в котором студенты завершат обучение по данному майнору.
  • Филиал, Факультет - для выбора Образовательной программы, реализующей майнор, в этих полях нужно указать Филиал и Факультет, на которых реализуется данная программа.
  • Образовательная программа, реализующая майнор - в этом поле необходимо выбрать образовательную программу, которая предлагает и будет реализовывать данный майнор.
  • Минимальное количество студентов - в этом поле нужно задать целое число, соответствующее минимальному количеству студентов, для которых будет реализовываться майнор; если минимальное количество студентов не ограничивается, это значение нужно оставить пустым.
  • Максимальное количество студентов - в этом поле нужно задать целое число, соответствующее максимальному количеству студентов, для которых будет реализовываться майнор; если максимальное количество студентов не ограничивается, это значение нужно оставить пустым.
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов в году указать количество периодов в учебном году.

После нажатия кнопки ОК запись о новом майноре будет добавлена в основную таблицу данных.

7.2. Редактирование объединенного майнора

Редактирование майнора состоит в наполнении его дисциплинами, которые могут быть объединены в группы, уточнении объема нагрузки по дисциплинам, установке форм итогового контроля по дисциплинам.

Майнор может состоять из записей двух видов: разделы (группы дисциплин) и дисциплины. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в майнор записей других типов (НИСы, курсовые, практики и проч.) недопустимо.

Редактирование объединенного майнора выполняется при помощи специализированной формы редактирования, которая открывается при вызове для майнора действия Открыть или при двойном щелчке мышью по записи о майноре.

Редактирование объединенногоо плана

Добавление и удаление записей майнора, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню.

Добавление Группы дисциплин (раздела)

Для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Добавление группы дисциплин в объединенный майнор

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

Добавление Дисциплины

Для добавления Дисциплины необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие Дисциплину,

Процедура добавление дисциплины в объединенный майнор

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный майнор

Пользователям разработчикам объединенных майноров предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

    • После того как запись о дисциплинебудет добавлена в майнор, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик объединенного майнора больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

Перемещение Группы дисциплин (раздела) или дисциплины

В случае если при добавлении Группы дисциплин или Дисциплины был неверно указан раздел, куда они должны быть включены, то в отношении такой Группы дисциплин или Дисциплины необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить Группу дисциплин или Дисциплину, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина будет перемещена в корень объединенного майнора.

Также можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

Печать объединенных планов факультетских дисциплин

По окончании работы с объединенным майнором его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати, Выгрузить для печати как Базовый майнор, Выгрузить для печати как Рабочий майнор расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

7.3. Передача объединенного майнора в реализацию

Для того, чтобы дисциплины объединенного майнора могли быть назначены студентам, необходимо для плана выполнить действие Передать на факультет.

Передача объединенного майнора в реализацию

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Майноры учебных планов. Эта таблица доступна в разделе Общевузовские ресурсы, в форме Учебные планы, формы и программы обучения на вкладке Майноры учебных планов.

Назначение дисциплин майноров студентам на участке Студент выполняется именно из таблицы данных Майноры учебных планов. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного майнора необходимо выполнять действие по передаче майнора на факультет.

7.4. Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные майноры (форма Майноры учебных планов) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи майнора выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

7.5. Связать с предложением кафедры

Для того чтобы связать запись объединенного майнора с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись майнора.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

7.6. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные майноры (форма Майноры учебных планов) выбрать майнор, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как РУП, Выгрузить для печати как БУП.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести майнор на печать.

7.7. Оценка плановой затратности плана

Для оценки плановой затратности майнора необходимо:

  1. В форме редактирования объединенного майнора открыть группу действий Дополнительные действия (правый верхний угол).
    Форма редактирования ОМ Дополнительные действия
  2. Выбрать действие Оценка плановой затратности (отчет).
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате сформируется отчет с оценкой затратности реализации объединенного майнора.

7.8. Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных майноров выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.

8. Базовые майноры

Базовый майнор - это план изучения определенного набора дисциплин в течение нескольких лет обучения. Каждый базовый майнор разрабатывается для определенного уровня образования. Базовый майнор реализуется одной из образовательных программ вуза в течение определенного периода (нескольних ученых годов). Для базового майнора может задаваться минимальное и максимальное число студентов, необходимое для реализации майнора.

8.1. Создание нового базового майнора

Создание базового майнора и работа с ним осуществляется в форме Майноры учебных планов, доступной на консоли управления в разделе Разработка учебных планов.

Майноры на консоли управления

Представление для работы с базовыми майнорами расположено на второй вкладке данной формы.

Таблица данных Базовые майноры

Для добавления нового базового майнора в таблице данных нужно вызвать действие Добавить базовый майнор. При вызове действия будет отображена форма параметров, которую нужно заполнить следующим образом:

Добавление Базового майнора
  • Уровень образования - в этом поле из выпадающего списка необходимо выбрать тот уровень образования, для студентов которого будет предназначен майор.
  • Наименование майнора - каждому майнору нужно присвоить наименование. Наименованием может быть любое строковое значение длиной не более 128 символов.
  • Год начала реализации - в этом поле нужно выбрать учебный год, в котором студенты, для которых предназначается майнор, учились (будут учиться) на первом курсе.
  • Год окончания реализации - в этом поле нужно выбрать учебный год, в котором студенты, для которых предназначается майнор, завершат обучение.
  • Число курсов - в этом поле нужно установить целочисленное значение числа курсов (лет обучения), соответствующее уровню образования
  • Образовательная программа, реализующая майнор - в этом поле необходимо выбрать образовательную программу, которая предлагает и будет реализовывать данный майнор.
  • Минимальное количество студентов - в этом поле нужно задать целое число, соответствующее минимальному количеству студентов, для которых будет реализовываться майнор; если минимальное количество студентов не ограничивается, это значение нужно оставить пустым.
  • Максимальное количество студентов - в этом поле нужно задать целое число, соответствующее максимальному количеству студентов, для которых будет реализовываться майнор; если максимальное количество студентов не ограничивается, это значение нужно оставить пустым.

После нажатия кнопки ОК запись о новом майноре будет добавлена в основную таблицу данных. При этом в подчиненной таблице данных Записи базового майнора будет создана одна запись вида "Раздел плана" с наименованием "Весь майнор", которая будет служить "коревой" записью для будущего майнора.

Выбирая значения полей Год начала реализации, Год окончания реализации, Число курсов нужно исходить из того, что майнор разрабатывается для всех курсов обучения студентов, для которых предназначен майнор. Даже в случае, если известно, например, что майнор будет использоваться для студентов 2 - 3 курсов бакалавриата, для майнора должно быть задано Число лет обучения = 4, и выбраны годы обучения с 1-го по 4-ый курс.

8.2. Редактирование базового майнора

Редактирование майнора состоит в наполнении его дисциплинами, которые могут быть объединены в группы, уточнении объема нагрузки по дисциплинам, установке форм итогового контроля по дисциплинам. Формируя майнор, нужно исходить из следующих требования к его структуре:

Требования к структуре майнора:

  • Майнор обязательно должен иметь одну и только одну корневую запись типа "Раздел плана". При создании майнора такая запись создается автоматически и получает наименование " Весь майнор ". Это наименование допустимо изменить.
  • Майнор может состоять из записей двух видов: разделы (группы дисциплин) и дисциплины. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в майнор записей других типов (НИСы, курсовые, практики и проч.) недопустимо.

Редактирование базового майнора выполняется при помощи специализированной формы редактирования, которая открывается при вызове для майнора действия Открыть или при двойном щелчке мышью по записи о майноре.

Форма редактирования Базового майнора

Добавление и удаление записей майнора, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню. Основные характеристики записей майнора (число часов, кредитов, формы итогового контроля) редактируются непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей майнора, не видимых в таблице, предназначено действие Дополнительные свойства.

Удалить запись базового майнора можно только при выполнении следюущих условий:

  • не существует записей рабочих майноров, связанных с данной записью базового майнора
  • раздел (группу дисциплин) можно удалить только в случае, если в него не влкючена ни одна дисциплина и ни один другой раздел; если раздел необходимо удалить, сначала из него неоходимо удалить все дисциплины и другие разделы;

В основном процесс редактирования базового майнора аналогичен процессу редактирования Базового учебного плана (см. раздел Редактирование базового учебного плана) с учетом особенностей работы с записями разных типов, описанных в разделе Особенности наполнения отдельных разделов БУП и РУП. Для базового майнора предусмотрена работа только с разделами (группами дисциплин) и с дисциплинами.

9. Рабочие майноры

Рабочий майнор - это план изучения определенного набора дисциплин, входящих в состав одно из Базовых майноров в течение одного учебного года (одного курса студентов). Рабочие майноры разрабатываются на основе разработанных и утвержденных Базовых майноров.

Рабочие майноры для "свободных майноров" не создаются.

9.1. Создание нового рабочего майнора

Создание рабочего майнора и работа с ним осуществляется в форме Майноры учебных планов, доступной на консоли управления в разделе Разработка учебных планов.

Майноры на консоли управления

Представление для работы с рабочими майнорами расположено на третьей вкладке данной формы.

Таблица данных Рабочие майноры

Создать новый рабочий майнор можно только на основе ранее созданного базового майнора вида "Обычный майнор". Рабочие майноры для "свободных" майноров не создаются. Для добавления нового рабочего майнора в таблице данных нужно вызвать действие Добавить рабочий майнор. При вызове действия будет отображена форма параметров, которую нужно заполнить следующим образом:

Добавление Рабочего майнора
  • Базовый майнор - в этом поле нужно выбрать один из базовых майноров, на основе которого будет разрабатываться новый рабочий майнор.
  • Учебный год - в этом поле нужно выбрать учебный код, для которого будет разрабатываться новый рабочий майнор, из справочника .
  • Курс - в этом поле нужно выбрать курс студентов, для которого будет разрабатываться новый рабочий майнор.
  • Реализуется по периодам - в этом поле нужно выбрать один из вариантов реализации майнора - по модулям или по семестрам.
  • Количество периодов - в этом поле нужно задать целочисленного значение числа периодов (модулей или семестров), для которых будет распределяться нагрузка по дисциплинам майнора.

После нажатия кнопки ОК запись о новом майноре будет добавлена в основную таблицу данных.

9.2. Редактирование рабочего майнора

Редактирование рабочего майнора состоит в задании кафедр, которые будут реализовывать дисциплины, уточнении параметров нагрузки по дисциплине (часов, кредитов), распределении нагрузки по видам работы (лекции, семинары, самостоятельная работа и проч.), и по периодам обучения (модулям или семестрам), установке числа форм текущего контроля (контрольных работ, домашних задний и проч.). Структура рабочего майнора должна повторять структуру базового майнора и соответствовать требованиям, предъявляемым к структуре базового майнора, которые описаны в разделе Редактирование базового майнора. Отличие структуры рабочего майнора от структуры базового майнора может состоять только в отсутствии в рабочем майноре групп дисциплин, которые не реализуются на соответствующем курсе.

Редактирование рабочего майнора выполняется при помощи специализированной формы редактирования, которая открывается при вызове для майнора действия Открыть или при двойном щелчке мышью по записи о майноре.

Форма редактирования Рабочего майнора

Установка кафедры, реализующей дисциплину майнора, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню. Основные характеристики записей майнора (число часов, кредитов), их распределение по видам работы и периодам обучения выполняется непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей майнора, не видимых в таблице, предназначено действие Дополнительные свойства. Для уточнения нагрузки и видов испытаний по периодам обучения предназначено действие Дополнительные свойства в периоде. Перед вызовом этого действия нужно выбрать одну из ячеек в колонке, соответствующей периоду, в правой части формы.

В основном процесс редактирования рабочего майнора аналогичен процессу редактирования Рабочего учебного плана (см. раздел Редактирование рабочего учебного плана) с учетом особенностей работы с записями разных типов, описанных в разделе Особенности наполнения отдельных разделов БУП и РУП. Для рабочего майнора предусмотрена работа только с разделами (группами дисциплин) и с дисциплинами.

10. Объединенные учебные планы аспирантуры

"Объединенные учебные планы аспирантуры" - это такой вид учебных планов, который объединяет в себе "базовый учебный план аспирантуры" и "рабочий учебный план аспирантуры". Объединенный учебный план разрабатывается сразу на все годы реализации образовательной программы, содержит полный набор разделов, дисциплин и других видов записей планов на весь период обучения, и в то же время отражает планирование нагрузки как по дисциплине в целом, так и по видам работ (лекции, семинары, практически и т.п.), по учебным годам, по периодам каждого года, а также отражает планирование испытаний текущего и рубежного контроля.

10.1. Создание нового объединенного учебного плана аспирантуры

Работа с Объединенными учебными планами аспирантуры ведется на участке "Разработка учебных планов" в форме "Объединенные учебные планы аспирантуры". Для создания нового объединенного учебного плана аспирантуры необходимо чтобы предварительно был сформирован соответствующий образовательный стандарт. Работа с образовательными стандартами описана в разделе Образовательные стандарты.

Для добавления объединенного учебного плана, необходимо в представлении Объединенные учебные планы аспирантуры с помощью контекстного меню вызвать действие Добавить объединенный план аспирантуры.

Вызвать действие Добавить ОУП аспирантов

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров Добавить ОУП аспирантуры

  • В полях Образовательный стандарт и Образовательную программа - выбрать образовательный стандарт и программу, для которой создается план.
  • Поля Аспирантская школа, Филиал, Форма обучения и Число лет обучения будут заполнены автоматически данными, заданными для образовательного стандарта и выбранной образовательной программы.
  • В полях Год начала обучения, Год окончания обучения указать года начала и окончания обучения, периоды, по которым будет планироваться нагрузка.
  • При наличии соответствующей информации можно указать Число кредитов по плану в целом.
  • В поле Реализуется по периодам выбрать один из предлагаемых вариантов реализации: по модулям, по семестрам или по периодам в аспирантуре.
  • В поле Количество периодов в году указать количество периодов в учебном году.

После того, как будет заполнена форма параметров, нужно нажать кнопку ОК. В результате запись о новом объединенном учебном плане аспирантов появится в представлении. При попытке добавления второго объединенного учебного плана аспирантуры на основе той же образовательной программы, образовательного стандарта для той же аспирантской школы, года начала обучения, произойдет ошибка дублирования объектов.

10.2. Редактирование объединенного учебного плана аспирантуры

Сформировать структуру и состав нового объединенного учебного плана аспирантуры можно на основе образовательного стандарта. Для этого нужно выбрать объединенный учебный план аспирантуры в представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) и в контекстном меню выбрать действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Сообщение о формировании ОУП аспирантов на основании стандарта

Если Вы уверены, что хотите сформировать учебный план на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненном представлении Все записи плана.

После того, как объединенный учебный план сформирован на основе стандарта, его можно редактировать. Для редактирования предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования ОУп аспирантов

Редактирование объединенного учебного плана аспирантов должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (практик аспирантов, кандидатских экзаменов, и т.п.), распределять нагрузку по видам работы (лекции, семинары, практические и т.д.), по годам обучения и по периодам обучения в каждом году, а также планировать рубежные испытания, распределять кредиты и объем нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: дисциплину, научно-исследовательский семинар, научные исследования аспирантов, практику аспирантов, кандидатский экзамен, итоговый госэкзамен, защиту научного доклада.

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, дисциплина по выбору или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

Форма редактирования ОУП аспирантов распределение нагрузки по годам

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение свойств разделов и дисциплин ОУП.

По окончании работы с объединенным учебным планом аспирантов его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении действия учебный план будет выгружен для печати в MS Excel.

10.2.1. Добавление дисциплин и НИС

При добавлении дисциплины или НИС в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие дисциплину или научно-исследовательский семинар, после чего заполнить следующую форму параметров:

Форма параметров Добавить дисциплину в ОУП аспирантуры
Пользователям разработчикам учебных планов предоставлена возможность связывания дисциплин и НИС учебного плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
      Для выбора из плана-предложения кафедры будут доступны только те дисциплины, которые совпадают по периоду реализации с периодом, заданным с помощью полей Год начала реализации и Год окончания реализации.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • Установить значение для признака Входит в расчет недельной нагрузки.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных профилей аспирантуры, необходимо выбрать профили, для которых добавляется дисциплина. Для выбора профилей необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей профилей, после чего нужно нажать кнопку ОК.
      Для каждого профиля в ОУП будет создана отдельная запись по дисциплине.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Вид дисциплины в плане, По выбору студентов, Формат изучения,На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных профилей подготовки аспирантуре, необходимо выбрать профили, для которых добавляется дисциплина. Для выбора профилей необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей профилей, после чего нужно нажать кнопку ОК.
      Для каждого профиля в ОУП будет создана отдельная запись по дисциплине.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план аспирантуры.
    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (более подробно см. Редактирование объединенного учебного плана аспирантуры). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признак Входит в расчет недельной нагрузки.
  • Профили для дисциплин и НИС (см. Установить/ изменить профиль).
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

10.2.2. Добавление практики аспирантов

При добавлении практики аспирантов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие практику аспирантов, после чего заполнить следующую форму параметров:

Форма параметров Добавить практику в ОУП аспирантуры

В первую очередь необходимо ввести Наименование практики и Общее число часов, указать Вид практики (справочник ) и Способ проведения практики, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК практика будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по практике (см. Редактирование объединенного учебного плана аспирантуры).

10.2.3. Добавление научного исследования аспирантов

При добавлении научного исследования аспирантов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие научные исследования аспирантов, после чего заполнить следующую форму параметров:

Форма параметров Добавить научные исследования в ОУП аспирантуры

В первую очередь необходимо указать Наименование и Общее число часов для научных исследований аспирантов, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК запись о научных исследованиях аспирантов будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по научным исследованиям (см. Редактирование объединенного учебного плана аспирантуры).

10.2.4. Добавление кандидатских экзаменов

При добавлении кандидатского экзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие кандидатский экзамен, после чего заполнить следующую форму параметров:

Форма параметров Добавить кандидатский экзамен в ОУП аспирантуры

В первую очередь необходимо ввести Наименование для экзамена и Общее число часов, выбрать Дисциплину ВУЗа, по которой будет проходить кандидатский экзамен, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК кандидатский экзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по кандидатскому экзамену (см. Редактирование объединенного учебного плана аспирантуры).

10.2.5. Добавление итогового госэкзамена

При добавлении госэкзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие итоговый госэкзамен, после чего заполнить следующую форму параметров:

Форма параметров Добавить госэкзамен в ОУП аспирантуры

В первую очередь необходимо ввести Наименование для экзамена и Общее число часов, при необходимости можно выбрать Дисциплину, по программе которой будет проходить экзамен, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК госэкзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по госэкзамену (см. Редактирование объединенного учебного плана аспирантуры).

10.2.6. Добавление защиты научного доклада

При добавлении защиты научного доклада в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие защита научного доклада, после чего заполнить следующую форму параметров:

Форма параметров Добавить защиту докладов в ОУП аспирантуры

В первую очередь необходимо ввести Наименование, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК госэкзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по защите научного доклада (см. Редактирование объединенного учебного плана аспирантуры).

10.2.7. Формирование информации о численности контингента

Для добавления информации о численности контингента необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать план, для записей которого будет уточняться информация о численности контингента.
  2. В представлении Все записи по годам обучения для записей учебного плана в соответствующих полях указать Количество потоков, Количество групп, Количество подгрупп и Количество студентов (аспирантов) (после изменения значения каждого из параметров нужно нажимать клавишу Enter).

10.2.8. Изменение периода реализации

Для изменения периода реализации записи объединенного учебного плана аспирантов, необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать учебный план.
  2. В представлении Все записи плана выбрать запись учебного плана, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

10.2.9. Уточнение свойств разделов и дисциплин ОУП

В формах редактирования объединенных учебных планов аспирантуры работают проверки контрольных соотношений, при помощи которых контролируется корректность и целостность плана, соответствие характеристик записей плана требованиям образовательного стандарта, выполнение Методических указаний по разработке объединенных учебных планов аспирантуры. Также при помощи функционала формы редактирования можно выполнять автоматизированные пересчеты показателей плана, в частности, суммирование значений числа часов, недель, кредитов по разделам и группам дисциплин.

В образовательном стандарте не содержится достаточно информации для того, чтобы реализовать корректную работу некоторых автоматизированных проверок и пересчетов. По этой причине после формирования учебного плана на основе стандарта, необходимо выполнить уточнение следующих значений для некоторых разделов и дисциплин учебного плана:

  1. Признак Рассчитывается как сумма элементов для групп дисциплин и разделов.

    Все разделы и группы дисциплин можно разделить на два вида:

    • Разделы или группы, показатели которых должны определяться путем суммирования показателей входящих в них записей.
    • Разделы или группы, показатели которых могут устанавливаться независимо.

    К первой группе относятся разделы и группы, все дисциплины которых обязательны для изучения всеми аспирантами. Ко второй группе относятся разделы и группы дисциплин по выбору. Для того, чтобы отличить один вид разделов от другого используется признак Рассчитывается как сумма элементов. При формировании учебного плана на основе стандарта для всех разделов и групп дисциплин этот признак получает значение Да. Если для признака установить значение Нет, то проверка соответствия суммы показателей для всех записей раздела со значением, установленным для раздела в целом, проводиться не будет, и сообщения об ошибках не будут формироваться. Для группы дисциплин (раздела) по выбору значения числа часов, недель, кредитов, числа экзаменов и зачетов нужно установить вручную таким образом, чтобы раздел, в свою очередь, внес необходимый вклад в план в целом. Например, если в раздел включено три дисциплины по выбору, трудоемкостью 108 часов каждая, а аспиранты должны выбрать только одну из них, для раздела вручную должно быть установлено число часов, равное 108.

    Для того чтобы в дальнейшем на основании разработанных объединенных учебных планов можно было сформировать учебный план аспиранта и проверить его полноту и корректность, необходимо задать для каждой группы или раздела дисциплин по выбору минимальное и максимальное количество дисциплин, которые должны быть обязательно выбраны аспирантом, также необходимо задать минимально и максимальное число кредитов, которое необходимо набрать при выборе дисциплин аспирантом. Если при наполнении образовательного стандарта эти значения не заданы, то их необходимо задать в форме редактирования объединенного учебного плана при помощи действия Дополнительные свойства.

  2. Признак Входит в расчет недельной нагрузки. Данный признак используется для того, чтобы исключить некоторые дисциплины учебного плана из расчета недельной аудиторной нагрузки аспирантов. Изменить значение данного признака можно в форме редактирования учебного плана при помощи действия Дополнительные свойства. При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются двумя звездочками (**) в колонке "Наименование дисциплины". По этой причине вносить знаки * в наименование дисциплины не нужно. В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.

10.2.10. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связать с предложением кафедры в ОУП аспирантуры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

10.2.11. Установить/ изменить профиль

Для установки, снятия и изменения профиля, установленного для записи учебного плана, необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать учебный план, в который входит запись.
  2. В представлении Все записи плана выбрать запись, для которой необходимо установить, снять или изменить профиль.
    При добавлении дисциплины или НИС можно установить сразу несколько специализаций, для каждой из них будет создана отдельная запись о дисциплине или НИС (см. Добавление дисциплин и НИС). В связи с этим необходимо удостовериться, что выбранная дисциплина или НИС соответствуют той записи, которую необходимо изменить. Установленные специализации можно проверить в поле Специализация.
  3. Из контекстного меню вызвать действие Установить\изменить профиль.
  4. В форме параметров указать Специализацию (профиль аспирантуры).
  5. Нажать кнопку ОК.

10.3. Передача плана на факультет

Для того чтобы дисциплины объединенного учебного плана аспирантуры могли быть назначены аспирантам, необходимо для плана выполнить действие Передать план в реализацию.

Вызов действия Передать план в реализацию для ОУП аспирантов

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

Результатом выполнения процедуры будет создание или уточнение свойств записей в представлении Учебные планы аспирантуры. Данное представление доступно на участке Аспирант, в форме Учебные планы аспирантуры.

10.4. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать действие Выгрузить для печати.
  3. В форме параметров указать Профиль, для которого нужно вывести на печать, или оставить пустое значение, если нужно вывести на печать учебный план для всех профилей.
  4. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.

10.5. Оценка плановой затратности плана

Выполнить оценку плановой затратности плана можно:

С помощью формирования отчета "Оценка плановой затратности плана"

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
    Вызов действия отчет оценка затратности ОУп аспирантов
  2. Выбрать действие Оценка плановой затратности (отчет).
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате сформируется отчет с оценкой затратности реализации объединенного учебного плана аспирантов.

С помощью действия Рассчитать плановую затратность

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
  2. Выбрать действие Рассчитать плановую затратность.
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате будет выведено сообщение с указанием плановой затратности плана.

11. Базовые учебные планы аспирантуры (БУПы аспирантуры)

Базовые учебные планы аспирантуры разрабатываются на основе Образовательных стандартов аспирантуры отдельно для каждой и для каждого набора аспирантов. Базовый учебный план аспирантуры отражает полный цикл дисциплин и других видов нагрузки, которые должны быть прослушаны и сданы аспирантами в течение всего срока обучения в аспирантуре с разбиением нагрузки по годам обучения.

Каждый базовый учебный план аспирантуры может расширять и уточнять содержание соответствующего образовательного стандарта. Работа с БУПом аспирантуры состоит из этапов:

  • Создание БУП аспирантуры на основе образовательного стандарта
  • Редактирование БУП аспирантуры
  • Согласование и утверждение БУП аспирантуры

11.1. Создание нового базового учебного плана аспирантуры

Для создания БУП аспирантуры необходимо, чтобы предварительно были сформированы следующие данные:

  • Создан и полностью сформирован Образовательный стандарт аспирантуры по соответствующему направлению подготовки.
  • В справочнике создана соответствующая аспирантская школа.
  • В справочнике созданы учебные года, соответствующие всем годам, в течение которых будет реализовываться новый БУП (от года начала обучения до года окончания обучения).
  • В справочнике созданы записи о форме и годах обучения, для которых будет разрабатываться БУП.

Создание и дальнейшая работа с БУП аспирантуры ведется в разделе Разработка учебных планов в форме Базовые и рабочие учебные планы аспирантуры на первой вкладке Базовые учебные планы аспирантуры. Для создания нового БУП аспирантуры на этой вкладке необходимо вызвать действие Добавить базовый учебный план.

Добавление БУП аспирантуры

Для добавления нужно в поле Аспирантская школа выбрать соответствующую школу из справочника , выбрать Образовательный стандарт из справочника Образовательные стандарты, выбрать Форму обучения и задать соответствующее этой форме Число лет обучения. Также необходимо выбрать Год начала обучения и Год окончания обучения из справочника .

После корректного заполнения всех полей формы добавления кнопка ОК станет активной. После ее нажатия новый базовый учебные план аспирантуры будет добавлен в таблицу данных.

11.2. Редактирование базового учебного плана аспирантуры

После создания БУП аспирантуры его необходимо заполнить и отредактировать путем выполнения следующих двух этапов:

  1. Сформировать на основе стандарта
  2. Отредактировать, указав распределение нагрузки, заданной стандартом по годам обучения, при необходимости уточнив и дополнив содержание стандарта.

Формирование БУП аспирантуры на основе стандарта

После создания БУП аспирантуры необходимо выбрать его в таблице данных и вызвать действие Сформировать на основе стандарта. Результатом выполнения этого действие будет копирование в БУП всего содержания стандарта с сохранением структуры разделов и величин нагрузки, заданных в стандарте.

Редактирование БУП аспирантуры

Для редактирования БУП аспирантуры предназначена специализированная форма, которая доступна посредством вызова действия Открыть по выбранному БУП. При помощи формы редактирования можно выполнять следующие операции:

  • Корректировать (в случае необходимости) или дополнять значения нагрузки, полученные из стандарта
  • Распределять нагрузку, предусмотренную по дисциплине в целом по годам обучения.
  • Дополнять содержание стандарта дополнительными дисциплинами и другими видами работы.
  • Уточнять структуру плана за счет добавления новых разделов или групп дисциплин и переноса дисциплин между разделами.

В целом принцип редактирования БУП аспирантуры аналогичен принципу редактирования БУП студентов, описанному в разделе Редактирование базового учебного плана. Работа с Графиками учебного процесса для БУП аспирантуры не предусмотрена.

Принципы работы с отдельными видами записей БУП аспирантуры аналогичны принципам, заложенным для БУП студентов и описаны в разделе Особенности наполнения отдельных разделов БУП и РУП.

В форме редактирования БУП аспирантуры реализованы проверки и автоматически расчеты, аналогичные реализованным для БУП факультетов. Принцип действия этих расчетов описан в разделе Расчетные показатели учебных планов.

Готовый БУП аспирантуры можно выгрузить в утвержденной форме в MS Excel при помощи действия Выгрузить для печати.

12. Рабочие учебные планы (РУПы)

Рабочие учебные планы представляют собой иерархическую структуру компонентов (разделов, циклов), групп дисциплин, дисциплин и записей других видов (курсовых работ, практик, итоговых госэкзаменов, выпускных квалификационных работ). Рабочий учебный план разрабатывается на один учебный год для одного курса студентов факультета (отделения), обучающихся по одному направлению (специальности), по одной специализации, магистерской программе и магистерской специализации. Рабочие учебные планы содержат информацию о видах и количестве испытаний текущего, промежуточного и итогового контроля по дисциплинам, о распределении учебной нагрузки по видам (лекции, семинары, самостоятельная работа и т.п.), а также о реализации дисциплин различными кафедрами ВУЗа.

Каждый рабочий учебный план формируется на основе базового учебного плана, благодаря чему получает атрибуты Тип образовательного стандарта, Образовательный стандартНаправление (специальность), Степень (квалификация), Факультет. Если для базового учебного плана были заданы Специализация, Магистерская программа, Магистерская специализация, то они также будут использованы для РУП. Если эти атрибуты не были заданы для БУП, их можно уточнить при создании РУП.

Создание нового рабочего учебного плана включает следующие этапы работы:

  1. Создание записи о РУПе и его наполнение на основе базового учебного плана.
  2. Редактирование сформированного РУПа.
  3. Связывание записей РУПа с компетенциями.

12.1. Создание нового рабочего учебного плана

Работа с РУПами ведется в форме Базовые и рабочие учебные планы в таблице данных Рабочие учебные планы. Для создания нового РУП нужно в этой таблице данных вызвать действие Добавить рабочий учебный план.

Добавление РУП бакалавриата

Форма добавления РУП (бакалавриат)

Добавление РУП магистратуры

Форма добавления РУП (магистратура)
  • В поле Факультет значение подставится автоматически, если Вы являетесь пользователем одного из факультетов. Если Вы имеете права на работу со всеми факультетами, то в этом поле нужно выбрать факультет, для которого создается РУП.
  • В поле Уровень обучения нужно выбрать один из предлагаемых вариантов (Бакалавриат, Специалитет, Магистратура)
  • В поле Базовый учебный план для выбора будут предложены все ранее созданные БУПы выбранного факультета и уровня обучения. После выбора БУП автоматически заполнятся поля Направление / специальность (обязательно присутствует в БУП), а также Специализация, Магистерская программа, Магистерская специализация (если они заданы в БУП).
  • Поле Направление / специальность заполняется автоматически при выборе БУП и недоступно для самостоятельного изменения.
  • Поле Специализация доступно для изменения только в случае, если в поле Уровень образования выбраны значения Бакалавриат или Специалитет, а также если специализация не задана в БУП. В этом случае специализацию можно выбрать из перечня специализаций, существующих в справочнике . Если РУП не требует задания специализации, то это поле нужно оставить пустым.
  • Поле Магистерская программа заполняется автоматически на основании выбранного БУП. Это поле недоступно для отдельного изменения.
  • Поле Магистерская специализация доступно для заполнения только в случае, если в поле Уровень образования выбрано значение Магистратура а также если магистерская специализация не задана в БУП. В этом случае ее можно выбрать из перечня, существующего в справочнике для выбранной магистерской программы.
  • В поле Форма обучения нужно выбрать ту форму обучения, по которой будет реализовываться РУП. Выбор производится из общевузовского справочника .
  • В поле Курс нужно выбрать курс факультета, для которого формируется РУП.
  • В поле Учебный год нужно выбрать учебный год, в котором будет реализовываться формируемый РУП.
  • Поле Вариант позволяет создать несколько вариантов РУП одного и того же РУП с тем, чтобы в дальнейшем выбрать наиболее удачный вариант. Для этого в данном поле нужно указать метку варианта (например, "в-2"). Желательно использовать минимального число символов. Если Вы не планируете работать с несколькими вариантами одного и того же РУП, это поле нужно оставить пустым.
  • В поле Реализуется по периодам нужно выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество учебных периодов нужно задать число модулей или семестров, по которым будет реализовываться план.
  • В поле Количество потоков нужно задать плановое число потоков по данному РУП.
  • В поле Количество студентов нужно задать плановое число студентов, которые будут обучаться по данному РУП.
  • В поле Количество групп нужно задать число групп студентов, которые будут обучаться по РУП.

После заполнения всех необходимых полей, нужно нажать кнопку ОК, и запись о новом РУП появится в таблице данных. Не допускается создание двух РУП с одинаковым сочетанием атрибутов

  • Факультет
  • Учебный год
  • Направление/специальность
  • Специализация
  • Магистерская программа
  • Магистерская специализация
  • Метка варианта плана
При попытке создания второго РУП с тем же сочетанием атрибутов произойдет ошибка дублирования объектов.

12.2. Создание рабочего учебного плана как копии существующего

Если необходимо создать рабочий учебный план, существенно схожий с уже существующим, можно воспользоваться возможностью копирования плана. При помощи копирования можно создать РУП другой специализации, другой магистерской специализации. Также допустимо копировать РУП с одного учебного года на другой. Для этого необходимо сменить БУП, на основе которого разрабатывается РУП на БУП другого года набора. Также при помощи копирования можно создать другую версию того же плана.
Несмотря на то, что при копировании РУП разрешена смена БУП, являющегося основой РУП, не рекомендуется копировать РУП со сменой направления (специальности) подготовки. Копировать РУП с одного учебного года на другой стоит только в том случае, если структура плана (разделы плана и порядок их включения друг в друга) сохраняется. Если же структура плана должна быть другой, то лучше создать новый план, после чего воспользоваться действием Сформировать не основе базового плана.
Для того чтобы создать новый план на основе существующего, нужно выбрать исходный план в таблице данных и вызвать действие Скопировать как новый план.

Форма копирования нового РУП на базе старого

Набор полей формы копирования аналогичен набору полей формы добавления рабочего плана. Принципы работы со всеми полями описаны в разделе Создание нового рабочего учебного плана. При открытии формы копирования плана все поля заполняются значениями, установленными для исходного плана. Для создания нового плана нужно изменить те значения, которые будут отличаться для нового плана и нажать кнопку ОК.

Результатом работы процедуры копирования будет запись о новом рабочем учебном плане в таблице данных Рабочие учебные планы. В подчиненной таблице Записи рабочего плана будет создан набор записей, полностью аналогичный составу исходного плана. Также для нового плана будет перенесена информация о распределении учебной нагрузки по периодам обучения и формы текущего контроля. Если с записями исходного плана были связаны компетенции, то они также будут скопированы в новый план и связаны с соответствующими записями.

После выполнения процедуры копирования можно продолжить редактирование нового плана. Редактирование может заключаться в добавлении новых записей, удалении созданных при копировании, уточнении форм итогового и текущего контроля по дисциплинам, значений объема учебной нагрузки в часах, неделях, кредитах.

Выполнять копирование плана лучше после того, как работа над составом и структурой исходного плана завершена (или близка к завершению). Автоматически актуализировать структуру и состав копии плана после изменения исходного плана будет невозможно. Однако возможно выполнить для нового плана действие Очистить, удалить план и снова сформировать его как копию существующего. Переформировывать таким образом план можно только пока он находится в статусе проект.

12.3. Редактирование рабочего учебного плана

Если рабочий учебный план не создавался методом копирования, то после создания его содержимое можно сформировать на основе выбранного при создании базового учебного плана. Для этого нужно выбрать РУП в таблице данных и выполнить действие Сформировать на основе базового плана. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Записи рабочего учебного плана. В таблице данных Развиваемые компетенции, подчиненной по отношению к записям плана, будут сформированы записи о компетенциях повторяющие записи, созданные в БУП.

После того, как РУП сформирован на основании БУП или скопирован, его можно редактировать. Для редактирования предназначена специализированная форма работы с РУП, которая открывается при вызове действия Открыть.

Редактирование РУП должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), выборе кафедр, которые будут преподавать дисциплины на факультете, распределении учебной нагрузки по видам (лекции, семинары, самостоятельная работа) и по учебным периодам. Для добавления записей в РУП предназначены соответствующие действия контекстного меню. Для добавлении записи в определенный раздел нужно сначала выбрать заголовок этого раздела или одну из входящих в него записей.

При добавлении дисциплины в РУП потребуется найти нужную дисциплину в общевузовском справочнике всех дисциплин. Данный справочник, как правило, содержит очень много записей, многие из которых имеют похожие наименования. Для поиска нужной дисциплины можно использовать следующие приемы:
  1. Начать ввод с клавиатуры названия дисциплины в поле Дисциплина формы добавления. По ходу вводу символов будут автоматически предлагаться дисциплины, наименование которых начинается с введенных символов (при вводе необходимо соблюдать регистр!).
  2. Открыть справочник дисциплин, воспользоваться фильтром по наименованию или по части наименования. В строке фильтра допустимо использование символов "*" (любое число любых символов) и "?" (один любой символ). Например, введя в строку фильтра значение *экономическ* и нажав Enter можно отобрать для показа только те дисциплины, которые имеют в своем наименовании буквосочетание "экономическ" ("История экономических учений", "Введение в экономическую географию", "Политико-экономический анализ" и т.п.). При этом дисциплина с наименованием "Экономическая теория" отобрана не будет, т.к. символ "Э" введен в ней в верхнем регистре.

    Установка фильтра 1
  3. Открыть справочник дисциплин, выбрать в нем любую запись, в записи выбрать колонку "Полное наименование". Прижав клавишу Alt, начать вводить наименование дисциплины. Регистр символов при этом не играет роли.

    Установка фильтра 2

    После того, как клавиша Alt будет отпущена, в таблице данных будет найдена и выделена первая дисциплина, наименование которой начинается с символов "дискр" в любом регистре, например, "Дискретная математика".

По окончании работы с РУП его можно вывести на печать. Для этого можно воспользоваться действием Напечатать план, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия РУП будет выгружен для печати в MS Excel.

12.4. Связывание записей рабочего плана с развиваемыми компетенциями

При формировании рабочего учебного плана не основе базового, компетенции, связанные с записями базового плана будут связаны с соответствующими записями рабочего плана. Для дополнения и уточнения развития компетенций в РУП можно удалить или добавить компетенции к записям РУП, что делается аналогично связыванию компетенций с записями БУП (см. раздел Связывание записей базового плана с развиваемыми компетенциями ).

13. Рабочие учебные планы аспирантуры (РУПы аспирантуры)

Рабочие учебные планы аспирантуры разрабатываются на основе Базовых учебных планов аспирантуры отдельно для каждой и для каждого учебного года. Рабочий учебный план аспирантуры отражает цикл дисциплин и других видов нагрузки, которые должны быть прослушаны и сданы аспирантами в течение одного года обучения с разбиением нагрузки по периодам обучения (полугодиям) т указанием форм промежуточного и итогового контроля по периодам обучения.

Каждый рабочий учебный план аспирантуры может расширять и уточнять содержание соответствующего базового учебного плана. Работа с РУПом аспирантуры состоит из этапов:

  • Создание РУП аспирантуры на основе БУП
  • Редактирование РУП аспирантуры
  • Согласование и утверждение РУП аспирантуры

13.1. Создание нового рабочего учебного плана аспирантуры

Для создания БУП аспирантуры необходимо, чтобы предварительно были сформированы следующие данные:

  • Создан и полностью сформирован Базовый учебный план аспирантуры, на основе которого должен быть разработан новый РУП.
  • В справочнике создан учебный год, на который будет разрабатываться новый РУП, и в составе этого учебного года должны быть созданы периоды обучения, по которым предстоит распределять нагрузку и планировать испытания (зачеты и экзамены).
  • В справочнике создана запись о форме и годе обучения, для которых будет разрабатываться РУП.

Создание и дальнейшая работа с РУП аспирантуры ведется в разделе Разработка учебных планов в форме Базовые и рабочие учебные планы аспирантуры на второй вкладке Рабочие учебные планы аспирантуры. Для создания нового РУП аспирантуры на этой вкладке необходимо вызвать действие Добавить рабочий учебный план.

Добавление РУП аспирантуры

Для добавления нужно в поле Аспирантская школа выбрать соответствующую школу из справочника , выбрать Базовый учебный план. После выбора базового учебного плана поля Направление / специальность и Форма обучения будут заполнены данными, соответствующими БУП. Изменять из независимо от БУП невозможно. Также необходимо выбрать Год обучения аспирантов из справочника и Учебный год из справочника . Значение в поле Количество учебных периодов позволит выполнять планировать нагрузку и проведение испытаний по соответствующему числу сессий. Значения Количество потоков, Количество групп, Количество аспирантов позволят рассчитывать нагрузку кафедр и преподавателей по реализации данного РУП.

После корректного заполнения всех полей формы добавления кнопка ОК станет активной. После ее нажатия новый рабочий учебные план аспирантуры будет добавлен в таблицу данных.

13.2. Редактирование рабочего учебного плана аспирантуры

После создания РУП аспирантуры его необходимо заполнить и отредактировать путем выполнения следующих двух этапов:

  1. Сформировать на основе БУП
  2. Отредактировать, указав распределение нагрузки, заданной БУП, по периодам учебного года, запланировать рубежные испытания (экзамены и зачеты) и текущий контроль (домашние задания, рефераты, контрольные работы). При необходимости можно уточнить и дополнить содержание БУП.

Формирование РУП аспирантуры на основе БУП

После создания РУП аспирантуры необходимо выбрать его в таблице данных и вызвать действие Сформировать на основе базового. Результатом выполнения этого действие будет копирование в РУП всего содержания РУП на один из годов обучения с сохранением структуры разделов и величин нагрузки, заданных в БУП.

Редактирование РУП аспирантуры

Для редактирования РУП аспирантуры предназначена специализированная форма, которая доступна посредством вызова действия Открыть по выбранному РУП. При помощи формы редактирования можно выполнять следующие операции:

  • Корректировать (в случае необходимости) или дополнять значения нагрузки, полученные из БУП
  • Распределять нагрузку, предусмотренную по дисциплине в учебном году по периодам учебного года.
  • Планировать текущий контроль (домашние задания, рефераты, контрольные работы и проч.).
  • Дополнять содержание БУП дополнительными дисциплинами и другими видами работы.
  • Уточнять структуру плана за счет добавления новых разделов или групп дисциплин и переноса дисциплин между разделами.

В целом принцип редактирования РУП аспирантуры аналогичен принципу редактирования РУП студентов, описанному в разделе Редактирование рабочего учебного плана.

Принципы работы с отдельными видами записей РУП аспирантуры аналогичны принципам, заложенным для РУП студентов и описаны в разделе Особенности наполнения отдельных разделов БУП и РУП.

В форме редактирования РУП аспирантуры реализованы проверки и автоматически расчеты, аналогичные реализованным для РУП факультетов. Принцип действия этих расчетов описан в разделе Расчетные показатели учебных планов.

Готовый РУП аспирантуры можно выгрузить в утвержденной форме в MS Excel при помощи действия Выгрузить для печати.

14. Рабочие учебные планы общевузовских дисциплин

В системе поддерживается возможность разработки рабочих учебных планов (РУПов), в которые будут включены дисциплины, преподаваемые не для студентов определенных образовательных программ, а предлагаемые для выбора всем студентам вуза. В отличие от обычных РУПов РУПы общевузовских дисциплин разрабатываются независимо от Базовых учебных планов (БУП) и Образовательных стандартов.

Структура и атрибутивный состав записей РУПов общевузовских дисциплин аналогичны обычным РУПам. При этом для РУПов общевузовских дисциплин не предусмотрен расчет итоговых показателей плана (сумма часов и кредитов, средняя аудиторная нагрузка и проч.). Также для РУПов общевузовских дисциплин не предусмотрены процедуры согласования и утверждения.

Данные о дисциплинах, входящих в общевузовские РУПы, используются при составлении планов нагрузки преподавателей. Нагрузка по дисциплинам общевузовских РУП рассчитывается аналогично нагрузке по дисциплинам обычных РУП.

Создание и редактирование РУПов общевузовских дисциплин выполняется в разделе Разработка учебных планов в форме Учебные планы общевузовских дисциплин на вкладке Рабочие планы общевузовских дисциплин.

14.1. Создание РУПа общевузовских дисциплин

Создание РУПов общевузовских дисциплин выполняется в разделе Разработка учебных планов в форме Учебные планы общевузовских дисциплин на вкладке Рабочие планы общевузовских дисциплин. Для создания нового плана нужно вызвать действие Добавить учебный план общевузовских дисциплин.

Добавление РУП общевузовских дисциплин

Для создания нового РУП необходимо выбрать Учебный год, занести Наименование плана, выбрать Уровень образования (параметр необязательный), выбрать тип периодов реализации в поле Реализуется по периодам и задать Количество учебных периодов.

От выбора Уровня образования будет зависеть то, по каким нормативам будет считаться нагрузка кафедр и преподавателей по дисциплинам этого плана. От выбора Периодов реализации и их количества будет зависеть то, по каким периодам будут планироваться испытания (экзамены и зачеты) по этим дисциплинам.

14.2. Редактирование РУПа общевузовских дисцплин

После создания РУПа общевузовских дисциплин его можно редактировать при помощи формы редактирования. Форма редактирования открывается при помощи действия Открыть.

Добавление разделов, групп дисциплин и дисциплин, уточнение их характеристик, распределения аудиторных часов по модулям выполняется аналогично этим же возможностям в обычных РУП. Подробнее - Редактирование рабочего учебного плана. Итоговые значения для плана в целом и средние значения недельной аудиторной нагрзки по плану в целом не подсчитываются.

14.3. Передача РУПа общевузовских дисциплин на реализацию

Для того, чтобы дисциплины общевузовского РУП могли быть назначены студентам, необходимо выполнить для плана действие Передать план на факультет. Для каждой отдельной дисциплины можно также вызывать действие Передать в план факультета в подчиненной таблице Записи рабочего учебного плана.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Дисциплины вне учебных планов. Эта таблица доступна в разделе Общевузовские ресурсы, в форме Учебные планы, программы и формы обучения на вкладке Дисциплины вне учебных планов.

Назначение дисциплин студентам на участке Студент выполняется именно из таблицы данных Дисциплины вне учебных планов. Поэтому при завершении создания дисциплины или при внесении изменений в данные общевузовского РУП необходимо выполнять действие по передаче плана или дисциплин на факультет.

15. Объединенные планы общевузовских дисциплин

Объединенный план общевузовских дисциплин дисциплин представляет собой иерархическую структуру групп дисциплин (раделов) и включенных в них дисциплин (НИС и дисциплин для иностранных студентов).

Создание и редактирование нового объединенного плана общевузовских дисциплин включает следующие этапы работы:

15.1. Создание нового объединенного плана общевузовских дисциплин

Работа с Объединенными учебными планами общевузовских дисциплин ведется на участке "Разработка учебных планов" в форме "Учебные планы общевузовских дисциплин".

Расположение формы Учебные планы общевузовских дисциплин

Для добавления плана необходимо в верхней таблице данных Объединенные планы общевузовских дисциплин с помощью контекстного меню вызвать действие Добавить объединенный план общеуниверситетских дисциплин.

Процедура добавления объединеннго плана общевузовских дисциплин

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров добавления объединенного плана общевузовских дисциплин
  • В поле Тип общевузовского плана выбрать из списка (кнопка Список) соотвествующий тип плана.
  • В поле Уровень образования из выпадающего списка необходимо выбрать тот уровень образования, для студентов которого предназначен создаваемый учебный план.
  • В поле Наименование плана учебному плану нужно присвоить наименование. Наименованием может быть любое строковое значение длиной не более 128 символов.
  • В поле Число лет реализации указать количество лет, в течение которых реализуется объединенный план общевузовских дисциплин.
  • В поле Учебный год начала реализации указать год начала обучения по данному плану.
  • В поле Год окончания реализации нужно выбрать учебный год, в котором студенты завершат обучение по данному плану.
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов указать количество периодов в учебном году.

После того, как все поля формы будут заполнены, кнопка ОК на форме добавления станет доступной. После ее нажатия, запись о новом объединенном плане общевузовских дисциплин появится в таблице данных. При попытке добавления второго плана идентичного уже созданному произойдет ошибка дублирования объектов.

15.2. Редактирование объединенного плана общевузовских дисциплин

Редактирование объединенного плана общевузовских дисциплин состоит в наполнении его дисциплинами, НИС, или дисциплинами иностранных студентов, которые могут быть объединены в группы, уточнении объема нагрузки, установке форм итогового контроля.

Объединенный план может состоять из следующих видов записей: разделы (группы дисциплин), дисциплины, НИС и Дисциплины иностранных студентов. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в план записей других типов (курсовые, практики и проч.) недопустимо.

Редактирование объединенного плана выполняется при помощи специализированной формы редактирования, которая открывается при вызове для выбранного учебного плана действия Открыть или при двойном щелчке мышью по записи об учебном плане.

Редактирование объединенного плана общевузовских дисциплин

Добавление и удаление записей учебного плана, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню.

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

Редактирование записей объединенного плана

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

По окончании работы с объединенным планом его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати или Выгрузить для печати как РУП расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия учебный план будет выгружен для печати в MS Excel.

15.2.1. Добавление раздела (группы дисциплин)

Для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Добавление группы дисциплин в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

15.2.2. Добавление дисциплины

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать действие дисциплину,

Процедура добавление дисциплины в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный план общевузовских дисциплин
Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

    • После того как запись о дисциплине будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с записью дисциплины, предлагаемой кафедрой, разработчик объедиеннного учебного плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

15.2.3. Добавление НИС

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать действие научно-исследовательский семинар,

Процедура добавление НИС в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный план общевузовских дисциплин
Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Семинар, предлагаемый кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего будет добавлен в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Семинар, предлагаемый кафедрой оставить пустым.
    • в поле Семинар (дисциплина ВУЗа) указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.

    • После того как запись о НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания семинара с дисциплиной-предложением кафедры разработчик объединенного учебного плана больше не сможет изменять параметры нагрузки по семинару, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

15.2.4. Добавление дисциплины иностранных студентов

Добавлять Дисциплины для иностранных студентов можно только в объединенные планы общевузовских дисциплин, у которых при создании Тип общевузовского плана был установлен как "Дисциплины для иностранных студентов". (см. Создание нового объединенного плана общевузовских дисциплин).

Для добавления Дисциплины иностранных студентов необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие дисциплину иностранных студентов,

Процедура добавление дисциплины иностранных студентов в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины иностранных студентов в объединенный план общевузовских дисциплин
  1. В поле Кафедра задать кафедру, которая будет вести дисциплину.
  2. в поле Дисциплина для иностранных студентов указать требуемую дисциплину, для этого необходимо открыть справочник Все дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Все дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
  3. Заполнить поля: Имеет пререквизиты, Код записи, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  4. Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соотвествующую область науки из выпадающего списка Список или с помощью справочника Справочник.
  5. Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

Отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля) можно непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице, предназначено действие Дополнительные свойства.

Редактирование записей объединенного плана

При необходимости вновь созданную дисципину для иностранных студентов можно связать с записью дисциплины, предлагаемой к реализации кафедрами, для этого:

  1. Из контекстного меню нужно вызвать действие Связать с предложением кафедры. При помощи параметров этой процедуры можно попытаться поискать подходящую дисциплину. Можно выполнить поиск не точно такой же, а "похожей" дисциплины. Для этого нужно очистить значение в поле Дисциплина для выбора и снова поискать дисциплину в поле Предложение кафедры. Можно также очистить поле Кафедра и поискать дисциплину на всех кафедрах. Если походящая дисциплина найдена, ее нужно выбрать и нажать кнопку ОК.
  2. Если же подходящей дисциплины так и не найдено, нужно заполнить кафедру в поле Кафедра и установить флажок Создать заявку на дисциплину (флажок доступен при условии, что кафедра задана, а поле "Предложение кафедры" пустое), после чего нажать кнопку ОК. В результате будет выполнен поиск плана-предложения кафедры с атрибутами Год начала реализации, Уровень образования, Реализуется по периодам, соответствующими атрибутам учебного плана; если такого плана-предложения найдено не будет, он будет создан для указанной кафедры. В найденный или созданный план-предложение будет добавлена дисциплина со всей информацией о нагрузке, раннее занесенной для нее в учебном плане; дисциплина в плане-предложении кафедры получит статус "заявка на дисциплину".

После связывания дисциплины плана с дисциплиной, предлагаемой кафедрой, разработчик объединенного учебного плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

15.2.5. Перемещение записей

В случае если при добавлении Группы дисциплин или Дисциплины (НИС, Дисциплины иностранных студентов) был неверно указан раздел, куда они должны быть включены, то в отношении такой записи необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить запись, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина (НИС, Дисциплины иностранных студентов) будет перемещена в корень объединенного плана общевузовских дисциплин.

Также для изменения порядка следования записей можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

15.2.6. Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные планы общевузовских дисциплин (форма Учебные планы общевузовских дисциплин) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи плана выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

15.2.7. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

15.2.8. Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных планов общевузовских дисциплин выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.

15.3. Передача планов в реализацию

Для того, чтобы дисциплины объединенного плана общевузовских дисциплин могли быть назначены студентам, необходимо для плана выполнить действие Передать в реализацию.

Процедура передачи плана на факультет

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Дисциплины вне учебных планов. Эта таблица доступна в разделе Общевузовские ресурсы, в форме Учебные планы, формы и программы обучения на вкладке Дисциплины вне учебных планов.

Назначение общевузовских дисциплин студентам на участке Студент выполняется именно из таблицы данных Дисциплины вне учебных планов. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного плана общевузовских дисциплин необходимо выполнять действие по передаче плана в реализацию.

15.4. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные планы общевузовских дисциплин (форма Учебные планы общевузовских дисциплин) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как РУП, Выгрузить для печати на английском языке, Выгрузить для печати как рабочий на английском языке.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.

16. Учебные планы лицея

Учебные планы представляют собой иерархическую структуру компонентов (разделов), школьных предметов и проектов школьников. Учебный план лицея разрабатывается сразу на все годы реализации образовательной программы, и содержит информацию о видах и количестве испытаний по школьным предметам, о распределении учебной нагрузки по периодам и т.д.

Создание нового учебного плана лицея включает следующие этапы работы:

  1. Создание записи об учебном плане лицея.
  2. Наполнение и редактирование учебного плана.
  3. Передача плана в реализацию.

16.1. Создание нового учебного плана лицея

Работа с учебными планами лицея ведется на участке "Разработка учебных планов" в форме "Учебные планы лицея".

Для добавления нового учебного плана лицея необходимо в представлении Учебные планы лицея с помощью контекстного меню вызвать действие Добавить план лицея.

Процедура Добавить план лицея

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров Добавить план лицея

  • В поле Направление в лицее - указать направление обучения школьников.
  • В полях Образовательный программа - выбрать образовательную программу, для которой создается план.
  • В поле Класс начала обучения - указать класс, начиная с которого будет реализовываться план.
  • В поле Число лет обучения - указать количество лет реализации плана.
  • В полях Год начала обучения, Год окончания обучения указать года начала и окончания обучения, периоды, по которым будет планироваться нагрузка.
  • В поле Реализуется по периодам выбрать один из предлагаемых вариантов реализации.
  • В поле Количество периодов в году указать количество периодов в учебном году.
  • При необходимости можно указать Количество учащихся и Количество классов.

После того, как для всех полей формы добавления учебного плана лицея будут заданы допустимые значения, кнопка ОК на форме добавления станет доступной. После ее нажатия запись о новом учебном плане появится в представлении Учебные планы лицея. При попытке добавления второго учебного плана такого же направления, образовательной программы и года начала обучения произойдет ошибка дублирования объектов.

16.2. Редактирование учебного плана лицея

Для редактирования учебного плана лицея предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования учебного плана лицея

Редактирование учебного плана должно заключаться в добавлении разделов, школьных предметов и проектов школьников, распределении нагрузки по видам работы (лекции, семинары, практические и т.д.), по годам обучения (классам) и по периодам обучения в каждом году (модулям, семестрам), а также планировании рубежных контролей.

Для добавления раздела необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие раздел плана.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: школьный предмет, проект школьников.

Форма редактирования группа процедур Добавить

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, формы контролей), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается школьниками или нет и т.д.), предназначено действие Дополнительные свойства.

Редактирование записей учебного плана лицея

16.2.1. Добавление раздела

Для создания раздела необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие раздел плана,

Форма редактирования Добавить раздел в учебный план лицея

после чего заполнить следующую форму параметров:

Форма параметров добавить раздел учебный план лицея

  • В поле Раздел из справочника выбрать раздел для добавления.
  • В поле Наименование необходимо ввести название раздела.
  • В поле Код записи при необходимости можно указать код записи для добавляемого раздела.
  • В полях Общее число часов и Число недель можно указать общее количество часов и число недель по плану для данного раздела. При необходимости данные поля можно оставить пустыми и указать данные параметры непосредственно в форме редактирования.
  • В поле Рассчитывается как сумма элементов необходимо установить значение "Да", если показатели раздела определяться путем суммирования показателей входящих в них записей. Если показатели раздела плана должны устанавливаться независимо, то необходимо установить значение "Нет".
  • Для разделов показатели, которых устанавливаются независимо, при необходимости можно указать Минимальное и Максимальное число дисциплин для выбора, и Минимальное и Максимальное число кредитов для выбирамых дисциплин.

После нажатия кнопки ОК, раздел будет добавлен.

16.2.2. Добавление школьного предмета

При добавлении школьного предмета в форме редактирования учебного плана лицея необходимо из контекстного меню в группе процедур Добавить вызвать действие школьный предмет, после чего заполнить следующую форму параметров:

Форма параметров Добавить школьный предмет в учебный план лицея
  • В поле Школьный предмет с помощью списка Список или справочника Справочник нужно выбрать школьный предмет для добавления.
  • В поле Кафедра при необходимости можно указать кафедру, которая будет реализовать школьный предмет.
  • В поле Вид дисциплины необходимо выбрать вид добавляемой дисциплины.
  • В поле По выбору студентов нужно установить значение "Да" для школьных предметов, назначаемых школьникам в обязательном порядке, и значение "Нет" для школьных предметов, которые назначаются при выборе школьником.
  • В полях Аудиторных часов и Число недель необходимо указать соответствующие числовые характеристики добавляемого школьного предмета.

После заполнения формы параметров необходимо нажать кнопку ОК, после чего школьный предмет будет добавлен в учебный план.

После того как запись о школьном предмете будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, недель, формы контролей), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается школьниками или нет и т.д.), предназначено действие Дополнительные свойства.

16.2.3. Добавление проекта школьников

При добавлении проекта школьников в форме редактирования учебного плана лицея необходимо из контекстного меню в группе процедур Добавить вызвать действие проект школьников, после чего заполнить следующую форму параметров:

Форма параметров Добавить проект школьников в учебный план лицея
  • В поле Наименование необходимо ввести наименование проекта школьников.
  • В поле Кафедра при необходимости можно указать кафедру, которая будет реализовать проект школьников.
  • В полях Число недель, Аудиторных часов нужно указать соответствующие числовые характеристики добавляемого школьного проекта.
  • Значение для Аудиторных часов в неделю определяется автоматически.
  • Если нагрузка по проекту должна учитываться при расчете недельной нагрузки, то в поле Входит в расчет недельной нагрузки должно быть установлено значение "Да".
  • В поле По выбору студентов должно быть установлено значение "Да" для проектов школьников, назначаемых школьникам в обязательном порядке, и значение "Нет" для проектов школьников, которые назначаются при выборе школьником.

После заполнения формы параметров необходимо нажать кнопку ОК, после чего школьный предмет будет добавлен в учебный план.

16.3. Передача плана в реализацию

Для того чтобы записи учебного плана могли быть назначены школьникам, необходимо для плана выполнить действие Передать план в реализацию.

Вызов действия передать план в реализацию

После чего в форме параметров нужно указать учебный год (поле На учебный год), за который будет передаваться план в реализацию, указать Номер класса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в представлении Учебные планы лицея. Данное представление доступно на участке Лицей университета, в форме Учебные планы лицея.

17. Особенности наполнения отдельных разделов БУП и РУП

Разделы БУП и РУП, наполненные дисциплинами, обязательными для изучения всеми студентами, не представляют большой сложности при заполнении. В них могут добавляться дисциплины, не присутствующие в стандарте или в БУП, при этом суммарные значения числа часов, числа недель, числа кредитов могут быть пересчитаны автоматически. Разделы, в состав которых входят дисциплины, необязательные для изучения всеми студентами, а также разделы, содержащие прочие виды нагрузки (курсовые работы, практики, итоговые экзамены, выпускные работы) требуют отдельного внимания.

Для того, чтобы отразить особенности различных разделов, дисциплин и других видов нагрузки, входящих в БУП или РУП, после автоматизированного формирования структуры плана для его записей необходимо уточнить ряд дополнительных свойств, таких как

  • Вид дисциплины, обязательность для изучения студентами
  • Учет в текущем, или только в кумулятивном рейтинге
  • Вхождение в расчет недельной аудиторной нагрузки студентов
  • Преподавание дисциплины на иностранном языке
  • Допустимость нескольких испытаний в одном периоде

Работа записями плана, не являющимися дисциплинами (курсовыми работами, практиками, итоговыми государственными экзаменами, выпускными квалификационными работами связана с рядом особенностей, которые изложены в следюущих ниже разделах.

17.1. Уточнение ряда свойств разделов и дисциплин БУП и РУП

В формах редактирования БУП и РУП работают проверки контрольных соотношений, при помощи которых контролируется корректность и целостность плана, соответствие характеристик записей плана требованиям образовательного стандарта, выполнение Методических указаний по разработке БУП и РУП. Также при помощи функционала формы редактирования можно выполнять автоматизированные пересчеты показателей плана, в частности, суммирование значений числа часов, недель, кредитов по разделам и группам дисциплин.

В образовательном стандарте не содержится достаточно информации для того, чтобы реализовать корректную работу некоторых автоматизированных проверок и пересчетов. По этой причине после формирования БУП на основе стандарта или РУП на основе БУП, необходимо выполнить уточнение следующих значений для некоторых разделов и дисциплин БУП или РУП:

  1. Признак Рассчитывается как сумма элементов для групп дисциплин и разделов.
  2. Свойство Количество выбираемых дисциплин для разделов и групп дисциплин по выбору.
  3. Признак Только в кумулятивный рейтинг для дисциплин, число кредитов по которым не должно участвовать в подсчете суммы по разделу и по плану в целом.
  4. Свойство Вид дисциплины и признак Выбирается студентами.
  5. Признак Входит в расчет недельной нагрузки.
  6. Свойство На иностранном языке.
  7. Свойство Допустимо несколько испытаний в периоде.
Уточнение данных свойств производится в форме редактирования БУП или РУП при помощи действия Дополнительные свойства.

Дополнительные свойства раздела плана:

Дополнительные свойства для раздела

Дополнительные свойства дисциплины плана:

Дополнительные свойства для дисциплины

1. Уточнение признака Рассчитывается как сумма элементов для групп дисциплин и разделов.

Все разделы и группы дисциплин можно разделить на два вида:

  • Разделы или группы, показатели которых должны определяться путем суммирования показателей входящих в них записей.
  • Разделы или группы, показатели которых могут устанавливаться независимо.
К первой группе относятся разделы и группы, все дисциплины которых обязательны для изучения всеми студентами. Ко второй группе относятся разделы и группы дисциплин по выбору, факультативов адаптационных дисциплин. Для того, чтобы отличить один вид разделов от другого используется признак Рассчитывается как сумма элементов. При формировании БУП на основе стандарта для всех разделов и групп дисциплин этот признак получает значение Да. При формировании РУП на основе БУП для разделов РУП устанавливается то же значение признака, которое было задано для данного раздела в БУП.

Если для признака установить значение Нет, то проверка соответствия суммы показателей для всех записей раздела со значением, установленным для раздела в целом, проводиться не будет и сообщения об ошибках не будут формироваться. В этом случая значения числа часов, недель, кредитов, числа экзаменов и зачетов (в РУП) для раздела нужно установить вручную таким образом, чтобы раздел, в свою очередь, внес необходимый вклад в план в целом. Например, если в раздел включено три дисциплины по выбору, трудоемкостью 108 часов каждая, а студенты должны выбрать только одну из них, для раздела вручную должно быть установлено число часов, равное 108.

Наименования разделов, для которых не используется контроль равенства суммы показателей раздела и суммы показателей входящих в него записей выделяется курсивным шрифтом. При проверке плана на такие разделы нужно обращать отдельное внимание.

Разделы, рассчитываемые и не рассчитываемые как сумма

2. Уточнение значения Количество выбираемых дисциплин

Для того, чтобы в дальнейшем на основании разработанных БУП и РУП можно было сформировать учебный план студента и проверить его полноту и корректность, необходимо задать для каждой группы или раздела дисциплин по выбору количество дисциплин, которые должны быть обязательно выбраны студентом.

Если при наполнении образовательного стандарта эти значения не заданы, то их необходимо задать в форме редактирования БУП или РУП при помощи действия Дополнительные свойства.

3. Уточнение признака Только в кумулятивный рейтинг

Ряд дисциплин, принадлежащих к разделу факультативов или к группам адаптационных дисциплин, могут не участвовать в подсчете суммы кредитов по группе, по разделу и по плану в целом. Кредиты по таким дисциплинам начисляются студентам только при расчете кумулятивного рейтинга, но не начисляются при расчете текущего рейтинга. Для того, чтобы было возможным рассчитать кумулятивный рейтинг студентов по таким дисциплинам, значения числа кредитов должны быть заданы, однако для того, чтобы корректно провести проверку суммарного числа кредитов БУП и РУП такие дисциплины необходимо выделить из перечня обычных дисциплин.

Уточнение данного признака производится в форме редактирования БУП и РУП при помощи действия Дополнительные свойства.

При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются одной звездочкой (*) в колонке "Зачетные единицы". В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.

4. Уточнение признаков Вид дисциплины и Выбирается студентами

Если при формировании стандарта или БУП для дисциплины были неверно заданы значения свойств Вид дисциплины и Выбирается студентами, то эти значения можно уточнить в формах редактирования БУП и РУП при помощи действия Дополнительные свойства. Эти свойства являются зависимыми, т.е. если для свойства Вид дисциплины установить значение Обязательная дисциплина или Обязательный факультатив, то для признака Выбирается студентами будет автоматически подставлено значение Нет. Если же для вида дисциплины выбрать значение Дисциплина по выбору или Факультатив, то признак автоматически получит значение Да. При исключении из этого правила, значение признака Выбирается студентами можно изменить вручную.

Корректная установка этих свойств важна для дальнейшего назначения учебных планов студентам и контроля полноты сформированных учебных планов студентов.

5. Уточнение признака Входит в расчет недельной нагрузки.

Данный признак используется для того, чтобы исключить некоторые дисциплины РУП из расчета недельной аудиторной нагрузки студентов. При формировании РУП на основе БУП для данного признака устанавливается значение Да. При редактировании РУП для факультативов, а также других дисциплин, аудиторная нагрузка по которым не должна входить в расчет недельной аудиторной нагрузки студентов, необходимо изменить значение этого признака на Нет.

Изменить значение данного признака можно в форме редактирования РУП при помощи действия Дополнительные свойства.

При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются двумя звездочками (**) в колонке "Наименование дисциплины". По этой причине вносить знаки * в наименование дисциплины не нужно. В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.

6. Выделение предметов, преподаваемых на иностранном языке.

Для того чтобы выделить дисциплины плана, преподаваемые на иностранном языке, при помощи действия Дополнительные свойства для них можно установить свойство На иностранном языке. При формировании БУП и РУП данное для данного свойства устанавливается пустое значение, что означает, что дисциплина преподается на русском языке. Для дисциплин, преподаваемых на иностранных языках, можно выбрать один из иностранных языков, преподаваемых в ВУЗе. Если в выпадающем списке нет нужного языка, необходимо обратиться к администратору системы с просьбой добавить язык в доступный перечень.

7. Наличие нескольких испытаний в одном периоде для дисциплины плана.

Как правило по всем дисциплинам плана в каждом из учебных периодов (модуле, семестре), предусматривается одно (или ни одного) испытание рубежного контроля. Если возникает исключительная ситуация, при которой необходимо запланировать более одного испытания в одном учебном периоде (например, экзамен и итоговый полевой сбор по военной подготовке), это можно сделать следующим образом:

  1. Выбрать дисциплину, вызвать действие Дополнительные свойства.
  2. Установить флажок к поле Допустимо несколько испытаний в периоде. В правой части строки в колонках, предназначенных для указания видов испытаний ("Экзамен", "Зачет") будут отображены два уровня по аналогии с записями разделов.
    Несколько испытаний в одном периоде
  3. Установить количество (в штуках) экзаменов и / или зачетов в строке дисциплины на соответствующем уровне (рядом со словом "Экз." или "Зач.").
  4. Проконтролировать правильность вычисления количества экзаменов и зачетов для раздела плана, в который входит данная дисциплина.

Если необходимость наличия нескольких испытаний в периоде отпала, или была установлена ошибочно, от нее можно отказаться, вызвав для дисциплины действие Дополнительные свойства и сняв флажок Допустимо несколько испытаний в периоде. Строка дисциплины снова будет отображаться обычным образом. В столбцах, отвечающих за виды испытаний по периодам, нужно выбрать значения "Экзамен" или "Зачет".

17.2. Организация разделов и групп дисциплин по выбору

Присутствующие в БУП или РУП дисциплины по выбору могут либо представлять собой единую группу, входящую в раздел "Дисциплины по выбору" одного из компонентов, либо формироваться в несколько групп, из каждой из которых студентами должно быть выбрано определенное количество дисциплин.

Если группы дисциплин были заданы в стандарте, то они будут созданы в БУП при его формировании по стандарту. При формировании РУП на основе БУП созданные в БУП группы будут перенесены в РУП. Группы дисциплин можно создавать и при редактировании БУП или РУП. После создания групп в них можно добавлять отдельные дисциплины. Также можно переносить существующие дисциплины в группы при помощи действия Перенести в другой раздел.

В отличие от обычных разделов и групп, для которых значения числа часов, недель и кредитов вычисляется как сумма значений, заданных для входящих в них дисциплин, для разделов и групп дисциплин по выбору эти значения должны задаваться самостоятельно. Для того, чтобы проверки и автоматические расчеты, работающие в формах редактирования БУП и РУП, работали корректно, а также с целью последующего контроля формирования индивидуальных учебных планов студентов, для разделов и групп дисциплин по выбору должны быть дополнительно уточнены значения ряда свойств. Уточнение выполняется при помощи действия Дополнительные свойства.

Дополнительные свойства для дисциплин по выбору
  • Для признака Рассчитывается как сумма элементов должно быть установлено значение Нет.
  • Если для раздела или группы определяется количество дисциплин, которые должны быть выбраны студентом, то это значение нужно занести в колонку Количество выбираемых дисциплин. Если количество дисциплин не задается, а накладывается ограничение только на число кредитов, то это значение нужно оставить пустым. Вы этом случае контролироваться будет не количество выбранных студентом дисциплин, а значение суммы кредитов по всем выбранным им дисциплинам.
  • Должны быть уточнены значения Трудоемкость в часах, Недели и Трудоемкость в зачетных единицах, объем аудиторной нагрузки по периодам, число форм текущего контроля (РУП). После того как для признака Рассчитывается как сумма элементов установлено значение Нет, значения числа часов, недель и кредитов, заданные для группы, не будут сравниваться с суммой значений для входящих в группу дисциплин и не будут автоматически пересчитываться.
Раздел дисциплин по выбору

Если все дисциплины раздела распределены по группам, для каждой из которых задано определенное значение числа часов, недель и кредитов, которые должны быть набраны студентом, то для раздела в целом значение признака Рассчитывается как сумма элементов должно быть установлено в Да, так как, действительно, для раздела должны быть просуммированы значения, заданные для каждой из групп.

Раздел дисциплин по выбору с группами

В данном примере для групп ДПВ1 (1 из 2) и ДПВ2 (1 из 6) значение признака Рассчитывается как сумма элементов установлено как Нет, а для записи раздела ОПД.В.00 Дисциплины по выбору установлено значение Да.

17.3. Работа с факультативами

Факультативы, также как и дисциплины по выбору должны быть выделены в БУП и в РУП в отдельный раздел или группу дисциплин. Для разделов или групп факультативов при помощи действия Дополнительные свойства признак Рассчитывается как сумма элементов должен быть установлен как Нет.

Дополнительные свойства для раздела факультативов

Для всех дисциплин, являющихся факультативами дополнительные свойства должны быть установлены следующим образом:

Дополнительные свойства для дисциплин факультативов

После того, как для факультативов установлен признак Только в кумулятивный рейтинг, число кредитов будет помечено знаком *. После установки значения Нет для признака Входит в расчет недельной нагрузки число аудиторных часов по факультативу в учебном периоде (модуле, семестре) не будет участвовать в расчете аудиторной нагрузки в периоде по разделу.

Если число часов, недель, кредитов, выделяемых на факультативы, не должно учитываться при расчете суммовых показателей плана, то для них в строке раздела или группы Факультативы можно задать нулевые или пустые значения.

17.4. Работа с адаптационными дисциплинами

Если в БУП или РУП включаются адаптационные дисциплины (т.е. дисциплины, изучаемые студентами, не имеющими на момент поступления достаточной подготовки по тем или иным предметам), то при работе с ними необходимо учитывать их особенности.

Адаптационной дисциплиной может быть как дополнительная дисциплина, не изучаемая основной массой студентов, так и дополнительная нагрузка по одной из существующих в БУП или РУП дисциплин (например, дополнительные часы по иностранному языку, экономической теории или математике). В любом случае адаптационная дисциплина должна добавляться в БУП и РУП как отдельная запись. При добавлении такой дисциплины в поле Вид дисциплины должно быть выбрано значение Адаптационный курс, в поле По выбору студентов должно быть установлено значение Да. Скорректировать значения данных свойств для адаптационных дисциплин можно в формах редактирования РУП и БУП при помощи действия Дополнительные свойства.

Дополнительные свойства для адаптационных дисциплин

Так как адаптационные дисциплины не являются обязательными для всех студентов, на них либо не выделяются кредиты, либо эти кредиты не участвуют в расчете текущего рейтинга. Поэтому для адаптационных дисциплин необходимо либо установить число кредитов, равное нулю, либо установить значение Да в колонке Только в кумулятивный рейтинг.

Нагрузка по адаптационным дисциплинам не должна учитываться при подсчете суммы часов, недель и кредитов и других показателей по разделу, в который они входят. Для того, чтобы расчет сумм по разделу был произведен корректно, рекомендуется выделить адаптационные дисциплины в отдельную группу дисциплин. Для этой группы для признака Рассчитывается как сумма элементов должно быть установлено значение Нет, а для свойств Трудоемкость в часах, Недели и Трудоемкость в зачетных единицах и других должны быть установлены пустые или нулевые значения. Такая установка свойств позволит корректно рассчитать суммы по разделу, в который входит группа адаптационных дисциплин.

Раздел адаптационных дисциплин

17.5. Курсовые работы

Курсовые работы могут присутствовать в различных разделах БУП и РУП. Если курсовые работы были занесены в стандарт, то они будут созданы и в БУП после его формирования на основе стандарта. При формировании РУП на основе БУП в нем будут созданы курсовые работы в случае если в БУП по курсовой работе были заданы часы или кредиты на данном курсе. Также курсовые работы можно создавать и непосредственно в БУП и РУП, используя действие Добавить ... / курсовую работу.

Если курсовая работа выполняется по одной дисциплине всеми студентами, то эту дисциплину необходимо выбрать в поле Дисциплина при добавлении курсовой работы. Если же курсовая работа является междисциплинарной, или если студенты могут выбирать дисциплину, по которой они будут выполнять работу, то поле Дисциплина надо оставить пустым. Заполнение поля Кафедра в РУП для курсовой работы необязательно. Оно должно заполняться только в том случае, если известно, что все студенты должны выполнить данную курсовую работу на данной кафедре.

Если создается курсовая работа по дисциплине, то ее Наименование будет сформировано автоматически. Если дисциплина не используется, то наименование курсовой работе может быть присвоено произвольно.

Значение числа кредитов для курсовых работ устанавливается независимо от значений числа часов и числа недель.

Раздел с курсовой работой

Если в БУП или РУП присутствует курсовая работа, то о ней должна быть обязательно создана запись типа Курсовая работа, даже если в плане существует одноименный раздел. Уточнить свойства записи о курсовой работе можно при помощи действия Дополнительные свойства

Дополнительные свойства для курсовой работы

Изменять тип записи при помощи этого действия нельзя. Если Вы ошиблись с типом записи, то нужно удалить существующую запись о курсовой работе и создать новую при помощи действия Добавить ... / курсовую работу.

В РУП для курсовой работы, так же как и для любой другой записи плана должно быть указано испытание рубежного контроля. Для того, чтобы в дипломе студентов по курсовой работе отображались оценки "отлично", "хорошо" и проч. видом рубежного контроля для курсовой работы должен быть "Экзамен". В противном случае в дипломе студента будут отображены результаты "зачтено" или "незачтено". Испытание должно быть запланировано в том модуле (семестре), в котором студенты должны сдать и защитить курсовую работу.

При расчете числа зачетов и экзаменов по модулям, отображаемого в печатной форме РУП, испытания по курсовым работам не учитываются.

17.6. Работа с практиками

Как в образовательном стандарте, так и в БУП и в РУП практики должны быть выделены в отдельный раздел (разделы). Если в стандарте значения трудоемкости задавались для раздела практик в целом, то в БУП и РУП обязательно нужно добавить записи о конкретных практиках того или иного вида. Добавление практики в БУП или РУП производится при помощи действия Добавить ... / практику.

При добавлении практики нужно обязательно задать Вид практики путем выбора из выпадающего списка. При выборе вида практики для нее будет автоматически предложено Наименование. Если в план необходимо добавить несколько практик одного вида, то наименование надо скорректировать таким образом, чтобы эти практики можно было отличить, например, "производственная практика 2 курс", "производственная практика 3 курс".

При помощи действия Дополнительные свойства можно уточнить параметры созданной записи о практике

Дополнительные свойства практик

При помощи данной формы можно уточнить вид практики. Тип записи обязательно должен быть установлен как Практика. Если тип записи установлен неверно, его нельзя изменить при помощи этой формы. В этом случае нужно удалить запись ошибочного типа и добавить новую при помощи действия Добавить ... / практику.

В БУП и РУП магистратуры наименования разделов могут включать в себя (и даже полностью повторять) наименование видов практики, например, "НИР.М.02 Научно-педагогическая практика" или "НИР.М.03 Научно-исследовательская практика". Несмотря на это, в такие разделы необходимо добавить записи о практиках соответствующего вида.

Значения числа недель и числа кредитов для практик устанавливаются независимо от числа часов.

17.7. Работа с разделом итоговой государственной аттестации

Итоговая государственная аттестация в образовательных стандартах выделяется в отдельный раздел. В состав итоговой аттестации могут входить итоговые экзамены и выпускная квалификационная работа (ВКР). Если записи о конкретных итоговых экзаменах и ВКР были созданы в стандарте, то они будут созданы и в БУП при его формировании по стандарту. Также записи об отдельных видах итоговой аттестации, созданные в БУП будут перенесены в РУП при его формировании на основе БУП. Если же в стандарте или БУП записи о конкретных испытаниях итоговой аттестации созданы не были, то их необходимо добавить в раздел итоговой аттестации при помощи действий Добавить ... / итоговый гоэкзамен и Добавить ... / выпускную работу.

Итоговый госэкзамен может быть как по одной конкретной дисциплине, так и междисциплинарным. Если итоговый госэкзамен проводится по дисциплине, то эту дисциплину необходимо выбрать в поле Дисциплина. При этом в поле Наименование автоматически сформируется значение, повторяющее наименование дисциплины. Если же экзамен является междисциплинарным, то поле Дисциплина нужно оставить пустым, в наименование ввести с клавиатуры (например, "Междисциплинарный экзамен по направлению подготовки").

Для свойства Форма итогового контроля должно быть установлено значение Экзамен.

Значение числа кредитов для итогового госэкзамена устанавливаются независимо от значений числа часов и числа недель.

При добавлении выпускной квалификационной работы (ВКР) ее наименование можно задать произвольно (например, "Подготовка и защита выпускной квалификационной работы"). Для свойства Форма итогового контроля должно быть установлено значение Экзамен.

Значение числа недель и числа кредитов для ВКР устанавливаются независимо от значений числа часов и числа недель.

Раздел итоговой аттестации

18. Расчетные показатели учебных планов

В ходе работы над базовыми и рабочими учебными планами необходимо помнить о том, что в итоговом варианте документа должны быть соблюдены требования к ряду расчетных показателей, характеризующих план в целом. Ниже описаны принципы расчета применяемых показателей и пути достижения необходимых значений.

18.1. Суммы показателей по разделам и по плану в целом

Образовательный стандарт представляет собой иерархическую структуру разделов (компонентов, циклов) и входящих в них дисциплин. Стандарт должен быть сформирован таким образом, чтобы на первом уровне иерархии была единственная запись. Как правило, эта запись имеет наименование Вся образовательная программа. Аналогичную структуру имеют БУПы и РУПы, сформированные на основе стандартов.

Формы редактирования БУП и РУП содержат проверки, контролирующие равенство сумм показателей (числа часов, недель, кредитов и проч.) записей, входящих в раздел, и значений тех же показателей, заданных для раздела. В суммировании участвуют только записи, непосредственно подчиненные данному разделу. Это означает, что если в раздел входит несколько других разделов, в состав которых, в свою очередь, входят дисциплины и записи других видов, то в суммировании будут участвовать только значения заданные для разделов в целом, а значения записей более низких уровней анализироваться не будут.

Для некоторых разделов (разделов дисциплин по выбору, факультативов, а иногда и других) итоговые значения не должны рассчитываться как сумма входящих в раздел дисциплин, т.к. не все указанные дисциплины должны в обязательном порядке изучаться студентами. Для того, чтобы отличить один вид разделов от другого, предназначено свойство раздела Рассчитывается как сумма элементов. Для просмотра и изменения значения этого свойства предназначено действие Дополнительные свойства, которым можно воспользоваться в формах редактирования БУП и РУП, предварительно выбрав строку нужного раздела.

Если для раздела установлено значение признака таким образом, что показатели входящих в него записей не суммируются, то проверок соответствия сумм проводиться не будет. При этом важно задать для раздела в целом такие значения, которые дадут необходимую сумму для вышестоящих разделов и для плана в целом. Например, для разделов или групп дисциплин по выбору надо задать такие значения нагрузки, которые обязательно должны быть выполнены студентами. Для разделов факультативов и адаптационных дисциплин допустимо устанавливать итоговые значения по разделу нулевыми или пустыми.

Суммирование показателей по разделам

В данном примере для раздела Дисциплины по выбору признак Рассчитывается как сумма элементов установлен как Нет (наименование раздела отображается курсивным шрифтом). Для всех остальных разделов установлено значение Да. При этом для раздела дисциплин по выбору установлены самостоятельные значения числа часов, недель и кредитов. Для раздела Общие гуманитарные и социально-экономические дисциплины значения рассчитываются как сумма по трем разделам, непосредственно входящим в него: 2160 = 1836 + 108 + 216.

Такой принцип суммирования и контроля значений для разделов действует как для базовых, так и для рабочих учебных планов.

18.2. Аудиторная нагрузка по периодам (РУП)

В рабочих учебных планах рассчитываются показатели аудиторной нагрузки по периодам. При этом в разделе возможно наличие дисциплин, аудиторная нагрузка по которым не входит в расчет недельной аудиторной нагрузки. Такими дисциплинами могут быть факультативы, физическая культура и некоторые другие дисциплины. Для таких дисциплин при помощи действия Дополнительные свойства необходимо установить признак Входит в расчет недельной нагрузки, равным Нет.

При суммировании значений аудиторной нагрузки в периоде по разделу в суммировании участвуют только те записи, нагрузка по которым входит в расчет недельной нагрузки. При этом допустимой считается ситуация, когда в строке раздела сумма аудиторных часов по всем периодам не будет равна значению, установленному в колонке "Аудиторные занятия".

Аудиторная нагрузка по периодам

В данном примере аудиторная нагрузка по дисциплине Физическая культура не входит в расчет недельной аудиторной нагрузки.

18.3. Число экзаменов и зачетов по периодам (РУП)

В рабочих учебных планах для записей разделов определяется число экзаменов и зачетов в каждом периоде обучения. Если показатели раздела рассчитываются как сумма по входящим в раздел элементам, то число экзаменов и зачетов по разделу будет контролироваться проверками системы. Если же показатели раздела не подлежат суммированию, то количество экзаменов и зачетов по разделу нужно установить вручную.

Испытания по курсовым работам не учитываются при подсчете числа зачетов и экзаменов в периоде.

Проверить и при необходимости изменить признак Рассчитывается как сумма элементов для раздела можно при помощи действия Дополнительные свойства.

Количество экзаменов и зачетов, получившееся в корневой строке "Вся образовательная программа будет считаться показателем плана в целом.

Аудиторная нагрузка по периодам

В данном примере видно, что в разделе "Другие виды подготовки" первом и третьем модулях нет ни экзаменов, ни зачетов, во втором модуле - 2 зачета, в четвертом модуле 1 экзамен и 2 зачета.

18.4. Недельная аудиторная нагрузка, число аудиторных часов в день (РУП)

Недельная аудиторная нагрузка в каждом учебном периоде (модуле, семестре) в рабочем учебном плане определяется как число аудиторных часов в периоде, рассчитанное для корневой записи плана, деленное на число недель в периоде.

Количество недель в периоде отображается в отдельной строке внизу плана после перечня всех его записей. При формировании РУП число недель в каждом периоде устанавливается равным значению, заданному для периода в общевузовском справочнике . Однако в каждом РУП при необходимости это значение можно изменить.

Ниже строки с количеством недель в периоде следует строка Недельная аудиторная нагрузка. Значение в этой строке является расчетным и не подлежит редактированию. Оно рассчитывается как число аудиторных часов в периоде, стоящее в корневой строке плана ("Вся образовательная программа"), деленное на число недель, стоящее в предыдущей строке.

Если полученное значение недельной аудиторной нагрузки не отвечает установленным требованиям, то его можно скорректировать изменив число аудиторных часов по отдельным дисциплинам плана или изменив его распределение по периодам обучения. Эти изменения приведут в свою очередь к изменениям значений для разделов плана и для корневого раздела "Вся образовательная программа".

Недельная аудиторная нагрузка

Показатель Число аудиторных часов в день определяется как рассчитанное значение недельной аудиторной нагрузки, деленное на 6 дней. Левее колонок, показывающих средние значения показателей по периодам расположена колонка, отображающая средние значения, рассчитанные для всех периодов.

19. Ход согласования учебных планов

Базовые, рабочие и объединенные учебные планы могут участвовать в процедурах согласования и утверждения. Переход плана с одного этапа согласования на другой заключается в смене статуса плана, а также в изменении режима доступа пользователей к данным плана.

Процессы согласования объединенных и базовых (рабочих) учебных планов отличаются, графически их можно представить следующим образом:

  1. Процесс согласования базовых и рабочих учебных планов:

    Ход согласования учебных планов

  2. Процесс согласования объединенных учебных планов:

    Согласование объединенного учебного плана

  3. Процесс согласования объединенных учебных планов аспирантуры:

    Схема согласования ОУП аспирантуры

19.1. Мониторинг готовности учебных планов факультетов и отделений

В форме Ход согласования учебных планов в таблицах данных Базовые учебные планы и Рабочие учебные планы представлены планы, доступные для просмотра пользователю. Пользователи-разработчики планов от отдельного факультета или отделения могут просматривать только планы своего факультета (отделения). Пользователи, принадлежащие к ролям методического управления, проректора и первого проректора могут просматривать планы всех факультетов и отделений.

За счет возможностей таблиц данных можно просматривать статусы планов по факультетам и отделениям, направлениям и специальностям, магистерским программам, учебным годам, курсам и т.д.

Мониторинг состояния БУП

19.2. Работа Ректора

Работа ректора, утверждающего учебные планы, состоит в следующем:

Согласование планов
Для согласования доступны планы, переведенные первым проректором в статус на утверждении ректором. С планами, находящимися в этом статусе, первый проректор может выполнять следующие действия:

  • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
  • Если по итогам работы с планом ректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в МУ.
  • Если у ректора нет критических замечаний к плану, он должен выполнить действие Утвердить.
  • Отслеживание статусов планов
    Первому проректору доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

19.3. Работа пользователя-разработчика плана

Работа пользователя, разрабатывающего учебный план, состоит из следующих этапов:

  1. Создание проекта плана
    При создании базового, рабочего учебного плана или объединенного учебного плана, план получает статус проект. В процессе создания базового учебного плана для факультетов филиалов, требуется указать "ведущий" факультет ВУЗа, с которым необходимо согласовать план, что описано в разделе Создание нового базового учебного плана. После создания, план наполняется на основании источника (стандарта или базового плана) и дополняется всей необходимой информацией, что описано в разделах Редактирование базового учебного плана, Редактирование рабочего учебного плана, Редактирование объединенного учебного плана. После того, как разработчик завершил первичное формирование плана, он должен выполнить действие Направить на согласование с деканом факультета.
  2. Согласование с деканом факультета
    На данном этапе разработчик плана не может корректировать план, но может просматривать замечания, сформулированные деканом факультета. Если декан факультета примет решение о возврате плана на доработку, то план перейдет в статус корректировка разработчиком и разработчик снова сможет корректировать план. Если же декан факультета примет решение о согласовании плана и направлении его на дальнейшее согласование, то от разработчика дальнейших действий не потребуется, они сможет только следить за дальнейшим изменением статусов плана.
  3. Корректировка разработчиком
    На этом этапе разработчик может вносить в план любые изменения на основе замечаний, полученных от декана факултета. По завершении работы разработчик снова должен выполнить действие Направить на согласование с деканом факультета.
  4. Отслеживание статуса плана
    После того, как план согласован с деканом факультета, активная работа разработчика заканчивается. План будет переводиться из одного статуса в другой другими пользователями. Разработчик сможет получать сообщения об изменении статуса планов, а также просматривать состояние статусов всех планов в таблице данных Базовые учебные планы или Рабочие учебные планы.

19.4. Работа разработчика ОУП аспирантуры

Работа пользователя, разрабатывающего ОУП аспирантуры, состоит из следующих этапов:

  1. Создание проекта плана
    При создании объединенного учебного плана, план получает статус проект. После создания, план наполняется на основании источника (стандарта) и дополняется всей необходимой информацией, что описано в разделе Редактирование объединенного учебного плана аспирантуры. После того, как разработчик завершил первичное формирование плана, он должен выполнить действие Направить на согласование с Директором аспирантской школы.
  2. Согласование с Директором аспирантской школы
    На данном этапе разработчик плана не может корректировать план, но может просматривать замечания, сформулированные директором аспирантской школы. Если директор аспирантской школы примет решение о возврате плана на доработку, то план перейдет в статус корректировка разработчиком и разработчик снова сможет корректировать план. Если же директор аспирантской школы примет решение о согласовании плана и направлении его на дальнейшее согласование, то от разработчика дальнейших действий не потребуется, они сможет только следить за дальнейшим изменением статусов плана.
  3. Корректировка разработчиком
    На этом этапе разработчик может вносить в план любые изменения на основе замечаний, полученных от директора аспирантской школы. По завершении работы разработчик снова должен выполнить действие Направить на согласованиес Директором аспирантской школы.
  4. Отслеживание статуса плана
    После того, как план согласован с директором аспирантской школы, план будет переводиться из одного статуса в другой другими пользователями, при этом на любом из этапов план может быть передан разработчику на корректировку. Разработчик сможет получать сообщения об изменении статуса планов, а также просматривать состояние статусов всех планов в представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры).

19.5. Работа разработчика учебного плана лицея

Работа пользователя, разрабатывающего учебные планы лицея, состоит из следующих этапов:

  1. Создание проекта плана
    При создании плана, план получает статус проект. После того, как разработчик завершил первичное формирование плана, он должен выполнить действие Направить на согласование с УРОП.
  2. Согласование с пользователями методического управления
    На данном этапе разработчик плана не может корректировать план, но может просматривать замечания, сформулированные пользователями методического управления. Если методическое управление примет решение о возврате плана на доработку, то план перейдет в статус корректировка разработчиком и разработчик снова сможет корректировать план. Если же методическое управление примет решение о согласовании плана и направлении его на дальнейшее согласование, то от разработчика дальнейших действий не потребуется, он сможет только следить за дальнейшим изменением статусов плана.
  3. Корректировка разработчиком
    На этом этапе разработчик может вносить в план любые изменения на основе замечаний, полученных от пользователей, согласующих план. По завершении работы разработчик снова должен выполнить действие Направить на согласованиес УРОП.
  4. Отслеживание статуса плана
    После того, как план согласован с УРОП, план будет переводиться из одного статуса в другой другими пользователями. Разработчик сможет получать сообщения об изменении статуса планов, а также просматривать состояние статусов всех планов в представлении Учебные планы лицея (форма Учебные планы лицея).

19.6. Работа декана факультета

Работа декана факультета, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные разработчиками в статус согласование с деканом факультета. С планами, находящимися в этом статусе декан факультета может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом деканом факультета принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени декана факультета. При этом, при появлении необходимости редактирования плана после этого, декан факультета может воспользоваться действием Отозвать согласование деканом факультета, после чего он сможет осуществлять редактирование плана.
    • После того, как декан факультета согласовал план, он должен выполнить действие Направить на утверждение. При этом, если декан факультета является деканом факультета филиала и требуется согласование с "ведущим" факульетом, он пользуется действием Направить на согласование с ведущим факультетом . Если же, он является деканом "ведущего" факультета ВУЗа, то он должен воспользоваться действием Направить на согласование с МУ (Методическим управлением). В отношении учебных планов, для которых установлен признак Является программой ДПО, необходимо воспользоваться действием Направить на согласование с МУ.
      Следует учитывать, что параметру Является программой ДПО будет присвоено значение Да только для БУП, разработанных пользователями-разработчиками подразделений ДПО. Для всех остальных подразделений будет установлено значение Нет.
  2. Отслеживание статусов планов
    Декану факультета доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

19.7. Работа декана "ведущего" факультета

Работа декана ведущего факультета, согласующего учебные планы, состоит в следующем:

Согласование планов
Для согласования доступны планы, переведенные деканами факультетов филиалов в статус согласование с ведущим факультетом. Также доступны планы собственного факультета, переведенными разработчиками в статус согласование с деканом факультета. С планами, находящимися в этих статусах декан ведущего факультета может выполнять следующие действия:

  • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
  • Если по итогам работы с планом деканом ведущего факультета принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику или вернуть на доработку (деканам факультетов филиала).
  • Если у декана ведущего факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от ведущего факультета. При этом, при появлении необходимости редактирования плана после этого, декан факультета может воспользоваться действием Отозвать согласование ведущим факультетом, после чего он сможет осуществлять редактирование плана.
  • После того, как декан ведущего факультета согласовал план факультета филиала, он должен выполнить действие Направить на согласование с зам. директора филиала. После согласования плана собственного факультета, он направляется на согласование с МУ. При этом, декан факультета пользуется действием Направить на согласование с МУ (Методическим Управлением).
  • Отслеживание статусов планов
    Декану ведущего факультета доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

19.8. Работа директора аспирантской школы

Работа директора аспирантской школы, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные разработчиками в статус на согласовании с Директором аспирантской школы. С планами, находящимися в этом статусе директор аспирантской школы может выполнять следующие действия (все действия с учебными планами выполняются в форме На согласовании с Директором аспирантской школы):
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом директором аспирантской школы принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у директора аспирантской школы нет критических замечаний к плану, он должен выполнить действие Согласовать план. При этом, при появлении необходимости редактирования плана, директор аспирантской школы может воспользоваться действием Отозвать согласование, после чего он сможет осуществлять редактирование плана.
    • После того, как директор аспирантской школы согласовал план, он должен выполнить действие Направить на согласование УАД.

19.9. Работа управления аспирантуры и докторантуры

Работа пользователей, состоит из следующих этапов:

  1. Отслеживание статусов планов
    Пользователям Управления аспирантуры и докторантуры доступны для просмотра объединенные учебные планы аспирантуры всех аспирантских школ, находящиеся во всех статусах. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) пользователи УАД могут видеть картину готовности планов по аспирантским школам, учебным годам и проч.
  2. Согласование планов
    С планами, находящимся в статусе Направить на согласование с УАД пользователи УАД могут выполнять следующие операции:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом пользователем УАД принято решение вернуть план разработчику, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у пользователя УАД нет критических замечаний к плану, он должен выполнить действие Согласовать план.
    • После того, как пользователь УАД согласовал план, он должен выполнить действие Направить на согласование с зам. директора филиала для планов аспирантов филиала, и Направить на утверждение проректором для всех остальных планов аспирантуры.

19.10. Работа Заместителя директора филиала

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

19.10.1. Согласование БУП и РУП

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

19.10.2. Согласование ОУП аспирантуры

Работа заместителя директора филиала, согласующего объединенные учебные планы аспирантуры, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы в представлении Объединенные учебные планы аспирантуры, в данном представлении отображаются планы, переведенные директорами аспирантских школ в статус на согласовании с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у зам.директора филиала нет критических замечаний к плану, он должен выполнить действие Согласовать план. При этом, при появлении необходимости редактирования плана, заместитель директора филиала может воспользоваться действием Отозвать согласование, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на утверждение проректором.

19.10.3. Согласование ОУП

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у зам.директора филиала нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Объединенные учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

19.11. Работа пользователей методического управления

Работа пользователей Методического управления, состоит из следующих этапов:

  1. Отслеживание статусов планов
    Пользователям Методического управления доступны для просмотра объединенные, базовые и рабочие учебные планы и майноры, объединенные планы факультетских дисциплин, базовые и рабочие планы аспирантуры, учебные планы лицея, находящиеся во всех статусах. В соответствующих представлениях формы На согласовании с УРОП пользователи УРОП могут видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.
  2. Согласование планов от имени УРОП
    С планами, находящимися в статусе на согласовании с УРОП пользователи Методического управления могут выполнять следующие операции:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания, как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом пользователем МУ принято решение вернуть план разработчику, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у пользователя МУ нет критических замечаний к плану, он должен выполнить действие Согласовать от имени УРОП.
    • После того, как пользователь УРОП согласовал план, он должен выполнить действие Направить на согласование с Директором по ДПО для планов ДПО, и Направить на согласование с проректором для всех остальных планов.
  3. Согласование с проректором и Директором по ДПО
    На данном этапе пользователь УРОП не может вносить замечания в план. Он может только просматривать замечания и комментарии, сделанные проректором и директором по ДПО. Если проректором будет принято решение вернуть план на доработку в УРОП, то план перейдет в статус на согласовании с УРОП, и пользователи УРОП снова смогут работать с планом.
  4. Утверждение плана
    На данном этапе пользователь УРОП не может вносить замечания в план. Он может только просматривать замечания и комментарии, сделанные проректором или Директором по ДПО. Если проректором или Директором по ДПО будет принято решение вернуть план на доработку в УРОП, то план перейдет в статус на согласовании с УРОП, и пользователи УРОП снова смогут работать с планом. Если план будет утвержден, то для всех пользователей он будет доступен только для просмотра.

19.12. Работа Директора по ДПО

Работа Директора по ДПО, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные пользователями МУ в статус согласование с Директором по ДПО. С планами, находящимися в этом статусе Директор по ДПО может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом Директором по ДПО принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в МУ.
    • Если у Директора по ДПО нет критических замечаний к плану, он должен выполнить действие Согласовать от имени Директора по ДПО. При этом, при появлении необходимости редактирования плана после этого, Директор по ДПО филиала может воспользоваться действием Отозвать согласование Директора по ДПО, после чего он сможет осуществлять редактирование плана.
    • После того, как Директор по ДПО согласовал план, он должен выполнить действие Направить на согласование с проректором.
  2. Отслеживание статусов планов
    Директору по ДПО доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

19.13. Работа проректора, согласующего планы

Работа проректора, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные пользователями УРОП, а также директором по ДПО в статус согласование с проректором. С планами, находящимися в этом статусе проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания, как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в УРОП.
    • Если у проректора нет критических замечаний к плану, он должен выполнить действие Согласовать от имени проректора. При появлении необходимости редактирования плана после этого, проректор может воспользоваться действием Отозвать согласование проектором, после чего он сможет осуществлять редактирование плана.
    • После того, как проректор согласовал план, он должен выполнить действие Направить на согласование с первым проректором для базовых учебных планов студентов и аспирантов и Направить на утверждение для остальных планов.
  2. Отслеживание статусов планов
    Проректору доступны для просмотра объединенные, базовые, рабочие учебные планы и майноры студентов, объединенные планы факультетских дисциплин, базовые и учебные планы аспирантуры, учебные планы лицея, находящиеся во всех статусах. В соответствующих представлениях формы На согласовании / утверждении проректором можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

19.14. Работа проректора, утверждающего ОУП аспирантуры

Работа проректора, утверждающего объединенные учебные планы аспирантуры, состоит в следующем:

  1. Утверждение планов
    Для утверждения доступны планы, переведенные пользователями УАД или заместителем директора филиала в статус на утверждении с проректором. С планами, находящимися в этом статусе проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у проректора нет критических замечаний к плану, он должен выполнить действие Утвердить план. При этом, при появлении необходимости редактирования плана, проректор может воспользоваться действием Отозвать утверждение, после чего он сможет осуществлять редактирование плана.
  2. Отслеживание статусов планов
    Проректору доступны для просмотра ОУП аспирантуры всех аспирантских школ, находящиеся во всех статусах. В представлении Объединенные учебные планы аспирантуры можно видеть картину готовности планов по аспирантским школам, учебным годам и проч.

19.15. Работа первого проректора согласующего / утверждающего планы

Работа первого проректора, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные проректором в статус на согласовании с первым проректором. С планами, находящимися в этом статусе, первый проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания, как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом первым проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в УРОП.
    • Если у первого проректора нет критических замечаний к плану, он должен выполнить действие Согласовать. При появлении необходимости редактирования плана после этого, первый проректор может воспользоваться действием Отозвать согласование первым проректором, после чего он сможет осуществлять редактирование плана.
    • После того, как первый проректор согласовал план, он должен выполнить действие Направить на утверждение ректором.
    • В отношении Объединенных учебных планов, Объединенных планов факультетских дисциплин и Объединенных майноров, при отсутствии критических замечаний, первый проректор должен выполнить действие Утвердить план.
  2. Утверждение планов
    Для утверждения доступны планы, переведенные проректором в статус на утверждении первым проректором. С планами, находящимися в этом статусе, первый проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом первым проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в УРОП.
    • Если у первого проректора нет критических замечаний к плану, он должен выполнить действие Утвердить план.

20. Оценка затратности реализации учебных планов

Оценкa зaтрaтности рeaлизaции учeбных плaнов зaключaeтся в оцeнке отношения количества студентов, которые будут обучаться по данному учебному плану к объeму нaгрузки прeподaвaтeлeй, трeбуeмому для рeaлизaции этого учeбного плана, выраженному в числе условных ставок преподавателей. Данное отношение называется Коэффициентом затратности плана. Чем коэффициент затратности выше, тем ниже затратность плана, и чем коэффиент ниже, тем выше затратность.

Оцeнкa зaтрaтности рeaлизaции плaнов рeaлиовaнa в систeмe в двух вaриaнтaх: для Paбочих учeбных плaнов и для Объeдинeнных учeбных плaнов. Для Объeдинeнных учeбных плaнов оцeнкa зaтрaтности производится отдльно для кaждого учeбного годa рeaлизaции. Принцип оцeнки зaтрaтности одинaков для рaзных видов плaнов и зaключaeтся в слeдующeм:

  1. Для кaждой дисциплины и НИС выполняeтся оцeнкa количeствa чaсов нaгрузки для рeaлизaции отдeльных видов нaгрузки (лeкций, сeминaров, прaктичeских, провeдeния экзaмeнов и зaчeтов, провeрки испытaний тeкущeго контроля)
  2. Для прочих видов зaписeй плaнa (курсовых рaбот, прaкик, итоговых госэкзaмeнов, ВКP) выполняeтся оцeнкa нaгрузки для типовых случaeв (курсовыe и ВКP нe нa инострaнном языкe, групповой вид прaктики, итоговыe экзaмeны в устной формe и т.п.)
  3. Количeтво чaсов нaгрузки по всeм зaписям плaнa суммируeтся и дeлится нa знaчeниe нaстройки "Нормaтив нaгрузки условного прeподaвaтeля" (нaпримeр, 700 чaсов). Тaким обрaзом вычисляeтся число условных стaвок прeподaвaтeлeй, трeбуeмых для рeaлизaции плaнa.
  4. Опрeдeляeтся отношeниe числa студeнтов, укaзaнного для плaнa в цeлом (в случae PУП) или для одного годa рeaлизaции Объeдинeнного плaнa, к числу условных стaвок прeподaвaтeлeй. Тaким обрaзом получaeтс знaчeниe Коэффициeнтa зaтрaтности плaнa.
  5. Получeнноe знaчeниe Коэффициeнтa зaтрaтности срaвнивaeтся с нормaтивными знaчeниями, хрaнящмися в спрaвочникe "Нормaтивныe коэффициeнты зaтрaтности плaнa", дeлaeтся вывод о повышeнной зaтрaтности плaнa или о зaтрaтности в рaмкaх стaндaртной.

Оценка затратности реализована в системе в виде интерактивного Excel-отчета, показывающего составляющие, на основе которых была произведена оценка и позволяющего сохранять полученное значение коэффициента затратности в базе данных.

20.1. Формирование справочников и установка настроек, необходимых для расчета

До того, как появится возможность оценить затратность отдельных учебных планов, следующие данных должны быть заполнены централизовано пользователем, имеющим права на работу со справочниками по планированию нагрузки преподавателей.

  1. Должно быть установлено значение настройки "Норматив нагрузки условного преподавателя". Значение выражено в числе часов нагрузки, составляющем одну условную ставку преподавателя (например, 700).
  2. Должны быть сформированы три записи справочника "Нормативные коэффициенты затратности плана" для уровней образования "Бакалавриат","Специалитет" и "Магистратура". Для каждого уровня должно быть занесено стандартное (минимально допустимое нормой) значение коэффициента затратности. Данный справочник расположен в разделе "Справочники на планированию нагрузки" на одноименной вкладке верхнего уровня.
  3. Справочник "Виды учебной работы преподавателей" должен быть полностью сформирован на тот учебный год, планы которого планируется оценивать. Среди видов работ, связанных с курсовыми работами, практиками, итоговыми госэкзаменами, ВКР при помощи простановки признака "Используется для оценки плана" должны быть выделены те виды работ, которые являются типовыми (не зависят от выбора студентами) и которые должны использоваться для оценки затратности плана. Простановка этого признака для дисциплин и НИС не требуется.

20.2. Оценка затратности Рабочего учебного плана

Оценка затратности РУП может выполняться тогда, когда план уже практически полностью сформирован (создан перечень дисциплин, распределена нагрузка по видам работы, занесено число испытаний текущего контроля, созданы зачеты и экзамены). Для получения оценки затратности РУП нужно проделать следующее:

  1. Уточнить (или задать) число студентов, установленное для плана в целом в таблице "Рабочие учебные планы" в колонке "Количество студентов".
  2. В подчиненной таблице "Записи рабочего учебного плана" необходимо проставить значения в колонках "Количество студентов", "Количество подгрупп", "Количество групп", "Количество потоков" для всех записей плана кроме разделов и зачетно-экзаменационных недель. Достаточно задать только те значения, от которых зависит расчет нагрузки для данной записи плана. Например, если по дисциплине или НИС нет лекций, значение "Количество потоков" можно не задавать. Заносимые значения должны учитывать в себе понижающие коэффициенты для случаев, когда известно, что студенты, обучающиеся по данному плану, будут изучать дисциплину в одном потоке с другими студентами. Например, если одну из дисциплин по выбору студенты будут изучать совместно со студентами, обучающимися по другим планам, то Количество потоков нужно сократить до доли, которую займут студенты данного плана (например, 0,33). Также можно уменьшать, в том числе до дробных значений, количество групп и подгрупп. Количество студентов должно быть задано таким, как оно оценивается для данной конкретной дисциплины.
  3. При помощи действия контекстного меню Оценка затратности плана выгрузить Excel-отчет, показывающий оценку величины нагрузки по каждой записи плана, по плану в целом, число условных ставок преподавателей, требуемых для реализации плана, а также полученную величину Коэффициента затратности плана и ее оценку ("план избыточно затратен" или "затратность плана в пределах стандарта").
  4. В случае получения нулевых или некорректных значений объема нагрузки нужно уточнить значение числа студентов, групп, подгрупп, потоков по плану в целом или для отдельных дисциплин. Если наблюдается некорректность расчета, нужно обратиться к пользователям, ответственным за работу со справочниками по планированию нагрузки. Если план избыточно затратен, для снижения затратности можно уменьшить число форм текущего контроля, экзаменов, использовать больше дисциплин, читаемых совместно со студентами других учебных планов или больше "внешних" дисциплин (например, MOOC’s). После внесения изменений в показатели плана отчет нужно выгрузить заново.
  5. Если полученное значение коэффициента затратности является корректным, нужно нажать на кнопку "Сохранить значение коэффициента", расположенную в "шапке" плана. Полученное значение коэффициента будет сохранено в таблице данных "Рабочие учебные планы" в одноименной колонке.

20.3. Оценка затратности Объедиенного плана

Оценка затратности Объединенного плана выполняется применительно к одному учебному году и может выполняться тогда, когда план уже практически полностью сформирован на данный учебный год (создан перечень дисциплин, распределена нагрузка по видам работы, занесено число испытаний текущего контроля, созданы зачеты и экзамены). Для получения оценки затратности Объединенного плана нужно проделать следующее:

  1. Задать число студентов для плана в целом применительно к учебному году, для которого выполняется оценка затратности, в подчиненной таблице "Реализация плана по годам".
  2. "Количество студентов", "Количество подгрупп", "Количество групп", "Количество потоков" для каждой из записей плана также оценивается применительно каждому учебному году. Установить эти значения нужно в подчиненной таблице "Все записи плана по годам" для нужного учебного года в одноименных колонках таблицы. Значения должны быть установлены для всех записей плана кроме разделов и зачетно-экзаменационных недель. Достаточно задать только те значения, от которых зависит расчет нагрузки для данной записи плана. Например, если по дисциплине или НИС нет лекций, значение "Количество потоков" можно не задавать. Заносимые значения должны учитывать в себе понижающие коэффициенты для случаев, когда известно, что студенты, обучающиеся по данному плану, будут изучать дисциплину в одном потоке с другими студентами. Например, если одну из дисциплин по выбору студенты будут изучать совместно со студентами, обучающимися по другим планам, то Количество потоков нужно сократить до доли, которую займут студенты данного плана (например, 0,33). Также можно уменьшать, в том числе до дробных значений, количество групп и подгрупп. Количество студентов должно быть задано таким, как оно оценивается для данной конкретной дисциплины.
  3. Выгрузить Excel-отчет при помощи действия контекстного меню Оценка затратности плана. Отчет требует указать учебный год, для которого он формируется. Отчет показывает оценку величины нагрузки по каждой записи плана, по плану в целом, число условных ставок преподавателей, требуемых для реализации плана, а также полученную величину Коэффициента затратности плана и ее оценку ("план избыточно затратен" или "затратность плана в пределах стандарта").
  4. В случае получения нулевых или некорректных значений объема нагрузки нужно уточнить значение числа студентов, групп, подгрупп, потоков по плану в целом или для отдельных дисциплин. Если наблюдается некорректность расчета, нужно обратиться к пользователям, ответственным за работу со справочниками по планированию нагрузки. Если план избыточно затратен, для снижения затратности можно уменьшить число форм текущего контроля, экзаменов, использовать больше дисциплин, читаемых совместно со студентами других учебных планов или больше "внешних" дисциплин (например, MOOC’s). После внесения изменений в показатели плана отчет нужно выгрузить заново.
  5. Если полученное значение коэффициента затратности является корректным, нужно нажать на кнопку "Сохранить значение коэффициента", расположенную в "шапке" плана. Полученное значение коэффициента будет сохранено в таблице данных "Реализация плана по годам" в одноименной колонке применительно к указанному при формировании отчета учебному году.

20.4. Формирование Перечня учебных планов с коэффициентами затратности

Отчет, выгружающий в MS Excel перечень всех Рабочих учебных планов одного учебного года (включая РУП, полученные по данным Объединенных планов) можно сформировать при помощи действия "Перечень утвержденных РУП", доступного с консоли управления в разделе Разработка учебных планов / Аналитические отчеты по РУП.

Перечень утвержденных РУП

При формировании отчета необходимо задать значение "Да" для параметра Выгружать коэффициенты затратности. В этом случае таблица сформируется со столбцом, содержащим коэффициенты затратности планов. В итоговых строках будут отражены средние значения коэффициента затратности по филиалу, факультету, уровню образования.

20.5. Отчеты о фактической затратности

Для оценки фактической затратности реализации образовательных программ представлены следующие отчеты:

  • Оценка фактической затратности ОП
  • Сводный отчет по затратности ОП в учебном году
  • Сводный отчет по затратности ОП по годам

20.5.1. Оценка фактической затратности ОП

Для формирования отчета Оценка фактической затратности ОП необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) выбрать учебный план.
  2. Из контекстного меню вызвать действие Оценка фактической затратности ОП.
    Вызов действия Оценка фактической затратности ОП
  3. В форме параметров необходимо указать Учебный год реализации образовательной программы, при этом Курс будет установлен автоматически. Для того чтобы отчет формировался подробно по каждому преподавателю, необходимо установить признак С конкретизацией по преподавателям.
    Форма параметров Оценка фактической затратности ОП

В результате сформируется отчет в виде Excel файла с оценкой фактической затратности реализации для одной выбранной образовательной программы, одного учебного года и одного курса.

Фактические значения рассчитываться следующим образом:

- Для дисциплины, НИС количество студентов данной ОП, которым назначена дисциплина или НИС для изучения на данном курсе.

- Для курсовой работы количество испытаний студентов данной ОП на данном курсе по курсовой работе с установленным признаком "В диплом" и непустым полем "Руководитель".

- Для практики количество испытаний студентов данной ОП на данном курсе по практике с установленным признаком "В диплом" и непустым полем "Руководитель практики".

- Для итогового экзамена количество студентов данной ОП, которым назначен итоговый экзамен для изучения на данном курсе.

- Для ВКР количество испытаний студентов данной ОП на данном курсе по ВКР с установленным признаком "В диплом" и непустым полем "Руководитель".

- Для проекта студентов количество испытаний студентов данной ОП на данном курсе по проекту с установленным признаком "В диплом" и непустым полем "Руководитель проекта - сотрудник вуза".

Доля студентов данной программы на данном курсе в предметной единице определяется как отношение количества студентов данной программы на данном курсе к общему количеству студентов в предметной единице. Количеством предметных единиц для строки отчета должна быть сумма долей по всем предметным единицам, подчиненным записи плана.

Количество студентов для расчета нагрузки за прием экзамена или зачета по дисциплинам, НИС и практикам определяется по ведомостям.

Количество потоков (при приеме письменных экзаменов) для дисциплин, НИС и практик рассчитывается как сумма долей студентов ОП определенного курса для каждого связанного приметного потока.

Количество групп (для консультаций при семестровой организации) для дисциплин НИС и практик рассчитывается как сумма долей студентов ОП для каждой связанной приметной группы.

Количество экзаменов для ВКР и итоговых экзаменов определяется как количество испытаний студентов данной ОП данного курса с признаком "в диплом", с непустым значением Руководитель работы (для ВКР), включенных в Локальные ГЭК.

Если при формировании отчета был установлен признак "С конкретизацией по преподавателям", то в отчет выгрузятся только те преподаватели, которым в плане нагрузки была назначена какая-либо нагрузка по записи учебного плана. При этом для видов работ, для которых невозможно определить однозначную связь преподаватель-студент, рассчитывается доля вклада преподавателя в выполнение нагрузки как отношение объема нагрузки определенного вида по записи плана, запланированной для данного преподавателя к объему нагрузки этого же вида, запланированной для всех преподавателей. Для отдельных видов работ фактическая нагрузка преподавателей считается по фактическому количеству связанных с ним студентов.

20.5.2. Сводный отчет по затратности ОП в учебном году

Для формирования отчета Сводный отчет по затратности ОП в учебном году необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) из контекстного меню вызвать действие Сводный отчет по затратности ОП в учебном году.
    Вызов действия Сводный отчет по затратности ОП в учебном году
  2. В форме параметров необходимо указать Учебный год, за который будет формироваться отчет. При необходимости можно конкретизировать перечень образовательных программ и курсов с помощью параметров Филиал, Факультет, Уровень образования, Форма обучения, Образовательная программа и Курс факультета.
    Если в форме параметров указан только параметр Учебный год, то отчет будет формироваться по всем образовательным программам и курсам ВУЗа, реализуемым в данном учебном году.
    Для выбора Образовательных программ и Курсов факультета, необходимо щелкнуть левой клавишей мыши на кнопку открытия справочника Справочник, в открывшихся справочниках или с помощью чек-бокса Чек-бокс выбрать одну или несколько записей и нажать кнопку ОК.

    Форма параметров Сводный отчет по затратности ОП в учебном году

В результате сформируется отчет в виде Excel файла со сводным отчетом по затратности в указанном учебном году для выбранных образовательных программ и курсов.

20.5.3. Сводный отчет по затратности ОП по годам

Для формирования отчета Сводный отчет по затратности ОП по годам необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) из контекстного меню вызвать действие Сводный отчет по затратности ОП по годам.
    Вызов действия Сводный отчет по затратности ОП по годам
  2. В форме параметров необходимо указать Учебный год начала обучения. При необходимости можно конкретизировать перечень образовательных программ и курсов с помощью параметров Филиал, Факультет, Уровень образования, Форма обучения, Образовательная программа и Курс факультета.
    Если в форме параметров указан только параметр Учебный год, то отчет будет формироваться по всем образовательным программам и курсам ВУЗа, реализуемым в данном учебном году.
    Для выбора Образовательных программ и Курсов факультета, необходимо щелкнуть левой клавишей мыши на кнопку открытия справочника Справочник, в открывшихся справочниках или с помощью чек-бокса Чек-бокс выбрать одну или несколько записей и нажать кнопку ОК.

    Форма параметров Сводный отчет по затратности ОП по годам

В результате сформируется отчет в виде Excel файла со сводным отчетом по затратности выбранных образовательных программ и курсов в учебных годах, начиная с указанного Учебного года начала обучения и до крайнего учебного года реализации образовательных программ.

21. Каталог дисциплин

Справочник "Каталог дисциплин"

Справочник содержит записи о дисциплинах, каждая из которых характеризуется определенным содержанием и объемом, который в свою очередь задается числом кредитов.

Поля:

  • Статус дисциплины - признак утверждения дисциплины Методическим управлением. Возможные варианты для статуса: проект и утверждено. При этом только утвержденные дисциплины могут быть доступны разработчикам учебных планов. Изменение статуса дисциплины доступно только пользователям Методического управления.
  • Код дисциплины - автоматически вычисляемое поле на основании данных подчиненной таблицы.
  • Дисциплина ВУЗа - наименование дисциплины ВУЗа из справочника Все дисциплины ВУЗа.
  • Число кредитов - числовое значение, весовая характеристика объема дисциплины.
  • Наименование на английском языке - наименование дисциплины на английском языке.
  • Порядковый номер - числовое значение. Позволяет располагать дисциплины в заданном пользователем порядке.

Для добавления новой дисциплины в католог необходимо воспользоваться соответствующим пунктом контекстного меню.

Откроется окно создания новой дисциплины:

Добавить дисциплину в каталог

- Дисциплина ВУЗа - наименование дисциплины ВУЗа из справочника Все дисциплины ВУЗа.

- Полное наименование дисциплины - заполняется автоматически из справочника Все дисциплины ВУЗа.

- Наименование на английском языке - наименование дисциплины на английском языке.

- Число кредитов - задается числовое значение кредитов для данной дисциплины.

Далее в правой части формы осуществляется выбор направлений (специальностей), для которых преподается данная дисциплина в соответствующих группах полей (по уровням образования).

Выбор осуществляется из справочников Направления и специальности (для уровней Бакалавриат, Специалитет и Магистратура), Отрасли науки и научные специальности (для аспирантуры) и Направления ДПО (для дополнительного профессионального образования).

Для каждого из уровней образования можно выбрать до трех специальностей (направлений).

После нажатия кнопки "Ок", запись о новой дисциплине появится в главной таблице. В поле "Статус дисциплины" будет установлено значение "проект".

Также в подчиненной таблице Направления/Специальности будет содержать перечень уровней и направлений (специальностей) подготовки, для которых преподается, созданная дисциплина.

Поля таблицы Направления/Специальности :

  • Уровень образования - показывается уровень образования для данного направления/специальности.
  • Аббревиатура направления/специальности - аббревиатура, соответствующая направлению/специальности из справочника Направления и специальности.
  • Направление/специальность ВПО - наименование направления/специальности, для которого преподается данная дисциплина. Выбор из справочника Направления и специальности. Для уровней образования Аспирантура и ДПО поле недоступно для редактирования и должно быть пустым.
  • Код научной специальности - код из справочника Отрасли науки и научные специальности
  • Научная специальность - наименование научной специальности аспирантуры, для которой преподается данная дисциплина. Выбор из справочника Отрасли науки и научные специальности
  • Аббревиатура направления ДПО - аббревиатура из справочника Направления ДПО
  • Направление ДПО - наименование направления ДПО, для которого преподается данная дисциплина. Выбор из справочника Направления ДПО.

По данным таблицы Направления ДПО система автоматически генерирует код дисциплины, который заносится в соответствующее поле главной таблицы.

Код дисциплины автоматически переформировывается при добавлении/удалении записей таблицы Направления/Специальности, а также при изменении числа кредитов в таблице Каталог дисциплин.

Алгоритм формирования кода дисциплины:

Код состоит из трех частей, разделенных знаком "/".

1-я часть: Аббревиатура всех уровней образования, для которых преподается данная дисциплина.

  • Б - бакалавриат
  • С - специалитет
  • М - магистратура
  • А - аспирантура
  • Д - ДПО

2-я часть: Аббревиатура (или коды) направлений, специальностей, научных специальностей, направлений ДПО, для которых преподается дисциплина. Для того, чтобы можно было различить направления (специальности) высшего образрования, научные специальности и направления ДПО, перед соответствующим кодом (аббревиатурой) проставляется индекс:

  • н - научная специальность
  • д - направление ДПО

Аббревиатуры (коды) направлений разделяются знаком "-".

Пример сформированных кодов дисциплин:

Пример 1:

Пример формирования кода дисциплины

Пример 2:

22. График учебного процесса

График учебного процесса является составной частью базового учебного плана. График учебного процесса в ВУЗе в базовом учебном плане составляется на весь период обучения по данному направлению (специальности) с учетом разбиения времени по модулям. На графике указываются продолжительность теоретического обучения, время, отводимое на все виды практики, подготовку выпускной квалификационной работы (ВКР), государственную итоговую аттестацию, каникулы, отпуск после окончания вуза.

Работы по формированию графика учебного процесса производятся на участке РАЗРАБОТКА УЧЕБНЫХ ПЛАНОВ в разделе Базовые и рабочие учебные планы в таблице Базовые учебные планы. Для отображения записей графика учебной работы предназначена подчиненная таблица График учебного процесса.

Перед началом работ по формированию графика учебного процесса необходимо убедиться, что для соответствующего БУП корректно заполнены поля "Реализуется по периодам" и "Число периодов в году" таблицы Базовые учебные планы

Таблица График учебного процесса

Для формирования графика учебного процесса необходимо в таблице Базовые учебные планы выбрать запись БУП, для которой планируется формировать график учебного процесса, вызвать контекстное меню (правая кнопка мыши) и воспользоваться действием "Сформировать график учебного процесса".

Откроется окно задания количества недель в году:

Сформировать график по умолчанию

По умолчанию количество недель проставляется равным "52". Это значение можно изменить.

После нажатия на кнопку "Ок" в таблице График учебного процесса будут созданы записи общим количеством равным заданному количеству недель в году умноженному на количество курсов, по данному учебному плану.

Также в подчиненной таблице Вид недельной нагрузки для каждой из записей таблицы График учебного процесса будут установлены значения "Теоретическое обучение".

Процесс формирования графика учебного процесса заключается в распределении по модулям, неделям и курсам видов учебной и внеучебной деятельности, таких как теоретическое обучение, практика, подготовка выпускной квалификационной работы (ВКР), государственная итоговая аттестация, каникулы, отпуск после окончания вуза.

Для этого необходимо в таблице Базовые учебные планы выбрать БУП, по которому создается график, вызвать контекстное меню (правая кнопка мыши) и воспользоваться пунктом "Открыть график учебного процесса".

Откроется форма редактирования соответствующего графика учебного плана.

Редактирование графика учебного процесса

Форма для редактирования графика учебного процесса содержит временную шкалу учебного года (начиная с сентября), которая рабита по месяцам и неделям. Также таблица разбита по курсам для выбранной степени образования. В правой части таблицы расчитывается количество недель, выделенное на нагрузку каждого вида для каждого курса и их сумма, а также показаны зачетные единицы из соответствующего БУП.

Для нового, только что созданного, графика учебного процесса во всех ячейках временной шкалы проставлены значения "Т" (теоретической обучение).

В первую очередь необходимо задать временные периоды модулей. Вертикальные границы серых областей, которыми обозначены модули, являются перемещаемыми по горизонтали. Для того, чтобы переместить одну из границ области необходимо подвести курсор мыши к перетаскиваемой границе, чтобы он принял вид Курсор. После этого нужно зажать левую кнопку мыши и перетащить границу на нужную неделю. Области модулей пересекаться не могут.

После того, как модули расположены на временной шкале, можно приступить к заполнению ячеек таблицы признаками вида учебной нагрузки. В результате должны быть заполнены ВСЕ ячейки временной шкалы.

Для того, чтобы установить вид недельной нагрузки в соответствующую ячейку необходимо выделить ячейку нажатием левой кнопки мыши (ячейка быдет выделена синим цветом), нажать правую кнопку мыши и из появившегося списка выбрать нужный вид недельной нагрузки. В одной ячейке может быть выбрано несколько видов недельной нагрузки. Для выбора каждого из них, необходимо каждый раз снова вызвать список выбора правой кнопкой мыши.

Выбор вида недельной нагрузки

В форме редактирования предусмотрена возможность назначения вида недельной нагрузки одновременно для нескольких соседних ячеек. Для множественного выбора необходимо, зажав левую кнопку мыши, провести ею над всеми ячейками, которые должны быть изменены. Все выбранные ячейки будут выделены синим цветом. Затем можно вызвать список видов недельной нагрузки нажатием правой кнопки мыши. Во всех выделенных ячейках проставится соответствующий вид нагрузки.

Кроме реквизитов БУП указанных в шапке формы, в верхнем правом углу расположены информационные элементы:

  • Статус плана - показывается статус согласования БУП
  • Программа двойных дипломов - признак программы двойных дипломов
  • Ход согласования - при нажатии на ссылку откроется таблица, содержащая сведения о ходе согласования БУП.
  • Дополнительные действия - открывется список дополнительных действий:
    • Сформировать протокол проверки - будет сформирован протоколол в проверки БУП в формате Excel, в котором будут отображены сообщения Системы о результатах проверки.
    • Напечатать график - будет создан и показан на экране файл Excel, содержащий печатную форму графика учебного процесса для проверки и распечатки. Пример Графика учебного процесса
    • Напечатать план - будет создан и показан на экране файл Excel, содержащий печатную форму БУП.

После того как работа с формой редактирования графика учебного процесса закончена, форму можно закрыть.

Просмотреть и распечатать график учебного процесса можно из таблицы Базовые учебные планы, воспользовавшись пунктом контекстного меню "График учебного процесса".

23. Переводы для учебных планов

Данная форма содержит в себе таблицы данных с перечнем всех терминов и элементов перечислений, используемых на веб-страницах для публикации Базовых и Рабочих учебных планов на английском языке.
Форма переводы для учебных планов

Для корректировки перевода необходимо:

  1. Для термина, перевод которого необходимо изменить, в поле Перевод щелкнуть левой клавишей мыши.
  2. С помощью кнопки Справочник открыть окно редактирования и ввести тест с новым переводом.
  3. Закрыть окно редактирования и подтвердить сохранение изменений.

24. Аналитические отчеты по РУП

24.1. Перечень утвержденных РУП (Форма 1)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Перечень утвержденных РУП (форма 1).
    Перечень утвержденных РУП

  2. В открывшейся форме параметров:
    Форма параметров Перечень утвержденных РУП

    • В поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • В поле Учебный год указать учебный год, для которого формируется отчет.
    • Для параметров Только по утвержденным РУП и Выводить оценку затратности с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

24.2. Регламентирующие показатели РУП (Форма 3)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Регламентирующие показатели РУП (форма 3).
    Регламентирующие показатели РУП

  2. В открывшейся форме параметров:
    Форма параметров Регламентирующие показатели РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • В поле Учебный год указать учебный год, для которого формируется отчет.
    • Для параметров Показывать соотношение в % и Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

24.3. Виды дисциплин в БУП и РУП (Форма 7)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Виды дисциплин в БУП и РУП (форма 7).
    Виды дисциплин в БУП и РУП

  2. В открывшейся форме параметров:
    Форма параметров Виды дисциплин в БУП и РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • В поле Учебный год указать учебный год, для которого формируется отчет.
    • В поле Вид учебных планов выбрать требуемый вид учебных планов.
    • Для параметра Только по утвержденным планам с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

24.4. Формы контроля в РУП (Форма 10)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Формы контроля в РУП (форма 10).
    Формы контроля в РУП

  2. В открывшейся форме параметров:
    Форма параметров Формы контроля в РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметра Учебный год.
    • При необходимости можно установить ограничение для отчета и указать параметр Только уровень образования.
    • Для параметра Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

24.5. Дисциплины РУП по циклам ГОС (Форма 11)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Дисциплины РУП по циклам ГОС (форма 11).
    Дисциплины РУП по циклам ГОС

  2. В открывшейся форме параметров:
    Форма параметров Дисциплины РУП по циклам ГОС

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметра Учебный год.
    • Для параметра Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

24.6. Дисциплины, не назначенные ни одному студенту

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Дисциплины, не назначенные ни одному студенту.
    Дисциплины, не назначенные ни одному студенту

  2. В открывшейся форме параметров:
    Форма параметров Дисциплины, не назначенные ни одному студенту

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметров Учебный год и Факультет.
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

24.7. Дисциплины по числу вхождений в РУП

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Дисциплины по числу вхождений в РУП.
    Дисциплины по числу вхождений в РУП

  2. В открывшейся форме параметров:
    Форма параметров Дисциплины по числу вхождений в РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметра Учебный год.
    • При необходимости можно установить параметр Минимальное число вхождений.
    • Для параметра Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

24.8. Выгрузка записей РУП для анализа

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Выгрузка записей РУП для анализа.
    Выгрузка записей РУП для анализа

  2. В открывшейся форме параметров:
    Форма параметров Выгрузка записей РУП для анализа

    • Устновить значения параметров Учебный год, Уровень образования, Филиал, Факультет и Образовательная программа.
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Базовые майноры (раздел целиком) (31.03.2018) Одним файлом
Базовые майноры

Базовый майнор - это план изучения определенного набора дисциплин в течение нескольких лет обучения. Каждый базовый майнор разрабатывается для определенного уровня образования. Базовый майнор реализуется одной из образовательных программ вуза в течение определенного периода (нескольних ученых годов). Для базового майнора может задаваться минимальное и максимальное число студентов, необходимое для реализации майнора.

1. Создание нового базового майнора

Создание базового майнора и работа с ним осуществляется в форме Майноры учебных планов, доступной на консоли управления в разделе Разработка учебных планов.

Майноры на консоли управления

Представление для работы с базовыми майнорами расположено на второй вкладке данной формы.

Таблица данных Базовые майноры

Для добавления нового базового майнора в таблице данных нужно вызвать действие Добавить базовый майнор. При вызове действия будет отображена форма параметров, которую нужно заполнить следующим образом:

Добавление Базового майнора
  • Уровень образования - в этом поле из выпадающего списка необходимо выбрать тот уровень образования, для студентов которого будет предназначен майор.
  • Наименование майнора - каждому майнору нужно присвоить наименование. Наименованием может быть любое строковое значение длиной не более 128 символов.
  • Год начала реализации - в этом поле нужно выбрать учебный год, в котором студенты, для которых предназначается майнор, учились (будут учиться) на первом курсе.
  • Год окончания реализации - в этом поле нужно выбрать учебный год, в котором студенты, для которых предназначается майнор, завершат обучение.
  • Число курсов - в этом поле нужно установить целочисленное значение числа курсов (лет обучения), соответствующее уровню образования
  • Образовательная программа, реализующая майнор - в этом поле необходимо выбрать образовательную программу, которая предлагает и будет реализовывать данный майнор.
  • Минимальное количество студентов - в этом поле нужно задать целое число, соответствующее минимальному количеству студентов, для которых будет реализовываться майнор; если минимальное количество студентов не ограничивается, это значение нужно оставить пустым.
  • Максимальное количество студентов - в этом поле нужно задать целое число, соответствующее максимальному количеству студентов, для которых будет реализовываться майнор; если максимальное количество студентов не ограничивается, это значение нужно оставить пустым.

После нажатия кнопки ОК запись о новом майноре будет добавлена в основную таблицу данных. При этом в подчиненной таблице данных Записи базового майнора будет создана одна запись вида "Раздел плана" с наименованием "Весь майнор", которая будет служить "коревой" записью для будущего майнора.

Выбирая значения полей Год начала реализации, Год окончания реализации, Число курсов нужно исходить из того, что майнор разрабатывается для всех курсов обучения студентов, для которых предназначен майнор. Даже в случае, если известно, например, что майнор будет использоваться для студентов 2 - 3 курсов бакалавриата, для майнора должно быть задано Число лет обучения = 4, и выбраны годы обучения с 1-го по 4-ый курс.

2. Редактирование базового майнора

Редактирование майнора состоит в наполнении его дисциплинами, которые могут быть объединены в группы, уточнении объема нагрузки по дисциплинам, установке форм итогового контроля по дисциплинам. Формируя майнор, нужно исходить из следующих требования к его структуре:

Требования к структуре майнора:

  • Майнор обязательно должен иметь одну и только одну корневую запись типа "Раздел плана". При создании майнора такая запись создается автоматически и получает наименование " Весь майнор ". Это наименование допустимо изменить.
  • Майнор может состоять из записей двух видов: разделы (группы дисциплин) и дисциплины. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в майнор записей других типов (НИСы, курсовые, практики и проч.) недопустимо.

Редактирование базового майнора выполняется при помощи специализированной формы редактирования, которая открывается при вызове для майнора действия Открыть или при двойном щелчке мышью по записи о майноре.

Форма редактирования Базового майнора

Добавление и удаление записей майнора, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню. Основные характеристики записей майнора (число часов, кредитов, формы итогового контроля) редактируются непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей майнора, не видимых в таблице, предназначено действие Дополнительные свойства.

Удалить запись базового майнора можно только при выполнении следюущих условий:

  • не существует записей рабочих майноров, связанных с данной записью базового майнора
  • раздел (группу дисциплин) можно удалить только в случае, если в него не влкючена ни одна дисциплина и ни один другой раздел; если раздел необходимо удалить, сначала из него неоходимо удалить все дисциплины и другие разделы;

В основном процесс редактирования базового майнора аналогичен процессу редактирования Базового учебного плана (см. раздел Редактирование базового учебного плана) с учетом особенностей работы с записями разных типов, описанных в разделе Особенности наполнения отдельных разделов БУП и РУП. Для базового майнора предусмотрена работа только с разделами (группами дисциплин) и с дисциплинами.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Редактирование учебного плана лицея (раздел целиком) (31.03.2018) Одним файлом
Редактирование учебного плана лицея

Для редактирования учебного плана лицея предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования учебного плана лицея

Редактирование учебного плана должно заключаться в добавлении разделов, школьных предметов и проектов школьников, распределении нагрузки по видам работы (лекции, семинары, практические и т.д.), по годам обучения (классам) и по периодам обучения в каждом году (модулям, семестрам), а также планировании рубежных контролей.

Для добавления раздела необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие раздел плана.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: школьный предмет, проект школьников.

Форма редактирования группа процедур Добавить

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, формы контролей), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается школьниками или нет и т.д.), предназначено действие Дополнительные свойства.

Редактирование записей учебного плана лицея

1. Добавление раздела

Для создания раздела необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие раздел плана,

Форма редактирования Добавить раздел в учебный план лицея

после чего заполнить следующую форму параметров:

Форма параметров добавить раздел учебный план лицея

  • В поле Раздел из справочника выбрать раздел для добавления.
  • В поле Наименование необходимо ввести название раздела.
  • В поле Код записи при необходимости можно указать код записи для добавляемого раздела.
  • В полях Общее число часов и Число недель можно указать общее количество часов и число недель по плану для данного раздела. При необходимости данные поля можно оставить пустыми и указать данные параметры непосредственно в форме редактирования.
  • В поле Рассчитывается как сумма элементов необходимо установить значение "Да", если показатели раздела определяться путем суммирования показателей входящих в них записей. Если показатели раздела плана должны устанавливаться независимо, то необходимо установить значение "Нет".
  • Для разделов показатели, которых устанавливаются независимо, при необходимости можно указать Минимальное и Максимальное число дисциплин для выбора, и Минимальное и Максимальное число кредитов для выбирамых дисциплин.

После нажатия кнопки ОК, раздел будет добавлен.

2. Добавление школьного предмета

При добавлении школьного предмета в форме редактирования учебного плана лицея необходимо из контекстного меню в группе процедур Добавить вызвать действие школьный предмет, после чего заполнить следующую форму параметров:

Форма параметров Добавить школьный предмет в учебный план лицея
  • В поле Школьный предмет с помощью списка Список или справочника Справочник нужно выбрать школьный предмет для добавления.
  • В поле Кафедра при необходимости можно указать кафедру, которая будет реализовать школьный предмет.
  • В поле Вид дисциплины необходимо выбрать вид добавляемой дисциплины.
  • В поле По выбору студентов нужно установить значение "Да" для школьных предметов, назначаемых школьникам в обязательном порядке, и значение "Нет" для школьных предметов, которые назначаются при выборе школьником.
  • В полях Аудиторных часов и Число недель необходимо указать соответствующие числовые характеристики добавляемого школьного предмета.

После заполнения формы параметров необходимо нажать кнопку ОК, после чего школьный предмет будет добавлен в учебный план.

После того как запись о школьном предмете будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, недель, формы контролей), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается школьниками или нет и т.д.), предназначено действие Дополнительные свойства.

3. Добавление проекта школьников

При добавлении проекта школьников в форме редактирования учебного плана лицея необходимо из контекстного меню в группе процедур Добавить вызвать действие проект школьников, после чего заполнить следующую форму параметров:

Форма параметров Добавить проект школьников в учебный план лицея
  • В поле Наименование необходимо ввести наименование проекта школьников.
  • В поле Кафедра при необходимости можно указать кафедру, которая будет реализовать проект школьников.
  • В полях Число недель, Аудиторных часов нужно указать соответствующие числовые характеристики добавляемого школьного проекта.
  • Значение для Аудиторных часов в неделю определяется автоматически.
  • Если нагрузка по проекту должна учитываться при расчете недельной нагрузки, то в поле Входит в расчет недельной нагрузки должно быть установлено значение "Да".
  • В поле По выбору студентов должно быть установлено значение "Да" для проектов школьников, назначаемых школьникам в обязательном порядке, и значение "Нет" для проектов школьников, которые назначаются при выборе школьником.

После заполнения формы параметров необходимо нажать кнопку ОК, после чего школьный предмет будет добавлен в учебный план.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Проекты для студентов (раздел целиком) (31.03.2018) Одним файлом
Проекты для студентов

Справочник "Проекты для студентов" позволяет работать с информацией о проектах, в которые могут включаться студенты в своей внеадиторной деятельности. Справочник распологается в разделе Объединенные учебные планы на соотвествующей вкладке Проекты для студентов.
Справочник проекты для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить проект.
    Вызов действия Добавить проект
  2. Заполнить форму параметров следующим образом:
    Форма параметров Добавить проект
    • Заполнить поля Идентификатор во внешней системе, Полное наименование, Полное наименование на английском языке, Тип проекта (выбирается из справочника Типы проектов для студентов), Вид проектной деятельности (выбирается из списка).
    • В одной из групп полей Руководитель из вуза или Внешний руководитель указать подразделение/организацию руководителя (выбирается из справочников или Места прохождения практики) и выбрать самого руководителя проекта (выбирается из справочника или Работники организации).
      Руководителем проекта может быть только либо представитель вуза, либо внешний руководитель. При этом если начать заполнять одну из групп полей (Руководитель из вуза или Внешний руководитель) другая перестанет быть доступной для заполнения.
    • Заполнить поля Учебный год, Дата начала реализации, Дата окончания реализации, Дата окончания записи на проект, Количество модулей, Период итогового контроля, Вид итогового контроля и Плановое количество кредитов.
  3. Нажать кнопку ОК.

1. Выгрузить проекты студентов

В справочнике Проекты для студентов предоставлена возможность сформировать отчет с информацией о проектах и студентах, которым назначены данные проекты.

Для формирования отчета необходимо:

  1. В справочнике Проекты для студентов из контекстного меню системы вызвать действие Выгрузить проекты студентов.
    Вызов действия Выгрузить проекты
  2. В форме пераметров с помощью выбора значений для параметров Филиал, Факультет, Образовательная программа, Курс, Группа, Проект можно ограничить выборку проектов, для которых будет формироваться отчет. Если все поля формы параметров оставить пустыми, то отчет сформируется для всех проектов ВУЗа, присутствующих в справочнике Проекты для студентов.
  3. Нажать кнопку ОК.

В результате сформируется отчет в формате MS Excel, содержащий информацию об образовательной программе, ФИО, курсе и группах студентов, участвующих в проектах, наименовании проекта, плановом и фактическом количестве кредитов, руководителях проектов, результатах участия в проекте студентов.

2. Загрузка данных о проектах с портала

3. Загрузка данных о назначении проектов студентам


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Базовые учебные планы аспирантуры (БУПы аспирантуры) (раздел целиком) (31.03.2018) Одним файлом
Базовые учебные планы аспирантуры (БУПы аспирантуры)

Базовые учебные планы аспирантуры разрабатываются на основе Образовательных стандартов аспирантуры отдельно для каждой и для каждого набора аспирантов. Базовый учебный план аспирантуры отражает полный цикл дисциплин и других видов нагрузки, которые должны быть прослушаны и сданы аспирантами в течение всего срока обучения в аспирантуре с разбиением нагрузки по годам обучения.

Каждый базовый учебный план аспирантуры может расширять и уточнять содержание соответствующего образовательного стандарта. Работа с БУПом аспирантуры состоит из этапов:

  • Создание БУП аспирантуры на основе образовательного стандарта
  • Редактирование БУП аспирантуры
  • Согласование и утверждение БУП аспирантуры

1. Создание нового базового учебного плана аспирантуры

Для создания БУП аспирантуры необходимо, чтобы предварительно были сформированы следующие данные:

  • Создан и полностью сформирован Образовательный стандарт аспирантуры по соответствующему направлению подготовки.
  • В справочнике создана соответствующая аспирантская школа.
  • В справочнике созданы учебные года, соответствующие всем годам, в течение которых будет реализовываться новый БУП (от года начала обучения до года окончания обучения).
  • В справочнике созданы записи о форме и годах обучения, для которых будет разрабатываться БУП.

Создание и дальнейшая работа с БУП аспирантуры ведется в разделе Разработка учебных планов в форме Базовые и рабочие учебные планы аспирантуры на первой вкладке Базовые учебные планы аспирантуры. Для создания нового БУП аспирантуры на этой вкладке необходимо вызвать действие Добавить базовый учебный план.

Добавление БУП аспирантуры

Для добавления нужно в поле Аспирантская школа выбрать соответствующую школу из справочника , выбрать Образовательный стандарт из справочника Образовательные стандарты, выбрать Форму обучения и задать соответствующее этой форме Число лет обучения. Также необходимо выбрать Год начала обучения и Год окончания обучения из справочника .

После корректного заполнения всех полей формы добавления кнопка ОК станет активной. После ее нажатия новый базовый учебные план аспирантуры будет добавлен в таблицу данных.

2. Редактирование базового учебного плана аспирантуры

После создания БУП аспирантуры его необходимо заполнить и отредактировать путем выполнения следующих двух этапов:

  1. Сформировать на основе стандарта
  2. Отредактировать, указав распределение нагрузки, заданной стандартом по годам обучения, при необходимости уточнив и дополнив содержание стандарта.

Формирование БУП аспирантуры на основе стандарта

После создания БУП аспирантуры необходимо выбрать его в таблице данных и вызвать действие Сформировать на основе стандарта. Результатом выполнения этого действие будет копирование в БУП всего содержания стандарта с сохранением структуры разделов и величин нагрузки, заданных в стандарте.

Редактирование БУП аспирантуры

Для редактирования БУП аспирантуры предназначена специализированная форма, которая доступна посредством вызова действия Открыть по выбранному БУП. При помощи формы редактирования можно выполнять следующие операции:

  • Корректировать (в случае необходимости) или дополнять значения нагрузки, полученные из стандарта
  • Распределять нагрузку, предусмотренную по дисциплине в целом по годам обучения.
  • Дополнять содержание стандарта дополнительными дисциплинами и другими видами работы.
  • Уточнять структуру плана за счет добавления новых разделов или групп дисциплин и переноса дисциплин между разделами.

В целом принцип редактирования БУП аспирантуры аналогичен принципу редактирования БУП студентов, описанному в разделе Редактирование базового учебного плана. Работа с Графиками учебного процесса для БУП аспирантуры не предусмотрена.

Принципы работы с отдельными видами записей БУП аспирантуры аналогичны принципам, заложенным для БУП студентов и описаны в разделе Особенности наполнения отдельных разделов БУП и РУП.

В форме редактирования БУП аспирантуры реализованы проверки и автоматически расчеты, аналогичные реализованным для БУП факультетов. Принцип действия этих расчетов описан в разделе Расчетные показатели учебных планов.

Готовый БУП аспирантуры можно выгрузить в утвержденной форме в MS Excel при помощи действия Выгрузить для печати.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Объединенные учебные планы аспирантуры (раздел целиком) (31.03.2018) Одним файлом
Объединенные учебные планы аспирантуры

"Объединенные учебные планы аспирантуры" - это такой вид учебных планов, который объединяет в себе "базовый учебный план аспирантуры" и "рабочий учебный план аспирантуры". Объединенный учебный план разрабатывается сразу на все годы реализации образовательной программы, содержит полный набор разделов, дисциплин и других видов записей планов на весь период обучения, и в то же время отражает планирование нагрузки как по дисциплине в целом, так и по видам работ (лекции, семинары, практически и т.п.), по учебным годам, по периодам каждого года, а также отражает планирование испытаний текущего и рубежного контроля.

1. Создание нового объединенного учебного плана аспирантуры

Работа с Объединенными учебными планами аспирантуры ведется на участке "Разработка учебных планов" в форме "Объединенные учебные планы аспирантуры". Для создания нового объединенного учебного плана аспирантуры необходимо чтобы предварительно был сформирован соответствующий образовательный стандарт. Работа с образовательными стандартами описана в разделе Образовательные стандарты.

Для добавления объединенного учебного плана, необходимо в представлении Объединенные учебные планы аспирантуры с помощью контекстного меню вызвать действие Добавить объединенный план аспирантуры.

Вызвать действие Добавить ОУП аспирантов

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров Добавить ОУП аспирантуры

  • В полях Образовательный стандарт и Образовательную программа - выбрать образовательный стандарт и программу, для которой создается план.
  • Поля Аспирантская школа, Филиал, Форма обучения и Число лет обучения будут заполнены автоматически данными, заданными для образовательного стандарта и выбранной образовательной программы.
  • В полях Год начала обучения, Год окончания обучения указать года начала и окончания обучения, периоды, по которым будет планироваться нагрузка.
  • При наличии соответствующей информации можно указать Число кредитов по плану в целом.
  • В поле Реализуется по периодам выбрать один из предлагаемых вариантов реализации: по модулям, по семестрам или по периодам в аспирантуре.
  • В поле Количество периодов в году указать количество периодов в учебном году.

После того, как будет заполнена форма параметров, нужно нажать кнопку ОК. В результате запись о новом объединенном учебном плане аспирантов появится в представлении. При попытке добавления второго объединенного учебного плана аспирантуры на основе той же образовательной программы, образовательного стандарта для той же аспирантской школы, года начала обучения, произойдет ошибка дублирования объектов.

2. Редактирование объединенного учебного плана аспирантуры

Сформировать структуру и состав нового объединенного учебного плана аспирантуры можно на основе образовательного стандарта. Для этого нужно выбрать объединенный учебный план аспирантуры в представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) и в контекстном меню выбрать действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Сообщение о формировании ОУП аспирантов на основании стандарта

Если Вы уверены, что хотите сформировать учебный план на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненном представлении Все записи плана.

После того, как объединенный учебный план сформирован на основе стандарта, его можно редактировать. Для редактирования предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования ОУп аспирантов

Редактирование объединенного учебного плана аспирантов должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (практик аспирантов, кандидатских экзаменов, и т.п.), распределять нагрузку по видам работы (лекции, семинары, практические и т.д.), по годам обучения и по периодам обучения в каждом году, а также планировать рубежные испытания, распределять кредиты и объем нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: дисциплину, научно-исследовательский семинар, научные исследования аспирантов, практику аспирантов, кандидатский экзамен, итоговый госэкзамен, защиту научного доклада.

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, дисциплина по выбору или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

Форма редактирования ОУП аспирантов распределение нагрузки по годам

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение свойств разделов и дисциплин ОУП.

По окончании работы с объединенным учебным планом аспирантов его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении действия учебный план будет выгружен для печати в MS Excel.

2.1. Добавление дисциплин и НИС

При добавлении дисциплины или НИС в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие дисциплину или научно-исследовательский семинар, после чего заполнить следующую форму параметров:

Форма параметров Добавить дисциплину в ОУП аспирантуры
Пользователям разработчикам учебных планов предоставлена возможность связывания дисциплин и НИС учебного плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
      Для выбора из плана-предложения кафедры будут доступны только те дисциплины, которые совпадают по периоду реализации с периодом, заданным с помощью полей Год начала реализации и Год окончания реализации.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • Установить значение для признака Входит в расчет недельной нагрузки.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных профилей аспирантуры, необходимо выбрать профили, для которых добавляется дисциплина. Для выбора профилей необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей профилей, после чего нужно нажать кнопку ОК.
      Для каждого профиля в ОУП будет создана отдельная запись по дисциплине.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Вид дисциплины в плане, По выбору студентов, Формат изучения,На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных профилей подготовки аспирантуре, необходимо выбрать профили, для которых добавляется дисциплина. Для выбора профилей необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей профилей, после чего нужно нажать кнопку ОК.
      Для каждого профиля в ОУП будет создана отдельная запись по дисциплине.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план аспирантуры.
    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (более подробно см. Редактирование объединенного учебного плана аспирантуры). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признак Входит в расчет недельной нагрузки.
  • Профили для дисциплин и НИС (см. Установить/ изменить профиль).
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

2.2. Добавление практики аспирантов

При добавлении практики аспирантов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие практику аспирантов, после чего заполнить следующую форму параметров:

Форма параметров Добавить практику в ОУП аспирантуры

В первую очередь необходимо ввести Наименование практики и Общее число часов, указать Вид практики (справочник ) и Способ проведения практики, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК практика будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по практике (см. Редактирование объединенного учебного плана аспирантуры).

2.3. Добавление научного исследования аспирантов

При добавлении научного исследования аспирантов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие научные исследования аспирантов, после чего заполнить следующую форму параметров:

Форма параметров Добавить научные исследования в ОУП аспирантуры

В первую очередь необходимо указать Наименование и Общее число часов для научных исследований аспирантов, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК запись о научных исследованиях аспирантов будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по научным исследованиям (см. Редактирование объединенного учебного плана аспирантуры).

2.4. Добавление кандидатских экзаменов

При добавлении кандидатского экзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие кандидатский экзамен, после чего заполнить следующую форму параметров:

Форма параметров Добавить кандидатский экзамен в ОУП аспирантуры

В первую очередь необходимо ввести Наименование для экзамена и Общее число часов, выбрать Дисциплину ВУЗа, по которой будет проходить кандидатский экзамен, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК кандидатский экзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по кандидатскому экзамену (см. Редактирование объединенного учебного плана аспирантуры).

2.5. Добавление итогового госэкзамена

При добавлении госэкзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие итоговый госэкзамен, после чего заполнить следующую форму параметров:

Форма параметров Добавить госэкзамен в ОУП аспирантуры

В первую очередь необходимо ввести Наименование для экзамена и Общее число часов, при необходимости можно выбрать Дисциплину, по программе которой будет проходить экзамен, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК госэкзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по госэкзамену (см. Редактирование объединенного учебного плана аспирантуры).

2.6. Добавление защиты научного доклада

При добавлении защиты научного доклада в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие защита научного доклада, после чего заполнить следующую форму параметров:

Форма параметров Добавить защиту докладов в ОУП аспирантуры

В первую очередь необходимо ввести Наименование, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК госэкзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по защите научного доклада (см. Редактирование объединенного учебного плана аспирантуры).

2.7. Формирование информации о численности контингента

Для добавления информации о численности контингента необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать план, для записей которого будет уточняться информация о численности контингента.
  2. В представлении Все записи по годам обучения для записей учебного плана в соответствующих полях указать Количество потоков, Количество групп, Количество подгрупп и Количество студентов (аспирантов) (после изменения значения каждого из параметров нужно нажимать клавишу Enter).

2.8. Изменение периода реализации

Для изменения периода реализации записи объединенного учебного плана аспирантов, необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать учебный план.
  2. В представлении Все записи плана выбрать запись учебного плана, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

2.9. Уточнение свойств разделов и дисциплин ОУП

В формах редактирования объединенных учебных планов аспирантуры работают проверки контрольных соотношений, при помощи которых контролируется корректность и целостность плана, соответствие характеристик записей плана требованиям образовательного стандарта, выполнение Методических указаний по разработке объединенных учебных планов аспирантуры. Также при помощи функционала формы редактирования можно выполнять автоматизированные пересчеты показателей плана, в частности, суммирование значений числа часов, недель, кредитов по разделам и группам дисциплин.

В образовательном стандарте не содержится достаточно информации для того, чтобы реализовать корректную работу некоторых автоматизированных проверок и пересчетов. По этой причине после формирования учебного плана на основе стандарта, необходимо выполнить уточнение следующих значений для некоторых разделов и дисциплин учебного плана:

  1. Признак Рассчитывается как сумма элементов для групп дисциплин и разделов.

    Все разделы и группы дисциплин можно разделить на два вида:

    • Разделы или группы, показатели которых должны определяться путем суммирования показателей входящих в них записей.
    • Разделы или группы, показатели которых могут устанавливаться независимо.

    К первой группе относятся разделы и группы, все дисциплины которых обязательны для изучения всеми аспирантами. Ко второй группе относятся разделы и группы дисциплин по выбору. Для того, чтобы отличить один вид разделов от другого используется признак Рассчитывается как сумма элементов. При формировании учебного плана на основе стандарта для всех разделов и групп дисциплин этот признак получает значение Да. Если для признака установить значение Нет, то проверка соответствия суммы показателей для всех записей раздела со значением, установленным для раздела в целом, проводиться не будет, и сообщения об ошибках не будут формироваться. Для группы дисциплин (раздела) по выбору значения числа часов, недель, кредитов, числа экзаменов и зачетов нужно установить вручную таким образом, чтобы раздел, в свою очередь, внес необходимый вклад в план в целом. Например, если в раздел включено три дисциплины по выбору, трудоемкостью 108 часов каждая, а аспиранты должны выбрать только одну из них, для раздела вручную должно быть установлено число часов, равное 108.

    Для того чтобы в дальнейшем на основании разработанных объединенных учебных планов можно было сформировать учебный план аспиранта и проверить его полноту и корректность, необходимо задать для каждой группы или раздела дисциплин по выбору минимальное и максимальное количество дисциплин, которые должны быть обязательно выбраны аспирантом, также необходимо задать минимально и максимальное число кредитов, которое необходимо набрать при выборе дисциплин аспирантом. Если при наполнении образовательного стандарта эти значения не заданы, то их необходимо задать в форме редактирования объединенного учебного плана при помощи действия Дополнительные свойства.

  2. Признак Входит в расчет недельной нагрузки. Данный признак используется для того, чтобы исключить некоторые дисциплины учебного плана из расчета недельной аудиторной нагрузки аспирантов. Изменить значение данного признака можно в форме редактирования учебного плана при помощи действия Дополнительные свойства. При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются двумя звездочками (**) в колонке "Наименование дисциплины". По этой причине вносить знаки * в наименование дисциплины не нужно. В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.

2.10. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связать с предложением кафедры в ОУП аспирантуры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

2.11. Установить/ изменить профиль

Для установки, снятия и изменения профиля, установленного для записи учебного плана, необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать учебный план, в который входит запись.
  2. В представлении Все записи плана выбрать запись, для которой необходимо установить, снять или изменить профиль.
    При добавлении дисциплины или НИС можно установить сразу несколько специализаций, для каждой из них будет создана отдельная запись о дисциплине или НИС (см. Добавление дисциплин и НИС). В связи с этим необходимо удостовериться, что выбранная дисциплина или НИС соответствуют той записи, которую необходимо изменить. Установленные специализации можно проверить в поле Специализация.
  3. Из контекстного меню вызвать действие Установить\изменить профиль.
  4. В форме параметров указать Специализацию (профиль аспирантуры).
  5. Нажать кнопку ОК.

3. Передача плана на факультет

Для того чтобы дисциплины объединенного учебного плана аспирантуры могли быть назначены аспирантам, необходимо для плана выполнить действие Передать план в реализацию.

Вызов действия Передать план в реализацию для ОУП аспирантов

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

Результатом выполнения процедуры будет создание или уточнение свойств записей в представлении Учебные планы аспирантуры. Данное представление доступно на участке Аспирант, в форме Учебные планы аспирантуры.

4. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать действие Выгрузить для печати.
  3. В форме параметров указать Профиль, для которого нужно вывести на печать, или оставить пустое значение, если нужно вывести на печать учебный план для всех профилей.
  4. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.

5. Оценка плановой затратности плана

Выполнить оценку плановой затратности плана можно:

С помощью формирования отчета "Оценка плановой затратности плана"

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
    Вызов действия отчет оценка затратности ОУп аспирантов
  2. Выбрать действие Оценка плановой затратности (отчет).
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате сформируется отчет с оценкой затратности реализации объединенного учебного плана аспирантов.

С помощью действия Рассчитать плановую затратность

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
  2. Выбрать действие Рассчитать плановую затратность.
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате будет выведено сообщение с указанием плановой затратности плана.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Объединенные майноры (раздел целиком) (31.03.2018) Одним файлом
Объединенные майноры

Объединенный майнор - это такой вид планов, который объединяет в себе "базовый майнор" и "рабочий майнор". Объединенный майнор разрабатывается на несколько лет обучения, содержит полный набор разделов, дисциплин и других видов записей планов на весь период обучения, и в то же время отражает планирование нагрузки как по дисциплине в целом, так и по видам работ (лекции, семинары, практически и т.п.), по учебным годам (курсам студентов), по периодам каждого года (модулям и семестрам), а также отражает планирование испытаний текущего и рубежного контроля. Дополнительной возможностью Объединенных майноров является возможность распределения кредитов, аудиторных часов и общих часов по "частям дисциплины", ограниченным рубежными испытаниями (зачетами и экзаменами).

1. Создание нового объединенного майнора

Создание объединенного майнора и работа с ним осуществляется в форме Майноры учебных планов, доступной на консоли управления в разделе Разработка учебных планов.

Меню разработка РУП

Представление для работы с базовыми майнорами расположено на первой вкладке данной формы.

Представление объединенные майноры

Для добавления нового объединенного майнора в таблице данных нужно вызвать действие Добавить объединенный майнор. При вызове действия будет отображена форма параметров, которую нужно заполнить следующим образом:

Форма параметров для добавления объединенного майнора
  • Уровень образования - в этом поле из выпадающего списка необходимо выбрать тот уровень образования, для студентов которого будет предназначен майор.
  • Наименование майнора - каждому майнору нужно присвоить наименование. Наименованием может быть любое строковое значение длиной не более 128 символов.
  • Начинается с курса - необходимо указать курс, начиная с которого будет реализовываться майнор.
  • Число лет реализации - в этом поле нужно установить целочисленное значение числа лет реализации майнора.
  • Учебный год начала реализации - в этом поле нужно выбрать учебный год, начиная с которого будет реализовываться данный майнор.
  • Год окончания реализации - в этом поле нужно выбрать учебный год, в котором студенты завершат обучение по данному майнору.
  • Филиал, Факультет - для выбора Образовательной программы, реализующей майнор, в этих полях нужно указать Филиал и Факультет, на которых реализуется данная программа.
  • Образовательная программа, реализующая майнор - в этом поле необходимо выбрать образовательную программу, которая предлагает и будет реализовывать данный майнор.
  • Минимальное количество студентов - в этом поле нужно задать целое число, соответствующее минимальному количеству студентов, для которых будет реализовываться майнор; если минимальное количество студентов не ограничивается, это значение нужно оставить пустым.
  • Максимальное количество студентов - в этом поле нужно задать целое число, соответствующее максимальному количеству студентов, для которых будет реализовываться майнор; если максимальное количество студентов не ограничивается, это значение нужно оставить пустым.
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов в году указать количество периодов в учебном году.

После нажатия кнопки ОК запись о новом майноре будет добавлена в основную таблицу данных.

2. Редактирование объединенного майнора

Редактирование майнора состоит в наполнении его дисциплинами, которые могут быть объединены в группы, уточнении объема нагрузки по дисциплинам, установке форм итогового контроля по дисциплинам.

Майнор может состоять из записей двух видов: разделы (группы дисциплин) и дисциплины. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в майнор записей других типов (НИСы, курсовые, практики и проч.) недопустимо.

Редактирование объединенного майнора выполняется при помощи специализированной формы редактирования, которая открывается при вызове для майнора действия Открыть или при двойном щелчке мышью по записи о майноре.

Редактирование объединенногоо плана

Добавление и удаление записей майнора, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню.

Добавление Группы дисциплин (раздела)

Для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Добавление группы дисциплин в объединенный майнор

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

Добавление Дисциплины

Для добавления Дисциплины необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие Дисциплину,

Процедура добавление дисциплины в объединенный майнор

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный майнор

Пользователям разработчикам объединенных майноров предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

    • После того как запись о дисциплинебудет добавлена в майнор, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик объединенного майнора больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

Перемещение Группы дисциплин (раздела) или дисциплины

В случае если при добавлении Группы дисциплин или Дисциплины был неверно указан раздел, куда они должны быть включены, то в отношении такой Группы дисциплин или Дисциплины необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить Группу дисциплин или Дисциплину, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина будет перемещена в корень объединенного майнора.

Также можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

Печать объединенных планов факультетских дисциплин

По окончании работы с объединенным майнором его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати, Выгрузить для печати как Базовый майнор, Выгрузить для печати как Рабочий майнор расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

3. Передача объединенного майнора в реализацию

Для того, чтобы дисциплины объединенного майнора могли быть назначены студентам, необходимо для плана выполнить действие Передать на факультет.

Передача объединенного майнора в реализацию

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Майноры учебных планов. Эта таблица доступна в разделе Общевузовские ресурсы, в форме Учебные планы, формы и программы обучения на вкладке Майноры учебных планов.

Назначение дисциплин майноров студентам на участке Студент выполняется именно из таблицы данных Майноры учебных планов. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного майнора необходимо выполнять действие по передаче майнора на факультет.

4. Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные майноры (форма Майноры учебных планов) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи майнора выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

5. Связать с предложением кафедры

Для того чтобы связать запись объединенного майнора с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись майнора.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

6. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные майноры (форма Майноры учебных планов) выбрать майнор, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как РУП, Выгрузить для печати как БУП.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести майнор на печать.

7. Оценка плановой затратности плана

Для оценки плановой затратности майнора необходимо:

  1. В форме редактирования объединенного майнора открыть группу действий Дополнительные действия (правый верхний угол).
    Форма редактирования ОМ Дополнительные действия
  2. Выбрать действие Оценка плановой затратности (отчет).
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате сформируется отчет с оценкой затратности реализации объединенного майнора.

8. Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных майноров выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Образовательные стандарты (раздел целиком) (31.03.2018) Одним файлом
Образовательные стандарты

Образовательный стандарт в системе представляет собой иерархическую структуру учебных циклов и включенных в них учебных дисциплин, снабженных информацией о трудоемкости их усвоения, выраженной в зачетных единицах (кредитах) или в учебных часах. Каждый образовательный стандарт соответствует одной степени / квалификации по одному из направлений / специальностей подготовки. К каждому образовательному стандарту относится перечень компетенций, развиваемых в ходе обучения студента по соответствующей образовательной программе. Развитие компетенций в каждом из учебных циклов отражается за счет связи цикла с набором компетенций стандарта.

Создание нового образовательного стандарта включает следующие этапы работы:

  1. Создание записи о стандарте.
  2. Наполнение стандарта записями о циклах дисциплин, учебных дисциплинах и других видах учебной нагрузки.
  3. Создание перечня компетенций, входящих в состав стандарта.
  4. Связывание записей стандарта с компетенциями.
Работа с компетенциями (пункты 3 и 4) ведется только при работе с образовательными стандартами III поколения (ФГОС, Оригинальные образовательные стандарты).

1. Создание нового образовательного стандарта

Для создания нового образовательного стандарта необходимо открыть форму Образовательные стандарты. Форма доступна на Консоли управления или на Панели инструментов системы.

В основной таблице данных Образовательные стандарты необходимо вызвать действие Добавить образовательный стандарт. При вызове действия будет отображена форма параметров нового стандарта:

Добавление образовательного стандарта

Поля формы добавления нужно заполнить следующим образом:

  • В поле Тип образовательного стандарта нужно выбрать один из типов, занесенных в Справочник "Типы образовательных стандартов".
  • В поле Уровень образования из выпадающего списка необходимо выбрать один из вариантов Бакалавриат, Специалитет, Магистратура или Аспирантура в зависимости от того, для какого уровня образования предназначен стандарт.
  • В поле Направление / специальность нужно выбрать соответствующую запись из общевузовского справочника . При выборе направления или специальности обращайте внимание не только на ее наименование, но и на код. Если в предыдущем поле выбрано значение "Бакалавриат" или "Магистратура", то для выбора будут предложены записи справочника, являющиеся направлениями, если же выбрано значение "Специалитет", то будут предложены записи, являющиеся специальностями (установлен флаг Является специальностью). В случае если Вы не находите нужного направления или специальности в этом справочнике, необходимо обратиться к бизнес-администратору системы с просьбой добавить его в справочник.
  • В поле Степень (квалификация) нужно выбрать степень или квалификацию, соответствующую уровню образования. В случае, если в предыдущем поле выбрано направление подготовки, то для выбора будут доступны степени бакалавр или магистр. Если же выбрана специальность, то для выбора будет доступна соответствующая квалификация. При создании образовательного стандарта для аспирантуры нужно выбрать степень кандидат наук.

Поле заполнения полей формы добавления надо нажать кнопку ОК, в результате чего в таблице появится запись о новом стандарте. При создании стандарта ему автоматически присваивается наименование, состоящее из типа стандарта, кода и наименования направления (специальности) и степени (квалификации). Создание двух и более стандартов одного типа по одной и той же степени (квалификации) одного и того же направления (специальности) недопустимо. При попытке создать второй аналогичный стандарт пользователь увидит сообщение об ошибке дублирования объектов.

Все созданные в системе образовательные стандарты отображаются в одной таблице данных, сгруппированной по уровням образования.

2. Наполнение образовательного стандарта

После создания записи о стандарте можно формировать структуру компонентов и дисциплин, составляющих стандарт. Записи стандарта имеют иерархическую структуру, отражающую включенность одних компонентов в состав других и вхождение дисциплин и других видов учебной нагрузки в группы и компоненты. Каждая запись наряду с атрибутами "наименование", "число часов", "число кредитов" и проч. имеет атрибут Входит в раздел, содержащий ссылку на раздел (или группу), в состав которого входит данная запись.

Стандарт состоит из записей нескольких видов:

  • раздел (цикл, компонент)
  • группа дисциплин
  • дисциплина
  • научно-исследовательский семинар
  • курсовая работа
  • практика
  • итоговый госэкзамен
  • выпускная квалификационная работа
  • зачетно-экзаменационные недели

Добавление записей стандарта производится путем вызова соответствующего действия их группы действий Добавить ....

Вид записи группа дисциплин должен использоваться во всех случаях, когда добавляемая запись строго не соответствует одной конкретной дисциплине, которая будет преподаваться на факультете определенной кафедрой по определенной программе или одной конкретной практике, курсовой работе и т.п. Например, запись "Иностранный язык" должна создаваться как группа дисциплин, в которую впоследствии будут включаться дисциплины "Английский язык", "Немецкий язык", "Французский язык" и т.д. Если набор иностранных языков, которые могут (должны) преподаваться по стандарту, известен, то их можно включить в группу иностранных языков как дисциплины. Если же набор иностранных языков не зафиксирован в стандарте, их можно будет задать позже при работе с базовым или рабочим учебным планом.

Если в стандарте задается объем нагрузки для курсовых работ в целом, а не для каждой работы, то такая запись также должна быть создана как раздел или группа дисциплин.

Если в стандарте задаются конкретные виды практик (учебная практика, преддипломная практика и т.д.), то такие записи могут быть созданы как практики. Если же в стандарте задается практика в целом, то такую запись нужно создать как раздел или как группу дисциплин.

В раздел итоговой государственной аттестации можно включить записи вида "итоговый госэкзамен" и "выпускная квалификационная работа", под которыми имеются в виду конкретные виды итоговых испытаний.

В дальнейшем при работе над базовыми и рабочими учебными планами, формируемыми на базе стандарта, в разделы и группы дисциплин можно будет включить записи о конкретных учебных дисциплинах и других видах учебной нагрузки. Также группы дисциплин используются в БУП и РУП для выделения групп дисциплин по выбору и задания их характеристик (число дисциплин или число кредитов, которое должно быть выбрано студентом по группе дисциплин).

Добавление записей стандарта должно начинаться с добавления корневого раздела (компонента). Для корневого раздела, как правило, задается наименование Вся образовательная программа. Для корневого компонента значение атрибута Входит в раздел должно быть пустым. Остальные записи должны включаться в состав этого корневого компонента или в состав других компонентов. Включение записей в состав дисциплин недопустимо. Иерархическая структура позволяет формировать стандарты любой структуры. Следующие ниже примеры будут иллюстрировать создание стандартов II и III поколения. Если ВУЗ имеет право вести обучение по собственным (оригинальным) стандартам, то они должны быть сформированы по аналогичным принципам.

Разделы и дисциплины стандарта могут иметь коды (ГСЭ.0, ЕН.Ф.03, Б1, Б5). В связи с тем, что в стандартах разных типов принято использование различных систем кодирования, включающих различные символы, а также в связи с тем, что не все записи стандарта имеют коды, для корректного задания порядка следования записей в стандарте используется дополнительное числовое поле Порядковый номер. Сортировка записей стандарта будет производиться в порядке возрастания значения порядкового номера в рамках каждого уровня иерархии (т.е. в рамках каждого раздела).

Пример структуры стандарта II поколения:

Структура стандарта II поколения

Пример структуры стандарта III поколения:

2.1. Добавление разделов (циклов, компанентов) стандарта

Для добавления компонента стандарта нужно выбрать запись о стандарте в основной таблице данных Образовательные стандарты, после чего в подчиненной таблице Состав стандарта вызвать действие Добавить ... / раздел. При добавлении первой записи нужно выполнить щелчок правой кнопкой мыши в пустом поле таблицы. При добавлении записи более низкого уровня сначала нужно выбрать запись компонента, в который планируется включить новый компонент, и только после этого вызвать действие добавления. Ссылка на запись компонента, выбранного в момент вызова действия добавления отобразится в поле Входит в раздел формы параметров. Если по ошибке вместо компонента выбрана дисциплина, то в поле Входит в раздел будет подставлена ссылка на раздел (компонент), в который включена данная дисциплина.

Добавление компонента стандарта II поколения:

Добавление раздела стандарта II поколения

Добавление компонента стандарта III поколения:

Добавление раздела стандарта III поколения

Поля формы добавления нужно заполнить следующим образом:

  • В поле Входит в раздел значение подставляется автоматически. Новая запись будет включена именно в данный раздел. При добавлении первой записи данное поле нужно оставить пустым. Если в поле подставилось значение, а Вы хотите добавить запись на первый уровень, то значение в поле нужно очистить, выделив весь текст и нажав клавишу Del.
  • Поле Компонент плана предназначено для работы со стандартами II поколения. В этом случае нужно выбрать необходимый компонент из справочника компонентов стандартов II поколения. После выбора значения в этом поле автоматически заполнятся и станут недоступными для изменения значения в полях Код записи и Наименование. При работе со стандартами III поколения это поле нужно оставить пустым.
  • В поле Наименование нужно ввести наименование раздела в случае, если не выбрано значение в предыдущем поле.
  • В поле Код записи нужно ввести код раздела в случае, если он задан в стандарте. Для стандартов II поколения это поле будет заполнено автоматически после выбора компонента плана в поле Компонент плана.
  • В поле Порядковый номер нужно ввести целое число, которое будет определять позицию записи в ряду всех записей, входящих в один раздел. Это значение предлагается автоматически как максимально существующий в данном разделе порядковый номер + 1. Если Вы хотите вставить запись не в конец, а в середину то это значение можно скорректировать. В этом случае после добавления записи нужно будет проверить и при необходимости изменить порядковые номера других записей. Сортировка записей стандарта будет производиться по значениям порядковых номеров в пределах каждого раздела. Допустим (но не рекомендуется) повтор значений порядковых номеров. В этом случае записи будут отсортированы в случайном порядке. Допустим пропуск значений позиций (например, 5, 10, 15, ...).
  • В поле Общее число часов нужно ввести значение общего числа часов по всем записям плана, входящим в раздел, в случае если это значение задано в стандарте.
  • В поле Число недель нужно ввести число недель, выделяемое на раздел, если это значение задано в стандарте.
  • Поля Минимальное число кредитов и Максимальное число кредитов предназначены для задания диапазона допустимых сумм кредитов для стандартов III поколения. В случае если задано одно значение числа кредитов, его нужно повторить в обоих полях.

2.2. Добавление групп дисциплин

В случае, если в стандарте указаны не конкретные дисциплины, а их обобщенные наименования (например, "Иностранный язык", "Древние языки", "Инженерно-технологические дисциплины, отражающие специфику отраслей сферы материального производства" и т.п.), то такие записи должны добавляться как группы дисциплин. При разработке базового учебного плана эти группы должны быть уточнены путем включения в них тех дисциплин, которые будут читаться студентам факультета (например, в группу "Иностранный язык" в базовом плане будут включены дисциплины "Английский язык", "Немецкий язык", в группу "Древние языки" будут включены дисциплины "Древнегреческий язык", "Латинский язык").

Для того, чтобы добавить в стандарт группу дисциплин нужно на вкладке Состав стандарта выбрать раздел, в который должна быть включена новая группа дисциплин и вызвать действие Добавить ... / группу дисциплин.

Добавление группы дисциплин в стандарт
  • В поле Входит в раздел должна отображаться ссылка на раздел, в который будет включена новая группа дисциплин. Если отображается неверный раздел, то нужно закрыть форму добавления, выбрать в списке записей стандарта нужный раздел и повторить вызов действия добавления.
  • В поле Наименование нужно ввести наименование группы дисциплин.
  • В поле Порядковый номер будет предложен очередной порядковый номер записи в выбранном разделе. При необходимости его можно изменить.
  • В поле Количество выбираемых дисциплин нужно занести числовое значение числа дисциплин данной группы, которое обязательно к изучению студентами.
  • В поле Общее число часов нужно занести число часов, выделяемых на изучение дисциплин группы.
  • В поле Число недель будет предложено значение, равное заданному числу часов, разделенному на 54. При необходимости это значение можно изменить.
  • В поле Число кредитовбудет предложено значение, равное заданному числу часов, разделенному на 36. При необходимости это значение можно изменить.

После нажатия кнопки ОК запись о новой группе дисциплин появится в таблице данных. После добавления группы дисциплин в нее можно включать отдельные дисциплины (если набор дисциплин задается в стандарте).

2.3. Добавление дисциплин

Дисциплины могут добавляться в любой из компонентов стандарта или в группу дисциплин. Для добавления дисциплины нужно выбрать в таблице данных компонент или группу, в которую должна быть включена дисциплина, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / дисциплину. При помощи этого действия должны добавляться только конкретные учебные дисциплины, которые будут читаться на факультете (отделении) определенной кафедрой по определенной программе. Если же в стандарте дисциплины заданы укрупненно, то нужно пользоваться действием добавления группы дисциплин (Добавление групп дисциплин).

Добавление дисциплины стандарта

Поля формы добавления дисциплины нужно заполнить следующим образом:

  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного компонента и снова вызвать действие добавления дисциплины.
  • В поле Дисциплина нужно выбрать дисциплину из общевузовского справочника дисциплин. Выбор можно осуществлять путем ввода начала наименования дисциплины с клавиатуры. При вводе будут предлагаться существующие в справочнике дисциплины. Процедура поиска дисциплины чувствительная к регистру символов. Наименования всех дисциплин справочника, как правило, начинаются с заглавной буквы. Если нужной дисциплины нет в справочнике, ее можно добавить, открыв справочник и вызвав действие Добавить дисциплину ВУЗа. Для добавления новой дисциплины достаточно ввести ее полное наименование. Наименование должно вводиться без сокращений. В дальнейшем оно будет использоваться во всех отчетных документах, а также в дипломе студента. Если при попытке добавления новой дисциплины произошла ошибка дублирования объектов, это означает, что дисциплина с таким наименованием уже существует.
  • В поле Код записи нужно ввести значение кода дисциплины в стандарте, если оно задано.
  • В поле Порядковый номер значение предлагается автоматически как следующая за максимально существующей в рамках раздела. При необходимости это значение можно изменить. Если необходимо добавить дисциплину не в конец, а в середину существующего списка, необходимо проверить и уточнить позиции всех следующих за ней дисциплин.
  • В поле Вид дисциплины нужно выбрать один из видов из выпадающего списка. Выбранный вид дисциплины в дальнейшем будет использоваться при контроле полноты и корректности формирования БУПов и РУПов, который может предполагать различные контрольные нормативы для обязательных дисциплин, факультативов, адаптационных дисциплин. Также от выбранного вида дисциплины зависит ее обязательность для изучения всеми студентами.
  • В поле По выбору студентов значение подставляется автоматически в зависимости от значения, выбранного в поле Вид дисциплины. Для видов Обязательная дисциплина и Обязательный факультатив подставляется значение Да, в остальных случаях - значение Нет. При необходимости установленное автоматически значение можно изменить.
  • В поле Общее число часов нужно ввести значение числа часов, выделяемых на изучение дисциплины, если оно задано в стандарте. При изменении значения в этом поле будут автоматически пересчитываться значения в полях Число недель и Число кредитов.
  • В поле Число недель значение будет заполнено автоматически путем деления значения из поля Общее число часов на 54. При необходимости это значение можно скорректировать.
  • В поле Число кредитов значение будет заполнено автоматически путем деления значения из поля Общее число часов на 36. При необходимости это значение можно скорректировать.

2.4. Добавление научно-исследовательских семинаров

Для добавления научно-исследовательского семинара предназначено действие Добавить / научно-исследовательский семинар. Форма добавление семинара и принципы ее заполнения аналогичны форме добавления дисциплины. Сам семинар выбирается из справочника всех дисциплин вуза. Если нужно семинара нет в справочнике, его можно добавить.

2.5. Добавление курсовых работ

Добавлять в образовательный стандарт курсовые работы надо только в том случае, если в нем зафиксированы конкретные работы, которые должны быть выполнены студентами. Если же курсовые работы заданы в стандарте укрупненно, то нужно пользоваться действиями, описанными в разделах Добавление разделов (циклов, компонентов) стандарта и Добавление групп дисциплин.

Для добавления курсовой работы нужно выбрать в таблице данных компонент или группу, в которую должна быть включена курсовая работа, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / курсовую работу. Курсовые работы могут быть как по одной конкретной учебной дисциплине, так и междисциплинарные. На приведенных ниже рисунках представлены примеры заполнения формы параметров в этих двух случаях. Если курсовая работа выполняется по конкретной дисциплине, но дисциплина может выбираться студентом, то курсовая работа добавляется по аналогии с междисциплинарной (дисциплина не указывается).

Добавление курсовой работы по дисциплине в стандарт

Добавление междисциплинарной курсовой в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел (группу дисциплин), который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления курсовой работы.
  • Поле По дисциплине нужно заполнять только в том случае, если курсовая работа должна выполняться по одной конкретной учебной дисциплине всеми студентами. Если дисциплина может выбираться студентами, или если курсовая работа является междисциплинарной, то данное поле нужно оставить пустым.
  • Поле Наименование доступно для заполнения только в том случае, если не выбрана дисциплина. По умолчанию предлагается наименование "Курсовая работа", но его можно изменить (например, "Междисциплинарная курсовая работа"). Если же дисциплина выбрана, то наименование курсовой работы будет сформировано автоматически.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для курсовых работ.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на данную курсовую работу.

После нажатия кнопки ОК на форме параметров запись о курсовой работе появится в таблице данных в соответствующей позиции.

2.6. Добавление практик

Добавлять в образовательный стандарт практики надо только в том случае, если в нем зафиксированы конкретные виды практик, которые должны быть пройдены студентами. Если же практики заданы в стандарте укрупненно, то нужно пользоваться действиями, описанными в разделах Добавление разделов (циклов, компонентов) стандарта и Добавление групп дисциплин.

Для добавления практики нужно выбрать в таблице данных компонент или группу, в которую должна быть включена практика, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить... / практику. Как правило, в образовательных стандартах выделяются специальные разделы практик.

Добавление практики в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел (группу дисциплин), который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления практики.
  • В поле Вид практики нужно выбрать практику из общевузовского справочника .
  • В поле Способ проведения практики нужно выбрать один из способов проведения практики.
  • После выбора вида практики в поле Наименование будет автоматически сформировано значение, соответствующее выбранному виду практики. Изменять его независимо от вида практики недопустимо.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • В поле Общее число часов значение можно оставить пустым, если оно не зафиксировано в стандарте.
  • В поле Число недель нужно задать число недель, выделяемых на практику.
  • В поле Число кредитов нужно установить число кредитов, выделяемых на практику, соблюдая требуемое соотношение между числом недель и числом кредитов.

После нажатия кнопки ОК на форме параметров запись о практике появится в таблице данных в соответствующей позиции.

2.7. Добавление итоговых госэкзаменов

итоговые государственные экзамены должны добавляться в раздел итоговой аттестации. Итоговые госэкзамены могут быть по одной конкретной дисциплине, или междисциплинарными.

Для добавления итогового экзамена нужно выбрать в таблице данных раздел итоговой аттестации, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / итоговый госэкзамен. На приведенных ниже рисунках представлены примеры заполнения формы параметров для случая добавления экзамена по дисциплине и междисциплинарного экзамена.

Добавление итогового экзамена по дисциплине в стандарт

Добавление междисциплинарного итогового экзамена в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления итогового госэкзамена.
  • Поле Дисциплина нужно заполнять только в случае экзамена по дисциплине. При выборе дисциплины автоматически формируется наименование записи об итоговом экзамене. Если экзамен является междисциплинарным, то поле Дисциплина нужно оставить пустым.
  • Поле Наименование доступно для заполнения только в случае, если поле Дисциплина пустое. В этом случае наименование итогового экзамена нужно ввести вручную с клавиатуры.
    Наименование, заданное для итогового экзамена, будет в дальнейшем использовано при формировании дипломов студентов.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для итогового экзамена.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на итоговый экзамен в соответствии с действующими нормативами.

После нажатия кнопки ОК на форме параметров запись об итоговом госэкзамене появится в таблице данных в соответствующей позиции.

2.8. Добавление выпускных квалификационных работ

Выпускные квалификационные работы (ВКР) должны добавляться в раздел итоговой аттестации.

Для добавления ВКР нужно выбрать в таблице данных раздел итоговой аттестации, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / выпускную работу.

Добавление ВКР в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления ВКР.
  • В поле Наименование нужно ввести наименование ВКР с клавиатуры (Например, "Подготовка и защита выпускной работы бакалавра" или "Подготовка и защита магистерской диссертации").
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для ВКР.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на ВКР в соответствии с действующими нормативами.

После нажатия кнопки ОК на форме параметров запись о выпускной работе появится в таблице данных в соответствующей позиции.

2.9. Добавление зачетно-экзаменационных недель

Зачетно-экзаменационные недели должны добавляться в корневой раздел стандарта (раздел "Вся образовательная программа").

Для добавления записи о зачетно-экзаменационных неделях нужно выбрать в таблице данных корневой раздел, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / зачетно-экзаменационные недели.

Добавление зачетно-экзаменационных недель в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления ВКР.
  • В поле Наименование автоматически формируется строка "Зачетно-экзаменационные недели". При необходимости это значение можно изменить.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • В поля Общее число часов и Число недель нужно занести значения, предусмотренные стандартом.

После нажатия кнопки ОК на форме параметров запись о зачетно-экзаменационных неделях появится в таблице данных в соответствующей позиции.

2.10. Внесение изменений в созданный стандарт

После того, как созданы записи стандарта, можно изменять как отдельные свойства записей, так и структуру стандарта. Доступны изменения следующих видов:

  1. Добавление новых записей.
    Для дополнения стандарта новыми записями необходимо вызвать одно из действий добавления, описанных в предыдущих разделах.
  2. Уточнение значений свойств записей стандарта.
    Значения различных свойств записей изменяются разными способами:
    • Наименование можно изменять путем ввода нового значения с клавиатуры с последующим нажатием клавиши Enter для всех записей, кроме тех, которые соответствуют дисциплинам (заполнено значение в колонке Дисциплина) или компонентам стандарта II поколения (заполнено значение в колонке Компонент плана). Для изменения наименования записи, соответствующей дисциплине, нужно в колонке Дисциплина выбрать другую дисциплину из справочника дисциплин. Если нужно дисциплины в справочнике нет, ее можно добавить в справочник. Для изменения наименования записи, соответствующей компоненту стандарта II поколения (ГОС) нужно выбрать другой компонент в колонке Компонент плана. Если нужного компонента в справочнике нет, необходимо обратиться к бизнес-администратору системы с просьбой уточнить данные справочника. При изменении наименования практики нужно проследить за тем, чтобы наименование соответствовало значению, установленному в колонке Вид практики.
    • Порядковый номер можно изменять путем ввода нового числового значения с клавиатуры с последующим нажатием клавиши Enter. При изменении порядкового номера одной из записей необходимо просмотреть значения порядковых номеров всех следующих за ней записей раздела и при необходимости скорректировать и их.
    • Код записи, Общее число часов, Число недель, Минимальное число кредитов, Максимальное число кредитов можно изменять путем ввода нового значения с клавиатуры с последующим нажатием клавиши Enter.
    • При изменении значений, выбранных в колонках Дисциплина и Компонент плана автоматически изменится значение в колонке Наименование.
    • Если Вы изменяете значение, выбранное в колонке Вид практики, необходимо вручную уточнить значение в колонке Наименование.
  3. Изменение структуры стандарта.
    Под изменением структуры понимается перенос записей из одного раздела в другой. Для этого нужно выбрать запись, которую Вы хотите перенести и вызвать для нее действие Перенести в другой раздел. Для выполнения действия нужно указать раздел, которому будет непосредственно подчинена запись.

    Перенос записи в другой раздел

    Для выбора будут доступны только записи вида Раздел плана (компоненты и группы дисциплин). Если Вы выполняете перенос раздела или группы, то необходимо следить за тем, чтобы не включить раздел сам в себя. При подобной попытке будет отображено сообщение об ошибке с текстом "Недопустимо включать раздел сам в себя".
  4. Удаление записей.
    Удаление записей производится при помощи действия Удалить, доступного в контекстном меню. Удалить можно только ту запись, в которую не включено ни одной другой записи. Это означает, что для того, чтобы удалить запись о разделе, нужно сначала удалить или перенести в другие разделы все входящие в него записи. Также удаление будет невозможным в случае, если на основе записи уже созданы записи базового или рабочего учебного плана.

3. Работа с компетенциями ФГОС

3.1. Создание перечня компетенций стандарта

В стандартах III поколения (Федеральных государственных образовательных стандартах, или ФГОС) присутствует перечень компетенций, развиваемых у студента в ходе обучения по соответствующим учебным программам. Перечень всех компетенций, перечисленных в стандарте, должен быть введен в систему. Сделать это можно, выбрав в таблице данных Образовательные стандарты нужный стандарт, и открыв подчиненную таблицу данных Компетенции в стандарте.

Добавление новой компетенции производиться при помощи действия Добавить компетенцию.

  • В поле Код компетенции нужно занести код, используемый для обозначения компетенции в стандарте.
  • В поле Тип компетенции нужно выбрать одно из предлагаемых значений из справочника типов компетенций.
  • В поле Описание компетенции нужно занести текст, разъясняющий содержание компетенции. Можно использовать стандартные действия копирования и вставки значений из других документов.

Перечень компетенций отображается сгруппированным по типам компетенций. После того, как компетенции будут связаны с определенными записями стандарта в подчиненной таблице Развитие в компонентах стандарта для каждой компетенции можно будет увидеть перечень записей стандарта, в которых она присутствует.

Перечень компетенций стандарта

В случае если в разных стандартах присутствуют схожие перечни компетенций, можно воспользоваться действиями Копировать и Вставить, вызываемыми из контекстного меню в таблице данных. Для этого нужно в главной таблице данных выбрать стандарт, для которого уже создан перечень компетеницй, в подчиненной таблице данных выбрать одну или несколько компетенций, выполнить действие Копировать. После этого выбрать другой стандарт в главной таблице, и в подчиненной таблице выполнить действие Вставить. После вставки значения кодов и описаний компетенций можно будет скорректировать.

3.2. Связь компетенций с записями стандарта

После того как сформированы записи стандарта (см. Наполнение стандарта компонентами и дисциплинами) и сформирован перечень компетенций стандарта (см. Создание перечня компетенций стандарта) можно устанавливать связи между записями стандарта и компетенциями. Для этого предназначена таблица данных, Развиваемые компетенции, расположенная на третьем уровне формы под таблицей Состав стандарта.

Компетенции могут связываться с любыми записями стандарта, как с компонентами, так и с дисциплинами. Для того, чтобы задать эту связь, нужно выбрать одну из записей стандарта, после чего в подчинненой таблице данных Развиваемые компетенции вызвать действие Добавить компетенцию.

Добавление компетенции к записи стандарта

В единственном поле формы параметров добавления компетенции нужно выбрать компетенцию из списка всех компетенций стандарта, или ввести код компетенции с клавиатуры. Для корректного поиска компетенции в перечне компетенций стандарта необходимо соблюдать регистр символов.

Полный перечень компетенций, связанных с записью стандарта, формируется многократным выполнением процедуры добавления компетенции. В случае, если нужной компетенции не найдено в перечне, предлагаемом для выбора, необходимо вернуться к этапу Создание перечня компетенций стандарта.

4. Работа с компетенциями оригинальных стандартов

В данном разделе описана реализованная в системе функциональность работы с системой компетенций. Ссистема компетенций может включать компетенции следующих видов:

  • Универсальные (системные) компетенции являются общими для всех направлений подготовки.
  • Профессиональные (инструментальные, социально-личностные) компетенции связаны с видами профессиональной деятельности.

Система компетенций состоит из общевузовских классификаторов компетенций трех основных видов: системных, социально-личностных и инструментальных, а также из перечня компетенций, формируемого для каждого из оригинальных образовательных стандартов на базе общевузовских справочников. Система компетенций включает в себя кодификацию, позволяющую отражать типологию компетенций, порядок их следования и взаимную связь друг с другом.

Работа с компетенциями оригинальных стандартов ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты.

Работа по формированию компетенций для каждого из образовательных стандартов должна включать следующие этапы:

  1. Формирование общевузовских справочников компетенций всех трех видов.
  2. Формирование перечня компетенций для образовательного стандарта, заключающееся в первичном наполнении перечня компетенциями из общевузовского справочника с дальнейшим уточнением их состава и содержания. Работа по уточнению перечня компетенций для стандарта ведется по-разному в зависимости от вида компетенции. Особенности работы с компетенциями разных видов описаны в следующих ниже разделах.

4.1. Общевузовские справочники компетенций

Работа по формированию системы компетенций оригинальных образовательных стандартов должна быть начата с формирования общевузовских классификаторов компетенций каждого из трех видов системных, социально-личностных и инструментальных.

Порядок работы с данными справочниками не существенен, однако до начала формирования перечней компетенций для конкретных образовательных стандартов общевузовские справочники компетенций должны быть сформированы полностью.

4.1.1. Системные (универсальные) компетенции

Работа с общевузовским справочником системных (универсальных) компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Системные компетенции.

Системные компетенции. Общевузовский справочник

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая системная компетенция имеет код и порядковый номер. Коды системных компетенций формируются автоматически из префикса СК-, символа уровня образования (Б или М) и порядкового номера (например, "СК-Б01", "СК-Б03", "СК-М08", "СК-М15"). Смысловое содержание компетенции представлено в поле Формулировка компетентностных образовательных результатов.

Для наполнения или уточнения общевузовского справочника системных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить системную компетенцию
  • Изменить порядковый номер
  • Удалить компетенцию
Уточнять текстовую формулировку компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter.

Добавление компетенции

Для того, чтобы добавить в справочник новую системную компетенцию, нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить системную компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление системной компетенции в общевузовский справочник

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Код компетенции значение будет составлено автоматически из префикса "СК-" (системная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура) и порядкового номера компетенции. Для порядковых номеров меньших 10 в первой позиции будет дописан 0. Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Формулировка компетентностных образовательных результатов значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой системной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера (кода) компетенции

Для изменения порядка следования компетенций предусмотрено действие контекстного меню Изменить порядковый номер. При изменении порядкового номера соответствующим образом изменится и код компетенции.

Изменение порядкового номера системной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции. При его изменении будет изменяться и код компетенции. Повтор порядковых номер компетенций недопустим. При попытке изменить порядковый номер компетенции на существующий произойдет ошибка дублирования объектов.

4.1.2. Социально-личностные компетенции

Работа с общевузовским справочником социально-личностных компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Социально-личностные компетенции.

Социально-личностные компетенции. Общевузовский справочник

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая социально-личностная компетенция имеет код и порядковый номер. Коды социально-личностных компетенций формируются автоматически из префикса СЛК-, символа уровня образования (Б или М) и порядкового номера (например, "СЛК-Б05", "СЛК-Б12", "СЛК-М02", "СЛК-М11"). Смысловое содержание компетенции представлено в поле Формулировка компетентностных образовательных результатов.

Для наполнения или уточнения общевузовского справочника социально-личностных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить социально-личностную компетенцию
  • Изменить порядковый номер
  • Удалить компетенцию
Уточнять текстовую формулировку компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter.

Добавление компетенции

Для того, чтобы добавить в справочник новую социально-личностную компетенцию, нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить социально-личностную компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление социально-личностной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Код компетенции значение будет составлено автоматически из префикса "СЛК-" (социально-личностная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура) и порядкового номера компетенции. Для порядковых номеров меньших 10 в первой позиции будет дописан 0. Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Формулировка компетентностных образовательных результатов значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера (кода) компетенции

Для изменения порядка следования компетенций предусмотрено действие контекстного меню Изменить порядковый номер. При изменении порядкового номера соответствующим образом изменится и код компетенции.

Изменение порядкового номера социально-личностной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции. При его изменении будет изменяться и код компетенции. Повтор порядковых номер компетенций недопустим. При попытке изменить порядковый номер компетенции на существующий произойдет ошибка дублирования объектов.

4.1.3. Инструментальные компетенции

Работа с общевузовским справочником инструментальных компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Инструментальные компетенции.

Инструментальные компетенции. Общевузовский справочник

Справочник имеет иерархическую структуру, которая отражает конкретизацию компетенций. Компетенции первого уровня являются наиболее общими и обозначают укрупненные виды деятельности (проектная деятельность, общение и коммуникация и проч.). Компетенция, которую конкретизирует данная компетенция, далее будет называться "родительской", а те компетенции, которые, в свою очередь, конкретизируют данную, будут называться "дочерними". Например, на представленном выше рисунке по отношению к компетенции "ИК-Б1.1 участвовать" родительской является компетенция "ИК-Б1 Проектная и иная деятельность", а дочерними являются компетенции "ИК-Б1.1н в научной деятельности" и "ИК-Б1.1и в исследовательской деятельности".

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая инструментальная компетенция имеет код и порядковый номер, а также может иметь символьное обозначение. Коды социально-личностных компетенций формируются автоматически из префикса ИК-, символа уровня образования (Б или М), собственного порядкового номера и порядковых номеров родительских компетенций, разделенных точкой, и символьного обозначения (при его наличии). Например, коды инструментальных компетенций могут иметь следующий вид: "ИК-Б1", "ИК-Б2.3", "ИК-М3.1и", "ИК-М2.2э". Для инструментальных компетенций в справочник заносится только наименование. Формулировки компетентностных образовательных результатов для компетенций данного вида будут задаваться отдельно для каждого из образовательных стандартов. Также в справочнике отображается формируемое автоматически полное наименование компетенции, составленное из наименования самой компетенции и всех ее родительских компетенций, разделенных символами "/".

Для наполнения или уточнения общевузовского справочника инструментальных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить компетенцию на первый уровень
  • Добавить дочернюю компетенцию
  • Изменить порядковый номер или символьное обозначение
  • Изменить родительскую компетенцию
  • Удалить компетенцию
Уточнять наименование компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter. Полное наименование компетенции при этом изменится автоматически.

Добавление компетенции

Для добавления инструментальных компетенций предусмотрено два действия: Добавить компетенцию на первый уровень и Добавить дочернюю компетенцию. Выбор действия зависит от того, нужно ли добавить самостоятельную компетенцию первого уровня, соответствующую укрупненному виду деятельности, которая не будет иметь родительской компетенции, или нужно добавить компетенцию, уточняющую одну из существующих (дочернюю по отношению к существующей).

Для добавления самостоятельной компетенции первого уровня нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить компетенцию на первый уровень. Отобразиться форма параметров процедуры добавления:

Добавление инструментальной компетенции на первый уровень

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего на первом уровне для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Символьное обозначение можно ввести символ, дополняющий код компетенции, если это необходимо. Если символьное обозначение для данной компетенции не используется, поле нужно оставить пустым.
  • В поле Код компетенции значение будет составлено автоматически из префикса "ИК-" (инструментальная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура), порядкового номера компетенции, символьного обозначения (если оно использовано). Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Наименование компетенции значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Для добавления компетенции, конкретизирующей одну из существующих, нужно сначала выбрать существующую (родительскую) компетенцию, которая должна быть конкретизирована, после чего вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить дочернюю компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление дочерней инструментальной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Родительская компетенция будет отображен код родительской компетенции, которая была выбрана в таблице данных перед вызовом действия добавления. Если новая компетенция должна быть подчинена другой родительской компетенции, то нужно закрыть данную форму при помощи кнопки Отмена, выбрать в таблице данных нужную родительскую компетенцию и снова вызвать действие добавления дочерней компетенции.
  • В поле Уровень образования значение будет подставлено автоматически на основе выбранной родительской компетенции. Изменять это значение при добавлении недопустимо. Если нужно добавить компетенцию для другого уровня образования, то нужно закрыть данную форму, выбрать в таблице данных родительскую компетенцию, принадлежащую к другому уровню образования и повторить добавление.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего на данном уровне иерархии для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Символьное обозначение можно ввести символ, дополняющий код компетенции, если это необходимо. Если символьное обозначение для данной компетенции не используется, поле нужно оставить пустым.
  • В поле Код компетенции значение будет составлено автоматически из префикса "ИК-" (инструментальная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура), порядкового номера компетенции и ее родительских компетенций, символьного обозначения (если оно использовано). Управлять значением данного поля можно изменяя порядковый номер, символьное значение или выбрав другую родительскую компетенцию перед добавлением.
  • В поле Наименование компетенции значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Удаление компетенции, имеющей дочерние компетенции, недопустимо. Если такую компетенцию все же надо удалить, то сначала нужно удалить все ее дочерние компетенции.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера и символьного обозначения компетенции

Для изменения порядка следования компетенций и их символьных обозначений предусмотрено действие контекстного меню Изменить порядковый номер или символьное обозначение. При изменении порядкового номера или символьного обозначения соответствующим образом изменится и код компетенции.

Изменение порядкового номера или символьного обозначения инструментальной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции и символьное обозначение. При изменении этих значений будет изменяться и код компетенции. Повтор полученных кодов компетенций недопустим. При попытке изменить порядковый номер или символьное обозначение таким образом, что полученный код компетенции будет повторять один из существующих, произойдет ошибка дублирования объектов.

Перенос компетенций по иерархической структуре

Для того, чтобы перенести существующую компетенцию по структуре (т.е. изменить для нее родительскую компетенцию), можно воспользоваться действием Изменить родительскую компетенцию.

Изменение родительской компетенции для инструментальной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Родительская компетенция нужно выбрать другую компетенцию из предложенного перечня, которая должна стать родительской по отношению к данной.
  • Значение полей Уровень образования и Наименование компетенции при использовании данной процедуры изменять нельзя.
  • В полях Порядковый номер и Символьное обозначение можно изменять значения описанным выше образом. Также при этом будет изменяться значение в поле Код компетенции.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о компетенции изменит свое положение в иерархической структуре. Также ей будут присвоены новые значения порядкового номера, сиваольного обозначения и кода.

4.2. Формирование и уточнение перечня компетенций для оригинального образовательного стандарта

При формировании на основе общевузовских справочников перечней компетенций для каждого из образовательных стандартов действуют следующие принципы:

  1. Системные (универсальные) компетенции переносятся в каждый из образовательных стандартов в полном соответствии с общевузовским справочником. Изменение перечня системных компетенций, их формулировок или кодов в конкретном стандарте недопустимо.
  2. Формулировки социально-личностных компетенций в каждом из образовательном стандарте могут уточнятся. При этом код компетенции автоматически получит постфикс, соответствующий аббревиатуре направления подготовки.
  3. Общевузовский справочник инструментальных компетенций имеет иерархическую структуру. Для инструментальных компетенций в общевузовском справочнике задаются только их наименования. Формулировка компетентностных образовательных результатов для инструментальных компетенций заносится только при добавлении компетенции в стандарт.
  4. В образовательный стандарт могут добавляться дополнительные социально-личностные компетенции, не связанные с компетенциями из общевузовского справочника. Добавление в стандарты системных и инструментальных компетенций, не связанных с общевузовскими справочниками, недопустимо.

Работа по формированию и уточнению перечня компетенций для каждого из образовательных стандартов ведется в форме Образовательные стандарты. Для того, чтобы просмотреть, сформировать или отредактировать перечень компетенций для стандарта, нужно выбрать этот стандарт на вкладке Образовательные стандарты и открыть подчиненную таблицу Компетенции в оригинальном стандарте.

До начала работы по формированию перечня компетенций для образовательных стандартов должны быть полностью сформированы Общевузовские справочники компетенций.

Для формирования и уточнения перечня компетенций в таблице данных Компетенции в оригинальном стандарте доступны действия, позволяющие:

  • переносить в образовательный стандарт полный набор компетенций определенного вида, занесенных в общевузовский справочник
  • добавлять к образовательному стандарту компетенции по одной
  • уточнять формулировку и код компетенции (доступно для социально-личностных и инструментальных компетенций)
  • удалять ошибочно добавленные компетенции

Коды компетенций, добавляемых в стандарт, могут отличаться от кодов, заданных в общевузовском справочнике. Отличие, как правило, заключается в дописывании к коду компетенции из общевузовского справочника аббревиатуры направления подготовки.

Аббревиатуры направлений подготовки задаются в общевузовском справочнике пользователями, наделенными правами на работу с данным справочником. Каждый образовательный стандарт относится к определенному направлению подготовки. Если аббревиатура направления не отображается в таблице "Образовательные стандарты" или отображается неверно, нужно обратиться к пользователю, ответственному за работу со справочником направлений и специальностей с просьбой уточнить аббревиатуру нужного направления.

4.2.1. Формирование перечня системных компетенций

Системные (универсальные) компетенции переносятся в каждый из образовательных стандартов в полном соответствии с общевузовским справочником. Изменение перечня системных компетенций, их формулировок или кодов в конкретном стандарте недопустимо.

Для переноса полного перечня системных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все системные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень системных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. Изменять формулировки или коды системных компетенций по сравнению с общевузовским справочником недопустимо.

Системные компетенции в образовательном стандарте

Если после последнего формирования перечня системных компетенций для стандарта произошло добавление системных компетенций в общевузовский справочник, действие Добавить все системные компетенции можно вызвать повторно. Его выполнение приведет к добавлению недостающих системных компетенций, коды и формулировки существующих компетенций будут приведены в соответствие со значениями из общевузовского справочника.

Если возникла необходимость удалить одну из системных компетенций, добавленных к стандарту, из общевузовского справочника, потребуется предварительно удалить ее из стандарта. Для этого необходимо выбрать удаляемую компетенцию в списке и выполнить действие Удалить компетенцию.

Если компетенция была удалена из стандарта ошибочно, или если перечень системных компетенций в общевузовском справочнике был расширен, отдельную системную компетенцию можно добавить в стандарт при помощи действия Добавить компетенцию... / системную компетенцию.

Добавление системной компетенции

Для добавления нужно в поле Компетенция из общевузовского справочника выбрать добавляемую компетенцию из общевузовского справочника системных компетенций. Формулировка выбранной компетенции отобразится в поле Формулировка компетентностных образовательных результатов автоматически. Изменение кода или формулировки системной компетенции недопустимо. После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте.

Повторное добавление компетенции в стандарт недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

4.2.2. Формирование перечня социально-личностных компетенций

Социально-личностные компетенции переносятся в каждый из образовательных стандартов в соответствии с общевузовским справочником. При этом в конкретном образовательном стандарте формулировка социально-личностной компетенции может быть изменена. При изменении формулировки изменяется и код социально-личностной компетенции - к нему дописывается аббревиатура направления подготовки.

В отличие от других видов компетенций в образовательный стандарт могут добавляться социально-личностные компетенции, не связанные с соответствующими компетенциями общевузовского справочника. Далее такие компетенции называются дополнительные социально-личностные компетенции.

Перенос социально-личностных компетенций из общевузовского справочника в образовательный стандарт можно выполнять одним из двух способов:

  • Добавить все социально-личностные компетенции из общевузовского справочника, после чего уточнить формулировки и коды тех компетенций, для которых это необходимо (рекомендуется в случае, если не планируется существенных изменений по сравнению с общевузовским справочником)
  • Добавлять социально-личностные компетенции по одной с одновременным уточнением их формулировок и кодов (рекомендуется в случае, если состав и содержание социально-личностных компетенций в стандарте должно существенно отличаться от общевузовского справочника)

Формирование перечня социально-личностных компетенций

Для переноса полного перечня социально-личностных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все социально-личностные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень социально-личностных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. После добавления коды и формулировки компетенций можно будет уточнить.

Социально-личностные компетенции в образовательном стандарте

Если после последнего формирования перечня социально-личностных компетенций для стандарта произошло добавление компетенций данного вида в общевузовский справочник, действие Добавить все социально-личностные компетенции можно вызвать повторно. Его выполнение приведет к добавлению недостающих системных компетенций, коды и формулировки существующих компетенций будут приведены в соответствие со значениями из общевузовского справочника.

Отдельную социально-личностную компетенцию, имеющую соответствие в общевузовском справочнике, можно добавить в стандарт при помощи действия Добавить компетенцию... / социально-личностную компетенцию. Одновременно с добавлением компетенции можно выполнить и ее уточнение.

Добавление социально-личностной компетенции

Для добавления нужно в поле Компетенция из общевузовского справочника выбрать добавляемую компетенцию из общевузовского справочника социально-личностных компетенций. Формулировка выбранной компетенции отобразится в поле Формулировка компетентностных образовательных результатов (значение из общевузовского справочника, недоступно для изменения). Та же формулировка отобразится в поле Формулировка компетентностных образовательных результатов (в стандарте). Если формулировку компетенции в стандарте нужно изменить, это можно сделать в поле, доступном для редактирования. Если изменение формулировки произведено, код компетенции будет дополнен аббревиатурой направления.

После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте. В таблице будут отображены как значения кода и формулировки, уточненные для стандарта, так и значения из общевузовского справочника.

Повторное добавление в стандарт компетенции, ссылающейся на ту же запись общевузовского справочника, недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

Для добавления дополнительной социально-личностной компетенции, не связанной с общевузовским справочником, предназначено действие Добавить компетенцию... / дополнительную социально-личностную компетенцию.

Добавление дополнительной социально-личностной компетенции

Для добавления нужно занести формулировку компетенции и ее порядковый номер. Для дополнительных компетенций необходимо использовать порядковые номер от 101 до 200. Код компетенции будет сформирован автоматически из префикса"СЛК-", порядкового номера и аббревиатуры направления подготовки.

После нажатия кнопки ОК дополнительная компетенция будет добавлена в стандарт. В таблице всех компетенций стандарта для дополнительных социально-личностных компетенций в колонках Код общевузовской компетенции и Формулировка компетентностных образовательных результатов (общевуз.) будут отображены пустые значения.

Уточнение социально-личностных компетенций

Социально-личностные компетенции, ранее добавленные в стандарт, могут уточняться по сравнению с компетенциями общевузовского справочника. Для того, чтобы уточнить компетенцию, нужно выбрать ее в таблице данных, после чего вызвать действие Уточнить компетенцию... / социально-личностную компетенцию

Уточнение социально-личностных компетенций

Уточнение компетенции заключается к корректировке ее формулировки по сравнению с формулировкой, заданной в общевузовском справочнике. Если формулировка изменена, в код компетенции будет автоматически дописана аббревиатура направления подготовки.

Удаление социально-личностной компетенции

Если возникла необходимость удалить одну из социально-личностных компетенций, добавленных к стандарту, нужно выбрать ее в таблице данных и воспользоваться действием Удалить компетенцию.

4.2.3. Формирование перечня инструментальных компетенций

Формирование перечня инструментальных компетенций для образовательного стандарта заключается в выборе соответствующих инструментальных компетенций из общевузовского справочника и занесения их формулировок. Так как в общевузовском справочнике инструментальных компетенций формулировки компетенций не заносятся, при добавлении инструментальных компетенций в стандарт формулировки должны быть заданы для каждой компетенции. Коды инструментальных компетенций в стандарте будут сформированы автоматически на основе кода компетенции в общевузовском справочнике и аббревиатуры направления подготовки.

Добавление в стандарт инструментальных компетенций, не связанных ни с одной записью общевузовского справочника, недопустимо.

Формирование перечня инструментальных компетенций для стандарта на основе общевузовского справочника можно выполнять одним из двух способов:

  • Добавить все инструментальные компетенции из общевузовского справочника, после чего уточнить все их формулировки и коды
  • Добавлять инструментальные компетенции по одной с одновременным уточнением их формулировок и кодов

Формирование перечня инструментальных компетенций

Для переноса полного перечня инструментальных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все инструментальные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень социально-личностных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. В качестве формулировки компетенции будет подставлено ее наименование их общевузовского справочника. После добавления инструментальных компетенций коды и формулировки всех компетенций необходимо будет уточнить.

Инструментальные компетенции в стандарте

По одной инструментальные компетенции можно добавлять при помощи действия Добавить компетенцию... / инструментальную компетенцию. Одновременно с добавлением компетенции можно выполнить и ее уточнение.

Добавление инструментальной компетенции в стандарт

Для добавления инструментальной компетенции нужно занести ее формулировку в поле Формулировка компетентностных образовательных результатов, после чего в поле Компетенция из общевузовского справочника выбрать наиболее подходящую общевузовскую компетенцию. Для удобства выбора общевузовский справочник инструментальных компетенций отображается в виде иерархической структуры. При этом для добавления в стандарт необходимо выбирать компетенции, не имеющие дочерних компетенций.

После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте. В таблице будут отображены как значения кода и формулировки, уточненные для стандарта, так и значения кода и наименования из общевузовского справочника.

Повторное добавление в стандарт компетенции, ссылающейся на ту же запись общевузовского справочника, недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

Уточнение инструментальных компетенций

Инструментальные компетенции, ранее добавленные в стандарт, могут уточняться по сравнению с компетенциями общевузовского справочника. Для того, чтобы уточнить компетенцию, нужно выбрать ее в таблице данных, после чего вызвать действие Уточнить компетенцию... / инструментальную компетенцию.

Уточнение инструментальных компетенций

Уточнение компетенции заключается к корректировке ее формулировки. Также при уточнении формулировки в код компетенции будет автоматически дописана аббревиатура направления подготовки.

Удаление инструментальной компетенции

Если возникла необходимость удалить одну из инструментальных компетенций, добавленных к стандарту, нужно выбрать ее в таблице данных и воспользоваться действием Удалить компетенцию.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Планирование реализации дисциплин (раздел целиком) (31.03.2018) Одним файлом
Планирование реализации дисциплин

Для планирования реализации дисциплин и НИС, преподаваемых кафедрой, необходимо выполнить формирование предметных единиц (предметных потоков, предметных групп, предметных подгрупп) для всех дисциплин и НИС, которые будут преподаваться кафедрой в очередном учебном году. Данные предметные единицы будут использованы при планировании нагрузки, для составления расписания занятий, для оценки фактически выполненной кафедрой учебной нагрузки.

В форме Планирование реализации дисциплин на вкладке Студенты, изучающие дисциплину, можно увидеть список студентов, которым дисциплина уже назначена. На основе этой информации можно оценить необходимое количество предметных потоков, групп, подгрупп. По мере включения академических групп в предметные единицы и распределения студентов по предметным единицам эта информация будет отображаться на подчиненных вкладках Связанные академические группы и на вкладке Студенты, изучающие дисциплину в колонках Предметный поток, Предметная группа, Предметная подгруппа, отдельно по каждому студенту.

Пользователи кафедр формируют предметные единицы, устанавливают максимальное количество студентов, которое может быть в них включено, и накладывают ограничения на использование предметных единиц. Включение студентов в предметные единицы будут выполнять Менеджеры образовательных программ, ответственные за организацию обучения студентов. Менеджерам образовательных программ будут доступны предметные единицы с учетом наложенных ограничений и они не смогут включить в предметную единицу больше студентов, чем установлено пользователем кафедры. Для случаев, когда кафедра не считает нужным ограничивать количество студентов, которые могут быть включены в предметную единицу, атрибут Максимальное количество студентов можно оставить пустым.

Формирование предметных единиц обязательное действие в следующих случаях:

  1. Создание предметных потоков для дисциплин обязательно, если есть лекции, проведение экзаменов в письменной форме.
  2. Создание предметных потоков для НИС обязательно во всех случаях.
  3. Создание предметных групп для дисциплин обязательно, если есть семинары, тренинги; при обучении по семестрам (для учета консультаций перед экзаменом).
  4. Создание предметных групп для НИС обязательно во всех случаях
  5. Создание предметных подгрупп для дисциплин обязательно, если есть практические, лабораторные работы, мастер-классы.
  6. Создание предметных подгрупп для НИС необязательно.

Для формирования предметных единиц необходимо выполнить ряд действий:

1. Формирование предметных потоков

Представление (таблица данных) Предметные потоки содержит перечень предметных потоков для каждой дисциплины кафедры. Для добавления предметных потоков необходимо:

Создание предметных потоков обязательно:
  1. Для всех НИС.
  2. Для дисциплин, если есть лекции, проведение экзаменов в письменной форме.
  1. Открыть раздел Планирование реализации дисциплин и выбрать дисциплину или НИС, для которой будут формироваться предметные единицы.
  2. В подчиненном представлении (таблице данных) Предметные потоки из контекстного меню вызвать действие Добавить предметный поток.
    Вызвов действия добавить предметный поток
  3. В форме параметров ввести Краткое наименование, при необходимости можно ограничить число студентов в потоке, указав Максимальное количество студентов на потоке.
  4. Нажать кнопку ОК.

Для редактирования существующих записей предметных единиц, необходимо дважды щелкнуть левой клавишей мыши по ячейке с параметром, который нужно изменить, ввести новое значение и нажать кнопку Enter.

После того как предметная единица была создана необходимо установить ограничения на ее использование см. Установка ограничений на использование предметных единиц.

2. Формирование предметных групп

Представление (таблица данных) Предметные группы содержит перечень предметных групп для каждой дисциплины кафедры. Предметные группы можно связывать с предметными потоками (в случаях, когда предметный поток формируется из определенных предметных групп), а можно создавать без связи с предметными потоками. Для добавления предметных групп необходимо:

Создание предметных групп обязательно:
  1. Для всех НИС.
  2. Для дисциплин, если есть семинары, тренинги; при обучении по семестрам (для учета консультаций перед экзаменом).
  1. Открыть раздел Планирование реализации дисциплин и выбрать дисциплину или НИС, для которой будут формироваться предметные единицы.
  2. В подчиненном представлении (таблице данных) Предметные группы из контекстного меню вызвать действие Добавить предметную группу.
    Вызов действия добавить предметную группу
  3. В форме параметров ввести Краткое наименование, при необходимости можно ограничить число студентов в группе, указав Максимальное количество студентов в группе. Также можно установить связь группы с потоком, выбрав в поле Входит в предметный поток соответствующий поток из справочника Предметные потоки (кнопка Справочник).
  4. Нажать кнопку ОК.

Для редактирования существующих записей предметных единиц, необходимо дважды щелкнуть левой клавишей мыши по ячейке с параметром, который нужно изменить, ввести новое значение и нажать кнопку Enter.

После того как предметная единица была создана необходимо установить ограничения на ее использование см.Установка ограничений на использование предметных единиц.

3. Формирование предметных подгрупп

Представление (таблица данных) Предметные подгруппы содержит перечень предметных подгрупп для каждой дисциплины кафедры. Предметные подгруппы можно связывать с предметными группами, а можно создавать независимо от предметных групп. Для добавления предметных подгрупп необходимо:

  1. Открыть раздел Планирование реализации дисциплин и выбрать дисциплину или НИС, для которой будут формироваться предметные единицы.
  2. В подчиненном представлении (таблице данных) Предметные подгруппы из контекстного меню вызвать действие Добавить предметную подгруппу.
    Вызов действия добавить предметную подгруппу
  3. В форме параметров ввести Краткое наименование, при необходимости можно ограничить число студентов в подгруппе, указав Максимальное количество студентов в подгруппе. Также можно установить связь подгруппы с группой, выбрав в поле Входит в предметную группу соответствующую группу из справочника Предметные группы (кнопка Справочник).
  4. Нажать кнопку ОК.

Для редактирования существующих записей предметных единиц, необходимо дважды щелкнуть левой клавишей мыши по ячейке со значением атрибута, который нужно изменить, ввести новое значение и нажать кнопку Enter.

Создание предметных подгрупп обязательно только для дисциплин, если есть практические, лабораторные работы, мастер-классы. Формирование предметных подгрупп для НИС необязательно.

После того как предметная единица была создана необходимо установить ограничения на ее использование см.Установка ограничений на использование предметных единиц

4. Установка ограничений на использование предметных единиц

После того как предметные единицы были созданы (см. Формирование предметных потоков, Формирование предметных групп и Формирование предметных подгрупп) необходимо установить ограничения на их использование, для этого необходимо:
Если предметная единица должна быть доступна Менеджерам образовательных программ всех Филиалов, Факультетов и Образовательных программ, то устанавливать ограничения нет необходимости.

  1. Открыть представление (таблицу данных) Предметные потоки, Предметные группы или Предметные подгруппы и выбрать предметную единицу.
  2. В подчиненном представлении (таблице данных) Ограничения использования потока, Ограничения использования группы или Ограничения использования подгруппы из контекстного меню вызвать действие Добавить ограничение.
    Вызов действия Добавить ограничение
  3. В форме установить Филиал, Факультет (при необходимости) и Образовательную программу (при необходимости).
  4. Нажать кнопку ОК. После чего предметная единица будет доступна только Менеджерам образовательных программ добавленного в ограничения Филиала, Факультета и Образовательной программы.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Ход согласования учебных планов (раздел целиком) (31.03.2018) Одним файлом
Ход согласования учебных планов

Базовые, рабочие и объединенные учебные планы могут участвовать в процедурах согласования и утверждения. Переход плана с одного этапа согласования на другой заключается в смене статуса плана, а также в изменении режима доступа пользователей к данным плана.

Процессы согласования объединенных и базовых (рабочих) учебных планов отличаются, графически их можно представить следующим образом:

  1. Процесс согласования базовых и рабочих учебных планов:

    Ход согласования учебных планов

  2. Процесс согласования объединенных учебных планов:

    Согласование объединенного учебного плана

  3. Процесс согласования объединенных учебных планов аспирантуры:

    Схема согласования ОУП аспирантуры

1. Мониторинг готовности учебных планов факультетов и отделений

В форме Ход согласования учебных планов в таблицах данных Базовые учебные планы и Рабочие учебные планы представлены планы, доступные для просмотра пользователю. Пользователи-разработчики планов от отдельного факультета или отделения могут просматривать только планы своего факультета (отделения). Пользователи, принадлежащие к ролям методического управления, проректора и первого проректора могут просматривать планы всех факультетов и отделений.

За счет возможностей таблиц данных можно просматривать статусы планов по факультетам и отделениям, направлениям и специальностям, магистерским программам, учебным годам, курсам и т.д.

Мониторинг состояния БУП

2. Работа Ректора

Работа ректора, утверждающего учебные планы, состоит в следующем:

Согласование планов
Для согласования доступны планы, переведенные первым проректором в статус на утверждении ректором. С планами, находящимися в этом статусе, первый проректор может выполнять следующие действия:

  • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
  • Если по итогам работы с планом ректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в МУ.
  • Если у ректора нет критических замечаний к плану, он должен выполнить действие Утвердить.
  • Отслеживание статусов планов
    Первому проректору доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

3. Работа пользователя-разработчика плана

Работа пользователя, разрабатывающего учебный план, состоит из следующих этапов:

  1. Создание проекта плана
    При создании базового, рабочего учебного плана или объединенного учебного плана, план получает статус проект. В процессе создания базового учебного плана для факультетов филиалов, требуется указать "ведущий" факультет ВУЗа, с которым необходимо согласовать план, что описано в разделе Создание нового базового учебного плана. После создания, план наполняется на основании источника (стандарта или базового плана) и дополняется всей необходимой информацией, что описано в разделах Редактирование базового учебного плана, Редактирование рабочего учебного плана, Редактирование объединенного учебного плана. После того, как разработчик завершил первичное формирование плана, он должен выполнить действие Направить на согласование с деканом факультета.
  2. Согласование с деканом факультета
    На данном этапе разработчик плана не может корректировать план, но может просматривать замечания, сформулированные деканом факультета. Если декан факультета примет решение о возврате плана на доработку, то план перейдет в статус корректировка разработчиком и разработчик снова сможет корректировать план. Если же декан факультета примет решение о согласовании плана и направлении его на дальнейшее согласование, то от разработчика дальнейших действий не потребуется, они сможет только следить за дальнейшим изменением статусов плана.
  3. Корректировка разработчиком
    На этом этапе разработчик может вносить в план любые изменения на основе замечаний, полученных от декана факултета. По завершении работы разработчик снова должен выполнить действие Направить на согласование с деканом факультета.
  4. Отслеживание статуса плана
    После того, как план согласован с деканом факультета, активная работа разработчика заканчивается. План будет переводиться из одного статуса в другой другими пользователями. Разработчик сможет получать сообщения об изменении статуса планов, а также просматривать состояние статусов всех планов в таблице данных Базовые учебные планы или Рабочие учебные планы.

4. Работа разработчика ОУП аспирантуры

Работа пользователя, разрабатывающего ОУП аспирантуры, состоит из следующих этапов:

  1. Создание проекта плана
    При создании объединенного учебного плана, план получает статус проект. После создания, план наполняется на основании источника (стандарта) и дополняется всей необходимой информацией, что описано в разделе Редактирование объединенного учебного плана аспирантуры. После того, как разработчик завершил первичное формирование плана, он должен выполнить действие Направить на согласование с Директором аспирантской школы.
  2. Согласование с Директором аспирантской школы
    На данном этапе разработчик плана не может корректировать план, но может просматривать замечания, сформулированные директором аспирантской школы. Если директор аспирантской школы примет решение о возврате плана на доработку, то план перейдет в статус корректировка разработчиком и разработчик снова сможет корректировать план. Если же директор аспирантской школы примет решение о согласовании плана и направлении его на дальнейшее согласование, то от разработчика дальнейших действий не потребуется, они сможет только следить за дальнейшим изменением статусов плана.
  3. Корректировка разработчиком
    На этом этапе разработчик может вносить в план любые изменения на основе замечаний, полученных от директора аспирантской школы. По завершении работы разработчик снова должен выполнить действие Направить на согласованиес Директором аспирантской школы.
  4. Отслеживание статуса плана
    После того, как план согласован с директором аспирантской школы, план будет переводиться из одного статуса в другой другими пользователями, при этом на любом из этапов план может быть передан разработчику на корректировку. Разработчик сможет получать сообщения об изменении статуса планов, а также просматривать состояние статусов всех планов в представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры).

5. Работа разработчика учебного плана лицея

Работа пользователя, разрабатывающего учебные планы лицея, состоит из следующих этапов:

  1. Создание проекта плана
    При создании плана, план получает статус проект. После того, как разработчик завершил первичное формирование плана, он должен выполнить действие Направить на согласование с УРОП.
  2. Согласование с пользователями методического управления
    На данном этапе разработчик плана не может корректировать план, но может просматривать замечания, сформулированные пользователями методического управления. Если методическое управление примет решение о возврате плана на доработку, то план перейдет в статус корректировка разработчиком и разработчик снова сможет корректировать план. Если же методическое управление примет решение о согласовании плана и направлении его на дальнейшее согласование, то от разработчика дальнейших действий не потребуется, он сможет только следить за дальнейшим изменением статусов плана.
  3. Корректировка разработчиком
    На этом этапе разработчик может вносить в план любые изменения на основе замечаний, полученных от пользователей, согласующих план. По завершении работы разработчик снова должен выполнить действие Направить на согласованиес УРОП.
  4. Отслеживание статуса плана
    После того, как план согласован с УРОП, план будет переводиться из одного статуса в другой другими пользователями. Разработчик сможет получать сообщения об изменении статуса планов, а также просматривать состояние статусов всех планов в представлении Учебные планы лицея (форма Учебные планы лицея).

6. Работа декана факультета

Работа декана факультета, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные разработчиками в статус согласование с деканом факультета. С планами, находящимися в этом статусе декан факультета может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом деканом факультета принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени декана факультета. При этом, при появлении необходимости редактирования плана после этого, декан факультета может воспользоваться действием Отозвать согласование деканом факультета, после чего он сможет осуществлять редактирование плана.
    • После того, как декан факультета согласовал план, он должен выполнить действие Направить на утверждение. При этом, если декан факультета является деканом факультета филиала и требуется согласование с "ведущим" факульетом, он пользуется действием Направить на согласование с ведущим факультетом . Если же, он является деканом "ведущего" факультета ВУЗа, то он должен воспользоваться действием Направить на согласование с МУ (Методическим управлением). В отношении учебных планов, для которых установлен признак Является программой ДПО, необходимо воспользоваться действием Направить на согласование с МУ.
      Следует учитывать, что параметру Является программой ДПО будет присвоено значение Да только для БУП, разработанных пользователями-разработчиками подразделений ДПО. Для всех остальных подразделений будет установлено значение Нет.
  2. Отслеживание статусов планов
    Декану факультета доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

7. Работа декана "ведущего" факультета

Работа декана ведущего факультета, согласующего учебные планы, состоит в следующем:

Согласование планов
Для согласования доступны планы, переведенные деканами факультетов филиалов в статус согласование с ведущим факультетом. Также доступны планы собственного факультета, переведенными разработчиками в статус согласование с деканом факультета. С планами, находящимися в этих статусах декан ведущего факультета может выполнять следующие действия:

  • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
  • Если по итогам работы с планом деканом ведущего факультета принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику или вернуть на доработку (деканам факультетов филиала).
  • Если у декана ведущего факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от ведущего факультета. При этом, при появлении необходимости редактирования плана после этого, декан факультета может воспользоваться действием Отозвать согласование ведущим факультетом, после чего он сможет осуществлять редактирование плана.
  • После того, как декан ведущего факультета согласовал план факультета филиала, он должен выполнить действие Направить на согласование с зам. директора филиала. После согласования плана собственного факультета, он направляется на согласование с МУ. При этом, декан факультета пользуется действием Направить на согласование с МУ (Методическим Управлением).
  • Отслеживание статусов планов
    Декану ведущего факультета доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

8. Работа директора аспирантской школы

Работа директора аспирантской школы, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные разработчиками в статус на согласовании с Директором аспирантской школы. С планами, находящимися в этом статусе директор аспирантской школы может выполнять следующие действия (все действия с учебными планами выполняются в форме На согласовании с Директором аспирантской школы):
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом директором аспирантской школы принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у директора аспирантской школы нет критических замечаний к плану, он должен выполнить действие Согласовать план. При этом, при появлении необходимости редактирования плана, директор аспирантской школы может воспользоваться действием Отозвать согласование, после чего он сможет осуществлять редактирование плана.
    • После того, как директор аспирантской школы согласовал план, он должен выполнить действие Направить на согласование УАД.

9. Работа управления аспирантуры и докторантуры

Работа пользователей, состоит из следующих этапов:

  1. Отслеживание статусов планов
    Пользователям Управления аспирантуры и докторантуры доступны для просмотра объединенные учебные планы аспирантуры всех аспирантских школ, находящиеся во всех статусах. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) пользователи УАД могут видеть картину готовности планов по аспирантским школам, учебным годам и проч.
  2. Согласование планов
    С планами, находящимся в статусе Направить на согласование с УАД пользователи УАД могут выполнять следующие операции:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом пользователем УАД принято решение вернуть план разработчику, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у пользователя УАД нет критических замечаний к плану, он должен выполнить действие Согласовать план.
    • После того, как пользователь УАД согласовал план, он должен выполнить действие Направить на согласование с зам. директора филиала для планов аспирантов филиала, и Направить на утверждение проректором для всех остальных планов аспирантуры.

10. Работа Заместителя директора филиала

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

10.1. Согласование БУП и РУП

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

10.2. Согласование ОУП аспирантуры

Работа заместителя директора филиала, согласующего объединенные учебные планы аспирантуры, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы в представлении Объединенные учебные планы аспирантуры, в данном представлении отображаются планы, переведенные директорами аспирантских школ в статус на согласовании с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у зам.директора филиала нет критических замечаний к плану, он должен выполнить действие Согласовать план. При этом, при появлении необходимости редактирования плана, заместитель директора филиала может воспользоваться действием Отозвать согласование, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на утверждение проректором.

10.3. Согласование ОУП

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у зам.директора филиала нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Объединенные учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

11. Работа пользователей методического управления

Работа пользователей Методического управления, состоит из следующих этапов:

  1. Отслеживание статусов планов
    Пользователям Методического управления доступны для просмотра объединенные, базовые и рабочие учебные планы и майноры, объединенные планы факультетских дисциплин, базовые и рабочие планы аспирантуры, учебные планы лицея, находящиеся во всех статусах. В соответствующих представлениях формы На согласовании с УРОП пользователи УРОП могут видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.
  2. Согласование планов от имени УРОП
    С планами, находящимися в статусе на согласовании с УРОП пользователи Методического управления могут выполнять следующие операции:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания, как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом пользователем МУ принято решение вернуть план разработчику, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у пользователя МУ нет критических замечаний к плану, он должен выполнить действие Согласовать от имени УРОП.
    • После того, как пользователь УРОП согласовал план, он должен выполнить действие Направить на согласование с Директором по ДПО для планов ДПО, и Направить на согласование с проректором для всех остальных планов.
  3. Согласование с проректором и Директором по ДПО
    На данном этапе пользователь УРОП не может вносить замечания в план. Он может только просматривать замечания и комментарии, сделанные проректором и директором по ДПО. Если проректором будет принято решение вернуть план на доработку в УРОП, то план перейдет в статус на согласовании с УРОП, и пользователи УРОП снова смогут работать с планом.
  4. Утверждение плана
    На данном этапе пользователь УРОП не может вносить замечания в план. Он может только просматривать замечания и комментарии, сделанные проректором или Директором по ДПО. Если проректором или Директором по ДПО будет принято решение вернуть план на доработку в УРОП, то план перейдет в статус на согласовании с УРОП, и пользователи УРОП снова смогут работать с планом. Если план будет утвержден, то для всех пользователей он будет доступен только для просмотра.

12. Работа Директора по ДПО

Работа Директора по ДПО, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные пользователями МУ в статус согласование с Директором по ДПО. С планами, находящимися в этом статусе Директор по ДПО может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом Директором по ДПО принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в МУ.
    • Если у Директора по ДПО нет критических замечаний к плану, он должен выполнить действие Согласовать от имени Директора по ДПО. При этом, при появлении необходимости редактирования плана после этого, Директор по ДПО филиала может воспользоваться действием Отозвать согласование Директора по ДПО, после чего он сможет осуществлять редактирование плана.
    • После того, как Директор по ДПО согласовал план, он должен выполнить действие Направить на согласование с проректором.
  2. Отслеживание статусов планов
    Директору по ДПО доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

13. Работа проректора, согласующего планы

Работа проректора, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные пользователями УРОП, а также директором по ДПО в статус согласование с проректором. С планами, находящимися в этом статусе проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания, как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в УРОП.
    • Если у проректора нет критических замечаний к плану, он должен выполнить действие Согласовать от имени проректора. При появлении необходимости редактирования плана после этого, проректор может воспользоваться действием Отозвать согласование проектором, после чего он сможет осуществлять редактирование плана.
    • После того, как проректор согласовал план, он должен выполнить действие Направить на согласование с первым проректором для базовых учебных планов студентов и аспирантов и Направить на утверждение для остальных планов.
  2. Отслеживание статусов планов
    Проректору доступны для просмотра объединенные, базовые, рабочие учебные планы и майноры студентов, объединенные планы факультетских дисциплин, базовые и учебные планы аспирантуры, учебные планы лицея, находящиеся во всех статусах. В соответствующих представлениях формы На согласовании / утверждении проректором можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

14. Работа проректора, утверждающего ОУП аспирантуры

Работа проректора, утверждающего объединенные учебные планы аспирантуры, состоит в следующем:

  1. Утверждение планов
    Для утверждения доступны планы, переведенные пользователями УАД или заместителем директора филиала в статус на утверждении с проректором. С планами, находящимися в этом статусе проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у проректора нет критических замечаний к плану, он должен выполнить действие Утвердить план. При этом, при появлении необходимости редактирования плана, проректор может воспользоваться действием Отозвать утверждение, после чего он сможет осуществлять редактирование плана.
  2. Отслеживание статусов планов
    Проректору доступны для просмотра ОУП аспирантуры всех аспирантских школ, находящиеся во всех статусах. В представлении Объединенные учебные планы аспирантуры можно видеть картину готовности планов по аспирантским школам, учебным годам и проч.

15. Работа первого проректора согласующего / утверждающего планы

Работа первого проректора, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные проректором в статус на согласовании с первым проректором. С планами, находящимися в этом статусе, первый проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания, как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом первым проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в УРОП.
    • Если у первого проректора нет критических замечаний к плану, он должен выполнить действие Согласовать. При появлении необходимости редактирования плана после этого, первый проректор может воспользоваться действием Отозвать согласование первым проректором, после чего он сможет осуществлять редактирование плана.
    • После того, как первый проректор согласовал план, он должен выполнить действие Направить на утверждение ректором.
    • В отношении Объединенных учебных планов, Объединенных планов факультетских дисциплин и Объединенных майноров, при отсутствии критических замечаний, первый проректор должен выполнить действие Утвердить план.
  2. Утверждение планов
    Для утверждения доступны планы, переведенные проректором в статус на утверждении первым проректором. С планами, находящимися в этом статусе, первый проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом первым проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в УРОП.
    • Если у первого проректора нет критических замечаний к плану, он должен выполнить действие Утвердить план.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Отчеты о фактической затратности (раздел целиком) (31.03.2018) Одним файлом
Отчеты о фактической затратности

Для оценки фактической затратности реализации образовательных программ представлены следующие отчеты:

  • Оценка фактической затратности ОП
  • Сводный отчет по затратности ОП в учебном году
  • Сводный отчет по затратности ОП по годам

1. Оценка фактической затратности ОП

Для формирования отчета Оценка фактической затратности ОП необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) выбрать учебный план.
  2. Из контекстного меню вызвать действие Оценка фактической затратности ОП.
    Вызов действия Оценка фактической затратности ОП
  3. В форме параметров необходимо указать Учебный год реализации образовательной программы, при этом Курс будет установлен автоматически. Для того чтобы отчет формировался подробно по каждому преподавателю, необходимо установить признак С конкретизацией по преподавателям.
    Форма параметров Оценка фактической затратности ОП

В результате сформируется отчет в виде Excel файла с оценкой фактической затратности реализации для одной выбранной образовательной программы, одного учебного года и одного курса.

Фактические значения рассчитываться следующим образом:

- Для дисциплины, НИС количество студентов данной ОП, которым назначена дисциплина или НИС для изучения на данном курсе.

- Для курсовой работы количество испытаний студентов данной ОП на данном курсе по курсовой работе с установленным признаком "В диплом" и непустым полем "Руководитель".

- Для практики количество испытаний студентов данной ОП на данном курсе по практике с установленным признаком "В диплом" и непустым полем "Руководитель практики".

- Для итогового экзамена количество студентов данной ОП, которым назначен итоговый экзамен для изучения на данном курсе.

- Для ВКР количество испытаний студентов данной ОП на данном курсе по ВКР с установленным признаком "В диплом" и непустым полем "Руководитель".

- Для проекта студентов количество испытаний студентов данной ОП на данном курсе по проекту с установленным признаком "В диплом" и непустым полем "Руководитель проекта - сотрудник вуза".

Доля студентов данной программы на данном курсе в предметной единице определяется как отношение количества студентов данной программы на данном курсе к общему количеству студентов в предметной единице. Количеством предметных единиц для строки отчета должна быть сумма долей по всем предметным единицам, подчиненным записи плана.

Количество студентов для расчета нагрузки за прием экзамена или зачета по дисциплинам, НИС и практикам определяется по ведомостям.

Количество потоков (при приеме письменных экзаменов) для дисциплин, НИС и практик рассчитывается как сумма долей студентов ОП определенного курса для каждого связанного приметного потока.

Количество групп (для консультаций при семестровой организации) для дисциплин НИС и практик рассчитывается как сумма долей студентов ОП для каждой связанной приметной группы.

Количество экзаменов для ВКР и итоговых экзаменов определяется как количество испытаний студентов данной ОП данного курса с признаком "в диплом", с непустым значением Руководитель работы (для ВКР), включенных в Локальные ГЭК.

Если при формировании отчета был установлен признак "С конкретизацией по преподавателям", то в отчет выгрузятся только те преподаватели, которым в плане нагрузки была назначена какая-либо нагрузка по записи учебного плана. При этом для видов работ, для которых невозможно определить однозначную связь преподаватель-студент, рассчитывается доля вклада преподавателя в выполнение нагрузки как отношение объема нагрузки определенного вида по записи плана, запланированной для данного преподавателя к объему нагрузки этого же вида, запланированной для всех преподавателей. Для отдельных видов работ фактическая нагрузка преподавателей считается по фактическому количеству связанных с ним студентов.

2. Сводный отчет по затратности ОП в учебном году

Для формирования отчета Сводный отчет по затратности ОП в учебном году необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) из контекстного меню вызвать действие Сводный отчет по затратности ОП в учебном году.
    Вызов действия Сводный отчет по затратности ОП в учебном году
  2. В форме параметров необходимо указать Учебный год, за который будет формироваться отчет. При необходимости можно конкретизировать перечень образовательных программ и курсов с помощью параметров Филиал, Факультет, Уровень образования, Форма обучения, Образовательная программа и Курс факультета.
    Если в форме параметров указан только параметр Учебный год, то отчет будет формироваться по всем образовательным программам и курсам ВУЗа, реализуемым в данном учебном году.
    Для выбора Образовательных программ и Курсов факультета, необходимо щелкнуть левой клавишей мыши на кнопку открытия справочника Справочник, в открывшихся справочниках или с помощью чек-бокса Чек-бокс выбрать одну или несколько записей и нажать кнопку ОК.

    Форма параметров Сводный отчет по затратности ОП в учебном году

В результате сформируется отчет в виде Excel файла со сводным отчетом по затратности в указанном учебном году для выбранных образовательных программ и курсов.

3. Сводный отчет по затратности ОП по годам

Для формирования отчета Сводный отчет по затратности ОП по годам необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) из контекстного меню вызвать действие Сводный отчет по затратности ОП по годам.
    Вызов действия Сводный отчет по затратности ОП по годам
  2. В форме параметров необходимо указать Учебный год начала обучения. При необходимости можно конкретизировать перечень образовательных программ и курсов с помощью параметров Филиал, Факультет, Уровень образования, Форма обучения, Образовательная программа и Курс факультета.
    Если в форме параметров указан только параметр Учебный год, то отчет будет формироваться по всем образовательным программам и курсам ВУЗа, реализуемым в данном учебном году.
    Для выбора Образовательных программ и Курсов факультета, необходимо щелкнуть левой клавишей мыши на кнопку открытия справочника Справочник, в открывшихся справочниках или с помощью чек-бокса Чек-бокс выбрать одну или несколько записей и нажать кнопку ОК.

    Форма параметров Сводный отчет по затратности ОП по годам

В результате сформируется отчет в виде Excel файла со сводным отчетом по затратности выбранных образовательных программ и курсов в учебных годах, начиная с указанного Учебного года начала обучения и до крайнего учебного года реализации образовательных программ.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Добавление дисциплин и НИС (раздел целиком) (31.03.2018) Одним файлом
Добавление дисциплин и НИС

При добавлении дисциплины или НИС в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие дисциплину или научно-исследовательский семинар, после чего заполнить следующую форму параметров:

Добавление дисциплины в ОУП
Пользователям разработчикам учебных планов предоставлена возможность связывания дисциплин и НИС учебного плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
      Для выбора из плана-предложения кафедры будут доступны только те дисциплины, которые совпадают по периоду реализации с периодом, заданным с помощью полей Год начала реализации и Год окончания реализации.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных специализаций, необходимо выбрать специализации, для которых добавляется дисциплина. Для выбора специализаций необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей специализаций, после чего нужно нажать кнопку ОК.
      Для каждой специализации в ОУП будет создана отдельная запись по дисциплине.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных специализаций, необходимо выбрать специализации, для которых добавляется дисциплина. Для выбора специализаций необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей специализаций, после чего нужно нажать кнопку ОК.
      Для каждой специализации в ОУП будет создана отдельная запись по дисциплине.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать и изменять специализацию для дисциплин и НИС (см. Установить или снять специализацию).
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

1. Установить или снять специализацию

Для установки, снятия и изменения специализации, установленной для дисциплины или НИС, необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Все записи плана выбрать дисциплину или НИС, для которой необходимо установить, снять или изменить специализацию.
    При добавлении дисциплины или НИС можно установить сразу несколько специализаций, для каждой из них будет создана отдельная запись о дисциплине или НИС (см. Добавление дисциплин и НИС). В связи с этим необходимо удостовериться, что выбранная дисциплина или НИС соответствуют той записи, которую необходимо изменить. Установленные специализации можно проверить в поле Для специализации.
  3. Из контекстного меню вызвать действие Установить\изменить специализацию.
  4. В форме параметров указать Специализацию факультета (для ОУП бакалавриата и специалитета) или Магистерская специализация (для ОУП магистратуры).
  5. Нажать кнопку ОК.

2. Изменение периода реализации

Для изменения периода реализации дисциплины или НИС, необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Все записи плана выбрать дисциплину или НИС, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

3. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Базовые учебные планы (БУПы) (раздел целиком) (31.03.2018) Одним файлом
Базовые учебные планы (БУПы)

Базовый учебный план (БУП) представляет собой иерархическую структуру учебных циклов и включенных в них дисциплин, формируемую на основе соответствующего образовательного стандарта. Базовый учебный план уточняет образовательный стандарт в части набора и трудоемкости дисциплин и других видов подготовки, а также отражает распределение учебной нагрузки по годам обучения студентов. Параметры базового учебного плана могут отличаться от образовательного стандарта. Допустимость или недопустимость таких различий регулируется при помощи контрольных соотношений, формируемых для БУПов.

Каждый базовый учебный план создается но основе одного из образовательных стандартов, задающего уровень образования, направление (специальность) и степень (квалификацию), для выбранного факультета (отделения) и года набора студентов. По одному образовательному стандарту для одного факультета и года набора может быть создано несколько БУПов, отличающихся специализацией (для бакалавриата и магистратуры) или магистерской программой и магистерской специализацией (для магистратуры).

Создание нового базового учебного плана включает следующие этапы работы:

  1. Создание записи о БУПе и его наполнение на основе образовательного стандарта.
  2. Редактирование сформированного БУПа.
  3. Связывание записей БУПа с компетенциями.

1. Создание нового базового учебного плана

Работа с базовыми учебными планами ведется в форме Базовые и рабочие учебные планы на вкладке Базовые учебные планы. Для создания нового БУПа необходимо чтобы предварительно был сформирован соответствующий образовательный стандарт. Работа с образовательными стандартами описана в разделе Образовательные стандарты. Для добавления нового БУП необходимо выполнить действие Добавить базовый учебный план, после чего заполнить форму параметров добавления следующим образом:

Форма добавления БУП (бакалавриат)

Форма добавления БУП (магистратура)
  • Поле Факультет будет заполнено автоматически, если Вы являетесь пользователем одного из факультетов и для Вас задана настройка "Факультет". В этом случае поле будет недоступно для изменения. Если же для Вас не установлена настройка факультета, то в данном поле Вы должны выбрать один из факультетов из общевузовского справочника Если Вам не удается выбрать нужный факультет, обратитесь к бизнес-администратору системы с просьбой уточнить установленные для Вас настройки.
  • Поле Ведущий факультет необходимо будет заполнить только в том случае, если БУП согласовывается с другим факультетом, для этого необходимо выбрать один из факультетов из общевузовского справочника
  • В поле Образовательная программа необходимо указать образовательную программу из соотвествующего справочника. В зависимости от выбранной образовательной программы изменяется доступность для заполнения полей Специализация, Магистерская программа, Магистерская специализация.
  • Поле Уровень образования будет заполнено автоматически.
  • В поле Образовательный стандарт необходимо выбрать один из существующих в системе образовательных стандартов. Для выбора предлагаются только стандарты для уровня образования, указанного в поле Уровень образования. Если необходимого образовательного стандарта нет в предлагаемом для выбора перечне, необходимо перейти в форму Образовательные стандарты и создать новый стандарт, после чего повторить добавление БУПа.
  • Поле Продолжительность программы ДПО является обязательным для заполнения только для программ подготовки специалистов, реализуемые в сокращенные или ускоренные сроки, для этого необходимо будет выбрать значение продолжительности программы только для ускоренных и сокращенных программы из соотвествующего справочника.
  • В поле Всего кредитов по плану будет автоматически предложено значение, соответствующее уровню образования (Бакалавриат - 240 кредитов, Специалитет - 300 кредитов, Магистратура - 120 кредитов). Однако, если для образовательной программы задано общее число кредитов, отличающее от значение, предлагаемых системой, эти значения можно исправить.
  • Поле Специализация доступно только в случае, если в поле Уровень образования указано значение Бакалавриат или Специалитет. Для выбора предлагаются специализации, существующие в справочнике . Если нужной специализации в этом перечне нет, то ее нужно добавить в справочник специализаций факультета. Если БУП не предполагает специализации, но это поле нужно оставить пустым. В дальнейшем на базе одного БУПа могут быть созданы различные рабочие учебные планы (РУПы) для различных специализаций.
  • Поле Магистерская программа доступно только в том случае, если в поле Уровень образования указано значение Магистратура. Для выбора доступны магистерские программы, существующие в справочнике . Если нужной программы в этом справочнике нет, ее нужно добавить, перейдя в справочник, после чего вернуться к созданию БУПа.
  • Поле Магистерская специализация доступно только в том случае, если в поле Уровень образования указано значение Магистратура. Для выбора доступны только магистерские специализации, существующие в справочнике и принадлежащие к выбранной магистерской программе. Если выбранная магистерская программе не предусматривает магистерских специализаций, или если БУП относится к программе в целом, то данное поле нужно оставить пустым. В дальнейшем на основе БУП для магистерской программы можно будет создавать различные рабочие учебные планы (РУПы) для разных магистерских специализаций.
  • В поле Форма обучения нужно выбрать форму обучения, по которой будет реализовываться образовательная программа, из общевузовского справочника .
  • В поле Программа двойных дипломов нужно установить флажок (значение Да) в случае, если БУП разрабатывается для программы двойных дипломов, реализуемой совместно с другими вузами (в т.ч. зарубежными). В противном случае флажок должен быть снят (значение Нет).
  • В поле Число лет обучения автоматически подставляется значение в зависимости от выбранной образовательной программы и уровня образования (Бакалавриат - 4 года, Специалитет - 5 лет, Магистратура - 2 года). Если БУП реализуется в течение другого числа лет, то это значение можно изменить.
  • В поле Реализуется по периодам нужно выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов в году необходимо указать количество преиодов в учебном году.
  • В поле Год начала обучения нужно выбрать год набора студентов, которые будут обучаться по данному БУП. Выбор производится из справочника среди учебных годов. Если нужного учебного года в справочнике нет, необходимо обратиться к бизнес-администратору системы с просьбой добавить его в справочник.
  • В поле Год окончания обучения нужно выбрать учебный год, в котором студенты, обучающиеся по данному БУП завершат обучение. Выбор производится аналогично выбору в поле Год начала обучения.
  • Поле Вариант позволяет создать несколько вариантов БУП одного и того же БУП с тем, чтобы в дальнейшем выбрать наиболее удачный вариант. Для этого в данном поле нужно указать метку варианта (например, "в-2"). Желательно использовать минимальное число символов. Если Вы не планируете работать с несколькими вариантами одного и того же БУП, это поле нужно оставить пустым.

После того, как для всех полей формы добавления БУП заданы допустимые значения, кнопка ОК на форме добавления станет доступной. После ее нажатия запись о новом БУП появится в таблице данных. При попытке добавления второго БУП на основе той же образовательной программы, образовательного стандарта для того же факультета, года начала обучения, специализации, магистерской программы, магистерской специализации БУП произойдет ошибка дублирования объектов.

2. Создание базового учебного плана как копии существующего

Если необходимо создать базовый учебный план, существенно схожий с уже существующим, можно воспользоваться возможностью копирования плана. Новый план, создаваемый методом копирования, должен отличаться от исходного не менее чем одним из следующих параметров:

  • специализацией;
  • магистерской специализацией;
  • годами обучения студентов;
  • при необходимости продолжительность программы ДПО.
Для того чтобы создать новый план на основе существующего, нужно выбрать исходный план в таблице данных и вызвать действие Скопировать как новый план.

Форма копирования нового БУП на базе старого

При открытии формы копирования плана все поля заполняются значениями, установленными для исходного плана. Для создания нового плана нужно изменить те значения, которые будут отличаться для нового плана и нажать кнопку ОК.

Результатом работы процедуры копирования будет запись о новом базовом учебном плане в таблице данных Базовые учебные планы. В подчиненной таблице Записи базового плана будет создан набор записей, полностью аналогичный составу исходного плана. Также для нового плана будет перенесена информация о распределении учебной нагрузки по годам обучения. Если с записями исходного плана были связаны компетенции, то они также будут скопированы в новый план и связаны с соответствующими записями.

После выполнения процедуры копирования можно продолжить редактирование нового плана. Редактирование может заключаться в добавлении новых записей, удалении созданных при копировании, уточнении форм итогового контроля по дисциплинам, значений объема учебной нагрузки в часах, неделях, кредитах.

Выполнять копирование плана лучше после того, как работа над составом и структурой исходного плана завершена (или близка к завершению). Автоматически актуализировать структуру и состав копии плана после изменения исходного плана будет невозможно. Однако возможно выполнить для нового плана действие Очистить, удалить план и снова сформировать его как копию существующего. Переформировывать таким образом план можно только пока он находится в статусе проект.

3. Редактирование базового учебного плана

Если БУП создавался методом копирования, то его состав уже сформирован и можно переходить к его редактированию. Если же создан пустой БУП, то его структуру и состав можно сформировать на основе образовательного стандарта. Для этого нужно выбрать БУП в таблице данных и выполнить действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Подтверждение формирования БУП

Если Вы уверены, что хотите сформировать БУП на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Записи базового плана. В таблице данных Развитие компетенций, подчиненной по отношению к записям плана, будут сформированы записи о компетенциях повторяющие записи, созданные в стандарте.

После того, как БУП сформирован на основе стандарта или скопирован, его можно редактировать. Для редактирования предназначена специализированная форма работы с БУП, которая открывается при вызове действия Открыть.

Редактирование БУП должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), установки видов итоговых испытаний, распределении нагрузки в часах и кредитах по года обучения (курсам). Для выполнения этих действий предназначены соответствующие действия контекстного меню. Для добавлении записи в определенный раздел нужно сначала выбрать заголовок этого раздела или одну из входящих в него записей.

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение ряда свойств разделов и дисциплин БУП.

График учебного процесса, являющийся частью БУП, необходимо разработать отдельно в виде файла формата MS Excel или MS Word. Полученный файл нужно загрузить как значение в колонке График учебного процесса. Для этого нужно непосредственно в колонке воспользоваться кнопкой открытия файла и выбрать файл при помощи стандартного диалога MS Windows. Для сохранения в базе данных системы загруженного файла необходимо нажать клавишу Enter. Если график нужно будет изменить, то его можно выгрузить и сохранить на диске при помощи кнопки сохранения файла, скорректировать файл и загрузить обратно (после повторной загрузки также необходимо нажимать Enter).

По окончании работы с БУП его можно вывести на печать. Для этого можно воспользоваться действием Напечатать план, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия БУП будет выгружен для печати в MS Excel.

4. Связывание записей базового плана с развиваемыми компетенциями

Записи базового учебного плана различных видов (разделы, дисциплины, группы дисциплин, курсовые работы, практики и т.д.) могут связываться с компетенциями, заданными для образовательного стандарта, на основе которого сформирован базовый план. До начала работы с распределением компетенций по записям базового плана, необходимо убедиться в том, что для стандарта корректно сформирован перечень компетенций (раздел Создание перечня компетенций стандарта).

Если базовый учебный план формировался с использованием действия Сформировать на основе стандарта, то перечень компетенций, связанных с записями стандарта (см. раздел Связь компетенций с записями стандарта), будет сформирован и для записей базового учебного плана. Дальнейшая работа должна заключаться в дополнительном связывании компетенций с записями базового плана с целью уточнения из развития за счет отдельных дисциплин.

Для того, чтобы связать компетенцию с записью БУП, нужно открыть форму Базовые и рабочие учебные планы, в ней открыть первую вкладку Базовые учебные планы. Среди всех доступных БУП нужно выбрать план, с которым предстоит работать. На вкладке второго уровня Записи базового плана нужно выбрать запись (дисциплину, группу дисциплин, курсовую работу и т.п.), с которой нужно связать компетенции. После этого на третьем уровне в таблице данных Развиваемые компетенции нужно вызвать действие Добавить компетенцию.

Для выбора в поле Компетенция стандарта доступны все компетенции, сформированные для стандарта в таблице данных Компетенции в стандарте. Если с одной записью БУП нужно связать несколько компетенций, то добавление компетенции нужно повторить.

Если компетенция связана с записью БУП ошибочно, ее можно удалить из списка при помощи действия Удалить.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Предложения кафедры в учебные планы (раздел целиком) (31.03.2018) Одним файлом
Предложения кафедры в учебные планы

Функционал раздела "Предложения кафедры в учебные планы" позволяет пользователям кафедры создавать и редактировать группы дисциплин ("планы-предложения"), которые кафедра готова реализовывать для различных образовательных программ университета.

Объединение в "группы" ("планы-предложения") может использоваться для разделения дисциплин, предлагаемых для разных уровней образования, реализуемых в разные периоды, и планируемых по разным видам периодов - по модулям или по семестрам.

1. Создание плана-предложения кафедры

Для добавления нового "плана-предложения" необходимо:

  1. На участке Рабочее место кафедры выбрать раздел "Предложения кафедры в учебные планы".
  2. В основной таблице данных Планы-предложения кафедры с помощью контекстного меню вызвать действие Добавить план-предложение кафедры.
    Добавление плана предложения
  3. В форме добавления необходимо:
    Форма добавления плана предложения
    • В полях Филиал, Факультет, Кафедра - указать соответствующие значения, если до этого были установлены соответствующие настройки пользователя (Настройка участка "Рабочее место кафедры"), то эти параметры будут заполнены автоматически.
    • С помощью полей Год начала реализации, Уровень образования и Число лет можно создавать планы предложения кафедры, как на все годы, так и группировать дисциплины в разные планы по годам или по уровням образования.
    • В поле Реализуется по периодам - выбрать вид периодов реализации плана (по модулям или по семестрам).
    • В поле Количество периодов - ввести количество периодов в учебном году (число модулей или число семестров).
  4. Нажать кнопку ОК, после чего план-предложение кафедры будет добавлен.

2. Формирование плана-предложения кафедры

Наполнение и редактирование плана-предложения кафедры выполняется с помощью специальной Формы редактирования, для открытия которой необходимо в разделе "Предложения кафедры в учебные планы" выбрать требуемое план-предложение и через контекстное меню вызвать действие Открыть и указать параметры для открытия формы редактирования.
Форма параметров для открытия формы редактирования ПП

  • Если в форму редактирования нужно вклучить дисциплины других планов предложений кафедры, то в поле Включить дисциплины других планов необходимо установить значение "Да".
  • С помощью полей С учебного года и По учебный год установить период для открытия формы редактирования.

    При открытии в форме редактирования будут только дисциплины, которые реализуются хотя бы в одном из учебных годов между указанными в полях С учебного года и По учебный год.

    В форме редактирования для изменения периода нужно воспользоваться действием Параметры редактирования (правый верхний угол формы редактирования).

Редактирование плана-предложения заключается в добавлении в существующие разделы дисциплин или семинаров, распределении учебной нагрузки по видам (лекции, семинары, самостоятельная работа) и по учебным периодам. Для добавления записей в план предложение предназначены соответствующие действия контекстного меню. Для добавлении записи в определенный раздел нужно сначала выбрать заголовок этого раздела или одну из входящих в него записей.

Добавлять в план-предложение кафедры можно "дисциплины" и "научно-исследовательские семинары", для этого необходимо в уже открытой Форме редактирования в контекстном меню найти группу действий Добавить и выбрать одно из действий дисциплину... или научно-исследовательский семинар... Добавление дисциплины в план-предложение кафедры

В результате откроется окно параметров, в котором необходимо: Форма параметров добавление дисциплины в план-предложение кафедры

  • В поле Источник финансирования из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
  • Установить Год начала реализации и Год окончания реализации.
  • В поле Дисциплина вуза или Семинар (дисциплина вуза) - с помощью списка Список или справочника Справочник выбрать дисциплину или семинар для добавления.
  • При необходимости установить значения параметров в полях Имеет пререквизиты, На иностранном языке, Читается носителем языка.
  • В поле Формат изучения установить формат изучения дисциплины.
  • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
  • В полях Общее число часов, Аудиторных часов - указать соответствующие числовые характеристики добавляемой дисциплины или семинара.

После нажатия кнопки ОК, дисциплина (семинар) будет добавлена и ей будет присвоен свободный порядковый номер.

Для изменения периода реализации дисциплины или НИС необходимо использовать процедуру Изменить период реализации.

Дисциплины (семинары), входящие в план-предложение кафедры имеют свойство Статус. Сразу после создания дисциплины пользователем кафедры дисциплина получает статус "проект". Пока дисциплина находится в этом статусе, разработчики планов образовательных программ не видят эту дисциплину и не могут использовать ее в своих планах. Этот статус необходим для того, чтобы пользователь кафедры закончил работу со всеми необходимыми характеристиками дисциплины, а также задал ограничения на использование дисциплины в учебных планах.

3. Добавление нагрузки для дисциплин и НИС

В планах предложениях для каждой дисциплины нужно сформировать нагрузку, как по годам, так и периодам каждого года.

Для добавления нагрузки необходимо:

  1. В представлении Планы-предложения кафедры (форма Предложения кафедры в учебные планы) выбрать план предложение, для которого будет формироваться нагрузка.
  2. Вызвать из контекстного меню действие Открыть.
  3. В форме редактирования выбрать дисциплину или НИС, для которой добавляются данные о нагрузке.
  4. Для каждой дисциплины (НИС) в форме редактирования представлен набор параметров (каждому параметру соответствует своя колонка), с помощью которых можно задать нагрузку:
    Форма редактирования фформирование нагрузки в плане предложении
    • В полях Всего часов по дисциплине и Всего аудиторных часов по дисциплине можно отредактировать соответствующее количество часов за весь период реализации дисциплины.
    • Для каждого учебного года, в рамках которых реализуется дисциплина, необходимо указать значения полей Всего часов в году и Аудиторных часов в году, а также распределить часы по видам работ в группах полей Ауд. часы по видам работы, Самостоятельная работа.
      Если для какого-либо учебного года были внесены данные о нагрузке (указаны Всего часов в году, Аудиторных часов в году и т.д.), то в представлении Нагрузка по годам появится соответствующая запись о нагрузке в учебном году, для которого добавлена информация о нагрузке.
    • Для каждого отдельного периода (модуля/семестра) необходимо указать значения следующих полей: Аудиторных часов в периоде, Форма контроля (указывается если в данном периоде предусмотрен рубежный контроль), Аудиторных часов за часть дисциплины и Общих часов за часть дисциплины (если в данном периоде предусмотрен рубежный, то нужно указать количество аудиторных и общих часов, которое будет зачтено при прохождении рубежного контроля в данном периоде (модуле/семестре)).
      Если для какого-либо периода в учебном году были внесены данные о нагрузке, то в представлении Нагрузка по периодам года (представление подчиненно представлению Предлагаемые дисциплины и НИС по годам) появится соответствующая запись о нагрузке в периоде, для которого добавлена информация о нагрузке.

Допустим в форме редактирования плана-предложения требуется ввести данные для дисциплины "Иностранный язык", которая характеризуется следующим набором данных:

  • Продолжительность: с 1 по 4 модуль первого года обучения.
  • Рубежный контроль: во 2 модуле зачет; в 4 модуле экзамен.
  • Всего часов: 108 (из них всего аудиторных 68).
  • Распределение часов по видам работ: 68 часов практических занятий и 40 часов самостоятельной работы.
  • Распределение часов по периодам: в 1, 2 и 3 модуле по 16 ауд.часов и 10 часов самостоятельной работы; в 4 модуле 20 ауд. часов и 10 часов самостоятельной работы.

Для этого необходимо найти нужный план-предложение и открыть форму редактирования (действие Открыть из контекстного меню). В форме редактирования найти дисциплину "Иностранный язык" и в следующих полях указать соответствующие данные:

  1. В полях Всего часов по дисциплине и Всего аудиторных часов по дисциплине указать значения 108 и 68 часов соответственно.
  2. Для 1 года обучения указать:
    • в полях Всего часов в году и Аудиторных часов в году указать 108 и 68 часов соответственно;
    • в поле практические занятия 68 часов;
    • в поле самостоятельная работа 40 часов;
  3. Для 1 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • поля Форма контроля, Аудиторных часов за часть дисциплины и Общих часов за часть дисциплины необходимо оставить пустыми, так как рубежный контроль в данном периоде не предусмотрен и часы за данный период будут суммироваться в периоде, в котором встречается следующий рубежный контроль (во 2 модуле).
  4. Для 2 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • в поле Форма контроля установить форму контроля "Зачет";
    • в поле Аудиторных часов за часть дисциплины 32 часа (так как в 1 модуле рубежного контроля не было, то аудиторные часы за часть дисциплины в 1 модуле суммируются к часам 2 модуля).
    • в поле Общих часов за часть дисциплины 52 часа (так так как в 1 модуле рубежного контроля не было, то общие часы за часть дисциплины в 1 модуле суммируются к часам 2 модуля).
  5. Для 3 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • поля Форма контроля, Аудиторных часов за часть дисциплины и Общих часов за часть дисциплины необходимо оставить пустыми, так как рубежный контроль в данном периоде не предусмотрен и часы за данный период будут суммироваться в периоде, в котором встречается следующий рубежный контроль (в 4 модуле).
  6. Для 4 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • в поле Форма контроля установить форму контроля "Экзамен";
    • в поле Аудиторных часов за часть дисциплины 36 часа (так как в 3 модуле рубежного контроля не было, то аудиторные часы за часть дисциплины в 3 модуле суммируются к часам 4 модуля).
    • в поле Общих часов за часть дисциплины 56 часа (так так как в 3 модуле рубежного контроля не было, то общие часы за часть дисциплины в 3 модуле суммируются к часам 4 модуля).

4. Установка ограничений на использование дисциплины

Пользователям кафедры предоставлена возможность устанавливать ограничения на использование дисциплины в тех или иных учебных планах, часть ограничений следуют из характеристик плана-предложения кафедры, в который включена дисциплина: Год начала реализации, Уровень образования, Реализуется по периодам.

При необходимости для каждой отдельной дисциплины (семинара) можно дополнительно ограничить возможность выбора дисциплины:

  • по направлению (специальности) образовательной программы;
  • по филиалу образовательной программы;
  • по факультету образовательной программы;
  • по конкретной образовательной программе (или конкретному набору программ).

Для добавления ограничения необходимо:

  1. Открыть раздел "Предложения кафедры в учебные планы".
  2. В подчиненной таблице данных Предлагаемые дисциплины и НИС выбрать дисциплину (семинар), на которую необходимо установить ограничения.
  3. В подчиненной вкладке Ограничения на выбор дисциплины с помощью контекстного меню вызвать действие Добавить ограничение.
    Установка ограничения на выбор дисциплины
  4. В форме параметров:
    Форма добавления ограничений
    • Если существует потребность одновременно с добавлением новых ограничений удалить старые, то необходимо для признака Удалять существующие ограничения установить значение "Да".
    • Можно установить ограничения по виду плана, для этого необходимо в поле Вид учебного плана установить вид плана, которому должна быть доступна данная дисциплина. Для объединенного плана общевузовских дисциплин дополнительно можно указать ограничение по типу общевузовского плана (поле Тип общевузовского плана), а для объединенного майнора по виду майнора (поле Вид майнора).
    • Можно установить ограничения по уровню образованич, для этого необходимо установить значение "Да" для тех уровней образования, которым должна быть доступна дисциплина.
    • В поле Направления / специальности можно выбрать направления / специальности для установки ограничений, для этого нужно нажать кнопку Справочник и с помощью чек-бокса Чек-бокс выбрать одно и более записей, после чего нажать кнопку ОК. Все выбранные записи отобразятся в поле Направления / специальности.
      Поле Направления / специальности будет доступно для установки ограничений, только если в поле Вид учебного плана установлено пустое значение или "Объединенный учебный план".
    • Аналогично направлениям / специальностям можно установить одно и более ограничений по Филиалу, Факультету, Образовательной программе и Курсу студентов.

      Для вида учебного плана "Объединенный план общевузовских дисциплин" поля для установки ограничений Филиал, Факультет, Образовательная программа и Курс студентов будут недоступны.

      Для вида учебного плана "Объединенный майнор" поля для установки ограничений Факультет, Образовательная программа и Курс студентов будут недоступны.

      Для вида учебного плана "Объединенный план факультетских дисциплин" поля для установки ограничений Образовательная программа и Курс студентов будут недоступны.

  5. После нажатия кнопки ОК будут созданы все возможные варианты ограничений с учетом установленных значений в форме параметров.
Если нужно задать ограничение таким образом, чтобы оно действовало не по одному, а по нескольким (но не всем) значениям, нужно добавить несколько подобных ограничений (например, добавить несколько ограничений, указав отдельные образовательные программы; в этом случае дисциплину можно будет использовать только в учебных планах этих конкретных образовательных программ).

5. Статусы дисциплин плана-предложения

Каждая дисциплина (НИС) в плане-предложении может находиться в одном из статусов:

  • проект;
  • заявка на дисциплину;
  • принята кафедрой;
  • отклонена;
  • утверждена.

Для изменения статуса пользователю кафедры необходимо открыть раздел Предложения кафедры в учебные планы и в таблице данных Предлагаемые дисциплины и НИС выбрать дисциплину, в контекстном меню системы найти группу действий Изменить статус и вызвать одно из действий: Принять к реализации, Вернуть в статус "проект", Утвердить реализацию, Отклонить реализацию.

При добавлении в план-предложение дисциплина получает статус "проект". После добавления пользователь кафедры должен максимально полно занести данные о нагрузке по дисциплине, ее распределении по видам работ и по периодам обучения, задать формы текущего и рубежного контроля. Эта информация будет необходима пользователям-разработчикам учебных планов для принятия решения о включении или невключении дисциплины в свои планы. Также, пока дисциплина находится в статусе "проект", пользователь кафедры должен занести ограничения на использование дисциплины. Из статуса "проект" пользователь кафедры может перевести дисциплину в статус "принята кафедрой" при помощи действия Принять к реализации. Дисциплины в статусе "принята кафедрой" становятся доступными для выбора пользователями - разработчиками учебных планов.

Для дисциплины в статусе "принята кафедрой" возможно выполнение действия Вернуть в статус "проект", однако выполнить это действие будет возможно только в случае, если дисциплина еще не включена ни в один из учебных планов.

Дисциплина может оказаться включенной в план-предложение кафедры разработчиком одного из учебных планов. В этом случае дисциплина появится в плане-предложении кафедры без непосредственного участия пользователя кафедры. Такие дисциплины будут появляться в статусе "заявка на дисциплину". Над дисциплиной в статусе "заявка на дисциплину" пользователь кафедры может выполнять следующие операции:

  • вносить изменения в данные о нагрузке по дисциплине;
  • выполнить для этой дисциплины действие Принять к реализации, в этом случае дисциплина перейдет в статус "принята кафедрой" ;
  • выполнить для этой дисциплины действие Отклонить реализацию ;
  • "объединить" дисциплину с какой-то другой из дисциплин своей кафедры; эта операция предусмотрена для случаев, когда пользователь кафедры считает, что разработчик учебного плана излишне создал дисциплину, и в учебном плане можно использовать другую схожую дисциплину со схожими параметрами нагрузки.

Пользователь кафедры может вносить изменения в данные о дисциплинах своей кафедры на разных этапах работы с учебными планам. Все изменения, сделанные пользователем кафедры, будут сразу же применяться ко всем учебным планам образовательных программ, в которых они задействованы. Однако перед "утверждением" учебных планов внесение изменений в данные о дисциплинах должно быть прекращено. Для фиксации такого состояния предназначен статус дисциплины "утверждена". Этот статус означает, что изменения в данные о дисциплине больше не вносятся. Перевести дисциплину в статус "утверждена" можно при помощи действия Утвердить реализацию.

6. Печать плана-предложения кафедры

Для выгрузки плана-предложения кафедры для печати необходимо в форме Предложения кафедры в учебные планы (таблица данных Планы-предложения кафедры) из контекстного меню вызвать действие Выгрузить для печати.
Вызов процедуры Выгрузить для печати план-предложение кафедры

В результате сформируется и откроется Excel-файл, содержащий всю информацию о плане-предложении.

7. Изменение периода реализации дисциплины или НИС

Для изменения периода реализации дисциплины или НИС, необходимо:

  1. В представлении Планы-предложения кафедры (форма Предложения кафедры в учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Предлагаемые дисциплины и НИС выбрать дисциплину или НИС, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Расчетные показатели учебных планов (раздел целиком) (31.03.2018) Одним файлом
Расчетные показатели учебных планов

В ходе работы над базовыми и рабочими учебными планами необходимо помнить о том, что в итоговом варианте документа должны быть соблюдены требования к ряду расчетных показателей, характеризующих план в целом. Ниже описаны принципы расчета применяемых показателей и пути достижения необходимых значений.

1. Суммы показателей по разделам и по плану в целом

Образовательный стандарт представляет собой иерархическую структуру разделов (компонентов, циклов) и входящих в них дисциплин. Стандарт должен быть сформирован таким образом, чтобы на первом уровне иерархии была единственная запись. Как правило, эта запись имеет наименование Вся образовательная программа. Аналогичную структуру имеют БУПы и РУПы, сформированные на основе стандартов.

Формы редактирования БУП и РУП содержат проверки, контролирующие равенство сумм показателей (числа часов, недель, кредитов и проч.) записей, входящих в раздел, и значений тех же показателей, заданных для раздела. В суммировании участвуют только записи, непосредственно подчиненные данному разделу. Это означает, что если в раздел входит несколько других разделов, в состав которых, в свою очередь, входят дисциплины и записи других видов, то в суммировании будут участвовать только значения заданные для разделов в целом, а значения записей более низких уровней анализироваться не будут.

Для некоторых разделов (разделов дисциплин по выбору, факультативов, а иногда и других) итоговые значения не должны рассчитываться как сумма входящих в раздел дисциплин, т.к. не все указанные дисциплины должны в обязательном порядке изучаться студентами. Для того, чтобы отличить один вид разделов от другого, предназначено свойство раздела Рассчитывается как сумма элементов. Для просмотра и изменения значения этого свойства предназначено действие Дополнительные свойства, которым можно воспользоваться в формах редактирования БУП и РУП, предварительно выбрав строку нужного раздела.

Если для раздела установлено значение признака таким образом, что показатели входящих в него записей не суммируются, то проверок соответствия сумм проводиться не будет. При этом важно задать для раздела в целом такие значения, которые дадут необходимую сумму для вышестоящих разделов и для плана в целом. Например, для разделов или групп дисциплин по выбору надо задать такие значения нагрузки, которые обязательно должны быть выполнены студентами. Для разделов факультативов и адаптационных дисциплин допустимо устанавливать итоговые значения по разделу нулевыми или пустыми.

Суммирование показателей по разделам

В данном примере для раздела Дисциплины по выбору признак Рассчитывается как сумма элементов установлен как Нет (наименование раздела отображается курсивным шрифтом). Для всех остальных разделов установлено значение Да. При этом для раздела дисциплин по выбору установлены самостоятельные значения числа часов, недель и кредитов. Для раздела Общие гуманитарные и социально-экономические дисциплины значения рассчитываются как сумма по трем разделам, непосредственно входящим в него: 2160 = 1836 + 108 + 216.

Такой принцип суммирования и контроля значений для разделов действует как для базовых, так и для рабочих учебных планов.

2. Аудиторная нагрузка по периодам (РУП)

В рабочих учебных планах рассчитываются показатели аудиторной нагрузки по периодам. При этом в разделе возможно наличие дисциплин, аудиторная нагрузка по которым не входит в расчет недельной аудиторной нагрузки. Такими дисциплинами могут быть факультативы, физическая культура и некоторые другие дисциплины. Для таких дисциплин при помощи действия Дополнительные свойства необходимо установить признак Входит в расчет недельной нагрузки, равным Нет.

При суммировании значений аудиторной нагрузки в периоде по разделу в суммировании участвуют только те записи, нагрузка по которым входит в расчет недельной нагрузки. При этом допустимой считается ситуация, когда в строке раздела сумма аудиторных часов по всем периодам не будет равна значению, установленному в колонке "Аудиторные занятия".

Аудиторная нагрузка по периодам

В данном примере аудиторная нагрузка по дисциплине Физическая культура не входит в расчет недельной аудиторной нагрузки.

3. Число экзаменов и зачетов по периодам (РУП)

В рабочих учебных планах для записей разделов определяется число экзаменов и зачетов в каждом периоде обучения. Если показатели раздела рассчитываются как сумма по входящим в раздел элементам, то число экзаменов и зачетов по разделу будет контролироваться проверками системы. Если же показатели раздела не подлежат суммированию, то количество экзаменов и зачетов по разделу нужно установить вручную.

Испытания по курсовым работам не учитываются при подсчете числа зачетов и экзаменов в периоде.

Проверить и при необходимости изменить признак Рассчитывается как сумма элементов для раздела можно при помощи действия Дополнительные свойства.

Количество экзаменов и зачетов, получившееся в корневой строке "Вся образовательная программа будет считаться показателем плана в целом.

Аудиторная нагрузка по периодам

В данном примере видно, что в разделе "Другие виды подготовки" первом и третьем модулях нет ни экзаменов, ни зачетов, во втором модуле - 2 зачета, в четвертом модуле 1 экзамен и 2 зачета.

4. Недельная аудиторная нагрузка, число аудиторных часов в день (РУП)

Недельная аудиторная нагрузка в каждом учебном периоде (модуле, семестре) в рабочем учебном плане определяется как число аудиторных часов в периоде, рассчитанное для корневой записи плана, деленное на число недель в периоде.

Количество недель в периоде отображается в отдельной строке внизу плана после перечня всех его записей. При формировании РУП число недель в каждом периоде устанавливается равным значению, заданному для периода в общевузовском справочнике . Однако в каждом РУП при необходимости это значение можно изменить.

Ниже строки с количеством недель в периоде следует строка Недельная аудиторная нагрузка. Значение в этой строке является расчетным и не подлежит редактированию. Оно рассчитывается как число аудиторных часов в периоде, стоящее в корневой строке плана ("Вся образовательная программа"), деленное на число недель, стоящее в предыдущей строке.

Если полученное значение недельной аудиторной нагрузки не отвечает установленным требованиям, то его можно скорректировать изменив число аудиторных часов по отдельным дисциплинам плана или изменив его распределение по периодам обучения. Эти изменения приведут в свою очередь к изменениям значений для разделов плана и для корневого раздела "Вся образовательная программа".

Недельная аудиторная нагрузка

Показатель Число аудиторных часов в день определяется как рассчитанное значение недельной аудиторной нагрузки, деленное на 6 дней. Левее колонок, показывающих средние значения показателей по периодам расположена колонка, отображающая средние значения, рассчитанные для всех периодов.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Добавление проекта студентов (раздел целиком) (31.03.2018) Одним файлом
Добавление проекта студентов

При добавлении проекта студентов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие проект студентов..., после чего заполнить следующую форму параметров:
Добавление проекта в ОУП

  • В поле Проект для студентов необходимо выбрать проект из справочника Проекты для студентов, если проект отсутствует, то его можно добавить (см. Проекты для студентов). Данное поле можно оставить пустым и не устанавливать ссылку на проект из справочника, а только указать Наименование проекта, Вид дисциплины в плане и Число кредитов.
    Записи о проектах в объединенных учебных планах, не связанные с записью справочника проектов, в учебный план факультета передаваться не будут.
  • В поле Вид дисциплины в плане выбрать вид дисциплины.
  • В поле Число кредитов указать соответствующее данному проекту число кредитов.
  • При необходимости установить признак Только в кумулятивный рейтинг.

После нажатия кнопки ОК проект будет добавлена в объединенный учебный план.

1. Проекты для студентов

Справочник "Проекты для студентов" позволяет работать с информацией о проектах, в которые могут включаться студенты в своей внеадиторной деятельности. Справочник распологается в разделе Объединенные учебные планы на соотвествующей вкладке Проекты для студентов.
Справочник проекты для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить проект.
    Вызов действия Добавить проект
  2. Заполнить форму параметров следующим образом:
    Форма параметров Добавить проект
    • Заполнить поля Идентификатор во внешней системе, Полное наименование, Полное наименование на английском языке, Тип проекта (выбирается из справочника Типы проектов для студентов), Вид проектной деятельности (выбирается из списка).
    • В одной из групп полей Руководитель из вуза или Внешний руководитель указать подразделение/организацию руководителя (выбирается из справочников или Места прохождения практики) и выбрать самого руководителя проекта (выбирается из справочника или Работники организации).
      Руководителем проекта может быть только либо представитель вуза, либо внешний руководитель. При этом если начать заполнять одну из групп полей (Руководитель из вуза или Внешний руководитель) другая перестанет быть доступной для заполнения.
    • Заполнить поля Учебный год, Дата начала реализации, Дата окончания реализации, Дата окончания записи на проект, Количество модулей, Период итогового контроля, Вид итогового контроля и Плановое количество кредитов.
  3. Нажать кнопку ОК.

1.1. Выгрузить проекты студентов

В справочнике Проекты для студентов предоставлена возможность сформировать отчет с информацией о проектах и студентах, которым назначены данные проекты.

Для формирования отчета необходимо:

  1. В справочнике Проекты для студентов из контекстного меню системы вызвать действие Выгрузить проекты студентов.
    Вызов действия Выгрузить проекты
  2. В форме пераметров с помощью выбора значений для параметров Филиал, Факультет, Образовательная программа, Курс, Группа, Проект можно ограничить выборку проектов, для которых будет формироваться отчет. Если все поля формы параметров оставить пустыми, то отчет сформируется для всех проектов ВУЗа, присутствующих в справочнике Проекты для студентов.
  3. Нажать кнопку ОК.

В результате сформируется отчет в формате MS Excel, содержащий информацию об образовательной программе, ФИО, курсе и группах студентов, участвующих в проектах, наименовании проекта, плановом и фактическом количестве кредитов, руководителях проектов, результатах участия в проекте студентов.

1.2. Загрузка данных о проектах с портала

1.3. Загрузка данных о назначении проектов студентам

2. Типы проектов для студентов

Справочник "Типы проектов для студентов" содержит в себе перечень типов проектов для внеаудиторной деятельности студентов и распологается в разделе Объединенные учебные планы на соотвествующей вкладке Типы проектов для студентов.
Справочник Типы проектов для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить тип проекта.
    Вызов действия Добавить тип проекта
  2. В форме параметров указать Краткое наименование и Полное наименование типа проекта для студентов.
    Форма параметров Добавить тип проекта
  3. Нажать кнопку ОК.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Формирование и уточнение перечня компетенций для оригинального образовательного стандарта (раздел целиком) (31.03.2018) Одним файлом
Формирование и уточнение перечня компетенций для оригинального образовательного стандарта

При формировании на основе общевузовских справочников перечней компетенций для каждого из образовательных стандартов действуют следующие принципы:

  1. Системные (универсальные) компетенции переносятся в каждый из образовательных стандартов в полном соответствии с общевузовским справочником. Изменение перечня системных компетенций, их формулировок или кодов в конкретном стандарте недопустимо.
  2. Формулировки социально-личностных компетенций в каждом из образовательном стандарте могут уточнятся. При этом код компетенции автоматически получит постфикс, соответствующий аббревиатуре направления подготовки.
  3. Общевузовский справочник инструментальных компетенций имеет иерархическую структуру. Для инструментальных компетенций в общевузовском справочнике задаются только их наименования. Формулировка компетентностных образовательных результатов для инструментальных компетенций заносится только при добавлении компетенции в стандарт.
  4. В образовательный стандарт могут добавляться дополнительные социально-личностные компетенции, не связанные с компетенциями из общевузовского справочника. Добавление в стандарты системных и инструментальных компетенций, не связанных с общевузовскими справочниками, недопустимо.

Работа по формированию и уточнению перечня компетенций для каждого из образовательных стандартов ведется в форме Образовательные стандарты. Для того, чтобы просмотреть, сформировать или отредактировать перечень компетенций для стандарта, нужно выбрать этот стандарт на вкладке Образовательные стандарты и открыть подчиненную таблицу Компетенции в оригинальном стандарте.

До начала работы по формированию перечня компетенций для образовательных стандартов должны быть полностью сформированы Общевузовские справочники компетенций.

Для формирования и уточнения перечня компетенций в таблице данных Компетенции в оригинальном стандарте доступны действия, позволяющие:

  • переносить в образовательный стандарт полный набор компетенций определенного вида, занесенных в общевузовский справочник
  • добавлять к образовательному стандарту компетенции по одной
  • уточнять формулировку и код компетенции (доступно для социально-личностных и инструментальных компетенций)
  • удалять ошибочно добавленные компетенции

Коды компетенций, добавляемых в стандарт, могут отличаться от кодов, заданных в общевузовском справочнике. Отличие, как правило, заключается в дописывании к коду компетенции из общевузовского справочника аббревиатуры направления подготовки.

Аббревиатуры направлений подготовки задаются в общевузовском справочнике пользователями, наделенными правами на работу с данным справочником. Каждый образовательный стандарт относится к определенному направлению подготовки. Если аббревиатура направления не отображается в таблице "Образовательные стандарты" или отображается неверно, нужно обратиться к пользователю, ответственному за работу со справочником направлений и специальностей с просьбой уточнить аббревиатуру нужного направления.

1. Формирование перечня системных компетенций

Системные (универсальные) компетенции переносятся в каждый из образовательных стандартов в полном соответствии с общевузовским справочником. Изменение перечня системных компетенций, их формулировок или кодов в конкретном стандарте недопустимо.

Для переноса полного перечня системных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все системные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень системных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. Изменять формулировки или коды системных компетенций по сравнению с общевузовским справочником недопустимо.

Системные компетенции в образовательном стандарте

Если после последнего формирования перечня системных компетенций для стандарта произошло добавление системных компетенций в общевузовский справочник, действие Добавить все системные компетенции можно вызвать повторно. Его выполнение приведет к добавлению недостающих системных компетенций, коды и формулировки существующих компетенций будут приведены в соответствие со значениями из общевузовского справочника.

Если возникла необходимость удалить одну из системных компетенций, добавленных к стандарту, из общевузовского справочника, потребуется предварительно удалить ее из стандарта. Для этого необходимо выбрать удаляемую компетенцию в списке и выполнить действие Удалить компетенцию.

Если компетенция была удалена из стандарта ошибочно, или если перечень системных компетенций в общевузовском справочнике был расширен, отдельную системную компетенцию можно добавить в стандарт при помощи действия Добавить компетенцию... / системную компетенцию.

Добавление системной компетенции

Для добавления нужно в поле Компетенция из общевузовского справочника выбрать добавляемую компетенцию из общевузовского справочника системных компетенций. Формулировка выбранной компетенции отобразится в поле Формулировка компетентностных образовательных результатов автоматически. Изменение кода или формулировки системной компетенции недопустимо. После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте.

Повторное добавление компетенции в стандарт недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

2. Формирование перечня социально-личностных компетенций

Социально-личностные компетенции переносятся в каждый из образовательных стандартов в соответствии с общевузовским справочником. При этом в конкретном образовательном стандарте формулировка социально-личностной компетенции может быть изменена. При изменении формулировки изменяется и код социально-личностной компетенции - к нему дописывается аббревиатура направления подготовки.

В отличие от других видов компетенций в образовательный стандарт могут добавляться социально-личностные компетенции, не связанные с соответствующими компетенциями общевузовского справочника. Далее такие компетенции называются дополнительные социально-личностные компетенции.

Перенос социально-личностных компетенций из общевузовского справочника в образовательный стандарт можно выполнять одним из двух способов:

  • Добавить все социально-личностные компетенции из общевузовского справочника, после чего уточнить формулировки и коды тех компетенций, для которых это необходимо (рекомендуется в случае, если не планируется существенных изменений по сравнению с общевузовским справочником)
  • Добавлять социально-личностные компетенции по одной с одновременным уточнением их формулировок и кодов (рекомендуется в случае, если состав и содержание социально-личностных компетенций в стандарте должно существенно отличаться от общевузовского справочника)

Формирование перечня социально-личностных компетенций

Для переноса полного перечня социально-личностных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все социально-личностные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень социально-личностных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. После добавления коды и формулировки компетенций можно будет уточнить.

Социально-личностные компетенции в образовательном стандарте

Если после последнего формирования перечня социально-личностных компетенций для стандарта произошло добавление компетенций данного вида в общевузовский справочник, действие Добавить все социально-личностные компетенции можно вызвать повторно. Его выполнение приведет к добавлению недостающих системных компетенций, коды и формулировки существующих компетенций будут приведены в соответствие со значениями из общевузовского справочника.

Отдельную социально-личностную компетенцию, имеющую соответствие в общевузовском справочнике, можно добавить в стандарт при помощи действия Добавить компетенцию... / социально-личностную компетенцию. Одновременно с добавлением компетенции можно выполнить и ее уточнение.

Добавление социально-личностной компетенции

Для добавления нужно в поле Компетенция из общевузовского справочника выбрать добавляемую компетенцию из общевузовского справочника социально-личностных компетенций. Формулировка выбранной компетенции отобразится в поле Формулировка компетентностных образовательных результатов (значение из общевузовского справочника, недоступно для изменения). Та же формулировка отобразится в поле Формулировка компетентностных образовательных результатов (в стандарте). Если формулировку компетенции в стандарте нужно изменить, это можно сделать в поле, доступном для редактирования. Если изменение формулировки произведено, код компетенции будет дополнен аббревиатурой направления.

После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте. В таблице будут отображены как значения кода и формулировки, уточненные для стандарта, так и значения из общевузовского справочника.

Повторное добавление в стандарт компетенции, ссылающейся на ту же запись общевузовского справочника, недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

Для добавления дополнительной социально-личностной компетенции, не связанной с общевузовским справочником, предназначено действие Добавить компетенцию... / дополнительную социально-личностную компетенцию.

Добавление дополнительной социально-личностной компетенции

Для добавления нужно занести формулировку компетенции и ее порядковый номер. Для дополнительных компетенций необходимо использовать порядковые номер от 101 до 200. Код компетенции будет сформирован автоматически из префикса"СЛК-", порядкового номера и аббревиатуры направления подготовки.

После нажатия кнопки ОК дополнительная компетенция будет добавлена в стандарт. В таблице всех компетенций стандарта для дополнительных социально-личностных компетенций в колонках Код общевузовской компетенции и Формулировка компетентностных образовательных результатов (общевуз.) будут отображены пустые значения.

Уточнение социально-личностных компетенций

Социально-личностные компетенции, ранее добавленные в стандарт, могут уточняться по сравнению с компетенциями общевузовского справочника. Для того, чтобы уточнить компетенцию, нужно выбрать ее в таблице данных, после чего вызвать действие Уточнить компетенцию... / социально-личностную компетенцию

Уточнение социально-личностных компетенций

Уточнение компетенции заключается к корректировке ее формулировки по сравнению с формулировкой, заданной в общевузовском справочнике. Если формулировка изменена, в код компетенции будет автоматически дописана аббревиатура направления подготовки.

Удаление социально-личностной компетенции

Если возникла необходимость удалить одну из социально-личностных компетенций, добавленных к стандарту, нужно выбрать ее в таблице данных и воспользоваться действием Удалить компетенцию.

3. Формирование перечня инструментальных компетенций

Формирование перечня инструментальных компетенций для образовательного стандарта заключается в выборе соответствующих инструментальных компетенций из общевузовского справочника и занесения их формулировок. Так как в общевузовском справочнике инструментальных компетенций формулировки компетенций не заносятся, при добавлении инструментальных компетенций в стандарт формулировки должны быть заданы для каждой компетенции. Коды инструментальных компетенций в стандарте будут сформированы автоматически на основе кода компетенции в общевузовском справочнике и аббревиатуры направления подготовки.

Добавление в стандарт инструментальных компетенций, не связанных ни с одной записью общевузовского справочника, недопустимо.

Формирование перечня инструментальных компетенций для стандарта на основе общевузовского справочника можно выполнять одним из двух способов:

  • Добавить все инструментальные компетенции из общевузовского справочника, после чего уточнить все их формулировки и коды
  • Добавлять инструментальные компетенции по одной с одновременным уточнением их формулировок и кодов

Формирование перечня инструментальных компетенций

Для переноса полного перечня инструментальных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все инструментальные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень социально-личностных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. В качестве формулировки компетенции будет подставлено ее наименование их общевузовского справочника. После добавления инструментальных компетенций коды и формулировки всех компетенций необходимо будет уточнить.

Инструментальные компетенции в стандарте

По одной инструментальные компетенции можно добавлять при помощи действия Добавить компетенцию... / инструментальную компетенцию. Одновременно с добавлением компетенции можно выполнить и ее уточнение.

Добавление инструментальной компетенции в стандарт

Для добавления инструментальной компетенции нужно занести ее формулировку в поле Формулировка компетентностных образовательных результатов, после чего в поле Компетенция из общевузовского справочника выбрать наиболее подходящую общевузовскую компетенцию. Для удобства выбора общевузовский справочник инструментальных компетенций отображается в виде иерархической структуры. При этом для добавления в стандарт необходимо выбирать компетенции, не имеющие дочерних компетенций.

После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте. В таблице будут отображены как значения кода и формулировки, уточненные для стандарта, так и значения кода и наименования из общевузовского справочника.

Повторное добавление в стандарт компетенции, ссылающейся на ту же запись общевузовского справочника, недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

Уточнение инструментальных компетенций

Инструментальные компетенции, ранее добавленные в стандарт, могут уточняться по сравнению с компетенциями общевузовского справочника. Для того, чтобы уточнить компетенцию, нужно выбрать ее в таблице данных, после чего вызвать действие Уточнить компетенцию... / инструментальную компетенцию.

Уточнение инструментальных компетенций

Уточнение компетенции заключается к корректировке ее формулировки. Также при уточнении формулировки в код компетенции будет автоматически дописана аббревиатура направления подготовки.

Удаление инструментальной компетенции

Если возникла необходимость удалить одну из инструментальных компетенций, добавленных к стандарту, нужно выбрать ее в таблице данных и воспользоваться действием Удалить компетенцию.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Рабочие учебные планы общевузовских дисциплин (раздел целиком) (31.03.2018) Одним файлом
Рабочие учебные планы общевузовских дисциплин

В системе поддерживается возможность разработки рабочих учебных планов (РУПов), в которые будут включены дисциплины, преподаваемые не для студентов определенных образовательных программ, а предлагаемые для выбора всем студентам вуза. В отличие от обычных РУПов РУПы общевузовских дисциплин разрабатываются независимо от Базовых учебных планов (БУП) и Образовательных стандартов.

Структура и атрибутивный состав записей РУПов общевузовских дисциплин аналогичны обычным РУПам. При этом для РУПов общевузовских дисциплин не предусмотрен расчет итоговых показателей плана (сумма часов и кредитов, средняя аудиторная нагрузка и проч.). Также для РУПов общевузовских дисциплин не предусмотрены процедуры согласования и утверждения.

Данные о дисциплинах, входящих в общевузовские РУПы, используются при составлении планов нагрузки преподавателей. Нагрузка по дисциплинам общевузовских РУП рассчитывается аналогично нагрузке по дисциплинам обычных РУП.

Создание и редактирование РУПов общевузовских дисциплин выполняется в разделе Разработка учебных планов в форме Учебные планы общевузовских дисциплин на вкладке Рабочие планы общевузовских дисциплин.

1. Создание РУПа общевузовских дисциплин

Создание РУПов общевузовских дисциплин выполняется в разделе Разработка учебных планов в форме Учебные планы общевузовских дисциплин на вкладке Рабочие планы общевузовских дисциплин. Для создания нового плана нужно вызвать действие Добавить учебный план общевузовских дисциплин.

Добавление РУП общевузовских дисциплин

Для создания нового РУП необходимо выбрать Учебный год, занести Наименование плана, выбрать Уровень образования (параметр необязательный), выбрать тип периодов реализации в поле Реализуется по периодам и задать Количество учебных периодов.

От выбора Уровня образования будет зависеть то, по каким нормативам будет считаться нагрузка кафедр и преподавателей по дисциплинам этого плана. От выбора Периодов реализации и их количества будет зависеть то, по каким периодам будут планироваться испытания (экзамены и зачеты) по этим дисциплинам.

2. Редактирование РУПа общевузовских дисцплин

После создания РУПа общевузовских дисциплин его можно редактировать при помощи формы редактирования. Форма редактирования открывается при помощи действия Открыть.

Добавление разделов, групп дисциплин и дисциплин, уточнение их характеристик, распределения аудиторных часов по модулям выполняется аналогично этим же возможностям в обычных РУП. Подробнее - Редактирование рабочего учебного плана. Итоговые значения для плана в целом и средние значения недельной аудиторной нагрзки по плану в целом не подсчитываются.

3. Передача РУПа общевузовских дисциплин на реализацию

Для того, чтобы дисциплины общевузовского РУП могли быть назначены студентам, необходимо выполнить для плана действие Передать план на факультет. Для каждой отдельной дисциплины можно также вызывать действие Передать в план факультета в подчиненной таблице Записи рабочего учебного плана.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Дисциплины вне учебных планов. Эта таблица доступна в разделе Общевузовские ресурсы, в форме Учебные планы, программы и формы обучения на вкладке Дисциплины вне учебных планов.

Назначение дисциплин студентам на участке Студент выполняется именно из таблицы данных Дисциплины вне учебных планов. Поэтому при завершении создания дисциплины или при внесении изменений в данные общевузовского РУП необходимо выполнять действие по передаче плана или дисциплин на факультет.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Учебные планы лицея (раздел целиком) (31.03.2018) Одним файлом
Учебные планы лицея

Учебные планы представляют собой иерархическую структуру компонентов (разделов), школьных предметов и проектов школьников. Учебный план лицея разрабатывается сразу на все годы реализации образовательной программы, и содержит информацию о видах и количестве испытаний по школьным предметам, о распределении учебной нагрузки по периодам и т.д.

Создание нового учебного плана лицея включает следующие этапы работы:

  1. Создание записи об учебном плане лицея.
  2. Наполнение и редактирование учебного плана.
  3. Передача плана в реализацию.

1. Создание нового учебного плана лицея

Работа с учебными планами лицея ведется на участке "Разработка учебных планов" в форме "Учебные планы лицея".

Для добавления нового учебного плана лицея необходимо в представлении Учебные планы лицея с помощью контекстного меню вызвать действие Добавить план лицея.

Процедура Добавить план лицея

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров Добавить план лицея

  • В поле Направление в лицее - указать направление обучения школьников.
  • В полях Образовательный программа - выбрать образовательную программу, для которой создается план.
  • В поле Класс начала обучения - указать класс, начиная с которого будет реализовываться план.
  • В поле Число лет обучения - указать количество лет реализации плана.
  • В полях Год начала обучения, Год окончания обучения указать года начала и окончания обучения, периоды, по которым будет планироваться нагрузка.
  • В поле Реализуется по периодам выбрать один из предлагаемых вариантов реализации.
  • В поле Количество периодов в году указать количество периодов в учебном году.
  • При необходимости можно указать Количество учащихся и Количество классов.

После того, как для всех полей формы добавления учебного плана лицея будут заданы допустимые значения, кнопка ОК на форме добавления станет доступной. После ее нажатия запись о новом учебном плане появится в представлении Учебные планы лицея. При попытке добавления второго учебного плана такого же направления, образовательной программы и года начала обучения произойдет ошибка дублирования объектов.

2. Редактирование учебного плана лицея

Для редактирования учебного плана лицея предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования учебного плана лицея

Редактирование учебного плана должно заключаться в добавлении разделов, школьных предметов и проектов школьников, распределении нагрузки по видам работы (лекции, семинары, практические и т.д.), по годам обучения (классам) и по периодам обучения в каждом году (модулям, семестрам), а также планировании рубежных контролей.

Для добавления раздела необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие раздел плана.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: школьный предмет, проект школьников.

Форма редактирования группа процедур Добавить

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, формы контролей), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается школьниками или нет и т.д.), предназначено действие Дополнительные свойства.

Редактирование записей учебного плана лицея

2.1. Добавление раздела

Для создания раздела необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие раздел плана,

Форма редактирования Добавить раздел в учебный план лицея

после чего заполнить следующую форму параметров:

Форма параметров добавить раздел учебный план лицея

  • В поле Раздел из справочника выбрать раздел для добавления.
  • В поле Наименование необходимо ввести название раздела.
  • В поле Код записи при необходимости можно указать код записи для добавляемого раздела.
  • В полях Общее число часов и Число недель можно указать общее количество часов и число недель по плану для данного раздела. При необходимости данные поля можно оставить пустыми и указать данные параметры непосредственно в форме редактирования.
  • В поле Рассчитывается как сумма элементов необходимо установить значение "Да", если показатели раздела определяться путем суммирования показателей входящих в них записей. Если показатели раздела плана должны устанавливаться независимо, то необходимо установить значение "Нет".
  • Для разделов показатели, которых устанавливаются независимо, при необходимости можно указать Минимальное и Максимальное число дисциплин для выбора, и Минимальное и Максимальное число кредитов для выбирамых дисциплин.

После нажатия кнопки ОК, раздел будет добавлен.

2.2. Добавление школьного предмета

При добавлении школьного предмета в форме редактирования учебного плана лицея необходимо из контекстного меню в группе процедур Добавить вызвать действие школьный предмет, после чего заполнить следующую форму параметров:

Форма параметров Добавить школьный предмет в учебный план лицея
  • В поле Школьный предмет с помощью списка Список или справочника Справочник нужно выбрать школьный предмет для добавления.
  • В поле Кафедра при необходимости можно указать кафедру, которая будет реализовать школьный предмет.
  • В поле Вид дисциплины необходимо выбрать вид добавляемой дисциплины.
  • В поле По выбору студентов нужно установить значение "Да" для школьных предметов, назначаемых школьникам в обязательном порядке, и значение "Нет" для школьных предметов, которые назначаются при выборе школьником.
  • В полях Аудиторных часов и Число недель необходимо указать соответствующие числовые характеристики добавляемого школьного предмета.

После заполнения формы параметров необходимо нажать кнопку ОК, после чего школьный предмет будет добавлен в учебный план.

После того как запись о школьном предмете будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, недель, формы контролей), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается школьниками или нет и т.д.), предназначено действие Дополнительные свойства.

2.3. Добавление проекта школьников

При добавлении проекта школьников в форме редактирования учебного плана лицея необходимо из контекстного меню в группе процедур Добавить вызвать действие проект школьников, после чего заполнить следующую форму параметров:

Форма параметров Добавить проект школьников в учебный план лицея
  • В поле Наименование необходимо ввести наименование проекта школьников.
  • В поле Кафедра при необходимости можно указать кафедру, которая будет реализовать проект школьников.
  • В полях Число недель, Аудиторных часов нужно указать соответствующие числовые характеристики добавляемого школьного проекта.
  • Значение для Аудиторных часов в неделю определяется автоматически.
  • Если нагрузка по проекту должна учитываться при расчете недельной нагрузки, то в поле Входит в расчет недельной нагрузки должно быть установлено значение "Да".
  • В поле По выбору студентов должно быть установлено значение "Да" для проектов школьников, назначаемых школьникам в обязательном порядке, и значение "Нет" для проектов школьников, которые назначаются при выборе школьником.

После заполнения формы параметров необходимо нажать кнопку ОК, после чего школьный предмет будет добавлен в учебный план.

3. Передача плана в реализацию

Для того чтобы записи учебного плана могли быть назначены школьникам, необходимо для плана выполнить действие Передать план в реализацию.

Вызов действия передать план в реализацию

После чего в форме параметров нужно указать учебный год (поле На учебный год), за который будет передаваться план в реализацию, указать Номер класса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в представлении Учебные планы лицея. Данное представление доступно на участке Лицей университета, в форме Учебные планы лицея.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Проверки и расчеты (руководство администратора) (раздел целиком) (31.03.2018) Одним файлом
Проверки и расчеты (руководство администратора)
Проверки и расчеты учебных планов хранятся в базе данных в виде объектов классов "Контрольное соотношение учебного плана" и "Действие соотношения учебного плана". На каждое контрольное соотношение может быть создано любое количество действий. Проверки и расчеты

1. Проверки
При создании проверки необходимо указать
  • Имя и наименование проверки. Имя проверки должно быть уникальным. Наименование проверки будет по умолчанию показано пользователю при невыполнении условий проверки.
  • Очередность применения проверки. Проверки применяются в порядке, определяемом этим свойством. В случае наличия проверок с одинаковой очередностью, порядок их применения может быть любым, и вам не следует делать предположений об этом порядке.
  • Область применимости проверки. Проверки могут применяться к базовым учебным планам, к рабочим учебным планам или к обоим типам. Проверки могут применяться либо к показателям, распределяемым по периодам обучения, либо нет. Также можно указать конкретный показатель плана, к которому будет применяться проверка.

2. Объекты, доступные в теле скриптов проверок и расчетов
  • ContextObject: IContext Контекстный объект, реализующий .
  • Period: Integer Для проверок, работающих по учебным периодам - номер проверяемого периода. Нумерация периодов начинается с нуля.
  • CurrentYear: Integer Для проверок, работающих по учебным периодам - номер проверяемого периода. Для учебных планов лицея, объединенных учебных планов и планов предложения кафедры - номер проверямого года для проверок, работающих по учебным годам. Нумерация периодов начинается с нуля.
  • CurrentControlType: WideString Для проверок, работающих по формам текущего контроля - идентификатор формы текущего контроля.
  • MasterPlan: WideString Идентификатор учебного плана.
  • ItemCount[SubjectClass: WideString]: Integer Количество записей плана с типом SubjectClass.
  • Course: WideString Идентификатор курса.
  • CourseNumber: Integer Номер курса.
  • RootItem: PlanItem Объект, обеспечивающий доступ к сумме корневых строк плана. Объект реализует описанный ниже интерфейс IPlanItem.
  • WeekCount[Period: Integer]: Integer Количество недель в соответствующем периоде.
  • WeeksByYearByPeriod[Year: Integer; Period: Integer]: Integer Количество недель в соответствующем периоде года (для объединенного рабочего плана).
  • AudHoursInWeekCountByYearByPeriod[Year: Integer; Period: Integer]: Double Количество аудиторных часов всех дисиплин, входящих в недельную нагрузку в соответствующем периоде года (для объединенного рабочего плана).
  • Result: OleVariant Через эту переменную передается результат расчета расчетного показателя.
  • ControlTypeCount[const ControlType: WideString; Period: Integer]: Integer Количество (по плану в целом) видов рубежного испытания ControlType за период Period
  • Message(Optional MessageText: WideString, Optional Color: WideString) Процедура генерирует сообщение проверки для пользователя. Текст сообщения и "цвет" по умолчанию берутся из свойств самой проверки.
  • Item: IPlanItem Объект, обеспечивающий доступ к свойствам проверяемой строки плана. Объект реализует описанный ниже интерфейс IPlanItem :
      IPlanItem = interface
    property ID: WideString readonly;

    property Parent: IPlanItem readonly;
    property ChildCount: Integer readonly;
    property Child[Index: Integer]: IPlanItem readonly;

    property PeriodCount: Integer readonly;

    property SubjectClass: WideString readonly;
    property IsCalculated: WordBool readonly;
    property CumulOnly: WordBool readonly;
    property SubjectType: WideString readonly;
    property PracticeType: WideString readonly;

    property BlockCode: WideString readonly;
    property Description: WideString readonly;
    property UnivSubject: WideString;
    property FacDepartment: WideString;

    property StandHours: Double readonly;
    property EntireHours: Double;
    property WeekCount: Double;
    property Credits: Double;
    property AudHours: Double;
    property LectionHours: Double;
    property SeminarHours: Double;
    property PracticeHours: Double;
    property SelfHours: Double;
    property FinalControl: WideString;
    property HoursByPeriod[Period: Integer]: Double;
    property CreditsByPeriod[Period: Integer]: Double;
    property AudHoursByPeriod[Period: Integer]: Double;
    property ControlsByPeriod[Period: Integer]: WideString;
    property CurrentControls[const CurrentControlType: WideString]: Integer;
    property ExamCountByPeriod[Period: Integer]: Integer;
    property TestCountByPeriod[Period: Integer]: Integer;

    function ChildrenAudHours: Double;
    function ChildrenLectionHours: Double;
    function ChildrenSeminarHours: Double;
    function ChildrenPracticeHours: Double;
    function ChildrenSelfHours: Double;
    function ChildrenStandHours: Double;
    function ChildrenEntireHours: Double;
    function ChildrenWeekCount: Double;
    function ChildrenCredits: Double;
    function ChildrenHoursByPeriod(Period: Integer): Double;
    function ChildrenCreditsByPeriod(Period: Integer): Double;
    function ChildrenCurrentControls(const CurrentControlType: WideString): Integer;
    function ChildrenAudHoursByPeriod(Period: Integer): Double;
    function ChildrenExamCountByPeriod(Period: Integer): Integer;
    function ChildrenTestCountByPeriod(Period: Integer): Integer;

    property YearsCount: Integer readonly;
    property AudHoursByYear[Year: Integer]: Double;
    property WeeksByYear[Year: Integer]: Double;
    property AudHoursByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property WeeksByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property ControlTypeByYearByPeriod[Year: Integer; Period: Integer]: WideString;

    function ChildrenAudHourByYear(Year: Integer): Double;
    function ChildrenWeeksByYear(Year: Integer): Double;
    function ChildrenAudHoursByYearByPeriod(Year: Integer; Period: Integer): Double;
    function ChildrenWeeksByYearByPeriod(Year: Integer; Period: Integer): Double;

    property StandCredits: Double readonly;
    property StandMinCredits: Double readonly;
    property StandMaxCredits: Double readonly;

    property CreditsByYear[Year: Integer]: Double;
    property EntireHoursByYear[Year: Integer]: Double;
    property LectionHoursByYear[Year: Integer]: Double;
    property SeminarHoursByYear[Year: Integer]: Double;
    property PracticeHoursByYear[Year: Integer]: Double;
    property SelfHoursByYear[Year: Integer]: Double;
    property CreditsByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property ExamAudHoursByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property ExamEntireHoursByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property CurrentControlsByYear[Year: Integer; const CurrentControlType: WideString]: Integer;

    property ItemStatus: WideString readonly;
    property ProposalStatus: WideString readonly;

    function ChildrenStandCredits: Double;
    function ChildrenCreditsByYear(Year: Integer): Double;
    function ChildrenEntireHoursByYear(Year: Integer): Double;
    function ChildrenLectionHoursByYear(Year: Integer): Double;
    function ChildrenSeminarHoursByYear(Year: Integer): Double;
    function ChildrenPracticeHoursByYear(Year: Integer): Double;
    function ChildrenSelfHoursByYear(Year: Integer): Double;
    function ChildrenCreditsByYearByPeriod(Year: Integer; Period: Integer): Double;
    function ChildrenExamAudHoursByYearByPeriod(Year: Integer; Period: Integer): Double;
    function ChildrenExamEntireHoursByYearByPeriod(Year: Integer; Period: Integer): Double;
    function ChildrenCurrentControlsByYear(Year: Integer; const CurrentControlType: WideString): Integer;

    property ExamCountByYearByPeriod[Year: Integer; Period: Integer]: Integer;
    property TestCountByYearByPeriod[Year: Integer; Period: Integer]: Integer;

    function ChildrenExamCountByYearByPeriod(Year: Integer; Period: Integer): Integer;
    function ChildrenTestCountByYearByPeriod(Year: Integer; Period: Integer): Integer;

    property MinCurrentCoefByYear(Year: Integer): Double readonly;
    property MinCurrentHoursByYear(Year: Integer): Double readonly;
    property PlanCurrentCoefByYear(Year: Integer): Double;
    property PlanCurrentHoursByYear(Year: Integer): Double;

    function ChildrenMinCurrentHoursByYear(Year: Integer): Double; safecall;
    function ChildrenPlanCurrentHoursByYear(Year: Integer): Double; safecall;

    property StudyFormat: WideString; safecall;
  end;
    • Свойство ID содержит идентифкатор строки учебного плана.
    • Свойство Parent содержит ссылку на объект, описыващий родительскую запись плана (если она есть). Объект реализует тот же интерфейс IPlanItem
    • Свойства ChildCount и Child возвращают, соответственно, количество дочерних записей плана и ссылки на объекты, описывающие дочерние записи (реализуют тот же интерфейс IPlanItem).
    • Свойство PeriodCount определяет количество учебных периодов, содержащихся в учебном плане. Для плана лицея - количество учебных периодов в году.
    • Свойство SubjectClass возвращает идентификатор класса строки учебного плана.
    • Свойство IsCalculated равно True, если строка является суммой своих дочерних строк.
    • Свойство CumulOnly равно True, если строка включается только в кумулятивный рейтинг.
    • Свойство SubjectType возвращает идентификатор вида дисциплины строки учебного плана.
    • Свойство PracticeType возвращает идентификатор вида практики строки учебного плана.
    • Свойство BlockCode возвращает код раздела учебного плана.
    • Свойство Description возвращает наименование строки учебного плана.
    • Свойство UnivSubject возвращает и устанавливает идентификатор дисциплины, которая описывается строкой учебного плана.
    • Свойство FacDepartment возвращает и устанавливает идентификатор кафедры строки учебного плана.
    • Свойство StandHours возвращает количество часов по стандарту.
    • Свойство EntireHours возвращает и устанавливает общее количество часов.
    • Свойство WeekCount возвращает и устанавливает общее количество недель.
    • Свойство Credits возвращает и устанавливает общее количество зачетных единиц.
    • Свойство AudHours возвращает и устанавливает количество аудиторных часов.
    • Свойство LectionHours возвращает и устанавливает количество часов лекций.
    • Свойство SeminarHours возвращает и устанавливает количество часов семинаров.
    • Свойство PracticeHours возвращает и устанавливает количество часов практических занятий.
    • Свойство SelfHours возвращает и устанавливает количество часов самостоятельной работы.
    • Свойство FinalControl возвращает и устанавливает идентификатор типа итогового контроля.
    • Свойство HoursByPeriod[Period] возвращает и устанавливает общее количество часов в учебном периоде с номером Period.
    • Свойство CreditsByPeriod[Period] возвращает и устанавливает количество зачетных единиц в учебном периоде с номером Period.
    • Свойство AudHoursByPeriod[Period] возвращает и устанавливает количество аудиторных часов в учебном периоде с номером Period.
    • Свойство ControlsByPeriod[Period] возвращает и устанавливает количество зачетных единиц в учебном периоде с номером Period.
    • Свойство ExamCountByPeriod[Period] возвращает и устанавливает количество экзаменов в учебном периоде с номером Period.
    • Свойство TestCountByPeriod[Period] возвращает и устанавливает количество зачетов в учебном периоде с номером Period.
    • Свойство CurrentControls[CurrentControlType] возвращает и устанавливает количество формы текущего контроля с идентификатором CurrentControlType.
    • Функции ChildrenAudHours, ChildrenLectionHours, ChildrenSeminarHours, ChildrenPracticeHours, ChildrenSelfHours, ChildrenStandHours, ChildrenEntireHours, ChildrenWeekCount, ChildrenCredits, ChildrenHoursByPeriod, ChildrenCreditsByPeriod, ChildrenCurrentControls, ChildrenAudHoursByPeriod, ChildrenAudHoursByPeriod, ChildrenAudHoursByPeriod, ChildrenExamCountByPeriod, ChildrenTestCountByPeriod, ChildrenAudHourByYear (только для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры), ChildrenWeeksByYear (только для учебного плана лицея), ChildrenAudHoursByYearByPeriod (только для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры), ChildrenWeeksByYearByPeriod (только для учебного плана лицея), ChildrenStandCredits (только для объединенного учебного плана и плана-предложения кафедры), ChildrenCreditsByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenEntireHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenLectionHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenSeminarHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenPracticeHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenSelfHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenCreditsByYearByPeriod (только для объединенного учебного плана и плана-предложения кафедры), ChildrenExamAudHoursByYearByPeriod (только для объединенного учебного плана и плана-предложения кафедры), ChildrenExamEntireHoursByYearByPeriod (только для объединенного учебного плана и плана-предложения кафедры), ChildrenCurrentControlsByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenExamCountByYearByPeriod (только для объединенного учебного плана), ChildrenTestCountByYearByPeriod (только для объединенного учебного плана) агрегируют соответствующие показатели по дочерним записям учебного плана. Важно, что строки, которые включается только в кумулятивный рейтинг, не агрегируются функциями ChildrenCredits и ChildrenCreditsByPeriod.
    • Свойство YearsCount определяет количество лет обучения (для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры)
    • Свойство AudHoursByYear[Year: Integer] возвращает и устанавливает количество аудиторных часов в учебном году с номером Year (нумеруются с нуля) (для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры).
    • Свойство WeeksByYear[Year: Integer] возвращает и устанавливает количество недель в учебном году с номером Year (нумеруются с нуля) (только для учебного плана лицея).
    • Свойство AudHoursByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает количество аудиторных часов в учебном периоде с номером Period (нумеруются с нуля) учебного года номером Year (нумеруются с нуля) (для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры).
    • Свойство WeeksByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает количество недель в учебном периоде с номером Period (нумеруются с нуля) учебного года номером Year (нумеруются с нуля) (только для учебного плана лицея).
    • Свойство ControlTypeByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает тип контоля в учебном периоде с номером Period (нумеруются с нуля) учебного года номером Year (нумеруются с нуля) (для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры).
    • Свойство StandCredits возвращает количество зачетных единиц по стандарту
    • Свойство StandMinCredits возвращает минимальное количество зачетных единиц по стандарту
    • Свойство StandMaxCredits возвращает максимальное количество зачетных единиц по стандарту
    • Свойство CreditsByYear[Year: Integer] возвращает и устанавливает количество зачетных единиц в учебном году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство EntireHoursByYear[Year: Integer] возвращает и устанавливает общее количество учебных часов в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство LectionHoursByYear[Year: Integer] возвращает и устанавливает количество учебных часов лекций в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство SeminarHoursByYear[Year: Integer] возвращает и устанавливает количество учебных часов семинаров в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство PracticeHoursByYear[Year: Integer] возвращает и устанавливает количество учебных часов практических занятий в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство SelfHoursByYear[Year: Integer] возвращает и устанавливает количество учебных часов самостоятельной работы в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство CreditsByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает количество зачетных единиц за период в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство ExamAudHoursByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает количество аудиторных часов на испытание за период в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство ExamEntireHoursByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает общее количество часов на испытание за период в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство CurrentControlsByYear[Year: Integer; const CurrentControlType: WideString] возвращает и устанавливает количество формы текущего контроля с идентификатором CurrentControlType за период в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство ItemStatus возвращает статус записи плана (для плана-предложения кафедры)
    • Свойство ProposalStatus возвращает статус предложения записи (для объединенного учебного плана)
    • Свойство ExamCountByYearByPeriod возвращает и устанавливает количество экзаменов в году с номером Year в учебном периоде с номером Period (для объединенного учебного плана).
    • Свойство TestCountByYearByPeriod возвращает и устанавливает количество зачетов в году с номером Year в учебном периоде с номером Period (для объединенного учебного плана).
    Соответствие между показателями учебного плана и элементами интерфейса IPlanItem представлено на рисунке:
    Показатели плана как члены интерфейса IPlanItem
    Показатели объединенного учебного плана
    Показатели плана-предложения кафедры


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Редактирование объединенного плана факультетских дисциплин (раздел целиком) (31.03.2018) Одним файлом
Редактирование объединенного плана факультетских дисциплин

Редактирование объединенного плана факультетских дисциплин заключается в создании Групп дисциплин (разделов), добавлении дисциплин в разделы, распределении нагрузки по видам работы (лекции, семинары, практические и т.д.), по годам обучения и по периодам обучения в каждом году (модулям, семестрам), а также планировании рубежных испытаний, распределении кредитов и объемов нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Добавление Группы дисциплин (раздела)

Для редактирования объединенного плана факультетских дисциплин необходимо в таблице данных Объединенные планы факультетских дисциплин выбрать план и с помощью контекстного меню вызвать действие Открыть.

Открытие формы редактирования объединенного плана факультета

В итоге откроется форма редактирования с пустым планом, в которой для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Процедура добавления раздела в объединенный план факультета

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования объединенного плана.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования объединенного плана факультетских дисциплин.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

Добавление Дисциплины или НИС

Для добавления Дисциплины необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие Дисциплину или НИС,

Процедура добавления дисциплины в объединенный план факультета

после чего заполнить следующую форму параметров:

Форма параметров добавления дисциплины в объединеннй план факультетских дисциплин

Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.

    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

Перемещение Группы дисциплин (раздела) или дисциплины

В случае если при добавлении Группы дисциплин или Дисциплины был неверно указан раздел, куда они должны быть включены, то в отношении такой Группы дисциплин или Дисциплины необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить Группу дисциплин или Дисциплину, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина будут перемещены в корень объединенного плана факультетских дисциплин.

Также можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

Печать объединенных планов факультетских дисциплин

По окончании работы с объединенным учебным планом его можно вывести на печать. Для этого можно воспользоваться одним из действий Выгрузить для печати, Выгрузить для печати как Базовый, Выгрузить для печати как Рабочий расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

1. Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные планы факультетских дисциплин (форма Объединенные планы факультетских дисциплин) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи плана выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

2. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

3. Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных планов факультетских дисциплин выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Работа Заместителя директора филиала (раздел целиком) (31.03.2018) Одним файлом
Работа Заместителя директора филиала

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

1. Согласование БУП и РУП

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

2. Согласование ОУП аспирантуры

Работа заместителя директора филиала, согласующего объединенные учебные планы аспирантуры, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы в представлении Объединенные учебные планы аспирантуры, в данном представлении отображаются планы, переведенные директорами аспирантских школ в статус на согласовании с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у зам.директора филиала нет критических замечаний к плану, он должен выполнить действие Согласовать план. При этом, при появлении необходимости редактирования плана, заместитель директора филиала может воспользоваться действием Отозвать согласование, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на утверждение проректором.

3. Согласование ОУП

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у зам.директора филиала нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Объединенные учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Оценка затратности реализации учебных планов (раздел целиком) (31.03.2018) Одним файлом
Оценка затратности реализации учебных планов

Оценкa зaтрaтности рeaлизaции учeбных плaнов зaключaeтся в оцeнке отношения количества студентов, которые будут обучаться по данному учебному плану к объeму нaгрузки прeподaвaтeлeй, трeбуeмому для рeaлизaции этого учeбного плана, выраженному в числе условных ставок преподавателей. Данное отношение называется Коэффициентом затратности плана. Чем коэффициент затратности выше, тем ниже затратность плана, и чем коэффиент ниже, тем выше затратность.

Оцeнкa зaтрaтности рeaлизaции плaнов рeaлиовaнa в систeмe в двух вaриaнтaх: для Paбочих учeбных плaнов и для Объeдинeнных учeбных плaнов. Для Объeдинeнных учeбных плaнов оцeнкa зaтрaтности производится отдльно для кaждого учeбного годa рeaлизaции. Принцип оцeнки зaтрaтности одинaков для рaзных видов плaнов и зaключaeтся в слeдующeм:

  1. Для кaждой дисциплины и НИС выполняeтся оцeнкa количeствa чaсов нaгрузки для рeaлизaции отдeльных видов нaгрузки (лeкций, сeминaров, прaктичeских, провeдeния экзaмeнов и зaчeтов, провeрки испытaний тeкущeго контроля)
  2. Для прочих видов зaписeй плaнa (курсовых рaбот, прaкик, итоговых госэкзaмeнов, ВКP) выполняeтся оцeнкa нaгрузки для типовых случaeв (курсовыe и ВКP нe нa инострaнном языкe, групповой вид прaктики, итоговыe экзaмeны в устной формe и т.п.)
  3. Количeтво чaсов нaгрузки по всeм зaписям плaнa суммируeтся и дeлится нa знaчeниe нaстройки "Нормaтив нaгрузки условного прeподaвaтeля" (нaпримeр, 700 чaсов). Тaким обрaзом вычисляeтся число условных стaвок прeподaвaтeлeй, трeбуeмых для рeaлизaции плaнa.
  4. Опрeдeляeтся отношeниe числa студeнтов, укaзaнного для плaнa в цeлом (в случae PУП) или для одного годa рeaлизaции Объeдинeнного плaнa, к числу условных стaвок прeподaвaтeлeй. Тaким обрaзом получaeтс знaчeниe Коэффициeнтa зaтрaтности плaнa.
  5. Получeнноe знaчeниe Коэффициeнтa зaтрaтности срaвнивaeтся с нормaтивными знaчeниями, хрaнящмися в спрaвочникe "Нормaтивныe коэффициeнты зaтрaтности плaнa", дeлaeтся вывод о повышeнной зaтрaтности плaнa или о зaтрaтности в рaмкaх стaндaртной.

Оценка затратности реализована в системе в виде интерактивного Excel-отчета, показывающего составляющие, на основе которых была произведена оценка и позволяющего сохранять полученное значение коэффициента затратности в базе данных.

1. Формирование справочников и установка настроек, необходимых для расчета

До того, как появится возможность оценить затратность отдельных учебных планов, следующие данных должны быть заполнены централизовано пользователем, имеющим права на работу со справочниками по планированию нагрузки преподавателей.

  1. Должно быть установлено значение настройки "Норматив нагрузки условного преподавателя". Значение выражено в числе часов нагрузки, составляющем одну условную ставку преподавателя (например, 700).
  2. Должны быть сформированы три записи справочника "Нормативные коэффициенты затратности плана" для уровней образования "Бакалавриат","Специалитет" и "Магистратура". Для каждого уровня должно быть занесено стандартное (минимально допустимое нормой) значение коэффициента затратности. Данный справочник расположен в разделе "Справочники на планированию нагрузки" на одноименной вкладке верхнего уровня.
  3. Справочник "Виды учебной работы преподавателей" должен быть полностью сформирован на тот учебный год, планы которого планируется оценивать. Среди видов работ, связанных с курсовыми работами, практиками, итоговыми госэкзаменами, ВКР при помощи простановки признака "Используется для оценки плана" должны быть выделены те виды работ, которые являются типовыми (не зависят от выбора студентами) и которые должны использоваться для оценки затратности плана. Простановка этого признака для дисциплин и НИС не требуется.

2. Оценка затратности Рабочего учебного плана

Оценка затратности РУП может выполняться тогда, когда план уже практически полностью сформирован (создан перечень дисциплин, распределена нагрузка по видам работы, занесено число испытаний текущего контроля, созданы зачеты и экзамены). Для получения оценки затратности РУП нужно проделать следующее:

  1. Уточнить (или задать) число студентов, установленное для плана в целом в таблице "Рабочие учебные планы" в колонке "Количество студентов".
  2. В подчиненной таблице "Записи рабочего учебного плана" необходимо проставить значения в колонках "Количество студентов", "Количество подгрупп", "Количество групп", "Количество потоков" для всех записей плана кроме разделов и зачетно-экзаменационных недель. Достаточно задать только те значения, от которых зависит расчет нагрузки для данной записи плана. Например, если по дисциплине или НИС нет лекций, значение "Количество потоков" можно не задавать. Заносимые значения должны учитывать в себе понижающие коэффициенты для случаев, когда известно, что студенты, обучающиеся по данному плану, будут изучать дисциплину в одном потоке с другими студентами. Например, если одну из дисциплин по выбору студенты будут изучать совместно со студентами, обучающимися по другим планам, то Количество потоков нужно сократить до доли, которую займут студенты данного плана (например, 0,33). Также можно уменьшать, в том числе до дробных значений, количество групп и подгрупп. Количество студентов должно быть задано таким, как оно оценивается для данной конкретной дисциплины.
  3. При помощи действия контекстного меню Оценка затратности плана выгрузить Excel-отчет, показывающий оценку величины нагрузки по каждой записи плана, по плану в целом, число условных ставок преподавателей, требуемых для реализации плана, а также полученную величину Коэффициента затратности плана и ее оценку ("план избыточно затратен" или "затратность плана в пределах стандарта").
  4. В случае получения нулевых или некорректных значений объема нагрузки нужно уточнить значение числа студентов, групп, подгрупп, потоков по плану в целом или для отдельных дисциплин. Если наблюдается некорректность расчета, нужно обратиться к пользователям, ответственным за работу со справочниками по планированию нагрузки. Если план избыточно затратен, для снижения затратности можно уменьшить число форм текущего контроля, экзаменов, использовать больше дисциплин, читаемых совместно со студентами других учебных планов или больше "внешних" дисциплин (например, MOOC’s). После внесения изменений в показатели плана отчет нужно выгрузить заново.
  5. Если полученное значение коэффициента затратности является корректным, нужно нажать на кнопку "Сохранить значение коэффициента", расположенную в "шапке" плана. Полученное значение коэффициента будет сохранено в таблице данных "Рабочие учебные планы" в одноименной колонке.

3. Оценка затратности Объедиенного плана

Оценка затратности Объединенного плана выполняется применительно к одному учебному году и может выполняться тогда, когда план уже практически полностью сформирован на данный учебный год (создан перечень дисциплин, распределена нагрузка по видам работы, занесено число испытаний текущего контроля, созданы зачеты и экзамены). Для получения оценки затратности Объединенного плана нужно проделать следующее:

  1. Задать число студентов для плана в целом применительно к учебному году, для которого выполняется оценка затратности, в подчиненной таблице "Реализация плана по годам".
  2. "Количество студентов", "Количество подгрупп", "Количество групп", "Количество потоков" для каждой из записей плана также оценивается применительно каждому учебному году. Установить эти значения нужно в подчиненной таблице "Все записи плана по годам" для нужного учебного года в одноименных колонках таблицы. Значения должны быть установлены для всех записей плана кроме разделов и зачетно-экзаменационных недель. Достаточно задать только те значения, от которых зависит расчет нагрузки для данной записи плана. Например, если по дисциплине или НИС нет лекций, значение "Количество потоков" можно не задавать. Заносимые значения должны учитывать в себе понижающие коэффициенты для случаев, когда известно, что студенты, обучающиеся по данному плану, будут изучать дисциплину в одном потоке с другими студентами. Например, если одну из дисциплин по выбору студенты будут изучать совместно со студентами, обучающимися по другим планам, то Количество потоков нужно сократить до доли, которую займут студенты данного плана (например, 0,33). Также можно уменьшать, в том числе до дробных значений, количество групп и подгрупп. Количество студентов должно быть задано таким, как оно оценивается для данной конкретной дисциплины.
  3. Выгрузить Excel-отчет при помощи действия контекстного меню Оценка затратности плана. Отчет требует указать учебный год, для которого он формируется. Отчет показывает оценку величины нагрузки по каждой записи плана, по плану в целом, число условных ставок преподавателей, требуемых для реализации плана, а также полученную величину Коэффициента затратности плана и ее оценку ("план избыточно затратен" или "затратность плана в пределах стандарта").
  4. В случае получения нулевых или некорректных значений объема нагрузки нужно уточнить значение числа студентов, групп, подгрупп, потоков по плану в целом или для отдельных дисциплин. Если наблюдается некорректность расчета, нужно обратиться к пользователям, ответственным за работу со справочниками по планированию нагрузки. Если план избыточно затратен, для снижения затратности можно уменьшить число форм текущего контроля, экзаменов, использовать больше дисциплин, читаемых совместно со студентами других учебных планов или больше "внешних" дисциплин (например, MOOC’s). После внесения изменений в показатели плана отчет нужно выгрузить заново.
  5. Если полученное значение коэффициента затратности является корректным, нужно нажать на кнопку "Сохранить значение коэффициента", расположенную в "шапке" плана. Полученное значение коэффициента будет сохранено в таблице данных "Реализация плана по годам" в одноименной колонке применительно к указанному при формировании отчета учебному году.

4. Формирование Перечня учебных планов с коэффициентами затратности

Отчет, выгружающий в MS Excel перечень всех Рабочих учебных планов одного учебного года (включая РУП, полученные по данным Объединенных планов) можно сформировать при помощи действия "Перечень утвержденных РУП", доступного с консоли управления в разделе Разработка учебных планов / Аналитические отчеты по РУП.

Перечень утвержденных РУП

При формировании отчета необходимо задать значение "Да" для параметра Выгружать коэффициенты затратности. В этом случае таблица сформируется со столбцом, содержащим коэффициенты затратности планов. В итоговых строках будут отражены средние значения коэффициента затратности по филиалу, факультету, уровню образования.

5. Отчеты о фактической затратности

Для оценки фактической затратности реализации образовательных программ представлены следующие отчеты:

  • Оценка фактической затратности ОП
  • Сводный отчет по затратности ОП в учебном году
  • Сводный отчет по затратности ОП по годам

5.1. Оценка фактической затратности ОП

Для формирования отчета Оценка фактической затратности ОП необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) выбрать учебный план.
  2. Из контекстного меню вызвать действие Оценка фактической затратности ОП.
    Вызов действия Оценка фактической затратности ОП
  3. В форме параметров необходимо указать Учебный год реализации образовательной программы, при этом Курс будет установлен автоматически. Для того чтобы отчет формировался подробно по каждому преподавателю, необходимо установить признак С конкретизацией по преподавателям.
    Форма параметров Оценка фактической затратности ОП

В результате сформируется отчет в виде Excel файла с оценкой фактической затратности реализации для одной выбранной образовательной программы, одного учебного года и одного курса.

Фактические значения рассчитываться следующим образом:

- Для дисциплины, НИС количество студентов данной ОП, которым назначена дисциплина или НИС для изучения на данном курсе.

- Для курсовой работы количество испытаний студентов данной ОП на данном курсе по курсовой работе с установленным признаком "В диплом" и непустым полем "Руководитель".

- Для практики количество испытаний студентов данной ОП на данном курсе по практике с установленным признаком "В диплом" и непустым полем "Руководитель практики".

- Для итогового экзамена количество студентов данной ОП, которым назначен итоговый экзамен для изучения на данном курсе.

- Для ВКР количество испытаний студентов данной ОП на данном курсе по ВКР с установленным признаком "В диплом" и непустым полем "Руководитель".

- Для проекта студентов количество испытаний студентов данной ОП на данном курсе по проекту с установленным признаком "В диплом" и непустым полем "Руководитель проекта - сотрудник вуза".

Доля студентов данной программы на данном курсе в предметной единице определяется как отношение количества студентов данной программы на данном курсе к общему количеству студентов в предметной единице. Количеством предметных единиц для строки отчета должна быть сумма долей по всем предметным единицам, подчиненным записи плана.

Количество студентов для расчета нагрузки за прием экзамена или зачета по дисциплинам, НИС и практикам определяется по ведомостям.

Количество потоков (при приеме письменных экзаменов) для дисциплин, НИС и практик рассчитывается как сумма долей студентов ОП определенного курса для каждого связанного приметного потока.

Количество групп (для консультаций при семестровой организации) для дисциплин НИС и практик рассчитывается как сумма долей студентов ОП для каждой связанной приметной группы.

Количество экзаменов для ВКР и итоговых экзаменов определяется как количество испытаний студентов данной ОП данного курса с признаком "в диплом", с непустым значением Руководитель работы (для ВКР), включенных в Локальные ГЭК.

Если при формировании отчета был установлен признак "С конкретизацией по преподавателям", то в отчет выгрузятся только те преподаватели, которым в плане нагрузки была назначена какая-либо нагрузка по записи учебного плана. При этом для видов работ, для которых невозможно определить однозначную связь преподаватель-студент, рассчитывается доля вклада преподавателя в выполнение нагрузки как отношение объема нагрузки определенного вида по записи плана, запланированной для данного преподавателя к объему нагрузки этого же вида, запланированной для всех преподавателей. Для отдельных видов работ фактическая нагрузка преподавателей считается по фактическому количеству связанных с ним студентов.

5.2. Сводный отчет по затратности ОП в учебном году

Для формирования отчета Сводный отчет по затратности ОП в учебном году необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) из контекстного меню вызвать действие Сводный отчет по затратности ОП в учебном году.
    Вызов действия Сводный отчет по затратности ОП в учебном году
  2. В форме параметров необходимо указать Учебный год, за который будет формироваться отчет. При необходимости можно конкретизировать перечень образовательных программ и курсов с помощью параметров Филиал, Факультет, Уровень образования, Форма обучения, Образовательная программа и Курс факультета.
    Если в форме параметров указан только параметр Учебный год, то отчет будет формироваться по всем образовательным программам и курсам ВУЗа, реализуемым в данном учебном году.
    Для выбора Образовательных программ и Курсов факультета, необходимо щелкнуть левой клавишей мыши на кнопку открытия справочника Справочник, в открывшихся справочниках или с помощью чек-бокса Чек-бокс выбрать одну или несколько записей и нажать кнопку ОК.

    Форма параметров Сводный отчет по затратности ОП в учебном году

В результате сформируется отчет в виде Excel файла со сводным отчетом по затратности в указанном учебном году для выбранных образовательных программ и курсов.

5.3. Сводный отчет по затратности ОП по годам

Для формирования отчета Сводный отчет по затратности ОП по годам необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) из контекстного меню вызвать действие Сводный отчет по затратности ОП по годам.
    Вызов действия Сводный отчет по затратности ОП по годам
  2. В форме параметров необходимо указать Учебный год начала обучения. При необходимости можно конкретизировать перечень образовательных программ и курсов с помощью параметров Филиал, Факультет, Уровень образования, Форма обучения, Образовательная программа и Курс факультета.
    Если в форме параметров указан только параметр Учебный год, то отчет будет формироваться по всем образовательным программам и курсам ВУЗа, реализуемым в данном учебном году.
    Для выбора Образовательных программ и Курсов факультета, необходимо щелкнуть левой клавишей мыши на кнопку открытия справочника Справочник, в открывшихся справочниках или с помощью чек-бокса Чек-бокс выбрать одну или несколько записей и нажать кнопку ОК.

    Форма параметров Сводный отчет по затратности ОП по годам

В результате сформируется отчет в виде Excel файла со сводным отчетом по затратности выбранных образовательных программ и курсов в учебных годах, начиная с указанного Учебного года начала обучения и до крайнего учебного года реализации образовательных программ.


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Редактирование объединенного учебного плана (раздел целиком) (31.03.2018) Одним файлом
Редактирование объединенного учебного плана

Сформировать структуру и состав нового объединенного учебного плана можно на основе образовательного стандарта. Для этого нужно выбрать объединенный учебный план в таблице данных и в контекстном меню выбрать действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Подтверждение формирования БУП

Если Вы уверены, что хотите сформировать учебный план на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Все записи плана.

После того, как объединенный учебный план сформирован на основе стандарта, его можно редактировать. Для редактирования предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования ОУП

Редактирование объединенного учебного плана должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), распределять нагрузку по видам работы (лекции, семинары, практические и т.д.), по годам обучения (курсам студентов) и по периодам обучения в каждом году (модулям, семестрам), а также планировать рубежные испытания, распределять кредиты и объем нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: дисциплину, научно-исследовательский семинар, курсовую работу, практику, проект студентов, дисциплину других планов, итоговый экзамен, выпускную квалификационную работу, зачетно-экзаменационные недели.

Добавление записи в ОУП

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

Редактирование записей объединенного плана

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение ряда свойств разделов и дисциплин БУП.

По окончании работы с объединенным учебным планом его можно вывести на печать. Для этого можно воспользоваться одним из действий Выгрузить для печати, Выгрузить для печати как Базовый, Выгрузить для печати как рабочий, расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

1. Добавление дисциплин и НИС

При добавлении дисциплины или НИС в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие дисциплину или научно-исследовательский семинар, после чего заполнить следующую форму параметров:

Добавление дисциплины в ОУП
Пользователям разработчикам учебных планов предоставлена возможность связывания дисциплин и НИС учебного плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
      Для выбора из плана-предложения кафедры будут доступны только те дисциплины, которые совпадают по периоду реализации с периодом, заданным с помощью полей Год начала реализации и Год окончания реализации.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных специализаций, необходимо выбрать специализации, для которых добавляется дисциплина. Для выбора специализаций необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей специализаций, после чего нужно нажать кнопку ОК.
      Для каждой специализации в ОУП будет создана отдельная запись по дисциплине.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных специализаций, необходимо выбрать специализации, для которых добавляется дисциплина. Для выбора специализаций необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей специализаций, после чего нужно нажать кнопку ОК.
      Для каждой специализации в ОУП будет создана отдельная запись по дисциплине.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать и изменять специализацию для дисциплин и НИС (см. Установить или снять специализацию).
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

1.1. Установить или снять специализацию

Для установки, снятия и изменения специализации, установленной для дисциплины или НИС, необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Все записи плана выбрать дисциплину или НИС, для которой необходимо установить, снять или изменить специализацию.
    При добавлении дисциплины или НИС можно установить сразу несколько специализаций, для каждой из них будет создана отдельная запись о дисциплине или НИС (см. Добавление дисциплин и НИС). В связи с этим необходимо удостовериться, что выбранная дисциплина или НИС соответствуют той записи, которую необходимо изменить. Установленные специализации можно проверить в поле Для специализации.
  3. Из контекстного меню вызвать действие Установить\изменить специализацию.
  4. В форме параметров указать Специализацию факультета (для ОУП бакалавриата и специалитета) или Магистерская специализация (для ОУП магистратуры).
  5. Нажать кнопку ОК.

1.2. Изменение периода реализации

Для изменения периода реализации дисциплины или НИС, необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Все записи плана выбрать дисциплину или НИС, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

1.3. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

2. Добавление курсовой работы

При добавлении курсовой работы в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие курсовую работы, после чего заполнить следующую форму параметров:

Добавление курсовой работы в ОУП

В первую очередь необходимо указать Наименование для курсовой работы, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК курсовая работа будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по курсовой работе.

3. Добавление практики

При добавлении практики в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие практику, после чего заполнить следующую форму параметров:

Добавление практики в ОУП

В первую очередь необходимо указать Вид практики (справочник ) и Способ проведения практики, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК практика будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по практике.

4. Добавление итогового экзамена

При добавлении итогового экзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие итоговый экзамен, после чего заполнить следующую форму параметров:

Добавление итогового экзамена в ОУП

В первую очередь необходимо указать Наименование для итогового экзамена, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК итоговый экзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по итоговому экзамену.

5. Добавление выпускной работы

При добавлении выпускной работы в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие выпускную работу, после чего заполнить следующую форму параметров:

Добавление ВКРБ в ОУП

В первую очередь необходимо указать Наименование и Форму итогового контроля для выпускной работы, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК выпускная работа будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по выпускной работе.

6. Добавление зачетно-экзаменационной недели

При добавлении зачетно-экзаменационной недели в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие зачетно-экзаменационную неделю, после чего заполнить следующую форму параметров:

Добавление зачетно-экзаменационных недель в ОУП

В первую очередь необходимо указать Наименование зачетно-экзаменационной недели, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК зачетно-экзаменационная неделя будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки для зачетно-экзаменационной недели.

7. Добавление проекта студентов

При добавлении проекта студентов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие проект студентов..., после чего заполнить следующую форму параметров:
Добавление проекта в ОУП

  • В поле Проект для студентов необходимо выбрать проект из справочника Проекты для студентов, если проект отсутствует, то его можно добавить (см. Проекты для студентов). Данное поле можно оставить пустым и не устанавливать ссылку на проект из справочника, а только указать Наименование проекта, Вид дисциплины в плане и Число кредитов.
    Записи о проектах в объединенных учебных планах, не связанные с записью справочника проектов, в учебный план факультета передаваться не будут.
  • В поле Вид дисциплины в плане выбрать вид дисциплины.
  • В поле Число кредитов указать соответствующее данному проекту число кредитов.
  • При необходимости установить признак Только в кумулятивный рейтинг.

После нажатия кнопки ОК проект будет добавлена в объединенный учебный план.

7.1. Проекты для студентов

Справочник "Проекты для студентов" позволяет работать с информацией о проектах, в которые могут включаться студенты в своей внеадиторной деятельности. Справочник распологается в разделе Объединенные учебные планы на соотвествующей вкладке Проекты для студентов.
Справочник проекты для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить проект.
    Вызов действия Добавить проект
  2. Заполнить форму параметров следующим образом:
    Форма параметров Добавить проект
    • Заполнить поля Идентификатор во внешней системе, Полное наименование, Полное наименование на английском языке, Тип проекта (выбирается из справочника Типы проектов для студентов), Вид проектной деятельности (выбирается из списка).
    • В одной из групп полей Руководитель из вуза или Внешний руководитель указать подразделение/организацию руководителя (выбирается из справочников или Места прохождения практики) и выбрать самого руководителя проекта (выбирается из справочника или Работники организации).
      Руководителем проекта может быть только либо представитель вуза, либо внешний руководитель. При этом если начать заполнять одну из групп полей (Руководитель из вуза или Внешний руководитель) другая перестанет быть доступной для заполнения.
    • Заполнить поля Учебный год, Дата начала реализации, Дата окончания реализации, Дата окончания записи на проект, Количество модулей, Период итогового контроля, Вид итогового контроля и Плановое количество кредитов.
  3. Нажать кнопку ОК.

7.1.1. Выгрузить проекты студентов

В справочнике Проекты для студентов предоставлена возможность сформировать отчет с информацией о проектах и студентах, которым назначены данные проекты.

Для формирования отчета необходимо:

  1. В справочнике Проекты для студентов из контекстного меню системы вызвать действие Выгрузить проекты студентов.
    Вызов действия Выгрузить проекты
  2. В форме пераметров с помощью выбора значений для параметров Филиал, Факультет, Образовательная программа, Курс, Группа, Проект можно ограничить выборку проектов, для которых будет формироваться отчет. Если все поля формы параметров оставить пустыми, то отчет сформируется для всех проектов ВУЗа, присутствующих в справочнике Проекты для студентов.
  3. Нажать кнопку ОК.

В результате сформируется отчет в формате MS Excel, содержащий информацию об образовательной программе, ФИО, курсе и группах студентов, участвующих в проектах, наименовании проекта, плановом и фактическом количестве кредитов, руководителях проектов, результатах участия в проекте студентов.

7.1.2. Загрузка данных о проектах с портала

7.1.3. Загрузка данных о назначении проектов студентам

7.2. Типы проектов для студентов

Справочник "Типы проектов для студентов" содержит в себе перечень типов проектов для внеаудиторной деятельности студентов и распологается в разделе Объединенные учебные планы на соотвествующей вкладке Типы проектов для студентов.
Справочник Типы проектов для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить тип проекта.
    Вызов действия Добавить тип проекта
  2. В форме параметров указать Краткое наименование и Полное наименование типа проекта для студентов.
    Форма параметров Добавить тип проекта
  3. Нажать кнопку ОК.

8. Добавление дисциплины других планов

Для добавления дисциплин, которые участвуют в расчетах затратности, но при этом не передаются в реализацию на факультеты и которые не участвуют в планировании нагрузки, необходимо:

  1. В форме редактирования объединенного учебного плана или в представлении Все записи плана из контекстного меню, в группе процедур Добавить, вызвать действие дисциплинудругих планов.
  2. Заполнить следующую форму параметров:
    Добавление дисциплины других учебных планов в ОУП
    • В полях Наименование и Наименование на английском языке указать наименование на русском и английском языке (при необходимости) соответственно.
    • При необходимости в поле Кафедра можно указать подразделение ВУЗа, которое реализует данную дисциплину. Для этого необходимо нажать кнопку Справочник, из справочника , с помощью чек-бокса Чек-бокс, выбрать подразделение и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, Общее число часов, Аудиторных часов и Только в кумулятивный рейтинг.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
  3. Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

Отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля) можно непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице, предназначено действие Дополнительные свойства.

9. Формирование информации о численности контингента

Для добавления информации о численности контингента необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать план, для записей которого будет уточняться информация о численности контингента.
  2. В представлении Все записи по годам обучения для записей учебного плана в соответствующих полях указать Количество потоков, Количество групп, Количество подгрупп и Количество студентов (после изменения значения каждого из параметров нужно нажимать клавишу Enter).


Дополнительные главы документации по учебному процессу(раздел целиком)

Дополнительные главы документации по учебному процессу - Общевузовские справочники компетенций (раздел целиком) (31.03.2018) Одним файлом
Общевузовские справочники компетенций

Работа по формированию системы компетенций оригинальных образовательных стандартов должна быть начата с формирования общевузовских классификаторов компетенций каждого из трех видов системных, социально-личностных и инструментальных.

Порядок работы с данными справочниками не существенен, однако до начала формирования перечней компетенций для конкретных образовательных стандартов общевузовские справочники компетенций должны быть сформированы полностью.

1. Системные (универсальные) компетенции

Работа с общевузовским справочником системных (универсальных) компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Системные компетенции.

Системные компетенции. Общевузовский справочник

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая системная компетенция имеет код и порядковый номер. Коды системных компетенций формируются автоматически из префикса СК-, символа уровня образования (Б или М) и порядкового номера (например, "СК-Б01", "СК-Б03", "СК-М08", "СК-М15"). Смысловое содержание компетенции представлено в поле Формулировка компетентностных образовательных результатов.

Для наполнения или уточнения общевузовского справочника системных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить системную компетенцию
  • Изменить порядковый номер
  • Удалить компетенцию
Уточнять текстовую формулировку компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter.

Добавление компетенции

Для того, чтобы добавить в справочник новую системную компетенцию, нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить системную компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление системной компетенции в общевузовский справочник

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Код компетенции значение будет составлено автоматически из префикса "СК-" (системная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура) и порядкового номера компетенции. Для порядковых номеров меньших 10 в первой позиции будет дописан 0. Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Формулировка компетентностных образовательных результатов значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой системной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера (кода) компетенции

Для изменения порядка следования компетенций предусмотрено действие контекстного меню Изменить порядковый номер. При изменении порядкового номера соответствующим образом изменится и код компетенции.

Изменение порядкового номера системной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции. При его изменении будет изменяться и код компетенции. Повтор порядковых номер компетенций недопустим. При попытке изменить порядковый номер компетенции на существующий произойдет ошибка дублирования объектов.

2. Социально-личностные компетенции

Работа с общевузовским справочником социально-личностных компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Социально-личностные компетенции.

Социально-личностные компетенции. Общевузовский справочник

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая социально-личностная компетенция имеет код и порядковый номер. Коды социально-личностных компетенций формируются автоматически из префикса СЛК-, символа уровня образования (Б или М) и порядкового номера (например, "СЛК-Б05", "СЛК-Б12", "СЛК-М02", "СЛК-М11"). Смысловое содержание компетенции представлено в поле Формулировка компетентностных образовательных результатов.

Для наполнения или уточнения общевузовского справочника социально-личностных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить социально-личностную компетенцию
  • Изменить порядковый номер
  • Удалить компетенцию
Уточнять текстовую формулировку компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter.

Добавление компетенции

Для того, чтобы добавить в справочник новую социально-личностную компетенцию, нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить социально-личностную компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление социально-личностной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Код компетенции значение будет составлено автоматически из префикса "СЛК-" (социально-личностная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура) и порядкового номера компетенции. Для порядковых номеров меньших 10 в первой позиции будет дописан 0. Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Формулировка компетентностных образовательных результатов значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера (кода) компетенции

Для изменения порядка следования компетенций предусмотрено действие контекстного меню Изменить порядковый номер. При изменении порядкового номера соответствующим образом изменится и код компетенции.

Изменение порядкового номера социально-личностной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции. При его изменении будет изменяться и код компетенции. Повтор порядковых номер компетенций недопустим. При попытке изменить порядковый номер компетенции на существующий произойдет ошибка дублирования объектов.

3. Инструментальные компетенции

Работа с общевузовским справочником инструментальных компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Инструментальные компетенции.

Инструментальные компетенции. Общевузовский справочник

Справочник имеет иерархическую структуру, которая отражает конкретизацию компетенций. Компетенции первого уровня являются наиболее общими и обозначают укрупненные виды деятельности (проектная деятельность, общение и коммуникация и проч.). Компетенция, которую конкретизирует данная компетенция, далее будет называться "родительской", а те компетенции, которые, в свою очередь, конкретизируют данную, будут называться "дочерними". Например, на представленном выше рисунке по отношению к компетенции "ИК-Б1.1 участвовать" родительской является компетенция "ИК-Б1 Проектная и иная деятельность", а дочерними являются компетенции "ИК-Б1.1н в научной деятельности" и "ИК-Б1.1и в исследовательской деятельности".

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая инструментальная компетенция имеет код и порядковый номер, а также может иметь символьное обозначение. Коды социально-личностных компетенций формируются автоматически из префикса ИК-, символа уровня образования (Б или М), собственного порядкового номера и порядковых номеров родительских компетенций, разделенных точкой, и символьного обозначения (при его наличии). Например, коды инструментальных компетенций могут иметь следующий вид: "ИК-Б1", "ИК-Б2.3", "ИК-М3.1и", "ИК-М2.2э". Для инструментальных компетенций в справочник заносится только наименование. Формулировки компетентностных образовательных результатов для компетенций данного вида будут задаваться отдельно для каждого из образовательных стандартов. Также в справочнике отображается формируемое автоматически полное наименование компетенции, составленное из наименования самой компетенции и всех ее родительских компетенций, разделенных символами "/".

Для наполнения или уточнения общевузовского справочника инструментальных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить компетенцию на первый уровень
  • Добавить дочернюю компетенцию
  • Изменить порядковый номер или символьное обозначение
  • Изменить родительскую компетенцию
  • Удалить компетенцию
Уточнять наименование компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter. Полное наименование компетенции при этом изменится автоматически.

Добавление компетенции

Для добавления инструментальных компетенций предусмотрено два действия: Добавить компетенцию на первый уровень и Добавить дочернюю компетенцию. Выбор действия зависит от того, нужно ли добавить самостоятельную компетенцию первого уровня, соответствующую укрупненному виду деятельности, которая не будет иметь родительской компетенции, или нужно добавить компетенцию, уточняющую одну из существующих (дочернюю по отношению к существующей).

Для добавления самостоятельной компетенции первого уровня нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить компетенцию на первый уровень. Отобразиться форма параметров процедуры добавления:

Добавление инструментальной компетенции на первый уровень

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего на первом уровне для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Символьное обозначение можно ввести символ, дополняющий код компетенции, если это необходимо. Если символьное обозначение для данной компетенции не используется, поле нужно оставить пустым.
  • В поле Код компетенции значение будет составлено автоматически из префикса "ИК-" (инструментальная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура), порядкового номера компетенции, символьного обозначения (если оно использовано). Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Наименование компетенции значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Для добавления компетенции, конкретизирующей одну из существующих, нужно сначала выбрать существующую (родительскую) компетенцию, которая должна быть конкретизирована, после чего вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить дочернюю компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление дочерней инструментальной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Родительская компетенция будет отображен код родительской компетенции, которая была выбрана в таблице данных перед вызовом действия добавления. Если новая компетенция должна быть подчинена другой родительской компетенции, то нужно закрыть данную форму при помощи кнопки Отмена, выбрать в таблице данных нужную родительскую компетенцию и снова вызвать действие добавления дочерней компетенции.
  • В поле Уровень образования значение будет подставлено автоматически на основе выбранной родительской компетенции. Изменять это значение при добавлении недопустимо. Если нужно добавить компетенцию для другого уровня образования, то нужно закрыть данную форму, выбрать в таблице данных родительскую компетенцию, принадлежащую к другому уровню образования и повторить добавление.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего на данном уровне иерархии для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Символьное обозначение можно ввести символ, дополняющий код компетенции, если это необходимо. Если символьное обозначение для данной компетенции не используется, поле нужно оставить пустым.
  • В поле Код компетенции значение будет составлено автоматически из префикса "ИК-" (инструментальная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура), порядкового номера компетенции и ее родительских компетенций, символьного обозначения (если оно использовано). Управлять значением данного поля можно изменяя порядковый номер, символьное значение или выбрав другую родительскую компетенцию перед добавлением.
  • В поле Наименование компетенции значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Удаление компетенции, имеющей дочерние компетенции, недопустимо. Если такую компетенцию все же надо удалить, то сначала нужно удалить все ее дочерние компетенции.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера и символьного обозначения компетенции

Для изменения порядка следования компетенций и их символьных обозначений предусмотрено действие контекстного меню Изменить порядковый номер или символьное обозначение. При изменении порядкового номера или символьного обозначения соответствующим образом изменится и код компетенции.

Изменение порядкового номера или символьного обозначения инструментальной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции и символьное обозначение. При изменении этих значений будет изменяться и код компетенции. Повтор полученных кодов компетенций недопустим. При попытке изменить порядковый номер или символьное обозначение таким образом, что полученный код компетенции будет повторять один из существующих, произойдет ошибка дублирования объектов.

Перенос компетенций по иерархической структуре

Для того, чтобы перенести существующую компетенцию по структуре (т.е. изменить для нее родительскую компетенцию), можно воспользоваться действием Изменить родительскую компетенцию.

Изменение родительской компетенции для инструментальной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Родительская компетенция нужно выбрать другую компетенцию из предложенного перечня, которая должна стать родительской по отношению к данной.
  • Значение полей Уровень образования и Наименование компетенции при использовании данной процедуры изменять нельзя.
  • В полях Порядковый номер и Символьное обозначение можно изменять значения описанным выше образом. Также при этом будет изменяться значение в поле Код компетенции.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о компетенции изменит свое положение в иерархической структуре. Также ей будут присвоены новые значения порядкового номера, сиваольного обозначения и кода.


Дополнительные главы документации по учебному процессу (одним файлом)

Дополнительные главы документации по учебному процессу (одним файлом) (31.03.2018)
1. Разработка и согласование учебных планов

Подсистема разработки и согласования учебных планов автоматизирует процессы подготовки проектов учебных планов факультетов и отделений на основе действующих образовательных стандартов, контроля соответствия проектов планов утвержденным требованиям и нормативами, процедуры согласования планов должностными лицами ВУЗа, контроля степени готовности планов очередного учебного года.

Доступ к функционалу подсистемы осуществляется посредством форм работы с данными Образовательные стандарты, Базовые и рабочие учебные планы, Ход согласования учебных планов. Данные формы доступны на Консоли управления системы в визуальной группе Разработка учебных планов.

Доступ пользователя к функционалу подсистемы зависит о его включения в одну из ролей:

  • Разработчик учебных планов
  • Специалист Методического управления
  • Проректор, согласующий учебные планы
  • Первый проректор, утверждающий рабочие учебные планы, согласующий базовые учебные планы
  • Ректор, утверждающий базовые учебные планы
  • Администратор подсистемы разработки учебных планов

Работа по подготовке, согласованию и утверждению учебных планов состоит из следующих этапов:

  1. Формирование справочника типов образовательных стандартов.
  2. Ввод образовательных стандартов.
  3. Формирование базовых учебных планов на основе образовательных стандартов.
  4. Формирование рабочих учебных планов на основе базовых учебных планов.

Описанный порядок работы касается как учебных планов основных образовательных программ подготовки бакалавров, специалистов и магистров, так и учебных планов аспирантуры.

Помимо учебных планов образовательных программ в системе также предусмотрена работа со следующими особыми видами учебных планов:

Рабочие учебные планы общевузовских дисциплин - это наборы дисциплин, которые предлагаются для выбора всем студентам вуза независимо от того, по какой образовательной программе они обучаются.

Майноры учебных планов - это наборы дисциплин, предлагаемых отдельными образовательными программами для изучения студентами других образовательных программ. Дисциплины майнора являются связанными друг с другом и планируются для изучения в течение нескольких лет (курсов). Студенты выбирают для изучения тот или иной майнор, после чего дисциплины, входящие в состав майнора, становятся обязательными для студента. Майноры могут принадлежать к одному из двух типов:

  • Обычный майнор - это набор дисциплин, изучение которых запланировано в определенной последовательности. При выборе студентом такого майнора на начальном курсе, дисциплины майнора становятся обязательным для него как на этом, так и на последующих курсах.
  • Свободный майнор - это такой майнор, выбрав который, студент сохраняет свободу в выборе дисциплин из любых майноров в течение всех лет обучения. В системе такой майнор создается, но не наполняется дисциплинами (т.е. остается пустым).

Мйноры, по аналогии с учебными планами, могут быть "базовыми" и "рабочими". Базовые майноры позволяют планировать перечень дисциплин и последовательность их изучения на все годы реализации майнора. Рабочие майноры более подробно отражают изучение дисциплин майноров в одном учебном году (для одного курса студентов). Каждый Рабочий майнор должен разрабатываться на основе утвержденного Базового майнора, должен содержать те же группы дисциплин и дисциплины, соответствующие дисциплинам Базового майнора, реализуемым в одном учебном году.

1.1. Настройки для работы с учебными планами

Прежде чем начать пользоваться функционалом участка Разработка учебных планов необходимо задать настройки Филиал и Факультет. Для определения данных настроек нужно воспользоваться разделом Настройки для работы с учебными планами на участке Разработка учебных планов.
Настройки для работы с учебными планами

После нажатия кнопки ОК все настройки будут заданы.

1.2. Справочник "Типы образовательных стандартов"

Работа со справочником ведется в форме Образовательные стандарты на вкладке Типы образовательных стандартов.

Типы образовательных стандартов

Для добавления нового вида стандарта нужно вызвать в таблице данных действие Добавить тип стандарта и заполнить поля Краткое наименование и Полное наименование.

Добавление типа стандарта

После добавления типа стандарта его краткое и полное наименование можно скорректировать непосредственно в таблице данных, введя новое значение с клавиатуры и нажав клавишу Enter.

Если тип стандарта создан ошибочно, его можно удалить, вызвав действие Удалить. Удаление возможно только в том случае, если в системе не существует стандартов данного вида.

1.3. Образовательные стандарты

Образовательный стандарт в системе представляет собой иерархическую структуру учебных циклов и включенных в них учебных дисциплин, снабженных информацией о трудоемкости их усвоения, выраженной в зачетных единицах (кредитах) или в учебных часах. Каждый образовательный стандарт соответствует одной степени / квалификации по одному из направлений / специальностей подготовки. К каждому образовательному стандарту относится перечень компетенций, развиваемых в ходе обучения студента по соответствующей образовательной программе. Развитие компетенций в каждом из учебных циклов отражается за счет связи цикла с набором компетенций стандарта.

Создание нового образовательного стандарта включает следующие этапы работы:

  1. Создание записи о стандарте.
  2. Наполнение стандарта записями о циклах дисциплин, учебных дисциплинах и других видах учебной нагрузки.
  3. Создание перечня компетенций, входящих в состав стандарта.
  4. Связывание записей стандарта с компетенциями.
Работа с компетенциями (пункты 3 и 4) ведется только при работе с образовательными стандартами III поколения (ФГОС, Оригинальные образовательные стандарты).

1.3.1. Создание нового образовательного стандарта

Для создания нового образовательного стандарта необходимо открыть форму Образовательные стандарты. Форма доступна на Консоли управления или на Панели инструментов системы.

В основной таблице данных Образовательные стандарты необходимо вызвать действие Добавить образовательный стандарт. При вызове действия будет отображена форма параметров нового стандарта:

Добавление образовательного стандарта

Поля формы добавления нужно заполнить следующим образом:

  • В поле Тип образовательного стандарта нужно выбрать один из типов, занесенных в Справочник "Типы образовательных стандартов".
  • В поле Уровень образования из выпадающего списка необходимо выбрать один из вариантов Бакалавриат, Специалитет, Магистратура или Аспирантура в зависимости от того, для какого уровня образования предназначен стандарт.
  • В поле Направление / специальность нужно выбрать соответствующую запись из общевузовского справочника . При выборе направления или специальности обращайте внимание не только на ее наименование, но и на код. Если в предыдущем поле выбрано значение "Бакалавриат" или "Магистратура", то для выбора будут предложены записи справочника, являющиеся направлениями, если же выбрано значение "Специалитет", то будут предложены записи, являющиеся специальностями (установлен флаг Является специальностью). В случае если Вы не находите нужного направления или специальности в этом справочнике, необходимо обратиться к бизнес-администратору системы с просьбой добавить его в справочник.
  • В поле Степень (квалификация) нужно выбрать степень или квалификацию, соответствующую уровню образования. В случае, если в предыдущем поле выбрано направление подготовки, то для выбора будут доступны степени бакалавр или магистр. Если же выбрана специальность, то для выбора будет доступна соответствующая квалификация. При создании образовательного стандарта для аспирантуры нужно выбрать степень кандидат наук.

Поле заполнения полей формы добавления надо нажать кнопку ОК, в результате чего в таблице появится запись о новом стандарте. При создании стандарта ему автоматически присваивается наименование, состоящее из типа стандарта, кода и наименования направления (специальности) и степени (квалификации). Создание двух и более стандартов одного типа по одной и той же степени (квалификации) одного и того же направления (специальности) недопустимо. При попытке создать второй аналогичный стандарт пользователь увидит сообщение об ошибке дублирования объектов.

Все созданные в системе образовательные стандарты отображаются в одной таблице данных, сгруппированной по уровням образования.

1.3.2. Наполнение образовательного стандарта

После создания записи о стандарте можно формировать структуру компонентов и дисциплин, составляющих стандарт. Записи стандарта имеют иерархическую структуру, отражающую включенность одних компонентов в состав других и вхождение дисциплин и других видов учебной нагрузки в группы и компоненты. Каждая запись наряду с атрибутами "наименование", "число часов", "число кредитов" и проч. имеет атрибут Входит в раздел, содержащий ссылку на раздел (или группу), в состав которого входит данная запись.

Стандарт состоит из записей нескольких видов:

  • раздел (цикл, компонент)
  • группа дисциплин
  • дисциплина
  • научно-исследовательский семинар
  • курсовая работа
  • практика
  • итоговый госэкзамен
  • выпускная квалификационная работа
  • зачетно-экзаменационные недели

Добавление записей стандарта производится путем вызова соответствующего действия их группы действий Добавить ....

Вид записи группа дисциплин должен использоваться во всех случаях, когда добавляемая запись строго не соответствует одной конкретной дисциплине, которая будет преподаваться на факультете определенной кафедрой по определенной программе или одной конкретной практике, курсовой работе и т.п. Например, запись "Иностранный язык" должна создаваться как группа дисциплин, в которую впоследствии будут включаться дисциплины "Английский язык", "Немецкий язык", "Французский язык" и т.д. Если набор иностранных языков, которые могут (должны) преподаваться по стандарту, известен, то их можно включить в группу иностранных языков как дисциплины. Если же набор иностранных языков не зафиксирован в стандарте, их можно будет задать позже при работе с базовым или рабочим учебным планом.

Если в стандарте задается объем нагрузки для курсовых работ в целом, а не для каждой работы, то такая запись также должна быть создана как раздел или группа дисциплин.

Если в стандарте задаются конкретные виды практик (учебная практика, преддипломная практика и т.д.), то такие записи могут быть созданы как практики. Если же в стандарте задается практика в целом, то такую запись нужно создать как раздел или как группу дисциплин.

В раздел итоговой государственной аттестации можно включить записи вида "итоговый госэкзамен" и "выпускная квалификационная работа", под которыми имеются в виду конкретные виды итоговых испытаний.

В дальнейшем при работе над базовыми и рабочими учебными планами, формируемыми на базе стандарта, в разделы и группы дисциплин можно будет включить записи о конкретных учебных дисциплинах и других видах учебной нагрузки. Также группы дисциплин используются в БУП и РУП для выделения групп дисциплин по выбору и задания их характеристик (число дисциплин или число кредитов, которое должно быть выбрано студентом по группе дисциплин).

Добавление записей стандарта должно начинаться с добавления корневого раздела (компонента). Для корневого раздела, как правило, задается наименование Вся образовательная программа. Для корневого компонента значение атрибута Входит в раздел должно быть пустым. Остальные записи должны включаться в состав этого корневого компонента или в состав других компонентов. Включение записей в состав дисциплин недопустимо. Иерархическая структура позволяет формировать стандарты любой структуры. Следующие ниже примеры будут иллюстрировать создание стандартов II и III поколения. Если ВУЗ имеет право вести обучение по собственным (оригинальным) стандартам, то они должны быть сформированы по аналогичным принципам.

Разделы и дисциплины стандарта могут иметь коды (ГСЭ.0, ЕН.Ф.03, Б1, Б5). В связи с тем, что в стандартах разных типов принято использование различных систем кодирования, включающих различные символы, а также в связи с тем, что не все записи стандарта имеют коды, для корректного задания порядка следования записей в стандарте используется дополнительное числовое поле Порядковый номер. Сортировка записей стандарта будет производиться в порядке возрастания значения порядкового номера в рамках каждого уровня иерархии (т.е. в рамках каждого раздела).

Пример структуры стандарта II поколения:

Структура стандарта II поколения

Пример структуры стандарта III поколения:

1.3.2.1. Добавление разделов (циклов, компанентов) стандарта

Для добавления компонента стандарта нужно выбрать запись о стандарте в основной таблице данных Образовательные стандарты, после чего в подчиненной таблице Состав стандарта вызвать действие Добавить ... / раздел. При добавлении первой записи нужно выполнить щелчок правой кнопкой мыши в пустом поле таблицы. При добавлении записи более низкого уровня сначала нужно выбрать запись компонента, в который планируется включить новый компонент, и только после этого вызвать действие добавления. Ссылка на запись компонента, выбранного в момент вызова действия добавления отобразится в поле Входит в раздел формы параметров. Если по ошибке вместо компонента выбрана дисциплина, то в поле Входит в раздел будет подставлена ссылка на раздел (компонент), в который включена данная дисциплина.

Добавление компонента стандарта II поколения:

Добавление раздела стандарта II поколения

Добавление компонента стандарта III поколения:

Добавление раздела стандарта III поколения

Поля формы добавления нужно заполнить следующим образом:

  • В поле Входит в раздел значение подставляется автоматически. Новая запись будет включена именно в данный раздел. При добавлении первой записи данное поле нужно оставить пустым. Если в поле подставилось значение, а Вы хотите добавить запись на первый уровень, то значение в поле нужно очистить, выделив весь текст и нажав клавишу Del.
  • Поле Компонент плана предназначено для работы со стандартами II поколения. В этом случае нужно выбрать необходимый компонент из справочника компонентов стандартов II поколения. После выбора значения в этом поле автоматически заполнятся и станут недоступными для изменения значения в полях Код записи и Наименование. При работе со стандартами III поколения это поле нужно оставить пустым.
  • В поле Наименование нужно ввести наименование раздела в случае, если не выбрано значение в предыдущем поле.
  • В поле Код записи нужно ввести код раздела в случае, если он задан в стандарте. Для стандартов II поколения это поле будет заполнено автоматически после выбора компонента плана в поле Компонент плана.
  • В поле Порядковый номер нужно ввести целое число, которое будет определять позицию записи в ряду всех записей, входящих в один раздел. Это значение предлагается автоматически как максимально существующий в данном разделе порядковый номер + 1. Если Вы хотите вставить запись не в конец, а в середину то это значение можно скорректировать. В этом случае после добавления записи нужно будет проверить и при необходимости изменить порядковые номера других записей. Сортировка записей стандарта будет производиться по значениям порядковых номеров в пределах каждого раздела. Допустим (но не рекомендуется) повтор значений порядковых номеров. В этом случае записи будут отсортированы в случайном порядке. Допустим пропуск значений позиций (например, 5, 10, 15, ...).
  • В поле Общее число часов нужно ввести значение общего числа часов по всем записям плана, входящим в раздел, в случае если это значение задано в стандарте.
  • В поле Число недель нужно ввести число недель, выделяемое на раздел, если это значение задано в стандарте.
  • Поля Минимальное число кредитов и Максимальное число кредитов предназначены для задания диапазона допустимых сумм кредитов для стандартов III поколения. В случае если задано одно значение числа кредитов, его нужно повторить в обоих полях.

1.3.2.2. Добавление групп дисциплин

В случае, если в стандарте указаны не конкретные дисциплины, а их обобщенные наименования (например, "Иностранный язык", "Древние языки", "Инженерно-технологические дисциплины, отражающие специфику отраслей сферы материального производства" и т.п.), то такие записи должны добавляться как группы дисциплин. При разработке базового учебного плана эти группы должны быть уточнены путем включения в них тех дисциплин, которые будут читаться студентам факультета (например, в группу "Иностранный язык" в базовом плане будут включены дисциплины "Английский язык", "Немецкий язык", в группу "Древние языки" будут включены дисциплины "Древнегреческий язык", "Латинский язык").

Для того, чтобы добавить в стандарт группу дисциплин нужно на вкладке Состав стандарта выбрать раздел, в который должна быть включена новая группа дисциплин и вызвать действие Добавить ... / группу дисциплин.

Добавление группы дисциплин в стандарт
  • В поле Входит в раздел должна отображаться ссылка на раздел, в который будет включена новая группа дисциплин. Если отображается неверный раздел, то нужно закрыть форму добавления, выбрать в списке записей стандарта нужный раздел и повторить вызов действия добавления.
  • В поле Наименование нужно ввести наименование группы дисциплин.
  • В поле Порядковый номер будет предложен очередной порядковый номер записи в выбранном разделе. При необходимости его можно изменить.
  • В поле Количество выбираемых дисциплин нужно занести числовое значение числа дисциплин данной группы, которое обязательно к изучению студентами.
  • В поле Общее число часов нужно занести число часов, выделяемых на изучение дисциплин группы.
  • В поле Число недель будет предложено значение, равное заданному числу часов, разделенному на 54. При необходимости это значение можно изменить.
  • В поле Число кредитовбудет предложено значение, равное заданному числу часов, разделенному на 36. При необходимости это значение можно изменить.

После нажатия кнопки ОК запись о новой группе дисциплин появится в таблице данных. После добавления группы дисциплин в нее можно включать отдельные дисциплины (если набор дисциплин задается в стандарте).

1.3.2.3. Добавление дисциплин

Дисциплины могут добавляться в любой из компонентов стандарта или в группу дисциплин. Для добавления дисциплины нужно выбрать в таблице данных компонент или группу, в которую должна быть включена дисциплина, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / дисциплину. При помощи этого действия должны добавляться только конкретные учебные дисциплины, которые будут читаться на факультете (отделении) определенной кафедрой по определенной программе. Если же в стандарте дисциплины заданы укрупненно, то нужно пользоваться действием добавления группы дисциплин (Добавление групп дисциплин).

Добавление дисциплины стандарта

Поля формы добавления дисциплины нужно заполнить следующим образом:

  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного компонента и снова вызвать действие добавления дисциплины.
  • В поле Дисциплина нужно выбрать дисциплину из общевузовского справочника дисциплин. Выбор можно осуществлять путем ввода начала наименования дисциплины с клавиатуры. При вводе будут предлагаться существующие в справочнике дисциплины. Процедура поиска дисциплины чувствительная к регистру символов. Наименования всех дисциплин справочника, как правило, начинаются с заглавной буквы. Если нужной дисциплины нет в справочнике, ее можно добавить, открыв справочник и вызвав действие Добавить дисциплину ВУЗа. Для добавления новой дисциплины достаточно ввести ее полное наименование. Наименование должно вводиться без сокращений. В дальнейшем оно будет использоваться во всех отчетных документах, а также в дипломе студента. Если при попытке добавления новой дисциплины произошла ошибка дублирования объектов, это означает, что дисциплина с таким наименованием уже существует.
  • В поле Код записи нужно ввести значение кода дисциплины в стандарте, если оно задано.
  • В поле Порядковый номер значение предлагается автоматически как следующая за максимально существующей в рамках раздела. При необходимости это значение можно изменить. Если необходимо добавить дисциплину не в конец, а в середину существующего списка, необходимо проверить и уточнить позиции всех следующих за ней дисциплин.
  • В поле Вид дисциплины нужно выбрать один из видов из выпадающего списка. Выбранный вид дисциплины в дальнейшем будет использоваться при контроле полноты и корректности формирования БУПов и РУПов, который может предполагать различные контрольные нормативы для обязательных дисциплин, факультативов, адаптационных дисциплин. Также от выбранного вида дисциплины зависит ее обязательность для изучения всеми студентами.
  • В поле По выбору студентов значение подставляется автоматически в зависимости от значения, выбранного в поле Вид дисциплины. Для видов Обязательная дисциплина и Обязательный факультатив подставляется значение Да, в остальных случаях - значение Нет. При необходимости установленное автоматически значение можно изменить.
  • В поле Общее число часов нужно ввести значение числа часов, выделяемых на изучение дисциплины, если оно задано в стандарте. При изменении значения в этом поле будут автоматически пересчитываться значения в полях Число недель и Число кредитов.
  • В поле Число недель значение будет заполнено автоматически путем деления значения из поля Общее число часов на 54. При необходимости это значение можно скорректировать.
  • В поле Число кредитов значение будет заполнено автоматически путем деления значения из поля Общее число часов на 36. При необходимости это значение можно скорректировать.

1.3.2.4. Добавление научно-исследовательских семинаров

Для добавления научно-исследовательского семинара предназначено действие Добавить / научно-исследовательский семинар. Форма добавление семинара и принципы ее заполнения аналогичны форме добавления дисциплины. Сам семинар выбирается из справочника всех дисциплин вуза. Если нужно семинара нет в справочнике, его можно добавить.

1.3.2.5. Добавление курсовых работ

Добавлять в образовательный стандарт курсовые работы надо только в том случае, если в нем зафиксированы конкретные работы, которые должны быть выполнены студентами. Если же курсовые работы заданы в стандарте укрупненно, то нужно пользоваться действиями, описанными в разделах Добавление разделов (циклов, компонентов) стандарта и Добавление групп дисциплин.

Для добавления курсовой работы нужно выбрать в таблице данных компонент или группу, в которую должна быть включена курсовая работа, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / курсовую работу. Курсовые работы могут быть как по одной конкретной учебной дисциплине, так и междисциплинарные. На приведенных ниже рисунках представлены примеры заполнения формы параметров в этих двух случаях. Если курсовая работа выполняется по конкретной дисциплине, но дисциплина может выбираться студентом, то курсовая работа добавляется по аналогии с междисциплинарной (дисциплина не указывается).

Добавление курсовой работы по дисциплине в стандарт

Добавление междисциплинарной курсовой в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел (группу дисциплин), который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления курсовой работы.
  • Поле По дисциплине нужно заполнять только в том случае, если курсовая работа должна выполняться по одной конкретной учебной дисциплине всеми студентами. Если дисциплина может выбираться студентами, или если курсовая работа является междисциплинарной, то данное поле нужно оставить пустым.
  • Поле Наименование доступно для заполнения только в том случае, если не выбрана дисциплина. По умолчанию предлагается наименование "Курсовая работа", но его можно изменить (например, "Междисциплинарная курсовая работа"). Если же дисциплина выбрана, то наименование курсовой работы будет сформировано автоматически.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для курсовых работ.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на данную курсовую работу.

После нажатия кнопки ОК на форме параметров запись о курсовой работе появится в таблице данных в соответствующей позиции.

1.3.2.6. Добавление практик

Добавлять в образовательный стандарт практики надо только в том случае, если в нем зафиксированы конкретные виды практик, которые должны быть пройдены студентами. Если же практики заданы в стандарте укрупненно, то нужно пользоваться действиями, описанными в разделах Добавление разделов (циклов, компонентов) стандарта и Добавление групп дисциплин.

Для добавления практики нужно выбрать в таблице данных компонент или группу, в которую должна быть включена практика, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить... / практику. Как правило, в образовательных стандартах выделяются специальные разделы практик.

Добавление практики в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел (группу дисциплин), который был выбран в таблице в момент вызова действия добавления. Если при вызове действия была выбрана дисциплина, то в поле подставится ссылка на раздел, в который входит данная дисциплина. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления практики.
  • В поле Вид практики нужно выбрать практику из общевузовского справочника .
  • В поле Способ проведения практики нужно выбрать один из способов проведения практики.
  • После выбора вида практики в поле Наименование будет автоматически сформировано значение, соответствующее выбранному виду практики. Изменять его независимо от вида практики недопустимо.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • В поле Общее число часов значение можно оставить пустым, если оно не зафиксировано в стандарте.
  • В поле Число недель нужно задать число недель, выделяемых на практику.
  • В поле Число кредитов нужно установить число кредитов, выделяемых на практику, соблюдая требуемое соотношение между числом недель и числом кредитов.

После нажатия кнопки ОК на форме параметров запись о практике появится в таблице данных в соответствующей позиции.

1.3.2.7. Добавление итоговых госэкзаменов

итоговые государственные экзамены должны добавляться в раздел итоговой аттестации. Итоговые госэкзамены могут быть по одной конкретной дисциплине, или междисциплинарными.

Для добавления итогового экзамена нужно выбрать в таблице данных раздел итоговой аттестации, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / итоговый госэкзамен. На приведенных ниже рисунках представлены примеры заполнения формы параметров для случая добавления экзамена по дисциплине и междисциплинарного экзамена.

Добавление итогового экзамена по дисциплине в стандарт

Добавление междисциплинарного итогового экзамена в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления итогового госэкзамена.
  • Поле Дисциплина нужно заполнять только в случае экзамена по дисциплине. При выборе дисциплины автоматически формируется наименование записи об итоговом экзамене. Если экзамен является междисциплинарным, то поле Дисциплина нужно оставить пустым.
  • Поле Наименование доступно для заполнения только в случае, если поле Дисциплина пустое. В этом случае наименование итогового экзамена нужно ввести вручную с клавиатуры.
    Наименование, заданное для итогового экзамена, будет в дальнейшем использовано при формировании дипломов студентов.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для итогового экзамена.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на итоговый экзамен в соответствии с действующими нормативами.

После нажатия кнопки ОК на форме параметров запись об итоговом госэкзамене появится в таблице данных в соответствующей позиции.

1.3.2.8. Добавление выпускных квалификационных работ

Выпускные квалификационные работы (ВКР) должны добавляться в раздел итоговой аттестации.

Для добавления ВКР нужно выбрать в таблице данных раздел итоговой аттестации, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / выпускную работу.

Добавление ВКР в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления ВКР.
  • В поле Наименование нужно ввести наименование ВКР с клавиатуры (Например, "Подготовка и защита выпускной работы бакалавра" или "Подготовка и защита магистерской диссертации").
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • Поля Общее число часов и Число недель можно оставить пустыми, если данные показатели не фиксируются для ВКР.
  • В поле Число кредитов нужно занести число кредитов, выделяемых на ВКР в соответствии с действующими нормативами.

После нажатия кнопки ОК на форме параметров запись о выпускной работе появится в таблице данных в соответствующей позиции.

1.3.2.9. Добавление зачетно-экзаменационных недель

Зачетно-экзаменационные недели должны добавляться в корневой раздел стандарта (раздел "Вся образовательная программа").

Для добавления записи о зачетно-экзаменационных неделях нужно выбрать в таблице данных корневой раздел, после чего кликнуть правой кнопкой мыши и вызвать действие Добавить ... / зачетно-экзаменационные недели.

Добавление зачетно-экзаменационных недель в стандарт
  • В поле Входит в раздел автоматически будет поставлена ссылка на раздел, который был выбран в таблице в момент вызова действия добавления. Если значение, подставленное в поле, Вы считаете неверным, то рекомендуется закрыть форму добавления, нажав кнопку Отмена, после чего выбрать запись нужного раздела и снова вызвать действие добавления ВКР.
  • В поле Наименование автоматически формируется строка "Зачетно-экзаменационные недели". При необходимости это значение можно изменить.
  • В поле Порядковый номер значение будет предложено автоматически. При необходимости его можно изменить.
  • В поля Общее число часов и Число недель нужно занести значения, предусмотренные стандартом.

После нажатия кнопки ОК на форме параметров запись о зачетно-экзаменационных неделях появится в таблице данных в соответствующей позиции.

1.3.2.10. Внесение изменений в созданный стандарт

После того, как созданы записи стандарта, можно изменять как отдельные свойства записей, так и структуру стандарта. Доступны изменения следующих видов:

  1. Добавление новых записей.
    Для дополнения стандарта новыми записями необходимо вызвать одно из действий добавления, описанных в предыдущих разделах.
  2. Уточнение значений свойств записей стандарта.
    Значения различных свойств записей изменяются разными способами:
    • Наименование можно изменять путем ввода нового значения с клавиатуры с последующим нажатием клавиши Enter для всех записей, кроме тех, которые соответствуют дисциплинам (заполнено значение в колонке Дисциплина) или компонентам стандарта II поколения (заполнено значение в колонке Компонент плана). Для изменения наименования записи, соответствующей дисциплине, нужно в колонке Дисциплина выбрать другую дисциплину из справочника дисциплин. Если нужно дисциплины в справочнике нет, ее можно добавить в справочник. Для изменения наименования записи, соответствующей компоненту стандарта II поколения (ГОС) нужно выбрать другой компонент в колонке Компонент плана. Если нужного компонента в справочнике нет, необходимо обратиться к бизнес-администратору системы с просьбой уточнить данные справочника. При изменении наименования практики нужно проследить за тем, чтобы наименование соответствовало значению, установленному в колонке Вид практики.
    • Порядковый номер можно изменять путем ввода нового числового значения с клавиатуры с последующим нажатием клавиши Enter. При изменении порядкового номера одной из записей необходимо просмотреть значения порядковых номеров всех следующих за ней записей раздела и при необходимости скорректировать и их.
    • Код записи, Общее число часов, Число недель, Минимальное число кредитов, Максимальное число кредитов можно изменять путем ввода нового значения с клавиатуры с последующим нажатием клавиши Enter.
    • При изменении значений, выбранных в колонках Дисциплина и Компонент плана автоматически изменится значение в колонке Наименование.
    • Если Вы изменяете значение, выбранное в колонке Вид практики, необходимо вручную уточнить значение в колонке Наименование.
  3. Изменение структуры стандарта.
    Под изменением структуры понимается перенос записей из одного раздела в другой. Для этого нужно выбрать запись, которую Вы хотите перенести и вызвать для нее действие Перенести в другой раздел. Для выполнения действия нужно указать раздел, которому будет непосредственно подчинена запись.

    Перенос записи в другой раздел

    Для выбора будут доступны только записи вида Раздел плана (компоненты и группы дисциплин). Если Вы выполняете перенос раздела или группы, то необходимо следить за тем, чтобы не включить раздел сам в себя. При подобной попытке будет отображено сообщение об ошибке с текстом "Недопустимо включать раздел сам в себя".
  4. Удаление записей.
    Удаление записей производится при помощи действия Удалить, доступного в контекстном меню. Удалить можно только ту запись, в которую не включено ни одной другой записи. Это означает, что для того, чтобы удалить запись о разделе, нужно сначала удалить или перенести в другие разделы все входящие в него записи. Также удаление будет невозможным в случае, если на основе записи уже созданы записи базового или рабочего учебного плана.

1.3.3. Работа с компетенциями ФГОС

1.3.3.1. Создание перечня компетенций стандарта

В стандартах III поколения (Федеральных государственных образовательных стандартах, или ФГОС) присутствует перечень компетенций, развиваемых у студента в ходе обучения по соответствующим учебным программам. Перечень всех компетенций, перечисленных в стандарте, должен быть введен в систему. Сделать это можно, выбрав в таблице данных Образовательные стандарты нужный стандарт, и открыв подчиненную таблицу данных Компетенции в стандарте.

Добавление новой компетенции производиться при помощи действия Добавить компетенцию.

  • В поле Код компетенции нужно занести код, используемый для обозначения компетенции в стандарте.
  • В поле Тип компетенции нужно выбрать одно из предлагаемых значений из справочника типов компетенций.
  • В поле Описание компетенции нужно занести текст, разъясняющий содержание компетенции. Можно использовать стандартные действия копирования и вставки значений из других документов.

Перечень компетенций отображается сгруппированным по типам компетенций. После того, как компетенции будут связаны с определенными записями стандарта в подчиненной таблице Развитие в компонентах стандарта для каждой компетенции можно будет увидеть перечень записей стандарта, в которых она присутствует.

Перечень компетенций стандарта

В случае если в разных стандартах присутствуют схожие перечни компетенций, можно воспользоваться действиями Копировать и Вставить, вызываемыми из контекстного меню в таблице данных. Для этого нужно в главной таблице данных выбрать стандарт, для которого уже создан перечень компетеницй, в подчиненной таблице данных выбрать одну или несколько компетенций, выполнить действие Копировать. После этого выбрать другой стандарт в главной таблице, и в подчиненной таблице выполнить действие Вставить. После вставки значения кодов и описаний компетенций можно будет скорректировать.

1.3.3.2. Связь компетенций с записями стандарта

После того как сформированы записи стандарта (см. Наполнение стандарта компонентами и дисциплинами) и сформирован перечень компетенций стандарта (см. Создание перечня компетенций стандарта) можно устанавливать связи между записями стандарта и компетенциями. Для этого предназначена таблица данных, Развиваемые компетенции, расположенная на третьем уровне формы под таблицей Состав стандарта.

Компетенции могут связываться с любыми записями стандарта, как с компонентами, так и с дисциплинами. Для того, чтобы задать эту связь, нужно выбрать одну из записей стандарта, после чего в подчинненой таблице данных Развиваемые компетенции вызвать действие Добавить компетенцию.

Добавление компетенции к записи стандарта

В единственном поле формы параметров добавления компетенции нужно выбрать компетенцию из списка всех компетенций стандарта, или ввести код компетенции с клавиатуры. Для корректного поиска компетенции в перечне компетенций стандарта необходимо соблюдать регистр символов.

Полный перечень компетенций, связанных с записью стандарта, формируется многократным выполнением процедуры добавления компетенции. В случае, если нужной компетенции не найдено в перечне, предлагаемом для выбора, необходимо вернуться к этапу Создание перечня компетенций стандарта.

1.3.4. Работа с компетенциями оригинальных стандартов

В данном разделе описана реализованная в системе функциональность работы с системой компетенций. Ссистема компетенций может включать компетенции следующих видов:

  • Универсальные (системные) компетенции являются общими для всех направлений подготовки.
  • Профессиональные (инструментальные, социально-личностные) компетенции связаны с видами профессиональной деятельности.

Система компетенций состоит из общевузовских классификаторов компетенций трех основных видов: системных, социально-личностных и инструментальных, а также из перечня компетенций, формируемого для каждого из оригинальных образовательных стандартов на базе общевузовских справочников. Система компетенций включает в себя кодификацию, позволяющую отражать типологию компетенций, порядок их следования и взаимную связь друг с другом.

Работа с компетенциями оригинальных стандартов ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты.

Работа по формированию компетенций для каждого из образовательных стандартов должна включать следующие этапы:

  1. Формирование общевузовских справочников компетенций всех трех видов.
  2. Формирование перечня компетенций для образовательного стандарта, заключающееся в первичном наполнении перечня компетенциями из общевузовского справочника с дальнейшим уточнением их состава и содержания. Работа по уточнению перечня компетенций для стандарта ведется по-разному в зависимости от вида компетенции. Особенности работы с компетенциями разных видов описаны в следующих ниже разделах.

1.3.4.1. Общевузовские справочники компетенций

Работа по формированию системы компетенций оригинальных образовательных стандартов должна быть начата с формирования общевузовских классификаторов компетенций каждого из трех видов системных, социально-личностных и инструментальных.

Порядок работы с данными справочниками не существенен, однако до начала формирования перечней компетенций для конкретных образовательных стандартов общевузовские справочники компетенций должны быть сформированы полностью.

1.3.4.1.1. Системные (универсальные) компетенции

Работа с общевузовским справочником системных (универсальных) компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Системные компетенции.

Системные компетенции. Общевузовский справочник

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая системная компетенция имеет код и порядковый номер. Коды системных компетенций формируются автоматически из префикса СК-, символа уровня образования (Б или М) и порядкового номера (например, "СК-Б01", "СК-Б03", "СК-М08", "СК-М15"). Смысловое содержание компетенции представлено в поле Формулировка компетентностных образовательных результатов.

Для наполнения или уточнения общевузовского справочника системных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить системную компетенцию
  • Изменить порядковый номер
  • Удалить компетенцию
Уточнять текстовую формулировку компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter.

Добавление компетенции

Для того, чтобы добавить в справочник новую системную компетенцию, нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить системную компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление системной компетенции в общевузовский справочник

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Код компетенции значение будет составлено автоматически из префикса "СК-" (системная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура) и порядкового номера компетенции. Для порядковых номеров меньших 10 в первой позиции будет дописан 0. Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Формулировка компетентностных образовательных результатов значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой системной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера (кода) компетенции

Для изменения порядка следования компетенций предусмотрено действие контекстного меню Изменить порядковый номер. При изменении порядкового номера соответствующим образом изменится и код компетенции.

Изменение порядкового номера системной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции. При его изменении будет изменяться и код компетенции. Повтор порядковых номер компетенций недопустим. При попытке изменить порядковый номер компетенции на существующий произойдет ошибка дублирования объектов.

1.3.4.1.2. Социально-личностные компетенции

Работа с общевузовским справочником социально-личностных компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Социально-личностные компетенции.

Социально-личностные компетенции. Общевузовский справочник

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая социально-личностная компетенция имеет код и порядковый номер. Коды социально-личностных компетенций формируются автоматически из префикса СЛК-, символа уровня образования (Б или М) и порядкового номера (например, "СЛК-Б05", "СЛК-Б12", "СЛК-М02", "СЛК-М11"). Смысловое содержание компетенции представлено в поле Формулировка компетентностных образовательных результатов.

Для наполнения или уточнения общевузовского справочника социально-личностных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить социально-личностную компетенцию
  • Изменить порядковый номер
  • Удалить компетенцию
Уточнять текстовую формулировку компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter.

Добавление компетенции

Для того, чтобы добавить в справочник новую социально-личностную компетенцию, нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить социально-личностную компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление социально-личностной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Код компетенции значение будет составлено автоматически из префикса "СЛК-" (социально-личностная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура) и порядкового номера компетенции. Для порядковых номеров меньших 10 в первой позиции будет дописан 0. Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Формулировка компетентностных образовательных результатов значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера (кода) компетенции

Для изменения порядка следования компетенций предусмотрено действие контекстного меню Изменить порядковый номер. При изменении порядкового номера соответствующим образом изменится и код компетенции.

Изменение порядкового номера социально-личностной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции. При его изменении будет изменяться и код компетенции. Повтор порядковых номер компетенций недопустим. При попытке изменить порядковый номер компетенции на существующий произойдет ошибка дублирования объектов.

1.3.4.1.3. Инструментальные компетенции

Работа с общевузовским справочником инструментальных компетенций ведется в разделе системы Разработка учебных планов в форме Образовательные стандарты. Открыть справочник можно выбрав вкладку верхнего уровня Инструментальные компетенции.

Инструментальные компетенции. Общевузовский справочник

Справочник имеет иерархическую структуру, которая отражает конкретизацию компетенций. Компетенции первого уровня являются наиболее общими и обозначают укрупненные виды деятельности (проектная деятельность, общение и коммуникация и проч.). Компетенция, которую конкретизирует данная компетенция, далее будет называться "родительской", а те компетенции, которые, в свою очередь, конкретизируют данную, будут называться "дочерними". Например, на представленном выше рисунке по отношению к компетенции "ИК-Б1.1 участвовать" родительской является компетенция "ИК-Б1 Проектная и иная деятельность", а дочерними являются компетенции "ИК-Б1.1н в научной деятельности" и "ИК-Б1.1и в исследовательской деятельности".

Каждая компетенция может относиться к одному из двух уровней образования - бакалавриату или магистратуре. Также каждая инструментальная компетенция имеет код и порядковый номер, а также может иметь символьное обозначение. Коды социально-личностных компетенций формируются автоматически из префикса ИК-, символа уровня образования (Б или М), собственного порядкового номера и порядковых номеров родительских компетенций, разделенных точкой, и символьного обозначения (при его наличии). Например, коды инструментальных компетенций могут иметь следующий вид: "ИК-Б1", "ИК-Б2.3", "ИК-М3.1и", "ИК-М2.2э". Для инструментальных компетенций в справочник заносится только наименование. Формулировки компетентностных образовательных результатов для компетенций данного вида будут задаваться отдельно для каждого из образовательных стандартов. Также в справочнике отображается формируемое автоматически полное наименование компетенции, составленное из наименования самой компетенции и всех ее родительских компетенций, разделенных символами "/".

Для наполнения или уточнения общевузовского справочника инструментальных компетенций доступны действия, вызываемые из контекстного меню (щелчок правой кнопкой мыши):

  • Добавить компетенцию на первый уровень
  • Добавить дочернюю компетенцию
  • Изменить порядковый номер или символьное обозначение
  • Изменить родительскую компетенцию
  • Удалить компетенцию
Уточнять наименование компетенции можно непосредственно в таблице данных. По окончании набора текста необходимо нажать клавишу Enter. Полное наименование компетенции при этом изменится автоматически.

Добавление компетенции

Для добавления инструментальных компетенций предусмотрено два действия: Добавить компетенцию на первый уровень и Добавить дочернюю компетенцию. Выбор действия зависит от того, нужно ли добавить самостоятельную компетенцию первого уровня, соответствующую укрупненному виду деятельности, которая не будет иметь родительской компетенции, или нужно добавить компетенцию, уточняющую одну из существующих (дочернюю по отношению к существующей).

Для добавления самостоятельной компетенции первого уровня нужно вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить компетенцию на первый уровень. Отобразиться форма параметров процедуры добавления:

Добавление инструментальной компетенции на первый уровень

Поля формы параметров заполняются следующим образом:

  • В поле Уровень образования нужно выбрать пункты Бакалавриат или Магистратура из выпадающего списка. Для уровня образования Специалитет работа с компетенциями не ведется, т.к. данный уровень не предусмотрен образовательными стандартами III поколения.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего на первом уровне для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Символьное обозначение можно ввести символ, дополняющий код компетенции, если это необходимо. Если символьное обозначение для данной компетенции не используется, поле нужно оставить пустым.
  • В поле Код компетенции значение будет составлено автоматически из префикса "ИК-" (инструментальная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура), порядкового номера компетенции, символьного обозначения (если оно использовано). Управлять значением данного поля можно изменяя уровень образования и порядковый номер компетенции.
  • В поле Наименование компетенции значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Для добавления компетенции, конкретизирующей одну из существующих, нужно сначала выбрать существующую (родительскую) компетенцию, которая должна быть конкретизирована, после чего вызвать из контекстного меню (щелчок правой кнопкой мыши) действие Добавить дочернюю компетенцию. Отобразиться форма параметров процедуры добавления:

Добавление дочерней инструментальной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Родительская компетенция будет отображен код родительской компетенции, которая была выбрана в таблице данных перед вызовом действия добавления. Если новая компетенция должна быть подчинена другой родительской компетенции, то нужно закрыть данную форму при помощи кнопки Отмена, выбрать в таблице данных нужную родительскую компетенцию и снова вызвать действие добавления дочерней компетенции.
  • В поле Уровень образования значение будет подставлено автоматически на основе выбранной родительской компетенции. Изменять это значение при добавлении недопустимо. Если нужно добавить компетенцию для другого уровня образования, то нужно закрыть данную форму, выбрать в таблице данных родительскую компетенцию, принадлежащую к другому уровню образования и повторить добавление.
  • В поле Порядковый номер значение будет предложено автоматически (на единицу больше максимального существующего на данном уровне иерархии для данного уровня образования). При необходимости это значение можно изменить. Поле может принимать целочисленные значения от 1 до 99.
  • В поле Символьное обозначение можно ввести символ, дополняющий код компетенции, если это необходимо. Если символьное обозначение для данной компетенции не используется, поле нужно оставить пустым.
  • В поле Код компетенции значение будет составлено автоматически из префикса "ИК-" (инструментальная компетенция), символа уровня образования (Б - бакалавриат, М - магистратура), порядкового номера компетенции и ее родительских компетенций, символьного обозначения (если оно использовано). Управлять значением данного поля можно изменяя порядковый номер, символьное значение или выбрав другую родительскую компетенцию перед добавлением.
  • В поле Наименование компетенции значение заносится путем набора текста на клавиатуре. Длина текста ограничена 2000 символов.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о новой социально-личностной компетенции появится в таблице данных.

Удаление компетенции

Для удаления ошибочно внесенной компетенции нужно выбрать эту компетенцию в таблице данных и вызвать действие Удалить компетенцию. Перед удалением будет отображено предупреждение. Если вы уверены в том, что компетенцию нужно удалить, нажмите кнопку Да на окне предупреждения.

Удаление компетенции, имеющей дочерние компетенции, недопустимо. Если такую компетенцию все же надо удалить, то сначала нужно удалить все ее дочерние компетенции.

Если удаляемая компетенция была включена в один из образовательных стандартов, при удалении может произойти ошибка, говорящая о существующей связи. В этом случае до удаления компетенции из общевузовского справочника ее необходимо удалить из всех образовательных стандартов, в которые они включена. Увидеть перечень стандартов, в которые входит компетенция, можно на подчиненной вкладке Вхождение компетенции в образовательные стандарты.

Изменение порядкового номера и символьного обозначения компетенции

Для изменения порядка следования компетенций и их символьных обозначений предусмотрено действие контекстного меню Изменить порядковый номер или символьное обозначение. При изменении порядкового номера или символьного обозначения соответствующим образом изменится и код компетенции.

Изменение порядкового номера или символьного обозначения инструментальной компетенции

В данной форме параметров изменять можно только числовое значение порядкового номера компетенции и символьное обозначение. При изменении этих значений будет изменяться и код компетенции. Повтор полученных кодов компетенций недопустим. При попытке изменить порядковый номер или символьное обозначение таким образом, что полученный код компетенции будет повторять один из существующих, произойдет ошибка дублирования объектов.

Перенос компетенций по иерархической структуре

Для того, чтобы перенести существующую компетенцию по структуре (т.е. изменить для нее родительскую компетенцию), можно воспользоваться действием Изменить родительскую компетенцию.

Изменение родительской компетенции для инструментальной компетенции

Поля формы параметров заполняются следующим образом:

  • В поле Родительская компетенция нужно выбрать другую компетенцию из предложенного перечня, которая должна стать родительской по отношению к данной.
  • Значение полей Уровень образования и Наименование компетенции при использовании данной процедуры изменять нельзя.
  • В полях Порядковый номер и Символьное обозначение можно изменять значения описанным выше образом. Также при этом будет изменяться значение в поле Код компетенции.

После заполнения всех полей формы нужно нажать кнопку ОК, и запись о компетенции изменит свое положение в иерархической структуре. Также ей будут присвоены новые значения порядкового номера, сиваольного обозначения и кода.

1.3.4.2. Формирование и уточнение перечня компетенций для оригинального образовательного стандарта

При формировании на основе общевузовских справочников перечней компетенций для каждого из образовательных стандартов действуют следующие принципы:

  1. Системные (универсальные) компетенции переносятся в каждый из образовательных стандартов в полном соответствии с общевузовским справочником. Изменение перечня системных компетенций, их формулировок или кодов в конкретном стандарте недопустимо.
  2. Формулировки социально-личностных компетенций в каждом из образовательном стандарте могут уточнятся. При этом код компетенции автоматически получит постфикс, соответствующий аббревиатуре направления подготовки.
  3. Общевузовский справочник инструментальных компетенций имеет иерархическую структуру. Для инструментальных компетенций в общевузовском справочнике задаются только их наименования. Формулировка компетентностных образовательных результатов для инструментальных компетенций заносится только при добавлении компетенции в стандарт.
  4. В образовательный стандарт могут добавляться дополнительные социально-личностные компетенции, не связанные с компетенциями из общевузовского справочника. Добавление в стандарты системных и инструментальных компетенций, не связанных с общевузовскими справочниками, недопустимо.

Работа по формированию и уточнению перечня компетенций для каждого из образовательных стандартов ведется в форме Образовательные стандарты. Для того, чтобы просмотреть, сформировать или отредактировать перечень компетенций для стандарта, нужно выбрать этот стандарт на вкладке Образовательные стандарты и открыть подчиненную таблицу Компетенции в оригинальном стандарте.

До начала работы по формированию перечня компетенций для образовательных стандартов должны быть полностью сформированы Общевузовские справочники компетенций.

Для формирования и уточнения перечня компетенций в таблице данных Компетенции в оригинальном стандарте доступны действия, позволяющие:

  • переносить в образовательный стандарт полный набор компетенций определенного вида, занесенных в общевузовский справочник
  • добавлять к образовательному стандарту компетенции по одной
  • уточнять формулировку и код компетенции (доступно для социально-личностных и инструментальных компетенций)
  • удалять ошибочно добавленные компетенции

Коды компетенций, добавляемых в стандарт, могут отличаться от кодов, заданных в общевузовском справочнике. Отличие, как правило, заключается в дописывании к коду компетенции из общевузовского справочника аббревиатуры направления подготовки.

Аббревиатуры направлений подготовки задаются в общевузовском справочнике пользователями, наделенными правами на работу с данным справочником. Каждый образовательный стандарт относится к определенному направлению подготовки. Если аббревиатура направления не отображается в таблице "Образовательные стандарты" или отображается неверно, нужно обратиться к пользователю, ответственному за работу со справочником направлений и специальностей с просьбой уточнить аббревиатуру нужного направления.

1.3.4.2.1. Формирование перечня системных компетенций

Системные (универсальные) компетенции переносятся в каждый из образовательных стандартов в полном соответствии с общевузовским справочником. Изменение перечня системных компетенций, их формулировок или кодов в конкретном стандарте недопустимо.

Для переноса полного перечня системных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все системные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень системных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. Изменять формулировки или коды системных компетенций по сравнению с общевузовским справочником недопустимо.

Системные компетенции в образовательном стандарте

Если после последнего формирования перечня системных компетенций для стандарта произошло добавление системных компетенций в общевузовский справочник, действие Добавить все системные компетенции можно вызвать повторно. Его выполнение приведет к добавлению недостающих системных компетенций, коды и формулировки существующих компетенций будут приведены в соответствие со значениями из общевузовского справочника.

Если возникла необходимость удалить одну из системных компетенций, добавленных к стандарту, из общевузовского справочника, потребуется предварительно удалить ее из стандарта. Для этого необходимо выбрать удаляемую компетенцию в списке и выполнить действие Удалить компетенцию.

Если компетенция была удалена из стандарта ошибочно, или если перечень системных компетенций в общевузовском справочнике был расширен, отдельную системную компетенцию можно добавить в стандарт при помощи действия Добавить компетенцию... / системную компетенцию.

Добавление системной компетенции

Для добавления нужно в поле Компетенция из общевузовского справочника выбрать добавляемую компетенцию из общевузовского справочника системных компетенций. Формулировка выбранной компетенции отобразится в поле Формулировка компетентностных образовательных результатов автоматически. Изменение кода или формулировки системной компетенции недопустимо. После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте.

Повторное добавление компетенции в стандарт недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

1.3.4.2.2. Формирование перечня социально-личностных компетенций

Социально-личностные компетенции переносятся в каждый из образовательных стандартов в соответствии с общевузовским справочником. При этом в конкретном образовательном стандарте формулировка социально-личностной компетенции может быть изменена. При изменении формулировки изменяется и код социально-личностной компетенции - к нему дописывается аббревиатура направления подготовки.

В отличие от других видов компетенций в образовательный стандарт могут добавляться социально-личностные компетенции, не связанные с соответствующими компетенциями общевузовского справочника. Далее такие компетенции называются дополнительные социально-личностные компетенции.

Перенос социально-личностных компетенций из общевузовского справочника в образовательный стандарт можно выполнять одним из двух способов:

  • Добавить все социально-личностные компетенции из общевузовского справочника, после чего уточнить формулировки и коды тех компетенций, для которых это необходимо (рекомендуется в случае, если не планируется существенных изменений по сравнению с общевузовским справочником)
  • Добавлять социально-личностные компетенции по одной с одновременным уточнением их формулировок и кодов (рекомендуется в случае, если состав и содержание социально-личностных компетенций в стандарте должно существенно отличаться от общевузовского справочника)

Формирование перечня социально-личностных компетенций

Для переноса полного перечня социально-личностных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все социально-личностные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень социально-личностных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. После добавления коды и формулировки компетенций можно будет уточнить.

Социально-личностные компетенции в образовательном стандарте

Если после последнего формирования перечня социально-личностных компетенций для стандарта произошло добавление компетенций данного вида в общевузовский справочник, действие Добавить все социально-личностные компетенции можно вызвать повторно. Его выполнение приведет к добавлению недостающих системных компетенций, коды и формулировки существующих компетенций будут приведены в соответствие со значениями из общевузовского справочника.

Отдельную социально-личностную компетенцию, имеющую соответствие в общевузовском справочнике, можно добавить в стандарт при помощи действия Добавить компетенцию... / социально-личностную компетенцию. Одновременно с добавлением компетенции можно выполнить и ее уточнение.

Добавление социально-личностной компетенции

Для добавления нужно в поле Компетенция из общевузовского справочника выбрать добавляемую компетенцию из общевузовского справочника социально-личностных компетенций. Формулировка выбранной компетенции отобразится в поле Формулировка компетентностных образовательных результатов (значение из общевузовского справочника, недоступно для изменения). Та же формулировка отобразится в поле Формулировка компетентностных образовательных результатов (в стандарте). Если формулировку компетенции в стандарте нужно изменить, это можно сделать в поле, доступном для редактирования. Если изменение формулировки произведено, код компетенции будет дополнен аббревиатурой направления.

После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте. В таблице будут отображены как значения кода и формулировки, уточненные для стандарта, так и значения из общевузовского справочника.

Повторное добавление в стандарт компетенции, ссылающейся на ту же запись общевузовского справочника, недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

Для добавления дополнительной социально-личностной компетенции, не связанной с общевузовским справочником, предназначено действие Добавить компетенцию... / дополнительную социально-личностную компетенцию.

Добавление дополнительной социально-личностной компетенции

Для добавления нужно занести формулировку компетенции и ее порядковый номер. Для дополнительных компетенций необходимо использовать порядковые номер от 101 до 200. Код компетенции будет сформирован автоматически из префикса"СЛК-", порядкового номера и аббревиатуры направления подготовки.

После нажатия кнопки ОК дополнительная компетенция будет добавлена в стандарт. В таблице всех компетенций стандарта для дополнительных социально-личностных компетенций в колонках Код общевузовской компетенции и Формулировка компетентностных образовательных результатов (общевуз.) будут отображены пустые значения.

Уточнение социально-личностных компетенций

Социально-личностные компетенции, ранее добавленные в стандарт, могут уточняться по сравнению с компетенциями общевузовского справочника. Для того, чтобы уточнить компетенцию, нужно выбрать ее в таблице данных, после чего вызвать действие Уточнить компетенцию... / социально-личностную компетенцию

Уточнение социально-личностных компетенций

Уточнение компетенции заключается к корректировке ее формулировки по сравнению с формулировкой, заданной в общевузовском справочнике. Если формулировка изменена, в код компетенции будет автоматически дописана аббревиатура направления подготовки.

Удаление социально-личностной компетенции

Если возникла необходимость удалить одну из социально-личностных компетенций, добавленных к стандарту, нужно выбрать ее в таблице данных и воспользоваться действием Удалить компетенцию.

1.3.4.2.3. Формирование перечня инструментальных компетенций

Формирование перечня инструментальных компетенций для образовательного стандарта заключается в выборе соответствующих инструментальных компетенций из общевузовского справочника и занесения их формулировок. Так как в общевузовском справочнике инструментальных компетенций формулировки компетенций не заносятся, при добавлении инструментальных компетенций в стандарт формулировки должны быть заданы для каждой компетенции. Коды инструментальных компетенций в стандарте будут сформированы автоматически на основе кода компетенции в общевузовском справочнике и аббревиатуры направления подготовки.

Добавление в стандарт инструментальных компетенций, не связанных ни с одной записью общевузовского справочника, недопустимо.

Формирование перечня инструментальных компетенций для стандарта на основе общевузовского справочника можно выполнять одним из двух способов:

  • Добавить все инструментальные компетенции из общевузовского справочника, после чего уточнить все их формулировки и коды
  • Добавлять инструментальные компетенции по одной с одновременным уточнением их формулировок и кодов

Формирование перечня инструментальных компетенций

Для переноса полного перечня инструментальных компетенций из общевузовского справочника предназначено действие контекстного меняю Добавить все инструментальные компетенции.

Действие не требует задания параметров. Результатом его выполнения является перечень социально-личностных компетенций для выбранного образовательного стандарта. Коды и формулировки компетенций переносятся в строгом соответствии с общевузовским справочником. В качестве формулировки компетенции будет подставлено ее наименование их общевузовского справочника. После добавления инструментальных компетенций коды и формулировки всех компетенций необходимо будет уточнить.

Инструментальные компетенции в стандарте

По одной инструментальные компетенции можно добавлять при помощи действия Добавить компетенцию... / инструментальную компетенцию. Одновременно с добавлением компетенции можно выполнить и ее уточнение.

Добавление инструментальной компетенции в стандарт

Для добавления инструментальной компетенции нужно занести ее формулировку в поле Формулировка компетентностных образовательных результатов, после чего в поле Компетенция из общевузовского справочника выбрать наиболее подходящую общевузовскую компетенцию. Для удобства выбора общевузовский справочник инструментальных компетенций отображается в виде иерархической структуры. При этом для добавления в стандарт необходимо выбирать компетенции, не имеющие дочерних компетенций.

После нажатия кнопки ОК запись о новой компетенции появится в таблице данных Компетенции в оригинальном стандарте. В таблице будут отображены как значения кода и формулировки, уточненные для стандарта, так и значения кода и наименования из общевузовского справочника.

Повторное добавление в стандарт компетенции, ссылающейся на ту же запись общевузовского справочника, недопустимо. При попытке выбора в поле Компетенция из общевузовского справочника компетенции, которая уже добавлена в стандарт, будет отображено предупреждение:

Предупреждение о дублировании компетенции

поле Компетенция из общевузовского справочника станет невалидным (фон приобретет зеленый цвет). Это означает, что нужно выбрать другую компетенцию из общевузовского справочника или отказаться от добавления.

Уточнение инструментальных компетенций

Инструментальные компетенции, ранее добавленные в стандарт, могут уточняться по сравнению с компетенциями общевузовского справочника. Для того, чтобы уточнить компетенцию, нужно выбрать ее в таблице данных, после чего вызвать действие Уточнить компетенцию... / инструментальную компетенцию.

Уточнение инструментальных компетенций

Уточнение компетенции заключается к корректировке ее формулировки. Также при уточнении формулировки в код компетенции будет автоматически дописана аббревиатура направления подготовки.

Удаление инструментальной компетенции

Если возникла необходимость удалить одну из инструментальных компетенций, добавленных к стандарту, нужно выбрать ее в таблице данных и воспользоваться действием Удалить компетенцию.

1.4. Объединенные учебные планы

"Объединенные учебные планы" - это такой вид учебных планов, который объединяет в себе "базовый учебный план" и "рабочий учебный план". Объединенный учебный план разрабатывается сразу на все годы реализации образовательной программы, содержит полный набор разделов, дисциплин и других видов записей планов на весь период обучения, и в то же время отражает планирование нагрузки как по дисциплине в целом, так и по видам работ (лекции, семинары, практически и т.п.), по учебным годам (курсам студентов), по периодам каждого года (модулям и семестрам), а также отражает планирование испытаний текущего и рубежного контроля. Дополнительной возможностью Объединенных учебных планов (по сравнению с РУП) является возможность распределения кредитов, аудиторных часов и общих часов по "частям дисциплины", ограниченным рубежными испытаниями (зачетами и экзаменами).

1.4.1. Создание нового объединенного учебного плана

Работа с Объединенными учебными планами ведется на участке "Разработка учебных планов" в форме "Объединенные учебные планы". Для создания нового объединенного учебного плана необходимо чтобы предварительно был сформирован соответствующий образовательный стандарт. Работа с образовательными стандартами описана в разделе Образовательные стандарты.

Для добавления объединенного учебного плана необходимо в верхней таблице данных Объединенные учебные планы с помощью контекстного меню вызвать действие Добавить объединенный план.

Добавление объединенного учебного плана

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров добавления объединенного учебного плана

  • В поле Уровень образования - указать уровень образования, для которого создается план.
  • В полях Образовательный стандарт и Образовательную программа - выбрать образовательный стандарт и программу, для которой создается план.
  • Поля Факультет, Филиал, Форма обучения, Магистерская программа, Число лет обучения будут заполнены автоматически данными, заданными для образовательного стандарта и выбранной образовательной программы.
  • При необходимости в полях Специализация и Магистерская специализация можно указать специализацию или магистерскую специализацию, если они не заданы для Образовательной программы.
  • В полях Год начала обучения, Год окончания обучения указать года начала и окончания обучения, периоды, по которым будет планироваться нагрузка (по модулям или по семестрам).
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов в году указать количество периодов в учебном году.

После того, как для всех полей формы добавления Объединенных учебных планов будут заданы допустимые значения, кнопка ОК на форме добавления станет доступной. После ее нажатия запись о новом объединенном учебном плане появится в таблице данных. При попытке добавления второго объединенного учебного плана на основе той же образовательной программы, образовательного стандарта для того же факультета, года начала обучения, специализации, магистерской программы, магистерской специализации произойдет ошибка дублирования объектов.

1.4.2. Редактирование объединенного учебного плана

Сформировать структуру и состав нового объединенного учебного плана можно на основе образовательного стандарта. Для этого нужно выбрать объединенный учебный план в таблице данных и в контекстном меню выбрать действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Подтверждение формирования БУП

Если Вы уверены, что хотите сформировать учебный план на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Все записи плана.

После того, как объединенный учебный план сформирован на основе стандарта, его можно редактировать. Для редактирования предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования ОУП

Редактирование объединенного учебного плана должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), распределять нагрузку по видам работы (лекции, семинары, практические и т.д.), по годам обучения (курсам студентов) и по периодам обучения в каждом году (модулям, семестрам), а также планировать рубежные испытания, распределять кредиты и объем нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: дисциплину, научно-исследовательский семинар, курсовую работу, практику, проект студентов, дисциплину других планов, итоговый экзамен, выпускную квалификационную работу, зачетно-экзаменационные недели.

Добавление записи в ОУП

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

Редактирование записей объединенного плана

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение ряда свойств разделов и дисциплин БУП.

По окончании работы с объединенным учебным планом его можно вывести на печать. Для этого можно воспользоваться одним из действий Выгрузить для печати, Выгрузить для печати как Базовый, Выгрузить для печати как рабочий, расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

1.4.2.1. Добавление дисциплин и НИС

При добавлении дисциплины или НИС в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие дисциплину или научно-исследовательский семинар, после чего заполнить следующую форму параметров:

Добавление дисциплины в ОУП
Пользователям разработчикам учебных планов предоставлена возможность связывания дисциплин и НИС учебного плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
      Для выбора из плана-предложения кафедры будут доступны только те дисциплины, которые совпадают по периоду реализации с периодом, заданным с помощью полей Год начала реализации и Год окончания реализации.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных специализаций, необходимо выбрать специализации, для которых добавляется дисциплина. Для выбора специализаций необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей специализаций, после чего нужно нажать кнопку ОК.
      Для каждой специализации в ОУП будет создана отдельная запись по дисциплине.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных специализаций, необходимо выбрать специализации, для которых добавляется дисциплина. Для выбора специализаций необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей специализаций, после чего нужно нажать кнопку ОК.
      Для каждой специализации в ОУП будет создана отдельная запись по дисциплине.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать и изменять специализацию для дисциплин и НИС (см. Установить или снять специализацию).
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

1.4.2.1.1. Установить или снять специализацию

Для установки, снятия и изменения специализации, установленной для дисциплины или НИС, необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Все записи плана выбрать дисциплину или НИС, для которой необходимо установить, снять или изменить специализацию.
    При добавлении дисциплины или НИС можно установить сразу несколько специализаций, для каждой из них будет создана отдельная запись о дисциплине или НИС (см. Добавление дисциплин и НИС). В связи с этим необходимо удостовериться, что выбранная дисциплина или НИС соответствуют той записи, которую необходимо изменить. Установленные специализации можно проверить в поле Для специализации.
  3. Из контекстного меню вызвать действие Установить\изменить специализацию.
  4. В форме параметров указать Специализацию факультета (для ОУП бакалавриата и специалитета) или Магистерская специализация (для ОУП магистратуры).
  5. Нажать кнопку ОК.

1.4.2.1.2. Изменение периода реализации

Для изменения периода реализации дисциплины или НИС, необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Все записи плана выбрать дисциплину или НИС, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

1.4.2.1.3. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

1.4.2.2. Добавление курсовой работы

При добавлении курсовой работы в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие курсовую работы, после чего заполнить следующую форму параметров:

Добавление курсовой работы в ОУП

В первую очередь необходимо указать Наименование для курсовой работы, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК курсовая работа будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по курсовой работе.

1.4.2.3. Добавление практики

При добавлении практики в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие практику, после чего заполнить следующую форму параметров:

Добавление практики в ОУП

В первую очередь необходимо указать Вид практики (справочник ) и Способ проведения практики, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК практика будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по практике.

1.4.2.4. Добавление итогового экзамена

При добавлении итогового экзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие итоговый экзамен, после чего заполнить следующую форму параметров:

Добавление итогового экзамена в ОУП

В первую очередь необходимо указать Наименование для итогового экзамена, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК итоговый экзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по итоговому экзамену.

1.4.2.5. Добавление выпускной работы

При добавлении выпускной работы в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие выпускную работу, после чего заполнить следующую форму параметров:

Добавление ВКРБ в ОУП

В первую очередь необходимо указать Наименование и Форму итогового контроля для выпускной работы, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК выпускная работа будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по выпускной работе.

1.4.2.6. Добавление зачетно-экзаменационной недели

При добавлении зачетно-экзаменационной недели в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие зачетно-экзаменационную неделю, после чего заполнить следующую форму параметров:

Добавление зачетно-экзаменационных недель в ОУП

В первую очередь необходимо указать Наименование зачетно-экзаменационной недели, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК зачетно-экзаменационная неделя будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки для зачетно-экзаменационной недели.

1.4.2.7. Добавление проекта студентов

При добавлении проекта студентов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие проект студентов..., после чего заполнить следующую форму параметров:
Добавление проекта в ОУП

  • В поле Проект для студентов необходимо выбрать проект из справочника Проекты для студентов, если проект отсутствует, то его можно добавить (см. Проекты для студентов). Данное поле можно оставить пустым и не устанавливать ссылку на проект из справочника, а только указать Наименование проекта, Вид дисциплины в плане и Число кредитов.
    Записи о проектах в объединенных учебных планах, не связанные с записью справочника проектов, в учебный план факультета передаваться не будут.
  • В поле Вид дисциплины в плане выбрать вид дисциплины.
  • В поле Число кредитов указать соответствующее данному проекту число кредитов.
  • При необходимости установить признак Только в кумулятивный рейтинг.

После нажатия кнопки ОК проект будет добавлена в объединенный учебный план.

1.4.2.7.1. Проекты для студентов

Справочник "Проекты для студентов" позволяет работать с информацией о проектах, в которые могут включаться студенты в своей внеадиторной деятельности. Справочник распологается в разделе Объединенные учебные планы на соотвествующей вкладке Проекты для студентов.
Справочник проекты для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить проект.
    Вызов действия Добавить проект
  2. Заполнить форму параметров следующим образом:
    Форма параметров Добавить проект
    • Заполнить поля Идентификатор во внешней системе, Полное наименование, Полное наименование на английском языке, Тип проекта (выбирается из справочника Типы проектов для студентов), Вид проектной деятельности (выбирается из списка).
    • В одной из групп полей Руководитель из вуза или Внешний руководитель указать подразделение/организацию руководителя (выбирается из справочников или Места прохождения практики) и выбрать самого руководителя проекта (выбирается из справочника или Работники организации).
      Руководителем проекта может быть только либо представитель вуза, либо внешний руководитель. При этом если начать заполнять одну из групп полей (Руководитель из вуза или Внешний руководитель) другая перестанет быть доступной для заполнения.
    • Заполнить поля Учебный год, Дата начала реализации, Дата окончания реализации, Дата окончания записи на проект, Количество модулей, Период итогового контроля, Вид итогового контроля и Плановое количество кредитов.
  3. Нажать кнопку ОК.

1.4.2.7.1.1. Выгрузить проекты студентов

В справочнике Проекты для студентов предоставлена возможность сформировать отчет с информацией о проектах и студентах, которым назначены данные проекты.

Для формирования отчета необходимо:

  1. В справочнике Проекты для студентов из контекстного меню системы вызвать действие Выгрузить проекты студентов.
    Вызов действия Выгрузить проекты
  2. В форме пераметров с помощью выбора значений для параметров Филиал, Факультет, Образовательная программа, Курс, Группа, Проект можно ограничить выборку проектов, для которых будет формироваться отчет. Если все поля формы параметров оставить пустыми, то отчет сформируется для всех проектов ВУЗа, присутствующих в справочнике Проекты для студентов.
  3. Нажать кнопку ОК.

В результате сформируется отчет в формате MS Excel, содержащий информацию об образовательной программе, ФИО, курсе и группах студентов, участвующих в проектах, наименовании проекта, плановом и фактическом количестве кредитов, руководителях проектов, результатах участия в проекте студентов.

1.4.2.7.1.2. Загрузка данных о проектах с портала

1.4.2.7.1.3. Загрузка данных о назначении проектов студентам

1.4.2.7.2. Типы проектов для студентов

Справочник "Типы проектов для студентов" содержит в себе перечень типов проектов для внеаудиторной деятельности студентов и распологается в разделе Объединенные учебные планы на соотвествующей вкладке Типы проектов для студентов.
Справочник Типы проектов для студентов

Для добавления нового проекта необходимо:

  1. С помощью контекстного меню вызвать действие Добавить тип проекта.
    Вызов действия Добавить тип проекта
  2. В форме параметров указать Краткое наименование и Полное наименование типа проекта для студентов.
    Форма параметров Добавить тип проекта
  3. Нажать кнопку ОК.

1.4.2.8. Добавление дисциплины других планов

Для добавления дисциплин, которые участвуют в расчетах затратности, но при этом не передаются в реализацию на факультеты и которые не участвуют в планировании нагрузки, необходимо:

  1. В форме редактирования объединенного учебного плана или в представлении Все записи плана из контекстного меню, в группе процедур Добавить, вызвать действие дисциплинудругих планов.
  2. Заполнить следующую форму параметров:
    Добавление дисциплины других учебных планов в ОУП
    • В полях Наименование и Наименование на английском языке указать наименование на русском и английском языке (при необходимости) соответственно.
    • При необходимости в поле Кафедра можно указать подразделение ВУЗа, которое реализует данную дисциплину. Для этого необходимо нажать кнопку Справочник, из справочника , с помощью чек-бокса Чек-бокс, выбрать подразделение и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, Общее число часов, Аудиторных часов и Только в кумулятивный рейтинг.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
  3. Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

Отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля) можно непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице, предназначено действие Дополнительные свойства.

1.4.2.9. Формирование информации о численности контингента

Для добавления информации о численности контингента необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать план, для записей которого будет уточняться информация о численности контингента.
  2. В представлении Все записи по годам обучения для записей учебного плана в соответствующих полях указать Количество потоков, Количество групп, Количество подгрупп и Количество студентов (после изменения значения каждого из параметров нужно нажимать клавишу Enter).

1.4.3. Передача плана на факультет

Для того, чтобы дисциплины объединенного учебного плана могли быть назначены студентам, необходимо для плана выполнить действие Передать на факультет. Для каждого отдельного года реализации плана можно также вызывать действие Передать в план факультета в подчиненной таблице Реализация плана по годам.

Передача ОУП на факультет

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.
Записи о проектах студентов в объединенных учебных планах, не связанные с записью справочника проектов, в учебный план факультета передаваться не будут.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Учебные планы факультета. Эта таблица доступна в разделе Студент, в форме Справочники факультета на вкладке Учебные планы факультета.

Назначение дисциплин студентам на участке Студент выполняется именно из таблицы данных Учебные планы факультета. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного учебного плана необходимо выполнять действие по передаче плана на факультет.

1.4.4. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как Рабочий, Выгрузить для печати как Базовый, Выгрузить для печати как Рабочий с нагрузкой преподавателей, Выгрузить для печати на английском, Выгрузить для печати как Базовый на английском или Выгрузить для печати как Рабочий на английском.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.

1.4.5. Оценка плановой затратности плана

Для оценки плановой затратности плана необходимо:

С помощью формирования отчета "Оценка плановой затратности плана"

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
    Группа действий Дополнительные действия
  2. Выбрать действие Оценка плановой затратности (отчет).
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате сформируется отчет с оценкой затратности реализации объединенного учебного плана.

С помощью действия Рассчитать плановую затратность

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
  2. Выбрать действие Рассчитать плановую затратность.
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате будет выведено сообщение с указание плановой затратности плана.

1.4.6. Оценка фактической затратности ОП

Для оценки фактической затратности образовательной программы необходимо:

  1. В представлении Объединенные учебные планы (форма Объединенные учебные планы) выбрать запись объединенного учебного плана.
  2. Из контекстного меню системы вызвать действие Оценка фактической затратности ОП.
  3. В форме параметров указать Учебный год, если нужна конкретизация по преподавателям, то для признака С конкретизацией по преподавателям нужно установить значение "Да".
  4. Нажать кнопку ОК.

В результате сформируется отчет с оценкой фактической затратности реализации образовательной программы.

1.5. Базовые учебные планы (БУПы)

Базовый учебный план (БУП) представляет собой иерархическую структуру учебных циклов и включенных в них дисциплин, формируемую на основе соответствующего образовательного стандарта. Базовый учебный план уточняет образовательный стандарт в части набора и трудоемкости дисциплин и других видов подготовки, а также отражает распределение учебной нагрузки по годам обучения студентов. Параметры базового учебного плана могут отличаться от образовательного стандарта. Допустимость или недопустимость таких различий регулируется при помощи контрольных соотношений, формируемых для БУПов.

Каждый базовый учебный план создается но основе одного из образовательных стандартов, задающего уровень образования, направление (специальность) и степень (квалификацию), для выбранного факультета (отделения) и года набора студентов. По одному образовательному стандарту для одного факультета и года набора может быть создано несколько БУПов, отличающихся специализацией (для бакалавриата и магистратуры) или магистерской программой и магистерской специализацией (для магистратуры).

Создание нового базового учебного плана включает следующие этапы работы:

  1. Создание записи о БУПе и его наполнение на основе образовательного стандарта.
  2. Редактирование сформированного БУПа.
  3. Связывание записей БУПа с компетенциями.

1.5.1. Создание нового базового учебного плана

Работа с базовыми учебными планами ведется в форме Базовые и рабочие учебные планы на вкладке Базовые учебные планы. Для создания нового БУПа необходимо чтобы предварительно был сформирован соответствующий образовательный стандарт. Работа с образовательными стандартами описана в разделе Образовательные стандарты. Для добавления нового БУП необходимо выполнить действие Добавить базовый учебный план, после чего заполнить форму параметров добавления следующим образом:

Форма добавления БУП (бакалавриат)

Форма добавления БУП (магистратура)
  • Поле Факультет будет заполнено автоматически, если Вы являетесь пользователем одного из факультетов и для Вас задана настройка "Факультет". В этом случае поле будет недоступно для изменения. Если же для Вас не установлена настройка факультета, то в данном поле Вы должны выбрать один из факультетов из общевузовского справочника Если Вам не удается выбрать нужный факультет, обратитесь к бизнес-администратору системы с просьбой уточнить установленные для Вас настройки.
  • Поле Ведущий факультет необходимо будет заполнить только в том случае, если БУП согласовывается с другим факультетом, для этого необходимо выбрать один из факультетов из общевузовского справочника
  • В поле Образовательная программа необходимо указать образовательную программу из соотвествующего справочника. В зависимости от выбранной образовательной программы изменяется доступность для заполнения полей Специализация, Магистерская программа, Магистерская специализация.
  • Поле Уровень образования будет заполнено автоматически.
  • В поле Образовательный стандарт необходимо выбрать один из существующих в системе образовательных стандартов. Для выбора предлагаются только стандарты для уровня образования, указанного в поле Уровень образования. Если необходимого образовательного стандарта нет в предлагаемом для выбора перечне, необходимо перейти в форму Образовательные стандарты и создать новый стандарт, после чего повторить добавление БУПа.
  • Поле Продолжительность программы ДПО является обязательным для заполнения только для программ подготовки специалистов, реализуемые в сокращенные или ускоренные сроки, для этого необходимо будет выбрать значение продолжительности программы только для ускоренных и сокращенных программы из соотвествующего справочника.
  • В поле Всего кредитов по плану будет автоматически предложено значение, соответствующее уровню образования (Бакалавриат - 240 кредитов, Специалитет - 300 кредитов, Магистратура - 120 кредитов). Однако, если для образовательной программы задано общее число кредитов, отличающее от значение, предлагаемых системой, эти значения можно исправить.
  • Поле Специализация доступно только в случае, если в поле Уровень образования указано значение Бакалавриат или Специалитет. Для выбора предлагаются специализации, существующие в справочнике . Если нужной специализации в этом перечне нет, то ее нужно добавить в справочник специализаций факультета. Если БУП не предполагает специализации, но это поле нужно оставить пустым. В дальнейшем на базе одного БУПа могут быть созданы различные рабочие учебные планы (РУПы) для различных специализаций.
  • Поле Магистерская программа доступно только в том случае, если в поле Уровень образования указано значение Магистратура. Для выбора доступны магистерские программы, существующие в справочнике . Если нужной программы в этом справочнике нет, ее нужно добавить, перейдя в справочник, после чего вернуться к созданию БУПа.
  • Поле Магистерская специализация доступно только в том случае, если в поле Уровень образования указано значение Магистратура. Для выбора доступны только магистерские специализации, существующие в справочнике и принадлежащие к выбранной магистерской программе. Если выбранная магистерская программе не предусматривает магистерских специализаций, или если БУП относится к программе в целом, то данное поле нужно оставить пустым. В дальнейшем на основе БУП для магистерской программы можно будет создавать различные рабочие учебные планы (РУПы) для разных магистерских специализаций.
  • В поле Форма обучения нужно выбрать форму обучения, по которой будет реализовываться образовательная программа, из общевузовского справочника .
  • В поле Программа двойных дипломов нужно установить флажок (значение Да) в случае, если БУП разрабатывается для программы двойных дипломов, реализуемой совместно с другими вузами (в т.ч. зарубежными). В противном случае флажок должен быть снят (значение Нет).
  • В поле Число лет обучения автоматически подставляется значение в зависимости от выбранной образовательной программы и уровня образования (Бакалавриат - 4 года, Специалитет - 5 лет, Магистратура - 2 года). Если БУП реализуется в течение другого числа лет, то это значение можно изменить.
  • В поле Реализуется по периодам нужно выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов в году необходимо указать количество преиодов в учебном году.
  • В поле Год начала обучения нужно выбрать год набора студентов, которые будут обучаться по данному БУП. Выбор производится из справочника среди учебных годов. Если нужного учебного года в справочнике нет, необходимо обратиться к бизнес-администратору системы с просьбой добавить его в справочник.
  • В поле Год окончания обучения нужно выбрать учебный год, в котором студенты, обучающиеся по данному БУП завершат обучение. Выбор производится аналогично выбору в поле Год начала обучения.
  • Поле Вариант позволяет создать несколько вариантов БУП одного и того же БУП с тем, чтобы в дальнейшем выбрать наиболее удачный вариант. Для этого в данном поле нужно указать метку варианта (например, "в-2"). Желательно использовать минимальное число символов. Если Вы не планируете работать с несколькими вариантами одного и того же БУП, это поле нужно оставить пустым.

После того, как для всех полей формы добавления БУП заданы допустимые значения, кнопка ОК на форме добавления станет доступной. После ее нажатия запись о новом БУП появится в таблице данных. При попытке добавления второго БУП на основе той же образовательной программы, образовательного стандарта для того же факультета, года начала обучения, специализации, магистерской программы, магистерской специализации БУП произойдет ошибка дублирования объектов.

1.5.2. Создание базового учебного плана как копии существующего

Если необходимо создать базовый учебный план, существенно схожий с уже существующим, можно воспользоваться возможностью копирования плана. Новый план, создаваемый методом копирования, должен отличаться от исходного не менее чем одним из следующих параметров:

  • специализацией;
  • магистерской специализацией;
  • годами обучения студентов;
  • при необходимости продолжительность программы ДПО.
Для того чтобы создать новый план на основе существующего, нужно выбрать исходный план в таблице данных и вызвать действие Скопировать как новый план.

Форма копирования нового БУП на базе старого

При открытии формы копирования плана все поля заполняются значениями, установленными для исходного плана. Для создания нового плана нужно изменить те значения, которые будут отличаться для нового плана и нажать кнопку ОК.

Результатом работы процедуры копирования будет запись о новом базовом учебном плане в таблице данных Базовые учебные планы. В подчиненной таблице Записи базового плана будет создан набор записей, полностью аналогичный составу исходного плана. Также для нового плана будет перенесена информация о распределении учебной нагрузки по годам обучения. Если с записями исходного плана были связаны компетенции, то они также будут скопированы в новый план и связаны с соответствующими записями.

После выполнения процедуры копирования можно продолжить редактирование нового плана. Редактирование может заключаться в добавлении новых записей, удалении созданных при копировании, уточнении форм итогового контроля по дисциплинам, значений объема учебной нагрузки в часах, неделях, кредитах.

Выполнять копирование плана лучше после того, как работа над составом и структурой исходного плана завершена (или близка к завершению). Автоматически актуализировать структуру и состав копии плана после изменения исходного плана будет невозможно. Однако возможно выполнить для нового плана действие Очистить, удалить план и снова сформировать его как копию существующего. Переформировывать таким образом план можно только пока он находится в статусе проект.

1.5.3. Редактирование базового учебного плана

Если БУП создавался методом копирования, то его состав уже сформирован и можно переходить к его редактированию. Если же создан пустой БУП, то его структуру и состав можно сформировать на основе образовательного стандарта. Для этого нужно выбрать БУП в таблице данных и выполнить действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Подтверждение формирования БУП

Если Вы уверены, что хотите сформировать БУП на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Записи базового плана. В таблице данных Развитие компетенций, подчиненной по отношению к записям плана, будут сформированы записи о компетенциях повторяющие записи, созданные в стандарте.

После того, как БУП сформирован на основе стандарта или скопирован, его можно редактировать. Для редактирования предназначена специализированная форма работы с БУП, которая открывается при вызове действия Открыть.

Редактирование БУП должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), установки видов итоговых испытаний, распределении нагрузки в часах и кредитах по года обучения (курсам). Для выполнения этих действий предназначены соответствующие действия контекстного меню. Для добавлении записи в определенный раздел нужно сначала выбрать заголовок этого раздела или одну из входящих в него записей.

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение ряда свойств разделов и дисциплин БУП.

График учебного процесса, являющийся частью БУП, необходимо разработать отдельно в виде файла формата MS Excel или MS Word. Полученный файл нужно загрузить как значение в колонке График учебного процесса. Для этого нужно непосредственно в колонке воспользоваться кнопкой открытия файла и выбрать файл при помощи стандартного диалога MS Windows. Для сохранения в базе данных системы загруженного файла необходимо нажать клавишу Enter. Если график нужно будет изменить, то его можно выгрузить и сохранить на диске при помощи кнопки сохранения файла, скорректировать файл и загрузить обратно (после повторной загрузки также необходимо нажимать Enter).

По окончании работы с БУП его можно вывести на печать. Для этого можно воспользоваться действием Напечатать план, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия БУП будет выгружен для печати в MS Excel.

1.5.4. Связывание записей базового плана с развиваемыми компетенциями

Записи базового учебного плана различных видов (разделы, дисциплины, группы дисциплин, курсовые работы, практики и т.д.) могут связываться с компетенциями, заданными для образовательного стандарта, на основе которого сформирован базовый план. До начала работы с распределением компетенций по записям базового плана, необходимо убедиться в том, что для стандарта корректно сформирован перечень компетенций (раздел Создание перечня компетенций стандарта).

Если базовый учебный план формировался с использованием действия Сформировать на основе стандарта, то перечень компетенций, связанных с записями стандарта (см. раздел Связь компетенций с записями стандарта), будет сформирован и для записей базового учебного плана. Дальнейшая работа должна заключаться в дополнительном связывании компетенций с записями базового плана с целью уточнения из развития за счет отдельных дисциплин.

Для того, чтобы связать компетенцию с записью БУП, нужно открыть форму Базовые и рабочие учебные планы, в ней открыть первую вкладку Базовые учебные планы. Среди всех доступных БУП нужно выбрать план, с которым предстоит работать. На вкладке второго уровня Записи базового плана нужно выбрать запись (дисциплину, группу дисциплин, курсовую работу и т.п.), с которой нужно связать компетенции. После этого на третьем уровне в таблице данных Развиваемые компетенции нужно вызвать действие Добавить компетенцию.

Для выбора в поле Компетенция стандарта доступны все компетенции, сформированные для стандарта в таблице данных Компетенции в стандарте. Если с одной записью БУП нужно связать несколько компетенций, то добавление компетенции нужно повторить.

Если компетенция связана с записью БУП ошибочно, ее можно удалить из списка при помощи действия Удалить.

1.6. Объединенные планы факультетских дисциплин

Объединенный план факультеских дисциплин представляет собой иерархическую структуру групп дисциплин (раделов) и включенных в них дисциплин.

Создание нового объединенного плана факултетских дисциплин включает следующие этапы работы:

1.6.1. Создание нового объединенного плана факультетских дисциплин

Работа с Объединенными учебными планами ведется на участке "Разработка учебных планов" в форме "Объединенные планы факультетских дисциплин".

Для добавления плана необходимо в верхней таблице данных Объединенные планы факультетских дисциплин с помощью контекстного меню вызвать действие Добавить объединенный план факультетских дисциплин.

Процедура добавления объединеннго плана факультетских дисциплин

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров добавления объединенного плана факультетских дисциплин

  • В поле Год начала обучения указать год начала обучения по данному плану.
  • В поле Филиал указать филиал, в котором находится факультет.
  • В поле Факультет выбрать один из факультетов из общевузовского справочника
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов указать количество периодов в учебном году.
  • В поле Число лет указать количество лет, в течение которых реализуется объединенный план факультетских дисциплин.

После того, как для все поля формы будут заполнены, кнопка ОК на форме добавления станет доступной. После ее нажатия, запись о новом объединенном плане факультетских дисциплин появится в таблице данных. При попытке добавления второго плана идентичного уже созданному произойдет ошибка дублирования объектов.

1.6.2. Редактирование объединенного плана факультетских дисциплин

Редактирование объединенного плана факультетских дисциплин заключается в создании Групп дисциплин (разделов), добавлении дисциплин в разделы, распределении нагрузки по видам работы (лекции, семинары, практические и т.д.), по годам обучения и по периодам обучения в каждом году (модулям, семестрам), а также планировании рубежных испытаний, распределении кредитов и объемов нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Добавление Группы дисциплин (раздела)

Для редактирования объединенного плана факультетских дисциплин необходимо в таблице данных Объединенные планы факультетских дисциплин выбрать план и с помощью контекстного меню вызвать действие Открыть.

Открытие формы редактирования объединенного плана факультета

В итоге откроется форма редактирования с пустым планом, в которой для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Процедура добавления раздела в объединенный план факультета

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования объединенного плана.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования объединенного плана факультетских дисциплин.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

Добавление Дисциплины или НИС

Для добавления Дисциплины необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие Дисциплину или НИС,

Процедура добавления дисциплины в объединенный план факультета

после чего заполнить следующую форму параметров:

Форма параметров добавления дисциплины в объединеннй план факультетских дисциплин

Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.

    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

Перемещение Группы дисциплин (раздела) или дисциплины

В случае если при добавлении Группы дисциплин или Дисциплины был неверно указан раздел, куда они должны быть включены, то в отношении такой Группы дисциплин или Дисциплины необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить Группу дисциплин или Дисциплину, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина будут перемещены в корень объединенного плана факультетских дисциплин.

Также можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

Печать объединенных планов факультетских дисциплин

По окончании работы с объединенным учебным планом его можно вывести на печать. Для этого можно воспользоваться одним из действий Выгрузить для печати, Выгрузить для печати как Базовый, Выгрузить для печати как Рабочий расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

1.6.2.1. Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные планы факультетских дисциплин (форма Объединенные планы факультетских дисциплин) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи плана выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

1.6.2.2. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

1.6.2.3. Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных планов факультетских дисциплин выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.

1.6.3. Передача объединенного плана факультетских дисциплин в реализацию

Для того, чтобы дисциплины объединенного плана факультетских дисциплин могли быть назначены студентам, необходимо для плана выполнить действие Передать на факультет. Для каждого отдельного года реализации плана можно также вызывать действие Передать в план факультета в подчиненной таблице Реализация учебного плана по годам.

Передача плана факультетских дисциплин в реализацию

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Планы факультетских дисциплин. Эта таблица доступна в разделе Студент, в форме Справочники факультета на вкладке Планы факультетских дисциплин.

Назначение дисциплин студентам на участке Студент выполняется именно из таблицы данных Планы факультетских дисциплин. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного плана факультетских дисциплин необходимо выполнять действие по передаче плана на факультет.

1.6.4. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные планы факультетских дисциплин (форма Объединенные планы факультетских дисциплин) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как РУП, Выгрузить для печати как БУП.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.

1.7. Объединенные майноры

Объединенный майнор - это такой вид планов, который объединяет в себе "базовый майнор" и "рабочий майнор". Объединенный майнор разрабатывается на несколько лет обучения, содержит полный набор разделов, дисциплин и других видов записей планов на весь период обучения, и в то же время отражает планирование нагрузки как по дисциплине в целом, так и по видам работ (лекции, семинары, практически и т.п.), по учебным годам (курсам студентов), по периодам каждого года (модулям и семестрам), а также отражает планирование испытаний текущего и рубежного контроля. Дополнительной возможностью Объединенных майноров является возможность распределения кредитов, аудиторных часов и общих часов по "частям дисциплины", ограниченным рубежными испытаниями (зачетами и экзаменами).

1.7.1. Создание нового объединенного майнора

Создание объединенного майнора и работа с ним осуществляется в форме Майноры учебных планов, доступной на консоли управления в разделе Разработка учебных планов.

Меню разработка РУП

Представление для работы с базовыми майнорами расположено на первой вкладке данной формы.

Представление объединенные майноры

Для добавления нового объединенного майнора в таблице данных нужно вызвать действие Добавить объединенный майнор. При вызове действия будет отображена форма параметров, которую нужно заполнить следующим образом:

Форма параметров для добавления объединенного майнора
  • Уровень образования - в этом поле из выпадающего списка необходимо выбрать тот уровень образования, для студентов которого будет предназначен майор.
  • Наименование майнора - каждому майнору нужно присвоить наименование. Наименованием может быть любое строковое значение длиной не более 128 символов.
  • Начинается с курса - необходимо указать курс, начиная с которого будет реализовываться майнор.
  • Число лет реализации - в этом поле нужно установить целочисленное значение числа лет реализации майнора.
  • Учебный год начала реализации - в этом поле нужно выбрать учебный год, начиная с которого будет реализовываться данный майнор.
  • Год окончания реализации - в этом поле нужно выбрать учебный год, в котором студенты завершат обучение по данному майнору.
  • Филиал, Факультет - для выбора Образовательной программы, реализующей майнор, в этих полях нужно указать Филиал и Факультет, на которых реализуется данная программа.
  • Образовательная программа, реализующая майнор - в этом поле необходимо выбрать образовательную программу, которая предлагает и будет реализовывать данный майнор.
  • Минимальное количество студентов - в этом поле нужно задать целое число, соответствующее минимальному количеству студентов, для которых будет реализовываться майнор; если минимальное количество студентов не ограничивается, это значение нужно оставить пустым.
  • Максимальное количество студентов - в этом поле нужно задать целое число, соответствующее максимальному количеству студентов, для которых будет реализовываться майнор; если максимальное количество студентов не ограничивается, это значение нужно оставить пустым.
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов в году указать количество периодов в учебном году.

После нажатия кнопки ОК запись о новом майноре будет добавлена в основную таблицу данных.

1.7.2. Редактирование объединенного майнора

Редактирование майнора состоит в наполнении его дисциплинами, которые могут быть объединены в группы, уточнении объема нагрузки по дисциплинам, установке форм итогового контроля по дисциплинам.

Майнор может состоять из записей двух видов: разделы (группы дисциплин) и дисциплины. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в майнор записей других типов (НИСы, курсовые, практики и проч.) недопустимо.

Редактирование объединенного майнора выполняется при помощи специализированной формы редактирования, которая открывается при вызове для майнора действия Открыть или при двойном щелчке мышью по записи о майноре.

Редактирование объединенногоо плана

Добавление и удаление записей майнора, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню.

Добавление Группы дисциплин (раздела)

Для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Добавление группы дисциплин в объединенный майнор

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

Добавление Дисциплины

Для добавления Дисциплины необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие Дисциплину,

Процедура добавление дисциплины в объединенный майнор

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный майнор

Пользователям разработчикам объединенных майноров предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

    • После того как запись о дисциплинебудет добавлена в майнор, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик объединенного майнора больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

Перемещение Группы дисциплин (раздела) или дисциплины

В случае если при добавлении Группы дисциплин или Дисциплины был неверно указан раздел, куда они должны быть включены, то в отношении такой Группы дисциплин или Дисциплины необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить Группу дисциплин или Дисциплину, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина будет перемещена в корень объединенного майнора.

Также можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

Печать объединенных планов факультетских дисциплин

По окончании работы с объединенным майнором его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати, Выгрузить для печати как Базовый майнор, Выгрузить для печати как Рабочий майнор расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении данных действий учебный план будет выгружен для печати в MS Excel.

1.7.3. Передача объединенного майнора в реализацию

Для того, чтобы дисциплины объединенного майнора могли быть назначены студентам, необходимо для плана выполнить действие Передать на факультет.

Передача объединенного майнора в реализацию

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Майноры учебных планов. Эта таблица доступна в разделе Общевузовские ресурсы, в форме Учебные планы, формы и программы обучения на вкладке Майноры учебных планов.

Назначение дисциплин майноров студентам на участке Студент выполняется именно из таблицы данных Майноры учебных планов. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного майнора необходимо выполнять действие по передаче майнора на факультет.

1.7.4. Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные майноры (форма Майноры учебных планов) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи майнора выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

1.7.5. Связать с предложением кафедры

Для того чтобы связать запись объединенного майнора с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись майнора.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

1.7.6. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные майноры (форма Майноры учебных планов) выбрать майнор, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как РУП, Выгрузить для печати как БУП.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести майнор на печать.

1.7.7. Оценка плановой затратности плана

Для оценки плановой затратности майнора необходимо:

  1. В форме редактирования объединенного майнора открыть группу действий Дополнительные действия (правый верхний угол).
    Форма редактирования ОМ Дополнительные действия
  2. Выбрать действие Оценка плановой затратности (отчет).
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате сформируется отчет с оценкой затратности реализации объединенного майнора.

1.7.8. Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных майноров выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.

1.8. Базовые майноры

Базовый майнор - это план изучения определенного набора дисциплин в течение нескольких лет обучения. Каждый базовый майнор разрабатывается для определенного уровня образования. Базовый майнор реализуется одной из образовательных программ вуза в течение определенного периода (нескольних ученых годов). Для базового майнора может задаваться минимальное и максимальное число студентов, необходимое для реализации майнора.

1.8.1. Создание нового базового майнора

Создание базового майнора и работа с ним осуществляется в форме Майноры учебных планов, доступной на консоли управления в разделе Разработка учебных планов.

Майноры на консоли управления

Представление для работы с базовыми майнорами расположено на второй вкладке данной формы.

Таблица данных Базовые майноры

Для добавления нового базового майнора в таблице данных нужно вызвать действие Добавить базовый майнор. При вызове действия будет отображена форма параметров, которую нужно заполнить следующим образом:

Добавление Базового майнора
  • Уровень образования - в этом поле из выпадающего списка необходимо выбрать тот уровень образования, для студентов которого будет предназначен майор.
  • Наименование майнора - каждому майнору нужно присвоить наименование. Наименованием может быть любое строковое значение длиной не более 128 символов.
  • Год начала реализации - в этом поле нужно выбрать учебный год, в котором студенты, для которых предназначается майнор, учились (будут учиться) на первом курсе.
  • Год окончания реализации - в этом поле нужно выбрать учебный год, в котором студенты, для которых предназначается майнор, завершат обучение.
  • Число курсов - в этом поле нужно установить целочисленное значение числа курсов (лет обучения), соответствующее уровню образования
  • Образовательная программа, реализующая майнор - в этом поле необходимо выбрать образовательную программу, которая предлагает и будет реализовывать данный майнор.
  • Минимальное количество студентов - в этом поле нужно задать целое число, соответствующее минимальному количеству студентов, для которых будет реализовываться майнор; если минимальное количество студентов не ограничивается, это значение нужно оставить пустым.
  • Максимальное количество студентов - в этом поле нужно задать целое число, соответствующее максимальному количеству студентов, для которых будет реализовываться майнор; если максимальное количество студентов не ограничивается, это значение нужно оставить пустым.

После нажатия кнопки ОК запись о новом майноре будет добавлена в основную таблицу данных. При этом в подчиненной таблице данных Записи базового майнора будет создана одна запись вида "Раздел плана" с наименованием "Весь майнор", которая будет служить "коревой" записью для будущего майнора.

Выбирая значения полей Год начала реализации, Год окончания реализации, Число курсов нужно исходить из того, что майнор разрабатывается для всех курсов обучения студентов, для которых предназначен майнор. Даже в случае, если известно, например, что майнор будет использоваться для студентов 2 - 3 курсов бакалавриата, для майнора должно быть задано Число лет обучения = 4, и выбраны годы обучения с 1-го по 4-ый курс.

1.8.2. Редактирование базового майнора

Редактирование майнора состоит в наполнении его дисциплинами, которые могут быть объединены в группы, уточнении объема нагрузки по дисциплинам, установке форм итогового контроля по дисциплинам. Формируя майнор, нужно исходить из следующих требования к его структуре:

Требования к структуре майнора:

  • Майнор обязательно должен иметь одну и только одну корневую запись типа "Раздел плана". При создании майнора такая запись создается автоматически и получает наименование " Весь майнор ". Это наименование допустимо изменить.
  • Майнор может состоять из записей двух видов: разделы (группы дисциплин) и дисциплины. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в майнор записей других типов (НИСы, курсовые, практики и проч.) недопустимо.

Редактирование базового майнора выполняется при помощи специализированной формы редактирования, которая открывается при вызове для майнора действия Открыть или при двойном щелчке мышью по записи о майноре.

Форма редактирования Базового майнора

Добавление и удаление записей майнора, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню. Основные характеристики записей майнора (число часов, кредитов, формы итогового контроля) редактируются непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей майнора, не видимых в таблице, предназначено действие Дополнительные свойства.

Удалить запись базового майнора можно только при выполнении следюущих условий:

  • не существует записей рабочих майноров, связанных с данной записью базового майнора
  • раздел (группу дисциплин) можно удалить только в случае, если в него не влкючена ни одна дисциплина и ни один другой раздел; если раздел необходимо удалить, сначала из него неоходимо удалить все дисциплины и другие разделы;

В основном процесс редактирования базового майнора аналогичен процессу редактирования Базового учебного плана (см. раздел Редактирование базового учебного плана) с учетом особенностей работы с записями разных типов, описанных в разделе Особенности наполнения отдельных разделов БУП и РУП. Для базового майнора предусмотрена работа только с разделами (группами дисциплин) и с дисциплинами.

1.9. Рабочие майноры

Рабочий майнор - это план изучения определенного набора дисциплин, входящих в состав одно из Базовых майноров в течение одного учебного года (одного курса студентов). Рабочие майноры разрабатываются на основе разработанных и утвержденных Базовых майноров.

Рабочие майноры для "свободных майноров" не создаются.

1.9.1. Создание нового рабочего майнора

Создание рабочего майнора и работа с ним осуществляется в форме Майноры учебных планов, доступной на консоли управления в разделе Разработка учебных планов.

Майноры на консоли управления

Представление для работы с рабочими майнорами расположено на третьей вкладке данной формы.

Таблица данных Рабочие майноры

Создать новый рабочий майнор можно только на основе ранее созданного базового майнора вида "Обычный майнор". Рабочие майноры для "свободных" майноров не создаются. Для добавления нового рабочего майнора в таблице данных нужно вызвать действие Добавить рабочий майнор. При вызове действия будет отображена форма параметров, которую нужно заполнить следующим образом:

Добавление Рабочего майнора
  • Базовый майнор - в этом поле нужно выбрать один из базовых майноров, на основе которого будет разрабатываться новый рабочий майнор.
  • Учебный год - в этом поле нужно выбрать учебный код, для которого будет разрабатываться новый рабочий майнор, из справочника .
  • Курс - в этом поле нужно выбрать курс студентов, для которого будет разрабатываться новый рабочий майнор.
  • Реализуется по периодам - в этом поле нужно выбрать один из вариантов реализации майнора - по модулям или по семестрам.
  • Количество периодов - в этом поле нужно задать целочисленного значение числа периодов (модулей или семестров), для которых будет распределяться нагрузка по дисциплинам майнора.

После нажатия кнопки ОК запись о новом майноре будет добавлена в основную таблицу данных.

1.9.2. Редактирование рабочего майнора

Редактирование рабочего майнора состоит в задании кафедр, которые будут реализовывать дисциплины, уточнении параметров нагрузки по дисциплине (часов, кредитов), распределении нагрузки по видам работы (лекции, семинары, самостоятельная работа и проч.), и по периодам обучения (модулям или семестрам), установке числа форм текущего контроля (контрольных работ, домашних задний и проч.). Структура рабочего майнора должна повторять структуру базового майнора и соответствовать требованиям, предъявляемым к структуре базового майнора, которые описаны в разделе Редактирование базового майнора. Отличие структуры рабочего майнора от структуры базового майнора может состоять только в отсутствии в рабочем майноре групп дисциплин, которые не реализуются на соответствующем курсе.

Редактирование рабочего майнора выполняется при помощи специализированной формы редактирования, которая открывается при вызове для майнора действия Открыть или при двойном щелчке мышью по записи о майноре.

Форма редактирования Рабочего майнора

Установка кафедры, реализующей дисциплину майнора, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню. Основные характеристики записей майнора (число часов, кредитов), их распределение по видам работы и периодам обучения выполняется непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей майнора, не видимых в таблице, предназначено действие Дополнительные свойства. Для уточнения нагрузки и видов испытаний по периодам обучения предназначено действие Дополнительные свойства в периоде. Перед вызовом этого действия нужно выбрать одну из ячеек в колонке, соответствующей периоду, в правой части формы.

В основном процесс редактирования рабочего майнора аналогичен процессу редактирования Рабочего учебного плана (см. раздел Редактирование рабочего учебного плана) с учетом особенностей работы с записями разных типов, описанных в разделе Особенности наполнения отдельных разделов БУП и РУП. Для рабочего майнора предусмотрена работа только с разделами (группами дисциплин) и с дисциплинами.

1.10. Объединенные учебные планы аспирантуры

"Объединенные учебные планы аспирантуры" - это такой вид учебных планов, который объединяет в себе "базовый учебный план аспирантуры" и "рабочий учебный план аспирантуры". Объединенный учебный план разрабатывается сразу на все годы реализации образовательной программы, содержит полный набор разделов, дисциплин и других видов записей планов на весь период обучения, и в то же время отражает планирование нагрузки как по дисциплине в целом, так и по видам работ (лекции, семинары, практически и т.п.), по учебным годам, по периодам каждого года, а также отражает планирование испытаний текущего и рубежного контроля.

1.10.1. Создание нового объединенного учебного плана аспирантуры

Работа с Объединенными учебными планами аспирантуры ведется на участке "Разработка учебных планов" в форме "Объединенные учебные планы аспирантуры". Для создания нового объединенного учебного плана аспирантуры необходимо чтобы предварительно был сформирован соответствующий образовательный стандарт. Работа с образовательными стандартами описана в разделе Образовательные стандарты.

Для добавления объединенного учебного плана, необходимо в представлении Объединенные учебные планы аспирантуры с помощью контекстного меню вызвать действие Добавить объединенный план аспирантуры.

Вызвать действие Добавить ОУП аспирантов

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров Добавить ОУП аспирантуры

  • В полях Образовательный стандарт и Образовательную программа - выбрать образовательный стандарт и программу, для которой создается план.
  • Поля Аспирантская школа, Филиал, Форма обучения и Число лет обучения будут заполнены автоматически данными, заданными для образовательного стандарта и выбранной образовательной программы.
  • В полях Год начала обучения, Год окончания обучения указать года начала и окончания обучения, периоды, по которым будет планироваться нагрузка.
  • При наличии соответствующей информации можно указать Число кредитов по плану в целом.
  • В поле Реализуется по периодам выбрать один из предлагаемых вариантов реализации: по модулям, по семестрам или по периодам в аспирантуре.
  • В поле Количество периодов в году указать количество периодов в учебном году.

После того, как будет заполнена форма параметров, нужно нажать кнопку ОК. В результате запись о новом объединенном учебном плане аспирантов появится в представлении. При попытке добавления второго объединенного учебного плана аспирантуры на основе той же образовательной программы, образовательного стандарта для той же аспирантской школы, года начала обучения, произойдет ошибка дублирования объектов.

1.10.2. Редактирование объединенного учебного плана аспирантуры

Сформировать структуру и состав нового объединенного учебного плана аспирантуры можно на основе образовательного стандарта. Для этого нужно выбрать объединенный учебный план аспирантуры в представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) и в контекстном меню выбрать действие Сформировать на основе стандарта. При вызове этого действия будет выдано предупреждение:

Сообщение о формировании ОУП аспирантов на основании стандарта

Если Вы уверены, что хотите сформировать учебный план на основе стандарта, то нажмите кнопку Да. Результатом выполнения этого действия будет создание записей в подчиненном представлении Все записи плана.

После того, как объединенный учебный план сформирован на основе стандарта, его можно редактировать. Для редактирования предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования ОУп аспирантов

Редактирование объединенного учебного плана аспирантов должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (практик аспирантов, кандидатских экзаменов, и т.п.), распределять нагрузку по видам работы (лекции, семинары, практические и т.д.), по годам обучения и по периодам обучения в каждом году, а также планировать рубежные испытания, распределять кредиты и объем нагрузки по "частям дисциплины", ограниченным рубежными испытаниями.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: дисциплину, научно-исследовательский семинар, научные исследования аспирантов, практику аспирантов, кандидатский экзамен, итоговый госэкзамен, защиту научного доклада.

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, дисциплина по выбору или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

Форма редактирования ОУП аспирантов распределение нагрузки по годам

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

В ходе работы с формой редактирования необходимо также выполнить уточнение некоторых свойств разделов, дисциплин и других видов записей плана, используемых при автоматизированных проверках и пересчетах показателей плана. Действия по уточнению этих свойств описаны ниже в разделе Уточнение свойств разделов и дисциплин ОУП.

По окончании работы с объединенным учебным планом аспирантов его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении действия учебный план будет выгружен для печати в MS Excel.

1.10.2.1. Добавление дисциплин и НИС

При добавлении дисциплины или НИС в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие дисциплину или научно-исследовательский семинар, после чего заполнить следующую форму параметров:

Форма параметров Добавить дисциплину в ОУП аспирантуры
Пользователям разработчикам учебных планов предоставлена возможность связывания дисциплин и НИС учебного плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину или НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
      Для выбора из плана-предложения кафедры будут доступны только те дисциплины, которые совпадают по периоду реализации с периодом, заданным с помощью полей Год начала реализации и Год окончания реализации.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • Установить значение для признака Входит в расчет недельной нагрузки.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных профилей аспирантуры, необходимо выбрать профили, для которых добавляется дисциплина. Для выбора профилей необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей профилей, после чего нужно нажать кнопку ОК.
      Для каждого профиля в ОУП будет создана отдельная запись по дисциплине.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Вид дисциплины в плане, По выбору студентов, Формат изучения,На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • В поле Только для специализаций если дисциплина предусмотрена только для определенных профилей подготовки аспирантуре, необходимо выбрать профили, для которых добавляется дисциплина. Для выбора профилей необходимо нажать на кнопку Справочник (правый верхний угол поля) и выбрать с помощью чек-боксов Чек-бокс одну и более записей профилей, после чего нужно нажать кнопку ОК.
      Для каждого профиля в ОУП будет создана отдельная запись по дисциплине.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план аспирантуры.
    • После того как запись о дисциплине или НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (более подробно см. Редактирование объединенного учебного плана аспирантуры). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации.

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с дисциплиной-предложением кафедры разработчик плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признак Входит в расчет недельной нагрузки.
  • Профили для дисциплин и НИС (см. Установить/ изменить профиль).
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах всех образовательных программ, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

1.10.2.2. Добавление практики аспирантов

При добавлении практики аспирантов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие практику аспирантов, после чего заполнить следующую форму параметров:

Форма параметров Добавить практику в ОУП аспирантуры

В первую очередь необходимо ввести Наименование практики и Общее число часов, указать Вид практики (справочник ) и Способ проведения практики, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК практика будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по практике (см. Редактирование объединенного учебного плана аспирантуры).

1.10.2.3. Добавление научного исследования аспирантов

При добавлении научного исследования аспирантов в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие научные исследования аспирантов, после чего заполнить следующую форму параметров:

Форма параметров Добавить научные исследования в ОУП аспирантуры

В первую очередь необходимо указать Наименование и Общее число часов для научных исследований аспирантов, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК запись о научных исследованиях аспирантов будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по научным исследованиям (см. Редактирование объединенного учебного плана аспирантуры).

1.10.2.4. Добавление кандидатских экзаменов

При добавлении кандидатского экзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие кандидатский экзамен, после чего заполнить следующую форму параметров:

Форма параметров Добавить кандидатский экзамен в ОУП аспирантуры

В первую очередь необходимо ввести Наименование для экзамена и Общее число часов, выбрать Дисциплину ВУЗа, по которой будет проходить кандидатский экзамен, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК кандидатский экзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по кандидатскому экзамену (см. Редактирование объединенного учебного плана аспирантуры).

1.10.2.5. Добавление итогового госэкзамена

При добавлении госэкзамена в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие итоговый госэкзамен, после чего заполнить следующую форму параметров:

Форма параметров Добавить госэкзамен в ОУП аспирантуры

В первую очередь необходимо ввести Наименование для экзамена и Общее число часов, при необходимости можно выбрать Дисциплину, по программе которой будет проходить экзамен, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК госэкзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по госэкзамену (см. Редактирование объединенного учебного плана аспирантуры).

1.10.2.6. Добавление защиты научного доклада

При добавлении защиты научного доклада в форме редактирования объединенного учебного плана необходимо из контекстного меню в группе процедур Добавить вызвать действие защита научного доклада, после чего заполнить следующую форму параметров:

Форма параметров Добавить защиту докладов в ОУП аспирантуры

В первую очередь необходимо ввести Наименование, также при возможности нужно указать значения остальных параметров.

После нажатия кнопки ОК госэкзамен будет добавлена в объединенный учебный план.

В дальнейшем при помощи Формы редактирования нужно максимально полно занести требуемые для плана параметры нагрузки по защите научного доклада (см. Редактирование объединенного учебного плана аспирантуры).

1.10.2.7. Формирование информации о численности контингента

Для добавления информации о численности контингента необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать план, для записей которого будет уточняться информация о численности контингента.
  2. В представлении Все записи по годам обучения для записей учебного плана в соответствующих полях указать Количество потоков, Количество групп, Количество подгрупп и Количество студентов (аспирантов) (после изменения значения каждого из параметров нужно нажимать клавишу Enter).

1.10.2.8. Изменение периода реализации

Для изменения периода реализации записи объединенного учебного плана аспирантов, необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать учебный план.
  2. В представлении Все записи плана выбрать запись учебного плана, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

1.10.2.9. Уточнение свойств разделов и дисциплин ОУП

В формах редактирования объединенных учебных планов аспирантуры работают проверки контрольных соотношений, при помощи которых контролируется корректность и целостность плана, соответствие характеристик записей плана требованиям образовательного стандарта, выполнение Методических указаний по разработке объединенных учебных планов аспирантуры. Также при помощи функционала формы редактирования можно выполнять автоматизированные пересчеты показателей плана, в частности, суммирование значений числа часов, недель, кредитов по разделам и группам дисциплин.

В образовательном стандарте не содержится достаточно информации для того, чтобы реализовать корректную работу некоторых автоматизированных проверок и пересчетов. По этой причине после формирования учебного плана на основе стандарта, необходимо выполнить уточнение следующих значений для некоторых разделов и дисциплин учебного плана:

  1. Признак Рассчитывается как сумма элементов для групп дисциплин и разделов.

    Все разделы и группы дисциплин можно разделить на два вида:

    • Разделы или группы, показатели которых должны определяться путем суммирования показателей входящих в них записей.
    • Разделы или группы, показатели которых могут устанавливаться независимо.

    К первой группе относятся разделы и группы, все дисциплины которых обязательны для изучения всеми аспирантами. Ко второй группе относятся разделы и группы дисциплин по выбору. Для того, чтобы отличить один вид разделов от другого используется признак Рассчитывается как сумма элементов. При формировании учебного плана на основе стандарта для всех разделов и групп дисциплин этот признак получает значение Да. Если для признака установить значение Нет, то проверка соответствия суммы показателей для всех записей раздела со значением, установленным для раздела в целом, проводиться не будет, и сообщения об ошибках не будут формироваться. Для группы дисциплин (раздела) по выбору значения числа часов, недель, кредитов, числа экзаменов и зачетов нужно установить вручную таким образом, чтобы раздел, в свою очередь, внес необходимый вклад в план в целом. Например, если в раздел включено три дисциплины по выбору, трудоемкостью 108 часов каждая, а аспиранты должны выбрать только одну из них, для раздела вручную должно быть установлено число часов, равное 108.

    Для того чтобы в дальнейшем на основании разработанных объединенных учебных планов можно было сформировать учебный план аспиранта и проверить его полноту и корректность, необходимо задать для каждой группы или раздела дисциплин по выбору минимальное и максимальное количество дисциплин, которые должны быть обязательно выбраны аспирантом, также необходимо задать минимально и максимальное число кредитов, которое необходимо набрать при выборе дисциплин аспирантом. Если при наполнении образовательного стандарта эти значения не заданы, то их необходимо задать в форме редактирования объединенного учебного плана при помощи действия Дополнительные свойства.

  2. Признак Входит в расчет недельной нагрузки. Данный признак используется для того, чтобы исключить некоторые дисциплины учебного плана из расчета недельной аудиторной нагрузки аспирантов. Изменить значение данного признака можно в форме редактирования учебного плана при помощи действия Дополнительные свойства. При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются двумя звездочками (**) в колонке "Наименование дисциплины". По этой причине вносить знаки * в наименование дисциплины не нужно. В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.

1.10.2.10. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связать с предложением кафедры в ОУП аспирантуры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

1.10.2.11. Установить/ изменить профиль

Для установки, снятия и изменения профиля, установленного для записи учебного плана, необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать учебный план, в который входит запись.
  2. В представлении Все записи плана выбрать запись, для которой необходимо установить, снять или изменить профиль.
    При добавлении дисциплины или НИС можно установить сразу несколько специализаций, для каждой из них будет создана отдельная запись о дисциплине или НИС (см. Добавление дисциплин и НИС). В связи с этим необходимо удостовериться, что выбранная дисциплина или НИС соответствуют той записи, которую необходимо изменить. Установленные специализации можно проверить в поле Специализация.
  3. Из контекстного меню вызвать действие Установить\изменить профиль.
  4. В форме параметров указать Специализацию (профиль аспирантуры).
  5. Нажать кнопку ОК.

1.10.3. Передача плана на факультет

Для того чтобы дисциплины объединенного учебного плана аспирантуры могли быть назначены аспирантам, необходимо для плана выполнить действие Передать план в реализацию.

Вызов действия Передать план в реализацию для ОУП аспирантов

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

Результатом выполнения процедуры будет создание или уточнение свойств записей в представлении Учебные планы аспирантуры. Данное представление доступно на участке Аспирант, в форме Учебные планы аспирантуры.

1.10.4. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать действие Выгрузить для печати.
  3. В форме параметров указать Профиль, для которого нужно вывести на печать, или оставить пустое значение, если нужно вывести на печать учебный план для всех профилей.
  4. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.

1.10.5. Оценка плановой затратности плана

Выполнить оценку плановой затратности плана можно:

С помощью формирования отчета "Оценка плановой затратности плана"

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
    Вызов действия отчет оценка затратности ОУп аспирантов
  2. Выбрать действие Оценка плановой затратности (отчет).
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате сформируется отчет с оценкой затратности реализации объединенного учебного плана аспирантов.

С помощью действия Рассчитать плановую затратность

  1. В форме редактирования объединенного учебного плана открыть группу действий Дополнительные действия (правый верхний угол).
  2. Выбрать действие Рассчитать плановую затратность.
  3. В форме параметров указать Учебный год и нажать кнопку ОК.

В результате будет выведено сообщение с указанием плановой затратности плана.

1.11. Базовые учебные планы аспирантуры (БУПы аспирантуры)

Базовые учебные планы аспирантуры разрабатываются на основе Образовательных стандартов аспирантуры отдельно для каждой и для каждого набора аспирантов. Базовый учебный план аспирантуры отражает полный цикл дисциплин и других видов нагрузки, которые должны быть прослушаны и сданы аспирантами в течение всего срока обучения в аспирантуре с разбиением нагрузки по годам обучения.

Каждый базовый учебный план аспирантуры может расширять и уточнять содержание соответствующего образовательного стандарта. Работа с БУПом аспирантуры состоит из этапов:

  • Создание БУП аспирантуры на основе образовательного стандарта
  • Редактирование БУП аспирантуры
  • Согласование и утверждение БУП аспирантуры

1.11.1. Создание нового базового учебного плана аспирантуры

Для создания БУП аспирантуры необходимо, чтобы предварительно были сформированы следующие данные:

  • Создан и полностью сформирован Образовательный стандарт аспирантуры по соответствующему направлению подготовки.
  • В справочнике создана соответствующая аспирантская школа.
  • В справочнике созданы учебные года, соответствующие всем годам, в течение которых будет реализовываться новый БУП (от года начала обучения до года окончания обучения).
  • В справочнике созданы записи о форме и годах обучения, для которых будет разрабатываться БУП.

Создание и дальнейшая работа с БУП аспирантуры ведется в разделе Разработка учебных планов в форме Базовые и рабочие учебные планы аспирантуры на первой вкладке Базовые учебные планы аспирантуры. Для создания нового БУП аспирантуры на этой вкладке необходимо вызвать действие Добавить базовый учебный план.

Добавление БУП аспирантуры

Для добавления нужно в поле Аспирантская школа выбрать соответствующую школу из справочника , выбрать Образовательный стандарт из справочника Образовательные стандарты, выбрать Форму обучения и задать соответствующее этой форме Число лет обучения. Также необходимо выбрать Год начала обучения и Год окончания обучения из справочника .

После корректного заполнения всех полей формы добавления кнопка ОК станет активной. После ее нажатия новый базовый учебные план аспирантуры будет добавлен в таблицу данных.

1.11.2. Редактирование базового учебного плана аспирантуры

После создания БУП аспирантуры его необходимо заполнить и отредактировать путем выполнения следующих двух этапов:

  1. Сформировать на основе стандарта
  2. Отредактировать, указав распределение нагрузки, заданной стандартом по годам обучения, при необходимости уточнив и дополнив содержание стандарта.

Формирование БУП аспирантуры на основе стандарта

После создания БУП аспирантуры необходимо выбрать его в таблице данных и вызвать действие Сформировать на основе стандарта. Результатом выполнения этого действие будет копирование в БУП всего содержания стандарта с сохранением структуры разделов и величин нагрузки, заданных в стандарте.

Редактирование БУП аспирантуры

Для редактирования БУП аспирантуры предназначена специализированная форма, которая доступна посредством вызова действия Открыть по выбранному БУП. При помощи формы редактирования можно выполнять следующие операции:

  • Корректировать (в случае необходимости) или дополнять значения нагрузки, полученные из стандарта
  • Распределять нагрузку, предусмотренную по дисциплине в целом по годам обучения.
  • Дополнять содержание стандарта дополнительными дисциплинами и другими видами работы.
  • Уточнять структуру плана за счет добавления новых разделов или групп дисциплин и переноса дисциплин между разделами.

В целом принцип редактирования БУП аспирантуры аналогичен принципу редактирования БУП студентов, описанному в разделе Редактирование базового учебного плана. Работа с Графиками учебного процесса для БУП аспирантуры не предусмотрена.

Принципы работы с отдельными видами записей БУП аспирантуры аналогичны принципам, заложенным для БУП студентов и описаны в разделе Особенности наполнения отдельных разделов БУП и РУП.

В форме редактирования БУП аспирантуры реализованы проверки и автоматически расчеты, аналогичные реализованным для БУП факультетов. Принцип действия этих расчетов описан в разделе Расчетные показатели учебных планов.

Готовый БУП аспирантуры можно выгрузить в утвержденной форме в MS Excel при помощи действия Выгрузить для печати.

1.12. Рабочие учебные планы (РУПы)

Рабочие учебные планы представляют собой иерархическую структуру компонентов (разделов, циклов), групп дисциплин, дисциплин и записей других видов (курсовых работ, практик, итоговых госэкзаменов, выпускных квалификационных работ). Рабочий учебный план разрабатывается на один учебный год для одного курса студентов факультета (отделения), обучающихся по одному направлению (специальности), по одной специализации, магистерской программе и магистерской специализации. Рабочие учебные планы содержат информацию о видах и количестве испытаний текущего, промежуточного и итогового контроля по дисциплинам, о распределении учебной нагрузки по видам (лекции, семинары, самостоятельная работа и т.п.), а также о реализации дисциплин различными кафедрами ВУЗа.

Каждый рабочий учебный план формируется на основе базового учебного плана, благодаря чему получает атрибуты Тип образовательного стандарта, Образовательный стандартНаправление (специальность), Степень (квалификация), Факультет. Если для базового учебного плана были заданы Специализация, Магистерская программа, Магистерская специализация, то они также будут использованы для РУП. Если эти атрибуты не были заданы для БУП, их можно уточнить при создании РУП.

Создание нового рабочего учебного плана включает следующие этапы работы:

  1. Создание записи о РУПе и его наполнение на основе базового учебного плана.
  2. Редактирование сформированного РУПа.
  3. Связывание записей РУПа с компетенциями.

1.12.1. Создание нового рабочего учебного плана

Работа с РУПами ведется в форме Базовые и рабочие учебные планы в таблице данных Рабочие учебные планы. Для создания нового РУП нужно в этой таблице данных вызвать действие Добавить рабочий учебный план.

Добавление РУП бакалавриата

Форма добавления РУП (бакалавриат)

Добавление РУП магистратуры

Форма добавления РУП (магистратура)
  • В поле Факультет значение подставится автоматически, если Вы являетесь пользователем одного из факультетов. Если Вы имеете права на работу со всеми факультетами, то в этом поле нужно выбрать факультет, для которого создается РУП.
  • В поле Уровень обучения нужно выбрать один из предлагаемых вариантов (Бакалавриат, Специалитет, Магистратура)
  • В поле Базовый учебный план для выбора будут предложены все ранее созданные БУПы выбранного факультета и уровня обучения. После выбора БУП автоматически заполнятся поля Направление / специальность (обязательно присутствует в БУП), а также Специализация, Магистерская программа, Магистерская специализация (если они заданы в БУП).
  • Поле Направление / специальность заполняется автоматически при выборе БУП и недоступно для самостоятельного изменения.
  • Поле Специализация доступно для изменения только в случае, если в поле Уровень образования выбраны значения Бакалавриат или Специалитет, а также если специализация не задана в БУП. В этом случае специализацию можно выбрать из перечня специализаций, существующих в справочнике . Если РУП не требует задания специализации, то это поле нужно оставить пустым.
  • Поле Магистерская программа заполняется автоматически на основании выбранного БУП. Это поле недоступно для отдельного изменения.
  • Поле Магистерская специализация доступно для заполнения только в случае, если в поле Уровень образования выбрано значение Магистратура а также если магистерская специализация не задана в БУП. В этом случае ее можно выбрать из перечня, существующего в справочнике для выбранной магистерской программы.
  • В поле Форма обучения нужно выбрать ту форму обучения, по которой будет реализовываться РУП. Выбор производится из общевузовского справочника .
  • В поле Курс нужно выбрать курс факультета, для которого формируется РУП.
  • В поле Учебный год нужно выбрать учебный год, в котором будет реализовываться формируемый РУП.
  • Поле Вариант позволяет создать несколько вариантов РУП одного и того же РУП с тем, чтобы в дальнейшем выбрать наиболее удачный вариант. Для этого в данном поле нужно указать метку варианта (например, "в-2"). Желательно использовать минимального число символов. Если Вы не планируете работать с несколькими вариантами одного и того же РУП, это поле нужно оставить пустым.
  • В поле Реализуется по периодам нужно выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество учебных периодов нужно задать число модулей или семестров, по которым будет реализовываться план.
  • В поле Количество потоков нужно задать плановое число потоков по данному РУП.
  • В поле Количество студентов нужно задать плановое число студентов, которые будут обучаться по данному РУП.
  • В поле Количество групп нужно задать число групп студентов, которые будут обучаться по РУП.

После заполнения всех необходимых полей, нужно нажать кнопку ОК, и запись о новом РУП появится в таблице данных. Не допускается создание двух РУП с одинаковым сочетанием атрибутов

  • Факультет
  • Учебный год
  • Направление/специальность
  • Специализация
  • Магистерская программа
  • Магистерская специализация
  • Метка варианта плана
При попытке создания второго РУП с тем же сочетанием атрибутов произойдет ошибка дублирования объектов.

1.12.2. Создание рабочего учебного плана как копии существующего

Если необходимо создать рабочий учебный план, существенно схожий с уже существующим, можно воспользоваться возможностью копирования плана. При помощи копирования можно создать РУП другой специализации, другой магистерской специализации. Также допустимо копировать РУП с одного учебного года на другой. Для этого необходимо сменить БУП, на основе которого разрабатывается РУП на БУП другого года набора. Также при помощи копирования можно создать другую версию того же плана.
Несмотря на то, что при копировании РУП разрешена смена БУП, являющегося основой РУП, не рекомендуется копировать РУП со сменой направления (специальности) подготовки. Копировать РУП с одного учебного года на другой стоит только в том случае, если структура плана (разделы плана и порядок их включения друг в друга) сохраняется. Если же структура плана должна быть другой, то лучше создать новый план, после чего воспользоваться действием Сформировать не основе базового плана.
Для того чтобы создать новый план на основе существующего, нужно выбрать исходный план в таблице данных и вызвать действие Скопировать как новый план.

Форма копирования нового РУП на базе старого

Набор полей формы копирования аналогичен набору полей формы добавления рабочего плана. Принципы работы со всеми полями описаны в разделе Создание нового рабочего учебного плана. При открытии формы копирования плана все поля заполняются значениями, установленными для исходного плана. Для создания нового плана нужно изменить те значения, которые будут отличаться для нового плана и нажать кнопку ОК.

Результатом работы процедуры копирования будет запись о новом рабочем учебном плане в таблице данных Рабочие учебные планы. В подчиненной таблице Записи рабочего плана будет создан набор записей, полностью аналогичный составу исходного плана. Также для нового плана будет перенесена информация о распределении учебной нагрузки по периодам обучения и формы текущего контроля. Если с записями исходного плана были связаны компетенции, то они также будут скопированы в новый план и связаны с соответствующими записями.

После выполнения процедуры копирования можно продолжить редактирование нового плана. Редактирование может заключаться в добавлении новых записей, удалении созданных при копировании, уточнении форм итогового и текущего контроля по дисциплинам, значений объема учебной нагрузки в часах, неделях, кредитах.

Выполнять копирование плана лучше после того, как работа над составом и структурой исходного плана завершена (или близка к завершению). Автоматически актуализировать структуру и состав копии плана после изменения исходного плана будет невозможно. Однако возможно выполнить для нового плана действие Очистить, удалить план и снова сформировать его как копию существующего. Переформировывать таким образом план можно только пока он находится в статусе проект.

1.12.3. Редактирование рабочего учебного плана

Если рабочий учебный план не создавался методом копирования, то после создания его содержимое можно сформировать на основе выбранного при создании базового учебного плана. Для этого нужно выбрать РУП в таблице данных и выполнить действие Сформировать на основе базового плана. Результатом выполнения этого действия будет создание записей в подчиненной таблице данных Записи рабочего учебного плана. В таблице данных Развиваемые компетенции, подчиненной по отношению к записям плана, будут сформированы записи о компетенциях повторяющие записи, созданные в БУП.

После того, как РУП сформирован на основании БУП или скопирован, его можно редактировать. Для редактирования предназначена специализированная форма работы с РУП, которая открывается при вызове действия Открыть.

Редактирование РУП должно заключаться в добавлении в существующие разделы дисциплин и других видов нагрузки (курсовых работ, практик, и т.п.), выборе кафедр, которые будут преподавать дисциплины на факультете, распределении учебной нагрузки по видам (лекции, семинары, самостоятельная работа) и по учебным периодам. Для добавления записей в РУП предназначены соответствующие действия контекстного меню. Для добавлении записи в определенный раздел нужно сначала выбрать заголовок этого раздела или одну из входящих в него записей.

При добавлении дисциплины в РУП потребуется найти нужную дисциплину в общевузовском справочнике всех дисциплин. Данный справочник, как правило, содержит очень много записей, многие из которых имеют похожие наименования. Для поиска нужной дисциплины можно использовать следующие приемы:
  1. Начать ввод с клавиатуры названия дисциплины в поле Дисциплина формы добавления. По ходу вводу символов будут автоматически предлагаться дисциплины, наименование которых начинается с введенных символов (при вводе необходимо соблюдать регистр!).
  2. Открыть справочник дисциплин, воспользоваться фильтром по наименованию или по части наименования. В строке фильтра допустимо использование символов "*" (любое число любых символов) и "?" (один любой символ). Например, введя в строку фильтра значение *экономическ* и нажав Enter можно отобрать для показа только те дисциплины, которые имеют в своем наименовании буквосочетание "экономическ" ("История экономических учений", "Введение в экономическую географию", "Политико-экономический анализ" и т.п.). При этом дисциплина с наименованием "Экономическая теория" отобрана не будет, т.к. символ "Э" введен в ней в верхнем регистре.

    Установка фильтра 1
  3. Открыть справочник дисциплин, выбрать в нем любую запись, в записи выбрать колонку "Полное наименование". Прижав клавишу Alt, начать вводить наименование дисциплины. Регистр символов при этом не играет роли.

    Установка фильтра 2

    После того, как клавиша Alt будет отпущена, в таблице данных будет найдена и выделена первая дисциплина, наименование которой начинается с символов "дискр" в любом регистре, например, "Дискретная математика".

По окончании работы с РУП его можно вывести на печать. Для этого можно воспользоваться действием Напечатать план, расположенным в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия РУП будет выгружен для печати в MS Excel.

1.12.4. Связывание записей рабочего плана с развиваемыми компетенциями

При формировании рабочего учебного плана не основе базового, компетенции, связанные с записями базового плана будут связаны с соответствующими записями рабочего плана. Для дополнения и уточнения развития компетенций в РУП можно удалить или добавить компетенции к записям РУП, что делается аналогично связыванию компетенций с записями БУП (см. раздел Связывание записей базового плана с развиваемыми компетенциями ).

1.13. Рабочие учебные планы аспирантуры (РУПы аспирантуры)

Рабочие учебные планы аспирантуры разрабатываются на основе Базовых учебных планов аспирантуры отдельно для каждой и для каждого учебного года. Рабочий учебный план аспирантуры отражает цикл дисциплин и других видов нагрузки, которые должны быть прослушаны и сданы аспирантами в течение одного года обучения с разбиением нагрузки по периодам обучения (полугодиям) т указанием форм промежуточного и итогового контроля по периодам обучения.

Каждый рабочий учебный план аспирантуры может расширять и уточнять содержание соответствующего базового учебного плана. Работа с РУПом аспирантуры состоит из этапов:

  • Создание РУП аспирантуры на основе БУП
  • Редактирование РУП аспирантуры
  • Согласование и утверждение РУП аспирантуры

1.13.1. Создание нового рабочего учебного плана аспирантуры

Для создания БУП аспирантуры необходимо, чтобы предварительно были сформированы следующие данные:

  • Создан и полностью сформирован Базовый учебный план аспирантуры, на основе которого должен быть разработан новый РУП.
  • В справочнике создан учебный год, на который будет разрабатываться новый РУП, и в составе этого учебного года должны быть созданы периоды обучения, по которым предстоит распределять нагрузку и планировать испытания (зачеты и экзамены).
  • В справочнике создана запись о форме и годе обучения, для которых будет разрабатываться РУП.

Создание и дальнейшая работа с РУП аспирантуры ведется в разделе Разработка учебных планов в форме Базовые и рабочие учебные планы аспирантуры на второй вкладке Рабочие учебные планы аспирантуры. Для создания нового РУП аспирантуры на этой вкладке необходимо вызвать действие Добавить рабочий учебный план.

Добавление РУП аспирантуры

Для добавления нужно в поле Аспирантская школа выбрать соответствующую школу из справочника , выбрать Базовый учебный план. После выбора базового учебного плана поля Направление / специальность и Форма обучения будут заполнены данными, соответствующими БУП. Изменять из независимо от БУП невозможно. Также необходимо выбрать Год обучения аспирантов из справочника и Учебный год из справочника . Значение в поле Количество учебных периодов позволит выполнять планировать нагрузку и проведение испытаний по соответствующему числу сессий. Значения Количество потоков, Количество групп, Количество аспирантов позволят рассчитывать нагрузку кафедр и преподавателей по реализации данного РУП.

После корректного заполнения всех полей формы добавления кнопка ОК станет активной. После ее нажатия новый рабочий учебные план аспирантуры будет добавлен в таблицу данных.

1.13.2. Редактирование рабочего учебного плана аспирантуры

После создания РУП аспирантуры его необходимо заполнить и отредактировать путем выполнения следующих двух этапов:

  1. Сформировать на основе БУП
  2. Отредактировать, указав распределение нагрузки, заданной БУП, по периодам учебного года, запланировать рубежные испытания (экзамены и зачеты) и текущий контроль (домашние задания, рефераты, контрольные работы). При необходимости можно уточнить и дополнить содержание БУП.

Формирование РУП аспирантуры на основе БУП

После создания РУП аспирантуры необходимо выбрать его в таблице данных и вызвать действие Сформировать на основе базового. Результатом выполнения этого действие будет копирование в РУП всего содержания РУП на один из годов обучения с сохранением структуры разделов и величин нагрузки, заданных в БУП.

Редактирование РУП аспирантуры

Для редактирования РУП аспирантуры предназначена специализированная форма, которая доступна посредством вызова действия Открыть по выбранному РУП. При помощи формы редактирования можно выполнять следующие операции:

  • Корректировать (в случае необходимости) или дополнять значения нагрузки, полученные из БУП
  • Распределять нагрузку, предусмотренную по дисциплине в учебном году по периодам учебного года.
  • Планировать текущий контроль (домашние задания, рефераты, контрольные работы и проч.).
  • Дополнять содержание БУП дополнительными дисциплинами и другими видами работы.
  • Уточнять структуру плана за счет добавления новых разделов или групп дисциплин и переноса дисциплин между разделами.

В целом принцип редактирования РУП аспирантуры аналогичен принципу редактирования РУП студентов, описанному в разделе Редактирование рабочего учебного плана.

Принципы работы с отдельными видами записей РУП аспирантуры аналогичны принципам, заложенным для РУП студентов и описаны в разделе Особенности наполнения отдельных разделов БУП и РУП.

В форме редактирования РУП аспирантуры реализованы проверки и автоматически расчеты, аналогичные реализованным для РУП факультетов. Принцип действия этих расчетов описан в разделе Расчетные показатели учебных планов.

Готовый РУП аспирантуры можно выгрузить в утвержденной форме в MS Excel при помощи действия Выгрузить для печати.

1.14. Рабочие учебные планы общевузовских дисциплин

В системе поддерживается возможность разработки рабочих учебных планов (РУПов), в которые будут включены дисциплины, преподаваемые не для студентов определенных образовательных программ, а предлагаемые для выбора всем студентам вуза. В отличие от обычных РУПов РУПы общевузовских дисциплин разрабатываются независимо от Базовых учебных планов (БУП) и Образовательных стандартов.

Структура и атрибутивный состав записей РУПов общевузовских дисциплин аналогичны обычным РУПам. При этом для РУПов общевузовских дисциплин не предусмотрен расчет итоговых показателей плана (сумма часов и кредитов, средняя аудиторная нагрузка и проч.). Также для РУПов общевузовских дисциплин не предусмотрены процедуры согласования и утверждения.

Данные о дисциплинах, входящих в общевузовские РУПы, используются при составлении планов нагрузки преподавателей. Нагрузка по дисциплинам общевузовских РУП рассчитывается аналогично нагрузке по дисциплинам обычных РУП.

Создание и редактирование РУПов общевузовских дисциплин выполняется в разделе Разработка учебных планов в форме Учебные планы общевузовских дисциплин на вкладке Рабочие планы общевузовских дисциплин.

1.14.1. Создание РУПа общевузовских дисциплин

Создание РУПов общевузовских дисциплин выполняется в разделе Разработка учебных планов в форме Учебные планы общевузовских дисциплин на вкладке Рабочие планы общевузовских дисциплин. Для создания нового плана нужно вызвать действие Добавить учебный план общевузовских дисциплин.

Добавление РУП общевузовских дисциплин

Для создания нового РУП необходимо выбрать Учебный год, занести Наименование плана, выбрать Уровень образования (параметр необязательный), выбрать тип периодов реализации в поле Реализуется по периодам и задать Количество учебных периодов.

От выбора Уровня образования будет зависеть то, по каким нормативам будет считаться нагрузка кафедр и преподавателей по дисциплинам этого плана. От выбора Периодов реализации и их количества будет зависеть то, по каким периодам будут планироваться испытания (экзамены и зачеты) по этим дисциплинам.

1.14.2. Редактирование РУПа общевузовских дисцплин

После создания РУПа общевузовских дисциплин его можно редактировать при помощи формы редактирования. Форма редактирования открывается при помощи действия Открыть.

Добавление разделов, групп дисциплин и дисциплин, уточнение их характеристик, распределения аудиторных часов по модулям выполняется аналогично этим же возможностям в обычных РУП. Подробнее - Редактирование рабочего учебного плана. Итоговые значения для плана в целом и средние значения недельной аудиторной нагрзки по плану в целом не подсчитываются.

1.14.3. Передача РУПа общевузовских дисциплин на реализацию

Для того, чтобы дисциплины общевузовского РУП могли быть назначены студентам, необходимо выполнить для плана действие Передать план на факультет. Для каждой отдельной дисциплины можно также вызывать действие Передать в план факультета в подчиненной таблице Записи рабочего учебного плана.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Дисциплины вне учебных планов. Эта таблица доступна в разделе Общевузовские ресурсы, в форме Учебные планы, программы и формы обучения на вкладке Дисциплины вне учебных планов.

Назначение дисциплин студентам на участке Студент выполняется именно из таблицы данных Дисциплины вне учебных планов. Поэтому при завершении создания дисциплины или при внесении изменений в данные общевузовского РУП необходимо выполнять действие по передаче плана или дисциплин на факультет.

1.15. Объединенные планы общевузовских дисциплин

Объединенный план общевузовских дисциплин дисциплин представляет собой иерархическую структуру групп дисциплин (раделов) и включенных в них дисциплин (НИС и дисциплин для иностранных студентов).

Создание и редактирование нового объединенного плана общевузовских дисциплин включает следующие этапы работы:

1.15.1. Создание нового объединенного плана общевузовских дисциплин

Работа с Объединенными учебными планами общевузовских дисциплин ведется на участке "Разработка учебных планов" в форме "Учебные планы общевузовских дисциплин".

Расположение формы Учебные планы общевузовских дисциплин

Для добавления плана необходимо в верхней таблице данных Объединенные планы общевузовских дисциплин с помощью контекстного меню вызвать действие Добавить объединенный план общеуниверситетских дисциплин.

Процедура добавления объединеннго плана общевузовских дисциплин

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров добавления объединенного плана общевузовских дисциплин
  • В поле Тип общевузовского плана выбрать из списка (кнопка Список) соотвествующий тип плана.
  • В поле Уровень образования из выпадающего списка необходимо выбрать тот уровень образования, для студентов которого предназначен создаваемый учебный план.
  • В поле Наименование плана учебному плану нужно присвоить наименование. Наименованием может быть любое строковое значение длиной не более 128 символов.
  • В поле Число лет реализации указать количество лет, в течение которых реализуется объединенный план общевузовских дисциплин.
  • В поле Учебный год начала реализации указать год начала обучения по данному плану.
  • В поле Год окончания реализации нужно выбрать учебный год, в котором студенты завершат обучение по данному плану.
  • В поле Реализуется по периодам выбрать один из двух предлагаемых вариантов реализации: по модулям или по семестрам.
  • В поле Количество периодов указать количество периодов в учебном году.

После того, как все поля формы будут заполнены, кнопка ОК на форме добавления станет доступной. После ее нажатия, запись о новом объединенном плане общевузовских дисциплин появится в таблице данных. При попытке добавления второго плана идентичного уже созданному произойдет ошибка дублирования объектов.

1.15.2. Редактирование объединенного плана общевузовских дисциплин

Редактирование объединенного плана общевузовских дисциплин состоит в наполнении его дисциплинами, НИС, или дисциплинами иностранных студентов, которые могут быть объединены в группы, уточнении объема нагрузки, установке форм итогового контроля.

Объединенный план может состоять из следующих видов записей: разделы (группы дисциплин), дисциплины, НИС и Дисциплины иностранных студентов. Дисциплины можно объединять в группы, также допустимо включение групп друг в друга. Добавление в план записей других типов (курсовые, практики и проч.) недопустимо.

Редактирование объединенного плана выполняется при помощи специализированной формы редактирования, которая открывается при вызове для выбранного учебного плана действия Открыть или при двойном щелчке мышью по записи об учебном плане.

Редактирование объединенного плана общевузовских дисциплин

Добавление и удаление записей учебного плана, изменение порядка следования записей, перенос записей из одного раздела (группы) в другой выполняется при помощи действий контекстного меню.

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

Редактирование записей объединенного плана

Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

По окончании работы с объединенным планом его можно вывести на печать. Для этого можно воспользоваться действием Выгрузить для печати или Выгрузить для печати как РУП расположенные в группе Дополнительные действия в правом верхнем углу формы. При выполнении этого действия учебный план будет выгружен для печати в MS Excel.

1.15.2.1. Добавление раздела (группы дисциплин)

Для создания Группы дисциплин (раздела) необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие группу дисциплин,

Добавление группы дисциплин в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавления раздела в объединенный план факультета

  • В поле Наименование необходимо ввести название Группы дисциплин (раздела).
  • В поле Количество выбираемых дисциплин при необходимости можно указать количество выбираемых в данном разделе дисциплин.
  • В поле Общее число часов можно указать общее количество часов по плану для данной Группы дисциплин (раздела). При необходимости данное поле можно оставить пустым и указать данный параметр непосредственно в форме редактирования.
  • Поля Число недель и Число кредитов устанавливаются автоматически в зависимости от указанного значения в поле Общее число часов, но при необходимости их можно изменить либо указать пустые значения, а позднее уточнить в форме редактирования.

После нажатия кнопки ОК, Группа дисциплин (раздел) будет добавлен.

1.15.2.2. Добавление дисциплины

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать действие дисциплину,

Процедура добавление дисциплины в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный план общевузовских дисциплин
Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти дисциплину из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Дисциплина, предлагаемая кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны дисциплины планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для дисциплин из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Дисциплина, предлагаемая кафедрой оставить пустым.
    • в поле Дисциплина ВУЗа указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

    • После того как запись о дисциплине будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания дисциплины плана с записью дисциплины, предлагаемой кафедрой, разработчик объедиеннного учебного плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

1.15.2.3. Добавление НИС

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать действие научно-исследовательский семинар,

Процедура добавление НИС в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины в объединенный план общевузовских дисциплин
Пользователям разработчикам объединенных планов предоставлена возможность связывания дисциплин разрабатываемого плана с записями о дисциплинах, предлагаемых к реализации кафедрами (более подробно о планах-предложениях кафедр описано в разделе Предложения кафедры в учебные планы). Связывать дисциплину своего учебного плана с дисциплиной предложением кафедры можно либо сразу при добавлении дисциплины в план, либо после добавления дисциплины при помощи действия Связать с предложением кафедры.
  1. В первую очередь нужно найти НИС из планов-предложений кафедр, для этого необходимо:
    • С помощью полей Год начала реализации и Год окончания реализации указать период реализации дисциплины.
    • В поле Кафедра можно указать подразделение, в данном случае будут предложены дисциплины-предложения именно этой кафедры, либо очистить поле Кафедра, после чего для выбора будут предложены дисциплины всех кафедр.

    • В поле Семинар, предлагаемый кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      Для поиска будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
  2. В случае если на одной из кафедр найдена подходящая дисциплина, ее можно выбрать, после чего в форме параметров автоматически заполнятся все поля, зависящие от дисциплины. Остальные поля нужно заполнять самостоятельно:
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Код записи при необходимости указать код записи дисциплины или НИС.
    • В поле Порядковый номер будет установлено текущее значение порядкового номера для добавляемой записи учебного плана, при необходимости его можно изменить
    • В поле Вид дисциплины в плане указать вид дисциплины в плане (обязательная, предмет по выбору...).
    • В поле По выбору студентов нужно установить значение "Да", если для назначения дисциплины необходимо чтобы студент предварительно ее выбрал для изучения.
    • В соответствующих полях установить признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Нажать кнопку ОК, после чего будет добавлен в объединенный учебный план.
    • Для созданной записи в форме редактирования необходимо установить значение Планового коэффициента для текущего контроля и экзамена.
    Значениями параметров разработчик плана сможет управлять и на последующих этапах работы с дисциплиной. Однако после связи дисциплины плана с дисциплиной-предложением кафедры разработчик не сможет изменять характеристики нагрузки по дисциплине и ее распределения во времени - этими параметрами будет управлять кафедра, в план-предложение которой включена выбранная дисциплина.
  3. Если среди дисциплин-предложений кафедры не найдено подходящей для плана дисциплины, то нужно:
    • поле Семинар, предлагаемый кафедрой оставить пустым.
    • в поле Семинар (дисциплина ВУЗа) указать требуемую дисциплину, для этого необходимо открыть справочник Дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
    • Заполнить поля: Имеет пререквизиты, Код записи, Порядковый номер, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
    • Установить Год начала реализации и Год окончания реализации.
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
    • Нажать кнопку ОК, после чего дисциплина или НИС будет добавлена в объединенный учебный план.

    • После того как запись о НИС будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, кредитов, формы итогового контроля), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается студентами или нет и т.д.), предназначено действие Дополнительные свойства. Для изменения периода реализации предназначено действие Изменение периода реализации дисциплин.

      Редактирование записей объединенного плана

      Для текущего контроля и экзамена в форме редактирования достаточно установить значение Планового коэффициента.

      Значение Минимального коэффициента определяется в зависимости от способа реализации дисциплины по справочнику .

      Значения Минимального числа часов и Планового числа часов рассчитается автоматически после того как будет добавлена информация о контингенте студентов (см. Формирование информации о численности контингента).

    • Для отредактированной записи нужно вызвать действие контекстного меню Связать с предложением кафедры, а далее либо связать с действующим предложением кафедры, либо оставить заявку на дисциплину.

После связывания семинара с дисциплиной-предложением кафедры разработчик объединенного учебного плана больше не сможет изменять параметры нагрузки по семинару, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  • Устанавливать значение Планового коэффициента для текущего контроля и экзамена.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

1.15.2.4. Добавление дисциплины иностранных студентов

Добавлять Дисциплины для иностранных студентов можно только в объединенные планы общевузовских дисциплин, у которых при создании Тип общевузовского плана был установлен как "Дисциплины для иностранных студентов". (см. Создание нового объединенного плана общевузовских дисциплин).

Для добавления Дисциплины иностранных студентов необходимо в форме редактирования выбрать Группу дисциплин (раздел), в которую она будет включена, и с помощью контекстного меню в группе процедур Добавить выбрать действие дисциплину иностранных студентов,

Процедура добавление дисциплины иностранных студентов в объединенный план общевузовских дисциплин

после чего заполнить следующую форму параметров:

Форма параметров добавление дисциплины иностранных студентов в объединенный план общевузовских дисциплин
  1. В поле Кафедра задать кафедру, которая будет вести дисциплину.
  2. в поле Дисциплина для иностранных студентов указать требуемую дисциплину, для этого необходимо открыть справочник Все дисциплины ВУЗа (кнопка Справочник) и выполнить поиск дисциплины. Если дисциплину не удается найти, то необходимо в справочнике Все дисциплины ВУЗа с помощью контекстного меню вызвать действие Добавить дисциплину ВУЗа, заполнить все требуемые параметры и нажать кнопку ОК.
  3. Заполнить поля: Имеет пререквизиты, Код записи, Вид дисциплины в плане, По выбору студентов, На иностранном языке, Читается носителем языка, Общее число часов, Аудиторных часов, Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
  4. Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соотвествующую область науки из выпадающего списка Список или с помощью справочника Справочник.
  5. Нажать кнопку ОК, после чего дисциплина будет добавлена в объединенный учебный план.

Отредактировать основные характеристики записей учебного плана (число часов, кредитов, формы итогового контроля) можно непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице, предназначено действие Дополнительные свойства.

Редактирование записей объединенного плана

При необходимости вновь созданную дисципину для иностранных студентов можно связать с записью дисциплины, предлагаемой к реализации кафедрами, для этого:

  1. Из контекстного меню нужно вызвать действие Связать с предложением кафедры. При помощи параметров этой процедуры можно попытаться поискать подходящую дисциплину. Можно выполнить поиск не точно такой же, а "похожей" дисциплины. Для этого нужно очистить значение в поле Дисциплина для выбора и снова поискать дисциплину в поле Предложение кафедры. Можно также очистить поле Кафедра и поискать дисциплину на всех кафедрах. Если походящая дисциплина найдена, ее нужно выбрать и нажать кнопку ОК.
  2. Если же подходящей дисциплины так и не найдено, нужно заполнить кафедру в поле Кафедра и установить флажок Создать заявку на дисциплину (флажок доступен при условии, что кафедра задана, а поле "Предложение кафедры" пустое), после чего нажать кнопку ОК. В результате будет выполнен поиск плана-предложения кафедры с атрибутами Год начала реализации, Уровень образования, Реализуется по периодам, соответствующими атрибутам учебного плана; если такого плана-предложения найдено не будет, он будет создан для указанной кафедры. В найденный или созданный план-предложение будет добавлена дисциплина со всей информацией о нагрузке, раннее занесенной для нее в учебном плане; дисциплина в плане-предложении кафедры получит статус "заявка на дисциплину".

После связывания дисциплины плана с дисциплиной, предлагаемой кафедрой, разработчик объединенного учебного плана больше не сможет изменять параметры нагрузки по дисциплине, их сможет изменять только пользователь кафедры. Но при этом разработчику плана останутся доступными для редактирования следующие параметры:

  • Код записи ;
  • Вид дисциплины в плане ;
  • Признаки Только в кумулятивный рейтинг и Входит в расчет недельной нагрузки.
Пользователь кафедры может изменять все атрибуты нагрузки по своей дисциплине и ее распределение во времени в любой момент по своей инициативе, эти изменения сразу же отразятся на планах, в которые включена изменяемая дисциплина. Также пользователь кафедры может переводить свою дисциплину из одного статуса в другой:
  • "принять" или "отклонить" дисциплину, созданную разработчиком плана как "заявка на дисциплину", если пользователь кафедры отклонит заявку на дисциплину, то разработчик учебного плана должен связать свою дисциплину с какой-либо другой дисциплиной этой или другой кафедр;
  • "утвердить" дисциплину, что означает, что в нее более не будет вноситься изменений.

1.15.2.5. Перемещение записей

В случае если при добавлении Группы дисциплин или Дисциплины (НИС, Дисциплины иностранных студентов) был неверно указан раздел, куда они должны быть включены, то в отношении такой записи необходимо с помощью контекстного меню вызвать действие Перенести в другой раздел...

Перемещение записей плана в другой раздел

и в форме параметров указать раздел, куда требуется переместить запись, если поле Новый раздел оставить пустым, то Группа дисциплин (раздел) или Дисциплина (НИС, Дисциплины иностранных студентов) будет перемещена в корень объединенного плана общевузовских дисциплин.

Также для изменения порядка следования записей можно воспользоваться действиями контекстного меню Переместить вверх и Переместить вниз.

1.15.2.6. Изменение периода реализации дисциплин

Для изменения периода реализации дисциплины, необходимо:

  1. В представлении Объединенные планы общевузовских дисциплин (форма Учебные планы общевузовских дисциплин) выбрать учебный план, в который входит дисциплина.
  2. В представлении Все записи плана выбрать дисциплину, для которой необходимо изменить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

1.15.2.7. Связать с предложением кафедры

Для того чтобы связать запись учебного плана с действующим предложением кафедры или оставить заявку на реализацию дисциплины, необходимо:

  1. В форме редактирования выбрать запись учебного плана.
  2. Из контекстного меню вызвать действие Связать с предложением кафедры.
  3. В форме параметров необходимо:
    Форма параметров Связатьс предложением кафедры
    • Поле Источник финансирования заполнится автоматически для планов, которым соответствует один возможный источник финансирования. Для планов, которым подходит более одного варианта, поле Источник финансирования будет подсвечено зеленым и в нем необходимо из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
    • В поле Дисциплина для выбора указать дисциплину для выбора с помощью справочника Дисциплины ВУЗа (кнопка Справочник).
      Для выбора будут доступны записи планов-предложений кафедр, у которых совпадают источник финансирования, год начала и окончания реализации со значениями, установленными в полях Источник финансирования, Год начала реализации и Год окончания реализации. Кроме этого для записей из планов-предложений кафедр могут быть установлены ограничения на выбор и тогда они будут доступны с учетом, установленных ограничений (см. Установка ограничений на использование дисциплины).
      Если есть сомнения в правильности выбора дисциплины в поле Дисциплина для выбора, то его необходимо оставить пустым. В данном случае для выбора из плана предложения кафедры будут доступны все записи плана, которые соответствуют типу записи плана, уровню образования, типам периодов реализации (модуль/семестр), году начала и окончания реализации, а не только те, которые совпадают по наименованию с дисциплиной указанной в поле Дисциплина для выбора.
    • В поле Кафедра задать кафедру (тогда будут предложены дисциплины-предложения именно этой кафедры), либо очистить поле "Кафедра", после чего для выбора будут предложены дисциплины от всех кафедр.

    • В поле Предложение кафедрой с помощью кнопки Справочник открыть справочник Все записи плана-предложения кафедры и выполнить поиск подходящей дисциплины. Для просмотра подробной информации о дисциплине можно воспользоваться действием Посмотреть в плане.

      При отображении дисциплин всех кафедр можно искать нужную (или похожую) дисциплину при помощи фильтра по колонке "Дисциплина", в том числе использую символы "*", например, вбив в строку фильтра значение "*микроэкономика*" можно найти все предлагаемые кафедрами дисциплины, в названии которых встречается слово "микроэкономика".
    • Если подходящая дисциплина не найдена, то можно оставить заявку на реализацию дисциплины. Для этого нужно значение в поле Предложение кафедры оставить пустым, в поле Дисциплина для выбора указать дисциплину, на которую будет отправляться заявка, в поле Кафедра указать кафедру, в план предложение которой будет добавлена заявка на дисциплину, в поле Создать заявку на дисциплину установить значение "Да".
    • Нажать кнопку ОК.

1.15.2.8. Формирование информации о численности контингента

Формирование данных о численности контингента для объединенных планов общевузовских дисциплин выполняется аналогично формированию информации о численности контингента для объединенного учебного плана.

1.15.3. Передача планов в реализацию

Для того, чтобы дисциплины объединенного плана общевузовских дисциплин могли быть назначены студентам, необходимо для плана выполнить действие Передать в реализацию.

Процедура передачи плана на факультет

После чего в форме параметров нужно выбрать Год реализации плана, который будет передаваться на факультет, выбрать График учебного процесса и нажать кнопку ОК.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в таблице Дисциплины вне учебных планов. Эта таблица доступна в разделе Общевузовские ресурсы, в форме Учебные планы, формы и программы обучения на вкладке Дисциплины вне учебных планов.

Назначение общевузовских дисциплин студентам на участке Студент выполняется именно из таблицы данных Дисциплины вне учебных планов. Поэтому при завершении создания дисциплины или при внесении изменений в данные объединенного плана общевузовских дисциплин необходимо выполнять действие по передаче плана в реализацию.

1.15.4. Вывод планов на печать

Для того чтобы вывести на печать план необходимо:

  1. В представлении Объединенные планы общевузовских дисциплин (форма Учебные планы общевузовских дисциплин) выбрать план, который необходимо вывести на печать.
  2. Из контекстного меню выбрать одно из действий Выгрузить для печати, Выгрузить для печати как РУП, Выгрузить для печати на английском языке, Выгрузить для печати как рабочий на английском языке.
  3. В открывшемся файле необходимо проверить указанные данные и с помощью стандартного функционала MS Excel вывести план на печать.

1.16. Учебные планы лицея

Учебные планы представляют собой иерархическую структуру компонентов (разделов), школьных предметов и проектов школьников. Учебный план лицея разрабатывается сразу на все годы реализации образовательной программы, и содержит информацию о видах и количестве испытаний по школьным предметам, о распределении учебной нагрузки по периодам и т.д.

Создание нового учебного плана лицея включает следующие этапы работы:

  1. Создание записи об учебном плане лицея.
  2. Наполнение и редактирование учебного плана.
  3. Передача плана в реализацию.

1.16.1. Создание нового учебного плана лицея

Работа с учебными планами лицея ведется на участке "Разработка учебных планов" в форме "Учебные планы лицея".

Для добавления нового учебного плана лицея необходимо в представлении Учебные планы лицея с помощью контекстного меню вызвать действие Добавить план лицея.

Процедура Добавить план лицея

После чего необходимо заполнить форму параметров следующим образом:

Форма параметров Добавить план лицея

  • В поле Направление в лицее - указать направление обучения школьников.
  • В полях Образовательный программа - выбрать образовательную программу, для которой создается план.
  • В поле Класс начала обучения - указать класс, начиная с которого будет реализовываться план.
  • В поле Число лет обучения - указать количество лет реализации плана.
  • В полях Год начала обучения, Год окончания обучения указать года начала и окончания обучения, периоды, по которым будет планироваться нагрузка.
  • В поле Реализуется по периодам выбрать один из предлагаемых вариантов реализации.
  • В поле Количество периодов в году указать количество периодов в учебном году.
  • При необходимости можно указать Количество учащихся и Количество классов.

После того, как для всех полей формы добавления учебного плана лицея будут заданы допустимые значения, кнопка ОК на форме добавления станет доступной. После ее нажатия запись о новом учебном плане появится в представлении Учебные планы лицея. При попытке добавления второго учебного плана такого же направления, образовательной программы и года начала обучения произойдет ошибка дублирования объектов.

1.16.2. Редактирование учебного плана лицея

Для редактирования учебного плана лицея предназначена специализированная форма, которая открывается при вызове действия Открыть.

Форма редактирования учебного плана лицея

Редактирование учебного плана должно заключаться в добавлении разделов, школьных предметов и проектов школьников, распределении нагрузки по видам работы (лекции, семинары, практические и т.д.), по годам обучения (классам) и по периодам обучения в каждом году (модулям, семестрам), а также планировании рубежных контролей.

Для добавления раздела необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие раздел плана.

Для добавлении записи в определенный раздел необходимо выбрать заголовок этого раздела или одну из входящих в него записей и с помощью контекстного меню в группе процедур Добавить выбрать одно из действий: школьный предмет, проект школьников.

Форма редактирования группа процедур Добавить

После того как сформирован перечень записей учебного плана, нужно отредактировать основные характеристики данной записи учебного плана (число часов, формы контролей), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается школьниками или нет и т.д.), предназначено действие Дополнительные свойства.

Редактирование записей учебного плана лицея

1.16.2.1. Добавление раздела

Для создания раздела необходимо с помощью контекстного меню в группе процедур Добавить выбрать действие раздел плана,

Форма редактирования Добавить раздел в учебный план лицея

после чего заполнить следующую форму параметров:

Форма параметров добавить раздел учебный план лицея

  • В поле Раздел из справочника выбрать раздел для добавления.
  • В поле Наименование необходимо ввести название раздела.
  • В поле Код записи при необходимости можно указать код записи для добавляемого раздела.
  • В полях Общее число часов и Число недель можно указать общее количество часов и число недель по плану для данного раздела. При необходимости данные поля можно оставить пустыми и указать данные параметры непосредственно в форме редактирования.
  • В поле Рассчитывается как сумма элементов необходимо установить значение "Да", если показатели раздела определяться путем суммирования показателей входящих в них записей. Если показатели раздела плана должны устанавливаться независимо, то необходимо установить значение "Нет".
  • Для разделов показатели, которых устанавливаются независимо, при необходимости можно указать Минимальное и Максимальное число дисциплин для выбора, и Минимальное и Максимальное число кредитов для выбирамых дисциплин.

После нажатия кнопки ОК, раздел будет добавлен.

1.16.2.2. Добавление школьного предмета

При добавлении школьного предмета в форме редактирования учебного плана лицея необходимо из контекстного меню в группе процедур Добавить вызвать действие школьный предмет, после чего заполнить следующую форму параметров:

Форма параметров Добавить школьный предмет в учебный план лицея
  • В поле Школьный предмет с помощью списка Список или справочника Справочник нужно выбрать школьный предмет для добавления.
  • В поле Кафедра при необходимости можно указать кафедру, которая будет реализовать школьный предмет.
  • В поле Вид дисциплины необходимо выбрать вид добавляемой дисциплины.
  • В поле По выбору студентов нужно установить значение "Да" для школьных предметов, назначаемых школьникам в обязательном порядке, и значение "Нет" для школьных предметов, которые назначаются при выборе школьником.
  • В полях Аудиторных часов и Число недель необходимо указать соответствующие числовые характеристики добавляемого школьного предмета.

После заполнения формы параметров необходимо нажать кнопку ОК, после чего школьный предмет будет добавлен в учебный план.

После того как запись о школьном предмете будет добавлена в учебный план, нужно отредактировать основные характеристики данной записи учебного плана (число часов, недель, формы контролей), что можно выполнить непосредственно в таблице (после изменения числовых и строковых значений необходимо нажимать клавишу Enter). Для изменения дополнительных атрибутов записей плана, не видимых в таблице (вид дисциплины, выбирается школьниками или нет и т.д.), предназначено действие Дополнительные свойства.

1.16.2.3. Добавление проекта школьников

При добавлении проекта школьников в форме редактирования учебного плана лицея необходимо из контекстного меню в группе процедур Добавить вызвать действие проект школьников, после чего заполнить следующую форму параметров:

Форма параметров Добавить проект школьников в учебный план лицея
  • В поле Наименование необходимо ввести наименование проекта школьников.
  • В поле Кафедра при необходимости можно указать кафедру, которая будет реализовать проект школьников.
  • В полях Число недель, Аудиторных часов нужно указать соответствующие числовые характеристики добавляемого школьного проекта.
  • Значение для Аудиторных часов в неделю определяется автоматически.
  • Если нагрузка по проекту должна учитываться при расчете недельной нагрузки, то в поле Входит в расчет недельной нагрузки должно быть установлено значение "Да".
  • В поле По выбору студентов должно быть установлено значение "Да" для проектов школьников, назначаемых школьникам в обязательном порядке, и значение "Нет" для проектов школьников, которые назначаются при выборе школьником.

После заполнения формы параметров необходимо нажать кнопку ОК, после чего школьный предмет будет добавлен в учебный план.

1.16.3. Передача плана в реализацию

Для того чтобы записи учебного плана могли быть назначены школьникам, необходимо для плана выполнить действие Передать план в реализацию.

Вызов действия передать план в реализацию

После чего в форме параметров нужно указать учебный год (поле На учебный год), за который будет передаваться план в реализацию, указать Номер класса и нажать кнопку ОК.

При выполнении первым проректором процедуры Утвердить план, учебный план на указанный год будет передан на факультет. В отношении других годов реализации учебного плана необходимо по каждому из них выполнить процедуру Передать на факультет отдельно.

Результатом выполнения этих действий будет создание или уточнение атрибутов записей в представлении Учебные планы лицея. Данное представление доступно на участке Лицей университета, в форме Учебные планы лицея.

1.17. Особенности наполнения отдельных разделов БУП и РУП

Разделы БУП и РУП, наполненные дисциплинами, обязательными для изучения всеми студентами, не представляют большой сложности при заполнении. В них могут добавляться дисциплины, не присутствующие в стандарте или в БУП, при этом суммарные значения числа часов, числа недель, числа кредитов могут быть пересчитаны автоматически. Разделы, в состав которых входят дисциплины, необязательные для изучения всеми студентами, а также разделы, содержащие прочие виды нагрузки (курсовые работы, практики, итоговые экзамены, выпускные работы) требуют отдельного внимания.

Для того, чтобы отразить особенности различных разделов, дисциплин и других видов нагрузки, входящих в БУП или РУП, после автоматизированного формирования структуры плана для его записей необходимо уточнить ряд дополнительных свойств, таких как

  • Вид дисциплины, обязательность для изучения студентами
  • Учет в текущем, или только в кумулятивном рейтинге
  • Вхождение в расчет недельной аудиторной нагрузки студентов
  • Преподавание дисциплины на иностранном языке
  • Допустимость нескольких испытаний в одном периоде

Работа записями плана, не являющимися дисциплинами (курсовыми работами, практиками, итоговыми государственными экзаменами, выпускными квалификационными работами связана с рядом особенностей, которые изложены в следюущих ниже разделах.

1.17.1. Уточнение ряда свойств разделов и дисциплин БУП и РУП

В формах редактирования БУП и РУП работают проверки контрольных соотношений, при помощи которых контролируется корректность и целостность плана, соответствие характеристик записей плана требованиям образовательного стандарта, выполнение Методических указаний по разработке БУП и РУП. Также при помощи функционала формы редактирования можно выполнять автоматизированные пересчеты показателей плана, в частности, суммирование значений числа часов, недель, кредитов по разделам и группам дисциплин.

В образовательном стандарте не содержится достаточно информации для того, чтобы реализовать корректную работу некоторых автоматизированных проверок и пересчетов. По этой причине после формирования БУП на основе стандарта или РУП на основе БУП, необходимо выполнить уточнение следующих значений для некоторых разделов и дисциплин БУП или РУП:

  1. Признак Рассчитывается как сумма элементов для групп дисциплин и разделов.
  2. Свойство Количество выбираемых дисциплин для разделов и групп дисциплин по выбору.
  3. Признак Только в кумулятивный рейтинг для дисциплин, число кредитов по которым не должно участвовать в подсчете суммы по разделу и по плану в целом.
  4. Свойство Вид дисциплины и признак Выбирается студентами.
  5. Признак Входит в расчет недельной нагрузки.
  6. Свойство На иностранном языке.
  7. Свойство Допустимо несколько испытаний в периоде.
Уточнение данных свойств производится в форме редактирования БУП или РУП при помощи действия Дополнительные свойства.

Дополнительные свойства раздела плана:

Дополнительные свойства для раздела

Дополнительные свойства дисциплины плана:

Дополнительные свойства для дисциплины

1. Уточнение признака Рассчитывается как сумма элементов для групп дисциплин и разделов.

Все разделы и группы дисциплин можно разделить на два вида:

  • Разделы или группы, показатели которых должны определяться путем суммирования показателей входящих в них записей.
  • Разделы или группы, показатели которых могут устанавливаться независимо.
К первой группе относятся разделы и группы, все дисциплины которых обязательны для изучения всеми студентами. Ко второй группе относятся разделы и группы дисциплин по выбору, факультативов адаптационных дисциплин. Для того, чтобы отличить один вид разделов от другого используется признак Рассчитывается как сумма элементов. При формировании БУП на основе стандарта для всех разделов и групп дисциплин этот признак получает значение Да. При формировании РУП на основе БУП для разделов РУП устанавливается то же значение признака, которое было задано для данного раздела в БУП.

Если для признака установить значение Нет, то проверка соответствия суммы показателей для всех записей раздела со значением, установленным для раздела в целом, проводиться не будет и сообщения об ошибках не будут формироваться. В этом случая значения числа часов, недель, кредитов, числа экзаменов и зачетов (в РУП) для раздела нужно установить вручную таким образом, чтобы раздел, в свою очередь, внес необходимый вклад в план в целом. Например, если в раздел включено три дисциплины по выбору, трудоемкостью 108 часов каждая, а студенты должны выбрать только одну из них, для раздела вручную должно быть установлено число часов, равное 108.

Наименования разделов, для которых не используется контроль равенства суммы показателей раздела и суммы показателей входящих в него записей выделяется курсивным шрифтом. При проверке плана на такие разделы нужно обращать отдельное внимание.

Разделы, рассчитываемые и не рассчитываемые как сумма

2. Уточнение значения Количество выбираемых дисциплин

Для того, чтобы в дальнейшем на основании разработанных БУП и РУП можно было сформировать учебный план студента и проверить его полноту и корректность, необходимо задать для каждой группы или раздела дисциплин по выбору количество дисциплин, которые должны быть обязательно выбраны студентом.

Если при наполнении образовательного стандарта эти значения не заданы, то их необходимо задать в форме редактирования БУП или РУП при помощи действия Дополнительные свойства.

3. Уточнение признака Только в кумулятивный рейтинг

Ряд дисциплин, принадлежащих к разделу факультативов или к группам адаптационных дисциплин, могут не участвовать в подсчете суммы кредитов по группе, по разделу и по плану в целом. Кредиты по таким дисциплинам начисляются студентам только при расчете кумулятивного рейтинга, но не начисляются при расчете текущего рейтинга. Для того, чтобы было возможным рассчитать кумулятивный рейтинг студентов по таким дисциплинам, значения числа кредитов должны быть заданы, однако для того, чтобы корректно провести проверку суммарного числа кредитов БУП и РУП такие дисциплины необходимо выделить из перечня обычных дисциплин.

Уточнение данного признака производится в форме редактирования БУП и РУП при помощи действия Дополнительные свойства.

При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются одной звездочкой (*) в колонке "Зачетные единицы". В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.

4. Уточнение признаков Вид дисциплины и Выбирается студентами

Если при формировании стандарта или БУП для дисциплины были неверно заданы значения свойств Вид дисциплины и Выбирается студентами, то эти значения можно уточнить в формах редактирования БУП и РУП при помощи действия Дополнительные свойства. Эти свойства являются зависимыми, т.е. если для свойства Вид дисциплины установить значение Обязательная дисциплина или Обязательный факультатив, то для признака Выбирается студентами будет автоматически подставлено значение Нет. Если же для вида дисциплины выбрать значение Дисциплина по выбору или Факультатив, то признак автоматически получит значение Да. При исключении из этого правила, значение признака Выбирается студентами можно изменить вручную.

Корректная установка этих свойств важна для дальнейшего назначения учебных планов студентам и контроля полноты сформированных учебных планов студентов.

5. Уточнение признака Входит в расчет недельной нагрузки.

Данный признак используется для того, чтобы исключить некоторые дисциплины РУП из расчета недельной аудиторной нагрузки студентов. При формировании РУП на основе БУП для данного признака устанавливается значение Да. При редактировании РУП для факультативов, а также других дисциплин, аудиторная нагрузка по которым не должна входить в расчет недельной аудиторной нагрузки студентов, необходимо изменить значение этого признака на Нет.

Изменить значение данного признака можно в форме редактирования РУП при помощи действия Дополнительные свойства.

При выводе плана на печать дисциплины, для которых установлен данный признак, помечаются двумя звездочками (**) в колонке "Наименование дисциплины". По этой причине вносить знаки * в наименование дисциплины не нужно. В нижней части плана автоматически формируется сноска, расшифровывающая значение данного признака.

6. Выделение предметов, преподаваемых на иностранном языке.

Для того чтобы выделить дисциплины плана, преподаваемые на иностранном языке, при помощи действия Дополнительные свойства для них можно установить свойство На иностранном языке. При формировании БУП и РУП данное для данного свойства устанавливается пустое значение, что означает, что дисциплина преподается на русском языке. Для дисциплин, преподаваемых на иностранных языках, можно выбрать один из иностранных языков, преподаваемых в ВУЗе. Если в выпадающем списке нет нужного языка, необходимо обратиться к администратору системы с просьбой добавить язык в доступный перечень.

7. Наличие нескольких испытаний в одном периоде для дисциплины плана.

Как правило по всем дисциплинам плана в каждом из учебных периодов (модуле, семестре), предусматривается одно (или ни одного) испытание рубежного контроля. Если возникает исключительная ситуация, при которой необходимо запланировать более одного испытания в одном учебном периоде (например, экзамен и итоговый полевой сбор по военной подготовке), это можно сделать следующим образом:

  1. Выбрать дисциплину, вызвать действие Дополнительные свойства.
  2. Установить флажок к поле Допустимо несколько испытаний в периоде. В правой части строки в колонках, предназначенных для указания видов испытаний ("Экзамен", "Зачет") будут отображены два уровня по аналогии с записями разделов.
    Несколько испытаний в одном периоде
  3. Установить количество (в штуках) экзаменов и / или зачетов в строке дисциплины на соответствующем уровне (рядом со словом "Экз." или "Зач.").
  4. Проконтролировать правильность вычисления количества экзаменов и зачетов для раздела плана, в который входит данная дисциплина.

Если необходимость наличия нескольких испытаний в периоде отпала, или была установлена ошибочно, от нее можно отказаться, вызвав для дисциплины действие Дополнительные свойства и сняв флажок Допустимо несколько испытаний в периоде. Строка дисциплины снова будет отображаться обычным образом. В столбцах, отвечающих за виды испытаний по периодам, нужно выбрать значения "Экзамен" или "Зачет".

1.17.2. Организация разделов и групп дисциплин по выбору

Присутствующие в БУП или РУП дисциплины по выбору могут либо представлять собой единую группу, входящую в раздел "Дисциплины по выбору" одного из компонентов, либо формироваться в несколько групп, из каждой из которых студентами должно быть выбрано определенное количество дисциплин.

Если группы дисциплин были заданы в стандарте, то они будут созданы в БУП при его формировании по стандарту. При формировании РУП на основе БУП созданные в БУП группы будут перенесены в РУП. Группы дисциплин можно создавать и при редактировании БУП или РУП. После создания групп в них можно добавлять отдельные дисциплины. Также можно переносить существующие дисциплины в группы при помощи действия Перенести в другой раздел.

В отличие от обычных разделов и групп, для которых значения числа часов, недель и кредитов вычисляется как сумма значений, заданных для входящих в них дисциплин, для разделов и групп дисциплин по выбору эти значения должны задаваться самостоятельно. Для того, чтобы проверки и автоматические расчеты, работающие в формах редактирования БУП и РУП, работали корректно, а также с целью последующего контроля формирования индивидуальных учебных планов студентов, для разделов и групп дисциплин по выбору должны быть дополнительно уточнены значения ряда свойств. Уточнение выполняется при помощи действия Дополнительные свойства.

Дополнительные свойства для дисциплин по выбору
  • Для признака Рассчитывается как сумма элементов должно быть установлено значение Нет.
  • Если для раздела или группы определяется количество дисциплин, которые должны быть выбраны студентом, то это значение нужно занести в колонку Количество выбираемых дисциплин. Если количество дисциплин не задается, а накладывается ограничение только на число кредитов, то это значение нужно оставить пустым. Вы этом случае контролироваться будет не количество выбранных студентом дисциплин, а значение суммы кредитов по всем выбранным им дисциплинам.
  • Должны быть уточнены значения Трудоемкость в часах, Недели и Трудоемкость в зачетных единицах, объем аудиторной нагрузки по периодам, число форм текущего контроля (РУП). После того как для признака Рассчитывается как сумма элементов установлено значение Нет, значения числа часов, недель и кредитов, заданные для группы, не будут сравниваться с суммой значений для входящих в группу дисциплин и не будут автоматически пересчитываться.
Раздел дисциплин по выбору

Если все дисциплины раздела распределены по группам, для каждой из которых задано определенное значение числа часов, недель и кредитов, которые должны быть набраны студентом, то для раздела в целом значение признака Рассчитывается как сумма элементов должно быть установлено в Да, так как, действительно, для раздела должны быть просуммированы значения, заданные для каждой из групп.

Раздел дисциплин по выбору с группами

В данном примере для групп ДПВ1 (1 из 2) и ДПВ2 (1 из 6) значение признака Рассчитывается как сумма элементов установлено как Нет, а для записи раздела ОПД.В.00 Дисциплины по выбору установлено значение Да.

1.17.3. Работа с факультативами

Факультативы, также как и дисциплины по выбору должны быть выделены в БУП и в РУП в отдельный раздел или группу дисциплин. Для разделов или групп факультативов при помощи действия Дополнительные свойства признак Рассчитывается как сумма элементов должен быть установлен как Нет.

Дополнительные свойства для раздела факультативов

Для всех дисциплин, являющихся факультативами дополнительные свойства должны быть установлены следующим образом:

Дополнительные свойства для дисциплин факультативов

После того, как для факультативов установлен признак Только в кумулятивный рейтинг, число кредитов будет помечено знаком *. После установки значения Нет для признака Входит в расчет недельной нагрузки число аудиторных часов по факультативу в учебном периоде (модуле, семестре) не будет участвовать в расчете аудиторной нагрузки в периоде по разделу.

Если число часов, недель, кредитов, выделяемых на факультативы, не должно учитываться при расчете суммовых показателей плана, то для них в строке раздела или группы Факультативы можно задать нулевые или пустые значения.

1.17.4. Работа с адаптационными дисциплинами

Если в БУП или РУП включаются адаптационные дисциплины (т.е. дисциплины, изучаемые студентами, не имеющими на момент поступления достаточной подготовки по тем или иным предметам), то при работе с ними необходимо учитывать их особенности.

Адаптационной дисциплиной может быть как дополнительная дисциплина, не изучаемая основной массой студентов, так и дополнительная нагрузка по одной из существующих в БУП или РУП дисциплин (например, дополнительные часы по иностранному языку, экономической теории или математике). В любом случае адаптационная дисциплина должна добавляться в БУП и РУП как отдельная запись. При добавлении такой дисциплины в поле Вид дисциплины должно быть выбрано значение Адаптационный курс, в поле По выбору студентов должно быть установлено значение Да. Скорректировать значения данных свойств для адаптационных дисциплин можно в формах редактирования РУП и БУП при помощи действия Дополнительные свойства.

Дополнительные свойства для адаптационных дисциплин

Так как адаптационные дисциплины не являются обязательными для всех студентов, на них либо не выделяются кредиты, либо эти кредиты не участвуют в расчете текущего рейтинга. Поэтому для адаптационных дисциплин необходимо либо установить число кредитов, равное нулю, либо установить значение Да в колонке Только в кумулятивный рейтинг.

Нагрузка по адаптационным дисциплинам не должна учитываться при подсчете суммы часов, недель и кредитов и других показателей по разделу, в который они входят. Для того, чтобы расчет сумм по разделу был произведен корректно, рекомендуется выделить адаптационные дисциплины в отдельную группу дисциплин. Для этой группы для признака Рассчитывается как сумма элементов должно быть установлено значение Нет, а для свойств Трудоемкость в часах, Недели и Трудоемкость в зачетных единицах и других должны быть установлены пустые или нулевые значения. Такая установка свойств позволит корректно рассчитать суммы по разделу, в который входит группа адаптационных дисциплин.

Раздел адаптационных дисциплин

1.17.5. Курсовые работы

Курсовые работы могут присутствовать в различных разделах БУП и РУП. Если курсовые работы были занесены в стандарт, то они будут созданы и в БУП после его формирования на основе стандарта. При формировании РУП на основе БУП в нем будут созданы курсовые работы в случае если в БУП по курсовой работе были заданы часы или кредиты на данном курсе. Также курсовые работы можно создавать и непосредственно в БУП и РУП, используя действие Добавить ... / курсовую работу.

Если курсовая работа выполняется по одной дисциплине всеми студентами, то эту дисциплину необходимо выбрать в поле Дисциплина при добавлении курсовой работы. Если же курсовая работа является междисциплинарной, или если студенты могут выбирать дисциплину, по которой они будут выполнять работу, то поле Дисциплина надо оставить пустым. Заполнение поля Кафедра в РУП для курсовой работы необязательно. Оно должно заполняться только в том случае, если известно, что все студенты должны выполнить данную курсовую работу на данной кафедре.

Если создается курсовая работа по дисциплине, то ее Наименование будет сформировано автоматически. Если дисциплина не используется, то наименование курсовой работе может быть присвоено произвольно.

Значение числа кредитов для курсовых работ устанавливается независимо от значений числа часов и числа недель.

Раздел с курсовой работой

Если в БУП или РУП присутствует курсовая работа, то о ней должна быть обязательно создана запись типа Курсовая работа, даже если в плане существует одноименный раздел. Уточнить свойства записи о курсовой работе можно при помощи действия Дополнительные свойства

Дополнительные свойства для курсовой работы

Изменять тип записи при помощи этого действия нельзя. Если Вы ошиблись с типом записи, то нужно удалить существующую запись о курсовой работе и создать новую при помощи действия Добавить ... / курсовую работу.

В РУП для курсовой работы, так же как и для любой другой записи плана должно быть указано испытание рубежного контроля. Для того, чтобы в дипломе студентов по курсовой работе отображались оценки "отлично", "хорошо" и проч. видом рубежного контроля для курсовой работы должен быть "Экзамен". В противном случае в дипломе студента будут отображены результаты "зачтено" или "незачтено". Испытание должно быть запланировано в том модуле (семестре), в котором студенты должны сдать и защитить курсовую работу.

При расчете числа зачетов и экзаменов по модулям, отображаемого в печатной форме РУП, испытания по курсовым работам не учитываются.

1.17.6. Работа с практиками

Как в образовательном стандарте, так и в БУП и в РУП практики должны быть выделены в отдельный раздел (разделы). Если в стандарте значения трудоемкости задавались для раздела практик в целом, то в БУП и РУП обязательно нужно добавить записи о конкретных практиках того или иного вида. Добавление практики в БУП или РУП производится при помощи действия Добавить ... / практику.

При добавлении практики нужно обязательно задать Вид практики путем выбора из выпадающего списка. При выборе вида практики для нее будет автоматически предложено Наименование. Если в план необходимо добавить несколько практик одного вида, то наименование надо скорректировать таким образом, чтобы эти практики можно было отличить, например, "производственная практика 2 курс", "производственная практика 3 курс".

При помощи действия Дополнительные свойства можно уточнить параметры созданной записи о практике

Дополнительные свойства практик

При помощи данной формы можно уточнить вид практики. Тип записи обязательно должен быть установлен как Практика. Если тип записи установлен неверно, его нельзя изменить при помощи этой формы. В этом случае нужно удалить запись ошибочного типа и добавить новую при помощи действия Добавить ... / практику.

В БУП и РУП магистратуры наименования разделов могут включать в себя (и даже полностью повторять) наименование видов практики, например, "НИР.М.02 Научно-педагогическая практика" или "НИР.М.03 Научно-исследовательская практика". Несмотря на это, в такие разделы необходимо добавить записи о практиках соответствующего вида.

Значения числа недель и числа кредитов для практик устанавливаются независимо от числа часов.

1.17.7. Работа с разделом итоговой государственной аттестации

Итоговая государственная аттестация в образовательных стандартах выделяется в отдельный раздел. В состав итоговой аттестации могут входить итоговые экзамены и выпускная квалификационная работа (ВКР). Если записи о конкретных итоговых экзаменах и ВКР были созданы в стандарте, то они будут созданы и в БУП при его формировании по стандарту. Также записи об отдельных видах итоговой аттестации, созданные в БУП будут перенесены в РУП при его формировании на основе БУП. Если же в стандарте или БУП записи о конкретных испытаниях итоговой аттестации созданы не были, то их необходимо добавить в раздел итоговой аттестации при помощи действий Добавить ... / итоговый гоэкзамен и Добавить ... / выпускную работу.

Итоговый госэкзамен может быть как по одной конкретной дисциплине, так и междисциплинарным. Если итоговый госэкзамен проводится по дисциплине, то эту дисциплину необходимо выбрать в поле Дисциплина. При этом в поле Наименование автоматически сформируется значение, повторяющее наименование дисциплины. Если же экзамен является междисциплинарным, то поле Дисциплина нужно оставить пустым, в наименование ввести с клавиатуры (например, "Междисциплинарный экзамен по направлению подготовки").

Для свойства Форма итогового контроля должно быть установлено значение Экзамен.

Значение числа кредитов для итогового госэкзамена устанавливаются независимо от значений числа часов и числа недель.

При добавлении выпускной квалификационной работы (ВКР) ее наименование можно задать произвольно (например, "Подготовка и защита выпускной квалификационной работы"). Для свойства Форма итогового контроля должно быть установлено значение Экзамен.

Значение числа недель и числа кредитов для ВКР устанавливаются независимо от значений числа часов и числа недель.

Раздел итоговой аттестации

1.18. Расчетные показатели учебных планов

В ходе работы над базовыми и рабочими учебными планами необходимо помнить о том, что в итоговом варианте документа должны быть соблюдены требования к ряду расчетных показателей, характеризующих план в целом. Ниже описаны принципы расчета применяемых показателей и пути достижения необходимых значений.

1.18.1. Суммы показателей по разделам и по плану в целом

Образовательный стандарт представляет собой иерархическую структуру разделов (компонентов, циклов) и входящих в них дисциплин. Стандарт должен быть сформирован таким образом, чтобы на первом уровне иерархии была единственная запись. Как правило, эта запись имеет наименование Вся образовательная программа. Аналогичную структуру имеют БУПы и РУПы, сформированные на основе стандартов.

Формы редактирования БУП и РУП содержат проверки, контролирующие равенство сумм показателей (числа часов, недель, кредитов и проч.) записей, входящих в раздел, и значений тех же показателей, заданных для раздела. В суммировании участвуют только записи, непосредственно подчиненные данному разделу. Это означает, что если в раздел входит несколько других разделов, в состав которых, в свою очередь, входят дисциплины и записи других видов, то в суммировании будут участвовать только значения заданные для разделов в целом, а значения записей более низких уровней анализироваться не будут.

Для некоторых разделов (разделов дисциплин по выбору, факультативов, а иногда и других) итоговые значения не должны рассчитываться как сумма входящих в раздел дисциплин, т.к. не все указанные дисциплины должны в обязательном порядке изучаться студентами. Для того, чтобы отличить один вид разделов от другого, предназначено свойство раздела Рассчитывается как сумма элементов. Для просмотра и изменения значения этого свойства предназначено действие Дополнительные свойства, которым можно воспользоваться в формах редактирования БУП и РУП, предварительно выбрав строку нужного раздела.

Если для раздела установлено значение признака таким образом, что показатели входящих в него записей не суммируются, то проверок соответствия сумм проводиться не будет. При этом важно задать для раздела в целом такие значения, которые дадут необходимую сумму для вышестоящих разделов и для плана в целом. Например, для разделов или групп дисциплин по выбору надо задать такие значения нагрузки, которые обязательно должны быть выполнены студентами. Для разделов факультативов и адаптационных дисциплин допустимо устанавливать итоговые значения по разделу нулевыми или пустыми.

Суммирование показателей по разделам

В данном примере для раздела Дисциплины по выбору признак Рассчитывается как сумма элементов установлен как Нет (наименование раздела отображается курсивным шрифтом). Для всех остальных разделов установлено значение Да. При этом для раздела дисциплин по выбору установлены самостоятельные значения числа часов, недель и кредитов. Для раздела Общие гуманитарные и социально-экономические дисциплины значения рассчитываются как сумма по трем разделам, непосредственно входящим в него: 2160 = 1836 + 108 + 216.

Такой принцип суммирования и контроля значений для разделов действует как для базовых, так и для рабочих учебных планов.

1.18.2. Аудиторная нагрузка по периодам (РУП)

В рабочих учебных планах рассчитываются показатели аудиторной нагрузки по периодам. При этом в разделе возможно наличие дисциплин, аудиторная нагрузка по которым не входит в расчет недельной аудиторной нагрузки. Такими дисциплинами могут быть факультативы, физическая культура и некоторые другие дисциплины. Для таких дисциплин при помощи действия Дополнительные свойства необходимо установить признак Входит в расчет недельной нагрузки, равным Нет.

При суммировании значений аудиторной нагрузки в периоде по разделу в суммировании участвуют только те записи, нагрузка по которым входит в расчет недельной нагрузки. При этом допустимой считается ситуация, когда в строке раздела сумма аудиторных часов по всем периодам не будет равна значению, установленному в колонке "Аудиторные занятия".

Аудиторная нагрузка по периодам

В данном примере аудиторная нагрузка по дисциплине Физическая культура не входит в расчет недельной аудиторной нагрузки.

1.18.3. Число экзаменов и зачетов по периодам (РУП)

В рабочих учебных планах для записей разделов определяется число экзаменов и зачетов в каждом периоде обучения. Если показатели раздела рассчитываются как сумма по входящим в раздел элементам, то число экзаменов и зачетов по разделу будет контролироваться проверками системы. Если же показатели раздела не подлежат суммированию, то количество экзаменов и зачетов по разделу нужно установить вручную.

Испытания по курсовым работам не учитываются при подсчете числа зачетов и экзаменов в периоде.

Проверить и при необходимости изменить признак Рассчитывается как сумма элементов для раздела можно при помощи действия Дополнительные свойства.

Количество экзаменов и зачетов, получившееся в корневой строке "Вся образовательная программа будет считаться показателем плана в целом.

Аудиторная нагрузка по периодам

В данном примере видно, что в разделе "Другие виды подготовки" первом и третьем модулях нет ни экзаменов, ни зачетов, во втором модуле - 2 зачета, в четвертом модуле 1 экзамен и 2 зачета.

1.18.4. Недельная аудиторная нагрузка, число аудиторных часов в день (РУП)

Недельная аудиторная нагрузка в каждом учебном периоде (модуле, семестре) в рабочем учебном плане определяется как число аудиторных часов в периоде, рассчитанное для корневой записи плана, деленное на число недель в периоде.

Количество недель в периоде отображается в отдельной строке внизу плана после перечня всех его записей. При формировании РУП число недель в каждом периоде устанавливается равным значению, заданному для периода в общевузовском справочнике . Однако в каждом РУП при необходимости это значение можно изменить.

Ниже строки с количеством недель в периоде следует строка Недельная аудиторная нагрузка. Значение в этой строке является расчетным и не подлежит редактированию. Оно рассчитывается как число аудиторных часов в периоде, стоящее в корневой строке плана ("Вся образовательная программа"), деленное на число недель, стоящее в предыдущей строке.

Если полученное значение недельной аудиторной нагрузки не отвечает установленным требованиям, то его можно скорректировать изменив число аудиторных часов по отдельным дисциплинам плана или изменив его распределение по периодам обучения. Эти изменения приведут в свою очередь к изменениям значений для разделов плана и для корневого раздела "Вся образовательная программа".

Недельная аудиторная нагрузка

Показатель Число аудиторных часов в день определяется как рассчитанное значение недельной аудиторной нагрузки, деленное на 6 дней. Левее колонок, показывающих средние значения показателей по периодам расположена колонка, отображающая средние значения, рассчитанные для всех периодов.

1.19. Ход согласования учебных планов

Базовые, рабочие и объединенные учебные планы могут участвовать в процедурах согласования и утверждения. Переход плана с одного этапа согласования на другой заключается в смене статуса плана, а также в изменении режима доступа пользователей к данным плана.

Процессы согласования объединенных и базовых (рабочих) учебных планов отличаются, графически их можно представить следующим образом:

  1. Процесс согласования базовых и рабочих учебных планов:

    Ход согласования учебных планов

  2. Процесс согласования объединенных учебных планов:

    Согласование объединенного учебного плана

  3. Процесс согласования объединенных учебных планов аспирантуры:

    Схема согласования ОУП аспирантуры

1.19.1. Мониторинг готовности учебных планов факультетов и отделений

В форме Ход согласования учебных планов в таблицах данных Базовые учебные планы и Рабочие учебные планы представлены планы, доступные для просмотра пользователю. Пользователи-разработчики планов от отдельного факультета или отделения могут просматривать только планы своего факультета (отделения). Пользователи, принадлежащие к ролям методического управления, проректора и первого проректора могут просматривать планы всех факультетов и отделений.

За счет возможностей таблиц данных можно просматривать статусы планов по факультетам и отделениям, направлениям и специальностям, магистерским программам, учебным годам, курсам и т.д.

Мониторинг состояния БУП

1.19.2. Работа Ректора

Работа ректора, утверждающего учебные планы, состоит в следующем:

Согласование планов
Для согласования доступны планы, переведенные первым проректором в статус на утверждении ректором. С планами, находящимися в этом статусе, первый проректор может выполнять следующие действия:

  • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
  • Если по итогам работы с планом ректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в МУ.
  • Если у ректора нет критических замечаний к плану, он должен выполнить действие Утвердить.
  • Отслеживание статусов планов
    Первому проректору доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

1.19.3. Работа пользователя-разработчика плана

Работа пользователя, разрабатывающего учебный план, состоит из следующих этапов:

  1. Создание проекта плана
    При создании базового, рабочего учебного плана или объединенного учебного плана, план получает статус проект. В процессе создания базового учебного плана для факультетов филиалов, требуется указать "ведущий" факультет ВУЗа, с которым необходимо согласовать план, что описано в разделе Создание нового базового учебного плана. После создания, план наполняется на основании источника (стандарта или базового плана) и дополняется всей необходимой информацией, что описано в разделах Редактирование базового учебного плана, Редактирование рабочего учебного плана, Редактирование объединенного учебного плана. После того, как разработчик завершил первичное формирование плана, он должен выполнить действие Направить на согласование с деканом факультета.
  2. Согласование с деканом факультета
    На данном этапе разработчик плана не может корректировать план, но может просматривать замечания, сформулированные деканом факультета. Если декан факультета примет решение о возврате плана на доработку, то план перейдет в статус корректировка разработчиком и разработчик снова сможет корректировать план. Если же декан факультета примет решение о согласовании плана и направлении его на дальнейшее согласование, то от разработчика дальнейших действий не потребуется, они сможет только следить за дальнейшим изменением статусов плана.
  3. Корректировка разработчиком
    На этом этапе разработчик может вносить в план любые изменения на основе замечаний, полученных от декана факултета. По завершении работы разработчик снова должен выполнить действие Направить на согласование с деканом факультета.
  4. Отслеживание статуса плана
    После того, как план согласован с деканом факультета, активная работа разработчика заканчивается. План будет переводиться из одного статуса в другой другими пользователями. Разработчик сможет получать сообщения об изменении статуса планов, а также просматривать состояние статусов всех планов в таблице данных Базовые учебные планы или Рабочие учебные планы.

1.19.4. Работа разработчика ОУП аспирантуры

Работа пользователя, разрабатывающего ОУП аспирантуры, состоит из следующих этапов:

  1. Создание проекта плана
    При создании объединенного учебного плана, план получает статус проект. После создания, план наполняется на основании источника (стандарта) и дополняется всей необходимой информацией, что описано в разделе Редактирование объединенного учебного плана аспирантуры. После того, как разработчик завершил первичное формирование плана, он должен выполнить действие Направить на согласование с Директором аспирантской школы.
  2. Согласование с Директором аспирантской школы
    На данном этапе разработчик плана не может корректировать план, но может просматривать замечания, сформулированные директором аспирантской школы. Если директор аспирантской школы примет решение о возврате плана на доработку, то план перейдет в статус корректировка разработчиком и разработчик снова сможет корректировать план. Если же директор аспирантской школы примет решение о согласовании плана и направлении его на дальнейшее согласование, то от разработчика дальнейших действий не потребуется, они сможет только следить за дальнейшим изменением статусов плана.
  3. Корректировка разработчиком
    На этом этапе разработчик может вносить в план любые изменения на основе замечаний, полученных от директора аспирантской школы. По завершении работы разработчик снова должен выполнить действие Направить на согласованиес Директором аспирантской школы.
  4. Отслеживание статуса плана
    После того, как план согласован с директором аспирантской школы, план будет переводиться из одного статуса в другой другими пользователями, при этом на любом из этапов план может быть передан разработчику на корректировку. Разработчик сможет получать сообщения об изменении статуса планов, а также просматривать состояние статусов всех планов в представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры).

1.19.5. Работа разработчика учебного плана лицея

Работа пользователя, разрабатывающего учебные планы лицея, состоит из следующих этапов:

  1. Создание проекта плана
    При создании плана, план получает статус проект. После того, как разработчик завершил первичное формирование плана, он должен выполнить действие Направить на согласование с УРОП.
  2. Согласование с пользователями методического управления
    На данном этапе разработчик плана не может корректировать план, но может просматривать замечания, сформулированные пользователями методического управления. Если методическое управление примет решение о возврате плана на доработку, то план перейдет в статус корректировка разработчиком и разработчик снова сможет корректировать план. Если же методическое управление примет решение о согласовании плана и направлении его на дальнейшее согласование, то от разработчика дальнейших действий не потребуется, он сможет только следить за дальнейшим изменением статусов плана.
  3. Корректировка разработчиком
    На этом этапе разработчик может вносить в план любые изменения на основе замечаний, полученных от пользователей, согласующих план. По завершении работы разработчик снова должен выполнить действие Направить на согласованиес УРОП.
  4. Отслеживание статуса плана
    После того, как план согласован с УРОП, план будет переводиться из одного статуса в другой другими пользователями. Разработчик сможет получать сообщения об изменении статуса планов, а также просматривать состояние статусов всех планов в представлении Учебные планы лицея (форма Учебные планы лицея).

1.19.6. Работа декана факультета

Работа декана факультета, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные разработчиками в статус согласование с деканом факультета. С планами, находящимися в этом статусе декан факультета может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом деканом факультета принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени декана факультета. При этом, при появлении необходимости редактирования плана после этого, декан факультета может воспользоваться действием Отозвать согласование деканом факультета, после чего он сможет осуществлять редактирование плана.
    • После того, как декан факультета согласовал план, он должен выполнить действие Направить на утверждение. При этом, если декан факультета является деканом факультета филиала и требуется согласование с "ведущим" факульетом, он пользуется действием Направить на согласование с ведущим факультетом . Если же, он является деканом "ведущего" факультета ВУЗа, то он должен воспользоваться действием Направить на согласование с МУ (Методическим управлением). В отношении учебных планов, для которых установлен признак Является программой ДПО, необходимо воспользоваться действием Направить на согласование с МУ.
      Следует учитывать, что параметру Является программой ДПО будет присвоено значение Да только для БУП, разработанных пользователями-разработчиками подразделений ДПО. Для всех остальных подразделений будет установлено значение Нет.
  2. Отслеживание статусов планов
    Декану факультета доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

1.19.7. Работа декана "ведущего" факультета

Работа декана ведущего факультета, согласующего учебные планы, состоит в следующем:

Согласование планов
Для согласования доступны планы, переведенные деканами факультетов филиалов в статус согласование с ведущим факультетом. Также доступны планы собственного факультета, переведенными разработчиками в статус согласование с деканом факультета. С планами, находящимися в этих статусах декан ведущего факультета может выполнять следующие действия:

  • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
  • Если по итогам работы с планом деканом ведущего факультета принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику или вернуть на доработку (деканам факультетов филиала).
  • Если у декана ведущего факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от ведущего факультета. При этом, при появлении необходимости редактирования плана после этого, декан факультета может воспользоваться действием Отозвать согласование ведущим факультетом, после чего он сможет осуществлять редактирование плана.
  • После того, как декан ведущего факультета согласовал план факультета филиала, он должен выполнить действие Направить на согласование с зам. директора филиала. После согласования плана собственного факультета, он направляется на согласование с МУ. При этом, декан факультета пользуется действием Направить на согласование с МУ (Методическим Управлением).
  • Отслеживание статусов планов
    Декану ведущего факультета доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

1.19.8. Работа директора аспирантской школы

Работа директора аспирантской школы, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные разработчиками в статус на согласовании с Директором аспирантской школы. С планами, находящимися в этом статусе директор аспирантской школы может выполнять следующие действия (все действия с учебными планами выполняются в форме На согласовании с Директором аспирантской школы):
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом директором аспирантской школы принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у директора аспирантской школы нет критических замечаний к плану, он должен выполнить действие Согласовать план. При этом, при появлении необходимости редактирования плана, директор аспирантской школы может воспользоваться действием Отозвать согласование, после чего он сможет осуществлять редактирование плана.
    • После того, как директор аспирантской школы согласовал план, он должен выполнить действие Направить на согласование УАД.

1.19.9. Работа управления аспирантуры и докторантуры

Работа пользователей, состоит из следующих этапов:

  1. Отслеживание статусов планов
    Пользователям Управления аспирантуры и докторантуры доступны для просмотра объединенные учебные планы аспирантуры всех аспирантских школ, находящиеся во всех статусах. В представлении Объединенные учебные планы аспирантуры (форма Объединенные учебные планы аспирантуры) пользователи УАД могут видеть картину готовности планов по аспирантским школам, учебным годам и проч.
  2. Согласование планов
    С планами, находящимся в статусе Направить на согласование с УАД пользователи УАД могут выполнять следующие операции:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом пользователем УАД принято решение вернуть план разработчику, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у пользователя УАД нет критических замечаний к плану, он должен выполнить действие Согласовать план.
    • После того, как пользователь УАД согласовал план, он должен выполнить действие Направить на согласование с зам. директора филиала для планов аспирантов филиала, и Направить на утверждение проректором для всех остальных планов аспирантуры.

1.19.10. Работа Заместителя директора филиала

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

1.19.10.1. Согласование БУП и РУП

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у декана факультета нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

1.19.10.2. Согласование ОУП аспирантуры

Работа заместителя директора филиала, согласующего объединенные учебные планы аспирантуры, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы в представлении Объединенные учебные планы аспирантуры, в данном представлении отображаются планы, переведенные директорами аспирантских школ в статус на согласовании с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у зам.директора филиала нет критических замечаний к плану, он должен выполнить действие Согласовать план. При этом, при появлении необходимости редактирования плана, заместитель директора филиала может воспользоваться действием Отозвать согласование, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на утверждение проректором.

1.19.10.3. Согласование ОУП

Работа заместителя директора филиала, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные деканами ведущих факультетов в статус согласование с зам. директора филиала. С планами, находящимися в этом статусе заместитель директора филиала может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом заместителем директора филиала принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку.
    • Если у зам.директора филиала нет критических замечаний к плану, он должен выполнить действие Согласовать от имени зам. директора филиала. При этом, при появлении необходимости редактирования плана после этого, заместитель директора филиала может воспользоваться действием Отозвать согласование зам. директора филиала, после чего он сможет осуществлять редактирование плана.
    • После того, как заместитель директора филиала согласовал план, он должен выполнить действие Направить на согласование с МУ.
    • Отслеживание статусов планов
      Заместителю директора филиала доступны для просмотра учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Объединенные учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

1.19.11. Работа пользователей методического управления

Работа пользователей Методического управления, состоит из следующих этапов:

  1. Отслеживание статусов планов
    Пользователям Методического управления доступны для просмотра объединенные, базовые и рабочие учебные планы и майноры, объединенные планы факультетских дисциплин, базовые и рабочие планы аспирантуры, учебные планы лицея, находящиеся во всех статусах. В соответствующих представлениях формы На согласовании с УРОП пользователи УРОП могут видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.
  2. Согласование планов от имени УРОП
    С планами, находящимися в статусе на согласовании с УРОП пользователи Методического управления могут выполнять следующие операции:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания, как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом пользователем МУ принято решение вернуть план разработчику, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у пользователя МУ нет критических замечаний к плану, он должен выполнить действие Согласовать от имени УРОП.
    • После того, как пользователь УРОП согласовал план, он должен выполнить действие Направить на согласование с Директором по ДПО для планов ДПО, и Направить на согласование с проректором для всех остальных планов.
  3. Согласование с проректором и Директором по ДПО
    На данном этапе пользователь УРОП не может вносить замечания в план. Он может только просматривать замечания и комментарии, сделанные проректором и директором по ДПО. Если проректором будет принято решение вернуть план на доработку в УРОП, то план перейдет в статус на согласовании с УРОП, и пользователи УРОП снова смогут работать с планом.
  4. Утверждение плана
    На данном этапе пользователь УРОП не может вносить замечания в план. Он может только просматривать замечания и комментарии, сделанные проректором или Директором по ДПО. Если проректором или Директором по ДПО будет принято решение вернуть план на доработку в УРОП, то план перейдет в статус на согласовании с УРОП, и пользователи УРОП снова смогут работать с планом. Если план будет утвержден, то для всех пользователей он будет доступен только для просмотра.

1.19.12. Работа Директора по ДПО

Работа Директора по ДПО, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные пользователями МУ в статус согласование с Директором по ДПО. С планами, находящимися в этом статусе Директор по ДПО может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом Директором по ДПО принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в МУ.
    • Если у Директора по ДПО нет критических замечаний к плану, он должен выполнить действие Согласовать от имени Директора по ДПО. При этом, при появлении необходимости редактирования плана после этого, Директор по ДПО филиала может воспользоваться действием Отозвать согласование Директора по ДПО, после чего он сможет осуществлять редактирование плана.
    • После того, как Директор по ДПО согласовал план, он должен выполнить действие Направить на согласование с проректором.
  2. Отслеживание статусов планов
    Директору по ДПО доступны для просмотра базовые и рабочие учебные планы всех факультетов и отделений, находящиеся во всех статусах. В таблицах данных Базовые учебные планы или Рабочие учебные планы можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

1.19.13. Работа проректора, согласующего планы

Работа проректора, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные пользователями УРОП, а также директором по ДПО в статус согласование с проректором. С планами, находящимися в этом статусе проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания, как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в УРОП.
    • Если у проректора нет критических замечаний к плану, он должен выполнить действие Согласовать от имени проректора. При появлении необходимости редактирования плана после этого, проректор может воспользоваться действием Отозвать согласование проектором, после чего он сможет осуществлять редактирование плана.
    • После того, как проректор согласовал план, он должен выполнить действие Направить на согласование с первым проректором для базовых учебных планов студентов и аспирантов и Направить на утверждение для остальных планов.
  2. Отслеживание статусов планов
    Проректору доступны для просмотра объединенные, базовые, рабочие учебные планы и майноры студентов, объединенные планы факультетских дисциплин, базовые и учебные планы аспирантуры, учебные планы лицея, находящиеся во всех статусах. В соответствующих представлениях формы На согласовании / утверждении проректором можно видеть картину готовности планов по факультетам (отделениям), курсам, учебным годам и проч.

1.19.14. Работа проректора, утверждающего ОУП аспирантуры

Работа проректора, утверждающего объединенные учебные планы аспирантуры, состоит в следующем:

  1. Утверждение планов
    Для утверждения доступны планы, переведенные пользователями УАД или заместителем директора филиала в статус на утверждении с проректором. С планами, находящимися в этом статусе проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку разработчику.
    • Если у проректора нет критических замечаний к плану, он должен выполнить действие Утвердить план. При этом, при появлении необходимости редактирования плана, проректор может воспользоваться действием Отозвать утверждение, после чего он сможет осуществлять редактирование плана.
  2. Отслеживание статусов планов
    Проректору доступны для просмотра ОУП аспирантуры всех аспирантских школ, находящиеся во всех статусах. В представлении Объединенные учебные планы аспирантуры можно видеть картину готовности планов по аспирантским школам, учебным годам и проч.

1.19.15. Работа первого проректора согласующего / утверждающего планы

Работа первого проректора, согласующего учебные планы, состоит в следующем:

  1. Согласование планов
    Для согласования доступны планы, переведенные проректором в статус на согласовании с первым проректором. С планами, находящимися в этом статусе, первый проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания, как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом первым проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в УРОП.
    • Если у первого проректора нет критических замечаний к плану, он должен выполнить действие Согласовать. При появлении необходимости редактирования плана после этого, первый проректор может воспользоваться действием Отозвать согласование первым проректором, после чего он сможет осуществлять редактирование плана.
    • После того, как первый проректор согласовал план, он должен выполнить действие Направить на утверждение ректором.
    • В отношении Объединенных учебных планов, Объединенных планов факультетских дисциплин и Объединенных майноров, при отсутствии критических замечаний, первый проректор должен выполнить действие Утвердить план.
  2. Утверждение планов
    Для утверждения доступны планы, переведенные проректором в статус на утверждении первым проректором. С планами, находящимися в этом статусе, первый проректор может выполнять следующие действия:
    • При помощи формы редактирования плана, доступной по действию Открыть, просматривать учебный план. Форма позволяет создавать комментарии и критические замечания как к отдельным записям плана, так и к плану в целом.
    • Если по итогам работы с планом первым проректором принято решение вернуть план на доработку, то для плана нужно выполнить действие Вернуть на доработку в УРОП.
    • Если у первого проректора нет критических замечаний к плану, он должен выполнить действие Утвердить план.

1.20. Оценка затратности реализации учебных планов

Оценкa зaтрaтности рeaлизaции учeбных плaнов зaключaeтся в оцeнке отношения количества студентов, которые будут обучаться по данному учебному плану к объeму нaгрузки прeподaвaтeлeй, трeбуeмому для рeaлизaции этого учeбного плана, выраженному в числе условных ставок преподавателей. Данное отношение называется Коэффициентом затратности плана. Чем коэффициент затратности выше, тем ниже затратность плана, и чем коэффиент ниже, тем выше затратность.

Оцeнкa зaтрaтности рeaлизaции плaнов рeaлиовaнa в систeмe в двух вaриaнтaх: для Paбочих учeбных плaнов и для Объeдинeнных учeбных плaнов. Для Объeдинeнных учeбных плaнов оцeнкa зaтрaтности производится отдльно для кaждого учeбного годa рeaлизaции. Принцип оцeнки зaтрaтности одинaков для рaзных видов плaнов и зaключaeтся в слeдующeм:

  1. Для кaждой дисциплины и НИС выполняeтся оцeнкa количeствa чaсов нaгрузки для рeaлизaции отдeльных видов нaгрузки (лeкций, сeминaров, прaктичeских, провeдeния экзaмeнов и зaчeтов, провeрки испытaний тeкущeго контроля)
  2. Для прочих видов зaписeй плaнa (курсовых рaбот, прaкик, итоговых госэкзaмeнов, ВКP) выполняeтся оцeнкa нaгрузки для типовых случaeв (курсовыe и ВКP нe нa инострaнном языкe, групповой вид прaктики, итоговыe экзaмeны в устной формe и т.п.)
  3. Количeтво чaсов нaгрузки по всeм зaписям плaнa суммируeтся и дeлится нa знaчeниe нaстройки "Нормaтив нaгрузки условного прeподaвaтeля" (нaпримeр, 700 чaсов). Тaким обрaзом вычисляeтся число условных стaвок прeподaвaтeлeй, трeбуeмых для рeaлизaции плaнa.
  4. Опрeдeляeтся отношeниe числa студeнтов, укaзaнного для плaнa в цeлом (в случae PУП) или для одного годa рeaлизaции Объeдинeнного плaнa, к числу условных стaвок прeподaвaтeлeй. Тaким обрaзом получaeтс знaчeниe Коэффициeнтa зaтрaтности плaнa.
  5. Получeнноe знaчeниe Коэффициeнтa зaтрaтности срaвнивaeтся с нормaтивными знaчeниями, хрaнящмися в спрaвочникe "Нормaтивныe коэффициeнты зaтрaтности плaнa", дeлaeтся вывод о повышeнной зaтрaтности плaнa или о зaтрaтности в рaмкaх стaндaртной.

Оценка затратности реализована в системе в виде интерактивного Excel-отчета, показывающего составляющие, на основе которых была произведена оценка и позволяющего сохранять полученное значение коэффициента затратности в базе данных.

1.20.1. Формирование справочников и установка настроек, необходимых для расчета

До того, как появится возможность оценить затратность отдельных учебных планов, следующие данных должны быть заполнены централизовано пользователем, имеющим права на работу со справочниками по планированию нагрузки преподавателей.

  1. Должно быть установлено значение настройки "Норматив нагрузки условного преподавателя". Значение выражено в числе часов нагрузки, составляющем одну условную ставку преподавателя (например, 700).
  2. Должны быть сформированы три записи справочника "Нормативные коэффициенты затратности плана" для уровней образования "Бакалавриат","Специалитет" и "Магистратура". Для каждого уровня должно быть занесено стандартное (минимально допустимое нормой) значение коэффициента затратности. Данный справочник расположен в разделе "Справочники на планированию нагрузки" на одноименной вкладке верхнего уровня.
  3. Справочник "Виды учебной работы преподавателей" должен быть полностью сформирован на тот учебный год, планы которого планируется оценивать. Среди видов работ, связанных с курсовыми работами, практиками, итоговыми госэкзаменами, ВКР при помощи простановки признака "Используется для оценки плана" должны быть выделены те виды работ, которые являются типовыми (не зависят от выбора студентами) и которые должны использоваться для оценки затратности плана. Простановка этого признака для дисциплин и НИС не требуется.

1.20.2. Оценка затратности Рабочего учебного плана

Оценка затратности РУП может выполняться тогда, когда план уже практически полностью сформирован (создан перечень дисциплин, распределена нагрузка по видам работы, занесено число испытаний текущего контроля, созданы зачеты и экзамены). Для получения оценки затратности РУП нужно проделать следующее:

  1. Уточнить (или задать) число студентов, установленное для плана в целом в таблице "Рабочие учебные планы" в колонке "Количество студентов".
  2. В подчиненной таблице "Записи рабочего учебного плана" необходимо проставить значения в колонках "Количество студентов", "Количество подгрупп", "Количество групп", "Количество потоков" для всех записей плана кроме разделов и зачетно-экзаменационных недель. Достаточно задать только те значения, от которых зависит расчет нагрузки для данной записи плана. Например, если по дисциплине или НИС нет лекций, значение "Количество потоков" можно не задавать. Заносимые значения должны учитывать в себе понижающие коэффициенты для случаев, когда известно, что студенты, обучающиеся по данному плану, будут изучать дисциплину в одном потоке с другими студентами. Например, если одну из дисциплин по выбору студенты будут изучать совместно со студентами, обучающимися по другим планам, то Количество потоков нужно сократить до доли, которую займут студенты данного плана (например, 0,33). Также можно уменьшать, в том числе до дробных значений, количество групп и подгрупп. Количество студентов должно быть задано таким, как оно оценивается для данной конкретной дисциплины.
  3. При помощи действия контекстного меню Оценка затратности плана выгрузить Excel-отчет, показывающий оценку величины нагрузки по каждой записи плана, по плану в целом, число условных ставок преподавателей, требуемых для реализации плана, а также полученную величину Коэффициента затратности плана и ее оценку ("план избыточно затратен" или "затратность плана в пределах стандарта").
  4. В случае получения нулевых или некорректных значений объема нагрузки нужно уточнить значение числа студентов, групп, подгрупп, потоков по плану в целом или для отдельных дисциплин. Если наблюдается некорректность расчета, нужно обратиться к пользователям, ответственным за работу со справочниками по планированию нагрузки. Если план избыточно затратен, для снижения затратности можно уменьшить число форм текущего контроля, экзаменов, использовать больше дисциплин, читаемых совместно со студентами других учебных планов или больше "внешних" дисциплин (например, MOOC’s). После внесения изменений в показатели плана отчет нужно выгрузить заново.
  5. Если полученное значение коэффициента затратности является корректным, нужно нажать на кнопку "Сохранить значение коэффициента", расположенную в "шапке" плана. Полученное значение коэффициента будет сохранено в таблице данных "Рабочие учебные планы" в одноименной колонке.

1.20.3. Оценка затратности Объедиенного плана

Оценка затратности Объединенного плана выполняется применительно к одному учебному году и может выполняться тогда, когда план уже практически полностью сформирован на данный учебный год (создан перечень дисциплин, распределена нагрузка по видам работы, занесено число испытаний текущего контроля, созданы зачеты и экзамены). Для получения оценки затратности Объединенного плана нужно проделать следующее:

  1. Задать число студентов для плана в целом применительно к учебному году, для которого выполняется оценка затратности, в подчиненной таблице "Реализация плана по годам".
  2. "Количество студентов", "Количество подгрупп", "Количество групп", "Количество потоков" для каждой из записей плана также оценивается применительно каждому учебному году. Установить эти значения нужно в подчиненной таблице "Все записи плана по годам" для нужного учебного года в одноименных колонках таблицы. Значения должны быть установлены для всех записей плана кроме разделов и зачетно-экзаменационных недель. Достаточно задать только те значения, от которых зависит расчет нагрузки для данной записи плана. Например, если по дисциплине или НИС нет лекций, значение "Количество потоков" можно не задавать. Заносимые значения должны учитывать в себе понижающие коэффициенты для случаев, когда известно, что студенты, обучающиеся по данному плану, будут изучать дисциплину в одном потоке с другими студентами. Например, если одну из дисциплин по выбору студенты будут изучать совместно со студентами, обучающимися по другим планам, то Количество потоков нужно сократить до доли, которую займут студенты данного плана (например, 0,33). Также можно уменьшать, в том числе до дробных значений, количество групп и подгрупп. Количество студентов должно быть задано таким, как оно оценивается для данной конкретной дисциплины.
  3. Выгрузить Excel-отчет при помощи действия контекстного меню Оценка затратности плана. Отчет требует указать учебный год, для которого он формируется. Отчет показывает оценку величины нагрузки по каждой записи плана, по плану в целом, число условных ставок преподавателей, требуемых для реализации плана, а также полученную величину Коэффициента затратности плана и ее оценку ("план избыточно затратен" или "затратность плана в пределах стандарта").
  4. В случае получения нулевых или некорректных значений объема нагрузки нужно уточнить значение числа студентов, групп, подгрупп, потоков по плану в целом или для отдельных дисциплин. Если наблюдается некорректность расчета, нужно обратиться к пользователям, ответственным за работу со справочниками по планированию нагрузки. Если план избыточно затратен, для снижения затратности можно уменьшить число форм текущего контроля, экзаменов, использовать больше дисциплин, читаемых совместно со студентами других учебных планов или больше "внешних" дисциплин (например, MOOC’s). После внесения изменений в показатели плана отчет нужно выгрузить заново.
  5. Если полученное значение коэффициента затратности является корректным, нужно нажать на кнопку "Сохранить значение коэффициента", расположенную в "шапке" плана. Полученное значение коэффициента будет сохранено в таблице данных "Реализация плана по годам" в одноименной колонке применительно к указанному при формировании отчета учебному году.

1.20.4. Формирование Перечня учебных планов с коэффициентами затратности

Отчет, выгружающий в MS Excel перечень всех Рабочих учебных планов одного учебного года (включая РУП, полученные по данным Объединенных планов) можно сформировать при помощи действия "Перечень утвержденных РУП", доступного с консоли управления в разделе Разработка учебных планов / Аналитические отчеты по РУП.

Перечень утвержденных РУП

При формировании отчета необходимо задать значение "Да" для параметра Выгружать коэффициенты затратности. В этом случае таблица сформируется со столбцом, содержащим коэффициенты затратности планов. В итоговых строках будут отражены средние значения коэффициента затратности по филиалу, факультету, уровню образования.

1.20.5. Отчеты о фактической затратности

Для оценки фактической затратности реализации образовательных программ представлены следующие отчеты:

  • Оценка фактической затратности ОП
  • Сводный отчет по затратности ОП в учебном году
  • Сводный отчет по затратности ОП по годам

1.20.5.1. Оценка фактической затратности ОП

Для формирования отчета Оценка фактической затратности ОП необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) выбрать учебный план.
  2. Из контекстного меню вызвать действие Оценка фактической затратности ОП.
    Вызов действия Оценка фактической затратности ОП
  3. В форме параметров необходимо указать Учебный год реализации образовательной программы, при этом Курс будет установлен автоматически. Для того чтобы отчет формировался подробно по каждому преподавателю, необходимо установить признак С конкретизацией по преподавателям.
    Форма параметров Оценка фактической затратности ОП

В результате сформируется отчет в виде Excel файла с оценкой фактической затратности реализации для одной выбранной образовательной программы, одного учебного года и одного курса.

Фактические значения рассчитываться следующим образом:

- Для дисциплины, НИС количество студентов данной ОП, которым назначена дисциплина или НИС для изучения на данном курсе.

- Для курсовой работы количество испытаний студентов данной ОП на данном курсе по курсовой работе с установленным признаком "В диплом" и непустым полем "Руководитель".

- Для практики количество испытаний студентов данной ОП на данном курсе по практике с установленным признаком "В диплом" и непустым полем "Руководитель практики".

- Для итогового экзамена количество студентов данной ОП, которым назначен итоговый экзамен для изучения на данном курсе.

- Для ВКР количество испытаний студентов данной ОП на данном курсе по ВКР с установленным признаком "В диплом" и непустым полем "Руководитель".

- Для проекта студентов количество испытаний студентов данной ОП на данном курсе по проекту с установленным признаком "В диплом" и непустым полем "Руководитель проекта - сотрудник вуза".

Доля студентов данной программы на данном курсе в предметной единице определяется как отношение количества студентов данной программы на данном курсе к общему количеству студентов в предметной единице. Количеством предметных единиц для строки отчета должна быть сумма долей по всем предметным единицам, подчиненным записи плана.

Количество студентов для расчета нагрузки за прием экзамена или зачета по дисциплинам, НИС и практикам определяется по ведомостям.

Количество потоков (при приеме письменных экзаменов) для дисциплин, НИС и практик рассчитывается как сумма долей студентов ОП определенного курса для каждого связанного приметного потока.

Количество групп (для консультаций при семестровой организации) для дисциплин НИС и практик рассчитывается как сумма долей студентов ОП для каждой связанной приметной группы.

Количество экзаменов для ВКР и итоговых экзаменов определяется как количество испытаний студентов данной ОП данного курса с признаком "в диплом", с непустым значением Руководитель работы (для ВКР), включенных в Локальные ГЭК.

Если при формировании отчета был установлен признак "С конкретизацией по преподавателям", то в отчет выгрузятся только те преподаватели, которым в плане нагрузки была назначена какая-либо нагрузка по записи учебного плана. При этом для видов работ, для которых невозможно определить однозначную связь преподаватель-студент, рассчитывается доля вклада преподавателя в выполнение нагрузки как отношение объема нагрузки определенного вида по записи плана, запланированной для данного преподавателя к объему нагрузки этого же вида, запланированной для всех преподавателей. Для отдельных видов работ фактическая нагрузка преподавателей считается по фактическому количеству связанных с ним студентов.

1.20.5.2. Сводный отчет по затратности ОП в учебном году

Для формирования отчета Сводный отчет по затратности ОП в учебном году необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) из контекстного меню вызвать действие Сводный отчет по затратности ОП в учебном году.
    Вызов действия Сводный отчет по затратности ОП в учебном году
  2. В форме параметров необходимо указать Учебный год, за который будет формироваться отчет. При необходимости можно конкретизировать перечень образовательных программ и курсов с помощью параметров Филиал, Факультет, Уровень образования, Форма обучения, Образовательная программа и Курс факультета.
    Если в форме параметров указан только параметр Учебный год, то отчет будет формироваться по всем образовательным программам и курсам ВУЗа, реализуемым в данном учебном году.
    Для выбора Образовательных программ и Курсов факультета, необходимо щелкнуть левой клавишей мыши на кнопку открытия справочника Справочник, в открывшихся справочниках или с помощью чек-бокса Чек-бокс выбрать одну или несколько записей и нажать кнопку ОК.

    Форма параметров Сводный отчет по затратности ОП в учебном году

В результате сформируется отчет в виде Excel файла со сводным отчетом по затратности в указанном учебном году для выбранных образовательных программ и курсов.

1.20.5.3. Сводный отчет по затратности ОП по годам

Для формирования отчета Сводный отчет по затратности ОП по годам необходимо:

  1. В представлении (таблице данных) Объединенные учебные планы (раздел Объединенные учебные планы) из контекстного меню вызвать действие Сводный отчет по затратности ОП по годам.
    Вызов действия Сводный отчет по затратности ОП по годам
  2. В форме параметров необходимо указать Учебный год начала обучения. При необходимости можно конкретизировать перечень образовательных программ и курсов с помощью параметров Филиал, Факультет, Уровень образования, Форма обучения, Образовательная программа и Курс факультета.
    Если в форме параметров указан только параметр Учебный год, то отчет будет формироваться по всем образовательным программам и курсам ВУЗа, реализуемым в данном учебном году.
    Для выбора Образовательных программ и Курсов факультета, необходимо щелкнуть левой клавишей мыши на кнопку открытия справочника Справочник, в открывшихся справочниках или с помощью чек-бокса Чек-бокс выбрать одну или несколько записей и нажать кнопку ОК.

    Форма параметров Сводный отчет по затратности ОП по годам

В результате сформируется отчет в виде Excel файла со сводным отчетом по затратности выбранных образовательных программ и курсов в учебных годах, начиная с указанного Учебного года начала обучения и до крайнего учебного года реализации образовательных программ.

1.21. Каталог дисциплин

Справочник "Каталог дисциплин"

Справочник содержит записи о дисциплинах, каждая из которых характеризуется определенным содержанием и объемом, который в свою очередь задается числом кредитов.

Поля:

  • Статус дисциплины - признак утверждения дисциплины Методическим управлением. Возможные варианты для статуса: проект и утверждено. При этом только утвержденные дисциплины могут быть доступны разработчикам учебных планов. Изменение статуса дисциплины доступно только пользователям Методического управления.
  • Код дисциплины - автоматически вычисляемое поле на основании данных подчиненной таблицы.
  • Дисциплина ВУЗа - наименование дисциплины ВУЗа из справочника Все дисциплины ВУЗа.
  • Число кредитов - числовое значение, весовая характеристика объема дисциплины.
  • Наименование на английском языке - наименование дисциплины на английском языке.
  • Порядковый номер - числовое значение. Позволяет располагать дисциплины в заданном пользователем порядке.

Для добавления новой дисциплины в католог необходимо воспользоваться соответствующим пунктом контекстного меню.

Откроется окно создания новой дисциплины:

Добавить дисциплину в каталог

- Дисциплина ВУЗа - наименование дисциплины ВУЗа из справочника Все дисциплины ВУЗа.

- Полное наименование дисциплины - заполняется автоматически из справочника Все дисциплины ВУЗа.

- Наименование на английском языке - наименование дисциплины на английском языке.

- Число кредитов - задается числовое значение кредитов для данной дисциплины.

Далее в правой части формы осуществляется выбор направлений (специальностей), для которых преподается данная дисциплина в соответствующих группах полей (по уровням образования).

Выбор осуществляется из справочников Направления и специальности (для уровней Бакалавриат, Специалитет и Магистратура), Отрасли науки и научные специальности (для аспирантуры) и Направления ДПО (для дополнительного профессионального образования).

Для каждого из уровней образования можно выбрать до трех специальностей (направлений).

После нажатия кнопки "Ок", запись о новой дисциплине появится в главной таблице. В поле "Статус дисциплины" будет установлено значение "проект".

Также в подчиненной таблице Направления/Специальности будет содержать перечень уровней и направлений (специальностей) подготовки, для которых преподается, созданная дисциплина.

Поля таблицы Направления/Специальности :

  • Уровень образования - показывается уровень образования для данного направления/специальности.
  • Аббревиатура направления/специальности - аббревиатура, соответствующая направлению/специальности из справочника Направления и специальности.
  • Направление/специальность ВПО - наименование направления/специальности, для которого преподается данная дисциплина. Выбор из справочника Направления и специальности. Для уровней образования Аспирантура и ДПО поле недоступно для редактирования и должно быть пустым.
  • Код научной специальности - код из справочника Отрасли науки и научные специальности
  • Научная специальность - наименование научной специальности аспирантуры, для которой преподается данная дисциплина. Выбор из справочника Отрасли науки и научные специальности
  • Аббревиатура направления ДПО - аббревиатура из справочника Направления ДПО
  • Направление ДПО - наименование направления ДПО, для которого преподается данная дисциплина. Выбор из справочника Направления ДПО.

По данным таблицы Направления ДПО система автоматически генерирует код дисциплины, который заносится в соответствующее поле главной таблицы.

Код дисциплины автоматически переформировывается при добавлении/удалении записей таблицы Направления/Специальности, а также при изменении числа кредитов в таблице Каталог дисциплин.

Алгоритм формирования кода дисциплины:

Код состоит из трех частей, разделенных знаком "/".

1-я часть: Аббревиатура всех уровней образования, для которых преподается данная дисциплина.

  • Б - бакалавриат
  • С - специалитет
  • М - магистратура
  • А - аспирантура
  • Д - ДПО

2-я часть: Аббревиатура (или коды) направлений, специальностей, научных специальностей, направлений ДПО, для которых преподается дисциплина. Для того, чтобы можно было различить направления (специальности) высшего образрования, научные специальности и направления ДПО, перед соответствующим кодом (аббревиатурой) проставляется индекс:

  • н - научная специальность
  • д - направление ДПО

Аббревиатуры (коды) направлений разделяются знаком "-".

Пример сформированных кодов дисциплин:

Пример 1:

Пример формирования кода дисциплины

Пример 2:

1.22. График учебного процесса

График учебного процесса является составной частью базового учебного плана. График учебного процесса в ВУЗе в базовом учебном плане составляется на весь период обучения по данному направлению (специальности) с учетом разбиения времени по модулям. На графике указываются продолжительность теоретического обучения, время, отводимое на все виды практики, подготовку выпускной квалификационной работы (ВКР), государственную итоговую аттестацию, каникулы, отпуск после окончания вуза.

Работы по формированию графика учебного процесса производятся на участке РАЗРАБОТКА УЧЕБНЫХ ПЛАНОВ в разделе Базовые и рабочие учебные планы в таблице Базовые учебные планы. Для отображения записей графика учебной работы предназначена подчиненная таблица График учебного процесса.

Перед началом работ по формированию графика учебного процесса необходимо убедиться, что для соответствующего БУП корректно заполнены поля "Реализуется по периодам" и "Число периодов в году" таблицы Базовые учебные планы

Таблица График учебного процесса

Для формирования графика учебного процесса необходимо в таблице Базовые учебные планы выбрать запись БУП, для которой планируется формировать график учебного процесса, вызвать контекстное меню (правая кнопка мыши) и воспользоваться действием "Сформировать график учебного процесса".

Откроется окно задания количества недель в году:

Сформировать график по умолчанию

По умолчанию количество недель проставляется равным "52". Это значение можно изменить.

После нажатия на кнопку "Ок" в таблице График учебного процесса будут созданы записи общим количеством равным заданному количеству недель в году умноженному на количество курсов, по данному учебному плану.

Также в подчиненной таблице Вид недельной нагрузки для каждой из записей таблицы График учебного процесса будут установлены значения "Теоретическое обучение".

Процесс формирования графика учебного процесса заключается в распределении по модулям, неделям и курсам видов учебной и внеучебной деятельности, таких как теоретическое обучение, практика, подготовка выпускной квалификационной работы (ВКР), государственная итоговая аттестация, каникулы, отпуск после окончания вуза.

Для этого необходимо в таблице Базовые учебные планы выбрать БУП, по которому создается график, вызвать контекстное меню (правая кнопка мыши) и воспользоваться пунктом "Открыть график учебного процесса".

Откроется форма редактирования соответствующего графика учебного плана.

Редактирование графика учебного процесса

Форма для редактирования графика учебного процесса содержит временную шкалу учебного года (начиная с сентября), которая рабита по месяцам и неделям. Также таблица разбита по курсам для выбранной степени образования. В правой части таблицы расчитывается количество недель, выделенное на нагрузку каждого вида для каждого курса и их сумма, а также показаны зачетные единицы из соответствующего БУП.

Для нового, только что созданного, графика учебного процесса во всех ячейках временной шкалы проставлены значения "Т" (теоретической обучение).

В первую очередь необходимо задать временные периоды модулей. Вертикальные границы серых областей, которыми обозначены модули, являются перемещаемыми по горизонтали. Для того, чтобы переместить одну из границ области необходимо подвести курсор мыши к перетаскиваемой границе, чтобы он принял вид Курсор. После этого нужно зажать левую кнопку мыши и перетащить границу на нужную неделю. Области модулей пересекаться не могут.

После того, как модули расположены на временной шкале, можно приступить к заполнению ячеек таблицы признаками вида учебной нагрузки. В результате должны быть заполнены ВСЕ ячейки временной шкалы.

Для того, чтобы установить вид недельной нагрузки в соответствующую ячейку необходимо выделить ячейку нажатием левой кнопки мыши (ячейка быдет выделена синим цветом), нажать правую кнопку мыши и из появившегося списка выбрать нужный вид недельной нагрузки. В одной ячейке может быть выбрано несколько видов недельной нагрузки. Для выбора каждого из них, необходимо каждый раз снова вызвать список выбора правой кнопкой мыши.

Выбор вида недельной нагрузки

В форме редактирования предусмотрена возможность назначения вида недельной нагрузки одновременно для нескольких соседних ячеек. Для множественного выбора необходимо, зажав левую кнопку мыши, провести ею над всеми ячейками, которые должны быть изменены. Все выбранные ячейки будут выделены синим цветом. Затем можно вызвать список видов недельной нагрузки нажатием правой кнопки мыши. Во всех выделенных ячейках проставится соответствующий вид нагрузки.

Кроме реквизитов БУП указанных в шапке формы, в верхнем правом углу расположены информационные элементы:

  • Статус плана - показывается статус согласования БУП
  • Программа двойных дипломов - признак программы двойных дипломов
  • Ход согласования - при нажатии на ссылку откроется таблица, содержащая сведения о ходе согласования БУП.
  • Дополнительные действия - открывется список дополнительных действий:
    • Сформировать протокол проверки - будет сформирован протоколол в проверки БУП в формате Excel, в котором будут отображены сообщения Системы о результатах проверки.
    • Напечатать график - будет создан и показан на экране файл Excel, содержащий печатную форму графика учебного процесса для проверки и распечатки. Пример Графика учебного процесса
    • Напечатать план - будет создан и показан на экране файл Excel, содержащий печатную форму БУП.

После того как работа с формой редактирования графика учебного процесса закончена, форму можно закрыть.

Просмотреть и распечатать график учебного процесса можно из таблицы Базовые учебные планы, воспользовавшись пунктом контекстного меню "График учебного процесса".

1.23. Переводы для учебных планов

Данная форма содержит в себе таблицы данных с перечнем всех терминов и элементов перечислений, используемых на веб-страницах для публикации Базовых и Рабочих учебных планов на английском языке.
Форма переводы для учебных планов

Для корректировки перевода необходимо:

  1. Для термина, перевод которого необходимо изменить, в поле Перевод щелкнуть левой клавишей мыши.
  2. С помощью кнопки Справочник открыть окно редактирования и ввести тест с новым переводом.
  3. Закрыть окно редактирования и подтвердить сохранение изменений.

1.24. Аналитические отчеты по РУП

1.24.1. Перечень утвержденных РУП (Форма 1)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Перечень утвержденных РУП (форма 1).
    Перечень утвержденных РУП

  2. В открывшейся форме параметров:
    Форма параметров Перечень утвержденных РУП

    • В поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • В поле Учебный год указать учебный год, для которого формируется отчет.
    • Для параметров Только по утвержденным РУП и Выводить оценку затратности с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

1.24.2. Регламентирующие показатели РУП (Форма 3)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Регламентирующие показатели РУП (форма 3).
    Регламентирующие показатели РУП

  2. В открывшейся форме параметров:
    Форма параметров Регламентирующие показатели РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • В поле Учебный год указать учебный год, для которого формируется отчет.
    • Для параметров Показывать соотношение в % и Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

1.24.3. Виды дисциплин в БУП и РУП (Форма 7)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Виды дисциплин в БУП и РУП (форма 7).
    Виды дисциплин в БУП и РУП

  2. В открывшейся форме параметров:
    Форма параметров Виды дисциплин в БУП и РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • В поле Учебный год указать учебный год, для которого формируется отчет.
    • В поле Вид учебных планов выбрать требуемый вид учебных планов.
    • Для параметра Только по утвержденным планам с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

1.24.4. Формы контроля в РУП (Форма 10)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Формы контроля в РУП (форма 10).
    Формы контроля в РУП

  2. В открывшейся форме параметров:
    Форма параметров Формы контроля в РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметра Учебный год.
    • При необходимости можно установить ограничение для отчета и указать параметр Только уровень образования.
    • Для параметра Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

1.24.5. Дисциплины РУП по циклам ГОС (Форма 11)

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Дисциплины РУП по циклам ГОС (форма 11).
    Дисциплины РУП по циклам ГОС

  2. В открывшейся форме параметров:
    Форма параметров Дисциплины РУП по циклам ГОС

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметра Учебный год.
    • Для параметра Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

1.24.6. Дисциплины, не назначенные ни одному студенту

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Дисциплины, не назначенные ни одному студенту.
    Дисциплины, не назначенные ни одному студенту

  2. В открывшейся форме параметров:
    Форма параметров Дисциплины, не назначенные ни одному студенту

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметров Учебный год и Факультет.
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

1.24.7. Дисциплины по числу вхождений в РУП

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Дисциплины по числу вхождений в РУП.
    Дисциплины по числу вхождений в РУП

  2. В открывшейся форме параметров:
    Форма параметров Дисциплины по числу вхождений в РУП

    • Поле Филиал заполнится автоматически в зависимости от установленных настроек (см. Настройки для работы с учебными планами).
    • Установить значение для параметра Учебный год.
    • При необходимости можно установить параметр Минимальное число вхождений.
    • Для параметра Только по утвержденным РУП с помощью чек-бокса Чек-бокс установить значение "Да", либо "Нет".
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

1.24.8. Выгрузка записей РУП для анализа

Для формирования отчета необходимо:

  1. На участке Разработка учебных планов, в разделе Аналитические отчеты по РУП, выбрать отчет Выгрузка записей РУП для анализа.
    Выгрузка записей РУП для анализа

  2. В открывшейся форме параметров:
    Форма параметров Выгрузка записей РУП для анализа

    • Устновить значения параметров Учебный год, Уровень образования, Филиал, Факультет и Образовательная программа.
    • Нажать кнопку ОК, при этом по умолчанию отчет сформируется в формате MS Excel. Для того чтобы отчет сформировался в других форматах нужно рядом с кнопкой ОК раскрыть список и выбрать требуемый формат.
      Список форматов сохранения

2. Рабочее место кафедры

2.1. Настройка участка "Рабочее место кафедры"

Для установки настроек Кафедра пользователям участка Рабочее место кафедры необходимо выполнить следующие действия:

  1. На участке Кафедра открыть один из разделов:
    • Настройка пользователя кафедры ;
    • Справочники кафедры ;
    • Предложения кафедры в учебном году ;
    • Дисциплины учебных планов и успеваемость ;
    • Дисциплины кафедры в РУП.
  2. В основной таблице данных вызвать контекстное меню (щелчок правой клавишей мыши) и выбрать процедуру Настройка пользователя кафедры. Установка настроек 'кафедра' на участке "Рабочее место кафедры"
  3. Заполнить форму настроек и нажать кнопку ОК, после чего пользователю будут доступны только данные определенной кафедры.
    Форма настроеек пользователя кафедры
В разделе Справочники кафедры прежде чем вызывать контекстное меню, следует выбрать закладку Преподаватели кафедры из основной таблицы данных.

2.2. Работа с ведомостями

Для просмотра ведомостей кафедры, необходимо в форме Дисциплины учебных планов и успеваемость открыть таблицу Все ведомости кафедры. В данной таблице отображаются ведомости только по дисциплинам, реализуемым кафедрой, с которой работает текущий пользователь.

Пользователю доступны следующие действия по работе с ведомостями:

  1. Выгрузка на печать ведомости, сформированной пользователем факультета. Для этого необходимо в таблице Все ведомости кафедры выбрать запись с требуемой ведомостью и через контекстное меню вызвать действие "Ведомость для печати" или "Ведомость для печати (двуязычная)".

    Вывод ведомости на печать

    Откроется форма параметров, в которой при необходимости можно указать Фамилию ИО преподавателя, которая будет выводиться в ведомость. При нажатии кнопки "ОК" будет сформирована ведомость.

  2. Вывод на печать «Объединенной ведомости». Для этого необходимо в таблице Все ведомости кафедры выбрать записи ведомостей, которые должны попасть в «Объединенную ведомость» и через контекстное меню вызвать действие "Объединенная ведомость". При нажатии кнопки "ОК" будет сформирована «Объединенная ведомость», в которой заголовок ведомости сформируется по данным первой из ведомостей, включенных в список, а также в заголовке сформируется список ФИО всех преподавателей, присоединенных ко всем ведомостям списка. Основную часть ведомости будет составлять таблица со списком студентов, включенных во все ведомости из переданного списка.

Для того, чтобы преподаватели могли скачивать и распечатывать свои ведомости используя веб-браузер, предоставлена возможность работы с специализированным веб-сервисом печати ведомостей. Для доступа к веб-сервису на главной веб-странице системы расположена ссылка «Я – преподватель», ведущая на страницу работы с ведомостями.

2.3. Предложения кафедры в учебные планы

Функционал раздела "Предложения кафедры в учебные планы" позволяет пользователям кафедры создавать и редактировать группы дисциплин ("планы-предложения"), которые кафедра готова реализовывать для различных образовательных программ университета.

Объединение в "группы" ("планы-предложения") может использоваться для разделения дисциплин, предлагаемых для разных уровней образования, реализуемых в разные периоды, и планируемых по разным видам периодов - по модулям или по семестрам.

2.3.1. Создание плана-предложения кафедры

Для добавления нового "плана-предложения" необходимо:

  1. На участке Рабочее место кафедры выбрать раздел "Предложения кафедры в учебные планы".
  2. В основной таблице данных Планы-предложения кафедры с помощью контекстного меню вызвать действие Добавить план-предложение кафедры.
    Добавление плана предложения
  3. В форме добавления необходимо:
    Форма добавления плана предложения
    • В полях Филиал, Факультет, Кафедра - указать соответствующие значения, если до этого были установлены соответствующие настройки пользователя (Настройка участка "Рабочее место кафедры"), то эти параметры будут заполнены автоматически.
    • С помощью полей Год начала реализации, Уровень образования и Число лет можно создавать планы предложения кафедры, как на все годы, так и группировать дисциплины в разные планы по годам или по уровням образования.
    • В поле Реализуется по периодам - выбрать вид периодов реализации плана (по модулям или по семестрам).
    • В поле Количество периодов - ввести количество периодов в учебном году (число модулей или число семестров).
  4. Нажать кнопку ОК, после чего план-предложение кафедры будет добавлен.

2.3.2. Формирование плана-предложения кафедры

Наполнение и редактирование плана-предложения кафедры выполняется с помощью специальной Формы редактирования, для открытия которой необходимо в разделе "Предложения кафедры в учебные планы" выбрать требуемое план-предложение и через контекстное меню вызвать действие Открыть и указать параметры для открытия формы редактирования.
Форма параметров для открытия формы редактирования ПП

  • Если в форму редактирования нужно вклучить дисциплины других планов предложений кафедры, то в поле Включить дисциплины других планов необходимо установить значение "Да".
  • С помощью полей С учебного года и По учебный год установить период для открытия формы редактирования.

    При открытии в форме редактирования будут только дисциплины, которые реализуются хотя бы в одном из учебных годов между указанными в полях С учебного года и По учебный год.

    В форме редактирования для изменения периода нужно воспользоваться действием Параметры редактирования (правый верхний угол формы редактирования).

Редактирование плана-предложения заключается в добавлении в существующие разделы дисциплин или семинаров, распределении учебной нагрузки по видам (лекции, семинары, самостоятельная работа) и по учебным периодам. Для добавления записей в план предложение предназначены соответствующие действия контекстного меню. Для добавлении записи в определенный раздел нужно сначала выбрать заголовок этого раздела или одну из входящих в него записей.

Добавлять в план-предложение кафедры можно "дисциплины" и "научно-исследовательские семинары", для этого необходимо в уже открытой Форме редактирования в контекстном меню найти группу действий Добавить и выбрать одно из действий дисциплину... или научно-исследовательский семинар... Добавление дисциплины в план-предложение кафедры

В результате откроется окно параметров, в котором необходимо: Форма параметров добавление дисциплины в план-предложение кафедры

  • В поле Источник финансирования из выпадающего списка выбрать требуемый вариант. Следует обратить внимание, что при выборе неподходящего варианта источника финансирования поле останется подсвеченным зеленым.
  • Установить Год начала реализации и Год окончания реализации.
  • В поле Дисциплина вуза или Семинар (дисциплина вуза) - с помощью списка Список или справочника Справочник выбрать дисциплину или семинар для добавления.
  • При необходимости установить значения параметров в полях Имеет пререквизиты, На иностранном языке, Читается носителем языка.
  • В поле Формат изучения установить формат изучения дисциплины.
  • Если дисциплина ведется на английском языке, то поле Область науки (межд.) станет обязательным для заполнения, в котором необходимо будет указать соответствующую область науки из выпадающего списка Список или с помощью справочника Справочник.
  • В полях Общее число часов, Аудиторных часов - указать соответствующие числовые характеристики добавляемой дисциплины или семинара.

После нажатия кнопки ОК, дисциплина (семинар) будет добавлена и ей будет присвоен свободный порядковый номер.

Для изменения периода реализации дисциплины или НИС необходимо использовать процедуру Изменить период реализации.

Дисциплины (семинары), входящие в план-предложение кафедры имеют свойство Статус. Сразу после создания дисциплины пользователем кафедры дисциплина получает статус "проект". Пока дисциплина находится в этом статусе, разработчики планов образовательных программ не видят эту дисциплину и не могут использовать ее в своих планах. Этот статус необходим для того, чтобы пользователь кафедры закончил работу со всеми необходимыми характеристиками дисциплины, а также задал ограничения на использование дисциплины в учебных планах.

2.3.3. Добавление нагрузки для дисциплин и НИС

В планах предложениях для каждой дисциплины нужно сформировать нагрузку, как по годам, так и периодам каждого года.

Для добавления нагрузки необходимо:

  1. В представлении Планы-предложения кафедры (форма Предложения кафедры в учебные планы) выбрать план предложение, для которого будет формироваться нагрузка.
  2. Вызвать из контекстного меню действие Открыть.
  3. В форме редактирования выбрать дисциплину или НИС, для которой добавляются данные о нагрузке.
  4. Для каждой дисциплины (НИС) в форме редактирования представлен набор параметров (каждому параметру соответствует своя колонка), с помощью которых можно задать нагрузку:
    Форма редактирования фформирование нагрузки в плане предложении
    • В полях Всего часов по дисциплине и Всего аудиторных часов по дисциплине можно отредактировать соответствующее количество часов за весь период реализации дисциплины.
    • Для каждого учебного года, в рамках которых реализуется дисциплина, необходимо указать значения полей Всего часов в году и Аудиторных часов в году, а также распределить часы по видам работ в группах полей Ауд. часы по видам работы, Самостоятельная работа.
      Если для какого-либо учебного года были внесены данные о нагрузке (указаны Всего часов в году, Аудиторных часов в году и т.д.), то в представлении Нагрузка по годам появится соответствующая запись о нагрузке в учебном году, для которого добавлена информация о нагрузке.
    • Для каждого отдельного периода (модуля/семестра) необходимо указать значения следующих полей: Аудиторных часов в периоде, Форма контроля (указывается если в данном периоде предусмотрен рубежный контроль), Аудиторных часов за часть дисциплины и Общих часов за часть дисциплины (если в данном периоде предусмотрен рубежный, то нужно указать количество аудиторных и общих часов, которое будет зачтено при прохождении рубежного контроля в данном периоде (модуле/семестре)).
      Если для какого-либо периода в учебном году были внесены данные о нагрузке, то в представлении Нагрузка по периодам года (представление подчиненно представлению Предлагаемые дисциплины и НИС по годам) появится соответствующая запись о нагрузке в периоде, для которого добавлена информация о нагрузке.

Допустим в форме редактирования плана-предложения требуется ввести данные для дисциплины "Иностранный язык", которая характеризуется следующим набором данных:

  • Продолжительность: с 1 по 4 модуль первого года обучения.
  • Рубежный контроль: во 2 модуле зачет; в 4 модуле экзамен.
  • Всего часов: 108 (из них всего аудиторных 68).
  • Распределение часов по видам работ: 68 часов практических занятий и 40 часов самостоятельной работы.
  • Распределение часов по периодам: в 1, 2 и 3 модуле по 16 ауд.часов и 10 часов самостоятельной работы; в 4 модуле 20 ауд. часов и 10 часов самостоятельной работы.

Для этого необходимо найти нужный план-предложение и открыть форму редактирования (действие Открыть из контекстного меню). В форме редактирования найти дисциплину "Иностранный язык" и в следующих полях указать соответствующие данные:

  1. В полях Всего часов по дисциплине и Всего аудиторных часов по дисциплине указать значения 108 и 68 часов соответственно.
  2. Для 1 года обучения указать:
    • в полях Всего часов в году и Аудиторных часов в году указать 108 и 68 часов соответственно;
    • в поле практические занятия 68 часов;
    • в поле самостоятельная работа 40 часов;
  3. Для 1 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • поля Форма контроля, Аудиторных часов за часть дисциплины и Общих часов за часть дисциплины необходимо оставить пустыми, так как рубежный контроль в данном периоде не предусмотрен и часы за данный период будут суммироваться в периоде, в котором встречается следующий рубежный контроль (во 2 модуле).
  4. Для 2 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • в поле Форма контроля установить форму контроля "Зачет";
    • в поле Аудиторных часов за часть дисциплины 32 часа (так как в 1 модуле рубежного контроля не было, то аудиторные часы за часть дисциплины в 1 модуле суммируются к часам 2 модуля).
    • в поле Общих часов за часть дисциплины 52 часа (так так как в 1 модуле рубежного контроля не было, то общие часы за часть дисциплины в 1 модуле суммируются к часам 2 модуля).
  5. Для 3 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • поля Форма контроля, Аудиторных часов за часть дисциплины и Общих часов за часть дисциплины необходимо оставить пустыми, так как рубежный контроль в данном периоде не предусмотрен и часы за данный период будут суммироваться в периоде, в котором встречается следующий рубежный контроль (в 4 модуле).
  6. Для 4 модуля указать:
    • в поле Аудиторных часов в периоде 16 часов;
    • в поле Форма контроля установить форму контроля "Экзамен";
    • в поле Аудиторных часов за часть дисциплины 36 часа (так как в 3 модуле рубежного контроля не было, то аудиторные часы за часть дисциплины в 3 модуле суммируются к часам 4 модуля).
    • в поле Общих часов за часть дисциплины 56 часа (так так как в 3 модуле рубежного контроля не было, то общие часы за часть дисциплины в 3 модуле суммируются к часам 4 модуля).

2.3.4. Установка ограничений на использование дисциплины

Пользователям кафедры предоставлена возможность устанавливать ограничения на использование дисциплины в тех или иных учебных планах, часть ограничений следуют из характеристик плана-предложения кафедры, в который включена дисциплина: Год начала реализации, Уровень образования, Реализуется по периодам.

При необходимости для каждой отдельной дисциплины (семинара) можно дополнительно ограничить возможность выбора дисциплины:

  • по направлению (специальности) образовательной программы;
  • по филиалу образовательной программы;
  • по факультету образовательной программы;
  • по конкретной образовательной программе (или конкретному набору программ).

Для добавления ограничения необходимо:

  1. Открыть раздел "Предложения кафедры в учебные планы".
  2. В подчиненной таблице данных Предлагаемые дисциплины и НИС выбрать дисциплину (семинар), на которую необходимо установить ограничения.
  3. В подчиненной вкладке Ограничения на выбор дисциплины с помощью контекстного меню вызвать действие Добавить ограничение.
    Установка ограничения на выбор дисциплины
  4. В форме параметров:
    Форма добавления ограничений
    • Если существует потребность одновременно с добавлением новых ограничений удалить старые, то необходимо для признака Удалять существующие ограничения установить значение "Да".
    • Можно установить ограничения по виду плана, для этого необходимо в поле Вид учебного плана установить вид плана, которому должна быть доступна данная дисциплина. Для объединенного плана общевузовских дисциплин дополнительно можно указать ограничение по типу общевузовского плана (поле Тип общевузовского плана), а для объединенного майнора по виду майнора (поле Вид майнора).
    • Можно установить ограничения по уровню образованич, для этого необходимо установить значение "Да" для тех уровней образования, которым должна быть доступна дисциплина.
    • В поле Направления / специальности можно выбрать направления / специальности для установки ограничений, для этого нужно нажать кнопку Справочник и с помощью чек-бокса Чек-бокс выбрать одно и более записей, после чего нажать кнопку ОК. Все выбранные записи отобразятся в поле Направления / специальности.
      Поле Направления / специальности будет доступно для установки ограничений, только если в поле Вид учебного плана установлено пустое значение или "Объединенный учебный план".
    • Аналогично направлениям / специальностям можно установить одно и более ограничений по Филиалу, Факультету, Образовательной программе и Курсу студентов.

      Для вида учебного плана "Объединенный план общевузовских дисциплин" поля для установки ограничений Филиал, Факультет, Образовательная программа и Курс студентов будут недоступны.

      Для вида учебного плана "Объединенный майнор" поля для установки ограничений Факультет, Образовательная программа и Курс студентов будут недоступны.

      Для вида учебного плана "Объединенный план факультетских дисциплин" поля для установки ограничений Образовательная программа и Курс студентов будут недоступны.

  5. После нажатия кнопки ОК будут созданы все возможные варианты ограничений с учетом установленных значений в форме параметров.
Если нужно задать ограничение таким образом, чтобы оно действовало не по одному, а по нескольким (но не всем) значениям, нужно добавить несколько подобных ограничений (например, добавить несколько ограничений, указав отдельные образовательные программы; в этом случае дисциплину можно будет использовать только в учебных планах этих конкретных образовательных программ).

2.3.5. Статусы дисциплин плана-предложения

Каждая дисциплина (НИС) в плане-предложении может находиться в одном из статусов:

  • проект;
  • заявка на дисциплину;
  • принята кафедрой;
  • отклонена;
  • утверждена.

Для изменения статуса пользователю кафедры необходимо открыть раздел Предложения кафедры в учебные планы и в таблице данных Предлагаемые дисциплины и НИС выбрать дисциплину, в контекстном меню системы найти группу действий Изменить статус и вызвать одно из действий: Принять к реализации, Вернуть в статус "проект", Утвердить реализацию, Отклонить реализацию.

При добавлении в план-предложение дисциплина получает статус "проект". После добавления пользователь кафедры должен максимально полно занести данные о нагрузке по дисциплине, ее распределении по видам работ и по периодам обучения, задать формы текущего и рубежного контроля. Эта информация будет необходима пользователям-разработчикам учебных планов для принятия решения о включении или невключении дисциплины в свои планы. Также, пока дисциплина находится в статусе "проект", пользователь кафедры должен занести ограничения на использование дисциплины. Из статуса "проект" пользователь кафедры может перевести дисциплину в статус "принята кафедрой" при помощи действия Принять к реализации. Дисциплины в статусе "принята кафедрой" становятся доступными для выбора пользователями - разработчиками учебных планов.

Для дисциплины в статусе "принята кафедрой" возможно выполнение действия Вернуть в статус "проект", однако выполнить это действие будет возможно только в случае, если дисциплина еще не включена ни в один из учебных планов.

Дисциплина может оказаться включенной в план-предложение кафедры разработчиком одного из учебных планов. В этом случае дисциплина появится в плане-предложении кафедры без непосредственного участия пользователя кафедры. Такие дисциплины будут появляться в статусе "заявка на дисциплину". Над дисциплиной в статусе "заявка на дисциплину" пользователь кафедры может выполнять следующие операции:

  • вносить изменения в данные о нагрузке по дисциплине;
  • выполнить для этой дисциплины действие Принять к реализации, в этом случае дисциплина перейдет в статус "принята кафедрой" ;
  • выполнить для этой дисциплины действие Отклонить реализацию ;
  • "объединить" дисциплину с какой-то другой из дисциплин своей кафедры; эта операция предусмотрена для случаев, когда пользователь кафедры считает, что разработчик учебного плана излишне создал дисциплину, и в учебном плане можно использовать другую схожую дисциплину со схожими параметрами нагрузки.

Пользователь кафедры может вносить изменения в данные о дисциплинах своей кафедры на разных этапах работы с учебными планам. Все изменения, сделанные пользователем кафедры, будут сразу же применяться ко всем учебным планам образовательных программ, в которых они задействованы. Однако перед "утверждением" учебных планов внесение изменений в данные о дисциплинах должно быть прекращено. Для фиксации такого состояния предназначен статус дисциплины "утверждена". Этот статус означает, что изменения в данные о дисциплине больше не вносятся. Перевести дисциплину в статус "утверждена" можно при помощи действия Утвердить реализацию.

2.3.6. Печать плана-предложения кафедры

Для выгрузки плана-предложения кафедры для печати необходимо в форме Предложения кафедры в учебные планы (таблица данных Планы-предложения кафедры) из контекстного меню вызвать действие Выгрузить для печати.
Вызов процедуры Выгрузить для печати план-предложение кафедры

В результате сформируется и откроется Excel-файл, содержащий всю информацию о плане-предложении.

2.3.7. Изменение периода реализации дисциплины или НИС

Для изменения периода реализации дисциплины или НИС, необходимо:

  1. В представлении Планы-предложения кафедры (форма Предложения кафедры в учебные планы) выбрать учебный план, в который входит дисциплина или НИС.
  2. В представлении Предлагаемые дисциплины и НИС выбрать дисциплину или НИС, для которой необходимо установить период реализации.
  3. Из контекстного меню вызвать действие Изменить период реализации.
  4. В форме параметров указать Год начала реализации и Год окончания реализации.
  5. Нажать кнопку ОК.

2.4. Планирование реализации дисциплин

Для планирования реализации дисциплин и НИС, преподаваемых кафедрой, необходимо выполнить формирование предметных единиц (предметных потоков, предметных групп, предметных подгрупп) для всех дисциплин и НИС, которые будут преподаваться кафедрой в очередном учебном году. Данные предметные единицы будут использованы при планировании нагрузки, для составления расписания занятий, для оценки фактически выполненной кафедрой учебной нагрузки.

В форме Планирование реализации дисциплин на вкладке Студенты, изучающие дисциплину, можно увидеть список студентов, которым дисциплина уже назначена. На основе этой информации можно оценить необходимое количество предметных потоков, групп, подгрупп. По мере включения академических групп в предметные единицы и распределения студентов по предметным единицам эта информация будет отображаться на подчиненных вкладках Связанные академические группы и на вкладке Студенты, изучающие дисциплину в колонках Предметный поток, Предметная группа, Предметная подгруппа, отдельно по каждому студенту.

Пользователи кафедр формируют предметные единицы, устанавливают максимальное количество студентов, которое может быть в них включено, и накладывают ограничения на использование предметных единиц. Включение студентов в предметные единицы будут выполнять Менеджеры образовательных программ, ответственные за организацию обучения студентов. Менеджерам образовательных программ будут доступны предметные единицы с учетом наложенных ограничений и они не смогут включить в предметную единицу больше студентов, чем установлено пользователем кафедры. Для случаев, когда кафедра не считает нужным ограничивать количество студентов, которые могут быть включены в предметную единицу, атрибут Максимальное количество студентов можно оставить пустым.

Формирование предметных единиц обязательное действие в следующих случаях:

  1. Создание предметных потоков для дисциплин обязательно, если есть лекции, проведение экзаменов в письменной форме.
  2. Создание предметных потоков для НИС обязательно во всех случаях.
  3. Создание предметных групп для дисциплин обязательно, если есть семинары, тренинги; при обучении по семестрам (для учета консультаций перед экзаменом).
  4. Создание предметных групп для НИС обязательно во всех случаях
  5. Создание предметных подгрупп для дисциплин обязательно, если есть практические, лабораторные работы, мастер-классы.
  6. Создание предметных подгрупп для НИС необязательно.

Для формирования предметных единиц необходимо выполнить ряд действий:

2.4.1. Формирование предметных потоков

Представление (таблица данных) Предметные потоки содержит перечень предметных потоков для каждой дисциплины кафедры. Для добавления предметных потоков необходимо:

Создание предметных потоков обязательно:
  1. Для всех НИС.
  2. Для дисциплин, если есть лекции, проведение экзаменов в письменной форме.
  1. Открыть раздел Планирование реализации дисциплин и выбрать дисциплину или НИС, для которой будут формироваться предметные единицы.
  2. В подчиненном представлении (таблице данных) Предметные потоки из контекстного меню вызвать действие Добавить предметный поток.
    Вызвов действия добавить предметный поток
  3. В форме параметров ввести Краткое наименование, при необходимости можно ограничить число студентов в потоке, указав Максимальное количество студентов на потоке.
  4. Нажать кнопку ОК.

Для редактирования существующих записей предметных единиц, необходимо дважды щелкнуть левой клавишей мыши по ячейке с параметром, который нужно изменить, ввести новое значение и нажать кнопку Enter.

После того как предметная единица была создана необходимо установить ограничения на ее использование см. Установка ограничений на использование предметных единиц.

2.4.2. Формирование предметных групп

Представление (таблица данных) Предметные группы содержит перечень предметных групп для каждой дисциплины кафедры. Предметные группы можно связывать с предметными потоками (в случаях, когда предметный поток формируется из определенных предметных групп), а можно создавать без связи с предметными потоками. Для добавления предметных групп необходимо:

Создание предметных групп обязательно:
  1. Для всех НИС.
  2. Для дисциплин, если есть семинары, тренинги; при обучении по семестрам (для учета консультаций перед экзаменом).
  1. Открыть раздел Планирование реализации дисциплин и выбрать дисциплину или НИС, для которой будут формироваться предметные единицы.
  2. В подчиненном представлении (таблице данных) Предметные группы из контекстного меню вызвать действие Добавить предметную группу.
    Вызов действия добавить предметную группу
  3. В форме параметров ввести Краткое наименование, при необходимости можно ограничить число студентов в группе, указав Максимальное количество студентов в группе. Также можно установить связь группы с потоком, выбрав в поле Входит в предметный поток соответствующий поток из справочника Предметные потоки (кнопка Справочник).
  4. Нажать кнопку ОК.

Для редактирования существующих записей предметных единиц, необходимо дважды щелкнуть левой клавишей мыши по ячейке с параметром, который нужно изменить, ввести новое значение и нажать кнопку Enter.

После того как предметная единица была создана необходимо установить ограничения на ее использование см.Установка ограничений на использование предметных единиц.

2.4.3. Формирование предметных подгрупп

Представление (таблица данных) Предметные подгруппы содержит перечень предметных подгрупп для каждой дисциплины кафедры. Предметные подгруппы можно связывать с предметными группами, а можно создавать независимо от предметных групп. Для добавления предметных подгрупп необходимо:

  1. Открыть раздел Планирование реализации дисциплин и выбрать дисциплину или НИС, для которой будут формироваться предметные единицы.
  2. В подчиненном представлении (таблице данных) Предметные подгруппы из контекстного меню вызвать действие Добавить предметную подгруппу.
    Вызов действия добавить предметную подгруппу
  3. В форме параметров ввести Краткое наименование, при необходимости можно ограничить число студентов в подгруппе, указав Максимальное количество студентов в подгруппе. Также можно установить связь подгруппы с группой, выбрав в поле Входит в предметную группу соответствующую группу из справочника Предметные группы (кнопка Справочник).
  4. Нажать кнопку ОК.

Для редактирования существующих записей предметных единиц, необходимо дважды щелкнуть левой клавишей мыши по ячейке со значением атрибута, который нужно изменить, ввести новое значение и нажать кнопку Enter.

Создание предметных подгрупп обязательно только для дисциплин, если есть практические, лабораторные работы, мастер-классы. Формирование предметных подгрупп для НИС необязательно.

После того как предметная единица была создана необходимо установить ограничения на ее использование см.Установка ограничений на использование предметных единиц

2.4.4. Установка ограничений на использование предметных единиц

После того как предметные единицы были созданы (см. Формирование предметных потоков, Формирование предметных групп и Формирование предметных подгрупп) необходимо установить ограничения на их использование, для этого необходимо:
Если предметная единица должна быть доступна Менеджерам образовательных программ всех Филиалов, Факультетов и Образовательных программ, то устанавливать ограничения нет необходимости.

  1. Открыть представление (таблицу данных) Предметные потоки, Предметные группы или Предметные подгруппы и выбрать предметную единицу.
  2. В подчиненном представлении (таблице данных) Ограничения использования потока, Ограничения использования группы или Ограничения использования подгруппы из контекстного меню вызвать действие Добавить ограничение.
    Вызов действия Добавить ограничение
  3. В форме установить Филиал, Факультет (при необходимости) и Образовательную программу (при необходимости).
  4. Нажать кнопку ОК. После чего предметная единица будет доступна только Менеджерам образовательных программ добавленного в ограничения Филиала, Факультета и Образовательной программы.

3. Проверки и расчеты (руководство администратора)
Проверки и расчеты учебных планов хранятся в базе данных в виде объектов классов "Контрольное соотношение учебного плана" и "Действие соотношения учебного плана". На каждое контрольное соотношение может быть создано любое количество действий. Проверки и расчеты

3.1. Проверки
При создании проверки необходимо указать
  • Имя и наименование проверки. Имя проверки должно быть уникальным. Наименование проверки будет по умолчанию показано пользователю при невыполнении условий проверки.
  • Очередность применения проверки. Проверки применяются в порядке, определяемом этим свойством. В случае наличия проверок с одинаковой очередностью, порядок их применения может быть любым, и вам не следует делать предположений об этом порядке.
  • Область применимости проверки. Проверки могут применяться к базовым учебным планам, к рабочим учебным планам или к обоим типам. Проверки могут применяться либо к показателям, распределяемым по периодам обучения, либо нет. Также можно указать конкретный показатель плана, к которому будет применяться проверка.

3.2. Объекты, доступные в теле скриптов проверок и расчетов
  • ContextObject: IContext Контекстный объект, реализующий .
  • Period: Integer Для проверок, работающих по учебным периодам - номер проверяемого периода. Нумерация периодов начинается с нуля.
  • CurrentYear: Integer Для проверок, работающих по учебным периодам - номер проверяемого периода. Для учебных планов лицея, объединенных учебных планов и планов предложения кафедры - номер проверямого года для проверок, работающих по учебным годам. Нумерация периодов начинается с нуля.
  • CurrentControlType: WideString Для проверок, работающих по формам текущего контроля - идентификатор формы текущего контроля.
  • MasterPlan: WideString Идентификатор учебного плана.
  • ItemCount[SubjectClass: WideString]: Integer Количество записей плана с типом SubjectClass.
  • Course: WideString Идентификатор курса.
  • CourseNumber: Integer Номер курса.
  • RootItem: PlanItem Объект, обеспечивающий доступ к сумме корневых строк плана. Объект реализует описанный ниже интерфейс IPlanItem.
  • WeekCount[Period: Integer]: Integer Количество недель в соответствующем периоде.
  • WeeksByYearByPeriod[Year: Integer; Period: Integer]: Integer Количество недель в соответствующем периоде года (для объединенного рабочего плана).
  • AudHoursInWeekCountByYearByPeriod[Year: Integer; Period: Integer]: Double Количество аудиторных часов всех дисиплин, входящих в недельную нагрузку в соответствующем периоде года (для объединенного рабочего плана).
  • Result: OleVariant Через эту переменную передается результат расчета расчетного показателя.
  • ControlTypeCount[const ControlType: WideString; Period: Integer]: Integer Количество (по плану в целом) видов рубежного испытания ControlType за период Period
  • Message(Optional MessageText: WideString, Optional Color: WideString) Процедура генерирует сообщение проверки для пользователя. Текст сообщения и "цвет" по умолчанию берутся из свойств самой проверки.
  • Item: IPlanItem Объект, обеспечивающий доступ к свойствам проверяемой строки плана. Объект реализует описанный ниже интерфейс IPlanItem :
      IPlanItem = interface
    property ID: WideString readonly;

    property Parent: IPlanItem readonly;
    property ChildCount: Integer readonly;
    property Child[Index: Integer]: IPlanItem readonly;

    property PeriodCount: Integer readonly;

    property SubjectClass: WideString readonly;
    property IsCalculated: WordBool readonly;
    property CumulOnly: WordBool readonly;
    property SubjectType: WideString readonly;
    property PracticeType: WideString readonly;

    property BlockCode: WideString readonly;
    property Description: WideString readonly;
    property UnivSubject: WideString;
    property FacDepartment: WideString;

    property StandHours: Double readonly;
    property EntireHours: Double;
    property WeekCount: Double;
    property Credits: Double;
    property AudHours: Double;
    property LectionHours: Double;
    property SeminarHours: Double;
    property PracticeHours: Double;
    property SelfHours: Double;
    property FinalControl: WideString;
    property HoursByPeriod[Period: Integer]: Double;
    property CreditsByPeriod[Period: Integer]: Double;
    property AudHoursByPeriod[Period: Integer]: Double;
    property ControlsByPeriod[Period: Integer]: WideString;
    property CurrentControls[const CurrentControlType: WideString]: Integer;
    property ExamCountByPeriod[Period: Integer]: Integer;
    property TestCountByPeriod[Period: Integer]: Integer;

    function ChildrenAudHours: Double;
    function ChildrenLectionHours: Double;
    function ChildrenSeminarHours: Double;
    function ChildrenPracticeHours: Double;
    function ChildrenSelfHours: Double;
    function ChildrenStandHours: Double;
    function ChildrenEntireHours: Double;
    function ChildrenWeekCount: Double;
    function ChildrenCredits: Double;
    function ChildrenHoursByPeriod(Period: Integer): Double;
    function ChildrenCreditsByPeriod(Period: Integer): Double;
    function ChildrenCurrentControls(const CurrentControlType: WideString): Integer;
    function ChildrenAudHoursByPeriod(Period: Integer): Double;
    function ChildrenExamCountByPeriod(Period: Integer): Integer;
    function ChildrenTestCountByPeriod(Period: Integer): Integer;

    property YearsCount: Integer readonly;
    property AudHoursByYear[Year: Integer]: Double;
    property WeeksByYear[Year: Integer]: Double;
    property AudHoursByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property WeeksByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property ControlTypeByYearByPeriod[Year: Integer; Period: Integer]: WideString;

    function ChildrenAudHourByYear(Year: Integer): Double;
    function ChildrenWeeksByYear(Year: Integer): Double;
    function ChildrenAudHoursByYearByPeriod(Year: Integer; Period: Integer): Double;
    function ChildrenWeeksByYearByPeriod(Year: Integer; Period: Integer): Double;

    property StandCredits: Double readonly;
    property StandMinCredits: Double readonly;
    property StandMaxCredits: Double readonly;

    property CreditsByYear[Year: Integer]: Double;
    property EntireHoursByYear[Year: Integer]: Double;
    property LectionHoursByYear[Year: Integer]: Double;
    property SeminarHoursByYear[Year: Integer]: Double;
    property PracticeHoursByYear[Year: Integer]: Double;
    property SelfHoursByYear[Year: Integer]: Double;
    property CreditsByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property ExamAudHoursByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property ExamEntireHoursByYearByPeriod[Year: Integer; Period: Integer]: Double;
    property CurrentControlsByYear[Year: Integer; const CurrentControlType: WideString]: Integer;

    property ItemStatus: WideString readonly;
    property ProposalStatus: WideString readonly;

    function ChildrenStandCredits: Double;
    function ChildrenCreditsByYear(Year: Integer): Double;
    function ChildrenEntireHoursByYear(Year: Integer): Double;
    function ChildrenLectionHoursByYear(Year: Integer): Double;
    function ChildrenSeminarHoursByYear(Year: Integer): Double;
    function ChildrenPracticeHoursByYear(Year: Integer): Double;
    function ChildrenSelfHoursByYear(Year: Integer): Double;
    function ChildrenCreditsByYearByPeriod(Year: Integer; Period: Integer): Double;
    function ChildrenExamAudHoursByYearByPeriod(Year: Integer; Period: Integer): Double;
    function ChildrenExamEntireHoursByYearByPeriod(Year: Integer; Period: Integer): Double;
    function ChildrenCurrentControlsByYear(Year: Integer; const CurrentControlType: WideString): Integer;

    property ExamCountByYearByPeriod[Year: Integer; Period: Integer]: Integer;
    property TestCountByYearByPeriod[Year: Integer; Period: Integer]: Integer;

    function ChildrenExamCountByYearByPeriod(Year: Integer; Period: Integer): Integer;
    function ChildrenTestCountByYearByPeriod(Year: Integer; Period: Integer): Integer;

    property MinCurrentCoefByYear(Year: Integer): Double readonly;
    property MinCurrentHoursByYear(Year: Integer): Double readonly;
    property PlanCurrentCoefByYear(Year: Integer): Double;
    property PlanCurrentHoursByYear(Year: Integer): Double;

    function ChildrenMinCurrentHoursByYear(Year: Integer): Double; safecall;
    function ChildrenPlanCurrentHoursByYear(Year: Integer): Double; safecall;

    property StudyFormat: WideString; safecall;
  end;
    • Свойство ID содержит идентифкатор строки учебного плана.
    • Свойство Parent содержит ссылку на объект, описыващий родительскую запись плана (если она есть). Объект реализует тот же интерфейс IPlanItem
    • Свойства ChildCount и Child возвращают, соответственно, количество дочерних записей плана и ссылки на объекты, описывающие дочерние записи (реализуют тот же интерфейс IPlanItem).
    • Свойство PeriodCount определяет количество учебных периодов, содержащихся в учебном плане. Для плана лицея - количество учебных периодов в году.
    • Свойство SubjectClass возвращает идентификатор класса строки учебного плана.
    • Свойство IsCalculated равно True, если строка является суммой своих дочерних строк.
    • Свойство CumulOnly равно True, если строка включается только в кумулятивный рейтинг.
    • Свойство SubjectType возвращает идентификатор вида дисциплины строки учебного плана.
    • Свойство PracticeType возвращает идентификатор вида практики строки учебного плана.
    • Свойство BlockCode возвращает код раздела учебного плана.
    • Свойство Description возвращает наименование строки учебного плана.
    • Свойство UnivSubject возвращает и устанавливает идентификатор дисциплины, которая описывается строкой учебного плана.
    • Свойство FacDepartment возвращает и устанавливает идентификатор кафедры строки учебного плана.
    • Свойство StandHours возвращает количество часов по стандарту.
    • Свойство EntireHours возвращает и устанавливает общее количество часов.
    • Свойство WeekCount возвращает и устанавливает общее количество недель.
    • Свойство Credits возвращает и устанавливает общее количество зачетных единиц.
    • Свойство AudHours возвращает и устанавливает количество аудиторных часов.
    • Свойство LectionHours возвращает и устанавливает количество часов лекций.
    • Свойство SeminarHours возвращает и устанавливает количество часов семинаров.
    • Свойство PracticeHours возвращает и устанавливает количество часов практических занятий.
    • Свойство SelfHours возвращает и устанавливает количество часов самостоятельной работы.
    • Свойство FinalControl возвращает и устанавливает идентификатор типа итогового контроля.
    • Свойство HoursByPeriod[Period] возвращает и устанавливает общее количество часов в учебном периоде с номером Period.
    • Свойство CreditsByPeriod[Period] возвращает и устанавливает количество зачетных единиц в учебном периоде с номером Period.
    • Свойство AudHoursByPeriod[Period] возвращает и устанавливает количество аудиторных часов в учебном периоде с номером Period.
    • Свойство ControlsByPeriod[Period] возвращает и устанавливает количество зачетных единиц в учебном периоде с номером Period.
    • Свойство ExamCountByPeriod[Period] возвращает и устанавливает количество экзаменов в учебном периоде с номером Period.
    • Свойство TestCountByPeriod[Period] возвращает и устанавливает количество зачетов в учебном периоде с номером Period.
    • Свойство CurrentControls[CurrentControlType] возвращает и устанавливает количество формы текущего контроля с идентификатором CurrentControlType.
    • Функции ChildrenAudHours, ChildrenLectionHours, ChildrenSeminarHours, ChildrenPracticeHours, ChildrenSelfHours, ChildrenStandHours, ChildrenEntireHours, ChildrenWeekCount, ChildrenCredits, ChildrenHoursByPeriod, ChildrenCreditsByPeriod, ChildrenCurrentControls, ChildrenAudHoursByPeriod, ChildrenAudHoursByPeriod, ChildrenAudHoursByPeriod, ChildrenExamCountByPeriod, ChildrenTestCountByPeriod, ChildrenAudHourByYear (только для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры), ChildrenWeeksByYear (только для учебного плана лицея), ChildrenAudHoursByYearByPeriod (только для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры), ChildrenWeeksByYearByPeriod (только для учебного плана лицея), ChildrenStandCredits (только для объединенного учебного плана и плана-предложения кафедры), ChildrenCreditsByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenEntireHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenLectionHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenSeminarHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenPracticeHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenSelfHoursByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenCreditsByYearByPeriod (только для объединенного учебного плана и плана-предложения кафедры), ChildrenExamAudHoursByYearByPeriod (только для объединенного учебного плана и плана-предложения кафедры), ChildrenExamEntireHoursByYearByPeriod (только для объединенного учебного плана и плана-предложения кафедры), ChildrenCurrentControlsByYear (только для объединенного учебного плана и плана-предложения кафедры), ChildrenExamCountByYearByPeriod (только для объединенного учебного плана), ChildrenTestCountByYearByPeriod (только для объединенного учебного плана) агрегируют соответствующие показатели по дочерним записям учебного плана. Важно, что строки, которые включается только в кумулятивный рейтинг, не агрегируются функциями ChildrenCredits и ChildrenCreditsByPeriod.
    • Свойство YearsCount определяет количество лет обучения (для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры)
    • Свойство AudHoursByYear[Year: Integer] возвращает и устанавливает количество аудиторных часов в учебном году с номером Year (нумеруются с нуля) (для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры).
    • Свойство WeeksByYear[Year: Integer] возвращает и устанавливает количество недель в учебном году с номером Year (нумеруются с нуля) (только для учебного плана лицея).
    • Свойство AudHoursByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает количество аудиторных часов в учебном периоде с номером Period (нумеруются с нуля) учебного года номером Year (нумеруются с нуля) (для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры).
    • Свойство WeeksByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает количество недель в учебном периоде с номером Period (нумеруются с нуля) учебного года номером Year (нумеруются с нуля) (только для учебного плана лицея).
    • Свойство ControlTypeByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает тип контоля в учебном периоде с номером Period (нумеруются с нуля) учебного года номером Year (нумеруются с нуля) (для учебного плана лицея, объединенного учебного плана и плана-предложения кафедры).
    • Свойство StandCredits возвращает количество зачетных единиц по стандарту
    • Свойство StandMinCredits возвращает минимальное количество зачетных единиц по стандарту
    • Свойство StandMaxCredits возвращает максимальное количество зачетных единиц по стандарту
    • Свойство CreditsByYear[Year: Integer] возвращает и устанавливает количество зачетных единиц в учебном году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство EntireHoursByYear[Year: Integer] возвращает и устанавливает общее количество учебных часов в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство LectionHoursByYear[Year: Integer] возвращает и устанавливает количество учебных часов лекций в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство SeminarHoursByYear[Year: Integer] возвращает и устанавливает количество учебных часов семинаров в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство PracticeHoursByYear[Year: Integer] возвращает и устанавливает количество учебных часов практических занятий в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство SelfHoursByYear[Year: Integer] возвращает и устанавливает количество учебных часов самостоятельной работы в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство CreditsByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает количество зачетных единиц за период в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство ExamAudHoursByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает количество аудиторных часов на испытание за период в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство ExamEntireHoursByYearByPeriod[Year: Integer; Period: Integer] возвращает и устанавливает общее количество часов на испытание за период в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство CurrentControlsByYear[Year: Integer; const CurrentControlType: WideString] возвращает и устанавливает количество формы текущего контроля с идентификатором CurrentControlType за период в году (для объединенного учебного плана и плана-предложения кафедры)
    • Свойство ItemStatus возвращает статус записи плана (для плана-предложения кафедры)
    • Свойство ProposalStatus возвращает статус предложения записи (для объединенного учебного плана)
    • Свойство ExamCountByYearByPeriod возвращает и устанавливает количество экзаменов в году с номером Year в учебном периоде с номером Period (для объединенного учебного плана).
    • Свойство TestCountByYearByPeriod возвращает и устанавливает количество зачетов в году с номером Year в учебном периоде с номером Period (для объединенного учебного плана).
    Соответствие между показателями учебного плана и элементами интерфейса IPlanItem представлено на рисунке:
    Показатели плана как члены интерфейса IPlanItem
    Показатели объединенного учебного плана
    Показатели плана-предложения кафедры

4. Расширение возможностей документирования пользовательских инструкций

Помимо встроенных возможностей документирования, в Системе предусмотрена возможность интегрирования внешних систем создания файлов документации.

Возможности подобного интегрирования будут рассмотрены далее на примере программного обеспечения HELP&MANUAL версии 5.6.0 (страница для скачивания здесь ). HELP&MANUAL является инструментом для создания документации, а также системой управления контентом. Данный продукт является коммерческим.

4.1. Установка ПО

- Скачать дистрибутив программы с сайта разработчика ( http://www.helpandmanual.com/downloads.html )

- Запустить исполняемый файл установщика hmsetup.exe. Начнется процесс установки.

Первый экран установки программы - приветствие: Установка HM 1

Нажать "Next".

Экран лицензионного соглашения:

Установка HM 2

Выбрать пункт "I accept the agreement", нажать "Next".

Экран выбора директории установки:

Установка HM 3

Здесь необходимо выбрать папку на жестком диске компьютера для установки Help&Manual, нажать "Next".

Экран выбора компонентов программы для установки:

Установка HM 4

Можно оставить без изменений, нажать "Next".

Экран выбора наименования группы программ в меню "Start" ("Пуск"):

Установка HM 5

Нажать "Next".

Экран дополнительных установок:

Установка HM 6

Здесь можно указать, должен ли установщик разместить значок Help&Manual для запуска программы на рабочем столе компьютера. Сделать выбор, нажать "Next".

Сводный экран установки программы:

Установка HM 7

Здесь указаны все параметры установки программы, выбранные на предыдущих шагах. Если необходимо внести изменения в параметры, можно воспользоваться кнопкой "Back". Если все параметры верны, нажать кнопку "Install".

Начнется процесс установки программного обеспечения:

Установка HM 8

После установки будет выведен полседний экран:

Установка HM Finish

Чекбокс "Launch Help&Manual" позволяет запустить программное обеспечение сразу после нажатия на кнопку "Finish".

При первом запуске программы будет выведен запрос на ввод код активации полного функционала программы:

Здесь необходимо указать серийный номер (Serial Number) и код активации (Activation Code). Данная информация доступна после приобретения программы. После ввода нажать кнопку "ОК". Программа готова для работы.

4.2. Создание проекта документации

После запуска программы будет выведено окно приветствия:

HM окно приветствия

Для создания нового проекта документации необходимо воспользоваться кнопкой или комбинацией клавиш "Alt+1".

HM new project

Откроется окно выбора параметров нового проекта:

HM параметры нового проекта 1

Оставляем параметры без изменений и нажимаем кнопку "Next".

Следующее окно параметров:

HM Окно выбора параметров нового проекта 2

В поле "Output File" необходимо указать название и место расположения на жестком диске файла проекта. Расширение файла оставляем без изменения. В поле "Project Title" можно ввести наименование проекта документации. В поле "Project Language" указывается язык проекта.

В поле "Character Set" должно быть установлено значение "RUSSIAN_CHARSET".

Нажать кнопку "Next".

Окно создания структуры проекта документации:

HM создание структуры документа

В этом окне можно задать предварительную структуру будущего документа. Пункты оглавления можно создавать, удалять, перемещать по списку. Структуру проекта можно будет изменять в дальнейшем в процессе работы. После нажатия кнопки "ОК" структура документа, описанная здесь, будет создана автоматически.

Главное окно программы:

HM главное окно

В левой части расположено навигационное дерево статей проекта документации, в правой отображается содержимое статей.

После того, как статьи созданы, необходимо добавить ключевые слова и фразы, для этого необходимо перейти на вкладку "Topic Options":

HM Topic Options Tab

Откроется окно установки свойств статьи:

HM Topic Options

Здесь в поле "Keywords" необходимо указать ключевые слова и фразы, по которым будет осуществляться переход из системы в соответствующую статью.

После того как все необходимые статьи созданы, ключевые фразы добавлены, файл документации нужно сохранить в формате chm. Для этого используется кнопка "Publish".

После ее нажатия будет выведено окно выбора формата конечного файла:

HM Выбор формата файла

Здесь выбирается вкладка "HTML Help (.chm)", указывается путь на жестком диске для сохранения.

После нажатия кнопки "ОК" файл будет сохранен в нужном формате.

4.3. Интеграция программы документирования с учетной системой

Связь Системы и программы создания документации осуществляется при помощи ключевых слов и фраз. После того как статья документации получила ключевые слова или фразы, необходимо указать их в Системе.

Для примера разберем связывание соответствующей статьи файла документации и формы Зарегистрировать, вызываемой с помощью пункта контекстного меню "Зарегистрировать" из таблицы Абитуриенты бакалавриата раздела Абитуриенты бакалавриата текущего набора участка Абитуриент.

Форма Зарегистрировать абитуриента бакалавриата

Нам необходимо добиться, чтобы при нажатии на выделенную красным кнопку на этой форме был вызван документ chm, содержащий инструкции для пользователей. При этом должна открыться статья, содержащая сведения именно о процессе заполнения формы Зарегистрировать.

Созданный в программе Help&Manual файл документации, должен находится в одной папке с запускаемым файлом DataBrowser.exe обозревателя DataMill.

Подпрограмма "Зарегистрировать" ("Register") является дочерней по отношению к классу "Абитуриент бакалавриата" ("TBachAbiturSt").

В Системе нужно открыть раздел Системная форма участка Администратору. На вкладке Классы при помощи фильтра по имени или наименованию найти класс "Абитуриент бакалавриата" ("TBachAbiturSt"). В подчиненном представлении перейти на вкладку Подпрограммы и найти подпрограмму "Зарегистрировать" ("Register"). В подчиненном представлении перейти на вкладку Ключи контекстной помощи, вызвать контекстное меню и воспользоваться пунктом "Создать".

Откроется окно ввода параметров:

Создание ключа контекстной помощи

В поле "Ключевое словосочетание" указывается ключевое слово или фраза, в том виде как они прописаны в программе Help&Manual в свойствах соответствующей статьи.

В поле "Хранилище" указывается имя chm-файла документации без расширения, который содержит в себе данную статью.

После нажатия кнопки "Ок" ключ будет добавлен в таблицу.

Создание ключей контекстного поиска

Таким образом, после вызова справки из формы "Зарегистрировать" пользователь увидит соответствующую статью:

HM Вывод статьи

Если ключей несколько и они ссылаются на разные статьи или документы, то при нажатии в форме "Зарегистрировать" на кнопку вызова помощи, пользователю будет предложено на выбор несколько вариантов ссылок.